### Important User Information

Solid-state equipment has operational characteristics differing from those of electromechanical equipment. Safety Guidelines for the Application, Installation and Maintenance of Solid State Controls (publication SGI-1.1 available from your local Rockwell Automation® sales office or online at [http://www.rockwellautomation.com/literature/](http://www.rockwellautomation.com/literature/)) describes some important differences between solid-state equipment and hard-wired electromechanical devices. Because of this difference, and also because of the wide variety of uses for solid-state equipment, all persons responsible for applying this equipment must satisfy themselves that each intended application of this equipment is acceptable.

In no event will Rockwell Automation, Inc. be responsible or liable for indirect or consequential damages resulting from the use or application of this equipment.

The examples and diagrams in this manual are included solely for illustrative purposes. Because of the many variables and requirements associated with any particular installation, Rockwell Automation, Inc. cannot assume responsibility or liability for actual use based on the examples and diagrams.

No patent liability is assumed by Rockwell Automation, Inc. with respect to use of information, circuits, equipment, or software described in this manual.

Reproduction of the contents of this manual, in whole or in part, without written permission of Rockwell Automation, Inc., is prohibited.

Throughout this manual, when necessary, we use notes to make you aware of safety considerations.

<table>
<thead>
<tr>
<th>WARNING:</th>
<th>Identifies information about practices or circumstances that can cause an explosion in a hazardous environment, which may lead to personal injury or death, property damage, or economic loss.</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATTENTION:</td>
<td>Identifies information about practices or circumstances that can lead to personal injury or death, property damage, or economic loss. Attentions help you identify a hazard, avoid a hazard, and recognize the consequence.</td>
</tr>
<tr>
<td>SHOCK HAZARD:</td>
<td>Labels may be on or inside the equipment, for example, a drive or motor, to alert people that dangerous voltage may be present.</td>
</tr>
<tr>
<td>BURN HAZARD:</td>
<td>Labels may be on or inside the equipment, for example, a drive or motor, to alert people that surfaces may reach dangerous temperatures.</td>
</tr>
<tr>
<td>IMPORTANT</td>
<td>Identifies information that is critical for successful application and understanding of the product.</td>
</tr>
</tbody>
</table>

---

Allen-Bradley, Rockwell Software, Rockwell Automation, and TechConnect are trademarks of Rockwell Automation, Inc.

Bluetooth is a trademark of Bluetooth SIG.

Xenon is trademark of General Electric Company.

Intel and XScale are trademarks of Intel Corporation.

Microsoft, Windows, and ActiveSync are trademarks of Microsoft Corporation.

Trademarks not belonging to Rockwell Automation are property of their respective companies.
Environment and Enclosure

Follow these guidelines for environment and enclosure information for this equipment.

### ATTENTION:
This equipment is intended for use in overvoltage Category II applications (as defined in IEC 60664-1), at altitudes up to 2000 m (6562 ft) without derating.

This equipment is considered Group 1, Class A industrial equipment according to IEC/CISPR 11. Without appropriate precautions, there may be difficulties with electromagnetic compatibility in residential and other environments due to conducted and radiated disturbances.

This equipment is supplied as enclosed equipment. It should not require additional system enclosure when used in locations consistent with the enclosure type ratings stated in the Specifications section of this publication. Subsequent sections of this publication may contain additional information regarding specific enclosure type ratings, beyond what this product provides, that are required to comply with certain product safety certifications.

In addition to this publication, see:
- Industrial Automation Wiring and Grounding Guidelines, Rockwell Automation publication 1770-4.1, for additional installation requirements.
- NEMA Standards 250 and IEC 60529, as applicable, for explanations of the degrees of protection provided by different types of enclosure.

Prevent Electrostatic Discharge

Follow these guidelines when you handle this equipment.

This equipment is sensitive to electrostatic discharge that can cause internal damage and affect normal operation. Follow these guidelines when you handle this equipment.

- Touch a grounded object to discharge potential static.
- Wear an approved grounding wrist strap.
- Do not touch connectors or pins on component boards.
- Do not touch circuit components inside the equipment.
- Use a static-safe workstation if available.
- Store the equipment in appropriate static-safe packaging when not in use.

About this Manual

This manual describes the standard features and operation of the RFID ICODE handheld interface. Unless otherwise stated, the operational characteristics described herein correspond to factory default configurations and settings as shipped from Allen-Bradley. Wherever used herein, the terms “RFID ICODE handheld interface” or “handheld” applies to all models (except as noted).
About RFID

RFID (Radio Frequency IDentification) is a wireless communication technology that uses the RF portion of the electromagnetic spectrum to transmit and receive information from EPC (Electronic Product Code) tags. The tags can come in many shapes and sizes - such as disks, cards, or paper labels (smart labels) - and can store a simple identification number or a sophisticated database.

RFID technology is based on the simple idea that a reader can activate an electronic circuit inside a tag from a distance and exchange information. An integrated circuit inside the reader creates an alternating current. This current generates an alternating magnetic field through the reader’s antenna that serves as a power source for a RFID tag. This magnetic field interacts with the antenna in the tag which, in turn, activates the tag’s integrated circuit causing the tag to create a digital signal, which contains an encoded identifier number.

The tag then generates its own alternating magnetic field, which interacts with the reader’s alternating magnetic field. A device inside the RFID reader senses the variations and converts this pattern to the digital signal, which interprets the tag’s identifier code.

About the RFID ICODE Handheld Interface

Designed for one-handed operation, the RFID ICODE handheld interface features a powerful Windows® CE 5.0 operating system and an Intel® PXA270 XScale™ processor that operates up to 624 MHz. It comes standard with Bluetooth, Wi-Fi, and serial communication ports (USB and RS-232).

With its 13.56 MHz RFID integrated reader and flip-out antenna, the RFID ICODE handheld interface can read and write ICODE ISO 15693 industry standard RFID tags within a 3.5 in. (90 mm) range making it ideal for item tracking, data collection, and setup/maintenance of RFID systems.

Additional Resources

These documents contain additional information concerning related products from Rockwell Automation.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Industrial Automation Wiring and Grounding Guidelines, publication 1770-4.1</td>
<td>Provides general guidelines for installing a Rockwell Automation industrial system.</td>
</tr>
</tbody>
</table>

You can view or download publications at http://www.rockwellautomation.com/literature/. To order paper copies of technical documentation, contact your local Allen-Bradley distributor or Rockwell Automation sales office.
# Table of Contents

## Preface
- Important User Information ........................................... 2
- Environment and Enclosure ........................................... 3
- Prevent Electrostatic Discharge ....................................... 3
- About this Manual ..................................................... 3
- About RFID .............................................................. 4
- About the RFID ICODE Handheld Interface ......................... 4
- Additional Resources .................................................. 4

## RFID ICODE Handheld Interface
### Features
- Operating System ...................................................... 9
- Rechargeable Battery Pack ......................................... 9
- Processor .................................................................. 9
- Memory and Mass Storage ......................................... 9
- Displays .................................................................... 10
- Keypads ..................................................................... 10
- Indicators .................................................................. 10
- Interface Capabilities .............................................. 10
- Durability .................................................................. 10
- Ingress Protection ..................................................... 10

## Quick Start Guide
- Powering up the RFID ICODE Handheld Interface ............. 11
- Reading an RFID Tag .................................................. 13
- Writing to an RFID Tag .............................................. 14

## Getting Started
- Front Components and Indicators .................................. 17
- Rear Components ....................................................... 18
- Compact Flash Slot Cover ........................................... 18
- Interface Connections ................................................ 19
- Power Supplies, Cables, and Adapters ......................... 20

## Operation
- Power ......................................................................... 21
  - Charging the Unit .................................................... 21
  - Charge/Low Battery Indicator ................................... 23
  - Power/Suspend Switch ............................................. 23
  - Replacing Batteries/Battery Pack ......................... 24
  - Power Management ................................................ 25
- Using the RFID Module ............................................. 26
  - Using the Compact Flash Slot ............................... 27
- Data Entry ..................................................................... 28
  - Keypads ................................................................... 28
  - Key Repeat ............................................................ 30
# Table of Contents

- CE Keyboard .................................................. 30
- Transcriber .................................................. 31
- Windows CE 5.0 Desktop .................................. 32
  - Windows CE 5.0 Desktop Functions .................. 32
- Taskbar ...................................................... 33
- Start Menu .................................................. 34
- Miscellaneous Tools ....................................... 34

## Chapter 5

Configuration
- Control Panel ............................................... 39
- Changing System Settings ................................ 40
- Taskbar and Start Menu Settings ....................... 41

## Chapter 6

Connections
- ActiveSync® ................................................ 43
  - Initial Communication .................................. 43
  - Subsequent Communication ............................. 47
- Wireless Connections ..................................... 48
  - Overview ................................................ 48
  - Wi-Fi Companion ....................................... 49
- Wireless Zero Configuration ......................... 50
- Setting Up Identification for Remote Networks ..... 53
- Connecting to a Mail Server ............................ 53
- Bluetooth Connections ................................... 56
- Setup and Configuration ................................ 56
- Making an ActiveSync Connection ..................... 67

## Chapter 7

Software
- User Interface ............................................. 73
  - Screen Elements ....................................... 73
  - Navigation .............................................. 75
- Working with Tags ........................................ 75
  - Read/Write Times ..................................... 75
  - Reading Tags .......................................... 75
  - Writing Tags .......................................... 78
- Device Menu .............................................. 85
  - Settings ............................................... 85
  - Minimize .............................................. 85
  - Exit .................................................. 89
- Data Menu ................................................ 89
  - Erase .................................................. 89
  - Clear Tag History .................................... 90
  - ASCII Table .......................................... 90
  - Tag Properties ....................................... 90
# Table of Contents

## Troubleshooting
- Help Menu ................................................................. 91
- Microsoft® Excel: Importing/Exporting ........................... 92

## Chapter 8
- Frequently Asked Questions ........................................ 95
- Error Codes ................................................................. 96
  - Initialization ............................................................ 96
  - Parameters .............................................................. 97
  - Read/Write ............................................................... 97

## Appendix A
- Handheld Specifications .............................................. 99
  - Power ................................................................. 99
  - Display ............................................................... 99
  - CPU ................................................................. 99
  - Memory and Mass Storage ....................................... 99
  - User Input ........................................................... 99
  - Indicators ............................................................ 100
  - Connectivity ......................................................... 100
  - Environmental ...................................................... 100
  - Physical Dimensions ............................................. 100
- Socket Go Wi-Fi! P500 Wireless Card Specifications .......... 103
  - Physical Characteristics: ........................................ 103
  - Power Consumption (3.3 V Supply): ......................... 103
  - Transmit Power: .................................................... 103
  - Standards Conformance: ....................................... 103
  - 802.11g: .............................................................. 103
  - 802.11b: .............................................................. 103
  - Frequency Range: ................................................. 103
  - Indoor Range: ....................................................... 104
  - Access Protocol: ................................................... 104
  - Certification/Compliance: ....................................... 104

## Appendix B
- Serial Interface Cables ............................................... 107
RFID ICODE Handheld Interface Features

<table>
<thead>
<tr>
<th>Features</th>
<th>Operating System</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The RFID ICODE handheld interface uses Windows® CE 5.0 as its operating system.</td>
</tr>
</tbody>
</table>

Rechargeable Battery Pack

The RFID ICODE handheld interface comes with a rechargeable Nickel Metal Hydride (NiMH) battery pack that can provide up to six hours of operating time on a full charge (depending on power management and use). The NiMH technology used in the RFID ICODE handheld interface has exceptional charge life without the “charge memory” characteristic of conventional nickel cadmium batteries. Partially discharged batteries or extended periods with the charger left connected will not adversely affect battery life or performance. The RFID ICODE handheld interface can also run on six AA alkaline batteries.

Processor

The RFID ICODE handheld interface utilizes an Intel® PXA270 processor designed specifically for high-performance, low power, portable, handheld devices. It incorporates Intel XScale technology with on-the-fly voltage, frequency scaling and sophisticated power management. It also complies with the ARM Architecture V5TE instruction set.

Memory and Mass Storage

The RFID ICODE handheld interface comes standard with 128 MB of SDRAM (approximately 30 MB used for the operating system) and 512 MB of internal compact flash memory. An additional 256 MB of SDRAM is optionally available. Internal compact flash memory is optionally expandable to 8+ GB. For removable data storage or I/O cards, the RFID ICODE handheld interface is equipped with a Compact Flash (CF) slot.
Displays

The RFID ICODE handheld interface features a supertwist nematic liquid crystal 320 x 240 QVGA-TFT color sunlight readable display with touch screen and LED backlight.

Keypads

Keypad configurations for the RFID ICODE handheld interface include the 45-key pad and 52-key with directional pad.

Indicators

The RFID ICODE handheld interface has five programmable LED indicators that can provide a number of useful functions including the state of keypad modifier keys. An additional LED indicates the current charge or low battery status.

Interface Capabilities

The RFID ICODE handheld interface comes standard with one USB port and one RS-232 serial port. The RFID ICODE handheld interface also includes Wi-Fi and Bluetooth®.

Durability

The case is made of General Electric Xenoy®, one of the most durable chemical resistant materials available today.

Ingress Protection

The RFID ICODE handheld interface is completely dust-tight and can withstand exposure to jets of water and has an IP (Ingress Protection) rating of 65 as defined by IEC standard 529.
Quick Start Guide

The Quick Start Guide will give basic instructions on how to use your new RFID ICODE handheld interface.

1. Charge the unit for a minimum of three hours prior to first use.
   a. If you are using the wall charger and serial cable (57RF-HH-56IN, 57RF-HH-56US2):
      i. Plug the power jack of the battery charger/power supply into the corresponding cable connector as shown below.

      **Figure 1 - Power Jack**

      ![Power Supply/Battery Charger](To Unit)

      ii. Remove the rubber cover from the RS-232 connector on the bottom of the RFID ICODE handheld interface. Plug the interface cable into the connector.

      iii. Plug the battery charger/power supply into a power outlet. The Charge LED should turn on, indicating that the batteries are charging.

      **Figure 2 - Power Outlet**

      ![Power Outlet](To Unit)

   b. If you are using the charging cradle (57RF-HH-56US1):
      i. Plug the two-pin connector of the power supply into the back of the charging cradle as shown below.

      **Figure 3 - Charging Cradle/Power Supply**

      ![Charging Cradle/Power Supply](To Unit)
ii. Plug one end of the detachable AC cord into the power supply and the other end into a power outlet as shown below.

**Figure 4 - Power Supply Cord**

iii. Remove the rubber cover from the RS-232 connector on the bottom of the RFID ICODE handheld interface.

iv. Place the RFID ICODE handheld interface in the charging cradle as shown below. The Charge LED should turn on, indicating that the batteries are charging.

**Figure 5 - Interface into Charging Cradle**

2. The Charge LED will blink green when the RFID ICODE handheld interface is fully charged. Unplug the unit or remove it from the charging cradle.

3. Press and hold the On/Off switch for one second. The unit should turn on and begin displaying the boot-up process. After approximately 15 seconds, the Windows CE 5.0 desktop should appear.

**Figure 6 - On/Off Switch**

4. Flip the RFID module 180° as shown below. This will provide optimal tag reading performance.

**Figure 7 - RFID Module**
Reading an RFID Tag

1. Using the stylus, double-tap the RFID ICODE icon on the desktop. The RFID application will open.

Figure 8 - RFID ICODE Application Icon

2. Double-tap in the Start field and type in 0 using the keypad. This sets the RFID application to start reading/writing tags at the first byte available for user data.

3. Double-tap in the Length field and type in 0 using the keypad. This sets the RFID application to read/write the entire tag.

4. Tap the arrow next to the drop-down menu labeled “Mode”. A list should open with these options: BIN, DEC, HEX, ASCII. Tap HEX to set the RFID application to read in hexadecimal mode.

5. If the checkbox labeled “Continuous” is unchecked, the RFID application is in Single Read/Write mode and will only read/write the first tag. If the checkbox is checked, tap the box with the stylus to clear it.

6. If the speaker symbol in the center of the bottom bar is blue, the sound is on. If it is grey, tap it with the stylus to turn the sound on.

Figure 9 - Application Screen Shot 1

7. Place an ICODE compatible tag in range of the RFID module (typically 0.25…3 in. (6.35…76.2 mm) away, depending on tag size).

8. Tap the Read button with the stylus.

9. The handheld will beep and the data grid will display the tag data.

10. The UID field will display the tag UID (Unique Identifier).

11. Use the scroll bar on the right side of the screen to scroll through and view the tag data.

Figure 10 - Application Screen Shot 2
Writing to an RFID Tag

1. If the Start field is not already 0, double-tap in the field and type in 0 using the keypad. This sets the RFID application to start reading/writing tags at the first byte available for user data.

2. Double-tap in the Length field and type in 8 using the keypad. This sets the RFID application to write a total of 8 bytes of data to the tag.

3. Tap the arrow next to the drop-down menu labeled “Mode” and select ASCII from the list.

4. Double-tap the UID field and type in 0 using the keypad. This allows the RFID application to write to any ICODE compatible tag. If there is a non-zero UID in the field, the application will only write to that specific tag.

5. If the checkbox labeled “Continuous” is unchecked, the RFID application is in Single Read/Write mode and will only read/write the first tag. If the checkbox is checked, tap the box with the stylus to clear it.

6. If the speaker symbol in the center of the bottom bar is blue, the sound is on. If it is grey, tap it with the stylus to turn the sound on.

7. Tap on cell 0 using the stylus. Use the keypad to enter Rockwell in cells 0…7.

8. Place an ICODE compatible tag in range of the RFID module (typically 0.25…3 in. (6.35…76.2 mm) away, depending on tag size).

9. Tap the Write button with the stylus. A pop-up window will appear, asking you to choose between Write from Screen and Write from File.

Figure 11 - Application Screen Shot 3

![Application Screen Shot 3](image)
10. Tap the radio button next to Screen.

Figure 12 - Application Screen Shot 4

11. Tap OK. The handheld will beep, and Rockwell will be written to the tag in cells 0...7.

12. To check that the write was successful, manually clear the screen by tapping in cells 0...7 and pressing Backspace on the keypad.

13. Perform a single read (See Reading an RFID Tag on page 13). The data grid will display Rockwell in cells 0...7.
Notes:
Getting Started

Front Components and Indicators

This section describes the components and indicators found on the front of the RFID ICODE handheld interface.

Figure 13 - Front Components and Indicators

Table 5 - Front Components and Indicators

<table>
<thead>
<tr>
<th>Item</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Display</td>
<td>Supertwist nematic liquid crystal display with touch screen</td>
</tr>
<tr>
<td>2</td>
<td>Battery Indicator</td>
<td>Indicates low battery (red) status and charging (green) status</td>
</tr>
<tr>
<td>3</td>
<td>LEDs</td>
<td>Indicates use of the SHIFT, CTRL, 2ND ALT, and CAPS modifier keys</td>
</tr>
<tr>
<td>4</td>
<td>On/Off Switch</td>
<td>Controls the Power, Suspend, and Resume operations</td>
</tr>
<tr>
<td>5</td>
<td>Keypad</td>
<td>52-key directional pad shown</td>
</tr>
</tbody>
</table>
Rear Components

This section describes the components found on the rear of the RFID ICODE handheld interface.

Figure 14 - Rear Components

Table 6 - Rear Components

<table>
<thead>
<tr>
<th>Item</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>RFID Module</td>
<td>The RFID Module attached to the rear of the unit can read RFID tags in its storage position (shown above) or swing out up to 180° for maximum range. See the RFID Read Range figure on page 27.</td>
</tr>
<tr>
<td>2</td>
<td>Battery Compartment</td>
<td>The battery compartment can store either the Nickel Metal Hydride (NiMH) rechargeable battery pack or six AA alkaline batteries. You can access the battery compartment by lifting up and turning the retaining clip. For more information using batteries, see &quot;Replacing Batteries/Battery Pack on page 24.&quot;</td>
</tr>
</tbody>
</table>

Compact Flash Slot Cover

The compact flash slot cover located on the top of the unit provides access to the compact flash slot that stores memory and device cards. The hatch cover thoroughly seals the RFID ICODE handheld interface to maintain a total IP65 solution. Four screws secure the cover to the top of the RFID ICODE handheld interface. To insert device or memory cards into the compact flash slot, you must first remove these screws using a flat head screwdriver.

For more information about inserting and removing memory and device cards, see "Using the Compact Flash Slot" on page 27.

Figure 15 - Compact Flash Slot Hatch
Interface Connections

This section describes the interface connectors found on the bottom of the RFID ICODE handheld interface.

The serial interface connection system is a set of rugged interface and cable connectors especially designed for industrial environments. It features positive connector retention without any hardware restraints for quick connect/disconnect operations and a contact design that prevents failure due to pin fatigue and cable stress after repeated use. A standard Type B Mini USB connector allows the RFID ICODE handheld interface to easily connect with PCs and laptops.

Figure 16 - USB and Serial Interface Connectors

Table 7 - Serial Interface Pin-Outs

<table>
<thead>
<tr>
<th>Pin</th>
<th>Description</th>
<th>Pin</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>X1</td>
<td>7</td>
<td>DSR</td>
</tr>
<tr>
<td>2</td>
<td>Ground</td>
<td>8</td>
<td>RTS</td>
</tr>
<tr>
<td>3</td>
<td>RI</td>
<td>9</td>
<td>DCD</td>
</tr>
<tr>
<td>4</td>
<td>CTS</td>
<td>10</td>
<td>11…18V DC input</td>
</tr>
<tr>
<td>5</td>
<td>DTR</td>
<td>11</td>
<td>Shield</td>
</tr>
<tr>
<td>6</td>
<td>TXD</td>
<td>12</td>
<td>RXD</td>
</tr>
</tbody>
</table>

Table 8 - USB Pin-Outs

<table>
<thead>
<tr>
<th>Pin</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>+5V DC</td>
</tr>
<tr>
<td>2</td>
<td>Data –</td>
</tr>
<tr>
<td>3</td>
<td>Data +</td>
</tr>
<tr>
<td>4</td>
<td>Device presence indicator</td>
</tr>
<tr>
<td>5</td>
<td>Ground</td>
</tr>
</tbody>
</table>
Rockwell Automation can provide the following optional power supplies, cables, and adapters based on communication and power requirements. For cable signal and pin assignments, see “Signal and Pin Assignments” in Appendix B, page 107.

### Table 9 - Available Power Supplies, Cables, and Adapters

<table>
<thead>
<tr>
<th>Catalog Number</th>
<th>Part Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>57RF-HH-56US1</td>
<td>Single position charging cradle with domestic power supply cable, USB cable</td>
</tr>
<tr>
<td>57RF-HH-56US2</td>
<td>Domestic wall mount power supply, serial cable, USB cable</td>
</tr>
<tr>
<td>57RF-HH-56IN</td>
<td>Power supply kit (includes power supply, adapters for USA, Europe, Australia, UK, and rest of world), serial cable, USB cable</td>
</tr>
<tr>
<td>57RF-HH-56CA</td>
<td>Serial cable, 15 ft, straight, 9-pin female connector, RS-232, molded</td>
</tr>
</tbody>
</table>
Chapter 4

Operation

Power

The RFID ICODE handheld interface comes with a rechargeable Nickel Metal Hydride (NiMH) battery pack that can provide up to six hours of operating time on a full charge (depending on power management and use).

You will need to charge the Nickel Metal Hydride (NiMH) rechargeable battery pack a minimum of three hours prior to first use. Please note that the battery pack will not attain maximum capacity until it has been charged and discharged approximately four times. As a result, you may experience shorter than expected operating time on the first few uses of the product.

NiMH batteries are an extremely stable and dependable source of electrical energy, but can be sensitive to extreme temperature. If you charge the battery pack in extreme hot or cold, it will not attain a full charge, and as a result will exhibit decreased useable time until it recharges again. As a precaution against overheating, the RFID ICODE handheld interface has built-in temperature sensors that will suspend the charging process if the battery becomes too warm.

Because the battery pack is an electrical device, you should not expose it to moisture or wet environments. If the battery becomes wet, wipe it dry and then allow it to dry thoroughly for several hours before attempting to use or charge it.

Do not leave the battery pack in a fully discharged state for extended periods. This condition may cause one or more of the cells within the battery pack to fail. When this occurs and the battery pack is subsequently re-charged, the failed cell will reduce the total voltage capacity of the battery pack, thus making the battery appear to discharge faster.

Charging the Unit

The nickel metal hydride battery technology used in the RFID ICODE handheld interface has exceptional charge life without the “charge memory” characteristic of conventional nickel cadmium batteries. Partially discharged batteries or extended periods with the charger left connected will not adversely affect battery life or performance.

WARNING: Do not enable or utilize the RFID module while charging the unit. Operation of this nature is likely to cause harmful interference.
To charge the Nickel Metal Hydride (NiMH) battery pack:

1. Plug the power jack of the battery charger/power supply into the corresponding cables connector as shown below.

![Figure 17 - Power Jack](image)

2. Plug the interface cable into the connector on the bottom of the RFID ICODE handheld interface.

3. Plug the battery charger/power supply into a power outlet. The Charge LED should turn on, indicating that the batteries are charging (see Charge/Low Battery Indicator Functions table on page 23).

![Figure 18 - Power Supply and Outlet](image)

4. Once the battery is fully charged (approximately four hours), you can disconnect the power supply and run the RFID ICODE handheld interface exclusively on battery power.

**IMPORTANT** Because the internal battery charger senses several conditions, including temperature, you should charge the unit away from any known, or potential, heat sources. Units exposed to temperatures in excess of 110 °F (43.3 °C) during the charge cycle may experience incomplete charging and reduced operating time per charge.
Chapter 4

Charge/Low Battery Indicator

When using the Nickel Metal Hydride (NiMH) battery pack, the Charge/Low Battery LED will indicate the current battery status as shown in the table below.

Table 10 - Charge/Low Battery Indicator Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
</table>
| **CHARGE** | With the power supply connected, the CHARGE/LOW BAT LED will indicate one of the following conditions:  
- High power charge – the LED will turn solid green  
- Fully/near full charge – the LED will blink green about four times a second  
- Trickle charge – the LED will blink green approximately once per second when either the battery voltage and/or temperature of the battery assembly are not within acceptable limits |
| **LOW BAT** | With the power supply disconnected, the CHARGE/LOW BAT LED will indicate one of the following conditions:  
- Batteries are low – the LED will blink red once per second when there is approximately 30 minutes of power remaining  
- Batteries are very low – the LED will turn solid red when there is approximately 10 minutes of power remaining |

Power/Suspend Switch

The On/Off switch is located above the keypad. Its function depends on the state of the RFID ICODE handheld interface at the time the switch is pressed and on the length of time that the switch is depressed. Operations that the power switch can initiate are:

- Power on
- Power off
- Suspend

Power On

To power on the RFID ICODE handheld interface:

1. Press and hold the ON/OFF switch for one second.
2. The unit should turn on and begin displaying the boot-up process.
3. After approximately 15 seconds, the Windows CE 5.0 desktop should appear.
However, because there is no outward indication (such as a flashing LED) that the RFID ICODE handheld interface is powered off or in Suspend mode, the handheld may resume an active application it if is indeed in a suspended state.

If the unit does not power up or you cannot select any items from the desktop, refer to “Troubleshooting” in Chapter 8 (page 95) for more information.

Power Off

To turn off the RFID ICODE handheld interface, press and hold the On/Off switch for approximately eight seconds. This action will also terminate running applications and cease serial port operations.

Suspend Mode

Suspend mode allows you to suspend, but not terminate active applications. In this mode, the display will turn off and the RFID ICODE handheld interface will cease serial port operations. For battery-powered units, Suspend mode also conserves battery power.

To place the unit in Suspend mode, press and release the On/Off switch.

To take the RFID ICODE handheld interface out of Suspend mode, press and release the On/Off switch again. The display will turn on and the RFID ICODE handheld interface will resume running any suspended application, but you must restart any serial port operations.

If you attempt to resume immediately after suspending the RFID ICODE handheld interface or vice versa, the unit will delay three seconds before resuming or suspending.

Replacing Batteries/Battery Pack

**WARNING:** There is a risk of explosion if you replace the NiMH battery with an incorrect type. Only use a NiMH battery supplied with your unit or a replacement NiMH battery supplied, recommended, or approved by Rockwell Automation.

When using alkaline batteries, replace all alkaline batteries in the RFID ICODE handheld interface at the same time. Do not mix old and new batteries, mix different types or brands of batteries, or dispose of the batteries in a fire. These actions can cause battery rupture or leakage that result in personal injury or property damage.

Remove the batteries from the RFID ICODE handheld interface when not using the handheld for extended periods. Store the batteries in a cool, dry location at normal room temperature.
To replace the rechargeable battery pack or change AA batteries:

1. Turn the power off. With the unit face down, pull the battery cover retaining clip up from its recessed slot and turn the clip in a counter clockwise motion (see the Changing Batteries figure below).

2. Lift the cover up and remove the batteries/battery pack.

3. If the unit contains a Nickel Metal Hydride (NiMH) battery pack, use the tab to lift up on the battery pack and then out.

4. Close the battery cover and turn the battery cover retaining clip clockwise to lock the cover.

**Figure 20 - Changing Batteries**

---

**Power Management**

Battery-powered units can utilize a rechargeable Nickel Metal Hydride (NiMH) battery pack that has an average operating time of six hours on a full charge with power management.

As with all battery-powered devices, the operating time is completely dependent on the environment, device usage, and the number and type of power-drawing peripherals attached. The battery discharge rate in a full “Power Off” state is only slightly higher to the self-discharge rate of the battery itself.
To lengthen the time between charges, you can perform the following actions:

- **Use external power for PC Card operations whenever possible**—some PC Cards as well as extended communication via the serial port, may require large amounts of power to operate, and can quickly drain the batteries.

- **Limit the use of backlight**—minimize backlight use when you are operating on battery power.
  
  You can adjust the backlight timeout level through the Display settings in the Control Panel or on some units by using the keypad.

- **Shorten auto-suspend time**—the RFID ICODE handheld interface is automatically set to suspend operation to conserve battery power when you have not used the keyboard or the stylus after three minutes. You can increase the auto-suspend time by changing the Power settings in the Control Panel.

### Using the RFID Module

The RFID module can read ISO-14443 and ISO-15693 RFID high frequency (13.56 MHz) tags and smart labels. It is compatible with all Rockwell Automation RFID ICODE tags, as well as ICODE tags from other manufacturers.

The RFID module is totally application dependent and derives power from the COM2 port. The RFID module has a flip-out antenna that provides a read range of approximately 3.5 in. (90 mm) with a credit card size tag at 90° (see Figure 21—RFID Read Range on page 27). For optimal tag reading performance, adjust the module to either 90° or 180°.

**IMPORTANT** Electronic items such as microwave ovens and cordless telephones can affect RFID performance. The presence of metal and/or water can also affect read range. Do not enable or utilize the RFID module with a cable connected. Operation of this nature is likely to cause harmful interference.
Using the Compact Flash Slot

The Compact Flash slot located on top of the RFID ICODE handheld interface enables you to utilize Compact Flash and device cards.

If you intend to use a device card, it may also be necessary to install a driver. If so, make sure the card is Windows CE 5.0 compatible and you have the necessary drivers. If you are not sure, check with the card manufacturer before attempting to install the card.

To use the compact flash slot:

1. If needed, remove any screws from the cover to access the Compact Flash slot.
2. Insert the compact flash card into the slot with the front of the display facing you and the top of the card pointed to the slot until it clicks and the release lever moves upward.

Figure 22 - Using the Compact Flash Slot
3. Close the cover.

4. When inserting memory cards, a “UserCF” folder will appear when you open My Computer. You can then copy and paste the contents of UserCF to the other folders on the RFID ICODE handheld interface.

When inserting device cards, the RFID ICODE handheld interface will attempt to recognize the device. If it finds a driver for the device, the RFID ICODE handheld interface will display a dialog box for that device.

If the RFID ICODE handheld interface cannot find a driver for the device, it will display the following dialog box:

5. If the correct card type appears, you can enter the appropriate information in the dialog box required and then click OK to complete the installation.

6. To remove a card from the slot, simply push the card release lever down and remove the card.

Data Entry

Keypads

52-Key Pads

This joystick style keypad with bezel nomenclature features easy screen navigation and alphanumeric keypad entry and four programmable function keys. Users can also access navigation keys and backlight control via the SHIFT key.
45-Key Pads

In order to provide the functionality of a full-size keyboard with only 45 keys, the RFID ICODE handheld interface keypad makes use of modifier keys. Units configured with the 45-key pad utilize five LED indicators (located above the On/Off switch) to indicate the active state of the keypad modifier keys. Units with the 45-key pad also have keypad functions to adjust contrast and backlight.

**Figure 24 - Standard 45-key Pad**

![Standard 45-key Pad Diagram]

**Modifier Keys**

The following modifier keys (located on the bottom of a standard keypad) enable you to access the various functions that can appear on a key. Modifier keys take effect when first pressed and typically remain in effect until you press another key, unless it is another modifier key (see the Modifier Key Actions table on page 30). Optionally equipped units can use LEDs to indicate the selection of a modifier key. The Power/Suspend Switch figure on page 23 provides examples of LEDs.

**Figure 25 - 45-Key Pad Modifier Key**

![45-Key Pad Modifier Key Diagram]

- **CTRL and ALT Keys**—operate in the same manner as on conventional PCs, except that by default they have a one-time locking action to facilitate one-handed operation.
• **SHIFT Key**—unlike conventional PC keyboards, the **SHIFT** key enables you to access symbols, punctuation marks and navigation arrows rather than shift alphabetic keys to uppercase. By default, the **SHIFT** key has a one-time action. However, you can press the **SHIFT** key twice and lock the keypad into Shift mode, where each subsequent key press will only access characters that appear in the upper left of a key. Pressing the **SHIFT** key a third time will release Shift mode.

On standard RFID ICODE handheld interface 45-key pads, the functions and characters accessed via the **SHIFT** key appear in the upper left of a key (shaded in light grey in the Standard 45-key Pad figure on page 29).

• **2ND Key**—shifts the numeric keys to corresponding function keys (1 = F1, 2 = F2, etc.) that are found on conventional PC keyboards. It also shifts other keys for punctuation, non-printing characters (such as Delete and TAB), and PC key definitions (such as Page Up, Page Down, Home, Insert and Caps Lock).

On standard RFID ICODE handheld interface 45-key pads, the functions and characters accessed via the **2ND** key appear at the bottom of a key, (shaded in dark grey in the Standard 45-key Pad figure on page 29).

Like the **SHIFT** key, the **2ND** key has a default one-time action and a locking mode (for example, pressing the **2ND** key twice will lock the keypad into 2ND mode).

<table>
<thead>
<tr>
<th>Table 11 - Modifier Key Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Key Presses</strong></td>
</tr>
<tr>
<td>A</td>
</tr>
<tr>
<td>Shift &amp; A</td>
</tr>
<tr>
<td>2ND &amp; A</td>
</tr>
<tr>
<td>2ND &amp; Caps Lock &amp; A</td>
</tr>
</tbody>
</table>

**Key Repeat**

By default, the RFID ICODE handheld interface does not automatically repeat a key stroke when you hold down a key. However, you can enable the key repeat function by configuring the Keyboard setting in the Control Panel.

**CE Keyboard**

In addition to entering data through the keypad, you can also enter data by using the CE Keyboard. This utility displays a keyboard on the screen to allow data entry via the Command Line or into applications where “text accessibility” control has focus (for example, text or combo box).
To use the CE Keyboard, select Programs>Tools>CeKeys from the Start menu.

To minimize the keyboard, click the keyboard icon that appears in the system tray.

Figure 26 - CE Keyboard

Transcriber

Microsoft® Transcriber is a natural handwriting recognition software program that interprets pen movement across the screen as handwriting (cursive, print, or mixed) input. For more information, please refer to Microsoft Transcriber Help on the RFID ICODE handheld interface.

To run Microsoft Transcriber, select Programs>Tools>Transcriber from the Start menu.

Figure 27 - Transcriber
Chapter 4

Windows CE 5.0 Desktop

This section provides a brief overview of the functions that appear on the Windows CE 5.0 desktop. For information on how to change desktop settings, refer to Windows CE help (Start>Help).

Figure 28 - Windows CE 5.0 Desktop

Windows CE 5.0 Desktop Functions

You can access the following applications, functions, and utilities from the Windows CE 5.0 desktop:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🗑️</td>
<td>Recycle Bin</td>
<td>Used to restore deleted files or empty the bin to create more disk space.</td>
</tr>
<tr>
<td>📱</td>
<td>My Device</td>
<td>Used to navigate and view the folders and files stored on the RFID ICODE handheld interface.</td>
</tr>
<tr>
<td>📥</td>
<td>Inbox</td>
<td>Used to send and receive e-mail by connecting to a POP3 or IMAP4 server.</td>
</tr>
<tr>
<td>📄</td>
<td>My Documents</td>
<td>Used as the default storage location for documents, graphics, and other files.</td>
</tr>
<tr>
<td>📝</td>
<td>Microsoft WordPad</td>
<td>Used to create or edit text files that contain formatting or graphics.</td>
</tr>
<tr>
<td>🌐</td>
<td>Internet Explorer</td>
<td>Used to view web pages.</td>
</tr>
<tr>
<td>🌐</td>
<td>PC Link</td>
<td>Used to make an ActiveSync, Bluetooth, or other type of connection to another device.</td>
</tr>
</tbody>
</table>
Taskbar

The taskbar at the bottom of the RFID ICODE handheld interface desktop displays the Start button, buttons of currently running applications, the Status Area and the Show Desktop icon.

Select the Start button to display the Start menu (see below for details). For each open application, a button appears on the taskbar. Simply click the button to activate the application.

The status area appears on the right and by default displays small icons for the input panel, current time, power status, and network connections. Double-click an icon to activate the related program.

Choosing the Show Desktop icon minimizes active applications and redisplay the desktop. Clicking the Keyboard icon displays the Input Panel menu for data entry.

Figure 29 - Windows CE 5.0 Desktop Taskbar

Power Status Icons

The RFID ICODE handheld interface will display power status icons (shown in the Power Status Icons table below) in the taskbar status area (Windows CE 5.0 Desktop Taskbar figure above) to indicate power use, charging status, and low battery conditions.

Table 12 - Power Status Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Batteries are charging" /></td>
<td>Batteries are charging</td>
</tr>
<tr>
<td><img src="image" alt="Batteries are low – approximately 30 minutes or less of use remaining" /></td>
<td>Batteries are low – approximately 30 minutes or less of use remaining (the CHARGE/LOW BAT LED will blink once per second)</td>
</tr>
<tr>
<td><img src="image" alt="Batteries are very low – approximately 10 minutes or less of use remaining" /></td>
<td>Batteries are very low – approximately 10 minutes or less of use remaining (the CHARGE/LOW BAT LED will turn solid red)</td>
</tr>
</tbody>
</table>
Start Menu

When you click **Start**, the Start menu appears.

**Figure 30 - Start Menu**

By selecting one of the icons in the Start menu (and not the name), you can:

- **Program** – open programs that do not appear on the desktop
- **Favorites** – view a list of web sites added to your Favorites list
- **Documents** – view recently accessed documents and images
- **Settings** – access the Control Panel, establish connections, or configure the Taskbar and Start Menu
- **Help** – view Help
- Start an application using the **Run** command
- Place the unit in Suspend mode

Miscellaneous Tools

You can access the following utility programs from the Tools menu.

**Screen Capture**

The Screen Capture program takes a picture of the screen and saves it as a bitmap file (.BMP) to a designated location. You can set up the program to run from the system tray, or by pressing a hot key.

To setup the Screen Capture program:

1. From the Start menu, select **Programs**>**Tools**>**Screen Capture**. The ScreenCapture.exe dialog box appears:

   ![ScreenCapture.exe dialog box]

   By default, the Screen Capture program is set to take a picture by pressing **HotKey1** after a five-second delay.
2. To change the wait time before the Screen Capture program takes a picture, press the up or down scroll bars under Capture Delay (sec). The default value is five seconds.

3. To change the Keyboard Hot Key assignment, you must access the Hot Key applet in the Control Panel. The default value is HotKey1.

4. To have the Screen Capture program take a picture when you click its icon in the System Tray, check **Auto run in the task bar**.

   **Note**: To deselect this option after making it active, press and hold the icon until the Screen Capture program appears.

5. To view the picture immediately following the screen capture, check **View following capture**.

6. To change the default folder (My Documents) where the pictures are stored, select the button under **Store screen capture in folder**.

   ![Capture Folder](image)

   7. Select a new location and click **OK**.

   8. By default the Screen Capture program automatically assigns a number to each screen capture.

   The numbering scheme starts at JET00000 and increments by one after each capture. To set this number back to JET00000, check **Reset Counter**.

   **IMPORTANT** Screen captures stored in folders other than the SystemCF folder will be lost if you remove power from the unit.

**Warm Boot**

Occasionally, a program may encounter an error from which it cannot recover. In these cases, you can perform a warm boot, which will reinitialize the unit without affecting the contents store in virtual memory.

To perform a warm boot:

1. Select **Programs>Tools>Warm Boot**, the “Are you sure?” prompt appears.

   ![Warm Boot Prompt](image)

   2. Click **Yes** to warm boot the unit.
Manually Saving the Persistent Registry

The RFID ICODE handheld interface internal memory consists of SDRAM and Flash. Typically, any changes made to the RFID ICODE handheld interface including file creation are temporarily stored in the unit’s SDRAM. You must then copy the files from SDRAM to internal flash memory or a removable compact flash card to store the information permanently.

Consequently, if you do not store the information to flash memory and the unit loses power, all information stored in SDRAM will be lost. However, whenever you make changes that affect the registry, such and changing settings in the Control Panel or installing software, you can permanently store registry changes without writing to flash memory by using the Persistent Registry.

To store registry information on the RFID ICODE handheld interface permanently:

1. From the Start menu, select Programs>Tools>SaveReg.

2. The RFID ICODE handheld interface will begin saving the registry.

3. After you successfully save the registry, a message box will appear:

   ![Save Registry, Standby..]

4. Click OK to close the message box.

Command Prompt Windows

The command prompt window allows you to execute limited MS-DOS command line arguments (for example, CD SystemCF, Run TEST.BAT, etc.).

To open the Command Prompt window:

1. From the Start menu, select Programs>Tools>Command Prompt. The Command Prompt window opens:

   ![Command Prompt]
2. You can then type in your commands, for a list of supported commands, type **Help** and press **Enter**.

3. To end the session, type **Exit** and press **Enter**.

**SystemCF Folder**

The only folder that provides non-volatile (permanent) storage is the SystemCF folder. Information stored in other folders will be lost when you remove power from the RFID ICODE handheld interface. You can however, have the RFID ICODE handheld interface automatically copy files from the SystemCF to other folders when booting up.
Notes:
## Configuration

The table below lists the available control panel functions on the RFID ICODE handheld interface.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Aux CF Card" /></td>
<td>Aux CF Card</td>
<td>This function enables you to enable/disable power to CF cards installed in the internal CF Card slot, which is not user accessible.</td>
</tr>
<tr>
<td><img src="image" alt="Aux Switch" /></td>
<td>Aux Switch</td>
<td>For units with a second COM that supplies 5V DC output, use this function to set the default power state (on or off), and test the connected devices.</td>
</tr>
<tr>
<td><img src="image" alt="Backlight" /></td>
<td>Backlight</td>
<td>Use this function to adjust the backlight setting for the following conditions: Line Active, Line Active Inactive, Battery Active, and Battery Inactive.</td>
</tr>
<tr>
<td><img src="image" alt="Battery Select" /></td>
<td>Battery Select</td>
<td>Select one of the following options to calibrate the power status icons for proper use: NIMH, AC Line, or Alkaline.</td>
</tr>
<tr>
<td><img src="image" alt="Beep Select" /></td>
<td>Beep Select</td>
<td>Use this function to change the frequency, volume, and duration properties of the beep.</td>
</tr>
<tr>
<td><img src="image" alt="Certificates" /></td>
<td>Certificates</td>
<td>Use this function to import, view, or remove certificates, which protect your personal information on the Internet, and protect your computer from unsafe software.</td>
</tr>
<tr>
<td><img src="image" alt="CPU Speed" /></td>
<td>CPU Speed</td>
<td>Use this function to determine the current CPU and cold boot-up speed. Allowable selections are 312 MHz and 624 MHz.</td>
</tr>
<tr>
<td><img src="image" alt="Date/Time" /></td>
<td>Date/Time</td>
<td>Use this function to adjust the date, time, and time zone.</td>
</tr>
<tr>
<td><img src="image" alt="Dialing" /></td>
<td>Dialing</td>
<td>Use this function to adjust the dialing location settings and dialing patterns when using a modem.</td>
</tr>
<tr>
<td><img src="image" alt="Display" /></td>
<td>Display</td>
<td>Use this function to adjust the backlight timeout, change the background image, or change the desktop color scheme.</td>
</tr>
<tr>
<td><img src="image" alt="Display Rotation" /></td>
<td>Display Rotation</td>
<td>Use this function to rotate the screen 180° (upside down).</td>
</tr>
<tr>
<td><img src="image" alt="Hot Keys" /></td>
<td>Hot Keys</td>
<td>Use this function to assign functionality to the unit’s eight programmable keys.</td>
</tr>
<tr>
<td><img src="image" alt="Internet Options" /></td>
<td>Internet Options</td>
<td>Use this function to set up connections, security settings, and internet related functions.</td>
</tr>
<tr>
<td><img src="image" alt="Keyboard" /></td>
<td>Keyboard</td>
<td>Use this function to change the repeat delay and repeat rate.</td>
</tr>
<tr>
<td><img src="image" alt="Network and Dial-up Connections" /></td>
<td>Network and Dial-up Connections</td>
<td>Use this function to change network adapter settings and/or set up identification for remote networks.</td>
</tr>
</tbody>
</table>
## Changing System Settings

Any time you make changes through the Control Panel (such changing the time zone), you must also update the persistent registry to store the changes in internal compact flash memory to make the changes permanent.

For example, to change the time zone and save the changes to the registry:

1. Select **Start > Settings > Control Panel**.

**IMPORTANT**  Click the icon, not the name.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Owner</td>
<td>Use this function to enter the owner name, address, phone numbers, notes, and network ID.</td>
</tr>
<tr>
<td></td>
<td>Password</td>
<td>Use this function to enable password protection and set a password.</td>
</tr>
<tr>
<td></td>
<td>PC Connection</td>
<td>Use this function to enable direct connection to a desktop computer.</td>
</tr>
<tr>
<td></td>
<td>Power</td>
<td>Use this function to:  * Check battery power  * Set device to turn off when idle  * Set up power schemes  * Check the power levels of your system devices</td>
</tr>
<tr>
<td></td>
<td>Regional Settings</td>
<td>Use this function to change the appearance of region specific information, such as date, time, and currency.</td>
</tr>
<tr>
<td></td>
<td>Remove Programs</td>
<td>This function enables you to remove programs installed in RAM.</td>
</tr>
<tr>
<td></td>
<td>Stylus</td>
<td>Use this function to recalibrate the touch screen and adjust the stylus double-click rate.</td>
</tr>
<tr>
<td></td>
<td>System</td>
<td>Use this function to view system information, change the RAM (Program/Storage memory) division, change the device name, and change the device description.</td>
</tr>
</tbody>
</table>
2. On the Control Panel, double-click **Date/Time**. The Date/Time Properties dialog box appears. You can now set the date, time and time zone.

3. To adjust the Current Time, use the scroll bars to increase or decrease the value, or select hours, minutes, seconds or AM/PM indicator to set the values individually.

4. To select the Time Zone, use the corresponding list.

5. To adjust the Date, either:
   - Click the arrows on the calendar to select the previous/next month
   - Double-click the month or year to select it from a list
   - Click a day to select it

6. To adjust the clock automatically for daylight savings, check the corresponding box.

7. Click **Apply** to have your setting take effect.

8. Click **OK** to close the Date/Time Properties dialog box and return to the Control Panel.

9. Click **OK** to exit the Control Panel.

10. From the Start menu, select **Programs>Tools>SaveReg**.

**Taskbar and Start Menu Settings**

To change the Taskbar and Start Menu settings:

1. Select **Start>Settings> Taskbar & Start Menu**. The Taskbar and Start Menu Properties dialog box opens.

2. Select the **General** tab:

   ![Taskbar and Start Menu Properties](image)

   - Check **Always on Top** to ensure that the taskbar is always visible, even when a program appears in a full window (maximized).
4. Check **Auto hide** to display the taskbar just when you point to the taskbar area.

5. Check **Show Clock** to display the time of day in the taskbar.

6. Select the **Advanced** tab:

7. Click the **Clear** button to remove the contents of the documents menu.

8. Check the **Expand Control Panel** box to display the contents of the Control Panel as items on the Settings| Control Panel menu.

9. Click **OK** to save the settings and exit the menu.
Connections

ActiveSync® is a desktop utility program (available as a free download from Microsoft®) that allows you to synchronize certain types of information between a PC and the RFID ICODE handheld interface. You can also use ActiveSync to transfer files and install programs on the handheld interface.

When connecting the RFID ICODE handheld interface to the PC via ActiveSync, you can opt to create a partnership and subsequently have the PC automatically recognize the handheld and synchronize information. You can also create a temporary Guest partnership to copy files and install programs. The following procedures describe how to make an ActiveSync connection using a USB or serial interface cable. For information on how to make an ActiveSync connection using Bluetooth or Wi-Fi, refer to the appropriate manual.

Initial Communication

To setup initial communication between the PC and the RFID ICODE handheld interface:

1. If using the serial interface cable, connect the cable to an available COM port on the PC and the RS-232 port on the RFID ICODE handheld interface. If using the USB cable, connect the cable to an available USB port on the PC and the mini USB port on the RFID ICODE handheld interface.

2. On the PC, start ActiveSync.
3. On the ActiveSync menu bar, select **Connection Settings** from the File menu. The Connection Settings dialog box opens.

![Connection Settings dialog box](image)

4. If using the serial interface cable, check the **Allow connections to one of the following** box, and assign the number of the available COM port (typically COM1). If using the USB cable, check the **Allow USB connections** box.

5. Click **OK** to exit.

6. On the ActiveSync menu bar, select **Get Connected** from the File menu. ActiveSync will then start the Get Connected wizard.
7. Click **Next**. ActiveSync will start attempting to establish a connection (this process will take several seconds).

![Screen shot of ActiveSync getting connected](image)

8. On the RFID ICODE handheld interface, double-click **PC Link**.

The following message box appears:

![Screen shot of connecting to PC 115K](image)

9. If ActiveSync successfully establishes communications, the ActiveSync dialog will briefly reappear on the PC and start the New Partnership dialog wizard.

![Screen shot of New Partnership dialog](image)
10. Select your Partnership option as needed and complete the wizard. The ActiveSync dialog box will reappear and display a status of “Synchronizing.” For example:

11. On the RFID ICODE handheld interface, an icon indicating an ActiveSync connection will appear in the system tray.

12. To terminate the ActiveSync connection, double-click the connection icon to display the Connect To dialog box and click Disconnect.
Subsequent Communication

After you install ActiveSync and establish the initial communication between the PC and the RFID ICODE handheld interface, use the following procedure to set up subsequent sessions:

1. If not already attached, connect an interface cable to an available COM port on the PC and the RS-232 port on the RFID ICODE handheld interface. Alternately, connect a USB cable to an available USB port on the PC and the mini USB port on the handheld.

2. On the RFID ICODE handheld interface desktop, double-click PC Link to attempt to re-establish communications.

3. When communication is successfully re-established, the New Partnership wizard appears.

4. Select No on the PC and then click Next. A status of “Connected” should appear in the ActiveSync window.


Wireless Connections

Overview

Turning the Radio On

Before you can utilize the WLAN software, you must make sure the radio is on. Follow the steps below:

1. Select Start>Settings>Control Panel.
2. Then double-click the AuxCF Slot applet.
3. Finally, select the Enabled radio button.
4. Warm boot the unit.

Wireless Zero Configuration Interface

The Wireless Zero Configuration interface enables you to setup, configure, and connect to a WLAN. Whenever you turn on the handheld computer, it will automatically start searching for any wireless network advertising its SSID (service set identifier, or network name) and will display the Wireless Configuration dialog box.

![Figure 31 - Wireless Zero Configuration Utility](image)

While searching for wireless networks, the handheld computer will display the following icons in the system tray to indicate the wireless network connection status. Double-click the WLAN Status icon to access the Wireless Network Connection interface at any time.

Table 13 - WLAN Connection Status Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Connected icon" /></td>
<td>Connected to WLAN</td>
</tr>
<tr>
<td><img src="image" alt="Disconnected icon" /></td>
<td>Disconnected from WLAN</td>
</tr>
</tbody>
</table>
**Wi-Fi Companion**

If you have the Go Wi-Fi P500 CF card, then you will have the Wi-Fi Companion software installed on your handheld computer. Double-click any **Connection Status** icon (as shown in the **Connection Status Icons** table above) to open the Wi-Fi Companion dialog box. Wi-Fi Companion performs a variety of utility functions, such as finding available networks, power management, certificate management, and network troubleshooting.

**Figure 32 - Wi-Fi Companion Screen**

![Wi-Fi Companion Screen]

The following icons will appear in the system tray to indicate the connection status. Double-click a **Connection Status** icon to access Wi-Fi Companion.

**Table 14 - Connection Status Icons**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Excellent" /></td>
<td>Excellent connection</td>
</tr>
<tr>
<td><img src="image" alt="Good" /></td>
<td>Good connection</td>
</tr>
<tr>
<td><img src="image" alt="Marginal" /></td>
<td>Marginal connection</td>
</tr>
<tr>
<td><img src="image" alt="Poor" /></td>
<td>Poor connection</td>
</tr>
<tr>
<td><img src="image" alt="Searching" /></td>
<td>Searching for networks</td>
</tr>
<tr>
<td><img src="image" alt="Available" /></td>
<td>Networks available</td>
</tr>
<tr>
<td><img src="image" alt="Out of Range" /></td>
<td>Networks out of range but configured</td>
</tr>
</tbody>
</table>
Wireless Zero Configuration

Wireless Zero Configuration Requirements

Before you start, find out what security settings you need to connect to your WLAN network. If applicable, consult with the network administrator. The necessary settings may include one or more of the following:

- Wireless network name (SSID)
- WEP network type (Open or Shared), WEP key, WEP key format (Hex or ASCII) and Key Index number
- Use of DHCP or Static IP to assign IP addresses

**Note:** To assign a static IP address to the handheld computer, use the Network and Dial-up Connections applet in the Control Panel. Simply double-click the P5001 icon to access the IP Address screen.

Wireless Zero Configuration Setup

To configure the handheld computer to connect to an 802.11 wireless network using the Wireless Zero Configuration utility:

1. In the Status Bar, double-click the WLAN Connection Status icon to access the Wireless Network Connection dialog box. This icon is also referred to as the Wireless Zero Configuration icon.

**IMPORTANT** The following scenario is for demonstration purposes only. SSIDs, keys, and pass-phrases will be different in your particular environment.
2. Select the **Wireless Information** tab.

3. If the SSID of the wireless network you want to connect to is listed, double-click it. If the name does not appear, double-click **Add New**. In either case the Wireless Properties dialog box appears as shown below.

   ![Wireless Properties Dialog Box](image)

   **IMPORTANT** The SSID is the network name given to a wireless access point. It defines the wireless network to which clients may connect.

4. If needed, enter the Network Name (SSID). (This entry is case sensitive).

5. Depending on your network type, select or enter the following information:
   a. For Open networks that do not use encryption, select **Disabled** as the encryption type.
   b. For Open or Shared networks that use **WEP** encryption:
      i. Select **WEP** as the Encryption type.
      ii. Select the Authentication type: **Open** or **Shared**.
         - If the key is provided automatically by the wireless access point, then make sure **The key is provided automatically** box is checked and skip to Step 5c).
         - If your network administrator informs you that you have to type in a key, clear **The key is provided automatically** checkbox and continue to the next step.
      iii. Enter the **Network Key**. For 40/64-bit keys, use either 10 hexadecimal digits or 5 ASCII characters. For 128-bit keys, use either 26 hex digits or 13 ASCII characters.
iv. Enter the **Key index** number if different than 1.

v. If you are utilizing the 802.1x authentication method in a WEP Open network, you will have to checkmark the **Enable 802.1x authentication** checkbox.

vi. Clear the **Enable 802.1x authentication** checkbox if you are not utilizing the 802.1x authentication method.

---

**IMPORTANT** In addition, if you are using WPA as your authentication method, you may need an additional 802.1x authentication configuration.

6. Click **OK** to save the settings and exit. The Wireless Information dialog window will reappear and the handheld computer will attempt to make a connection to that network.

7. If the connection was successful, a blue halo will appear on the icon next to the connected wireless network name, as shown below.

![Wireless Information dialog window](image)

8. Click **OK** to exit the Wireless Configuration dialog box.

9. To verify that you have a successful network connection, launch Internet Explorer and type in a known web address. That page should appear on your display. For example:

![Internet Explorer with Rockwell Automation website](image)
Setting Up Identification for Remote Networks

To set up identification for remote networks:

1. Select Start>Settings>Control Panel.
2. Double-click Owner. The Owner Properties dialog box appears.
3. In the Network ID tab, enter the user name, password, and domain name you use to log on to the remote network.
4. Click OK to exit.

Connecting to a Mail Server

You can send and receive e-mail by connecting to a POP3 or IMAP4 server. Inbox contains an e-mail service for each method you use. For either service, you must establish a connection to your Internet service provider (ISP) or to the appropriate mail server in your local area network. In addition to creating this connection, you must also create the e-mail service.

Prior to setting up a service, you should obtain the following information from your ISP or network administrator: POP3 or IMAP4 server name, SMTP host name, user name, password, and domain name (for network connections only).

IMPORTANT Windows CE 5.0 does not support other mail protocols such as AOL or services that use special authentication, such as MSN. However, you can gain access to the Internet through these services. If you use the same service to connect to different mailboxes, set up and name a different service for each connection. For additional information about the Inbox, refer to Windows CE 5.0 online help.
To connect to your POP3 or IMAP4 mail server:

1. Select **Start**>**Programs**>**Inbox**>**Services**>**Options**. The Options dialog box opens.

2. Select the **Services** tab and click **Add**. The Service Name dialog box opens.

3. From the Service type list, select POP3 Mail or IMAP4 Mail, enter a unique name for the service (you cannot change this name once entered) and click **OK**. The Mail Service Setup wizard appears.

4. In the Required panel:
   - Select the name of the connection you created to connect to the mail server. If you are receiving e-mail through a network (Ethernet) connection, select **Network Connection**. If you want the Inbox to use your current connection, select **None**.
   - If you have not created a connection, select **Create New Connection**, double-click the **Make New Connection** icon, and follow the instructions in the wizard. When finished, select **Inbox** in the taskbar and continue setting up the Inbox.
   - Enter the **POP3 Host** or **Server (IMAP4)** name of the mail server you use to receive and send messages.
• Enter the **User ID** (user name or mailbox ID) assigned to you.

• Enter the **Password** you will use to access this mail account. If you do not want a prompt to enter the password each time you connect, select **Save password**.

5. In the Optional panel:

• If connecting to a network that uses Windows® NT domain security, enter the **Windows® NT domain name**.

• If your mail service uses a separate server for SMTP, enter the **SMTP Host name**. For POP3 Mail service with an ISP, the ISP must use an SMTP mail gateway.

• Enter your **return e-mail address**.

6. Click **Next**. The General Preferences dialog box opens.

7. Choose any of the settings, all of which are optional, then click **Next**. The Inbox Preferences dialog box opens.

8. Choose any of the settings as needed, then click **Finish**. The Mail Service Setup wizard closes and the Options dialog box reappears.

   **Note:** Receiving entire messages consumes storage memory.

9. Close the Options dialog box to return to the Inbox.
Bluetooth Connections

Setup and Configuration

Introduction

This chapter discusses how to:

- Enable and disable the Bluetooth transmitter
- Make the unit accessible
- Configure Bluetooth services

Before You Start

Before you start, make sure that you enable the Bluetooth device you wish to connect to and set it to discoverable mode. You may also need to configure the services you will use on the device for authentication, encryption and COM port assignment.

If you are using authentication, make sure you have any PIN codes or passkeys handy at both devices.

Bluetooth Icon

The Bluetooth icon in the system tray provides access to the Bluetooth Control Center. It also indicates the state of the Bluetooth transmitter. When the transmitter is active (on), the Bluetooth icon is blue. When the transmitter is inactive (off), the Bluetooth icon is grey with a red X next to it.

Figure 33 - Bluetooth Enabled

Figure 34 - Bluetooth Disabled

Bluetooth Control Center

The Bluetooth Control Center (BCC) application manages Bluetooth operation, accessibility, and services. You can use the BCC to change the settings for connection, discovery and pairing modes, authentication and encryption, COM ports, assignments, etc.

To access the Bluetooth Control Center, double-click the Bluetooth icon in the System Tray. The BCC dialog box appears:
The BCC dialog box has four tabs: General, Accessibility, Services and About.

- Through the General tab, you can turn the Bluetooth transmitter on or off, and access the Bluetooth Connection Manager and Bluetooth Pairing Wizard.

- The Accessibility tab allows you to set the device name (as it will appear to devices trying to make a connection), and make the unit connectable and discoverable by other devices.

- The Services tab enables you to configure File Transfer, Push and Generic Serial service.

- The About tab displays BCC version information.

*Enabling and Disabling the Bluetooth Transmitter*

**Enable the Bluetooth Transmitter**

To enable the Bluetooth transmitter, when it is disabled:

1. Double-click the **Bluetooth** icon in the System Tray. The Bluetooth Control Center (BCC) dialog box opens.
2. Click the **ON** button. After the unit successfully enables the transmitter, it will update the Bluetooth status to **ON**, and the device address should display in the BCC dialog box. The status should be **Bluetooth enabled**.

![Bluetooth Control Center (BCC)](image)

3. Click **OK** to save your changes and exit the BCC.

**Disable the Bluetooth Transmitter**

To disable the Bluetooth transmitter, when it is enabled:

1. Double-click the **Bluetooth** icon in the System Tray. The Bluetooth Control Center (BCC) dialog box opens.

![Bluetooth Control Center (BCC)](image)
2. Click the **OFF** button. After the unit successfully disables the transmitter, it will update the Bluetooth status to **OFF**, and it will no longer display the device address in the BCC dialog box. The status is **Bluetooth disabled**.

![BCC dialog box](image)

3. Click **OK** to save your changes and exit the BCC.

*Making the Unit Accessible*

To configure how the unit interacts with other Bluetooth devices:

1. Double-click the **Bluetooth** icon in the System Tray. The Bluetooth Control Center (BCC) dialog box opens.

2. Select the **Accessibility** tab.

![BCC Accessibility tab](image)

3. Enter a name that uniquely identifies this unit to other Bluetooth devices. The default value is "JETTXL/EYE."

4. Check or clear the **Discoverable Mode** box to make the unit discoverable or not discoverable by other Bluetooth devices. To be found by another Bluetooth device in a search, a unit must be discoverable. The default value is discoverable.

5. Check or clear the **Connectable Mode** box to allow or prevent other Bluetooth devices from connecting to the unit. The default value is connectable.
6. After making your selection, click **OK** to save your changes and exit the BCC.

**Configuring Bluetooth Services**

You can enable and configure the following Bluetooth services on the unit:
- File Transfer Service
- Push Service
- Generic Serial Service

**Configuring File Transfer Service**

The File transfer service enables a remote device to connect to the unit and perform file transfers via FTP.

To set up the File Transfer service:

1. Double-click the **Bluetooth** icon in the System Tray. The Bluetooth Control Center (BCC) dialog box opens.
2. Select the **Services** tab.

![BCC dialog box]

3. If you do not require connected users to enter a username and password, to perform file transfers, then check **Enable File transfer service**.
   
   To require users enter a username and password to perform file transfers, check **Authentication** and then check **Enable File transfer service**.

4. To configure the shared folder or create users, click the **Settings** link that appears next to the Enable File transfer service box. The FTP Server dialog box opens.
5. Under User Settings, click Settings. The User Settings dialog box opens.

6. Click Add to create a new user. The New User dialog box opens.
7. Type in the username and password and then click **OK**. The User Settings dialog box reopens and displays the current users.

![User Settings dialog box]

8. After entering all your user names and passwords, click **Exit** to return to the FTP Server dialog box.

![FTP Server dialog box]

9. To change the shared folder path, change the share path name or set up authentication for everyone, click the **Settings** link that appears next to the Share folder setting box. The Add share folder dialog box opens.

![Add share folder dialog box]
a. To change the path of the shared folder: click the **Browse** button. The Select Directory dialog box opens.

![Select Directory dialog box]

By default, the SystemCF folder is the designated shared folder. You can choose an existing subfolder from the list or click **Up** to select a different folder.

---

**WARNING:** If the unit should lose power, it will only save the contents of the SystemCF folder.

---

a. After making your selection, click **OK**. The Add a Share Folder dialog box reappears.

b. To change the share name, simply type the new share name in the share name box.

c. To set up authentication for everyone:

   Check the **Share this folder for everyone** box. An entry for Everyone will appear in the Registered users box and a prompt for a Password will appear. If needed, type in the password.

![Add share folder dialog box]

10. After making all your selections, click **OK** to return to the FTP Server dialog box and then close the FTP Server dialog box to return to the BCC Services dialog box.
Configuring Push Service

The Push Service enables a remote device to receive a vCard from your unit.

**IMPORTANT** The RFID ICODE handheld interface does not have a default vCard. You must first transfer a vCard from another device.

To enable the Push service:

1. Double-click the **Bluetooth** icon in the System Tray. The Bluetooth Control Center (BCC) dialog box opens.
2. Select the **Services** tab.
3. Click the **Settings** link that appears next to the **Enable Push service** box. The Push server settings dialog box opens.
4. Click **Browse** to select a business card.

![Browse](image)

5. Click **OK** to return to the Push server settings dialog box.

![Push server settings](image)

6. Click **OK** to return to the BCC Services dialog box.

7. Check **Enable Push service**.

**Configuring Generic Serial Service**

The Generic Serial service enables a remote device to connect to the unit for RS-232 based serial communications.

To enable generic Serial service:

1. Double-click the **Bluetooth** icon in the System Tray. The Bluetooth Control Center (BCC) dialog box opens.

![Bluetooth](image)

2. Select the **Services** tab.
3. Click the Settings link that appears next to the Enable Generic Serial service box. The Serial Server dialog box opens.

![Serial Server dialog box]

4. To authenticate incoming serial service request, check Secure connection.

5. To change the COM port for serial connection, ensure that you Allow Serial Connection to this COM port and then select an available COM port (6 or 7).

6. Close the Serial Server dialog box to return to the BCC dialog box.

7. Check the Enable Generic Serial service box to enable serial service.

**Bluetooth Connection Manager**

**Introduction**

The Bluetooth Connection Manager wizard guides you through the process of discovering the following types of devices, establishing connections, and accessing available services:

- LAN Access Points (LAP)
- Bluetooth Phones (Dial-Up Networking)
- Human Interface Devices (HID)
- Generic Serial Devices
- Devices that provide FTP service
- Devices that provide push server service for business card exchanges

The Bluetooth Connection Manager also provides a generic device search and access to a list of favorites.
Accessing the Connection Manager

Before attempting to make a connection with another device, you should make sure that other device is Bluetooth ready, set to **Discoverable**, and set up for the service you want to use.

To access the Bluetooth Connection Manager:

1. Click the **Bluetooth Connection Manager** link in the BCC.

2. The Connection Manager wizard appears.

3. Use the scroll bars to find a device or service type to search for, and then click on that **device** or **service** to begin the connection process.

Making an ActiveSync Connection

ActiveSync is a desktop utility program (available as a free download from Microsoft®) that allows you to synchronize certain types of information between a PC and a Windows CE device. You can also use ActiveSync to transfer files and install programs on the device.

When connecting the device to the PC via ActiveSync, you can create a temporary Guest partnership to copy files and install programs, or you can opt to create a partnership and subsequently have the PC automatically recognize the device and synchronize information.
To make an ActiveSync connection:

1. On the PC, determine the COM port used for Bluetooth serial communication (for example, COM4).
   
   In most cases, this information is viewable in the Bluetooth Configuration window. If you are unsure on how to access this information, consult the documentation for the Bluetooth device connected to your PC.

2. Open ActiveSync and select **Connection Settings** from the File menu.

3. If not enabled, check the **Allow serial cable or infrared connection to this COM port** box and select the same COM port number assigned in Step 1 (for example, COM4).

4. Click **OK** to save your settings.
5. Double-click the **Bluetooth** icon in the System Tray and select the **Bluetooth Connection Manager** link to open the wizard, click the **ActiveSync Connection**. The Find Devices and Services window appears.

![Bluetooth Connection Manager](image)

6. Follow the on-screen instructions and then click **Next >>** to continue. The Bluetooth Connection Manager will then search and display a list of available computers.

![Find Devices and Services](image)

7. Select a device and click **Next >>**. The Bluetooth Connection Manager will then search and display the computer’s services.

![Searching Services](image)
8. Click Next >> to continue. The Bluetooth Connection Manager will prompt you to “Add to Favorites.” To change the connection name, simply type the new connection name in the connection name box.

9. If you wish to add this connection to your list of Bluetooth favorites, check the Add this configuration to favorites checkbox and click Next >> to continue.

10. Click Connect to continue. The Bluetooth Connection Manager will then attempt to make a connection.

11. In some cases, an Authorization dialog box may appear on the PC. For example:

12. Select your options as needed and continue. If ActiveSync successfully establishes communications, the ActiveSync dialog will briefly reappear on the PC and start the New Partnership dialog wizard.
a. If you do not require synchronization or plan to connect to the PC on a regular basis, you can set up a “guest” connection to perform tasks such as copying files or installing programs.

b. To create a guest connection during your initial setup, select No in the New Partnership wizard and then click Next. The ActiveSync main menu will reappear. A status of Connected should appear in the ActiveSync window.

b. To setup a partnership, select Yes. Click Next and complete the wizard.

13. After making the connection, the Bluetooth Connection Manager will reappear. An icon indicating an ActiveSync connection will appear in the system tray.
Notes:
Software

User Interface

Screen Elements

1. **Device Menu** – Use the device menu to change settings, minimize, or exit the program.

2. **Data Menu** – Use the data menu to access additional functions such as Erase, Clear Tag History, Tag Properties, and ASCII characters.

3. **Help Menu** – Access error codes, version information, and technical support.

4. **Column Headers** – Column headers correspond to the byte numbers of the cells in the top row (0...7).

5. **Row Headers** – Row headers correspond to the byte number of the cell in the first column.

6. **Scroll Bar** – Use to scroll up and down to view tag data displayed on the screen.

7. **Data** – The screen displays the data from the last read/write operation. For decimal, hex, and ASCII mode, eight bytes are shown in each row, and four rows can be displayed on the screen at a time. If data is displayed in Binary mode, each row will show 1 byte of data. Individual cells can be edited by selecting the cell and typing new data using the keypad.
8. **Read Button** – Push to read tag data.

9. **Write Button** – Push to write to tag(s).

10. **Continuous Read/Write Check Box** – Select for continuous read or continuous write. Deselect for single read or single write.

11. **Start** – User can specify the start byte for read/write operations. Most tags either have 4 bytes/block or 8 bytes/block. Read/write operations may only start at the beginning of a block. Check **Data > Tag Properties** for information about a specific tag.

12. **Length** – User can specify the length of bytes for read/write operations. Enter “0” to read/write the entire tag. Most tags either have 4 bytes/block or 8 bytes/block. Read/write operations may only be performed on whole blocks. Check **Data > Tag Properties** for information about a specific tag.

13. **Mode** – This is a pull-down menu that allows the user to select the data from four (4) modes (also known as radices): binary, decimal, hexadecimal, or ASCII.

14. **Tag ID** – This shows the Universally Unique Identifier (UUID) of the tag. The user is able to enter a specific UID or “0” in this box.

15. **Type** – This shows the type and memory size of the last tag read, such as SLI 128, SLI-S 256, SLI-L 64, or FRAM 2K.

16. **Scan Number** – The scan number shows the current tag displayed on the screen and the total number of tags as “Scan [Current] of [Total]”. Scan 1 will always be the oldest tag in the history, and the highest number will be the newest tag. Use the down arrow to view older tags and the up arrow to view newer tags. The user can also tap the number field and type in a number to view the corresponding tag.

17. **Read/Write History** – “R” denotes that the record is of a read tag. “W” denotes that the record is of a written tag.

18. **Sound** – The handheld can beep upon successful read/write operation. Push the speaker icon to toggle sound on or off. Sound is on when the icon is blue. Sound is off when the icon is grey.

19. **Status Bar** – The status bar describes operations currently being performed by the handheld, such as “Reading” or “Writing”. It also displays the error code of non-fatal errors.

20. **Date and Time** – The date and time reflects the system date and time. Time can be displayed in 12 hr or 24 hr mode.
### Navigation

There are multiple ways to navigate inside the RFID software. Tap on any text field (such as Start, Length, or UID) using the stylus to edit it. Double-tap a text field to highlight the text. Use the scroll bar to view the contents of the data grid. Additionally, users can tap anywhere within the data grid and use the arrow keys to move up, down, left, and right within the grid.

![Figure 35 - Arrow Keys, 52-Key Keypad](image1)

![Figure 36 - Arrow Key, 45-Key Keypad](image2)

### Working with Tags

#### Read/Write Times

Refer to the following table for tag read/write times:

<table>
<thead>
<tr>
<th>Tag Type</th>
<th>User Memory</th>
<th>Read Time</th>
<th>Write Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>SLI 128</td>
<td>112 Bytes</td>
<td>0.254 s</td>
<td>0.59 s</td>
</tr>
<tr>
<td>SLI-S 256</td>
<td>160 Bytes</td>
<td>1.27 s</td>
<td>2.95 s</td>
</tr>
<tr>
<td>SLI-L 64</td>
<td>32 Bytes</td>
<td>0.47 s</td>
<td>0.95 s</td>
</tr>
<tr>
<td>FRAM 2K</td>
<td>2000 Bytes</td>
<td>6 s</td>
<td>11 s</td>
</tr>
</tbody>
</table>

### Reading Tags

**Single Tag Read to Screen**

Deselect the check box marked *Continuous* for single tag read. Specify the start byte and the length of data you want to read. Enter a length of “0” to read the entire tag. Select the data mode or radix (binary, decimal, hexadecimal, or ASCII) using the drop-down menu. Position the tag and push the *Read* button.

**IMPORTANT** Start and Length values must be in increments of 4 or 8 bytes, depending on block size.
When the handheld interface is reading the tag, the Read button will turn blue, and the status message at the bottom of the screen will say “Reading.” The data will populate on the screen. After the read operation is complete, the Read button will return to its original grey color.

**Single Tag Read to File**

If the Save read tags to file option is selected in Read Settings (see Read Settings on page 87 section), each read tag will be individually saved to a text file in the following tab delimited format:

```
.Mode (Radix) <Date and Time Stamp> <Tag UID> <Tag Type> <Start> <Length> <Data*> [CR] [LF]
```

*The individual data bytes in the data field are separated from one another by a tab, except in ASCII mode.

The time stamp corresponds with the date and time of read. The Tag UID and Type are the same numbers displayed on the screen. The Start and Length correspond to the user-specified values displayed on the screen. Mode will be represented by a single letter: B for binary, D for decimal, H for hexadecimal, and A for ASCII. The Tag Value is the data on the tag between the start byte and the length; this will also correspond with the data displayed on the screen.

**Example:**

```
```

**IMPORTANT** Tag reads will be saved to the \System\RFID ICODE\Data folder.

**Continuous Tag Read to Screen**

Select the check box marked Continuous for continuous read. Specify the start byte and the length of data you want to read. Enter a length of “0” to read the entire tag. Select the data mode (binary, decimal, hexadecimal, or ASCII) using the drop-down menu. Push the Read button to start continuous read.
Chapter 7

The **Read** button will turn blue, and the status bar will alternate between “Scanning” and “Reading”. The handheld will continuously read tags in its field until the blue “Read” button is pushed. After the continuous read operation is complete, the “Read” button will return to its original grey color.

**Continuous Tag Read to File**

To enable the “Save read tags to file” setting, select **Device > Settings** on the “Read” tab. Select whether continuously read tags should be saved into one file for the entire continuous read operation or multiple files with one tag per file. (See **Read Settings** on page 87 for more information).

Select the check box marked **Continuous** for continuous read. Specify the start byte and the length of data you want to read. Enter a length of “0” to read the entire tag. Select the data mode (binary, decimal, hexadecimal, or ASCII) using the drop-down menu. Push the **Read** button to start continuous read.

**IMPORTANT** Start and Length values must be in increments of 4 or 8 bytes, depending on block size.

The **Read** button will turn blue, and the status bar will say “Reading”. The handheld will continuously read tags until the blue **Read** button is pushed. After the continuous read operation is complete, the **Read** button will return to its original grey color.

Tag data will be saved in the following tab delimited format:

```
<Mode> <Date and Time Stamp> <Tag UID> <Tag Type> <Start> <Length> <Data*> [CR] [LF]
```

*The individual data bytes in the data field are separated from one another by a tab, except in ASCII mode.

The time stamp corresponds with the date and time of read. The Tag UID and Type are the same numbers displayed on the screen. The Start and Length
correspond to the user-specified values displayed on the screen. Mode will be represented by a single letter: B for binary, D for decimal, H for hexadecimal, and A for ASCII. The Tag Value is the data on the tag between the start byte and the length; this will also correspond with the data displayed on the screen.

**IMPORTANT** Tag reads will be saved to the \System\RFID\ICODE\Data folder.

### Writing Tags

**Single Tag Write from Screen**

Select the data mode (binary, decimal, hexadecimal, or ASCII) using the drop-down menu. Select the cell to be edited. The cell text will be highlighted, indicating that it is selected. Enter in the new data using the keypad. Specify the start byte and the length of data you want to write. Enter a length of “0” to write the entire contents of the screen.

**IMPORTANT** Start and Length values must be in increments of 4 or 8 bytes, depending on block size.

The data will be written to the tag specified in the “Tag UID” box. To write the data to any tag, enter “0” in the “Tag UID” box. With the Continuous check box deselected, push the **Write** button.

**IMPORTANT** To return the Tag UID to that of the previously read tag, completely delete the contents of the Tag UID box. The previous Tag UID will automatically repopulate.

A confirmation dialogue will pop up. Selecting **Cancel** or the **X** button will cancel the write operation. Select the radio button next to **Screen** and push **OK** to write to the tag from the screen.
The **Write** button will turn blue, and the status bar will say “Writing.” After the write operation is complete, the **Write** button will return to its original grey color.

**Single Tag Write from File**

To write to a tag from a file, ensure that the file is a text (.txt) file in the following tab-delimited format, with a new line denoting a new tag:

```
<Mode> <Date and Time Stamp> <Tag UID> <Tag Type> <Start> <Length> <Data*> [CR] [LF]
```

*The individual data bytes in the data field are separated from one another by a tab, except in ASCII mode.

Deselect the **Continuous** box for Single Write. Push the **Write** button. A confirmation dialogue will pop up. Selecting **Cancel** or the **X** button will cancel the write operation. To change or verify the file from which data will be written, push **Settings**.

This will bring up the **Write Settings** tab and allow users to select a file for write from file. Push the “...” button to open the File Browser window and select a text file. Push **Cancel** to close the settings window without making changes. Push **OK** to save changes, close the window, and return to the **Write from** pop-up window. See **Write Settings on page 88** for more information.
Select the **File** radio button and press **OK** to begin the Write from File operation.

The following five data organization formats are allowed:

- Single Line, Unspecified Tag UID
- Single Line, Specified Tag UID
- Multiple Lines, Each Line Specifies a Tag UID
- Multiple Lines, Unspecified Tag UID in Top Line Only
- Multiple Lines, No Specified Tag UIDs

**Single Line, Unspecified Tag UID**

Data from the file can be written to any tag.

**Example:**

```
H 2/6/2011 13:55:53 0 SLI 128 8 4 61 75 74 6f
```

**Single Line, Specified Tag UID**

Data from the file will only be written to the tag that matches the specified Tag UID. Attempting to write the data to a tag with a different Tag UID will result in an error message.

**Example:**

```
```

**Multiple Lines, Each Line Specifies a Tag UID**

The program will search the file for the Tag UID that matches with the tag that is currently being scanned. The corresponding data will be written to the tag. If the file does not contain a Tag UID that matches with the tag currently being scanned, an error message will pop up.

**Example:**

```
```
Multiple Lines, Unspecified Tag UID in Top Line Only

The program will search the file for the Tag UID that matches with the tag that is currently being scanned. The corresponding data will be written to the tag. If the file does not contain a Tag UID that matches with the tag currently being scanned, the data corresponding with the top line will be written to the tag.

Example:


Multiple Lines, No Specified Tag UIDs

The top line will be written to the tag.

Example:

H 2/6/2011 13:55:53 0 SLI 128 8 4 61 75 74 6f
B 2/6/2011 13:56:06 0 SLI 128 8 4 01101101 01100001 01110100 01101001

IMPORTANT If the tag is read in binary mode, each set of 8 bits will be reversed in the text file compared with the data displayed in the RFID application. This is because the application grid is little endian (least significant bit first), and the text file is big endian (most significant bit first).

Continuous Tag Write from Screen

Select the data mode (binary, decimal, hexadecimal, or ASCII) using the drop-down menu. Select the cell to be edited. The cell text will be highlighted, indicating that it is selected. Enter in the new data using the keypad. Specify the start byte and the length of data you want to write. Enter a length of “0” to write the entire contents of the screen. Click the Tag UID box and change it to “0” using the keypad.

IMPORTANT Start and Length values must be in increments of 4 or 8 bytes, depending on block size

Check the Continuous check box. Push the Write button. A confirmation dialogue will pop up. Selecting Cancel or the X button will cancel the write operation. Select Screen and OK to write to the tag from the screen.
The Write button will turn blue, and the status bar will say “Writing”. The device will continuously write the specified data to tags until the blue Write button is pushed. After the continuous write operation is complete, the Write button will return to its original grey color.

Continuous Tag Write from File

To write to a tag from a file, ensure that the file is a text (.txt) file in the following tab-delimited format, with a new line denoting a new tag:

```
<Mode> <Date and Time Stamp> <Tag UID> <Tag Type> <Start> <Length> <Data*> [CR] [LF]
```

*The individual data bytes in the data field are separated from one another by a tab, except in ASCII mode.

Check the Continuous box for Continuous Write. Push the Write button. A confirmation dialogue will pop up. Selecting Cancel or the X button will cancel the write operation. To change or verify the file from which data will be written, push Settings.
This will bring up the Write Settings tab and allow users to select a file for Write from File. Push the “…” button to open the File Browser window and select a text file. Push Cancel to close the settings window without making changes. Push OK to save changes, close the window, and return to the Write from… pop-up window. (See Write Settings on page 88 for more information.)

Select the File button and press OK to begin the Write from File operation. The Write button will turn blue during the operation. Press the blue Write button to stop the operation at any time. The Write button will return to its original grey color after the operation is complete.

The following four data organization formats are allowed:

- Multiple Lines, Each Line Specifies a Tag UID
- Multiple Lines, Unspecified Tag UID in Top Line Only
- Multiple Lines, No Specified Tag UIDs
- Single Line, Unspecified Tag UID

Multiple Lines, Each Line Specifies a Tag UID

In this format, the Tag UID is specified for each tag in the file. When a tag is scanned, the software searches for its Tag UID in the file and writes the corresponding data to the tag. The status bar will display “Writing” while the data is being written to the tag and “Ready” when it is waiting for the next tag. If the user scans a tag for which the Tag UID does not appear in the file, an error message will appear.
Example:


Multiple Lines, Unspecified Tag UID in Top Line Only

In this format, the Tag UID is specified for each tag in the file, except for the top line, which has an unspecified Tag UID (for example, “0”). When a tag is scanned, the software searches for its Tag UID in the file and writes the corresponding data to the tag. If the user scans a tag for which the Tag UID does not appear in the file, the data corresponding with the top line (unspecified Tag UID) will be written to the tag. The status bar will display “Writing” while the data is being written to the tag and “Ready” when it is waiting for the next tag.

Example:

H 2/6/2011 13:55:53 0 SLI 128 8 4 61 75 74 6f
B 2/6/2011 13:56:06 0 SLI 128 8 4 01101101 01100001 01110100 01101001

Multiple Lines, No Specified Tag UIDs

In this format, all Tag UIDs in the file are unspecified (for example, “0”). When the first tag is scanned, the data in the first line will be written to the tag. When the handheld detects a tag with a different Tag UID, the data in the second line will be written to the second tag. For each line, the handheld will wait for a tag with a different Tag UID than the tag that was previously written to. The status bar will display “Writing” while the data is being written to the tag and “Ready” when it is waiting for the next tag. After writing all lines in the file, the device will exit Continuous Write mode.

Example:

H 2/6/2011 13:55:53 0 SLI 128 8 4 61 75 74 6f
B 2/6/2011 13:56:06 0 SLI 128 8 4 01101101 01100001 01110100 01101001

Single Line, Unspecified Tag UID

In this format, the file contains only one line, and the Tag UID is unspecified (for example, “0”). The data from the file is written to each tag that is scanned during the Continuous Write operation.
Example:

H 2/6/2011 13:55:53 0 S11 128 8 4 61 75 74 6f

**IMPORTANT** If the tag is read in binary mode, each set of 8 bits will be reversed in the text file compared with the data displayed in the RFID application. This is because the application grid is little endian (least significant bit first), and the text file is big endian (most significant bit first).

### Device Menu

**Settings**

Push the **Device** menu button and choose **Settings** from the drop-down menu. This will open up a pop-up window with configurable settings for the handheld device.

#### General Settings

The **Settings** menu always opens on the **General** tab. The **General** tab has the following options:

**Detect Tag Timeout** – This setting specifies the amount of time in seconds that the handheld will wait to detect a tag on Single Read or Single Write mode. If no tag is detected within the allotted time, the read/write operation will stop, and an error will be displayed in the status bar. The selectable options are 1, 3, 5, or 10 s.

**Use 24 hour time** – This setting toggles the time on the status bar between 12 hr and 24 hr mode.

Choose **OK** to save changes to settings and close the pop-up window. Choose **Cancel** to close the pop-up window without saving changes.
Grid Settings

The Grid tab allows users to customize the appearance of the data grid with the following options:

**Grid Size** – This setting allows users to specify the number of cells in the grid. The selectable options are 64, 112, 128, 256, and 2000.

**IMPORTANT** If a tag that is larger than the specified grid size is read, the data grid will automatically resize to the size of the tag.

**Headers** – Select between decimal and hexadecimal row and column headers.

Choose **OK** to save changes to settings and close the pop-up window. Choose **Cancel** to close the pop-up window without saving changes.

**History Settings**

The History tab allows the user to set the maximum number of records displayed in tag history. If the user scans more than the max number defined in Settings, the earliest scanned record will be deleted from tag history. The selectable options are 10, 20, 50, 100, or 500 records.

Choose **OK** to save changes to settings and close the pop-up window. Choose **Cancel** to close the pop-up window without saving changes.
Read Settings

The Read tab allows users to choose whether read tags are saved to a text file (.txt). If the box next to **Save read tags to file** is checked, the user can then either choose to save to a default file name or specify a file name. The program will automatically increment the file name for each new tag read. (For example, if the user specifies “myfile” as the file name, subsequent tags will be saved as “myfile1.txt”, “myfile2.txt”, etc.)

**IMPORTANT** When specifying a file name, do not enter the .txt suffix, as it will automatically be appended.

When Single Read tags are saved, a separate file is created for each tag. Under the **Save continuous read as** selection, users can choose to save each tag from a Continuous Read operation into a separate file by selecting **Multiple files**.

**Example:**

`myfile1.txt`


`myfile2.txt`


`myfile3.txt`


Choose **One file** to save all tags from a Continuous Read operation to the same file.

**Example:**

`myfile1.txt`


If the **Save read tags to file** box is unchecked, read tags will be displayed on the screen but not saved to a file.
Chapter 7

Choose **OK** to save changes to settings and close the pop-up window. Choose **Cancel** to close the pop-up window without saving changes.

**Write Settings**

The **Write** tab allows users to write to tags from an existing text file (.txt). This tab can be accessed whenever users choose to write from file. (See Writing Tags on page 78 for more information.)

Press the “...” button to the right of the text field to open the file browser. Double-click on a file to select it and return to the Write Settings tab. The selected file will be displayed in the text field. Press **OK** to save changes to Settings, or press **Cancel** to close the Settings window without saving changes.
Chapter 7

Erase Settings

The **Erase** tab allows users to configure erase options. Select the radio button next to \(<00>\) to fill each block in the tag with the value \(<00>\) when the **Erase** button is pushed. Similarly, selecting \(<FF>\) causes the erase function to fill the tag with the value \(<FF>\). The third radio button allows the user to specify a value to fill the tag with when erasing.

Choose **OK** to save changes to settings and close the pop-up window. Choose **Cancel** to close the pop-up window without saving changes.

**Minimize**

Go to **Device > Minimize** to minimize the RFID application. If another application is running, it will be displayed. If no other application is running, the Start Menu will be displayed.

**IMPORTANT** Minimize will not display the Desktop.
If the Taskbar is hidden, click on the bottom of the screen to show it.

**Exit**

Go to **Device > Exit** to exit the RFID application.

**IMPORTANT** Tag History will be cleared upon exiting the application.

**Data Menu**

**Erase**

Navigate to **Data > Erase**. Push **Yes** on the confirmation dialogue to erase the tag. Push **No** to cancel the operation. Erasing a tag sets all writeable bytes to \(<00>\), \(<FF>\), or a user-defined value (depending on settings in Erase Options). Enter
the UID in the **Tag UID** box to erase data from a specific tag. Set the **Tag UID** box to 0 to erase any tag. The status bar will say “Erasing” while the operation is being performed.

**IMPORTANT**  
Erase will not affect the data displayed on the screen.

## Clear Tag History

Navigate to **Data > Clear Tag History** to clear all tags in read/write history. Push **Yes** on the confirmation dialogue to proceed. Push **No** to cancel. The tag history counter will be reset to “1 of 0”, and the data grid will be completely cleared. Tag history can also be cleared by exiting the program.

## ASCII Table

To enter special characters in ASCII mode, navigate to **Data>ASCII**. Select the character from the pop-up ASCII table or push the ‘X’ to return to the main screen.

![ASCII Table](image)

## Tag Properties

![Tag Properties](image)
Navigate to **Data > Tag Properties**. A pop-up window will open displaying additional information about the current tag. The user can scroll through tag properties of any tag in tag history by using the up/down arrows in the lower left corner of the window. Alternately, tap in the text field, type the number of the tag record to view, and press **Enter**. Press **X** to close the Tag Properties pop-up window.

Tag Properties shows the following information:

- **Tag UID**: The Universally Unique Identifier of the tag. Also displayed on main screen.
- **Tag Type**: Displays whether a tag is SLI 128, SLI-S 256, SLI-L 64, or FRAM 2K.
- **Start Byte**: First byte from which the read/write operation was performed. Also displayed on main screen.
- **Bytes Read**: Total number of bytes read in the operation. This is also the number in the “Length” field on the main screen.
- **Bytes per Block**: Start and Length values must be 0 or multiples of this number. Typically 4 for SLI, SLI-L, and SLI-S tags and 8 for FRAM tags.
- **Number of Blocks**: Total number of blocks in the tag. Also the tag size in bytes divided by the block size.
- **User Memory**: Total number of bytes available for user read/write access.

**Help Menu**

*Error Table*

Navigate to **Help > Error Codes** to bring up a list of error codes and their meanings. For more information on error codes see the “Error Codes” section on page 96.

*About*

Navigate to **Help > About** to bring up information about the software, such as Version and Release Date. The About window also displays contact information for technical support.
This section assumes that an ActiveSync connection has been made between the PC and the handheld device. If not, please read the ActiveSync section on page 43 for instructions on how to set up ActiveSync.

This example uses Microsoft Excel 2007. The sequence may differ slightly depending on the Excel version used and the configuration of the PC.

Open the RFID software on the handheld device. Go to the **Read** tab under **Device>Settings** and check the **Single read to file** box. Specify file name as “testfile”.

Enter “0” as the Start byte, “4” as the Length, and “Hex” as the Mode. Perform a single read to file. (See **Single Tag Read to File on page 76** section for more details.) The data from the tag will populate on the screen and simultaneously be saved to a text file.

Open the ActiveSync window on the PC and click on **Explore**.

Navigate to the \SystemCF\RFID ICODE\Data folder. Copy the file “testfile1.txt” to the desktop of the PC. Start Excel on the PC.

Drag and drop the “testfile1.txt” icon from the desktop to the Excel window.
The contents of the file should now be displayed in Excel, with each field appearing in its own column. The width of the columns in the spreadsheet can be adjusted by double-clicking the lines between the column headings.

Make the following edits to the file in Excel:
- Copy the tag record and paste it into row 2
- Change the UID (column C) to 0 for both tag records
- Change the Length (column F) of both tag records to 8
- Edit the Data of the first record (columns G...N) to AA BB CC DD A1 B2 C3 D4
- Change the Mode (column A) of the second record to A for ASCII
- Edit the Data (column G) of the second record to “Rockwell”, without the quotes
- Delete any data in the columns H...J of the second record

Save the file to the PC desktop as “Testfile_new.txt”. Click Yes on the pop-up dialogue.
Copy and paste “testfile_new.txt” to the \SystemCF\RFIDApp\Data folder using the ActiveSync window on the PC.

If the RFID software is not already running on the handheld device, open the program. Go to the **Write** tab under **Device > Settings**. Push “…” to open the file browser and navigate to the \SystemCF\RFIDApp\Data folder. Double-click on “**Testfile_new.txt**” and click **OK** on the Write Settings window.

Perform a continuous write from file using two ICODE compatible RFID tags. (See **Continuous Tag Write from File on page 82** for more details.) The data from the file will populate on the screen and simultaneously be written to the tag. The Continuous Write from File operation will end after writing the two records from the file to tags.

**IMPORTANT** If the handheld displays the “Bad record format” error during Continuous Write, open the file in WordPad and delete any extraneous spaces, tabs, or returns.

The handheld should display the data “**Rockwell**” in ASCII mode written to the second tag in cells 0...7.

Push the down arrow in Read/Write History to display the previous record on the screen. Change the Mode to Hex. The handheld should now display the data AA, BB, CC, DD, A1, B2, C3, D4 written to the first tag.

**IMPORTANT** Do not use the ASCII mode to read tags when the values of the data bytes are less than 20h (32d). Data stored in this manner can contain control characters (e.g. TAB’s, used as separator), which can lead to erroneous results and interpretations when displayed in ASCII format in text editors or Excel.
Troubleshooting

Frequently Asked Questions

My RFID ICODE handheld interface does not respond when I press the power button.

- Is the unit in Suspend mode?
- If battery-powered, check the batteries.
- Are all cables connected properly:
  - Is the power supply plugged into an active AC outlet?
  - Is the power connector securely plugged into the RFID ICODE handheld interface?

I changed my system settings, but when I turn on the RFID ICODE handheld interface, my settings are gone.

- You must save the registry after making any system or configuration changes. See Manually Saving the Persistent Registry on page 36.

I transferred files to the RFID ICODE handheld interface from my host computer, but when I turn on the RFID ICODE handheld interface my transferred files are missing.

- To store transferred files permanently, you must file copy the files into internal flash memory or a compact flash card.
  Occasionally, transferred files can be hidden from view, double-click My Computer, select Options from the View menu and clear all boxes.

I cannot connect to the development system using ActiveSync.

- Did you install ActiveSync using the Administrator account?
- Check the cable connections.
- Check the serial communications configuration.
- Make sure the correct COM port is available.
- In ActiveSync, check the Connection Settings for the connection type you are using (USB, Serial or Ethernet).

The screen is too light or too dark.

- Adjust the brightness via the brightness control in the Control Panel.

The stylus is not responding properly.

- The screen is not calibrated correctly to interpret the screen taps. You need to recalibrate the screen.
The RFID ICODE handheld interface acts slowly.

- The unit may be short of program memory or storage memory.
- Increase the amount of storage or program memory through the System control in the Control Panel.
- You can also delete any unnecessary files.

I get little or no sound from the RFID ICODE handheld interface.

- Adjust the volume and sound properties via the Volume and Sound control in the Control Panel.

The RFID ICODE handheld interface does not recognize a compact flash or device card.

- The card is not installed or seated properly.
- Reinstall the card. There may be an unstable connection between the card and the RFID ICODE handheld interface.
- Remove the card, clean the edge connector with a soft dry cloth, and reinstall the card.

The RFID ICODE handheld interface goes into auto-suspend after a short period of inactivity.

- As a default, the device will auto-suspend after two minutes of inactivity while running on batteries and after thirty minutes of inactivity when running on AC power.
- Adjust the power management properties via the Power control in the Control Panel.

No sound is heard when you tap the touch screen or press a key.

- Volume setting is low or turned off.
- Check the volume slider in the Volume & Sound properties dialog box in the Control Panel.

## Error Codes

### Initialization

The RFID ICODE handheld interface will return the following error codes if an error occurs during initialization:

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>Not initialized</td>
</tr>
<tr>
<td>101</td>
<td>Could not open COM port</td>
</tr>
<tr>
<td>102</td>
<td>Could not turn on auxiliary power</td>
</tr>
<tr>
<td>103</td>
<td>Could not initialize module</td>
</tr>
</tbody>
</table>
Parameters

The RFID ICODE handheld interface will return the following error codes if an error occurs while passing function parameters:

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>200</td>
<td>Invalid flag setting</td>
</tr>
<tr>
<td>201</td>
<td>Invalid tag type</td>
</tr>
<tr>
<td>202</td>
<td>Tag ID is empty</td>
</tr>
<tr>
<td>203</td>
<td>Invalid tag type for read/write command</td>
</tr>
<tr>
<td>204</td>
<td>Invalid starting block (starting block range is 0…249)</td>
</tr>
<tr>
<td>205</td>
<td>Invalid number of data blocks (data block range is 1…16)</td>
</tr>
<tr>
<td>206</td>
<td>Tag data is empty</td>
</tr>
<tr>
<td>207</td>
<td>Data byte size cannot be less than one</td>
</tr>
<tr>
<td>208</td>
<td>Invalid sector number</td>
</tr>
<tr>
<td>209</td>
<td>Invalid key length</td>
</tr>
<tr>
<td>210</td>
<td>Invalid key type</td>
</tr>
<tr>
<td>211</td>
<td>Invalid function type</td>
</tr>
<tr>
<td>212</td>
<td>Invalid data (data range must be 0…255)</td>
</tr>
</tbody>
</table>

Read/Write

The RFID ICODE handheld interface will return the following error codes if an error occurs while attempting to read, write, clear or lock tag data:

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>–1</td>
<td>No tag present</td>
</tr>
<tr>
<td>–2</td>
<td>Invalid start block or length</td>
</tr>
<tr>
<td>–3</td>
<td>Tag ID mismatch</td>
</tr>
<tr>
<td>–4</td>
<td>User cancelled</td>
</tr>
<tr>
<td>–5</td>
<td>Invalid tag info read</td>
</tr>
<tr>
<td>300</td>
<td>No tag ID found in RF field</td>
</tr>
<tr>
<td>301</td>
<td>Not a valid tag ID, invalid tag type detected</td>
</tr>
<tr>
<td>302</td>
<td>Could not read tag data</td>
</tr>
<tr>
<td>303</td>
<td>Invalid starting block (starting block range is 0…249)</td>
</tr>
<tr>
<td>304</td>
<td>Invalid number of data blocks</td>
</tr>
<tr>
<td>305</td>
<td>Could not set reader command</td>
</tr>
<tr>
<td>306</td>
<td>Could not write tag data</td>
</tr>
<tr>
<td>307</td>
<td>Invalid message length</td>
</tr>
<tr>
<td>308</td>
<td>Could not lock data blocks or data blocks already locked</td>
</tr>
<tr>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>-------</td>
<td>-------------------------------------------------</td>
</tr>
<tr>
<td>309</td>
<td>Could not validate tag ID</td>
</tr>
<tr>
<td>310</td>
<td>Could not authorize tag key</td>
</tr>
<tr>
<td>311</td>
<td>Tag not authorized</td>
</tr>
<tr>
<td>312</td>
<td>Could not write tag keys</td>
</tr>
<tr>
<td>313</td>
<td>Could not get firmware revision</td>
</tr>
<tr>
<td>314</td>
<td>Extended function failed</td>
</tr>
<tr>
<td>315</td>
<td>Tag type not supported in current firmware</td>
</tr>
<tr>
<td>316</td>
<td>Tag does not support this function</td>
</tr>
<tr>
<td>317</td>
<td>Sleep/Wake command failed</td>
</tr>
</tbody>
</table>
Appendix A

Specifications

Handheld Specifications

Power

- **Recharge/Line-Power:** 11...18V DC, 1.2 A
- **Standard:** Input at 11...18V DC via serial interface for line-power or battery charging operations
- **Rechargeable Battery Type:** Nickel Metal Hydride (or six AA alkaline batteries)
  - Current Rating: 2 A Max.
  - Voltage: 7.2 V
  - Capacity: 2500 mAh

Display

- Supertwist Nematic Liquid Crystal TFT Touch Screen with white LED backlight
- **Resolution:** 320 x 240 pixels QVGA color

CPU

- **Type:** Intel PXA270 XScale processor
- **Speed:** up to 624 MHz
- **Operating System:** Windows CE 5.0

Memory and Mass Storage

- **SDRAM:** 128 MB
- **Compact Flash:** 512 MB internal compact flash memory, Compact Flash card slot

User Input

- Touch Screen
- **Key Pad:** Choice of 52-key joystick style elastomeric keypad or 45-key elastomeric keypad (includes modifier keys)
- **Feedback:** Tactile and audible
Appendix A

Indicators
• 5 Modifier Key/Programmable LEDs
• Charge/Low Battery Status Indicator

Connectivity
• Serial: RS-232 and Mini USB Type B
• Wireless: Bluetooth (Class 1 or 2) and Wi-Fi (802.11b)

Environmental
• Operating Temperature: -20…+50 °C
• Storage Temperature: -20…+70 °C
• Charging Temperature: -20…+ 40 °C
• Humidity: 5…95% Non-condensing
• IP Rating: 65

Physical Dimensions
• Height (H) without Hatch: 9.84 in. (250 mm)
• Height (H) with Hatch: 10.33 in. (262.4 mm)
• Width (W): 4.75 in. (120.7 mm)
• Depth (D): 1.83 in. (46.5 mm)
• Weight with NiMH Battery: 29 oz (822 g)
• Weight with Alkaline Batteries: 28 oz (794 g)
• Weight without Batteries: 23 oz (652 g)
Figure 38 - Case Dimensions

Dimensions are shown in millimeters (inches).
Figure 39 - Case Dimension with Hatch

Dimensions are shown in millimeters (inches).
Socket Go Wi-Fi! P500 Wireless Card Specifications

Physical Characteristics:
- **Operating Temperature:** 32…158 °F (0…70 °C)
- **Storage Temperature:** 5…185 °F (-20…+85 °C)

Power Consumption (3.3 V Supply):
- **Idle:** <20 mA
- **Transmission:** 265 mA (peak)

Transmit Power:
- **CCK:** 17 dBm typical
- **OFDM:** 14 dBm typical

Standards Conformance:
- Wi-Fi Certified
- Meets 802.1x requirements
- WPA2-Enterprise
- CCX v4
- IEEE 802.11b and 802.11g
- CompactFlash Spec 2.0

**802.11g:**
- Data rate dynamically shifts between 54, 48, 36, 24, 18, 12, 9 and 6 Mbps based on signal strength, for maximum availability and reliability of connection. OFDM with BPSK, QPSK, 16-QAM and 54-QAM (at 6/9, 12/18, 24/36, and 48/54 Mbps, respectively)

**802.11b:**
- Data rate dynamically shifts between 11, 5, 2, and 1 Mbps based on signal strength, for maximum availability and reliability of connection. DSSS with BPSK, QPSK, and CCK (at 1, 2, and 5/11 Mbps, respectively)

Frequency Range:
- **North America:** 2.412…2.462 GHz, channels 1…11
- **Europe ETSI:** 2.412…2.472 GHz, channels 1…13
- **Japan:** 2.412…2.484 GHz, channels 1…14
Indoor Range:

- Approx. 300 ft (100 m) (typical office environment)

Access Protocol:

- Carrier Sense Multiple Access with Collision Avoidance Protocol (CSMA/CA)

Certification/Compliance:

- FCC: Part 15, Class C
- CE: EN 300 328, EN 301 489-17
- Industry Canada: RSS210
- TELEC

IMPORTANT For more information on the Socket Go Wi-Fi! Card, see the following link: [http://www.socketmobile.com/pdf/wireless-lan/go-wi-fi_spec.pdf](http://www.socketmobile.com/pdf/wireless-lan/go-wi-fi_spec.pdf)
Notes:
Signal and Pin Assignments

Serial Interface Cables

This figure lists the standard RS-232 signal and pin assignments for the RFID ICODE handheld interface serial cables.

Figure 40 - 57RF-HH-56CA Cable (Female DE9) RS-232 Signal and Pin Assignments
Notes:
Notes:
Notes:
Rockwell Automation Support

Rockwell Automation provides technical information on the Web to assist you in using its products. At http://www.rockwellautomation.com/support/, you can find technical manuals, a knowledge base of FAQs, technical and application notes, sample code and links to software service packs, and a MySupport feature that you can customize to make the best use of these tools.

For an additional level of technical phone support for installation, configuration, and troubleshooting, we offer TechConnect™ support programs. For more information, contact your local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/support/.

Installation Assistance

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can contact Customer Support for initial help in getting your product up and running.

<table>
<thead>
<tr>
<th>United States or Canada</th>
<th>1.440.646.3434</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States or Canada</td>
<td>Use the Worldwide Locator at <a href="http://www.rockwellautomation.com/support/americas/phone_en.html">http://www.rockwellautomation.com/support/americas/phone_en.html</a>, or contact your local Rockwell Automation representative.</td>
</tr>
</tbody>
</table>

New Product Satisfaction Return

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. However, if your product is not functioning and needs to be returned, follow these procedures.

<table>
<thead>
<tr>
<th>United States</th>
<th>Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to your distributor to complete the return process.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States</td>
<td>Please contact your local Rockwell Automation representative for the return procedure.</td>
</tr>
</tbody>
</table>

Documentation Feedback

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, complete this form, publication RA-DU002, available at http://www.rockwellautomation.com/literature/.

Rockwell Otomasyon Ticaret A.Ş., Kar Plaza İş Merkezi E Blok Kat:6 34752 İçerenköy, İstanbul, Tél: +90 (216) 5698400

www.rockwellautomation.com

Power, Control and Information Solutions Headquarters

Americas: Rockwell Automation, 1201 South Second Street, Milwaukee, WI 53204-2496 USA, Tél: (1) 414.382.2000, Fax: (1) 414.382.4444
Europe/Middle East/Africa: Rockwell Automation NV, Pegasus Park, De Kleeflaan 12a, 1831 Diegem, Belgium, Tél: (32) 2 663 0600, Fax: (32) 2 663 0640
Asia Pacific: Rockwell Automation, Level 14, Core F, Cyberport 3, 100 Cyberport Road, Hong Kong, Tél: (852) 2887 4788, Fax: (852) 2508 1846

Publication 57RF-UM001A-EN-P - September 2011