# Table of Contents

## Overview

**Chapter 1**

Integration with Other Rockwell Automation Products .......................... 8  
FactoryTalk Historian Installation Package ........................................ 9  
Typical Architecture ........................................................................... 9  
User Documentation .......................................................................... 10  
  - On the Installation DVD .............................................................. 10  
  - On the Local Hard Drive ............................................................ 11  
  - In the Start Menu ....................................................................... 11  
Technical Support and Resources ...................................................... 13  
  - Technical Support .................................................................... 13  
  - Knowledgebase ....................................................................... 13  
  - Worldwide Support ................................................................ 13  
  - Training Programs ................................................................... 13  
  - TechConnect Support ............................................................... 14  
  - Find the Version and Build Numbers ....................................... 15  
  - View Computer Platform Information ...................................... 15

**Chapter 2**

System Requirements  
  - FactoryTalk Historian SE Server Machine ................................ 17  
  - FactoryTalk Historian Live Data Interface Machine .................. 18  
  - FactoryTalk Historian Client Machine ...................................... 18  
  - FactoryTalk Historian Asset Framework ................................. 19  
  - FactoryTalk Historian DataLink ............................................... 20

**Chapter 3**

Pre-Installation Tasks  
  - Synchronize Time Settings on FactoryTalk Historian System  
    Computers .................................................................................. 23  
  - Disable the Windows Time Zone (TZ) Environment Variable ... 24  
  - Learn About Installation-related Recommendations ............... 24

**Chapter 4**

Installing FactoryTalk Historian  
  - Installing Core Components .................................................... 25  
    - Install Microsoft SQL Server ................................................ 25  
    - Install FactoryTalk Services Platform .................................. 27  
      - Specify FactoryTalk Directory Server Location ................. 28  
      - Install FactoryTalk Activation Manager .......................... 30
<table>
<thead>
<tr>
<th>Chapter 5</th>
<th>Chapter 6</th>
</tr>
</thead>
<tbody>
<tr>
<td>Post-Installation Tasks</td>
<td>Configuring FactoryTalk Historian</td>
</tr>
<tr>
<td>View the Installation Log File</td>
<td>Activating the Historian Server</td>
</tr>
<tr>
<td>Verify that Historian Services are Running</td>
<td>Securing the Historian Server</td>
</tr>
<tr>
<td>Verify that the Historian Server is Updating Data for Default Tags</td>
<td>Historian Security Components and Their Privileges</td>
</tr>
<tr>
<td>Add the AF Service Computer to the AFServer Group</td>
<td>Managing Historian Security Components</td>
</tr>
<tr>
<td>Manually Create the Asset Framework Database</td>
<td>Creating Security Mappings</td>
</tr>
<tr>
<td>Manually Configure the Asset Framework Service</td>
<td>Managing Security of the Historian Server Database</td>
</tr>
<tr>
<td>Perform the MDB to AF Synchronization</td>
<td>Configuring Firewall for FactoryTalk Historian</td>
</tr>
<tr>
<td>Verify the MDB to AF Synchronization</td>
<td>Configuring the Historian Server</td>
</tr>
<tr>
<td>Disable Virus Scanning</td>
<td>Adding the Server to the FactoryTalk Directory</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Install RSLinx Enterprise (Data Server)</th>
<th>Install Additional Historian Components</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installing FactoryTalk Historian Suites</td>
<td>Install Advanced Server (Optional)</td>
</tr>
<tr>
<td>Install FactoryTalk Historian Asset Framework</td>
<td>Install FactoryTalk VantagePoint (Optional)</td>
</tr>
<tr>
<td>Installation Modes for FactoryTalk Historian Asset Framework</td>
<td>Install FactoryTalk Historian Management Tools (Optional)</td>
</tr>
<tr>
<td>Install FactoryTalk Historian Asset Framework Server</td>
<td>Install FactoryTalk Historian Live Data Interface (Optional)</td>
</tr>
<tr>
<td>Install FactoryTalk Historian SE Server</td>
<td>Install FactoryTalk Historian Management Tools (Optional)</td>
</tr>
<tr>
<td>Install FactoryTalk Historian Live Data Interface (Optional)</td>
<td>Install Advanced Server (Optional)</td>
</tr>
<tr>
<td>Install FactoryTalk Historian Management Tools (Optional)</td>
<td>Install Additional Historian Components</td>
</tr>
<tr>
<td>Install Advanced Server (Optional)</td>
<td>Install Additional Historian Components</td>
</tr>
<tr>
<td>Install FactoryTalk VantagePoint (Optional)</td>
<td>Install Additional Historian Components</td>
</tr>
<tr>
<td>Install Additional Historian Components</td>
<td>Install Additional Historian Components</td>
</tr>
<tr>
<td>Chapter</td>
<td>Title</td>
</tr>
<tr>
<td>---------</td>
<td>-------</td>
</tr>
<tr>
<td>5</td>
<td>Types of Licenses</td>
</tr>
<tr>
<td></td>
<td>How Licenses Are Distributed Between License Pools</td>
</tr>
<tr>
<td></td>
<td>Assigning License Activations to the Historian Server</td>
</tr>
<tr>
<td></td>
<td>Allocating Licenses to Interface Types</td>
</tr>
<tr>
<td></td>
<td>Viewing Allocated Licenses</td>
</tr>
<tr>
<td></td>
<td>Configuring Points</td>
</tr>
<tr>
<td></td>
<td>Adding Individual Data Points Manually</td>
</tr>
<tr>
<td></td>
<td>Adding Multiple Data Points Automatically</td>
</tr>
<tr>
<td></td>
<td>Viewing Current and Archive Data</td>
</tr>
<tr>
<td></td>
<td>Viewing Current Data</td>
</tr>
<tr>
<td></td>
<td>Viewing Archive Data</td>
</tr>
<tr>
<td></td>
<td>Archiving and Backups</td>
</tr>
<tr>
<td></td>
<td>Restarting FactoryTalk Historian SE Server</td>
</tr>
<tr>
<td></td>
<td>Configuring the Data Server</td>
</tr>
<tr>
<td></td>
<td>Configuring Historian Interface Connections</td>
</tr>
<tr>
<td></td>
<td>Configuring FactoryTalk Historian Live Data Interface</td>
</tr>
<tr>
<td></td>
<td>Registering Live Data Interfaces</td>
</tr>
<tr>
<td></td>
<td>Live Data Interface Services</td>
</tr>
<tr>
<td></td>
<td>Enable Buffering</td>
</tr>
<tr>
<td></td>
<td>Manually Enabling Excel Add-ins</td>
</tr>
<tr>
<td></td>
<td>Recording Messages Using FactoryTalk Diagnostics</td>
</tr>
<tr>
<td></td>
<td>Message Parameters</td>
</tr>
<tr>
<td></td>
<td>Viewing Messages</td>
</tr>
<tr>
<td></td>
<td>Chapter 7</td>
</tr>
<tr>
<td></td>
<td>Using FactoryTalk Historian ME Modules with FactoryTalk Security</td>
</tr>
<tr>
<td></td>
<td>Verifying the Windows Administrator Privileges</td>
</tr>
<tr>
<td></td>
<td>Resolving Error and Warning Messages</td>
</tr>
<tr>
<td></td>
<td>General</td>
</tr>
<tr>
<td></td>
<td>Error: System is a PINs Node</td>
</tr>
<tr>
<td></td>
<td>Error: Server Not Found</td>
</tr>
<tr>
<td></td>
<td>Error: Failure to Retrieve Interface Information</td>
</tr>
<tr>
<td></td>
<td>No Connection to FactoryTalk Directory</td>
</tr>
<tr>
<td></td>
<td>Schema Creation</td>
</tr>
<tr>
<td></td>
<td>Folders Creation</td>
</tr>
</tbody>
</table>

**Troubleshooting FactoryTalk Historian**

Types of Licenses ................................................................. 78
How Licenses Are Distributed Between License Pools .......... 80
Assigning License Activations to the Historian Server ........ 85
Allocating Licenses to Interface Types ................................. 86
Viewing Allocated Licenses .................................................... 89
Configuring Points ............................................................... 90
Adding Individual Data Points Manually ......................... 90
Adding Multiple Data Points Automatically .................... 91
Viewing Current and Archive Data ...................................... 93
Viewing Current Data .......................................................... 93
Viewing Archive Data .......................................................... 94
Archiving and Backups ....................................................... 95
Restarting FactoryTalk Historian SE Server ...................... 96
Configuring the Data Server ................................................. 96
Configuring Historian Interface Connections ..................... 97
Configuring FactoryTalk Historian Live Data Interface ......... 98
Registering Live Data Interfaces ......................................... 98
Live Data Interface Services ................................................. 99
Enable Buffering ................................................................. 100
Manually Enabling Excel Add-ins ....................................... 103
Recording Messages Using FactoryTalk Diagnostics ............. 104
Message Parameters .......................................................... 104
Viewing Messages .............................................................. 105

Chapter 7

Using FactoryTalk Historian ME Modules with FactoryTalk Security ......................................................... 107
Verifying the Windows Administrator Privileges ................. 108
Resolving Error and Warning Messages .......................... 109
General ............................................................................ 109
   Error: System is a PINs Node ........................................ 109
   Error: Server Not Found .............................................. 110
   Error: Failure to Retrieve Interface Information .......... 111
No Connection to FactoryTalk Directory ......................... 111
Schema Creation .............................................................. 112
Folders Creation .............................................................. 113
# Table of Contents

Firewall-related Errors ................................................................. 114  
Configuring Windows Firewall with WFCU ........................... 115

## Appendix A
- High Availability (HA) Architecture ...................................... 117  
- Working with Server Collectives .............................................. 119  
- Creating Server Collectives ...................................................... 120  
- Verifying Communication Between Server Collective Members. 122  
- Verifying Replication of Configuration Changes in the Primary  
  Server ...................................................................................... 124  
- Assigning License Activations to Server Collectives .............. 125  
- Configuring Interfaces and Buffering Services for Historian Server  
  Collectives ............................................................................. 128

## Appendix B
- Overview .................................................................................. 129

## Appendix C
- Creating Security Trusts for the FactoryTalk View TrendX Display  
  Object .................................................................................. 131  
- Configuring Trend Properties .................................................... 134

## Appendix D
- Upgrading FactoryTalk Historian to the Current Version .......... 137

## Appendix E
- Removing the Suite Using the Start Menu .............................. 140  
- Removing the Suite Using Control Panel ............................... 140  
- Removing the Suite Using the Installation DVD ...................... 141
Chapter 1

Overview

FactoryTalk Historian Site Edition (SE) provides the capability to collect, store, analyze, and visualize data using a powerful engine and a set of reporting tools such as time-series trends, bar charts, pie charts, pareto and tabular trends, and a method of generating reports using Microsoft Excel. It also uses compressed-storage data algorithms to contain a vast amount of data in a small format.

In the following chapters, you will find information on how to install, secure, configure, use, and troubleshoot FactoryTalk Historian SE:

- System Requirements (page 17)
- Pre-Installation Tasks (page 23)
- Installing FactoryTalk Historian (page 25)
- Post-Installation Tasks (page 53)
- Configuring FactoryTalk Historian (page 61)
- Troubleshooting FactoryTalk Historian (page 107)
- Appendix A: Configuring Historian Servers in High Availability Mode (page 117)
- Appendix B: Configuring Live Data Interface Redundancy (page 129)
- Appendix C: FactoryTalk View SE TrendX (page 131)
- Appendix D: Upgrading FactoryTalk Historian (page 137)
- Appendix E: Removing FactoryTalk Historian (page 139)
**Integration with Other Rockwell Automation Products**

FactoryTalk Historian SE is closely integrated with FactoryTalk Services Platform and the following Rockwell Automation applications:

<table>
<thead>
<tr>
<th>Application</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FactoryTalk Live Data (FTLD)</td>
<td>A direct data interface to FTLD delivers native FTLD data directly to FactoryTalk Historian SE without requiring intermediate interfaces and standards such as OPC.</td>
</tr>
<tr>
<td>FactoryTalk Directory</td>
<td>FactoryTalk Historian SE uses FactoryTalk Directory to look up data points for configuring points to historize. The FactoryTalk Directory is also used for auto-discovering controller data sources and tags in the initial configuration process.</td>
</tr>
<tr>
<td>FactoryTalk Activation</td>
<td>FactoryTalk Historian SE is activated by Rockwell Automation’s central licensing system based on the FactoryTalk Activation Server.</td>
</tr>
<tr>
<td>FactoryTalk Diagnostics</td>
<td>Because of a close integration of FactoryTalk Historian SE with FactoryTalk Diagnostics, all system and diagnostics messages from FactoryTalk Historian SE are centrally stored and maintained in the FactoryTalk Diagnostics database.</td>
</tr>
<tr>
<td>FactoryTalk Audit</td>
<td>All FactoryTalk Historian SE Server auditing messages are stored and available in the FactoryTalk Audit database.</td>
</tr>
<tr>
<td>FactoryTalk View SE Trending</td>
<td>FactoryTalk View Site Edition natively trends data from FactoryTalk Historian SE.</td>
</tr>
<tr>
<td>FactoryTalk Historian Machine Edition (ME)</td>
<td>FactoryTalk Historian ME provides a Data Transfer service to allow its logged data to be transferred to the FactoryTalk Historian SE for long-term storage and analysis.</td>
</tr>
<tr>
<td>FactoryTalk VantagePoint</td>
<td>The data from multiple FactoryTalk Historian SE Servers and FactoryTalk Historian ME Servers can be brought together into a single information management and decision support system using FactoryTalk VantagePoint.</td>
</tr>
<tr>
<td>FactoryTalk Batch</td>
<td>The event journal data from your FactoryTalk Batch system can be collected through the FactoryTalk Batch Interface and stored within FactoryTalk Historian SE.</td>
</tr>
</tbody>
</table>
The FactoryTalk Historian SE installation DVD contains the following software products:

- FactoryTalk Services Platform (with FactoryTalk Directory)
- FactoryTalk Historian Asset Framework
- FactoryTalk Historian SE (includes FactoryTalk Historian SE Server, FactoryTalk Historian Live Data Interface, and FactoryTalk Activation Manager)
- FactoryTalk Historian Management Tools
- RSLinx Enterprise
- FactoryTalk Historian DataLink

The following diagram shows a typical architecture of the FactoryTalk Historian SE environment.
The user documentation on FactoryTalk Historian SE is available in the following locations:

- The FactoryTalk Historian SE installation DVD (page 10).
- The computer on which you have installed FactoryTalk Historian SE (page 11).
- The Help folder in the Start menu (page 11).

There are the following locations on the FactoryTalk Historian SE installation DVD with the user documentation and documentation-related resources:

- The Open Installation Instructions > Installation Instructions page
  On this page you will find the following resources:
  - FactoryTalk Historian SE Installation Assistant
  - FactoryTalk Historian SE Installation and Configuration Guide
  - Adobe Reader required to open PDF files.
- The Read Documentation > Documentation page
  On this page you will find the following resources:
  - FactoryTalk Historian SE Upgrade and Migration Guide
  - FactoryTalk Historian SE Installation and Configuration Guide
  - FactoryTalk Historian SE Reference Guide
  - FactoryTalk Historian Live Data Interface User Guide
  - Introduction to Historian SE Server System Management Guide
  - FactoryTalk Historian SE Release Notes
• Adobe Reader required to open the PDF files.

• A link to the Redist\Docs folder on the installation DVD that stores all the user documentation.


• The Watch Historian How-to Videos on YouTube link on the main page of the installation wizard.

A link to a Rockwell Automation channel at YouTube devoted to FactoryTalk Historian (http://www.youtube.com/playlist?list=PLB6E76CAA1F7F7B5&feature=plcp).

To access the user documentation available on your computer, go to the following locations:

• On a 32-bit operating system:
  C:\Program Files\Common Files\Rockwell\Help.

• On a 64-bit operating system:
  C:\Program Files (x86)\Common Files\Rockwell\Help.

Go to Start > All Programs > Rockwell Software > FactoryTalk Historian SE > Help to access the following documents:

• Auditing the FactoryTalk Historian SE Server User Guide (.pdf)

• Configuring FactoryTalk Historian SE Security User Guide (.pdf)

• FactoryTalk Historian DataLink Online Help (.chm)

• FactoryTalk Historian SE Live Data Interface User Guide (.pdf)
Chapter 1  Overview

- FactoryTalk Historian SE AF 2010 R2 Installation and Maintenance Guide (.pdf)
- FactoryTalk Historian SE Applications User Guide (.pdf)
- FactoryTalk Historian SE Buffering User Guide (.pdf)
- FactoryTalk Historian SE High Availability Administrator Guide (.pdf)
- Introduction to Historian SE Server System Management (.pdf)
- FactoryTalk Historian SE MDB to AF Transition Guide (.pdf)
- FactoryTalk Historian SE OPC DA Interface Failover Manual (.pdf)
- FactoryTalk Historian SE OPC Interface Manual (.pdf)
- FactoryTalk Historian SE Server Reference Guide (.pdf)
- FactoryTalk Historian SE System Explorer User Guide (.pdf)
- FactoryTalk Historian SE System Management Guide (.pdf)
- FactoryTalk Historian DataLink User Guide (.pdf)
- FactoryTalk Historian SE Installation and Configuration Guide (.pdf)
- FactoryTalk Historian SE Upgrade and Migration Guide (.pdf)
- FactoryTalk Historian SE Online Help (.chm)
- FactoryTalk Historian DataLink Release Notes (.htm)
- FactoryTalk Historian SE Release Notes (.chm)
Technical Support and Resources

Rockwell provides dedicated technical support internationally, 24 hours a day, 7 days a week.

You can read complete information about technical support options, and access all of the following resources at the Rockwell Automation Support Web site (http://www.rockwellautomation.com/support/).

Technical Support

Please visit Rockwell Automation Customer Support Center (http://www.rockwellautomation.com/support/) for access to user forums, sample code, software and firmware updates, product manuals, and other downloads.

Knowledgebase

The Customer Support Center offers an extensive online knowledgebase that includes frequently asked questions (FAQs) and the latest patches. Please visit the support site (http://www.rockwellautomation.com/resources/support.html) and select the Knowledgebase link located under Tools & Resources to:

- View technical and application notes.
- Obtain software patches and firmware updates.
- Subscribe to product and service e-mail notifications.
- Ask questions.

Worldwide Support

If you are not located in North America and want to contact Rockwell Automation Support, use the Worldwide Locator (http://www.rockwellautomation.com/locations/) for worldwide contact information.

Training Programs

Rockwell Automation offers a wide range of training programs that include e-learning, regularly scheduled and custom-tailored classes, self-paced training, and certificate programs. For more information on the trainings, visit the Rockwell Automation Training site.
(http://www.rockwellautomation.com/services/training/) or call 1.440.646.3434.

If you are not located in North America and want to contact Rockwell Automation Support, use the Worldwide Locator (http://www.rockwellautomation.com/locations/) for worldwide contact information.

TechConnect Support

With TechConnect Support, your site has unlimited, real-time access to Rockwell Automation’s global network of Customer Support Centers and technical resources. TechConnect service levels are provided at the TechConnect site (http://www.rockwellautomation.com/services/onlinephone/techconnect/).

When you contact Rockwell Technical Support, please provide:

- Product name, version, and/or build numbers.
- Computer platform (CPU type, operating system, and version number).
- Exact wording of any messages that appeared on your screen.
- The message log(s) at that time.
- Descriptions of:
  - What happened and what you were doing when the problem occurred.
  - How you tried to solve the problem.
Find the Version and Build Numbers

To find version and build numbers for each Historian Server subsystem (which vary depending on installed upgrades, updates, or patches), use either of the following methods:

To check the numbers with System Management Tools (SMT):

2. Under Collectives and Servers, select the name of the server you want to check.

The Version in Memory and Version on Disk columns display information on versions of all the server subsystems.

If you do not have System Management Tools installed, open a command prompt, change to the pi\adm directory, and type piversion -v. To see individual version numbers for each subsystem, change to the pi\bin directory and type the subsystem name followed by the option -v (for example, piarchss.exe -v).

View Computer Platform Information

To view platform specifications, right-click My Computer and select Properties. For more detailed information, choose Start > Run, and type msinfo32.exe.
System Requirements

The hardware required with FactoryTalk Historian Site Edition depends on the demands an application places on the system. The greater the demand, the more powerful a system is required. In any application, faster processors and more memory will result in better performance. In addition, there should always be sufficient disk space to provide virtual memory that is at least twice the size of the physical memory.

Learn about the system requirements for the following components of FactoryTalk Historian SE:

- FactoryTalk Historian SE Server Machine (page 17)
- FactoryTalk Historian Live Data Interface Machine (page 18)
- FactoryTalk Historian Client Machine (page 18)
- FactoryTalk Historian Asset Framework (page 19)
- FactoryTalk Historian DataLink (page 20)

### FactoryTalk Historian SE Server Machine

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System requirements</td>
<td>• FactoryTalk Historian SE 25,000 points and below</td>
</tr>
<tr>
<td></td>
<td><strong>Minimum:</strong> Intel Pentium Xeon, 3.2 GHz, 4GB RAM</td>
</tr>
<tr>
<td></td>
<td>• FactoryTalk Historian SE 50,000 points and below</td>
</tr>
<tr>
<td></td>
<td><strong>Minimum:</strong> Intel Pentium Xeon, 3.2 GHz, 4GB RAM</td>
</tr>
<tr>
<td></td>
<td>• FactoryTalk Historian SE 100,000 points and below</td>
</tr>
<tr>
<td></td>
<td><strong>Minimum:</strong> Intel Pentium Xeon dual processor, 3.4 GHz, 4GB RAM</td>
</tr>
<tr>
<td>Hardware</td>
<td>• 100 Megabit or faster Ethernet card, network cable,</td>
</tr>
<tr>
<td></td>
<td>concentrator if using twisted pair wiring; TCP/IP protocol.</td>
</tr>
<tr>
<td></td>
<td>• SVGA TrueColor monitor with 1 MB of video RAM and 1024x768 resolution.</td>
</tr>
</tbody>
</table>
### Chapter 2  System Requirements

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating systems</td>
<td>Microsoft Windows Server 2008 R2 with Service Pack 1 64-bit</td>
</tr>
</tbody>
</table>

#### FactoryTalk Historian Live Data Interface Machine

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware</td>
<td>Minimum: Intel Celeron D, 3.0Ghz, 512MB RAM</td>
</tr>
<tr>
<td>Operating systems</td>
<td>• Microsoft Windows 7 with Service Pack 1 32-bit and 64-bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows XP with Service Pack 3 32-bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2003 R2 with Service Pack 2 32-bit and 64-bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2008 R2 with Service Pack 1 64-bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2008 with Service Pack 2 32-bit and 64-bit</td>
</tr>
</tbody>
</table>

#### FactoryTalk Historian Client Machine

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware</td>
<td>• 100 Megabit or faster Ethernet card, network cable; concentrator if using twisted pair wiring; TCP/IP protocol</td>
</tr>
<tr>
<td></td>
<td>• SVGA TrueColor monitor with 1 MB of video RAM and 1024x768 resolution</td>
</tr>
<tr>
<td></td>
<td>• <strong>Minimum:</strong> Intel Pentium III, 600Mhz, 512MB RAM</td>
</tr>
<tr>
<td></td>
<td>• <strong>Recommended:</strong> Intel Celeron, 3GHz or higher, 1GB RAM or more</td>
</tr>
<tr>
<td>Operating systems</td>
<td>• Microsoft Windows 7 with Service Pack 1 32-bit and 64-bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows XP with Service Pack 3 32-bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2008 R2 with Service Pack 1 64-bit</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Server 2008 with Service Pack 2 32-bit and 64-bit</td>
</tr>
<tr>
<td>Other software</td>
<td>• Microsoft Internet Explorer 6SP1, IE7, IE8</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Excel 2003 or newer for FactoryTalk Historian DataLink or FactoryTalk Historian System Management Tools (SMT)</td>
</tr>
</tbody>
</table>
FactoryTalk Historian Asset Framework

FactoryTalk Historian Asset Framework requirements

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hardware</td>
<td>Processor: a single quad-core processor, minimum 2.2 GHz</td>
</tr>
<tr>
<td>Operating systems</td>
<td>• Microsoft Windows Server 2008 R2</td>
</tr>
<tr>
<td>(both 32-bit and</td>
<td>• Microsoft Windows Server 2008</td>
</tr>
<tr>
<td>64-bit versions,</td>
<td>• Microsoft Windows Server 2003 (with Service Pack 1 or later)</td>
</tr>
<tr>
<td>if available)</td>
<td>• Microsoft Windows 7</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows Vista</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Windows XP with Service Pack 2 or later</td>
</tr>
</tbody>
</table>

Database size

Database storage is consumed depending on the type and quantity of FactoryTalk Historian Asset Framework objects. The table below shows approximate database sizes of some representative Asset Framework systems.

<table>
<thead>
<tr>
<th>AF Element Count (in MB)</th>
<th>Event Frames Count (in MB)</th>
<th>SQL DB Size (in MB)</th>
<th>Recommended Memory (in MB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>40</td>
<td>24</td>
</tr>
<tr>
<td>1,000</td>
<td>10,000</td>
<td>165</td>
<td>99</td>
</tr>
<tr>
<td>2,000</td>
<td>20,000</td>
<td>285</td>
<td>171</td>
</tr>
<tr>
<td>3,000</td>
<td>30,000</td>
<td>400</td>
<td>240</td>
</tr>
<tr>
<td>4,000</td>
<td>40,000</td>
<td>520</td>
<td>312</td>
</tr>
<tr>
<td>5,000</td>
<td>50,000</td>
<td>640</td>
<td>384</td>
</tr>
<tr>
<td>6,000</td>
<td>60,000</td>
<td>755</td>
<td>453</td>
</tr>
<tr>
<td>10,000</td>
<td>100,000</td>
<td>1,100</td>
<td>660</td>
</tr>
<tr>
<td>20,000</td>
<td>200,000</td>
<td>2,230</td>
<td>1,338</td>
</tr>
<tr>
<td>30,000</td>
<td>300,000</td>
<td>3,300</td>
<td>1,980</td>
</tr>
<tr>
<td>40,000</td>
<td>400,000</td>
<td>4,320</td>
<td>2,592</td>
</tr>
<tr>
<td>50,000</td>
<td>500,000</td>
<td>5,380</td>
<td>3,228</td>
</tr>
<tr>
<td>100,000</td>
<td>1,000,000</td>
<td>10,640</td>
<td>6,384</td>
</tr>
</tbody>
</table>
### SQL Server requirements

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Supported SQL Server editions             | • Express  
• Standard                                           |
| Supported SQL Server versions (both 32-bit and 64-bit versions, if available) | SQL Server 2008                                        |
| Required SQL Server components            | • Database Engine  
• Agent (backup and replication)                      |
| Required memory                           | • 1GB for databases with up to 50000 elements  
• 4 GB for databases with up to 200000 elements       |

**NOTE** For databases with up to 1000 elements, Asset Framework may be installed on the FactoryTalk Historian server. For more information on the Microsoft SQL Server system requirements, refer to the Microsoft Development Network (http://msdn.microsoft.com/en-us/library/ms143506(SQL.90).aspx).

### FactoryTalk Historian DataLink

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Hardware        | • Physical memory:  
Min. 32 MB, recommended 128 MB  
• Processor: Pentium or higher  
• Disk space requirements:  
Min. 120 MB for application files and registry entries as well as space for keeping a backup copy of the pisdk.msi and ProcessBook.msi files. |
| Operating systems | • Microsoft Windows Server 2008 R2  
• Microsoft Windows 7  
• Microsoft Windows XP with Service Pack 2 or higher |
### Other software

- **Microsoft Excel Versions:**
  - Microsoft Excel 2010 (32-bit) *
  - Microsoft Excel 2007 *
  - FactoryTalk Services Platform 2.50 (CPR 9 SR 5)

**NOTES**

* If this is a Microsoft Office upgrade and there is a pre-existing installation of DataLink 4.x on that machine, a removal and reinstalltion of DataLink may be necessary. Refer to the KB article 254380 (http://rockwellautomation.custhelp.com/app/answers/detail/a_id/254380/kw/254380) to eliminate VBA related errors that might occur after an Excel upgrade.

** In rare instances, the PI tab does not appear on the ribbon immediately following the installation of the Microsoft Excel add-in. Refer to the KB article 254379 (http://rockwellautomation.custhelp.com/app/answers/detail/a_id/254379/kw/254379) to resolve the situation.
Pre-Installation Tasks

Before you install FactoryTalk Historian SE, do the following:

- Synchronize time settings on Historian system computers (page 23).
- Disable the Windows time zone (page 23).
- Learn about installation-related recommendations (page 24).

Synchronize Time Settings on FactoryTalk Historian System Computers

For all machines that are part of the FactoryTalk Historian system, you must ensure that the time is set correctly and synchronized with the FactoryTalk Historian server. In addition, make sure that all Windows machines have the proper time-zone settings and that they are set to automatically adjust for daylight-saving changes.

The clocks of the FactoryTalk Historian server computer and client computers should all be synchronized. This is typically done through the domain controller. The domain controller’s time is synchronized first by an NTP source. Then, the domain controller synchronizes all the other computers that are a part of the FactoryTalk Historian system.

For details, search the Rockwell Automation Technical Support (http://rockwellautomation.custhelp.com/) web site for daylight saving time.
**Disable the Windows Time Zone (TZ) Environment Variable**

The Windows time zone (TZ) environment variable adversely affects the Historian server. You must ensure that TZ is not set on the Historian server computer.

To confirm that the TZ variable is not set on computers prior to Windows 2008:

1. Go to Start > My Computer.
2. Right-click and select Properties.
3. In the System Properties dialog box, click the Advanced tab.
4. Click Environment Variables.
5. If the TZ variable is present, delete it.
6. If prompted, restart the computer.

To confirm that the TZ variable is not set on Windows Server 2008 and 2008 R2:

1. Go to Start > My Computer.
2. Right-click and select Properties.
3. Click Advanced system settings.
4. Click Environment Variables.
5. If the TZ variable is present, delete it.
6. If prompted, restart the computer.

**Learn About Installation-related Recommendations**

We recommend that you use the default installation options.

If you want to use the SMT software installed on a FactoryTalk Historian SE server computer to manage a FactoryTalk Historian Live Data Interface installed on another computer, you must log on to both computers with the same user name. (The user must have administrator privileges on both computers.)
Chapter 4

Installing FactoryTalk Historian

In this chapter you will find instructions on how to install the following:

- Core components of the product (page 25).
- FactoryTalk Historian suites (page 32).

Installing Core Components

In this section you will find instructions on how to install the following core components of FactoryTalk Historian SE:

- Microsoft SQL Server (page 25)
- FactoryTalk Services Platform (page 27)
- FactoryTalk Activation Manager (page 30)
- RSLinx Enterprise (Data Server) (page 31)

Install Microsoft SQL Server

Microsoft SQL Server 2008 is a requirement for running FactoryTalk Historian Asset Framework.

FactoryTalk Historian SE 3.01 supports SQL Server Express and Standard Editions. Rockwell Automation recommends using the SQL Server Express Edition, which is available on the FactoryTalk Historian SE installation DVD. If you choose to use the SQL Standard Edition (for example, from the FactoryTalk VantagePoint installation DVD), please acquire appropriate Client Access Licenses (CAL) and/or processor licenses from Microsoft. For more information, refer to the Microsoft site (http://www.microsoft.com/sqlserver/en/us/get-sql-server/how-to-buy.aspx).
If you already have an SQL Server, you will be able to point to it during the installation of FactoryTalk Historian Asset Framework.

If you are going to use FactoryTalk VantagePoint as your Historian client, you can use Microsoft SQL Server 2008 R2 that is provided on the FactoryTalk VantagePoint installation DVD. Refer to the following documentation before the installation of the SQL Server:

- *FactoryTalk VantagePoint Getting Results Guide*, section "Installing and Configuring IIS". The guide is available on the FactoryTalk VantagePoint installation DVD.
- Article 279061 - *How to install Microsoft SQL Server 2008 R2 for use with FactoryTalk VantagePoint v3.1.5 and higher*. The article is available on the Rockwell Automation Knowledgebase (http://rockwellautomation.custhelp.com/).

**NOTE** If you want to install the Asset Framework SQL database only, you need to run the installation on the machine with the Microsoft SQL Server installed.

**To install Microsoft SQL Server 2008 Express:**

1. Run the FactoryTalk Historian SE installation DVD.
3. Follow the on-screen instructions to complete the process.

**NOTE** For more information on installing Microsoft SQL Server 2008 Express, refer to the product documentation.
4. If instructed, restart the computer.
Install FactoryTalk Services Platform

When you select this option, the following components will be installed:

- FactoryTalk Diagnostics
- Windows Firewall Configuration Utility (WFCU)
- FactoryTalk Services Platform

FactoryTalk Services Platform is an underlying architecture and a set of common services (such as diagnostic messages, health monitoring services, access to real-time data, and shared plant resources such as tags and graphic displays) that Rockwell Automation products build upon. It is a prerequisite for all FactoryTalk-enabled software products, such as FactoryTalk Historian SE, FactoryTalk View, and RSLinx Enterprise.

FactoryTalk Diagnostics collects and provides access to activity, status warnings, and error messages generated throughout a FactoryTalk system.

For more information on FactoryTalk, refer to FactoryTalk Help. You can access it from Start > All Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk Help after you have installed FactoryTalk Services Platform on your machine.

NOTE  Make sure to install FactoryTalk Services Platform on all the computers, including the computer that will serve as the FactoryTalk Directory.

To install FactoryTalk Services Platform:

1. Run the FactoryTalk Historian SE installation DVD.

2. On the welcome page of the installation wizard, click Install FactoryTalk Historian SE > Install FactoryTalk Services Platform > Install FactoryTalk Services Platform.
Chapter 4 Installing FactoryTalk Historian

The system checks if you have all the required components installed. If any components are missing, a dialog box appears prompting you to install the missing components. Click **Install** to install the components.

The installation wizard appears.

3. On the **Welcome...** page, click **Next**.

4. On the **License Agreement** page, read and accept the terms of the license agreement, selecting the **I accept...** option.

   Click **Next**.

5. On the **Setup Type** page, select **Standard** and click **Next**.

6. On the **Ready to Install the Program** page, click **Install** to start the installation.

   The **Installing** page appears with the status of the installation.

7. On the **InstallShield Wizard Completed** page, click **Finish** to exit the wizard.

   You may be prompted to restart your computer to complete the installation. If you do not choose to restart your computer at this time, be sure to restart it at the completion of the required installation steps for FactoryTalk Historian SE.

**Specify FactoryTalk Directory Server Location**

This configuration points your client computer to the FactoryTalk Directory server computer. Once your computer is connected to the FactoryTalk Directory server, you can use the client computer to administer the Network directory on the FactoryTalk Directory server computer. Also, the FactoryTalk Administration Console window on your client computer reflects the content of the Network Directory server computer.
To specify the FactoryTalk Directory server location:

1. Run the FactoryTalk Historian SE installation DVD.

2. On the welcome page of the installation wizard, click Install FactoryTalk Historian SE > Install FactoryTalk Services Platform > Specify FactoryTalk Directory Server Location.

   The FactoryTalk Directory Server Location Utility dialog box appears.

3. In the FactoryTalk Directory Server Location Utility dialog box, identify the computer that hosts the FactoryTalk Directory server. If it is the current computer, leave localhost in the text box. Otherwise, do the following to point to the proper FactoryTalk Directory computer:
   1. Click the ellipsis button (...). The Login User dialog box appears.
   2. In the User name and Password text boxes, type the credentials to the current FactoryTalk Directory machine. The FactoryTalk Directory Server Configuration dialog box appears.
   3. Select the Remote computer option and click the ellipsis button (...). The Browse for Computer dialog box appears.
   4. Select the machine that hosts the FactoryTalk Directory and click OK.

      The name of the machine appears in the FactoryTalk Directory Server Location Utility dialog box.

5. Click OK.

6. In the message box informing you that you will need to restart the computer, click OK.

7. In the Log On to FactoryTalk (New Server) dialog box, type the user name and password to the newly selected FactoryTalk Directory machine.
Chapter 4  Installing FactoryTalk Historian

8. Click OK. The system connects to the FactoryTalk Directory server.

**NOTE**

On the computers that have FactoryTalk Services Platform installed, you can open the **Specify FactoryTalk Directory Server Location Utility** dialog box also from Start > All Programs > Rockwell Software > FactoryTalk Tools > Specify FactoryTalk Directory Location.

---

**Install FactoryTalk Activation Manager**

FactoryTalk Activation Manager allows you to download activation files using an Internet connection, and transfer activation files to a computer that does not have an Internet connection. Install this software on the same computer as the FactoryTalk Directory server.

**To install the FactoryTalk Activation Manager:**

1. Run the FactoryTalk Historian SE installation DVD.

2. On the welcome page of the installation wizard, click **Install FactoryTalk Historian Site Edition > Install FactoryTalk Services Platform > Install FactoryTalk Activation.**

   The FactoryTalk Activation Manager installation wizard appears with a list of prerequisite packages.

   Click **Continue**.

3. In the message box that appears:
   - Click **Yes**, if you want to install the software for Rockwell Automation USB dongles.
     
     The drivers are used to support mobile activations which are locked in a hardware dongle.
     
     Follow the on-screen instruction to install the software.
   - Click **No**, if you want to skip this step.

4. On the **Welcome...** page, click **Next**.
5. On the **License Agreement** page, read and accept the terms of the license agreement, selecting the **I accept...** option.

   Click **Next**.

6. On the **Ready to Install the Program** page, click **Install** to start the installation.

   The **Installing** page appears with the status of the installation.

7. On the **InstallShield Wizard Completed** page, click **Finish** to exit the wizard.

   You may be prompted to restart your computer to complete the installation. If you do not choose to restart your computer at this time, be sure to restart it before running FactoryTalk Activation.

   **NOTE**
   For more information on FactoryTalk Activation, see "Activating FactoryTalk Historian SE Server  61".

---

**Install RSLinx Enterprise (Data Server)**

RSLinx Enterprise is a FactoryTalk Live Data server and a device-based alarm and event server. RSLinx Enterprise links Allen-Bradley networks and devices to Microsoft Windows products such as the FactoryTalk View SE (HMI software) and the RSLogix family of device programming software. RSLinx Enterprise provides FactoryTalk Historian SE with the data points (tags) it collects from Rockwell Automation controllers.

**NOTE**
It is recommended to install RSLinx Enterprise (Data Server) on the same machine as FactoryTalk Historian Live Data Interface, remote from the FactoryTalk Historian SE server.

**To install RSLinx Enterprise:**

1. Run the FactoryTalk Historian SE installation DVD.

2. On the welcome page of the installation wizard, click **Install FactoryTalk Historian Site Edition > Install RSLinx Enterprise.**
The system checks if you have all the required components installed. If any components are missing, a dialog box appears prompting you to install the missing components. Click OK.

The installation wizard appears.

3. On the Welcome page, click Next.

4. On the License Agreement page, read and accept the terms of the license agreement, selecting the I accept... option. Click Next.

5. On the Setup Type page, select Standard Feature Set Installation, and click Next.

6. On the Ready to Install the Program page, click Install to start the installation.

The Installing... page appears with the status of the installation.

7. In the Windows Security dialog box, select Always trust software from "Rockwell Automation", and click Install to proceed with the installation of the software.

8. On the InstallShield Wizard Completed page:
   • Clear the check box next to Review Release Notes, if you do not want to have them displayed.
   • Click Finish to exit the wizard.

Installing FactoryTalk Historian Suites

In this section you will find instructions on how to install the following suites of FactoryTalk Historian SE:

• FactoryTalk Historian Asset Framework (page 33)
• FactoryTalk Historian SE Server (page 39)
• (Optional) FactoryTalk Historian Live Data Interface (page 43)

Applicable only to the customers who want to install the interface on a remote computer.
• (Optional) FactoryTalk Historian Management Tools (page 47)
  Applicable only to the customers who want to administer the FactoryTalk Historian SE server from a remote computer.
• (Optional) Install Advanced Server (page 50)
• (Optional) Install FactoryTalk VantagePoint (page 52)
• Install Additional Historian Components (page 52)

**NOTE**
To install FactoryTalk Historian SE, use a local Administrator account or any other account that is a member of the Domain Admins group. Do not use the built-in Domain Administrator account of the domain created on Microsoft Windows Server 2008 R2.

**Install FactoryTalk Historian Asset Framework**
When you select this option, the following components will be installed:

• (Optional) Microsoft SQL Server 2008 Express
• FactoryTalk Historian Asset Framework Server

**FactoryTalk Historian Asset Framework is a prerequisite for installing FactoryTalk Historian SE.** AF replaces the Historian Module Database (MDB). Over time, Rockwell Automation will transform MDB applications into AF applications. To provide backward compatibility, FactoryTalk Historian SE 3.01 copies the contents of Historian MDB over to AF, in a process called *transition*. After the migration, the Historian server constantly synchronizes the MDB content with AF, allowing you to access MDB content from AF clients as well as MDB clients. Similarly, you can access AF content from MDB clients, as well as AF clients. This allows you to access your AF content with MDB-based tools, such as ACE, or with an AF client such as FactoryTalk Historian System Explorer.
AF itself requires Microsoft SQL Server. See "Install Microsoft SQL Server (page 25)" for more information.

Before installing FactoryTalk Historian Asset Framework, learn about the installation options it offers. See "Installation Modes for FactoryTalk Historian Asset Framework (page 34)" for more information.

For the best performance and improved security, Rockwell Automation recommends that you install the SQL Server and the Asset Framework service on different computers.

During the installation process, you can decide how the AF service and the AF SQL database will be installed on your computer, by choosing one of five installation modes representing the following scenarios:

- Both the service and the database are located on the same machine:

<table>
<thead>
<tr>
<th>Installation mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AF Application Service and AF SQL Database</td>
<td>The service and the database are installed on the same machine.</td>
</tr>
<tr>
<td>AF Application Service and AF SQL Database with unprocessed database scripts</td>
<td>The service is installed on the machine, the system is prepared for the database installation, and the database scripts are copied to the following location in the Program Files directory: Rockwell Software\FactoryTalk Historian\PIPC\AF\SQL. You can create the database manually, using the provided scripts. See &quot;Manually Create the Asset Framework Database (page 56)&quot; for more information. If you select this option, you need to provide in the DB Server Name text box the name of the SQL Server machine and (optionally) the name of the instance of the SQL Server with which the AF service will communicate.</td>
</tr>
</tbody>
</table>

- The service and the database are located on different machines:
### Installation mode

<table>
<thead>
<tr>
<th>Installation mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AF Application Service</td>
<td>Only the service is installed on the machine. If you select this option, you need to provide in the <strong>DB Server Name</strong> text box the name of the SQL Server machine and (optionally) the name of the instance of the SQL Server with which the AF service will communicate.</td>
</tr>
<tr>
<td>AF SQL Database</td>
<td><strong>Note:</strong> This option must be executed on the machine with the Microsoft SQL Server installed. Only the database is installed on the machine. If you select this option, the database scripts will be copied to the machine and executed during the installation. This will result in creating the PI/FD Asset Framework SQL database.</td>
</tr>
<tr>
<td>AF SQL Database with unprocessed database scripts</td>
<td><strong>Note:</strong> This option must be executed on the machine with the Microsoft SQL Server installed. The system is prepared for the database installation, and the database scripts are copied to the following location in the <strong>Program Files</strong> directory: <em>Rockwell Software\FactoryTalk Historian\PIPC\AF\SQL</em>. You can create the database manually, using the provided scripts. See “Manually Create the Asset Framework Database (page 56)” for more information.</td>
</tr>
</tbody>
</table>

You may choose to create the AF SQL database manually using the provided scripts, for example when the configuration of your SQL server does not allow for the integrated Windows authentication. During the execution of the database scripts you can provide the user name and the password to the SQL Server.
Install FactoryTalk Historian Asset Framework Server

NOTE
If you want to install the Asset Framework SQL database only, you need to run the installation on the machine with the Microsoft SQL Server installed.

To install FactoryTalk Historian Asset Framework Server:

1. Run the FactoryTalk Historian SE installation DVD.


   The installation wizard appears.

   If there are any software prerequisites missing from the computer, they are listed in red at the bottom of the installation wizard Welcome page. Click Cancel and Finish to exit the wizard, install the prerequisites, and start the installation wizard again.

3. On the Welcome... page, click Next.

4. On the License Agreement page, read and accept the terms of the license agreement, selecting the I accept... option.

5. Click Next.

6. On the Review Component Installation page, review the list of the components that are already installed and those that will be installed during the installation process.

   Click Next.

7. On the Destination Drive page, select the drive on which you want to install the product.

   If the space available on the drive is not sufficient for the installation, a warning message will appear below the Installation drive list. In such a case, select another drive or increase the available space on the drive you have originally selected. For more information on the disk space
requirements, refer to the *FactoryTalk Historian SE Release Notes*.

**NOTE**

You can choose the destination drive only if you install the component on the selected machine for the first time. If there have been any FactoryTalk Historian components installed on the machine before, the *Installation drive* list will not be enabled.

Click **Next**.

8. On the **AF Server Components Configuration** page, choose the Microsoft SQL Server name and the installation mode.

1. In the **DB Server Name** text box, type the name of a Microsoft SQL Server or an SQL Server named instance that will host the AF SQL database.

   - To use the local default instance created by Microsoft SQL Server Express, leave the default database name displayed in the text box.

   - To use another SQL Server database instance, type the name of the computer on which the database is located, followed by the name of the instance that hosts the AF SQL database, if the instance name is different than the default one. For example: `SQLDBSERVER\SQLDBINSTANCE`.

2. From the list, select the installation mode. See "Installation Modes for FactoryTalk Historian Asset Framework (page 34)" for more information.

<table>
<thead>
<tr>
<th>Choose this mode:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>(1) AF Application Service and AF SQL Database</td>
<td>Install both the service and the database on the same machine.</td>
</tr>
<tr>
<td>(2) AF Application Service and AF SQL Database with unprocessed database scripts</td>
<td>Install the service, prepare the system for the database installation, and copy the database executable scripts to the machine.</td>
</tr>
<tr>
<td>(3) AF Application Service</td>
<td>Install the service only.</td>
</tr>
<tr>
<td>(4) AF SQL Database</td>
<td>Install the database only.</td>
</tr>
</tbody>
</table>

Rockwell Automation Publication HSE-IN024A-EN-E—December 2012 37
Chapter 4 Installing FactoryTalk Historian

Choose this mode: To:
(5) AF SQL Database with unprocessed database scripts Prepare the system for the database installation, and copy the database executable scripts to the machine.

NOTE For more information on using the database scripts to manually create the database, see "Manually Create the Asset Framework Database (page 56)."

9. Click Next.

- If you have selected to install both the AF service and the AF SQL database (installation mode 1) or the database only (installation mode 4), the installation wizard will test the connection with the database instance. If the connection test fails, an error message generated by the database server appears, for example:

Click OK to close the message. Follow the instructions provided in the message to verify the connection and then click Next on the wizard page to resume the installation.

- If you have selected either to install the AF SQL database only (installation mode 4) or the AF SQL database with the unprocessed database scripts (installation mode 5), a message will appear prompting you to manually add the machine with the AF service installed to the Windows AFServer user group, which is created during the installation of the Asset Framework.
NOTE
See "Add the AF Service Computer to the AFServer Group 55" for more information.

The Installation Progress page appears. It lists the components that are going to be installed. The status of the installation is displayed in the Status column of the component table.

10. Click Install to start the installation.

11. Wait until the components are installed. The installation time will vary depending on the selected installation mode and the computer performance. The installation status is displayed on the progress bar below the component table.

12. On the Installation Wizard Completed page, click Show the installation log, if you want to view the installation log after the installation wizard closes.

13. Click Finish to exit the installation wizard.

Install FactoryTalk Historian SE Server

The FactoryTalk Historian SE server is installed with the following FactoryTalk Historian components:

- FactoryTalk Historian server
- FactoryTalk Historian Live Data Interface
- Historian Interface Configuration Utility (ICU)
- RA Components
- FactoryTalk Activation Manager
Chapter 4 Installing FactoryTalk Historian

NOTE

The FactoryTalk Historian SE Server must be installed on Microsoft Windows Server 2008 R2 with Service Pack 1 64-bit. If you try to install it on any other operating system, the message presented below will appear and the installation will be aborted.

To install the FactoryTalk Historian SE server:

1. Run the FactoryTalk Historian SE installation DVD.

2. On the welcome page of the installation wizard, click Install FactoryTalk Historian SE > Install FactoryTalk Historian Server.

   The installation wizard appears.

   If there are any software prerequisites missing from the computer, they are listed in red at the bottom of the installation wizard Welcome page. Click Cancel and Finish to exit the wizard, install the prerequisites, and start the installation wizard again.

3. On the Welcome... page, click Next.

4. On the License Agreement page, read and accept the terms of the license agreement, selecting the I accept... option.

5. Click Next.

6. On the Customer Information page, type your user name, organization, and the 10-digit product serial number, e.g. 0123456789.
7. On the **Review Component Installation** page, review the list of the components that are already installed and those that will be installed during the installation process.

   Click **Next**.

8. On the **Destination Drive** page, select the drive on which you want to install the product.

   If the space available on the drive is not sufficient for the installation, a warning message will appear below the **Installation drive** list. In such a case, select another drive or increase the available space on the drive you have originally selected.

   **NOTE**

   You can choose the destination drive only if you install the component on the selected machine for the first time. If there have been any FactoryTalk Historian components installed on the machine before, the **Installation drive** list will not be enabled.

   Click **Next**.

   The **Installation Progress** page appears. It lists the components that are going to be installed. The status of the installation is displayed in the **Status** column of the component table.

9. Click **Install** to start the installation.

10. Wait until the components are installed. The installation time will vary depending on the number of components being installed and the computer performance. The installation status is displayed below the component table.

   During the installation process, the **Release Notes** appear. Close the dialog box to proceed with the installation.

   If the FactoryTalk Activation Manager has not been installed yet, the wizard for installing USB dongles software appears.

   The FactoryTalk Activation Manager installation wizard appears with a list of prerequisite packages.

   Click **Continue**.
11. In the message box that appears:
   • Click Yes, if you want to install the software for Rockwell Automation USB dongles.
      The drivers are used to support mobile activations which are locked in a hardware dongle.
      Follow the on-screen instruction to install the software.
   • Click No, if you want to skip this step.
      The installation wizard appears.

12. Follow the instructions displayed on the screen to complete the installation.

13. In the **FactoryTalk Directory Server Location Utility** dialog box, identify the computer that hosts the FactoryTalk Directory server. If it is the current computer, leave localhost in the text box. Otherwise, do the following to point to the proper FactoryTalk Directory computer:
   1. Click the ellipsis button (••). The **Login User** dialog box appears.
   2. In the **User name** and **Password** text boxes, type the credentials to the current FactoryTalk Directory machine. The **FactoryTalk Directory Server Configuration** dialog box appears.
   3. Select the **Remote computer** option and click the ellipsis button (••) to open the **Browse for Computer** dialog box.
   4. Select the machine that hosts the FactoryTalk Directory and click **OK**.
      The name of the machine appears in the **FactoryTalk Directory Server Location Utility** dialog box.
   5. Click **OK**.
   6. In the message box informing you that you will need to restart the computer, click **OK**.
7. In the **Log On to FactoryTalk (New Server)** dialog box, type the user name and password to the newly selected FactoryTalk Directory machine.

8. Click **OK**. The system connects to the FactoryTalk Directory server.

14. On the **Installation Wizard Completed** page, click **Show the installation log**, if you want to view the installation log after the installation wizard closes.

   **NOTE** See "View the Installation Log File (page 53)" for more information.

   If any of the installed components requires rebooting the computer, a relevant message will appear on the installation wizard page, and you will be prompted to restart the machine after the installation wizard closes.

15. Click **Finish** to exit the installation wizard.

16. In the message box prompting you to restart the computer, click **Yes**.

---

**Install FactoryTalk Historian Live Data Interface (Optional)**

The FactoryTalk Historian Live Data Interface collects data points (tags) from the data server and passes them to the FactoryTalk Historian SE server. Install the FactoryTalk Historian Live Data Interface component on the same computer as the data server and separate from the computer that has the FactoryTalk Historian SE server installed.

After installing the interface, configure the buffering service on the data server computer. The buffering service stores data in its memory so that in the event the interface is not able to communicate with the FactoryTalk Historian SE server, the data will not be lost.

By default, the FactoryTalk Historian Live Data Interface is installed during the installation of the FactoryTalk Historian SE Server. Such a configuration is typically used for demonstration
purposes rather than real-life production environments. It is recommended to install the FactoryTalk Historian Live Data Interface on a different computer than the FactoryTalk Historian server, typically on a data server computer.

**NOTE** For more information on buffering, see "Enable Buffering (page 100)".

To install the FactoryTalk Historian Live Data Interface on the data server computer:

1. Run the FactoryTalk Historian SE installation DVD.

2. On the welcome page of the installation wizard, click *Install FactoryTalk Historian SE > Install FactoryTalk Historian Live Data Interface*.

   The installation wizard appears.

   If there are any software prerequisites missing from the computer, they are listed in red at the bottom of the installation wizard *Welcome* page. Click *Cancel* and *Finish* to exit the wizard, install the prerequisites, and start the installation wizard again.

3. On the *Welcome...* page, click *Next*.

4. On the *License Agreement* page, read and accept the terms of the license agreement, selecting the *I accept...* option.

5. Click *Next*.

6. On the *Review Component Installation* page, review the list of the components that are already installed and those that will be installed during the installation process.

   Click *Next*.

7. On the *Destination Drive* page, select the drive on which you want to install the product.

   If the space available on the drive is not sufficient for the installation, a warning message will appear below the
Installation drive list. In such a case, select another drive or increase the available space on the drive you have originally selected.

**NOTE** You can choose the destination drive only if you install the component on the selected machine for the first time. If there have been any FactoryTalk Historian components installed on the machine before, the Installation drive list will not be enabled.

Click Next.

The Installation Progress page appears. It lists the components that are going to be installed. The status of the installation is displayed in the Status column of the component table.

8. Click Install to start the installation.

9. Wait until the components are installed. The installation time will vary depending on the number of components being installed and the computer performance. The installation status is displayed below the component table.

During the installation process, the Release Notes appear. Close the dialog box to proceed with the installation.

If the FactoryTalk Activation Manager has not been installed yet, the wizard for installing USB dongles software appears.

The FactoryTalk Activation Manager installation wizard appears with a list of prerequisite packages.

Click Continue.

10. In the message box that appears:

   • Click Yes, if you want to install the software for Rockwell Automation USB dongles.

      The drivers are used to support mobile activations which are locked in a hardware dongle.

      Follow the on-screen instruction to install the software.

   • Click No, if you want to skip this step.
The installation wizard appears.

11. Follow the instructions displayed on the screen to complete the installation.

12. In the FactoryTalk Directory Server Location Utility dialog box, identify the computer that hosts the FactoryTalk Directory server. If it is the current computer, leave localhost in the text box. Otherwise, do the following to point to the proper FactoryTalk Directory computer:

   1. Click the ellipsis button (…). The Login User dialog box appears.

   2. In the User name and Password text boxes, type the credentials to the current FactoryTalk Directory machine. The FactoryTalk Directory Server Configuration dialog box appears.

   3. Select the Remote computer option and click the ellipsis button (…) to open the Browse for Computer dialog box.

   4. Select the machine that hosts the FactoryTalk Directory and click OK.

      The name of the machine appears in the FactoryTalk Directory Server Location Utility dialog box.

   5. Click OK.

   6. In the message box informing you that you will need to restart the computer, click OK.

   7. In the Log On to FactoryTalk (New Server) dialog box, type the user name and password to the newly selected FactoryTalk Directory machine.

13. Click OK. The system connects to the FactoryTalk Directory server.

14. On the Installation Wizard Completed page, click Show the installation log (page 53), if you want to view the installation log after the installation wizard closes.
If any of the installed components requires rebooting the computer, a relevant message will appear on the installation wizard page, and you will be prompted to restart the machine after the installation wizard closes.

15. Click **Finish** to exit the installation wizard.
16. If prompted, restart the computer.

**Install FactoryTalk Historian Management Tools (Optional)**

The FactoryTalk Historian Management Tools are installed automatically as a part of the FactoryTalk Historian SE installation. This option allows you to install just the Management Tools on a non-FactoryTalk Historian Server computer, typically a FactoryTalk View SE client computer or a remote computer, from which you can perform administrative tasks.

The FactoryTalk Historian Management Tools are installed with the following FactoryTalk Historian components:

- Historian Software Development Kit (PI SDK)
- Historian Interface Configuration Utility (ICU)
- FactoryTalk Historian SE RA Components
- FactoryTalk Activation Manager
- Rockwell MS Runtime Redistributables

**To install the FactoryTalk Historian Management Tools:**

1. Run the FactoryTalk Historian SE installation DVD.
2. On the welcome page of the installation wizard, click *Install FactoryTalk Historian SE > Install FactoryTalk Historian Management Tools*.

The installation wizard appears.

If there are any software prerequisites missing from the computer, they are listed in red at the bottom of the
installation wizard **Welcome** page. Click **Cancel** and **Finish** to exit the wizard, install the prerequisites, and start the installation wizard again.

3. On the **Welcome**... page, click **Next**.

4. On the **License Agreement** page, read and accept the terms of the license agreement, selecting the **I accept**... option. Click **Next**.

5. On the **Review Component Installation** page, review the list of the components that are already installed and those that will be installed during the installation process. Click **Next**.

6. On the **Destination Drive** page, select the drive on which you want to install the product.

   If the space available on the drive is not sufficient for the installation, a warning message will appear below the **Installation drive** list. In such a case, select another drive or increase the available space on the drive you have originally selected.

   **NOTE** You can choose the destination drive only if you install the component on the selected machine for the first time. If there have been any FactoryTalk Historian components installed on the machine before, the **Installation drive** list will not be enabled. Click **Next**.

   The **Installation Progress** page appears. It lists the components that are going to be installed. The status of the installation is displayed in the **Status** column of the component table.

7. Click **Install** to start the installation.

8. Wait until the components are installed. The installation time will vary depending on the number of components being installed and the computer performance. The installation status is displayed below the component table.
During the installation process, the *Release Notes* appear. Close the dialog box to proceed with the installation.

If the FactoryTalk Activation Manager has not been installed yet, the wizard for installing USB dongles software appears. The FactoryTalk Activation Manager installation wizard appears with a list of prerequisite packages.

Click *Continue*.

9. In the message box that appears:

- Click *Yes*, if you want to install the software for Rockwell Automation USB dongles.
  
  The drivers are used to support mobile activations which are locked in a hardware dongle.
  
  Follow the on-screen instruction to install the software.

- Click *No*, if you want to skip this step.

The installation wizard appears.

10. Follow the instructions displayed on the screen to complete the installation.

11. In the **FactoryTalk Directory Server Location Utility** dialog box, identify the computer that hosts the FactoryTalk Directory server. If it is the current computer, leave *localhost* in the text box. Otherwise, do the following to point to the proper FactoryTalk Directory computer:

   1. Click the ellipsis button (●). The **Login User** dialog box appears.

   2. In the **User name** and **Password** text boxes, type the credentials to the current FactoryTalk Directory machine.

   The **FactoryTalk Directory Server Configuration** dialog box appears.

   3. Select the **Remote computer** option and click the ellipsis button (●) to open the **Browse for Computer** dialog box.
4. Select the machine that hosts the FactoryTalk Directory and click **OK**.

   The name of the machine appears in the **FactoryTalk Directory Server Location Utility** dialog box.

5. Click **OK**.

6. In the message box informing you that you will need to restart the computer, click **OK**.

7. In the **Log On to FactoryTalk (New Server)** dialog box, type the user name and password to the newly selected FactoryTalk Directory machine.

12. Click **OK**. The system connects to the FactoryTalk Directory server.

13. On the **Installation Wizard Completed** page, click **Show the installation log** (page 53), if you want to view the installation log after the installation wizard closes.

   If any of the installed components requires rebooting the computer, a relevant message will appear on the installation wizard page, and you will be prompted to restart the machine after the installation wizard closes.

14. Click **Finish** to exit the installation wizard.

15. If prompted, restart the computer.

---

**Install Advanced Server (Optional)**

Advanced Server is a collection of add-on components to FactoryTalk Historian SE Server. The Advanced Server includes:

- ACE Advanced Computation Engine for Visual Basic calculations on Historian data
- Data Access
  - JDBC Data Provider
  - ODBC
  - OLE DB Provider
Installing FactoryTalk Historian

Chapter 4

- OPC DA Server
- OPC HDA Server
- OPC HDA DA Server
- WebServices
- Notifications for using Microsoft Lync Unified Communication Server

New users may activate the Advanced Server components with the \textit{FTHSE.Advanced} license activation.

For the users upgrading their license activations from FactoryTalk Historian SE 2.2/2.1, the Advanced Server components are activated automatically when the total license count of the \textit{FHL} and \textit{PTY3} license activations is at least 250.

**To install the Advanced Server components:**

1. Open the FactoryTalk Historian SE installation DVD.
2. Go to the \textit{Redist\Advanced Server Options} folder.
3. Choose the components you want to install.
4. Follow the on-screen instructions to complete the process.

**To activate the Advanced Server components:**

- See "Activating FactoryTalk Historian SE Server (page 61)" to learn about the activation process.
- See "Types of Licenses (page 78)" to learn about the license activation.
Install FactoryTalk VantagePoint (Optional)

The data from multiple FactoryTalk Historian SE servers and FactoryTalk Historian ME servers can be brought together into a single information management and decision support system using FactoryTalk VantagePoint.

For detailed instructions on installing FactoryTalk VantagePoint and its components, refer to the FactoryTalk VantagePoint documentation.

Install Additional Historian Components

The FactoryTalk Historian SE DVD contains several optional Historian components used for data management, such as FactoryTalk Historian DataLink or PerfMon Health Monitor. These components are located in the Redist folder on the installation DVD.

If you choose to install these components, be sure to install them after you install FactoryTalk Historian SE. For further information regarding these components, refer to the FactoryTalk Historian SE documentation, available in the Redist\Docs folder on the FactoryTalk Historian SE installation DVD.
Chapter 5

Post-Installation Tasks

In this chapter you will learn about the following tasks that you should perform after installing FactoryTalk Historian SE:

- View the Historian server installation log file. (page 53)
- Verify that Historian services are running. (page 53)
- Verify that Historian server is updating data for default tags. (page 54)
- Add the AF Service computer to the AFServer group. (page 55)
- Manually create the Asset Framework database. (page 56)
- Manually configure the Asset Framework service. (page 58)
- Perform the MDB to AF synchronization. (page 59)
- Verify the MDB to AF synchronization. (page 59)
- Disable virus scanning. (page 60)

View the Installation Log File

You can open the installation log, `fth_installer.log`, directly from the installation wizard. If you want to refer to it later, open it from the following location:

```
C:\Program Files\Rockwell Software\FactoryTalk Historian\Installation Manager\<Name of the Historian suite>\FTHInstallerLogs\<Date and Time of the Installation>.
```

Verify that Historian Services are Running

Use Historian Services in System Management Tools to view, configure, start and stop Historian services for each connected Historian server. The status of each service is updated every 30 seconds by default. You may change this refresh rate. You can also
view the status, errors, and thread details for services used by the connected Historian server, and export a list of Historian services.

To open Historian services:


2. Under Collectives and Servers, select the server for which you want to view the information.


4. Verify that the following Historian services and default interfaces are running:
   - Archive Subsystem
   - Backup Subsystem
   - Base Subsystem
   - License Manager
   - Network Manager
   - Ramp Soak Simulator (rmp_sk) Interface
   - Random Simulator (random) Interface
   - Snapshot Subsystem
   - SQL Subsystem
   - Update Manager

Depending on your license, you might see additional services.
Verify that the Historian Server is Updating Data for Default Tags

To verify that the Historian server is updating data for default tags:

1. On the computer with the Historian server installed, go to Start > All Programs > Rockwell Software > FactoryTalk Historian SE > System Management Tools. The System Management Tools dialog box appears.

2. Under Collectives and Servers, select the Historian server whose data you want to view.

3. Under System Management Tools, select Data > Archive Editor.

4. In the (Tag Not Specified) tab, click The Tag Search dialog box appears.

5. In the Tag Mask text box, type cdt158, and click Search. The cdt158 tag appears in the search results list.

6. Click OK.

The list of events of the selected tag is displayed in the tab in the right pane of the System Management Tools dialog box.

NOTE For more information on the Archive Editor, click .

Add the AF Service Computer to the AFServer Group

NOTE This procedure applies if you have selected either of the following installation modes of FactoryTalk Historian Asset Framework:

- AF SQL Database.
- AF SQL Database with unprocessed database scripts.

See "Installation Modes for FactoryTalk Historian Asset Framework (page 34)” for information on the installation modes.
To add the computer with the AF service installed to the AFServer group:


2. In the explorer tree, select System Tools > Local Users and Groups > Groups.

3. In the right pane, right-click the AFServers group, and select Add to Group.

4. In the AFServers Properties dialog box, click Add.

5. In the Select Users, Computers, Service Accounts, or Groups dialog box, type the name of the machine with the AF service installed in the text box, and click Check Names to verify the name.

6. Click OK to exit the dialog boxes.

**Manually Create the Asset Framework Database**

This procedure applies if you have selected either of the following installation modes of FactoryTalk Historian Asset Framework:
- AF Application Service and AF SQL Database with unprocessed database scripts.
- AF SQL Database with unprocessed database scripts.

See "Installation Modes for FactoryTalk Historian Asset Framework (page 34)" for information on the installation modes.

If you have installed FactoryTalk Historian Asset Framework with unprocessed scripts, you need to create the AF SQL database manually using the scripts. The scripts create the AF SQL database called PIFD and populate its tables.

**NOTE** To execute the scripts, you must have sysadmin privileges on the SQL Server instance.
To manually create the Asset Framework SQL PIFD database:

1. On the computer to which the unprocessed database scripts were copied during the FactoryTalk Historian Asset Framework installation process, open the Command Prompt window and navigate to the following folder in the Program Files directory: Rockwell Software\FactoryTalk Historian\PIPC\AF\SQL.

2. Call the **GO.bat** file with the following parameters, depending on the user authentication method:
   - SQL Server authentication:
     
     ```batch
     GO.bat SQL.Server\SQL.Instance PIFD SQL.ServerLogin SQL.ServerPassword,
     ```
     
     where:
     - **SQL.Server** is the name of the SQL Server machine on which the PIFD database will be installed.
     - **SQL.Instance** is the name of the instance of the SQL Server. This parameter is required if the SQL Server has been installed with an instance name.
     - **SQL.ServerLogin** is the SQL Server user name.
     - **SQL.ServerPassword** is the password of the SQL Server user.
   - Windows authentication:
     
     ```batch
     GO.bat SQL.Server\SQL.Instance PIFD
     ```

3. Press Enter to start the database creation process.

The end of the process is indicated with an underscore at the command prompt.

Once the database is created, you need to configure the Asset Framework service to communicate with the database. See "Manually Configure the Asset Framework Service (page 58)" for more information.
Manually Configure the Asset Framework Service

NOTE Perform the steps described below on each computer with the Asset Framework service installed.

To configure the AF service to communicate with the PIFD SQL database:

1. In Windows Explorer, navigate to the following folder in the Program Files directory: Rockwell Software\FactoryTalk Historian\PIPC\AF.

2. Open the AFService.exe.config file in a text editor.

3. Navigate to the <appSettings> section, and in the add element with the key=connectString attribute update the values of the server attribute:

   server=SQLServer\SQLInstance

For example:

```xml
<configuration>
  <appSettings>
    <add key="connectString" value="Persist Security Info=False;Integrated Security=SSPI;server=\sqlserver\sqlinstance;database=PIFD;Application Name=AP Application Server."/>
  </appSettings>
</configuration>
```

- If the SQL Server is running on a computer cluster, type the IP address of the clustered resource as the SQLServer value.
- If the SQL Server is configured to use the SQL Server database mirroring, add the failover partner attribute after the server attribute with the following values:

  failover partner=SQLServer\SQLInstance

For example:

```xml
<configuration>
  <appSettings>
    <add key="connectString" value="Persist Security Info=False;Integrated Security=SSPI;server=\sqlserver\sqlinstance;database=PIFD;Application Name=AP Application Server.;failover partner=\sqlserver\sqlinstance"/>
  </appSettings>
</configuration>
```
• If you want to enable the encrypted communication between the AF service and the AF SQL database, add the **encrypt=Yes** attribute to the code, for example:

```xml
<?xml version="1.0"?>
<configuration>
  <configSections>
    <appSettings>
      <add key="connectString" value="Persist Security=SSPI;server=\sqlserver\failover partner;Name=AF Application Server;encrypt=Yes" />
    </appSettings>
  </configSections>
</configuration>
```

• If you want to configure other options, refer to the Microsoft SQL Native Client documentation.

4. Save the file.

5. If the Asset Framework service is running, restart it for the changes to take effect:

1. Go to **Start > All Programs > Administrative Tools > Services**.

2. In the **Services** dialog box, right-click **PI AF Server 2.x** and select **Restart**.

---

**Perform the MDB to AF Synchronization**

Once you have the FactoryTalk Historian Asset Framework and the FactoryTalk Historian SE Server installed, you need to set up synchronization between the AF service and the Historian server. This process is called the **MDB to AF transition**. For more information, refer to the **FT Historian SE MDB to AF Transition Guide**.

**Verify the MDB to AF Synchronization**

To verify the MDB to AF synchronization:

1. Click **Start > All Programs > Rockwell Software > FactoryTalk Historian SE > System Management Tools**. The **System Management Tools** dialog box appears.
2. Under **System Management Tools**, select **Operation > MDB to AF Synchronization**.

3. Select the Historian server for which you want to verify the synchronization.
   
   • If the synchronization is operating correctly, a green icon appears next to the name of the server.
   
   • If the synchronization fails, a red icon appears. Click in the **System Management Tools** dialog box for information on how to diagnose and solve the problem.

**Disable Virus Scanning**

Rockwell Automation considers it a good practice to exclude the following directories from anti-virus software scanning:

- On Historian server computers, exclude the **Server\dat** directory and any directory where archive or event queue files are located.

- For Interface nodes, exclude the **pipc\dat** and **pipc\log** directories, as well as the directory where buffer queue files are located.

By excluding these directories you avoid random signature match incidents, potential performance impacts, and conflicts with locked files.

**NOTE**

For more details, see the **FT Historian SE Server Reference Guide**, available in the **Redist\Docs** folder on the FactoryTalk Historian SE installation DVD and in the **Common Files\Rockwell\Help** folder in your **Program Files** directory.
Chapter 6

Configuring FactoryTalk Historian

In this chapter you will find the following information on configuring FactoryTalk Historian SE and its components:

- Activating the Historian server. (page 61)
- Securing the Historian server. (page 62)
- Configuring Windows Firewall for FactoryTalk Historian SE. (page 73)
- Configuring the Historian server. (page 75)
- Configuring the Data server. (page 96)
- Configuring Historian interface connections. (page 97)
- Configuring FactoryTalk Historian Live Data Interface. (page 98)
- Configuring Excel Add-ins for FactoryTalk clients. (page 103)
- Recording messages using FactoryTalk Diagnostics. (page 104)

Activating the Historian Server

You need to activate the FactoryTalk Historian SE server so that it starts collecting data points (tags) from data servers.

You activate the server by obtaining license activation file(s) from the Rockwell Automation licensing website and assigning them to the server using the FactoryTalk Activation Manager.

To activate FactoryTalk Historian SE server:

1. Go to Start > All Programs > Rockwell Software > FactoryTalk Activation > FactoryTalk Activation Manager. The FactoryTalk Activation Manager dialog box appears.
2. Follow the instructions displayed in the wizard to configure your activations.

**NOTE** Click **Help** for more information, or refer to the instructions from the *Activate Rockwell Software Products* leaflet, available with your FactoryTalk Historian SE installation package.

### Securing the Historian Server

FactoryTalk Historian SE allows you to manage the Historian server authentication through Windows and Microsoft Active Directory (AD). This solution improves the Historian server security, reduces your management workload, and provides users with a single sign-on experience.

With Windows authentication for the FactoryTalk Historian SE Server, users log on to their Windows accounts and are automatically authenticated on the Historian server. The Historian server comes with a set of preconfigured security components created to reflect particular roles that may be adopted by users to access the Historian server resources. Each user comes with predefined trusts and is assigned to one or more groups, depending on the scope of privileges they should have. Each group is defined with a different scope of privileges. The users and groups are assigned to individual database tables, creating in this way a system of permissions for accessing the Historian server database resources.

The users are the central components that connect the Windows authentication functionality with the Historian server security model. They determine which Windows users are authenticated on the Historian server and what access permissions they have there (for example, whether the user is allowed to create a point or run a backup).

The connection between the Windows users and/or groups and the Historian server security users is established through mappings. If you want to grant a Windows user or group access to a Historian server resource (such as a point or a module), you need to create on the Historian server mappings between the Windows users and/or
groups and relevant Historian server users or groups. In this way the Window users and/or groups adopt the permissions from the Historian users to which they are mapped. This is the safest, quickest and most convenient way of distributing the Historian server privileges.

You can manage the Historian server security with the System Management Tools.

See the following sections to learn more about the Historian server security model:

- Historian Security Components and Their Privileges (page 63)
- Managing Historian Security Components (page 67)
- Creating Security Mappings (page 69)
- Managing Security of the Historian Server Database (page 71)

The following components constitute the Historian security model:

<table>
<thead>
<tr>
<th>Identities</th>
<th>Users</th>
<th>Groups</th>
</tr>
</thead>
<tbody>
<tr>
<td>PIEngineers</td>
<td>FTHEngineer</td>
<td>FTHEngineers</td>
</tr>
<tr>
<td>PIOperators</td>
<td>FTHOperator</td>
<td>FTHOperators</td>
</tr>
<tr>
<td>PISupervisors</td>
<td>FTHSupervisor</td>
<td>FTHSupervisors</td>
</tr>
<tr>
<td>PIWorld</td>
<td>pidemo</td>
<td>FTHAdministrators</td>
</tr>
<tr>
<td></td>
<td>piadmin</td>
<td>piusers</td>
</tr>
</tbody>
</table>

The descriptions and privileges of the security components are presented in the following tables:

<table>
<thead>
<tr>
<th>Identities</th>
<th>Description and privileges</th>
</tr>
</thead>
<tbody>
<tr>
<td>PIEngineers</td>
<td>A sample identity with engineering duties with no pre-configured settings.</td>
</tr>
<tr>
<td>PIOperators</td>
<td>A sample identity with operational duties with no pre-configured settings.</td>
</tr>
<tr>
<td>Identities</td>
<td>Description and privileges</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>PI Supervisors</td>
<td>A sample identity with supervisory duties with no pre-configured settings.</td>
</tr>
</tbody>
</table>
| PI World     | An identity with preconfigured access permissions to Historian server resources. It represents the "everyone" concept of Windows, and specifies the rights of non-explicit users or groups. All authenticated Historian server users are given at least PI World privileges.  
The **PI World** identity has write access to the following table:  
- PIMSGSS  
The **PI World** identity has read access to the following tables:  
- PIAudit  
- PIBatch  
- PIBatchLegacy  
- PICampaign  
- PIDBSEC  
- PIDS  
- PI Heading Sets  
- PIModules  
- PIPOINT  
- PIReplication  
- PITransferRecords  
- PI USER  
The **PI World** identity does not have access to the following tables:  
- PIAFLINK  
- PIARCDATA  
- PIBACKUP  
- PIMAPPING  
- PITRUST  
- PITuning  
You can or cannot do the following with the **PI World** identity:  
- You can:  
  - Fully disable it.  
- You cannot:  
  - Delete it.
## Identities Description and privileges

- Use it in a mapping.
- Use it in a trust.

## Users Description and privileges

<table>
<thead>
<tr>
<th>Users</th>
<th>Description and privileges</th>
</tr>
</thead>
<tbody>
<tr>
<td>FTHEngineer</td>
<td>A preconfigured user, member of the <strong>FTHEngineers</strong> and <strong>FTHSupervisors</strong> groups.</td>
</tr>
<tr>
<td>FTHOperator</td>
<td>A preconfigured user, member of the <strong>FTHOperators</strong> group.</td>
</tr>
<tr>
<td>FTHSupervisor</td>
<td>A preconfigured user, member of the <strong>FTHSupervisors</strong> group.</td>
</tr>
<tr>
<td>piadmin</td>
<td>A preconfigured administrative PI User with unrestricted access to Historian server resources.</td>
</tr>
</tbody>
</table>

You can or cannot do the following with the **piadmin** user:
- You can disable its properties:
  - To be used in a mapping.
  - To be used in a trust.
  - To be used for an explicit logon.
- You cannot:
  - Delete it.
  - Fully disable it.

You should:
- Map it only to a limited group of administrators.

**Piadmin** is a member of the **FTHEngineers**, **FTHSupervisors**, and **FTHAdministrators** groups.

| pidemo         | A generic PI User, member of the **piusers** group.                                           |
### Groups Description and privileges

<table>
<thead>
<tr>
<th>Groups</th>
<th>Description and privileges</th>
</tr>
</thead>
</table>
| FTHAdministrators | It represents Historian server administrators and has read-and-write access to all Historian server resources and default points, except the following database tables:  
  - PIDS  
  - PIHeadingSets  
  - PIPOINT  
You can or cannot do the following with the **FTHAdministrators** group:  
  - You can:  
    - Map it to the AD group that represents your Historian server system administrators.  
    - Adjust its access permissions to meet your needs.  
    - Fully disable it.  
  - You cannot:  
    - Delete it. |
| FTHEngineers   | A preconfigured group with the following privileges:  
  - Create, modify, and delete point definitions.  
  - Read and write access to the following database tables:  
    - PIDS  
    - PIHeadingSets  
    - PIPOINT |
| FTHOperators   | A preconfigured group with the following privileges:  
  - Read any point definition.  
  - Read any point’s historical data set. |
| FTHSupervisors | A preconfigured group with the following privileges:  
  - Read any point definition.  
  - Read any point’s historical data set.  
When the users belonging to the **FTHSupervisors** group create points in the FactoryTalk Administration Console, they get the following privileges to these points:  
  - Add new point data to any point’s historical data set.  
  - Add, modify, and delete point data. |
<table>
<thead>
<tr>
<th>Groups</th>
<th>Description and privileges</th>
</tr>
</thead>
</table>
| piusers | A generic PI Group formerly named "piuser". This group has no preconfigured access permissions. You can or cannot do the following with the piusers group:  
• You can:  
  • Fully disable it.  
• You cannot:  
  • Delete it. |

Use the System Management Tools to manage the security components and security of your Historian server database.

**NOTE**  
To manage security identities, users, and groups, you need administrative rights to the Historian server.

**Managing Historian Security Components**

**To manage the Historian server security components:**

1. Go to Start > All Programs > Rockwell Software > FactoryTalk Historian SE > System Management Tools.
2. Under Collectives and Servers, click the check box next to the server for which you want to view and manage the security information.

   In the right pane, the **PI Identities**, **PI Users**, and **PI Groups** tabs appear.

   Each tab contains a set of columns with security-related information. To modify the type of information displayed, right-click a column name and add or remove columns from the context menu.
4. Click the tab containing the security component type you want to view and manage.

5. In the selected tab, right-click the security component that you want to view or modify, and select Properties. The Properties dialog box appears.
The content of the dialog box differs depending on the security component type you select.

6. View the settings of the selected security component presented in the tabs.

You can modify the privileges of the security component to the extent that is allowed by the component’s configuration. See "Historian Security Components and Their Privileges (page 63)" for more information.

7. Click OK.

Creating Security Mappings  

To create a security mapping between a Windows user and/or group and a Historian server user:

2. Under **Collectives and Servers**, select the server for which you want to create the mapping.

3. Under **System Management Tools**, select **Security > Mappings & Trusts**.

4. In the **Mappings** tab, click ![Add New Mapping](image). The Add New Mapping dialog box appears.

5. Click ![add](image) next to **Windows Account**. The Select User, Computer, or Group dialog box appears.

6. In the text box, type the name of the user, for which you want to create the mapping.

7. Click **Check Names** to verify the user name, and click **OK**.

8. Click ![add](image) next to **PI Identity**. The Select PI Identity, PI Group, or PI User dialog box appears.

9. From the **Type** drop-down list, select **PI Users**.

10. Select the PI user, to which you want to map the selected Windows user (e.g. `piadmin`), and click **OK**.

11. Click **OK** to apply the changes. The new mapping is listed in the **Mappings** tab.

**To check if a Windows user/group is mapped to a Historian security user:**

1. In the **System Management Tools**, select **File > Connections**. The Connection Manager appears.

2. Select the server and view its **Connected User** information. The information contains the domain name, the Windows user/group name, and the name of the Historian security user, to which the Windows user/group is mapped. It also lists other Historian server security components, whose privileges the Windows user/group shares via the Historian security user.
Managing Security of the Historian Server Database

To view and manage security privileges of the Historian server database:

2. Under Collectives and Servers, select the server for which you want to manage security.
   In the right pane of the dialog box, a list of individual database tables is displayed.
   The Security column contains a summary of security-related information: a list of the security components (identities, users, and/or groups) assigned to the database table, and their rights displayed in brackets.

NOTE To manage security of the Historian server database, you need administrative rights to the Historian server.
To modify the type of information displayed, right-click a column name and add or remove columns from the context menu.

4. Right-click the name of the database table for which you want to manage the security information, and select Properties. The Security for... dialog box appears.
5. Click a security component to check its privileges in the Permissions for... list.

You can modify the privileges of the component for the database table to the extent that is allowed by the component’s configuration. See “Historian Security Components and Their Privileges (page 63)” for more information.

6. Click OK.

### Configuring Firewall for FactoryTalk Historian

If you use Microsoft Windows Firewall on the computers on which you have installed FactoryTalk Historian SE, the firewall configuration is performed automatically during the installation of individual FactoryTalk Historian components, using the Rockwell Firewall Configuration Utility (WFCU).

If you use another utility, you need to configure the firewall manually following the steps presented below. Refer to the user documentation of your firewall configuration utility for more information.

**NOTE** You need administrator privileges to perform the steps described below.

**To manually configure the firewall:**

- Open TCP/IP ports in the firewall to accept incoming connections:

  See the table below to learn which ports need to be open for individual FactoryTalk Historian suites.

<table>
<thead>
<tr>
<th>For this FactoryTalk Historian suite:</th>
<th>Open these ports:</th>
<th>Of this type:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Historian to Historian Interface</td>
<td>5450</td>
<td>TCP</td>
</tr>
<tr>
<td>Asset Framework</td>
<td>5457, 5459</td>
<td>TCP</td>
</tr>
</tbody>
</table>
### For this FactoryTalk Historian suite:

<table>
<thead>
<tr>
<th></th>
<th>Open these ports:</th>
<th>Of this type:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Historian Server</td>
<td>5450</td>
<td>TCP</td>
</tr>
<tr>
<td></td>
<td>5454</td>
<td>TCP</td>
</tr>
<tr>
<td></td>
<td>5455</td>
<td>TCP</td>
</tr>
<tr>
<td></td>
<td>5456</td>
<td>TCP</td>
</tr>
<tr>
<td></td>
<td>5458</td>
<td>TCP</td>
</tr>
<tr>
<td>Live Data Interface</td>
<td>6000</td>
<td>TCP</td>
</tr>
</tbody>
</table>

- Allow FactoryTalk Historian Live Data Interface to communicate through the firewall:

See the table below to learn which settings you need to use when configuring the firewall.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>The absolute path to the Live Data interface</td>
<td><code>&lt;PIHOME_Value&gt;\Interfaces\LDInterface\FTLDInt.exe</code>, where <code>&lt;PIHOME_Value&gt;</code> is the path specified in the following registry key: Computer &gt; HKEY_LOCAL_MACHINE &gt; Software &gt; Wow6432Node &gt; PISystem</td>
</tr>
<tr>
<td>The name (ID) of the Live Data interface</td>
<td>PIUniint Interface to the PI System.</td>
</tr>
<tr>
<td>Network location types</td>
<td>Private and public.</td>
</tr>
</tbody>
</table>

**To check the location of the Live Data interface:**

1. Open the Windows Registry Editor.
2. Go to `Computer > HKEY_LOCAL_MACHINE > Software > Wow6432Node > PISystem`.
3. Double-click the `PIHOME` value and copy the path from the value data text box.

The complete path to the Live Data Interface will consist of the following parts:

- The path you get from the registry.
- \`\Interfaces\LDInterface\FTLDInt.exe`
Example: If the PIHOME value points to the following location:

C:\Program Files (x86)\Rockwell Software\FactoryTalk Historian\PIPC\

The complete path to the Live Data interface would be:

C:\Program Files (x86)\Rockwell Software\FactoryTalk Historian\PIPC\Interfaces\LDInterface\FTLDInt.exe

NOTE
For more information on firewall configuration, refer to the documentation of your firewall.

In the following sections you will learn how to configure and use FactoryTalk Historian SE Server.

Once the FactoryTalk Historian SE server is installed and running, add it to the FactoryTalk Directory.

To add the FactoryTalk Historian SE server to the FactoryTalk Directory:

1. Go to Start > All Programs > Rockwell Software > FactoryTalk Administration Console.
2. In the Select FactoryTalk Directory dialog box, select Network, and click OK.
3. In the Explorer tree, expand System > Connections.
4. Right-click Historical Data and select New Historian Server Connection.
5. In the New Historian Server Connection dialog box, select the name of your FactoryTalk Historian SE server from the Server or Collective name drop-down list, and click Test Server Connection.
• If the connection is successful, the **Server found** message appears next to the **Test Server Connection** button.

• If the connection is not successful, the **No server found** message appears next to the **Test Server Connection** button. In such a case, check the status of your server in the Connection Manager.

6. Click **Finish**. The new server connection with the default Live Data interface instance *FTLD1* appears under the **Historical Data** folder.

![Connections Diagram](image)

The local interface is now configured to start collecting data points from any data servers that are available to the FactoryTalk Historian SE server.

For more information on the FactoryTalk Historian Live Data Interface, see "Configuring FactoryTalk Historian Live Data Interface (page 98)."

If you want to verify if the FTLD interface is properly configured, see "Verifying the FactoryTalk Historian Live Data Local Interface (page 77)."

---

**IMPORTANT**

You can use the local interface for data collection. However, we strongly recommend that you create a remote interface on the computer that has the data server installed. Buffering, which ensures that the loss of data does not occur, can only be enabled on a remote interface. To learn more about buffering, see "Enable Buffering (page 100)."
Verifying the FactoryTalk Historian Live Data Local Interface

To verify that the local interface is configured:

1. Go to Start > All Programs > Rockwell Software > FactoryTalk Administration Console. The FactoryTalk Administration Console appears.

2. In the Select FactoryTalk Directory dialog box, select Network, and click OK.

3. In the Explorer tree, expand System > Connections > Historical Data, and the FactoryTalk Historian SE server node.

4. Right-click FTLD1, and select Properties. The Data Collection Interface Properties dialog box appears.

5. Go to the General tab, and verify in the Service Status section that the Startup Type is set to Automatic.

6. To start the data collection service, click Start and wait until the service status changes to Started. For more information, click the help icon in the dialog box.

7. Click OK to close the dialog box.

Managing Licenses

Once you have your activations, you can assign them to your Historian server, and allocate tag counts to selected interface types (or point sources).

See the following topics for more information:

- Types of Licenses (page 78)
- Using the General License Pool (page 80)
- Assigning License Activations to FactoryTalk Historian SE Server (page 85)
- Allocating Licenses to Interface Types (page 86)
- Viewing Allocated Licenses (page 88)
Types of Licenses

The license activations you get for your Historian server are various types of licenses that you can use in either of the following pools of licenses:

- **Rockwell**
  Groups license activations for Rockwell sources only.

- **General**
  Groups license activations for tags from both Rockwell and third-party devices.

You may use the following license activations with your FactoryTalk Historian:

<table>
<thead>
<tr>
<th>Type of license activation</th>
<th>Point sources</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FHSE.XXX</td>
<td>FTLD</td>
<td>FactoryTalk Live Data connector interfaces.</td>
</tr>
<tr>
<td></td>
<td>FTMS</td>
<td>Points transferred from a FactoryTalk Historian ME module.</td>
</tr>
<tr>
<td>FHSE.H2H</td>
<td>FHSS</td>
<td>FactoryTalk Server to Server interfaces. The license sets the number of points from the FHSS interface to unlimited.</td>
</tr>
</tbody>
</table>
## Configuring FactoryTalk Historian

### Chapter 6

<table>
<thead>
<tr>
<th>Type of license activation</th>
<th>Point sources</th>
<th>Description</th>
</tr>
</thead>
</table>
| FTHSE.Advanced             | not applicable| Activates the following Advanced Server components for the standard FactoryTalk Historian SE server:  
  - ACE Advanced Computation Engine for Visual Basic calculations on Historian data  
  - Data Access  
  - JDBC Data Provider  
  - ODBC  
  - OLE DB Provider  
  - OPC DA Server  
  - OPC HDA Server  
  - OPC HDA DA Server  
  - WebServices  
  - Notifications for using Microsoft Lync Unified Communication Server  
  **Note:** For the users upgrading their license activations from FactoryTalk Historian SE 2.2/2.1, the Advanced Server components are activated automatically when the total license count of the FHLD and PTY3 license activations is at least 250. |

<table>
<thead>
<tr>
<th>FTBAInt.XXX</th>
<th>FTBOINT</th>
<th>FactoryTalk Batch Interface. The license sets the number of points from the FTBOINT AND PIFTBOINT interfaces to unlimited.</th>
</tr>
</thead>
<tbody>
<tr>
<td>FHSE3ADD.XXX</td>
<td>Third-party and Rockwell point sources.</td>
<td>See &quot;Using the General License Pool (page 80)&quot; for details.</td>
</tr>
</tbody>
</table>

The names of the license activations have the following structure: `<Type>.<Quantity>`, and contain the following information:

- **<Type>**
  
  The type of the license activation.

- **<Quantity>**
The maximum number of individual licenses that can be allocated to an interface type (or point source). Each license corresponds to a single point with which the server can collect data from the interface.

For example, for the \textit{FTHSE} license activation, the quantity ranges from 250 to 100K points.

- For some types of license activations, instead of the \texttt{<Quantity>} part there is a combination of digits and/or characters that further describe the activation, e.g. \texttt{FTHSE.H2H}, \texttt{FTBAInt.1}.

Each license activation contains a number of individual licenses. The system distributes the licenses between the Rockwell and General license pools, depending on the type of license activations you have. When you allocate licenses to interface types (or point sources), you take the licenses from either of the license pools.

**To use the licenses:**

1. Learn how FactoryTalk Historian distributes individual licenses between the license pools. (page 80)

2. Assign the license activations to your Historian server (page 85).

3. Allocate the individual licenses to interface types (or point sources) (page 86).

**How Licenses Are Distributed Between License Pools**

When you acquire license activations for your FactoryTalk Historian and assign them to your Historian server, the system automatically distributes individual licenses from the license activations between the General and Rockwell license pools.
The system takes into account the following license activations to calculate the volume of the individual license pools:

- FHSE3ADD
- FHSE
- FHLD
- PTY3

If you want to calculate how licenses from your license activations will be distributed between the license pools, follow the steps described below.

**To calculate the distribution of licenses between the General and Rockwell license pools:**

1. Calculate the \(<\text{BaseLicenseCount}>\) value.

   It is an intermediate value that will be used to calculate your number of licenses of the General pool.

   - If you use FHSE3ADD license activations, take the number of your FHSE license activations and substitute it into the following equation:
     \[ <\text{BaseLicenseCount}> = 20\% \times \sum <\text{FHSE licenses}> \]

     See "Distributing Licenses with FHSE3ADD Activation (page 82)" for details.

   - If you do not use FHSE3ADD license activations, take the number of your FHSE license activations and substitute it into the following equation:
     \[ <\text{BaseLicenseCount}> = \max (\min (1000, \sum <\text{FHSE licenses}>), 20\% \times \sum <\text{FHSE licenses}> ) \]

     See "Distributing Licenses without FHSE3ADD Activation (page 83)" for details.
2. Calculate the number of licenses for the Rockwell license pool.

Take the number of your FHLD licenses, FHSE licenses, and the \(<\text{BaseLicenseCount}>\) value, and then substitute them into the following equation:

\[ <\text{RockwellLicensePool}> = \sum <\text{FHLD licenses}> + \sum <\text{FHSE licenses}> - <\text{BaseLicenseCount}> \]

3. Calculate the number of licenses for the General license pool.

Take the number of your PTY3 licenses, the FHSE3ADD licenses, and the \(<\text{BaseLicenseCount}>\) value, and then substitute them into the following equation:

\[ <\text{GeneralLicensePool}> = \sum <\text{PTY3 licenses}> + <\text{BaseLicenseCount}> + \sum <\text{FHSE3ADD licenses}> \]

In the following example we will calculate how licenses will be distributed between the General and Rockwell license pools with FHSE3ADD license activations.

We will use the following values:

<table>
<thead>
<tr>
<th>Activation</th>
<th>Value</th>
<th>( \Sigma )</th>
</tr>
</thead>
<tbody>
<tr>
<td>FHSE.2K</td>
<td>2000</td>
<td>12000</td>
</tr>
<tr>
<td>FHSE.10K</td>
<td>10000</td>
<td></td>
</tr>
<tr>
<td>FHSE3ADD.2K</td>
<td>0</td>
<td>2000</td>
</tr>
<tr>
<td>FHL.5K</td>
<td>5000</td>
<td>5000</td>
</tr>
<tr>
<td>PTY3.500</td>
<td>500</td>
<td>500</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td><strong>19500</strong></td>
</tr>
</tbody>
</table>

To distribute licenses between the license pools:

1. Calculate the \(<\text{BaseLicenseCount}>\) value.

\[ <\text{BaseLicenseCount}> = 20\% \times \sum <\text{FHSE licenses}> \]

\[ <\text{BaseLicenseCount}> = 20\% \times 12000 \]

\[ <\text{BaseLicenseCount}> = 2400 \]
2. Calculate the number of licenses for the Rockwell license pool.

\[ \text{<RockwellLicensePool> = } \sum \text{<FHLD licenses> + } \sum \text{<FHSE licenses>} - \text{<BaseLicenseCount>} \]

\[ \text{<RockwellLicensePool> = 5000 + 12000 - 2400} \]

\[ \text{<RockwellLicensePool> = 14600} \]

3. Calculate the number of licenses for the General license pool.

\[ \text{<GeneralLicensePool> = } \sum \text{<PTY3 licenses>} + \text{<BaseLicenseCount>} + \sum \text{<FHSE3ADD licenses>} \]

\[ \text{<GeneralLicensePool> = 500 + 2400 + 2000} \]

\[ \text{<GeneralLicensePool> = 4900} \]

In this example, the total of 19500 licenses has been distributed in the following way:

<table>
<thead>
<tr>
<th>Licenses and license pools</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>License total</td>
<td>19500</td>
</tr>
<tr>
<td>Rockwell license pool</td>
<td>14600</td>
</tr>
<tr>
<td>General license pool</td>
<td>4900</td>
</tr>
</tbody>
</table>

Distributing Licenses without FHSE3ADD Activation

In the following example we will calculate how licenses will be distributed between the General and Rockwell license pools without FHSE3ADD license activations.

We will use the following values:

<table>
<thead>
<tr>
<th>Activation</th>
<th>Value</th>
<th>( \Sigma )</th>
</tr>
</thead>
<tbody>
<tr>
<td>FHSE.2K</td>
<td>2000</td>
<td>12000</td>
</tr>
<tr>
<td>FHSE.10K</td>
<td>10000</td>
<td></td>
</tr>
<tr>
<td>FHSE3ADD.2K</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

\(<BaseLicenseCount> = 2400\)
### Activation Value

<table>
<thead>
<tr>
<th>Activation</th>
<th>Value</th>
<th>Σ</th>
</tr>
</thead>
<tbody>
<tr>
<td>FHLD.5K</td>
<td>5000</td>
<td>5000</td>
</tr>
<tr>
<td>PTY3.500</td>
<td>500</td>
<td>500</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td>17500</td>
</tr>
</tbody>
</table>

To distribute licenses between the license pools:

1. Calculate the `<BaseLicenseCount>` value.

   \[
   <\text{BaseLicenseCount}> = \max (\min (1000, \sum <\text{FHSE licenses}>), \ 0.2 \times \sum <\text{FHSE licenses}>)
   \]

   \[
   <\text{BaseLicenseCount}> = \max (\min (1000, 12000), 2400)
   \]

   \[
   <\text{BaseLicenseCount}> = \max (1000, 2400)
   \]

   \[
   <\text{BaseLicenseCount}> = 2400
   \]

2. Calculate the number of licenses for the Rockwell license pool.

   \[
   <\text{RockwellLicensePool}> = \sum <\text{FHLD licenses}> + \sum <\text{FHSE licenses}> - <\text{BaseLicenseCount}>
   \]

   \[
   <\text{RockwellLicensePool}> = 5000 + 12000 - 2400
   \]

   \[
   <\text{RockwellLicensePool}> = 14600
   \]

3. Calculate the number of licenses for the General license pool.

   \[
   <\text{GeneralLicensePool}> = \sum <\text{PTY3 licenses}> + <\text{BaseLicenseCount}> + \sum <\text{FHSE3ADD licenses}>
   \]

   \[
   <\text{GeneralLicensePool}> = 500 + 2400 + 0
   \]

   \[
   <\text{GeneralLicensePool}> = 2900
   \]
In this example, the total of 17500 licenses has been distributed in the following way:

<table>
<thead>
<tr>
<th>Licenses and license pools</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>License total</td>
<td>17500</td>
</tr>
<tr>
<td>Rockwell license pool</td>
<td>14600</td>
</tr>
<tr>
<td>General license pool</td>
<td>2900</td>
</tr>
</tbody>
</table>

**Assigning License Activations to the Historian Server**

In order to assign the activations to a FactoryTalk Historian SE server, the server must be added to the FactoryTalk Directory. See “Adding the Server to the FactoryTalk Directory (page 75)” for more information.

To assign the license activations to the server:

1. Go to Start > All Programs > Rockwell Software > FactoryTalk Administration Console.
2. In the Select FactoryTalk Directory dialog box, select Network and click OK.
3. In the Explorer tree, expand System > Connections > Historical Data.
4. Right-click the name of the server to which you want to assign the license activations, and click Properties.
5. In the Historian Server Connection Properties dialog box, click the Licensing tab. The table in the tab lists the types and number of activations available for the selected server.
6. To assign a license activation to the server, type a number in the Assigned column for the selected license activation. The number shows how many licenses of the selected type will be assigned to the server.
7. Click **Apply**.

**Allocating Licenses to Interface Types**

By allocating a license to an interface type (or point source), you specify the maximum number of points with which the server will collect data from a given interface type (or point source).

To allocate licenses to interface types:

1. In the **Historian Server Connection Properties** dialog box, click the **Point Sources** tab.

The tab contains two tables that display the following information:

<table>
<thead>
<tr>
<th>Item name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interface Type</td>
<td>Pools of licenses (Rockwell and General) assigned to the server.</td>
</tr>
<tr>
<td></td>
<td>This information cannot be edited.</td>
</tr>
<tr>
<td>Interface Type Allocation</td>
<td>Abbreviated names of interface types (or point sources) to which you can allocate licenses from the license pools. The FTLD interface type is the default type and it cannot be edited.</td>
</tr>
<tr>
<td>Points in Use</td>
<td>The number of points already configured for collecting data from a given interface type. This information is updated automatically and cannot be edited.</td>
</tr>
</tbody>
</table>
### Item name  Description

| Limit   | The maximum number of licenses that is allocated to a license pool or an interface type.  
|---|---|
| For the license pools, the limits are collected from the license activations. This information cannot be edited.  
| For the FTLD interface type, the limit equals the total number of unallocated licenses from both Rockwell and General license pools. This information is updated automatically and cannot be edited.  |

2. In the **Interface Type Allocation** column, type the abbreviated name of the interface type (or point source) to which you want to allocate a license limit. See Types of Licenses (page 78) for more information on the interface types.

```
<table>
<thead>
<tr>
<th>Production Historian - Historian Server Connection Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
</tr>
<tr>
<td>-----------------</td>
</tr>
<tr>
<td>Interface Type</td>
</tr>
<tr>
<td>Rockwell</td>
</tr>
<tr>
<td>General</td>
</tr>
<tr>
<td>Interface Type Allocation</td>
</tr>
<tr>
<td>FTLD</td>
</tr>
<tr>
<td>FTMS</td>
</tr>
</tbody>
</table>
```

3. In the **Limit** column, type the maximum number of licenses for points that the server will use to collect data from the selected interface type. The number must be a multiple of 50.
Chapter 6 Configuring FactoryTalk Historian

If you type incorrect information in the **Interface Type Allocation** or **Limit** columns, a relevant message will appear. Read the message to learn about the error, for example:

![Manage 3rd Party Licensed Points](image)

**NOTE** For PINotifications, you allocate the maximum number of licenses for individual notifications instead of points. The licenses are taken from the Rockwell pool.

4. Click **Apply**. The license limit of the *FTLD* interface type is updated accordingly:

   ![Production Historian - Historian Server Connection Properties](image)

5. Repeat the steps for other interface types that you want to add.

6. Click **OK**.

7. Restart the FactoryTalk Historian SE server (page 96) for the changes to take effect.

You can view the information on the allocated licenses in System Management Tools (page 88).
Viewing Allocated Licenses

To view the information on the allocated licenses:

1. Go to Start > All Programs > Rockwell Software > FactoryTalk Historian SE > System Management Tools.
2. Under Collectives and Servers, select the server for which you want to view the license information.
4. Click Resources > PointSourcesLimit.<InterfaceTypeName>.

<InterfaceTypeName> is the abbreviated name of the interface type you added to the Point Sources tab when allocating points.

The node contains the following information:

<table>
<thead>
<tr>
<th>Item name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>The description of the license limit assigned to the interface type. (point source).</td>
</tr>
<tr>
<td>Total</td>
<td>The total number of licenses allocated to the interface type.</td>
</tr>
<tr>
<td>Amount Used</td>
<td>The number of points already configured for collecting data from the interface type.</td>
</tr>
<tr>
<td>Amount Left</td>
<td>The number of licenses still available for the interface type.</td>
</tr>
<tr>
<td>Level</td>
<td>The license enforcement level.</td>
</tr>
<tr>
<td>End Time</td>
<td>The license expiration date.</td>
</tr>
</tbody>
</table>
NOTE The numbers provided for PInotifications in **Total, Amount Used**, and **Amount Left** are multiplied by 7 against those set in the FactoryTalk Administration Console. It is because each notification uses 7 points from the Rockwell pool. For example, if you set the limit for PInotifications to 50 in the FactoryTalk Administration Console, the **Total** number of allocated licenses in the System Management Tools will equal 350.

**Configuring Points**

Use the FactoryTalk Administration Console to configure your FactoryTalk Historian SE server to start collecting data points. You can add data points to the server in either of the following ways:

- Adding individual data points manually (page 90).
- Adding multiple data points automatically (page 91).

Once you have added the data points to the server, you can verify if the points are collected by the server correctly. See "Viewing Archive Data (page 94)" for more information.

**Adding Individual Data Points Manually**

To add individual data points to the FactoryTalk Historian SE server:

1. Go to **Start > All Programs > Rockwell Software > FactoryTalk Administration Console**. The **FactoryTalk Administration Console** dialog box appears.
2. In the **Select FactoryTalk Directory** dialog box, choose either **Network** or **Local** directory that you want to use, and click **OK**.
3. In the **Explorer** tree, right-click the application from which you want to collect points, and select **Add Individual**
Historian Points. The Add Historian Points dialog box appears.

4. In the Add points to server list, select the FactoryTalk Historian SE server to which you want to add the points.

5. In the respective lists, select the data collection interface, default scan rate, and tag attributes for new points.

6. Click Browse Tags. The Tag Browser dialog box appears.

7. In the Tag Browser dialog box, select the folder from which you want to collect data points. The data points from the selected folder are displayed in the right pane of the dialog box.

8. Select the data points that you want to add, and click Add Tag(s) to List. The tags appear in the Selected tag(s) list at the bottom of the Tag Browser dialog box.

9. Click OK until you return to the FactoryTalk Administration Console.

Adding Multiple Data Points Automatically

The point discovery wizard is a feature of FactoryTalk Historian SE that guides you through the process of finding data points from selected point sources, such as Linx Enterprise, Linx Classic, other OPC-DA Servers (for example, kepware opc), and HMI/Alarm Servers (for example, FactoryTalk View).

The point discovery wizard uses discovery rules to search for Historian points. Creating the rules is a part of the discovery process. The data points (tags) that match the rules you create are added to the FactoryTalk Historian SE server. The default rules are stored in the following XML file:

C:\ProgramData\Rockwell Automation\FactoryTalk Historian\Auto Discovery and Configuration Rules.xml

The rules that you define are saved in a user-defined XML file. The file is stored in the same location as the file with the default set of rules. The point discovery wizard uses the rules from both files.
However, the rules defined in the user-defined XML file take precedence over the rules defined in the default XML file.

To automatically discover Historian points with the wizard:

1. Go to Start > All Programs > Rockwell Software > FactoryTalk Administration Console. The FactoryTalk Administration Console appears.

2. In the Select FactoryTalk Directory dialog box, choose either Network or Local directory that you want to use, and click OK.

3. In the Explorer tree, right-click the application or area from which you want to search for data points, and select Discover Historian Points. The Discover New Historian Points dialog box appears.

   **NOTE** For more information on the point discovery wizard, click the help icon in the Discover New Historian Points dialog box.

4. In the Add points to server list, select the FactoryTalk Historian SE server to which you want to add the points.

5. In the Using data collection interface list, select the appropriate data collection interface.

6. In the Default scan rate list, select the time interval at which points will be collected.

7. Under Add points from these sources, select the sources from which you want to add the points.

8. Under Start searching from, click the tree at the starting point for the point search. If this is a new server, the root node in the tree is selected by default.

9. Click Edit Discovery Rules to create rules to be used during the discovery process. The FactoryTalk Historian Discovery Rule Editor dialog box appears.

   **NOTE** For more information on the Discovery Rule Editor click the help icon in the dialog box.
10. Select **Enable data type filter** to perform the search using the default discovery rule.

**NOTE** When you check the **Enable data type filter** option, the auto-discovery mechanism will get all attributes that match the name, UDT, and data type rule. When you leave the option cleared, the mechanism will ignore the data type filter and only check the name and UDT rule.

11. Click **Next** to begin discovering points. The **Discovering Historian Points** dialog box displays the progress of point discovery.

   The discovered points are listed in the **Confirm New Historian Points** dialog box.

12. Click **Confirm Points** to accept the search result.

13. In the **New Historian Points Discovery Complete** dialog box, click **Start**. The FactoryTalk Historian SE server starts collecting the discovered points.

14. Click **OK**.

**Viewing Current and Archive Data**

You can view current and archive data using System Management Tools. In this section you will learn how to:

- View current data (page 93).
- View archive data (page 94).

**Viewing Current Data**

To view current data being collected by the FactoryTalk Historian SE server:

1. Go to **Start > All Programs > Rockwell Software > FactoryTalk Historian SE > System Management Tools**. The **System Management Tools** dialog box appears.

2. Under **Collectives and Servers**, select the FactoryTalk Historian SE server whose data you want to view.
3. Under **System Management Tools**, select **Data > Current Values**.

4. From the menu bar, select **Tools > Tag Search**. The **Tag Search** dialog box appears.

5. Use the default settings and click **Search**.

6. From the list of tags that appears in the search results, select the tags you want to view, and click **OK**. The current values of the tags are displayed in the right pane of the **System Management Tools** dialog box.

If you want the server to start updating the values for the tag, right-click it and select **Start Updating Values**.

**Viewing Archive Data**

To view archive data that has been collected by the FactoryTalk Historian SE server:

1. Go to **Start > All Programs > Rockwell Software > FactoryTalk Historian SE > System Management Tools**. The **System Management Tools** dialog box appears.

2. Under **Collectives and Servers**, select the FactoryTalk Historian SE server whose data you want to view.

3. Under **System Management Tools**, select **Data > Archive Editor**.

4. In the (Tag Not Specified) tab, click **Add Tag**. The **Tag Search** dialog box appears.

5. Use the default settings and click **Search**.

6. From the list of tags that appears in the search results, choose one of the tags you have selected in "Adding Individual Data Points Manually (page 90)", and click **OK**.
The list of events of the selected tag is displayed in the tab in the right pane of the **System Management Tools** dialog box.

7. Verify that the system has returned archived values, and close the System Management Tools.

### Archiving and Backups

After you have installed and verified the Historian server, configure your Historian server automatic daily backups. You must specifically schedule a backup task on the Historian server.

Historian Archive files store the historical record of process data maintained by the Historian server. By default, the Historian server setup program creates three archive files. Make sure that the location of the archive directory contains enough free space for these files.

The default archive file size of 256 MB might be too small for most systems. Rockwell Automation recommends that you change the default size based on the number of Historian Points, according to the recommendations in the *Introduction to Historian SE Server System Management* guide.

The complete user documentation on FactoryTalk Historian SE is available in the `Common Files\Rockwell\Help` folder in your `Program Files` directory, and in the `Redist\Docs` folder on your FactoryTalk Historian SE installation DVD.

The location for archives is typically on the largest drive on the server. Rockwell Automation recommends that you change the name of the archive directory from the default `Server\dat` to a more meaningful name, such as `\arc`.

Use the Windows File System Compression feature with caution; it might slow down the access of the Historian server to archive files. The compression can save disk space, but it requires more CPU resources.
Restarting FactoryTalk Historian SE Server

NOTE You need administrative rights to perform these steps.

To restart the server:

1. Stop the server:
   1. Go to Start > All Programs > Rockwell Software > FactoryTalk Historian SE > Stop FactoryTalk Historian SE.
      The server stopping process begins. The progress is displayed in the Command Prompt window.
   2. Wait until the server is stopped and the Command Prompt window is closed.

2. Start the server:
   1. Go to Start > All Programs > Rockwell Software > FactoryTalk Historian SE > Start FactoryTalk Historian SE.
      The server starting process begins. The progress is displayed in the Command Prompt window.
   2. Wait until the server is started and the Command Prompt window is closed.

Configuring the Data Server

Use the FactoryTalk Administration Console to configure the data server by adding new applications, areas, data server instances, and shortcuts to controllers.

To open FactoryTalk Administration Console:

1. Go to Start > All Programs > Rockwell Software > FactoryTalk Administration Console. The FactoryTalk Administration Console dialog box appears.
Under **Explorer**, the tree of the FactoryTalk Directory you have selected using the FactoryTalk Directory Server Location Utility (page 28) is displayed.

2. From the menu bar, select **Help > Contents** to open *FactoryTalk Help* and learn more about configuring the data server.

### Configuring Historian Interface Connections

**NOTE** Refer to the information on configuring Historian interface connections in the *Configuring FT Historian SE Security* guide for details associated with the following procedure.

To configure your Historian server to provide access for Historian Interfaces:

1. Identify all the Historian Interfaces that need access to the Historian server.

2. Consult the documentation for each interface and gather the information you need to configure the trust. You need to know the connection type. The type of connection determines what information you can use to define the trust. You also need to specify at least one of the following:
   - The correct application name to define the trust.
   - IP information for the connecting computer.

3. Decide how many trusts you will create. You can create explicit individual trusts for each Historian interface, or you can group them by subnet, host machine, or user name. A group of Historian interfaces can share the same privileges.

4. For each trust, create a PI identity.

5. Give that PI identity all the access permissions required by the trust.

6. Create a trust based on that PI identity.
The interface collects data points (tags) from the data server and passes them to the FactoryTalk Historian SE server. Install the FactoryTalk Historian Live Data Interface component on the same computer as the data server. After installing the interface, configure the buffering service on the data server computer. The buffering service stores data in its memory so that in the event the interface is not able to communicate with the FactoryTalk Historian SE server, the data will not be lost.

When you create a Historian server connection in the FactoryTalk Administration Console (page 75), a default Live Data Interface instance FTLD1 is created and registered.

To register another instance of the FactoryTalk Historian Live Data Interface:

1. On the computer with the FactoryTalk Historian SE server installed, go to Start > All Programs > Rockwell Software > FactoryTalk Administration Console.
2. In the Select FactoryTalk Directory dialog box, click Network.
3. In the Explorer tree of the FactoryTalk Administration Console dialog box, go to System > Connections > Historical Data, right-click the FactoryTalk Historian server connection name, and select New Data Collection Interface. The Data Collection Interface Properties dialog box appears.
4. In the Computer hosting the interface drop-down list, select the name of the computer on which you have installed the data server and the FactoryTalk Historian Live Data Interface.
5. From the Startup Type drop-down list, choose Automatic.
6. Click Apply.
7. Click **Start** to start the data collection service. Wait until the service status changes to **Started**.

8. Click **OK**.

The new Live Data Interface instance is added to the server connection branch.

**Live Data Interface Services**

For each instance of the FactoryTalk Historian Live Data Interface, a service (FTLD) is created and started when you start the interface. You define the service startup type (page 98) in the **Data Collection Interface Properties** dialog box in the FactoryTalk Administration Console.

To view the status of the services, open the **Services** dialog box (*Start > All Programs > Administrative Tools > Services*).
The services are removed when you delete the interface instances in FactoryTalk Administration Console.

**Enable Buffering**

*NOTE* If you want to take advantage of the buffering feature, Rockwell Automation recommends that you install the FactoryTalk Historian Live Data Interface on a remote computer, typically the computer where the data server is installed.

The buffering subsystem stores time-series values to memory when the remote interface computer cannot communicate with the FactoryTalk Historian SE server.

*NOTE* FactoryTalk Historian SE supports the PI Buffer Subsystem only. It does not support the API Buffer Subsystem.

To enable buffering on the computer with the FactoryTalk Historian Live Data Interface installed:

1. Go to **Start > All Programs > Rockwell Software > FactoryTalk Historian SE System Management Tools**. The **System Management Tools** dialog box appears.
2. From the menu bar, select **File > Connections**. The **Connection Manager** dialog box appears.
3. Select the FactoryTalk Historian SE server to which you want to connect.

If the server name is not listed, do the following:

1. From the menu bar, select **Server > Add Server**. The **Add Server** dialog box appears.
2. In the **Network Node** text box, type the fully qualified domain name (FQDN) of the server.
3. Clear the **Confirm** check box, and click **OK**. The new server is added to the server list.

This allows a remote client connection to be established with the FactoryTalk Historian SE server.
4. Close the Connection Manager.


5. Verify that PIBuffSubSystemService is listed in the Trusts tab.


8. From the Interface list, select the name of the FactoryTalk Historian Live Data Interface.

9. From the menu bar, select Tools > Buffering. The Buffering dialog box appears.

10. In the Choose Buffer Type pane, select the Enable buffering with PI Buffer Subsystem option.

11. Click Yes in the confirmation message box that appears. Wait until the status box at the bottom of the Buffering dialog box displays Current Configuration: Good.

NOTE
If you delete an interface and recreate the interface (with the same ID) on another computer, you will get errors unless you restart the computer on which the deleted interface was located. Restarting the computer ensures the restarting of the buffering subsystem.
As a general rule, you must always disable buffering on the interface before you delete it. If you forget to disable buffering, you will have to restart the computer to make sure the buffering subsystem is restarted.

12. Select **Buffered Servers** in the left pane of the dialog box. From the **Buffering to collective/server** drop-down list, select the name of the computer on which the FactoryTalk Historian Live Data Interface is installed, and click **Yes** in to the confirmation message box.

13. Click **OK** to close the **Buffering** dialog box.

14. From the tree in the **Interface Configuration Utility** dialog box, select **Service**.

15. In the **Dependencies** box, add the **pibufss** service from the **Installed services** list.

![Dependencies Image]

**NOTE**
Add **pibufss** as a dependent service to make sure your interface always starts after the buffering service starts.

**IMPORTANT**
If the interface starts before the buffering subsystem, data will be lost.

16. On the toolbar, click **Restart** to restart the interface.

17. Verify that the status bar at the bottom of the dialog box displays the status **Ready and Running**.

18. Click **Close** to exit the **Interface Configuration Utility** dialog box. The buffering service is now configured.
NOTE
If you want to configure a remote FactoryTalk Historian Live Data Interface to start from a local cache file with or without a valid connection to the host FactoryTalk Historian Server, enable the Disconnected Startup feature. For more information, refer to the KB article 66883 (https://rockwellautomation.custhelp.com/app/answers/detail/a_id/66883).

Manually Enabling Excel Add-ins

To manually enable Excel Add-ins for FactoryTalk Historian DataLink, FactoryTalk Historian Management Tools, and MDB Builder:

1. Start Microsoft Excel.
2. Select Office Button > Excel Options. The Excel Options dialog box appears.
3. Click Add-Ins.
4. At the bottom of the page, click Go. The Add-Ins dialog box appears.
5. Click Browse. The Browse dialog box appears.
6. Navigate to and select the following files:
   - for FactoryTalk Historian DataLink:
     ...\Program Files (x86)\Rockwell Software\FactoryTalk Historian\PIPC\Excel\:
     • PITrendXL.xla
     • pipc32.xll
     • pidldialogs.xla
   - for FactoryTalk Historian Management Tools:
     ...\Program Files (x86)\Rockwell Software\FactoryTalk Historian\PIPC\SMT\:
7. Click OK after selecting each file. The file is added to the Add-Ins available list.

8. Click OK to close the dialog box. The tabs with the selected Excel Add-ins are added to the ribbon.

Recording Messages Using FactoryTalk Diagnostics

FactoryTalk Historian SE uses the FactoryTalk Diagnostics component of the FactoryTalk Services Platform to record messages sent by the FactoryTalk Historian SE server. In the event of a message, the FactoryTalk server logs it in the FactoryTalk Diagnostics service.

If the FactoryTalk Historian SE server cannot connect to the FactoryTalk Diagnostics service, the server will log the messages in the Windows Event log and continue to reconnect to FactoryTalk Diagnostics service. Once the server reconnects to the FactoryTalk Diagnostics service, a message is logged indicating that some messages may not have been logged and will advise you to check the local Windows Event log.

Message Parameters

Each message logged to the FactoryTalk Diagnostics service contains the following information:

<table>
<thead>
<tr>
<th>Item name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date/Time</td>
<td>The date and time the message was recorded. The time is the local time for the server. This is important to note if you are in a different time zone than the server.</td>
</tr>
</tbody>
</table>
### Item name | Description
--- | ---
User Name | The name of the user that performed or requested an operation that generated the error message. **Note:** If you plan to track user IDs in FactoryTalk Diagnostics for auditing purposes, you must create identical user IDs in the FactoryTalk Historian SE. Refer to the *FT Historian SE System Management Guide* for information on creating user IDs in the Historian server.
User Description | The full name of the user.
Severity | All messages are logged as Warning or Informational.
Audience | **Engineer** is the default audience type for all messages.
Message text | A description of the error that occurred.
Location | The name of the computer where the diagnostic message was generated.
Provider | The name of the FactoryTalk product or subsystem that generated the message.

### Viewing Messages

To view the messages in FactoryTalk Diagnostics, run the FactoryTalk Diagnostics Viewer tool. See the *FactoryTalk Diagnostics Viewer Help* for more information.

To view messages stored in the Windows Event log, click **Start > Settings > Control Panel > Administrative Tools > Event Viewer.**
Troubleshooting FactoryTalk Historian

In this chapter you will learn how to:

- Use FactoryTalk Historian ME modules with FactoryTalk Security (page 107).
- Verify the Windows Administrator privileges (page 108).
- Resolve error and warning messages (page 109).

If you are using FactoryTalk Security to authenticate your FactoryTalk Historian ME 1756-HISTxG module, and you want to establish a connection between the Historian ME and SE modules, you need to make sure the following FactoryTalk Security groups are created in FactoryTalk Historian SE:

- FTHAdministrators
- FTHEngineers
- FTHSupervisors
- FTHOperators

To verify that these four user groups were created:

1. Click Start > All Programs > Rockwell Software > FactoryTalk Administration Console. The FactoryTalk Administration Console dialog box appears.
2. In the Select FactoryTalk Directory dialog box, select Network, and click OK.
3. In the Explorer tree, expand Users and Groups > User Groups.
The folder should include the four FactoryTalk Historian user groups:

1. Log on to Windows as the local Administrator.
2. Log on to FactoryTalk as a member of the FactoryTalk Administrators user group.
3. Open the **FactoryTalk Administration Console**, and create a computer account for each FactoryTalk Historian SE host.
5. Double-click the **FTHMESecurityUpdate.bat** file.
6. Return to **FactoryTalk Administration Console** and verify that the user groups have been created.

### Verifying the Windows Administrator Privileges

To verify that the Windows Administrators group is part of the FTHAdministrators group:

1. In **FactoryTalk Administration Console**, expand Users and Groups > User Groups.
2. Double-click the FTHAdministrators group. The **FTHAdministrators Properties** dialog box appears.
The Windows Administrators group should appear in the Members list. If it does not, do the following:

1. Click Add. The Select User or Group dialog box appears.
2. Select Windows Administrators and click OK. The group is added to the FTHAdministrators group.
3. Click OK to close the dialog box.

**Resolving Error and Warning Messages**

Use this section to find information about the following types of error and warning messages:

- General (page 109)
- No Connection to FactoryTalk Directory (page 111)

**General**

Use this section to find information about the following error messages:

- Error: System is a PINs Node (page 109)
- Error: Server Not Found (page 110)
- Error: Failure to Retrieve Interface Information (page 111)

**Error: System is a PINs Node**

<table>
<thead>
<tr>
<th>Message</th>
<th>FactoryTalk Historian SE server setup has determined that this is a PINs node. The FactoryTalk server installation cannot continue. Please completely remove the Historian SDK and rerun setup.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cause</strong></td>
<td>The error occurs if you install a FactoryTalk Historian SE server on a computer that already has FactoryTalk Historian SE Clients (ProcessBook, DataLink) or components (System Management Tools) installed.</td>
</tr>
<tr>
<td><strong>Resolution</strong></td>
<td>Remove the Historian Software Development Kit (Historian SDK) using Control Panel &gt; Programs &gt; Programs and Features.</td>
</tr>
</tbody>
</table>
Error: Server Not Found

<table>
<thead>
<tr>
<th>Message</th>
<th>The requested server &lt;FTHSE-SRV&gt; was not found in the known servers table.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cause</td>
<td>The error occurs when you try to create a new Data Collection Interface from a computer that has FactoryTalk Historian SE Live Data Interface installed. Your client computer could not locate the FactoryTalk Historian SE server.</td>
</tr>
<tr>
<td>Resolution</td>
<td>Manually create a connection to the FactoryTalk Historian SE server computer. See the instruction below.</td>
</tr>
</tbody>
</table>

To manually create a connection to the FactoryTalk Historian SE server computer:

1. On your client computer, go to Start > All Programs > Rockwell Software > FactoryTalk Historian SE System Management Tools. The System Management Tools dialog box appears.

2. From the menu bar, select File > Connections. The Connection Manager dialog box appears.

3. Select the FactoryTalk Historian SE server to which you want to connect.

   If the server name is not listed, do the following:

1. From the menu bar, select Server > Add Server. The Add Server dialog box appears.

2. In the Network Node text box, type the fully qualified domain name (FQDN) of the server.

3. Clear the Confirm check box, and click OK.

   The new server is added to the server list.
**Error: Failure to Retrieve Interface Information**

<table>
<thead>
<tr>
<th>Message</th>
<th>Failure to get/update interface information because the Historian MDB content was bad.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cause</td>
<td>The error occurs if, during an upgrade, you manually remove the earlier version of FactoryTalk Historian SE server using Control Panel &gt; Programs &gt; Programs and Features.</td>
</tr>
<tr>
<td>Resolution</td>
<td>Delete the FTLD1 interface and create it again. See the instruction below.</td>
</tr>
</tbody>
</table>

**To delete the FTLD1 interface:**

1. Click **Start > All Programs > Rockwell Software > FactoryTalk Administration Console**. The **FactoryTalk Administration Console** dialog box appears.
2. In the **Select FactoryTalk Directory** dialog box, select **Network**, and click **OK**.
3. In the **Explorer** tree, expand **System > Connections > Historical Data**, and the FactoryTalk Historian SE server node.
4. Right-click **FTLD1** and select **Delete**.
5. Click **Yes** in the confirmation message box.
6. Right-click the FactoryTalk Historian SE server and select **New Data Collection Interface** to create a new interface.

**NOTE:** During upgrades, use the installation DVD to install the latest version of FactoryTalk Historian SE server. The older version is removed during the setup procedure. Avoid removing the FactoryTalk Historian SE server with Control Panel > Programs > Programs and Features.

**No Connection to FactoryTalk Directory**

Use this section to find information about the following warning messages:

- Schema Creation (page 112)
- Folders Creation (page 113)
## Schema Creation

<table>
<thead>
<tr>
<th>Message</th>
<th>Due to the lack of connection to the network, some of the FactoryTalk Historian components have not been correctly configured.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cause</td>
<td>The warning occurs if you try to create the schema in the FactoryTalk Directory when your client computer is not connected to the network.</td>
</tr>
<tr>
<td>Resolution</td>
<td>Manually create a connection to the FactoryTalk Directory and add the schema information. See the instruction below.</td>
</tr>
</tbody>
</table>

To add the schema information to the FactoryTalk Directory, we recommend that you execute the `FTHMESecurityUpdate.bat` file. It is located in the `Redist\FTHME Security` directory on your FactoryTalk Historian SE installation DVD. The file automatically adds schema information and folders to the FactoryTalk Directory on your client computer.

**To manually add the schema information to the FactoryTalk Directory:**

Open the Command Prompt window and type the following:

```
"[ProgramFilesFolder]Rockwell Software\Management Tools\FTHistorianInstallSetup.exe"
"[CommonAppDataFolder]Rockwell Automation\FactoryTalk Historian\FTHistorianSchema.xml"
"[CommonAppDataFolder]Rockwell Automation\FactoryTalk Historian\FTHistorianStrings.xml" -G, where:
```

-  **[ProgramFilesFolder]** is the system's **Program Files (x86)** directory (e.g. `C:\Program Files (x86)`)
-  **[CommonAppDataFolder]** is the system's **ProgramData** directory (e.g. `C:\ProgramData`)
## Folders Creation

<table>
<thead>
<tr>
<th>Message</th>
<th>Due to the lack of connection to the network, some of the FactoryTalk Historian components have not been correctly configured.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cause</td>
<td>The warning occurs if you try to create new folders in the FactoryTalk Directory when your client computer is not connected to the network.</td>
</tr>
<tr>
<td>Resolution</td>
<td>Manually create a connection to the FactoryTalk Directory and add folders. See the instruction below.</td>
</tr>
</tbody>
</table>

To add the schema information to the FactoryTalk Directory, we recommend that you execute the `FTHMESecurityUpdate.bat` file. It is located in the `Redist\FTHME Security` directory on your FactoryTalk Historian SE installation DVD. The file automatically adds schema information and folders to the FactoryTalk Directory on your client computer.

### To manually add folders to the FactoryTalk Directory:

Open the Command Prompt window and type the following:

```
"[ProgramFilesFolder]Rockwell Software\Management Tools\FTHistorianInstallSetup.exe"
"[CommonAppDataFolder]Rockwell Automation\FactoryTalk Historian\FTHistorianFolders.xml" -G
```

Where:

- `[ProgramFilesFolder]` is the **Program Files** (x86) directory (e.g. `c:\Program Files (x86)`).
- `[CommonAppDataFolder]` is the **ProgramData** directory (e.g. `c:\ProgramData`) on your client computer.
Firewall-related Errors

During the installation, the FactoryTalk Historian suites attempt to update the configuration of the system firewall using the Rockwell Firewall Configuration Utility (WFCU) that has been installed along with FactoryTalk Services Platform.

If the update of the firewall configuration cannot be completed during the installation, a relevant error message is displayed on the last page of the FactoryTalk Historian installation wizard.

The errors fall into the following categories, depending on the firewall configuration you have:

- The errors that may appear if you use Windows Firewall to configure network security on the computer with FactoryTalk Historian installed:

<table>
<thead>
<tr>
<th>Error number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>20</td>
<td>The user has insufficient permissions to modify Windows Firewall rules.</td>
</tr>
<tr>
<td>200</td>
<td>The user has declined to make the changes to the configuration of Windows Firewall.</td>
</tr>
</tbody>
</table>
| 320          | The network connection specified in WFCU could not be found.  
  Cause: No network connection is configured.  
  Resolution: Configure the network connection and then configure Windows Firewall. |

See "Configuring Windows Firewall with WFCU (page 115)" for details.

- The errors that may appear if you use another firewall utility to configure network security on the computer with FactoryTalk Historian installed:

<table>
<thead>
<tr>
<th>Error number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>The version of Windows Firewall is not supported by WFCU.</td>
</tr>
<tr>
<td>100</td>
<td>Some parameters of the WFCU configuration are missing.</td>
</tr>
<tr>
<td>110</td>
<td>Some parameters of the WFCU configuration are incorrect.</td>
</tr>
</tbody>
</table>
### Troubleshooting FactoryTalk Historian

#### Chapter 7

<table>
<thead>
<tr>
<th>Error number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>120</td>
<td>The .WFCU file contains incorrect data.</td>
</tr>
<tr>
<td>130</td>
<td>The .WFCU file is missing.</td>
</tr>
<tr>
<td>300</td>
<td>The configuration of Windows Firewall is not supported by WFCU.</td>
</tr>
<tr>
<td>310</td>
<td>The .WFCU file contains incorrect configuration settings.</td>
</tr>
<tr>
<td>400</td>
<td>The Microsoft Firewall service is stopped.</td>
</tr>
<tr>
<td>-999</td>
<td>Rockwell Windows Firewall Configuration Utility (WFCU) could not be found.</td>
</tr>
</tbody>
</table>

See "Configuring Firewall for FactoryTalk Historian (page 73)" for details.

If the error message does not contain the error number, refer to the FactoryTalk Historian log for the error details.

---

### Configuring Windows Firewall with WFCU

**NOTE** You need administrator privileges to perform the steps described below.

**TIP** If you prefer, you may configure the firewall settings described below manually (page 73).

To automatically configure Windows Firewall with WFCU:

1. Go to the computer on which you have the particular Historian suite installed.
2. Check the location of the **Common Files** folder on the computer for the 32-bit operating system. You will need it in the command line.
3. Open the Command Prompt window.
4. Type the command provided in the table below.

<table>
<thead>
<tr>
<th>For this FactoryTalk Historian suite:</th>
<th>Run these commands:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Historian to Historian Interface</td>
<td><code>%COMMONFILESFOLDER%\Rockwell\WFCU\wfcu.exe -I &quot;%COMMONFILESFOLDER%\Rockwell\WFCU\FTH2HIInterface.wfcu&quot;</code></td>
</tr>
</tbody>
</table>
### Chapter 7  Troubleshooting FactoryTalk Historian

#### For this FactoryTalk Historian suite:

<table>
<thead>
<tr>
<th></th>
<th>Run these commands:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asset Framework</td>
<td><code>%COMMONFILESFOLDERX86%\Rockwell\WFCU\wfcu.exe -I &quot;%COMMONFILESFOLDERX86%\Rockwell\WFCU\FTHistorianSEAF.wfcu&quot;</code></td>
</tr>
<tr>
<td>Historian Server</td>
<td><code>%COMMONFILESFOLDERX86%\Rockwell\WFCU\wfcu.exe -I &quot;%COMMONFILESFOLDERX86%\Rockwell\WFCU\FTHistorianSEServer.wfcu&quot;</code></td>
</tr>
<tr>
<td>Live Data Interface</td>
<td><code>%COMMONFILESFOLDERX86%\Rockwell\WFCU\wfcu.exe -I &quot;%COMMONFILESFOLDERX86%\Rockwell\WFCU\FTHistorianSELiveDataInterface.wfcu&quot; -s</code></td>
</tr>
</tbody>
</table>

The `%COMMONFILESFOLDERX86%` variable stands for the location of the **Common Files** folder on the computer.

Example: If the **Common Files** folder is in the following location:

*C:\Program Files\Common Files*

The complete path to the command that you need to run for the Historian to Historian Interface is:

*C:\Program Files\Common Files\Rockwell\WFCU\wfcu.exe -I "C:\Program Files\Common Files\Rockwell\WFCU\FTH2HInterface.wfcu"*

**5.** Press Enter.

The firewall is configured.
Appendix A

Configuring Historian Servers in High Availability Mode

In this chapter you will learn about the following:

- High availability (HA) architecture (page 117).
- Working with server collectives (page 119).
- Creating server collectives (page 120).
- Verifying communication between server collective members (page 122).
- Verifying replication of configuration changes in the primary server (page 124).
- Assigning license activations to server collectives (page 125).
- Configuring interfaces and buffering services for Historian server collectives (page 128).

**NOTE** For detailed information on the high availability functionality, refer to the FT Historian High Availability Administrator Guide.

High Availability (HA) Architecture

You can configure high availability (HA) features on appropriate Historian components. To ensure the high availability of FactoryTalk Historian server data, you must configure three types of components:

- **A FactoryTalk Historian server collective**
  
  To implement HA, install two FactoryTalk Historian servers and configure the FactoryTalk Historian SE system to store...
and write identical data on each server. Together, this set of servers, called a FactoryTalk Historian server collective, acts as the logical FactoryTalk Historian server for your system. The server collective receives data from one or more interfaces and responds to requests for data from one or more clients. Because more than one server contains your system data, system reliability increases. When one server becomes unavailable, for planned or unplanned reasons, another server contains the same data and responds to requests for that data. Similarly, when the demand for accessing data is high, you can spread that demand among the servers.

- **Redundant interfaces**

  To implement HA, configure interfaces to support failover and n-way buffering:

  - **Failover** ensures that time-series data reaches the FactoryTalk Historian server even if one interface fails.

    To support failover, install a redundant copy of an interface on a separate computer. When one interface is unavailable, the redundant interface automatically starts collecting, buffering, and sending data to the FactoryTalk Historian server.

  - **N-way buffering** ensures that identical time-series data reaches each FactoryTalk Historian server in a collective.

    To support n-way buffering, configure the buffering service on interface computers to queue data independently to each FactoryTalk Historian server in a collective.
• Clients (user workstations)

To implement HA, configure clients to connect to either server in a collective and seamlessly switch to another server if necessary.

Working with Server Collectives

A server collective consists of two FactoryTalk Historian SE servers (primary and secondary) that have the same configuration database. This provides the same association between the key values in the FactoryTalk Historian SE tables on all of the servers. This also ensures that the archive data files have the same structure on all of the servers.

Keep the following in mind about server collectives:

• When creating server collectives, you must always use fully qualified host names, not IP addresses. Therefore, the name resolution functionality must work on the network.

• If you make one or more FactoryTalk Historian SE servers members of a collective, you must restart them after a server collective is created. Otherwise, FactoryTalk Administration
Appendix A  Configuring Historian Servers in High Availability Mode

Console will not recognize any of the third-party tag licenses you may have on your servers.

- To create a server collective on computers that have Windows Firewall turned on, you must manually open the TCP 445 port between the two computers. Please refer to the Microsoft documentation for more information.

- The Windows user that configures server collectives must be a domain user and must be mapped to the piadmin user. See "Create Security Mappings (page 69)" for more information.

- The same Windows user to piadmin user mapping must be performed on both the primary and secondary server in a collective.

- Activate your server collective in the FactoryTalk Administration Console.

Creating Server Collectives  To create a collective:

1. Click Start > All Programs > Rockwell Software > FactoryTalk Historian SE > FactoryTalk Historian SE System > Collective Manager. The Collective Manager dialog box appears.

2. From the menu bar, select File > Connections. The Connection Manager dialog box appears.

3. From the menu bar, select Server > Add Server. The Add Server dialog box appears.

4. In the Network Node text box, type the name of the other server that you want to add to your collective.

5. Click OK, and then Save.

6. From the menu bar, select File > Create New Collective. The Create New Collective wizard appears.

7. Select both check boxes, and click Next.
8. On the **Existing Or New Primary** page, select **A newly installed Historian Server**, and click **Next**.

The **Select Primary and Collective Name** page appears.

9. Review the following for additional information:

<table>
<thead>
<tr>
<th>Item name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Collective Primary</td>
<td>From the drop-down list, select the name of the server you want to make primary. If the name is not in the list, click ![...], and select the server from the <strong>Connection Manager</strong> dialog box.</td>
</tr>
<tr>
<td>Primary Description</td>
<td>(Optional) Type a description of the primary server.</td>
</tr>
<tr>
<td>Collective Name</td>
<td>Type a name of the collective. The name must be unique.</td>
</tr>
<tr>
<td>Collective Description</td>
<td>(Optional) Type a description of the collective.</td>
</tr>
</tbody>
</table>

10. Click **Next**. The **Select Secondary Servers** page appears.

11. From the **Server** drop-down list, select the name of the server you want to add as secondary.

If the name is not in the list, click ![...], and select the server from the **Connection Manager** dialog box.

12. Click **Add** to add the selected server to the secondary servers list, and click **Next**.

13. On the **Select Archives** page, select the archives from your primary server you want to copy to your secondary server. We recommend that you back up all your primary server archives onto your secondary server.

Click **Next**.

14. On the **Select Backup Location** page, leave the default location, or click ![...], and browse to the location to which you want to back up the content of your primary server.

15. Click **Refresh** to check the space available in the selected location. Make sure that the space available is larger than the space required.
Click Next.

16. On the Verify Selections page, verify the collective data, and click Next.

The Conversion Progress page displays the status and individual steps of the conversion process. Wait until the conversion is complete.

17. If the Server ID Mismatch dialog box appears, select Accept the new ID, and click OK.

18. On the Finished page, click Finish. The new collective is displayed in the Collective Manager dialog box.

TIP For more information on collectives, refer to the Collective Manager Help. To access it, select Help > Contents from the menu bar of the Collective Manager dialog box.

Verifying Communication Between Server Collective Members

Use the Collective Manager to verify that the members of your server collective are communicating.

To check communication of the members of a server collective:

1. Click Start > All Programs > Rockwell Software > FactoryTalk Historian SE > FactoryTalk Historian SE System > Collective Manager. The Collective Manager dialog box appears.

If the server collective does not appear under Collectives, you must enable communication between the Collective Manager and the collective:

1. Select File > Connections. The Connection Manager dialog box appears.

2. Click the check box next to the name of the server collective to select it.
If the server collective is not listed in the Connection Manager, add it:

1. Select Server > Add Server.

2. In the Network Node text box, type the fully qualified domain name (FQDN) for the primary server in the collective.

3. Click OK.

3. Select the server collective.

4. Click Save to close the Connection Manager.

2. Under Collectives, select your server collective.

The right pane of the dialog box displays the current status of the connection between the members of the selected server collective. The Collective Manager shows a diagram of server collective members. An icon represents each server in the collective. A green check mark on the icon indicates that the server is communicating correctly. A red x mark indicates that the server is not communicating correctly. If a server icon is not communicating correctly, you can:

- Wait a few moments. Occasionally, the status of the secondary server will get updated at the next attempt to synchronize.

- Try to reinitialize the server. To do so, right-click the server icon and select Reinitialize Server.
Verifying Replication of Configuration Changes in the Primary Server

To verify that a Historian server collective replicates primary server configuration changes to all secondary servers, you can edit a point on the primary server and verify the change on the secondary server in the collective.

To verify configuration replication in a Historian server collective:

1. Click Start > All Programs > Rockwell Software > FactoryTalk Historian SE > System Management Tools. The System Management Tools dialog box appears.
2. Under Collectives and Servers, select all the servers that are members in the collective.
4. Add a point found in all the servers to the list of points:
   1. On the toolbar, click The Tag Search dialog box appears.
   2. In Tag Mask, type sinusoid.
   3. Click Search to find all instances of this built-in point on the selected servers.
   4. Click Select All to choose all instances.
   5. Click OK to add these points to the list of points in the Point Builder.
5. Edit the point on the primary server:
   1. Select the point on the primary server.
      The Point Builder shows the configuration of the selected point in the tabs at the bottom of the System Management Tools dialog box.
2. In the **General** tab, change the text in the **Descriptor** text box. For example, change *12 Hour Sine Wave* to *12-hour sine wave*.

3. Click ![Image](image.png)

   The Point Builder shows the updated **Descriptor** text for this point on the primary server.

6. Click ![Image](image.png)

   If the replication is working properly, the modified **Descriptor** text appears for the sinusoid point on all the servers in the collective.

   If the replication fails, refer to the *FT Historian High Availability Administrator Guide*, section "Historian Collective Health".

   **NOTE**

   In order to assign the activations to a FactoryTalk Historian SE server, the server must be added to the FactoryTalk Directory. See "Adding the Server to the FactoryTalk Directory (page 75)" for more information.

   Depending on the type of license activations, you may need to acquire a single or double number of license activations of a given type for your Historian server collective.

   - For the following license activations, you need a single activation of a given type for both servers in a collective:
     - FHSE.Advanced
     - FHSE.H2H
     - FTBAInt.*
     - AVIEW.*

   **NOTE** The asterisk (*) stands for any count of FTBAInt and AVIEW license activations.

   If you assign any of the license activations listed above to a Historian server collective, the primary server retrieves (checks out) the license activations from the FactoryTalk Activation...
server to be used by both servers in a collective. In the FactoryTalk Activation Manager, the number of activations in use is reflected only for the primary server in a collective. It is because the assignment of activations to the secondary server in a collective is performed outside the FactoryTalk Activation mechanism.

For example, if you want to assign 1 license activation of type \textit{FHSE.H2H} to your Historian server collective, you need to acquire 1 license activation of this type and then assign it to the primary server in your collective.

- For all other license activations, you need a separate activation of a given type for each server in a collective.

If you assign any license activations other than those listed above to a Historian server collective, the primary server retrieves (checks out) the license activations from the FactoryTalk Activation, and the second license activation of the same type is automatically checked out for the secondary server in a collective. In the FactoryTalk Activation Manager, the number of activations in use is reflected for both servers in the collective.

For example, if you want to assign 2 license activations of type \textit{FHLD.5000} to your Historian server collective, you need to acquire 4 license activations of this type and then assign 2 activations to the primary server. The other 2 activations will be automatically assigned to the secondary server in your collective. You will be able to assign license activations of a given type to your server collective only if you have a sufficient number of them available.
To assign license activations to the primary server in a collective:

1. Go to Start > All Programs > Rockwell Software > FactoryTalk Administration Console.
2. In the Select FactoryTalk Directory dialog box, select Network and click OK.
3. In the Explorer tree, expand System > Connections > Historical Data.
4. Right-click the name of the server to which you want to assign the license activations, and click Properties.
5. In the Historian Server Connection Properties dialog box, click the Licensing tab. The table in the tab lists the types and number of activations available for the selected server.
6. To assign a license activation to the server, type a number in the Assigned column for the selected license activation. The number shows how many licenses of the selected type will be assigned to the server.
If you have an insufficient number of the license activations that need to be assigned separately to the primary and secondary server in a collective, you are prompted to reassign the licenses.

7. Click \textbf{Apply}. The license activations are saved.

\begin{figure}[h]
\centering
\includegraphics[width=0.5\textwidth]{license_assignment.png}
\caption{License Management}
\end{figure}

\textbf{Configuring Interfaces and Buffering Services for Historian Server Collectives}

To implement HA, configure interfaces to support failover and n-way buffering. Failover ensures that time-series data reaches the Historian server even if one interface fails; n-way buffering ensures that identical time-series data reaches each Historian server in a collective.

To support failover, install a redundant copy of an interface on a separate computer. When one interface is unavailable, the redundant interface automatically starts collecting, buffering, and sending data to the Historian server. To support n-way buffering, configure the buffering service on interface computers to queue data independently to each Historian server in a collective.

In some deployments, interfaces send outputs (that is, data from the Historian server) to the data source. With a proper configuration, failover considers the availability of the Historian server for outputs in addition to the availability of the interface.

\textbf{NOTE}

For more information, refer to the \textit{FT Historian High Availability Administrator Guide}, chapter "Interfaces".
Appendix B

Configuring Live Data Interface Redundancy

Overview

For detailed information on the installation and configuration of the interface redundancy, refer to the KB article 59932 (https://rockwellautomation.custhelp.com/app/answers/detail/a_id/59932).
Appendix C

FactoryTalk View SE TrendX

The FactoryTalk View TrendX display object supports FactoryTalk Historian SE server as a data source. In this chapter you will learn how to configure FactoryTalk View TrendX to trend the data points (tags) from FactoryTalk Historian SE server. A trend is a visual representation or a chart of real-time or historical data. It provides a way to track plant activity as it is happening.

Before you start using the TrendX object with your FactoryTalk Historian SE server, do the following:

- Install the FactoryTalk Historian Management Tools (page 47) on the FactoryTalk View SE Server, Studio, and client computers.
- Either use a Windows user (page 69) mapped in the System Management Tools, or create a trust (page 131) between the device on which you will use the TrendX object and the FactoryTalk Historian SE server that will be used as the data source of the object.
- Add the FactoryTalk Historian SE server to the FactoryTalk Directory (page 75).
- Make sure both the device and the FactoryTalk Historian SE server point to the same FactoryTalk Directory (page 28).

If you intend to use the FactoryTalk View TrendX display object to trend data points (tags) from the FactoryTalk Historian SE server, you need to establish a security connection between the device on which you use the TrendX object (e.g. a computer with FactoryTalk

Creating Security Trusts for the FactoryTalk View TrendX Display Object
View running) and the FactoryTalk Historian SE server. You can achieve it by creating a trust between the IP address of the device and the **FTHOperator** user of the FactoryTalk Historian SE server security model.

**NOTE** For more information on the FactoryTalk Historian SE server users, see "Historian Security Components and Their Privileges (page 63)".

To create a security trust for the FactoryTalk View TrendX object:

1. On the computer with the FactoryTalk Historian SE server installed, go to **Start > All Programs > Rockwell Software > FactoryTalk Historian SE > System Management Tools**. The **System Management Tools** dialog box appears.
2. Under **Collectives and Servers**, select the FactoryTalk Historian SE server, for which you want to create the trust.
3. Under **System Management Tools**, select **Security > Mappings & Trust**.
4. Go to the **Trusts** tab.
5. On the toolbar, click the arrow next to **``** Advanced **``**, and select **Advanced**.
6. In the **Add New Trust** dialog box, provide the following information:

<table>
<thead>
<tr>
<th>Item name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trust Name</td>
<td>Type a name of the trust.</td>
</tr>
<tr>
<td>Server Name</td>
<td>Select from the list the FactoryTalk Historian SE server for which you want to create the trust.</td>
</tr>
<tr>
<td>IP Address</td>
<td>Type the IP address of the device on which you will use the FactoryTalk View TrendX objects.</td>
</tr>
</tbody>
</table>
7. Click **OK**. The new trust appears in the **Trusts** tab.

Now you can start using the FactoryTalk View TrendX object with your FactoryTalk Historian SE server.
To configure trend properties for an existing application:

1. On the computer with FactoryTalk View Studio installed, go to Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. In the Application Type Selection dialog box, select the type of the application and click Continue.

3. In the application dialog box, select the existing application name, the language for the application, and click Open.

4. In the Explorer tree, expand a HMI project, and select a display.

5. Right-click the display and select Open. The display canvas appears in the right pane of the dialog box. Click in the canvas to display additional menu items in the menu bar.

6. From the menu bar, select Objects > Advanced > Trend. The object type name appears next to the mouse pointer.

7. Place the mouse pointer on the display canvas, press and hold the left mouse button and drag the mouse pointer to create a trend.

8. Double-click the trend object. The Trend Properties dialog box appears.

   **NOTE** For more information on the trend properties, refer to the FactoryTalk View SE Help. To access it, click Help in the Trend Properties dialog box.

9. In the General tab, select either of the following options from the Data Server list:

<table>
<thead>
<tr>
<th>Item name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real-time data server</td>
<td>Retrieves data from the snapshot subsystem. This option is preferred for points that change infrequently like setpoints.</td>
</tr>
<tr>
<td>Poll historical data</td>
<td>Retrieves data from the archive files. This option is preferred for points that change faster than a second.</td>
</tr>
</tbody>
</table>
10. In the **Pens** tab, select **Historian Server** from the **Pen Source** list.

11. Click **Add Pen(s)**. The **Add Pen Configuration** dialog box appears.

   **NOTE** You can add new or existing FactoryTalk Historian data points (tags) in pen for trending - one pen per tag.

12. From the **FT Historian Server** list, select the FactoryTalk Historian SE server for which you have created the trust (page 131).

   **NOTE** The TrendX object supports pens that come from different FactoryTalk Historian SE servers. For example, you can add a **Pen 1** tag from the Server A and a **Pen 2** tag from the Server B. The tag names must be unique.

13. In the **Enter or Select Tag** text box:
   - Type the name of the data point (tag) you want to add, or
   - Search for a tag by clicking ![tag_search_icon] The **Tag Search** dialog box appears.

   **TIP** For information on how to use the **Tag Search** dialog box, click **Help** in the dialog box.

14. Once you have selected the tag, click **OK**.

15. In the **Add Pen Configuration** dialog box, click **Add**.

   The tag name is validated.

   - If validation fails, a relevant message appears. Correct the tag name and click **Add** again.
   - If validation succeeds, the tag is added to the list box and the **Enter or Select Tag** text box is cleared.

16. Click **OK**.

   The tag is displayed in the **Pens** tab of the **Trend Properties** dialog box.

17. Click **OK**.

   The tag is added to the trend object in the display.
18. Click the toolbar to test the display.

The trend starts displaying data from the selected tag.
Upgrading FactoryTalk Historian to the Current Version

Upgrading FactoryTalk Historian to the Current Version

In this chapter you will learn how to upgrade your FactoryTalk Historian 3.0 to the current version of the product.

NOTE You need administrative rights to perform these steps.

To upgrade your Historian 3.0 to FactoryTalk Historian SE 3.01:

1. Stop the server:
   1. Go to Start > All Programs > Rockwell Software > FactoryTalk Historian SE > Stop FactoryTalk Historian SE.
      The server stopping process begins. The progress is displayed in the Command Prompt window.
   2. Wait until the server is stopped and the Command Prompt window is closed.

2. Stop the FTHConnector service:
   1. Go to Start > All Programs > Administrative Tools > Services. The Services dialog box appears.
   2. Right-click FTHConnector and select Stop.
   3. Wait until the service is stopped.


4. Start the server:
   1. Go to Start > All Programs > Rockwell Software > FactoryTalk Historian SE > Start FactoryTalk Historian SE.
The server starting process begins. The progress is displayed in the Command Prompt window.

2. Wait until the server is started and the Command Prompt window is closed.

5. If prompted, restart the computer.
Appendix E

Removing FactoryTalk Historian

**IMPORTANT** Do not remove FactoryTalk Historian SE unless you have decided not to use Historian SE server, or you are resetting your FactoryTalk Historian plant floor operations. Removing FactoryTalk Historian SE will result in the loss of data.

To remove FactoryTalk Historian SE, choose either of the following methods:

- Using the Start menu (page 140).
- Using Control Panel (page 140).
- Using the FactoryTalk Historian SE installation DVD (page 141).

If you are removing FactoryTalk Historian from a computer, on which FactoryTalk Historian SE 3.0 has been previously installed, a message will appear informing you that FactoryTalk Historian SE 3.0 will be removed as well when you exit the removal wizard:

*Warning*

In order to complete the removal process, the following suite must be uninstalled: FactoryTalk Historian Site Edition 3.00 Server Suite. The uninstaller will start automatically. One or more components to be uninstalled require that you restart the computer manually after the removal process completes.
Click **OK** to complete the removal process.

**NOTE** The FactoryTalk Historian removal wizard does not remove the components that are shared by other FactoryTalk products. If you want to remove them as well, you need to do it manually using Control Panel.

### Removing the Suite Using the Start Menu

**To remove the suite using the** Start menu:

1. Go to **Start > All Programs > Rockwell Software > FactoryTalk Historian SE**.

2. Click the **Uninstall** link of the FactoryTalk Historian suite you want to remove from the computer. The removal wizard appears.

3. On the wizard pages, click **Next** and then **Uninstall** to start the removal process.

4. Click **Finish**.

5. In the message that appears, click **OK** to complete the removal process.

### Removing the Suite Using Control Panel

**To remove the suite using Control Panel:**

1. Go to **Start > Control Panel > Programs > Programs and Features**.

2. Under **Uninstall or change a program**, select the name of the FactoryTalk Historian suite you want to remove from the computer, and click **Uninstall/Change**. The removal wizard appears.

3. On the wizard pages, click **Next** and then **Uninstall** to start the removal process.
4. Click Finish.

5. In the message that appears, click OK to complete the removal process.

Removing the Suite Using the Installation DVD

To remove FactoryTalk Historian SE using the FactoryTalk Historian SE installation DVD:

1. Run the FactoryTalk Historian SE installation DVD.


3. On the Uninstall FactoryTalk Historian Site Edition page, click the Uninstall link of the FactoryTalk Historian suite you want to remove from the computer.

   The removal wizard appears.

4. On the wizard pages, click Next and then Uninstall to start the removal process.

5. Click Finish.

6. In the message that appears, click OK to complete the removal process.
Index

A
Activating the Historian Server 61
Add the AF Service Computer to the AFServer Group 55
Adding Individual Data Points Manually 90
Adding Multiple Data Points Automatically 91
Adding the Server to the FactoryTalk Directory 75
Allocating Licenses to Interface Types 86
Archiving and Backups 95
Assigning License Activations to Server Collectives 125
Assigning License Activations to the Historian Server 85

C
Configuring FactoryTalk Historian 61
Configuring FactoryTalk Historian Live Data Interface 98
Configuring Firewall for FactoryTalk Historian 73
Configuring Historian Interface Connections 97
Configuring Historian Servers in High Availability Mode 117
Configuring Interfaces and Buffering Services for Historian Server Collectives 128
Configuring Live Data Interface Redundancy 129
Configuring Points 90
Configuring the Data Server 96
Configuring the Historian Server 75
Configuring Trend Properties 134
Configuring Windows Firewall with WFCU 115
Creating Security Mappings 69
Creating Security Trusts for the FactoryTalk View TrendX Display Object 131
Creating Server Collectives 120

D
Disable the Windows Time Zone (TZ) Environment Variable 24
Disable Virus Scanning 60
Distributing Licenses with FHSE3ADD Activation 82
Distributing Licenses without FHSE3ADD Activation 83
Documentation Feedback 146

E
Enable Buffering 100
Error
  Failure to Retrieve Interface Information 111
  Server Not Found 110
  System is a PINs Node 109

F
FactoryTalk Historian Asset Framework 19
FactoryTalk Historian Client Machine 18
FactoryTalk Historian DataLink 20
FactoryTalk Historian Installation Package 9
FactoryTalk Historian Live Data Interface Machine 18
FactoryTalk Historian SE Server Machine 17
FactoryTalk View SE TrendX 131
Find the Version and Build Numbers 15
Firewall-related Errors 114
Folders Creation 113

G
General 109
Index

H
High Availability (HA) Architecture 117
Historian Security Components and Their Privileges 63
How Licenses Are Distributed Between License Pools 80

I
In the Start Menu 11
Install Additional Historian Components 52
Install Advanced Server (Optional) 50
Install FactoryTalk Activation Manager 30
Install FactoryTalk Historian Asset Framework 33
Install FactoryTalk Historian Asset Framework Server 36
Install FactoryTalk Historian Live Data Interface (Optional) 43
Install FactoryTalk Historian Management Tools (Optional) 47
Install FactoryTalk Historian SE Server 39
Install FactoryTalk Services Platform 27
Install FactoryTalk VantagePoint (Optional) 52
Install Microsoft SQL Server 25
Install RSLinx Enterprise (Data Server) 31
Installation Assistance 146
Installation Modes for FactoryTalk Historian Asset Framework 34
Installing Core Components 25
Installing FactoryTalk Historian 25
Installing FactoryTalk Historian Suites 32
Integration with Other Rockwell Automation Products 8

K
Knowledgebase 13

L
Learn About Installation-related Recommendations 24
Live Data Interface Services 99

M
Managing Historian Security Components 67
Managing Licenses 77
Managing Security of the Historian Server Database 71
Manually Configure the Asset Framework Service 58
Manually Create the Asset Framework Database 56
Manually Enabling Excel Add-ins 103
Message Parameters 104

N
New Product Satisfaction Return 146
No Connection to FactoryTalk Directory 111

O
On the Installation DVD 10
On the Local Hard Drive 11
Overview 7, 129

P
Perform the MDB to AF Synchronization 59
Post-Installation Tasks 53
Pre-Installation Tasks 23

R
Recording Messages Using FactoryTalk Diagnostics 104
Registering Live Data Interfaces 98
## Index

Removing FactoryTalk Historian 139  
Removing the Suite Using Control Panel 140  
Removing the Suite Using the Installation DVD 141  
Removing the Suite Using the Start Menu 140  
Resolving Error and Warning Messages 109  
Restarting FactoryTalk Historian SE Server 96  
Rockwell Automation Support 146

### S

Schema Creation 112  
Securing the Historian Server 62  
Specify FactoryTalk Directory Server Location 28  
Synchronize Time Settings on FactoryTalk Historian System Computers 23  
System Requirements 17

### T

TechConnect Support 14  
Technical Support 13  
Technical Support and Resources 13  
Training Programs 13  
Troubleshooting FactoryTalk Historian 107  
Types of Licenses 78  
Typical Architecture 9

### U

Upgrading FactoryTalk Historian 137

Upgrading FactoryTalk Historian to the Current Version 137  
User Documentation 10  
Using FactoryTalk Historian ME Modules with FactoryTalk Security 107

### V

Verify that Historian Services are Running 53  
Verify that the Historian Server is Updating Data for Default Tags 55  
Verify the MDB to AF Synchronization 59  
Verifying Communication Between Server Collective Members 122  
Verifying Replication of Configuration Changes in the Primary Server 124  
Verifying the FactoryTalk Historian Live Data Local Interface 77  
Verifying the Windows Administrator Privileges 108  
View Computer Platform Information 15  
View the Installation Log File 53  
Viewing Allocated Licenses 89  
Viewing Archive Data 94  
Viewing Current and Archive Data 93  
Viewing Current Data 93  
Viewing Messages 105

### W

Working with Server Collectives 119  
Worldwide Support 13
Rockwell Automation Support

Rockwell Automation provides technical information on the Web to assist you in using its products. At http://www.rockwellautomation.com/support/, you can find technical manuals, a knowledge base of FAQs, technical and application notes, sample code and links to software service packs, and a MySupport feature that you can customize to make the best use of these tools.

For an additional level of technical phone support for installation, configuration, and troubleshooting, we offer TechConnect support programs. For more information, contact your local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/support/.

Installation Assistance

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can contact Customer Support for initial help in getting your product up and running.

<table>
<thead>
<tr>
<th>United States or Canada</th>
<th>1.440.646.3434</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States or Canada</td>
<td>Use the Worldwide Locator at <a href="http://www.rockwellautomation.com/support/americas/phone_en.html">http://www.rockwellautomation.com/support/americas/phone_en.html</a>, or contact your local Rockwell Automation representative.</td>
</tr>
</tbody>
</table>

New Product Satisfaction Return

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. However, if your product is not functioning and needs to be returned, follow these procedures.

<table>
<thead>
<tr>
<th>United States</th>
<th>Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to your distributor to complete the return process.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States</td>
<td>Please contact your local Rockwell Automation representative for the return procedure.</td>
</tr>
</tbody>
</table>

Documentation Feedback

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, complete this form, publication RA-DU002, available at http://www.rockwellautomation.com/literature/.

www.rockwellautomation.com