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Preface 

This manual describes how to install and configure the Emonitor®® 4.0 
Conditional Monitoring Software (CMS). 

Copyright notice 

© 2016 Rockwell Automation, Inc. All rights reserved. Printed in USA. 

This document and any accompanying Rockwell Software products are 
copyrighted by Rockwell Automation, Inc. Any reproduction and/or distribution 
without prior written consent from Rockwell Automation, Inc. is strictly 
prohibited. Please refer to the license agreement for details. 

End User License Agreement (EULA) 

You can view the Rockwell Automation End-User License Agreement ("EULA") 
by opening the License.rtf file located in your product's install folder on your hard 
drive. 

 

Trademark Notices 

Allen-Bradley, Dynamix, Emonitor, Enwatch, FactoryTalk, Logix5000, Intelligent 
Advisory Evaluator, Rockwell Automation, Rockwell Software, RSLinx Classic, 
RSMACC, and XM are trademarks of Rockwell Automation, Inc. 

Any Rockwell Automation software or hardware not mentioned here is also a 
trademark, registered or otherwise, of Rockwell Automation, Inc. 

Other Trademarks 

ActiveX, Microsoft, Excel, Exchange, Internet Explorer, Outlook, Windows, and 
Windows Server are either registered trademarks or trademarks of Microsoft 
Corporation in the United States and/or other countries. 

Adobe, Acrobat, and Reader are either registered trademarks or trademarks of 
Adobe Systems Incorporated in the United States and/or other countries. 

All other trademarks are the property of their respective holders and are hereby 
acknowledged. 

Warranty 

This product is warranted in accordance with the product license. The product’s 
performance may be affected by system configuration, the application being 

Legal Notices 
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performed, operator control, maintenance, and other related factors. Rockwell 
Automation is not responsible for these intervening factors. The instructions in 
this document do not cover all the details or variations in the equipment, 
procedure, or process described, nor do they provide directions for meeting every 
possible contingency during installation, operation, or maintenance. This 
product’s implementation may vary among users. 

This document is current as of the time of release of the product; however, the 
accompanying software may have changed since the release. Rockwell Automation, 
Inc. reserves the right to change any information contained in this document or 
the software at any time without prior notice. It is your responsibility to obtain the 
most current information available from Rockwell when installing or using this 
product. 

Environmental compliance 

Rockwell Automation maintains current product environmental information on 
its website at http://www.rockwellautomation.com/rockwellautomation/about-
us/sustainability-ethics/product-environmental-compliance.page 

Contact Rockwell 

Customer Support Telephone — 1.440.646.3434 
Online Support —http://www.rockwellautomation.com/support/ 

 

 

http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/support/
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Chapter 1 

Introduction 

This chapter introduces the Emonitor® software and gives an overview of the 
installation process. 

This installation guide offers information on the entire installation process, 
including software installation, database server and client installation, and 
database connection information. 

This installation guide is intended for first-time installation or upgrades from 
earlier versions of Emonitor software. It also contains reference information for 
later use. 

The following items are the minimum system requirements to install Emonitor 
version 4.0. 

Hardware Requirements 

• Intel Core i5 microprocessor

• 1 GB of RAM

• DVD ROM drive

• 200 MB of space available on the hard drive, or more depending on the size
of the database to be used

• Internet access

• SVGA graphics card

• 17 inch computer monitor (screen)

Overview of Emonitor 
Installation Guide 

System requirements 
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Software Requirements 

• Windows® 7 Service Pack 1 (SP1), Professional, Enterprise, or Ultimate 
edition operating system (32 or 64-bit version) 

• Administrator rights on the computer where Emonitor is being installed 

• RSLinx® Classic (or Classic Lite) version 3.6, 3.70, or 3.74 must be installed 
and running as a service 

• Microsoft .NET Framework 4.5.1 (If it is not installed, it will be installed as 
a part of the installation process and a reboot may be required.) 

• SQL Server® installed on the server and the client computers 

• Device serial number and product key 

Minimum recommended disk space 

For a guideline, the Emonitor software requires about 200 megabytes (MB) of disk 
space. There are additional disk space requirements depending on the database 
setup. Be sure to check with your database administrator about these requirements 
and about backing up the database. 

Internet access 

FactoryTalk® Activation requires an activation file, also called a license file. Unless 
using a hardware dongle (usually a USB key), the FactoryTalk Activation Manager 
must be used to request one or more license files from the Rockwell software 
licensing website. If the computer running Emonitor does not have Internet 
access, Rockwell Automation Technical Support must be contacted in order to get 
the activation file by phone. Refer to the FactoryTalk Activation document for 
more information. 

Operating System 

You must install Emonitor on a computer running either the 32 or 64-bit version 
of the Windows 7 SP1 operating system. The Professional, Enterprise and 
Ultimate editions of Windows 7 SP1 are supported for running Emonitor. 
Emonitor version 4.0 is not supported on any other operating system. 

Microsoft SQL Server 2012 data management software 

Before installing Emonitor, make sure the computer hosting the database server is 
running the required version of SQL Server. Consult with your database 
administrator to verify which version of the database server is being used. The 
version supported by Emonitor 4.0 is SQL Server 2012. If the database server does 
not have the required version ask your database administrator for assistance. 
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All Emonitor client computers must be able to connect to the database server. 

Serial number and product key 

Emonitor requires activation using license files. As part of the Emonitor 
installation process, FactoryTalk Activation software must be installed. 

The FactoryTalk Activation Manager replaces the old parallel port security keys 
and the CD Activation Key. The FactoryTalk Activation Manager is installed 
with Emonitor, and requires the Serial number and Product Key (located on the 
activation certificate) to activate the software. The Activation Certificate is 
included with the Emonitor Install DVD. 

For more information on viewing the FactoryTalk Activation Manager 
documentation and installing the application, see Install FactoryTalk Activation 
Manager on page 23. 

Microsoft SQL Server 2012 is the only database program supported by this 
version of Emonitor. 

Refer to the database software manufacturer’s documentation for the 
requirements for the computer running the database server software. 

The following list provides sources of additional information that may be required 
depending on your system setup. 

• To learn about new features and improvements in Emonitor, read the 
Emonitor Product Release Notes. These are located on the Emonitor Install 
DVD (insert the DVD and then click Documentation). 

• To get started quickly, read the Emonitor Quick Start Guide. This provides 
an introduction to the software and how to use the online help included 
with the software. This guide is located on the Emonitor Install DVD. 

• Refer to the online help for detailed instructions on using all the functions 
of the software. The online help system also includes explanations for all the 
commands and controls. Just press F1 to access the online help at any time 
in Emonitor. 

• If using data collectors with a walk-around system, an additional Data 
Collector User’s Guide may be included for each of those interfaces. 

Additional manuals for the hardware used for data collection may also be 
included. These manuals are delivered as PDF files on the CD that comes with the 
data collector or other hardware. Reference the data collector online help files 
installed with Emonitor from the Help menu in Emonitor. 

 

Database system 
requirements 

Additional information 
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If you cannot connect to the Internet or cannot find answers to your questions in 
this help file or on the Technical Support Web 
site http://www.rockwellautomation.com/support/, call Technical Support. 

• Phone: 440-646-3434 in North America 

• Technical Support hours of operation: 8:00 AM - 5:00 PM 

If you are not located in North America and want to contact Rockwell 
Automation Technical Support by telephone, access the web 
address http://www.rockwellautomation.com/support/, select your region and 
country under Get Support Now, and then click Get Support for information 
about contacting your local support organization. 

When you call you should be at your computer and be prepared to give the 
following information: 

• The product version number 

• The type of hardware you are using 

• The exact wording of any messages that appeared on your screen 

• A description of what happened and what you were doing when the 
problem occurred 

• A description of how you tried to solve the problem 

For information about all Rockwell Automation products or for technical 
support, select one of the following: 

• http://www.rockwellautomation.com/rockwellsoftware/  

• http://www.rockwellautomation.com/support/  

• http://rockwellautomation.custhelp.com/  

 

Contact us 

http://www.rockwellautomation.com/support/
http://www.rockwellautomation.com/support/
http://www.rockwellautomation.com/support/
http://www.rockwellautomation.com/support/
http://www.rockwellautomation.com/rockwellsoftware/
http://www.rockwellautomation.com/support/
http://rockwellautomation.custhelp.com/
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Chapter 2 

Install the database components 

This chapter describes the database installation process. 

This chapter is primarily of use to those performing new installations of Emonitor 
or those setting up a new Emonitor Microsoft SQL Server 2012 database. Users 
with existing SQL Server 2012 databases that are upgrading from a previous 
version of Emonitor can proceed to Upgrade from a previous version of Emonitor. 
on page 35 

Emonitor 4.0 requires Microsoft SQL Server 2012. 

Tip: When upgrading SQL Server it is advised to back up all database directories to 
ensure that a copy is available. 

Refer to the Microsoft documentation for instructions on installing the database 
server, including the choice of Microsoft operating systems. The database server 
installation procedures may require a database administrator to complete the 
configuration. 

Note: TCP/IP for SQL Server Configuration must be enabled on the computer that is running SQL 
Server. 

This section describes the process for creating the Emonitor databases and the 
users, or logins, for those databases. It is recommended that this section be 
completed before beginning the Emonitor installation process. 

The File Group names in the following steps (EmonitorI, EmonitorD, 
ECONFIGI, ECONFIGD) are recommended but not required; different Group 
names can be substituted in the steps, but require the database creation scripts to 
be edited. Information on editing those scripts can be found in the Configure the 
databases section. 

Install Microsoft SQL Server 
2012 

Create the databases 
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To create the Emonitor databases: 

1. Click Start and then select Microsoft SQL Server Management Studio. 

2. In the Object Explorer, alternate-click the Databases folder and select New 
Database. 

 

3. Emonitor database 

a. Name the new database Emonitor. 

b. Set the Initial Size for Emonitor_log database file to 25 MB. 

4. EmonitorD database 

a. Click Add to create a new Database file in the table. 

b. Change the Logical Name of this new file to EmonitorD. 

c. Set the Initial Size for the EmonitorD database file to 500 MB. 

d. Click the Filegroup column and use the pull-down to select <new 
filegroup>. 

e. Name the new file group EmonitorD. 
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5. EmonitorI database 

a. Click Add to create another new Database file. 

b. Change the Logical Name of this file to EmonitorI. 

c. Set the Initial Size of EmonitorI to 50 MB. 

d. Click the Filegroup column and use the pull-down to select <new 
filegroup>. 

e. Name this new file group EmonitorI. 

 

6. In the Select a page window, select the Options.  

7. Set the Compatibility level to SQL Server 2008 (100). 

8. Click Ok to create the database. 
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To configure the Econfig databases: 

1. Econfig database 

a. Name the new database Econfig. 

b. Set the Initial Size for Econfig_log database file to 5 MB. 

2. ECONFIGD database 

a. Click Add to create a new Database file in the table. 

b. Change the Logical Name of this new file to ECONFIGD. 

c. Set the Initial Size for the ECONFIGD database file to 40 MB. 

d. Click the Filegroup column and use the pull-down to select <new 
filegroup>. 

e. Name the new file group ECONFIGD. 

3. ECONFIGI database 

a. Click Add to create another new Database file. 

b. Change the Logical Name of this file to ECONFIGI. 

c. Set the Initial Size of ECONFIGI to 10 MB. 

d. Click the Filegroup column and use the pull-down to select <new 
filegroup>. 

e. Name this new file group ECONFIGI. 

4. Set the compatibility level to SQL 2008 (100) 
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To create users: 

Once both databases are completed you can create users. 

1. In the Object Explorer, expand the Security folder. 

2. Right-click Logins and choose New Login. 

 

3. On the General page, in Login name, type Emonitor. 

4. Select SQL Server authentication. 

5. In Password, type the password for the Emonitor Login name. 

6. In Confirm password, type the password again. 

7. Clear the Enforce password policy check box. 
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8. In Default database select Emonitor. 

 

9. Select the User Mapping page. 

10. In the Map column, select the check box corresponding to 
the Emonitor database. 
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11. In the Database role membership for: Emonitor area, select db_owner. 

 

12. Click OK. 

13. Repeat this process to create an econfig user, mapped to the Econfig 
database, with a database role of db_owner for the EConfig database. 

Important: Before you can complete the rest of the database configuration steps you 
must install Emonitor. 
See Install Emonitor on page 25. 

Next, follow the instructions to install Emonitor, which will eventually lead 
to Configure the databases on page 17. 
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A database creation script must be run in order to configure the structure of the 
Emonitor and EConfig databases. If the two databases already exist, these steps 
can be ignored. 

Important: The database creation scripts are installed with the Emonitor software. Emonitor must be 
installed before the database creation scripts are run. 

 

To run the database creation script: 

The scripts may need to be modified to use the correct Group names. Change all 
references to "ON EmonitorI", "ON EmonitorD", "ON ECONFIGI", and "ON 
ECONFIGD" to their appropriate names. If your database administrator chooses 
not to use file groups, the database creation scripts must be edited in order to 
remove these references entirely. 

1. Click Start and then select Microsoft SQL Server Management Studio. 

2. Select File > Open > File… and then select SQL Server files for Files of 
type. Then select the Emonitormsq.sql script file, located in the Emonitor 
program directory: 

C:\Program Files\Rockwell 
Software\Emonitor\Emonitormsq.sql 

 

Configure the databases 
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3. On the toolbar, select Emonitor as the database from the Available 
Databases pull-down menu as shown in the following image. 

 

4. Select Query > Execute, or press F5. This creates the Emonitor database 
structure. 

5. Next, open and run the EConfig creation script, cfgmsq.sql, located in the 
following directory. This creates the EConfig database structure. 

C:\Program Files\Rockwell 
Software\Emonitor\cfgmsq.sql 

6. On the toolbar, select Econfig as the database from the Available 
Databases pull-down menu. 

7. Select Query > Execute, or press F5. This creates the Econfig database 
structure. 

The databases have now been structured. See the section Import initial database 
data on page 19 to continue the installation. 
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After running the database creation scripts, the data must be imported into the 
tables.  

If upgrading from a previous version of Emonitor with a pre-existing Emonitor 
database, do not import the data files as described in this section, the Emonitor 
data files already exist in the database. 

Important: This procedure must be done after installing Emonitor because the data import utility 
provided with the installation is required. It must be done before starting Emonitor for the 
first time, but after the database creation scripts have been run.  
See the section Install Emonitor and supporting applications on page 23 for information on 
installing Emonitor.  

To import the data: 

1. On the Emonitor client machine, select Start > All Programs > Rockwell 
Software > Emonitor > Utilities > Emonitor Import-Export Utility. 

2. From the Options menu, choose Import. Choose the following settings for 
each field and then click Ok. 

a. Leave Database blank. 

b. For Username, enter the username associated with the Emonitor 
database (which defaults to ‘Emonitor’). 

c. For Password, enter the password for the chosen username. 

d. For DBServer, enter the connection string for the database. This is the 
"Server alias" from the Microsoft SQL Server Client Network Utility. 

 

Import initial database 
data 
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3. From the File menu, choose Import Database. Select Emonitor.dbu and 
choose Open. The file is located here: 

C: Program File\Rockwell Software\Emonitor\ 

4. Once the import processes completes (which may take some time), repeat 
steps 1 through 3 for the econfig.dbu file (using the ‘econfig’ username and 
the matching password in step 2). 

Tip: If the database server is installed on a separate computer from the Emonitor computer, this will be 
the first time that the client computer will attempt to contact the server. If the client computer cannot 
connect to the server, ensure that the correct credentials are being used and that the database server 
is configured to allow TCP/IP connections. Consult the SQL Server 2012 documentation for more 
information. 

When both imports are complete, Emonitor can connect to the database after it 
launches. 
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Chapter 3 

Install Emonitor and supporting applications 

This section describes the process for a new installation of Emonitor 4.0. If 
upgrading from an existing version, refer to the section Upgrade from a previous 
version of Emonitor on page 35. 

Emonitor is activated using license files. As part of the Emonitor installation 
process, FactoryTalk Activation Manager must be installed. For more information 
on FactoryTalk Activation, refer to the FactoryTalk Activation documentation. 
To display the documentation, follow these steps: 

1. Insert the Emonitor Installation DVD into the DVD drive of the
computer. It should auto-start and display the Autorun screen. If the
Autorun screen does not appear, start Windows Explorer and navigate to
the DVD drive. Double-click autorun.exe on the Emonitor DVD to run
the installation program.

Tip: If the installation DVD drive is on another computer, that drive must be mapped to a drive on the local 
computer. 

2. After the Autorun screen appears, click Documentation. The list of
available documentation appears in the computer’s default HTML browser.

3. Click FactoryTalk Activation.

4. After reviewing the FactoryTalk Activation documentation, return to the
Autorun screen.

Tip: Documentation included on the Emonitor Install DVD is in PDF format. To view PDF files, an 
appropriate viewer, such as Adobe® Reader®, must be installed. Adobe Reader can be installed by 
clicking Extras on the Emonitor Install DVD Autorun screen and then clicking Adobe® Reader®.  

5. From the Autorun screen, click FactoryTalk Activation to install the
FactoryTalk Activation Manager from the DVD drive.

6. When finished, click Back to return to the main Autorun screen.

Install FactoryTalk 
Activation Manager 
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Emonitor requires RSLinx Classic or Classic Lite to import measurements from 
certain online instruments: 

Use XM/DYN Online Data to import data from XM® and XM DYN modules 
into the Emonitor database 

Use Logix Online Data to import data from the Logix family of controllers into 
the Emonitor database. 

Tip: Install RSLinx Classic before installing Emonitor. RSLinx Classic installs the 
FactoryTalk Services Platform, which includes the latest Windows Firewall 
Configuration Utility. This utility configures the Windows firewall to work with 
Rockwell Automation products. 

To install the RSLinx software: 

Note: If RSLinx Classic or Classic Lite version 3.6, 3.70, or 3.74 is already installed, these steps 
may be skipped. 

1. From the Autorun screen, click RSLinx Classic. 

2. Follow the steps as directed by the RSLinx Classic installation wizard. 

3. Click RSLinx Classic and follow the directions that appear on the screen. 

4. When the installation is complete, return to the Autorun screen and 
continue the installation process. 

When installing Emonitor version 4.0 on the Windows 7 Professional, Enterprise, 
or Ultimate operating system, no additional software is required for the CMMS 
XML Gateway. 

 

Install RSLinx Classic 

Install the CMMS XML 
Gateway prerequisites 
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Chapter 4 

Install Emonitor 

This installation is intended for first-time installations. If upgrading from a 
previous version of Emonitor, see the section Upgrade from a previous version of 
Emonitor on page 35 

Tip: The CD Activation Key that was used to define the available features in Emonitor 3.00 and earlier versions has 
been replaced by FactoryTalk Activation described in the section Install FactoryTalk Activation Manager on page 
23. 

Portable systems use walk-around data collectors for collecting data, and all 
Emonitor components can be installed on one computer. Online systems use 
networked systems that monitor and collect data, and Emonitor can be installed 
on different computers to increase efficiency. Installations may also use a 
combination of portable and online systems, and use different computers for each 
part. 

This section describes the installation step-by-step with specific information 
available when needed. This section goes through a typical installation for a 
portable system. 

To install the Emonitor system: 

1. Exit any running applications before starting the Emonitor installation
program.

Important: The Emonitor installation program requires a reboot of the computer after 
installing the software. 

2. If they do not already exist, create the Emonitor vibration and configuration
databases. For more information on how to do so, see Create the databases.
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3. From the main Autorun screen click Emonitor. Follow the instructions on 
the screen. Alternatively, navigate to the installation media, right-click on 
the setup.exe file, and select Run as Administrator. 

 

4. The installer will automatically check for the presence of Microsoft.NET 
Framework 4.5.1. 

• If the required version of .NET Framework is detected, the installer will 
proceed directly to the next relevant step. 

• If the required version of .NET Framework is not installed, the 
following window will be displayed. Click Install. 
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5. The End User License Agreement will be displayed. Review the agreement 
and, if agreeing to the terms, select Yes. 

 

6. The next dialog shows the results of a system requirements test. Click Next. 
See System requirements on page 7 for more information. 

7. Choose the directory where Emonitor will be installed. Click Browse to 
change the destination directory. 

8. Select the program folder on the Start menu for Emonitor, then click Next. 

9. Click Next to accept the configuration. The installation program begins 
copying files to the computer. 
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10. The installation program installs the Windows Firewall Configuration 
Utility. The Firewall Configuration program then runs to automatically 
modify the Windows Firewall settings to allow the following components 
to communicate with Emonitor: Emonitor OPC Enumerator, SQL Server, 
DCOM, Enlive, and the Emonitor Online programs (Enwatch Setup, 
Online Data Console, Create Loadfile, Load and Unload). Then the 
DCOM Security configuration program runs to complete the 
modifications. 

Tip: The message "The Windows Firewall configuration interface is unavailable" might 
appear if the Windows Firewall is disabled. If another software or hardware 
firewall is being used, it might need to be manually configured it to allow the 
Emonitor programs to communicate. 

11. On the Vibration database screen, enter the connection information for the 
Emonitor database. Click Next to continue. 
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12. On the Configuration database screen, enter the connection information 
for the EConfig database. Click Next to continue. 

Important: If incorrect information is entered in step 10 or 11, the next time Emonitor is started, the program 
will display a database connection error message. Click Retry and enter the correct information 
(connect string, username, and password). Due to enhanced security in Emonitor versions 3.40 and 
later, the password is encrypted and can no longer be edited in the Registry. 

13. After a few processes run, the following warning will be displayed. Allow the 
system to reboot by selecting OK. 

 

At this point, the installation of Emonitor is complete. However, before running 
Emonitor for the first time, the databases must be configured and loaded with 
data. If working Emonitor databases already exist, these steps do not need to be 
followed. The scripts to create the databases are installed with Emonitor, so they 
can only be run after installing Emonitor. See Configure the databases on page 
17 and Import initial database data on page 19 for further details. 

To import data from XM or XM DYN modules into Emonitor, the EDS files 
must be properly registered in RSLinx. EDS files are simple text files that are used 
by network configuration Tools such as the Emonitor Online Configuration 
Utility to describe products so that they can be easily commissioned on a network. 
EDS files describe a product device type, revision, and configurable parameters. 

To install the EDS files: 

1. Start the EDS Hardware Installation Tool. Click Start > All Programs > 
Rockwell Software > RSLinx > Tools > EDS Hardware Installation 
Tool. 

2. In the EDS Hardware Installation Tool, click Add. 

3. Select Register a directory of EDS files. 

4. Click Browse, and navigate to the Emonitor program directory and click 
OK. The default directory is: 

C:\Program Files\Rockwell Software\Emonitor 

Install the EDS files 
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5. Click Next. The Tool installs all the EDS files in the Emonitor program 
directory. Some EDS files may show minor errors that do not have any 
functional impact, such as "The help string has exceeded the maximum 
length." Click Next. 

6. Continue to click Next to complete the EDS Wizard, and finally click 
Finish. 

The Scheduler program can be used to automate many data-related tasks. A task 
automated in Scheduler is called an event. A Scheduler profile defines not only the 
event, but also when and how often the event should occur. The Scheduler has 
two parts: 

• The Scheduler program allows for the creation and editing of profiles. 

• The Scheduler service that runs in the background and launches (executes) 
the scheduled profiles. The Scheduler service must be running in order to 
execute scheduled profiles. 

The Emonitor Scheduler service is disabled by default. In order to launch (run) 
scheduled tasks, including importing data, it must be enabled. 

To start the Scheduler service: 

Note: The following steps require Administrator rights on the machine that will run the 
Scheduler service. 

1. Click Start > Control Panel > Administrative Tools > Services. 

2. Select Services (local) in the left side of the Services window. 

3. Select EmonitorScheduler in the right side of the Services window. 

4. The EmonitorScheduler Startup Type should be Automatic. If it is 
Manual or Disabled, right-click on EmonitorScheduler and select 
Properties. In the Properties dialog box, set Startup Type to Automatic, 
and then click OK. 

5. The EmonitorScheduler Status should be Started. If it is Stopped (or not 
showing a status), right-click on EmonitorScheduler and select Start. 

Tip: It is strongly recommended that the Startup Type for the Emonitor Scheduler be 
set to "Automatic" in the services console. This starts the Scheduler service 
automatically when Windows starts. 

 

Set up scheduler to 
automate tasks 
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After enabling the Scheduler service it will start when Windows starts. Scheduled 
events are executed only when the Scheduler service is running. 

Scheduler can be used on any computer in an Emonitor Online system (both 
Viewing station and Unload station computers). 

The Emonitor Scheduler is installed as part of the Emonitor software. Since 
Scheduler profiles are stored in the central Emonitor database, all scheduler 
profiles are launched on all computers in an Emonitor Online system that are 
running the Scheduler service. This may not be a problem when using Scheduler 
only for data import tasks on one or two computers. However, if Scheduler is used 
for additional kinds of tasks, such as Emonitor database maintenance, running the 
same scheduled task from multiple computers can place a significant load on the 
Database Server computer. Refer to the Scheduler help for more information 
(Start > All Programs > Rockwell Software > Emonitor > Help > Scheduler). 

To set up additional online profiles: 

These steps show how to set up two different online profiles. The first is the 
Online Import Event, which looks for unload files (containing data from the data 
collection instruments) in the unload directory and sends the information to the 
Emonitor database. The second is the Storage Limit Updater, which allows the 
limiting of data storage to specific parameters and specify a time during low 
database usage, saving dis space and time (a database maintenance task). Follow 
these steps to set up online profiles using Scheduler. 

Tip: For more information on setting up different kinds of Scheduler profiles, refer to 
the Scheduler online help. 

1. Start Scheduler (Start > All Programs > Rockwell Software > Emonitor > 
Utilities > Scheduler) and click Add. 
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2. On the Profile dialog, enter the Profile Name, such as Storage Limit 
Updater or Online Import Event. If desired, enter notes about the profile as 
well. Check the box beside Enable profile for scheduling. Click Next to 
continue. 

3. On the Response dialog, select Scheduled time/date/frequency. 

• For the Storage Limit Updater, click Next and then skip to step 7. 
• For the Online Import Event, select File change notification and 

click Settings. 

4. Click Add File. Select the UD directory under the Emonitor program 
directory. In the File name box, enter *.ulf. This tells Scheduler to look for 
unload files in the unload directory. Click Open. 

5. The unload files appear in the Monitored Files list. Click OK to continue. 

6. Click Next on the Response dialog. 

7. On the Events dialog, click Add Event. 

8. Enter the Executable file and the Command line using the following 
guidelines, then click OK.  

Note: This example used the default Emonitor installation directory. If Emonitor was installed in 
a different directory, use the path of the Emonitor program directory. 

For Online Import Event 

Executable file: 

C:\Program Files\Rockwell 
Software\Emonitor\didaemon.exe 

Command line: 

C:\Program Files\Rockwell 
Software\Emonitor\odonline.edi 

For Storage Limit Updater 

Executable file: 

C:\Program Files\Rockwell 
Software\Emonitor\stglimit.exe 
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Command line (must be one of the following): 

/all  Remove all measurement data, system event log data and alarm event log data outside the 
storage limits. 

/list “list name" Remove measurement data which are saved to a list with "list name" and are outside the 
storage limits.  

/alarm Remove alarm event log data outside the storage limits. 

/system Remove system event log data outside the storage limits. 

9. Click Next to continue. 

10. On the Frequency dialog, set the Date and Time desired for launching the 
profile. Click Finish. 

The profile is now added to Scheduler. The executable file and command line 
information for the various database import and update programs is also included 
in the online help for the Scheduler program. Scheduler help can be displayed by 
pressing F1, or from the Start menu (Start > Programs > Rockwell Software > 
Emonitor > Help > Scheduler). 

More information on using the Scheduler in an Emonitor Online system can be 
found in the help for the Online Data Management Console. Click Start > 
Programs > Rockwell Software > Emonitor > Help > Online Data 
Management Console to access this help. 

 





Rockwell Automation Publication EMONTR-IN005A-EN-E 35 

Chapter 5 

Upgrade from a previous version of Emonitor 

This chapter describes the process of upgrading from an earlier version of the 
Emonitor software to Emonitor 4.0. 

When upgrading from Emonitor 3.60 or 3.70 running on Windows 7, much of 
the work required to preserve settings and configuration files is performed 
automatically by the installer. 

Important: Emonitor 3.7 users that have previously installed the Emonitor RTA and DDM utilities must 
uninstall that software and reboot their computer prior to installing Emonitor 4.0. 

Upgrade from Emonitor 3.6 
or 3.7 
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Upgrading from a previous version of Emonitor is very similar to the process 
outlined in Install Emonitor on page 25 with a few minor differences. 

Tip: During the installation of Emonitor 4.0, the instructions refer to the vibration database as the Emonitor database. 
Note that in Emonitor version 3.7 and earlier, this database was referred to as the Entek database.  
Simply substitute the login credentials for the already established Entek database any time the Emonitor 
database is referenced. There is no need to rename the database. 

To upgrade the software: 

After Microsoft.NET Framework 4.5.1 has been installed, the following screen 
will be displayed with options for how to perform the upgrade. 

 

To upgrade all components: 

1. Select Upgrade all components installed by the previous setup to 
proceed automatically. 

2. On the next screen, enter a location for the old Emonitor configuration files 
to be backed up to. Click Next. 

3. The following screen will list the files to be backed up. Click Next. 

4. The next screen will show the results of the backup operation and list any 
errors. Click Next. 

5. The older version of Emonitor will now be uninstalled. Once this is 
complete, the computer will need to be rebooted. 



 Upgrade from a previous version of Emonitor                  Chapter 5 

 

 Rockwell Automation Publication EMONTR-IN005A-EN-E 37 

6. Upon rebooting, a message should appear asking whether to proceed with 
the upgrade. Choose Yes. Choosing No will require settings to be restored 
manually at the end of the installation.  

 

7. Installation will proceed as outlined in Install Emonitor on page 25. If you 
opted to use the previous Emonitor settings the system will automatically 
restore the configuration files as a part of the process. 

8. After installation is complete, the database will need to be restructured 
before the new version of Emonitor can be used. See the section Restructure 
the database. 
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To uninstall all components: 

1. Select Uninstall all components to remove the old Emonitor without 
automatically upgrading. 

After selecting this option, the option will be given to back up the old 
configuration files, as shown below. If the save operation is not performed 
the uninstall will proceed and the computer will reboot. 

 

2. On the next screen, enter a location for the old Emonitor configuration files 
to be backed up to. Click Next. 

3. The following screen will list the files to be backed up. Click Next. 

4. The next screen will show the results of the backup operation and list any 
errors. Click Next. 

5. The computer will reboot. 

6. After the reboot, proceed as outlined in the section Install Emonitor 
on page 25. If old configuration files were backed up, they can be manually 
restored after the database has been restructured. 

See Restructure the database on page 40 and Restore Emonitor configuration files 
on page 42 for more information on reinstalling Emonitor. 
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Emonitor version 4.0 runs only on 32-bit versions of the Windows 7 operating 
system. This means that a direct upgrade from versions 3.50 and earlier of 
Emonitor is not possible; instead, Emonitor version 4.0 must be installed on a 
computer running Windows 7 and the configuration files copied over. 

Scheduler, Enwatch Online Data, XM/DYN Online Data, Enterprise Online 
Configuration Utility, and Emonitor OPC Client configuration files from 
previous versions of Emonitor should work with the new version of Emonitor. 
New data sources will need to be created in the Online Data Management 
Console after the upgrade. For more information, refer to the Online Data 
Management Console after completing the upgrade (click Start > Programs > 
Rockwell Software > Emonitor > Help > Online Data Management Console). 

To upgrade from Emonitor 3.50 or earlier:  

Note: If upgrading from a version of Emonitor prior to 3.20, please contact Customer Support for 
assistance. See Contact us on page 10 for contact information. 

1. Migrate older Emonitor SQL databases to a Microsoft SQL Server 2012 
implementation accessible from the Windows 7 PC on which Emonitor 4.0 
will be installed. 

2. Install Emonitor version 4.0 on a computer running Windows 7. See Install 
Emonitor on page 255 for more information. Note that in older versions of 
Emonitor, the vibration database was referred to as the Entek database. 
There is no need to rename this database for Emonitor 4.0. Instead, simply 
substitute the Entek database connection information whenever the 
Emonitor database connection information is called for. 

3. Move the existing Emonitor configuration files to the computer where 
Emonitor version 4.0 is installed. See Manually back up Emonitor 
configuration files on page 39 and Restore Emonitor configuration files 
on page 42. 

Emonitor uses configuration files that are stored outside of the Emonitor 
database.  

These files contain the settings for a number of Emonitor programs, including: 

• Scheduler 

• Emonitor Online Hardware Setup 

• XM Emonitor Gateway 

• Enterprise Online Configuration Utility 

• Emonitor OPC Client 

Upgrade from Emonitor 
3.50 or earlier 

Manually back up Emonitor 
configuration files 
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To use these configuration files with Emonitor version 4.0, they must be copied 
from their current Emonitor installation to the computer running Emonitor 
version 4.0. 

The default directories for the configuration files are listed below. If different 
directories have been used, make sure that those directories are backed up, as well. 

Files Default directories 

DCF Files (Windows XP) For Emonitor Online: 
C:\Program Files\Rockwell Software\Emonitor\[PROFILE_NAME].DCF 

EOL Files (Windows XP) For Emonitor Online: 
C:\Program Files\Rockwell Software\Emonitor\[PROFILE_NAME].EOL 

OnlineDataConsole.XML (Windows XP) C:\Windows\system32\OnlineDataConsole.XML 

Templates (Windows XP) C:\Program Files\Rockwell Software\Emonitor\English Templates 
C:\Program Files\Rockwell Software\Emonitor\Metric Templates 

Load and Unload directories (Windows XP) C:\Program Files\Rockwell Software\Emonitor\LD 
C:\Program Files\Rockwell Software\Emonitor\UD 

Online directory (Windows XP) C:\Program Files\Rockwell Software\Emonitor\Online 

INI, EDI and EAX Files (Windows XP) C:\Program Files\Rockwell Software\Emonitor\LD 
C:\Program Files\Rockwell Software\Emonitor\UD 

Online directory (Windows XP) C:\Program Files\Rockwell Software\Emonitor\ 

New EDS files are installed with Emonitor 3.6 or later on a computer running 
Windows 7; however, any custom EDS files must be backed up manually. 

 

After any upgrade, the database must be restructured. This adds the necessary data 
and structure information to the current database, allowing it to run the new 
version of the program. When first starting Emonitor, the restructure program 
automatically starts if it is needed. 

Important: Make sure to follow these steps before restructuring the databases. 

• Back up the databases. 

• Unload any data collectors. 

• Disconnect all users from the database. 

If upgrading from Emonitor version 3.30 or earlier, the files in the \Restruct folder 
must be renamed from *.msq to *.sql (on the computer where Emonitor was 
installed). Failing to rename the restructure files will cause the database restructure 
process to fail. 

Restructure the database 
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To restructure the database: 

1. Start the Emonitor software from the Start menu on any client computer 
(Start > Programs > Rockwell Software > Emonitor > Emonitor). 
Click Yes to update the database. 

The default Admin username and password are "admin" and "password". 

 

2. Click Restructure to begin the update process. 

 

3. Make sure the database has been backed up, then click OK to continue. 

4. Make sure that no users are still attached to the database, then click OK to 
continue. 

Important: Allow plenty of time to restructure the database. It might appear to stop or be locked up, and stay at 99% 
for a long time. Do not try to restart the computer during restructure – just be patient and let the 
program finish. 

5. When the process is finished, click Close. The new version of Emonitor can 
now be run. 
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After restoring the Emonitor database files, restore the Emonitor configuration 
files. 

Important: Note that the default directories for Emonitor configuration files on Windows 7 are different than they 
were on previous versions. 

DCF Files (Windows 7): 

C:\Users\Public\Documents\Rockwell 
Software\Emonitor\[PROFILE_NAME].DCF 

OnlineDataConsole.XML (Windows 7): 

C:\Users\Public\Documents\Rockwell 
Software\Emonitor\OnlineDataConsole.XML 

Tip: Edit the XML files and change all instances in the document from: 
<XMProfile>C:\Program Files\Rockwell 
Software\Emonitor\ 

to: 

<XMProfile>C:\Users\Public\ 
Documents\Rockwell Software\Emonitor\ 

Templates (Windows 7) 

C:\Users\Public\Documents\Rockwell 
Software\Emonitor\Templates\English 

C:\Users\Public\Documents\Rockwell 
Software\Emonitor\Templates\Metric 

Load and Unload directories (Windows 7) 

C:\Users\Public\Documents\Rockwell Software\Emonitor\UD 

C:\Users\Public\Documents\Rockwell Software\Emonitor\ld 

Online directory (Windows 7) 

C:\Users\Public\Documents\Rockwell Software\Emonitor\Online 

EDS files are installed with Emonitor 3.60. If any custom EDS files were backed 
up, restore them to: 

C:\Program Files\Rockwell Software\Emonitor\ 

INI, EDI and EAX Files (Windows 7) 

C:\Program Files\Rockwell Software\Emonitor\ 

Note: This is the same directory as for Emonitor 3.5 

 

Restore Emonitor 
configuration files 
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After restoring the odonline.edi file, it must be edited to update the path 
information. 

To edit the odonline.edi file: 

1. Shut down Emonitor if it is running. 

2. Open C:\Program Files\Rockwell Software\Emonitor\odonline.edi with 
Windows Notepad or another text editor. 

3. Edit C:\Program Files\Rockwell Software\Emonitor\odoonline.edi as 
follows: 

[Source] 

DataFileConfigFile=C:\Program Files\Rockwell 

Software\Emonitor\odonline.ini 

DataFileDir=C:\Users\Public\Documents\Rockwell 

Software\Emonitor\ud 

DataFiles=C:\Users\Public\Documents\Rockwell 

Software\Emonitor\ud\*.ulf 

[Options] 

BackupPathnameOnError=C:\Users\Public\Documents\Rockwell 

Software\Emonitor\online\backup\ 

LogFilePathname=C:\Users\Public\Documents\Rockwell 

Software\Emonitor\online\online.log 

Change paths in 
odonline.edi 
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To restart the Scheduler and Emonitor Online services: 

1. Click Start > Control Panel > Administrative Tools > Services to open 
the Services snap-in. 

2. In the Navigation pane, select Services (local). 

3. In the Details pane, select EmonitorScheduler. 

4. If the EmonitorScheduler status is Started, right-click EmonitorScheduler 
and select Restart. 

5. In the Details pane, select EmonitorOnline. 

6. If the EmonitorOnline status is Started, right-click EmonitorOnline and 
select Restart. 

7. After restarting, both services should have a status of Running. 
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Rockwell Automation support 

Rockwell Automation provides technical information on the web to assist you in using its products. 
At http://www.rockwellautomation.com/support you can find technical and application notes, sample code, and links to software service packs. You 
can also visit our Support Center at https://rockwellautomation.custhelp.com for software updates, support chats and forums, technical 
information, FAQs, and to sign up for product notification updates. 

In addition, we offer multiple support programs for installation, configuration, and troubleshooting. For more information, contact your local 
distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/services/online-phone. 

Installation assistance 

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can contact 
Customer Support for initial help in getting your product up and running. 

United States or Canada 1.440.646.3434 

Outside United States or Canada Use the Worldwide Locator available at http://www.rockwellautomation.com/locations, or contact your local Rockwell 
Automation representative. 

New product satisfaction return 

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. However, if 
your product is not functioning and needs to be returned, follow these procedures. 

United States Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to 
your distributor to complete the return process. 

Outside United States Please contact your local Rockwell Automation representative for the return procedure. 

Documentation feedback 

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, complete the 
feedback form, publication RA-DU002 http://literature.rockwellautomation.com/idc/groups/literature/documents/du/ra-du002_-en-e.pdf. 

http://www.rockwellautomation.com/support
https://rockwellautomation.custhelp.com/
http://www.rockwellautomation.com/services/online-phone
http://www.rockwellautomation.com/locations
http://literature.rockwellautomation.com/idc/groups/literature/documents/du/ra-du002_-en-e.pdf
http://literature.rockwellautomation.com/idc/groups/literature/documents/du/ra-du002_-en-e.pdf
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