Installation and Upgrade Guide

FactoryTalk® Batch Components
Important User Information

Solid-state equipment has operational characteristics differing from those of electromechanical equipment. Safety Guidelines for the Application, Installation, and Maintenance of Solid State Controls (publication SGI-1.1 available from your local Rockwell Automation sales office or online at http://www.rockwellautomation.com/literature/) describes some important differences between solid-state equipment and hard-wired electromechanical devices. Because of this difference, and also because of the wide variety of uses for solid-state equipment, all persons responsible for applying this equipment must satisfy themselves that each intended application of this equipment is acceptable.

In no event will Rockwell Automation, Inc. be responsible or liable for indirect or consequential damages resulting from the use or application of this equipment.

The examples and diagrams in this manual are included solely for illustrative purposes. Because of the many variables and requirements associated with any particular installation, Rockwell Automation, Inc. cannot assume responsibility or liability for actual use based on the examples and diagrams.

No patent liability is assumed by Rockwell Automation, Inc. with respect to use of information, circuits, equipment, or software described in this manual.

Reproduction of the contents of this manual, in whole or in part, without written permission of Rockwell Automation, Inc., is prohibited.

Throughout this manual, when necessary, we use notes to make you aware of safety considerations.

WARNING: Identifies information about practices or circumstances that can cause an explosion in a hazardous environment, which may lead to personal injury or death, property damage, or economic loss.

ATTENTION: Identifies information about practices or circumstances that can lead to personal injury or death, property damage, or economic loss. Attentions help you identify a hazard, avoid a hazard, and recognize the consequence.

SHOCK HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that dangerous voltage may be present.

BURN HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that surfaces may reach dangerous temperatures.

Important: Identifies information that is critical for successful application and understanding of the product.
# Table of contents

## Chapter 1

### How to use these installation instructions

- Get started .............................................................................................................................. 7
- Select instructions for each computer ................................................................................ 8
  - Examples ............................................................................................................................ 8
- Additional resources .......................................................................................................... 8
- What is new in this release? ............................................................................................... 9
  - FactoryTalk Batch enhancements .................................................................................. 9

### FactoryTalk Batch system overview

- Server placement guidelines ............................................................................................. 12

### System requirements overview

- Windows Server configuration requirements .................................................................. 15
  - DEP settings .................................................................................................................... 16

## Chapter 2

### Pre-installation administrative tasks

- Administrator privileges on target computer ................................................................. 17
- Security accounts .............................................................................................................. 18
- Enable the Windows Firewall ............................................................................................ 19
- Windows Workgroup ......................................................................................................... 20
  - Windows accounts ......................................................................................................... 20
  - Add an incoming firewall rule ......................................................................................... 20
  - Disable Administrative Approval Mode ......................................................................... 21
- Configure the Remote Registry on a Windows desktop operating system .................... 22
- System date and time ........................................................................................................ 22
- Event log settings ............................................................................................................. 23
- SQL Server installation ...................................................................................................... 23
  - Configure Reporting Services for FactoryTalk Event Archiver ................................ 25
  - Configure SQL Server 2016 for Reporting Services ..................................................... 26

## Chapter 5

### Install FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver

- Pre-installation configuration .......................................................................................... 30
  - Configure the Windows Server operating system for the Batch and eProcedure Servers ................................................................. 30
  - Configure the Windows Server 2016 operating system for the eProcedure Server ......................................................................................... 32
  - Configure the Windows desktop operating system for the Batch and eProcedure Servers ......................................................................................... 33
Table of contents

Allow Active Server Pages........................................................................................................ 35
Install FactoryTalk Batch .......................................................................................................... 35
Post-FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver installation ................................................................................................................................. 37
Configure SQL Server to enable FactoryTalk Event Archiver with Reporting Services ......................................................................................................................... 37
Configure SQL Server 2014 or SQL Server 2016 to enable FactoryTalk Event Archiver with Reporting Services ............................................................................ 39
FactoryTalk Batch directory on the SQL Server computer ............................................ 40
Shared directory ................................................................................................................. 40
Server options .................................................................................................................. 40
Redundant servers (optional) .......................................................................................... 40
Area model in the FactoryTalk Batch Equipment Editor ...................................... 40
Create recipes in FactoryTalk Batch Recipe Editor .............................................. 41
Start or restart the FactoryTalk Batch Server ......................................................... 41
Security on Logs and Journals folders ........................................................................... 42
Set the Internet Explorer home page for eProcedure Clients ........................................... 42
Configure Compatibility View settings ........................................................................... 43

Chapter 6
Install FactoryTalk Batch Client components

Install the FactoryTalk Batch Client.................................................................................... 46
Post-FactoryTalk Batch Client component installation ...................................................... 47

Chapter 7
Install eProcedure Client components

Implementation recommendations for eProcedure Clients ................................................ 50
Install the eProcedure Client ............................................................................................ 51
Correct error messages seen when view eProcedure pages in Internet Explorer ............... 52
Configure Internet Explorer compatibility view settings ................................................. 53

Chapter 8
Install FactoryTalk Batch Material Manager Server components

Pre-installation configuration ............................................................................................... 55
Configure Microsoft Queuing Service and COM+ Network Access for Material Server ......................................................................................................................... 56
Install the Material Manager Server .................................................................................. 57
Post-Material Manager Server installation ......................................................................... 58
Start or restart the FactoryTalk Batch Server ................................................................. 58
Identify the material database ......................................................................................... 59
# Table of Contents

## Chapter 9
Install the Material Manager Client ................................................................. 61

## Chapter 10
Cumulative unit licensing .................................................................................. 64

## Chapter 11
Pre-upgrade tasks ............................................................................................... 67
- Allow the Message Queue to clear for Material Manager .......................... 67
- Export XML or RDB recipes to binary ......................................................... 68
- Back up files ................................................................................................. 69
- Uninstall the previous version of FactoryTalk Batch ................................. 70
- Restore back up files .................................................................................. 72
- Migrate area models from FactoryTalk Batch version 13.0 ...................... 73
- Migrate recipes from FactoryTalk Batch version 12.01 ............................ 74
- Convert binary recipes to XML or RDB ...................................................... 75
  - Convert migrated recipes back to XML format (optional) ....................... 76
  - Convert migrated recipes back to RDB format (optional) ....................... 77
- Recipe storage .............................................................................................. 77

## Chapter 12
Uninstall the FactoryTalk Batch System ............................................................. 79
- Uninstall the FactoryTalk Batch components ............................................ 80
- Uninstall Material Manager ....................................................................... 80
- Delete the default directories (optional) .................................................... 81
- Delete databases (optional) ....................................................................... 82

## Chapter 13
- Manually configure the Windows Firewall ............................................... 83
- Define or reset a disabled FactoryTalk Administrator account ............... 84
- Communication with Batch Server times out ........................................... 85
- Configure Internet Explorer security settings for Trusted Sites ............ 85
- Internet Explorer’s intranet zone ............................................................... 86
- Run as Administrator on eProcedure Client on Windows Server operating systems ................................................................. 86
- Manually recreate the masterrecipes database ........................................ 86
- Legal Notices .............................................................................................. 89

## Legal Notices

## Index
Chapter 1

How to use these installation instructions

These instructions provide information and procedures for the installation and upgrade of a FactoryTalk® Batch system:

- FactoryTalk Batch
- FactoryTalk eProcedure*
- FactoryTalk Event Archiver Database, with Batch Reports and Database Management Tool
- FactoryTalk Batch Material Manager

Get started

Before installing the FactoryTalk Batch components, read the following sections to become familiar with the new features and system requirements for FactoryTalk Batch version 13.00.02.

- How to use these installation instructions
- What is new in this release?
- System requirements
- FactoryTalk Batch components system overview

The What is new in this release? section lists the FactoryTalk Batch components that can be customized for the installation.

Review the System requirements overview section for important hardware, software, and operating system requirements in version 13.00.02.

The FactoryTalk Batch components system overview section outlines server placement guidelines and information about implementing the FactoryTalk Batch system.

If upgrading earlier versions of FactoryTalk Batch components to a later version, refer to the Upgrade FactoryTalk Batch components section.

See also

What is new in this release on page 9
Chapter 1

How to use these installation instructions

System requirements overview on page 13

FactoryTalk Batch components system overview on page 11

Upgrade FactoryTalk Batch components on page 67

Select instructions for each computer

Based on the FactoryTalk Batch system configuration, follow the instructions for each computer in the system, or repeat the instructions for several computers.

For example, if the FactoryTalk Batch system includes a FactoryTalk Batch Server and several FactoryTalk Batch Clients, determine which components to install on each computer.

These documents contain additional information concerning related Rockwell Automation products.

Examples

Additional resources

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FactoryTalk Batch Administrator Guide</td>
<td>Instructions for configuring security and services, and implementation and use of components not normally accessed or used by batch operators, such as the FactoryTalk Batch Server.</td>
</tr>
<tr>
<td>FactoryTalk eProcedure Administrator Guide</td>
<td>Procedures specific to FactoryTalk eProcedure, such as implementing security and configuring the user-defined area active server page. Included are instructions for tasks specific to FactoryTalk Batch, such as configuring security and services to support eProcedure. Provides instructions on the implementation and use of components not normally accessed or used by batch operators, such as the FactoryTalk Batch Server.</td>
</tr>
<tr>
<td>FactoryTalk Batch Material Manager Administrator Guide</td>
<td>Information and instructions specific to FactoryTalk® Batch Material Manager. Intended for use by the system administrator and database administrator.</td>
</tr>
<tr>
<td>FactoryTalk Event Archiver User Guide</td>
<td>Information and procedures to configure the FactoryTalk® Event Archiver and the SQL server either with or without reporting services.</td>
</tr>
</tbody>
</table>

View or download publications at
http://www.rockwellautomation.com/literature. To order paper copies of technical documentation, contact the local Rockwell Automation distributor or sales representative.
What is new in this release?

There are new features and enhancements for the FactoryTalk Batch components, including FactoryTalk Batch, FactoryTalk eProcedure, FactoryTalk Batch Material Manager, and the FactoryTalk Event Archiver.

FactoryTalk Batch enhancements

Following are new or enhanced features of FactoryTalk Batch version 13.00.02:

New features

FactoryTalk Batch

- Two new reports (100-Operation Sequence and 110-Event Summary) have been added to this release. In addition, the Batch Detail, Batch Summary, Batch Execution, and Batch Exception reports now support operation sequence related event data.

  The 100-Operation Sequence report displays the association and Operation Sequence data for FactoryTalk Batch and SequenceManager events. The 110-Event Summary report displays a custom event summary based on report parameter filter selection.

FactoryTalk Batch Material Manager

- There are no new features for FactoryTalk Batch Material Manager version 13.00.02.

FactoryTalk eProcedure

- There are no new features for FactoryTalk eProcedure version 13.00.02.

Enhanced features

FactoryTalk Batch

- If auditing is enabled, users can route Batch audit messages to both FactoryTalk Administration Console and FactoryTalk Diagnostics local logs individually or at the same time. Batch audit messages are generated in two formats: Engineer Audit (for the local log) and Secure Audit (for FactoryTalk Administration Console).

FactoryTalk Batch Material Manager

- There are no new features for FactoryTalk Batch Material Manager version 13.00.02.
FactoryTalk eProcedure

- There are no new features for FactoryTalk eProcedure version 13.00.02.
Chapter 2

FactoryTalk Batch system overview

Review the FactoryTalk Batch components before setting up the FactoryTalk Batch system.

FactoryTalk Batch components are configurable products that help define, manage, monitor and control manufacturing at local or remote sites. A typical FactoryTalk Batch architecture consists of one or more computers on a single network. The following diagram gives an example of a possible FactoryTalk Batch network.

![Diagram of FactoryTalk Batch system](image)

1. Site Level
2. FactoryTalk Batch Material Manager Clients
3. FactoryTalk Batch Material Server
4. SQL Server
5. FactoryTalk Batch Clients
6. TCP/IP
7. Plant Floor
8. FactoryTalk eProcedure Clients
9. FactoryTalk Batch Server (1-10) and FactoryTalk eProcedure Server
10. FactoryTalk Batch Server connects to SQL Server for Master Recipe Storage
FactoryTalk Batch Clients
Proprietary Network
Process-Connected Device (PCD)
FactoryTalk Event Archiver Database

See also
System requirements overview on page 13
FactoryTalk Activation on page 63

Server placement guidelines

Consider the following guidelines when deciding where to place FactoryTalk Batch system servers on the network:

- Install the FactoryTalk eProcedure Server on the same computer as the FactoryTalk Batch Server.

- Install the FactoryTalk Batch Material Server on a computer with SQL Server. Do not install the Material Server on the same computer as the FactoryTalk Batch Server.

- A maximum of ten FactoryTalk Batch Servers can exist in a FactoryTalk Batch network.

- When installing FactoryTalk Event Archiver, use the remote server connection for the FactoryTalk Event Archiver Database and Management Tool on a different server from the FactoryTalk Batch Server.

See also
Windows Server configuration requirements on page 15
System requirements overview

The following are the minimum and recommended system requirements to successfully install, configure, and run FactoryTalk Batch components. These requirements assume that no other applications are on the computer, unless it is an application listed in this section.

**Hardware requirements**

- **Server requirements**
  - 4 GB of RAM
  - 60 GB free hard disk space
  - 2.8 GHz processor or greater, including hyper-threading models
- **Client requirements**
  - 2 GB of RAM
  - 30 GB free hard disk space
  - 2.6 GHz processor or greater

**Supported Microsoft operating systems (English only)**

- Windows Server 2008 R2 Service Pack 1, Standard or Enterprise (64-bit)
- Windows Server 2012 Standard Edition or DataCenter (64-bit)
- Windows Server 2012 R2 Standard Edition or DataCenter (64-bit)
- Windows Server 2016 Standard Edition or DataCenter (64-bit)
- Windows 7 Service Pack 1 Professional or Enterprise (32-bit and 64-bit)
- Windows 8.1 Professional or Enterprise (32-bit and 64-bit)
- Windows 10 Professional or Enterprise on version 1607 (64-bit)

**Firmware requirements**

The integration of SequenceManager requires Logix5000 v29 firmware or later for FactoryTalk Batch Components version 13.00.02.
Supported Microsoft applications

- Internet Explorer® 11 (32-bit)
- Microsoft SQL Server (For storing recipes, materials, or Batch reports):
  - SQL Server 2008 Service Pack 4 Standard Edition (32-bit, English version only)
  - SQL Server 2008 R2 Standard Edition (32-bit and 64-bit, English version only)
  - SQL Server 2012 Service Pack 2 (32-bit and 64-bit, English version only)
  - SQL Server 2014 Service Pack 1 (64-bit, English version only)
  - SQL Server 2016 (64-bit, English version only)

Supported Adobe® applications

- Reader® XI (11)

Supported Rockwell Software applications

- Logix5000 version 29 or later
- RSLinx® Classic version 4.00 or later
- RSLinx® Enterprise version 5.81 or later
- FactoryTalk® Activation version 4.00 or later
- FactoryTalk® Services Platform version 3.0 or later
- FactoryTalk® View Site Edition (SE) version 8.1 or later

Anti-virus software

All of the Rockwell Software products CPR 9 and newer support the Symantec™ 12.1.x protection program version that is available at the start of testing for a product release.

The Rockwell Software products are expected to be compatible with most anti-virus protections on the market. However, proper configuration is required. It is important to understand that any of these anti-virus protections can impact operation if the configuration is too restrictive. These configurations are generally in the area of firewalls, network threat protections, and access controls.

The warranty does not cover systems that do not meet the minimum requirements for the version of software.
Important: FactoryTalk Batch components for version 13.00.02 support only the *U.S. English* versions of operating systems. Install the English language version of Windows Server 2008, Windows Server 2012, or Windows Server 2016, SQL Server (if used), Windows 7, Windows 8.1, or Windows 10 to ensure proper operation of the FactoryTalk Batch components. For more information about supported operating systems and other Rockwell Software product version support, refer to the Product Compatibility and Download Center (PCDC) [http://www.rockwellautomation.com/compatibility/#/scenarios].

- The FactoryTalk Batch Server computer cannot be configured as a:
  - Domain controller
  - DHCP server
  - WINS server
  - RAS server
  - DNS server
  - Master Browser
- Replication is not a supported feature on the FactoryTalk Batch Server computer.
- Install FactoryTalk Batch software on an NTFS formatted hard drive, as Windows security features are available only for drives formatted to use NTFS.

**Important:** FactoryTalk Batch version 13.00.02 components do not support touch screen technology.

See also

*Windows Server configuration requirements* on page 15

Install the operating system using the default selections.

**Tip:** Rockwell Automation tests all supported operating systems and warranties the operating systems for FactoryTalk Batch version 13.00.02.

See also

*Configure the Windows Server operating system for the Batch and Procedure Servers* on page 30
DEP settings

Data Execution Prevention (DEP) is a hardware and software security feature that prevents the execution of malicious code in Windows operating systems.

Rockwell Automation supports DEP OptIn and OptOut settings. For more information, see Microsoft KB article 875352.
Pre-installation administrative tasks

This section describes administrative tasks to perform before installing FactoryTalk Batch components.

Log on to the target computer with administrator privileges. Close any open applications.

Important: Users must have administrative privileges on the target computer to install FactoryTalk Batch components.

Administrator privileges apply to the following installations:

- FactoryTalk Batch Server
- FactoryTalk Batch Client
- FactoryTalk Event Archiver
- FactoryTalk eProcedure Server
- FactoryTalk eProcedure Client
- FactoryTalk Batch Material Manager Server
- FactoryTalk Batch Material Manager Client

See also

- Install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver components on page 35
- Install the FactoryTalk Batch Client on page 46
- Install the eProcedure Client on page 51
- Install the Material Manager Server on page 57
- Install the Material Manager Client on page 61
Security accounts

User groups apply to the following installations:

- FactoryTalk Batch Server
- FactoryTalk Batch Material Manager Server

Create one or more domain user accounts for the FactoryTalk Batch application servers to use. The installation program for the application servers require a user account and password for the FactoryTalk Batch Server to run under.

FactoryTalk Batch user groups

The installation of the FactoryTalk Batch Server creates the Windows user group batchsvr_group on the FactoryTalk Batch Server. This group is automatically assigned all the user rights and default access permissions required for the FactoryTalk Batch Server to function correctly.

The installation adds the FactoryTalk Batch Server user account to the following:

- Administrators group
- batchsvr_group
- Batch COM+ Application
- FactoryTalk Batch Server service
- FactoryTalk Event Archiver service
- FactoryTalk eProcedure Server service (eProcedure Server installation)

The services for the FactoryTalk Batch Server, FactoryTalk Event Archiver, FactoryTalk eProcedure Server, and the Batch COM+ Application require identical user accounts to support the FactoryTalk Batch Server functionality.

Material Manager user groups

Domain user groups

- MTBatchServer

User Group & COM+ Role

Add the FactoryTalk Batch user account under which the FactoryTalk Batch Server service is running to the MTBatchServer group. The MTBatchServer group is added to the MTBatchServer role during installation. This is the role that the FactoryTalk Batch Server uses to access the material database. All FactoryTalk Batch Servers have unlimited access to Material Manager.
• MTGeneral
  
  **COM+ Role**
  
  The MTGeneral role is used internally by the Material Manager Server to check security and communication between clients and the server.

• MTLotAuthor
  
  **User Group & COM+ Role**
  
  The MTLotAuthor role has permission to add, edit, and delete lots. The MTLotAuthor group is added to the MTLotAuthor role during installation.

• MTMaterialAuthor
  
  **User Group & COM+ Role**
  
  The MTMaterialAuthor role has permission to add, edit, and delete materials and containers. The MTMaterialAuthor group is added to the MTMaterialAuthor role during installation.

• MTMaterialViewer
  
  **User Group & COM+ Role**
  
  The MTMaterialViewer role has permission to view items in the Editor. The MTMaterialViewer group is added to the MTMaterialViewer role during installation.

**Domain user account for the server**

• User
  
  The domain user account specified during the installation is added to the local group, MTUsers. This is the account under which the server runs.

See also

Install the FactoryTalk Batch Server, Procedure Server, and FactoryTalk Event Archiver components on page 35

Install the Material Manager Server on page 57

---

**Enable the Windows Firewall**

For the installation program to populate the firewall exceptions automatically, enable the Windows Firewall Service prior to running the installation. This allows the Firewall Configuration Utility to add the necessary exceptions.

**Important:** When managing the Windows Firewall settings externally, the installation cannot change the Windows Firewall settings.
The installer updates Windows Firewall settings for the following:

- FactoryTalk Batch Server
- FactoryTalk Batch Client
- FactoryTalk Event Archiver
- FactoryTalk eProcedure Server
- FactoryTalk eProcedure Client
- FactoryTalk Batch Material Manager Server
- FactoryTalk Batch Material Manager Client

Typically, Windows Firewall appears under Control Panel > Windows Firewall. For more information, see the Windows operating system for the current installation.

See also

- Add an incoming firewall rule on page 20
- Disable Administrative Approval Mode on page 21
- Manually configure the Windows Firewall on page 83

Windows Workgroup

Windows accounts

Add an incoming firewall rule

This section describes steps to configure FactoryTalk Batch to run under a Windows Workgroup.

If the FactoryTalk Batch application servers use a local account, create Windows accounts with the same name and password on all computers in the workgroup.

If the FactoryTalk Batch system will run on a Windows Workgroup:

- Add an incoming firewall rule
- Disable Administrative Approval Mode

This task applies to the following installations:

- FactoryTalk Batch Server
- FactoryTalk eProcedure Server
- FactoryTalk Batch Material Manager Server

To add an incoming firewall rule:

On the computer where the component is being installed:
Pre-installation administrative tasks

1. Navigate to **Windows Firewall with Advanced Security**.

2. Select **Inbound Rules**, right-click **Inbound Rules**, and then select **New Rule**.

3. In the **New Inbound Rule Wizard**, select the following values:
   a. In **Rule Type**, select **Port**.
   b. In **Protocol and Ports**, select **TCP** and in **Specific local ports**, type **49157**.
   c. In **Action**, select **Allow the connection**.
   d. In **Profile**, select all profiles (Domain, Private, Public).
   e. In **Name**, in the **Name** box, enter **Port 49157 TCP**, and then select **Finish**.
   f. Verify that the **Port 49157 TCP** rule was added to the **Inbound Rules** list.
   g. Close **Windows Firewall with Advanced Security**.

See also

- **Enable the Windows Firewall** on page 19
- **Disable Administrative Approval Mode** on page 21

### Disable Administrative Approval Mode

Disable Administrative Approval Mode for all Administrators on the server computer when running in a Workgroup configuration. This ensures that users do not have to install or run programs using elevated privileges.

**To disable Administrative Approval Mode:**

On the computer where the Batch Server has been installed:

1. Navigate to **Control Panel > Administrative Tools > Local Security Policy**.

2. Expand **Local Policies** and select **Security Options**.

3. Locate **User Account Control: Run all Administrators in Admin Approval Mode** and double-click it.

4. In the **Security Setting** tab, select **Disabled** and click **OK**.
5. Verify that User Account Control: Run All Administrators in Admin Approval Mode is now set to Disabled.


See also

Add an incoming firewall rule on page 20

Configure the Remote Registry on a Windows desktop operating system

When installing the FactoryTalk Batch Server or Material Manager Server on a Windows desktop operating system, use the following instructions to configure the remote registry.

Configure the remote registry for the following installations:

- FactoryTalk Batch Server
- FactoryTalk Batch Material Manager Server

To configure the remote registry on a Windows desktop:

2. In the Details pane, right-click Remote Registry and select Properties.
3. For Startup type, select Automatic.
4. Close the dialog box.

See also

Install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver components on page 35

Install the Material Manager Server on page 57

System date and time

Set the date and time on each computer on the network

**Important:** The date and time must match for correlation between events, journals, and logs in the FactoryTalk Batch system.

Set the date and time for the following installations:

- FactoryTalk Batch Server
- FactoryTalk Batch Client
- FactoryTalk Event Archiver
- FactoryTalk eProcedure Server
- FactoryTalk eProcedure Client
- FactoryTalk Batch Material Manager Server
- FactoryTalk Batch Material Manager Client

See also

- Install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver components on page 35
- Install the FactoryTalk Batch Client on page 46
- Install the eProcedure Client on page 51
- Install the Material Manager Server on page 57
- Install the Material Manager Client on page 61

Event log settings

The Windows Event Log service records application, system, and security information.

Configure the Windows Application and System logs to use the setting Overwrite events as needed. For more information about event log settings, see Modify Event Log Settings in the FactoryTalk Batch Administrator Guide.

Configure event logs for the FactoryTalk Batch Server installation.

See also

- Install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver components on page 35

SQL Server installation

The following applications use SQL Server:

- FactoryTalk Batch Server to store recipes in RDB format
- FactoryTalk Event Archiver to use Batch reports
- FactoryTalk Batch Material Manager Server to store materials for recipes

Install a supported version of SQL Server listed in the System requirements overview section and select the following features:

- Database Engine Services
- Reporting Services – Native (if using FactoryTalk Event Archiver with Batch reports)
Go to: https://www.microsoft.com/en-us/ to get the latest supported version of SQL Server for the FactoryTalk Batch system.

The following requirements apply to SQL Server installation:

- Create a SQL Server database login for the user performing the FactoryTalk Batch installation, with permissions to create a database.
- The user installing Material Manager must have read and write access to the SQL Server database.
- SQL Server can reside on the same computer as the Batch Server.
- If using a single SQL Server installation, install SQL Server on the same computer where the FactoryTalk Batch Material Server will be installed.
- If using a single SQL Server installation for recipes, Batch reports, and materials, use the default instance name (MSSQLSERVER). The FactoryTalk Batch Material Server supports only default instances.
- Support for named instances:
  - FactoryTalk Batch and the FactoryTalk Batch Material Server do not support named instances.
  - FactoryTalk Event Archiver supports named instances.
- Add TCP Port 1433 as an exception in the Windows Firewall to store recipes from FactoryTalk Batch Recipe Editor on a remote SQL Server. (For more information about configuring the Windows Firewall, see Manually configure the Windows Firewall.
- Install the Event Archiver Management Tool on the same computer as SQL Server.

See also

System requirements overview on page 13

Configure Reporting Services for FactoryTalk Event Archiver on page 24

Manually configure the Windows Firewall on page 83

Configure SQL Server 2016 for Reporting Services on page 26
Configure Reporting Services for FactoryTalk Event Archiver

Configure SQL Server Reporting Services so FactoryTalk Event Archiver can create reports.

Tip: Consider the following:
- This procedure is only required if the Install only option was selected when installing Reporting Services instead of installing and configuring Reporting Services, or if an existing SQL Server installation was modified to add the Reporting Services feature and the option to configure reporting services was not selected.
- Use the same user account for installing FactoryTalk Batch and FactoryTalk Event Archiver and configuring Reporting Services. When using a different user account, a prompt may appear for user credentials.

To configure Reporting Services for FactoryTalk Event Archiver:

1. Open the Reporting Services Configuration Manager:
   - For Windows 8.1 and later:
     - Search for Reporting Services Configuration Manager.
   - For earlier Windows versions:
     - Navigate to the installed version of Microsoft SQL Server > Configuration Tools > Reporting Services Configuration Manager.

2. In the Reporting Services Configuration Connection dialog box, configure the following:
   a. In Server Name, specify the name of the computer with the report server instance.
   b. In Report Server Instance, select the default instance (MSSQLSERVER) from the list.
   c. Select Connect.

3. In the Reporting Services Configuration Manager dialog box, select Report Manager URL.
Chapter 4  Pre-installation administrative tasks

Tip: If a message appears stating that Web Services have not been assigned, select Web Service URL from the Connect pane, accept the defaults, and click Apply before returning to this page.

4. Select the URLs link to open Home - Report Manager in a web browser.
   - If the link is not active, select Apply to activate the link.
   - If this is the first time accessing the Report Manager page, warning messages may appear. To continue, select Close for any warning.

   Tip: Some configurations may require:
   • An additional log in to the site
   • The browser to launch using the Run as administrator option,
   • The Enhanced Security Configuration dialog box to block the site.

5. In Home - Report Manager, select Folder Settings.


7. In New Role Assignment, in Group or user name, enter a group or a user name to run reports. Use the format domain\account.

8. Select the Role check box to select all of the roles, or select the check box next to individual roles to apply the role to a group or user.


See also

SQL Server installation on page 23

Configure SQL Server to enable FactoryTalk Event Archiver with Reporting Services on page 37

Configure SQL Server 2016 for Reporting Services

Configure SQL Server Reporting Services so FactoryTalk Event Archiver can create reports.

To configure the Microsoft SQL Server for Reporting Services:

1. In the Reporting Services Configuration Connection dialog box, select the report server instance to configure.
   a. In Server Name, specify the name of the computer on which the report server instance is installed.
b. In Report Server Instance, select the SQL Server Reporting Services instance to configure.

Only report server instances for this version of SQL Server appear in the list.

2. Click Connect. The Reporting Services Configuration Manager opens.

3. On the left pane, select Web Portal URL.

4. In the Web Portal URL pane, select the URLs: link to open SQL Server Reporting Services in a web browser.

   • If the link is not active, select Apply to activate the link.
   • If this is the first time accessing the SQL Server Reporting Services page, browser warning messages may open. To continue, select Close or Add for each warning.
   • If asked to log into Reporting Services, log in as a user with administrative permissions to the BatchHistoryEX and ReportServer databases.

1. In Home - SQL Server Reporting Services, select Manage folder.

2. In Security, select Add group or user.

3. On the New Role Assignment page, enter the domain\user name (that was used when SQL Server was installed) in the Group or user name box.

4. Select the Role check box to select all of the roles.

5. Select OK. The new role is added to the list on the SQL Server Reporting Services Security page.

See also

SQL Server installation on page 23
This section provides instructions on how to install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver software on the same computer. If a FactoryTalk Batch Server already exists, see Install the FactoryTalk Batch client to install FactoryTalk Batch Client components on a different computer.

The installation process has three categories:

- Pre-installation procedures
- Installation procedures
- Post-installation procedures

Use the following chart to install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver:
Important: Use the default installation directories for all components.

See also

Pre-installation configuration on page 30
Install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver components on page 35
Post FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver installation on page 37
Install the FactoryTalk Batch Client on page 46

This section describes steps to perform before installing the software.

Use Windows Server Manager to configure Windows Server operating systems when installing FactoryTalk Batch Server or eProcedure Server as an Application Server.

To configure the Windows Server operating system for the Batch and eProcedure Servers:

1. Configure the following values:

   FactoryTalk Batch Server:
   a. In Server Manager Dashboard, select Add Roles and Features.
   b. In Add Roles and Features Wizard, select Next.
   c. For Installation Type, select Role-based or feature-based installation.
   d. For Server Selection, select Select a server from the server pool, and then select the appropriate server in the Server Pool list.
   e. For Server Roles, select Application Server.

   Tip: This option has been removed in Windows Server 2016.

   eProcedure Server:
   Select the following Server Roles under Web Server (IIS).
• **Application Server** (ignore this option for Windows Server 2016).
  • Web Server (IIS) Support

• **IIS6 Management Compatibility**
  • IIS6 Metabase compatibility
  • IIS6 Management Console

• **Web Server > Application Development:**
  • For Windows Server 2008:
    • ASP
    • ASP.NET
  • For Windows Server 2012:
    • ASP
    • ASP.NET 3.5
    • ASP.NET 4.5
  • For Windows Server 2016
    • ASP
    • ASP.NET 3.5
    • ASP.NET 4.6

• **Web Server**
  • Common HTTP Features
  • Static Content

**Important:** Selecting certain options may automatically select new additional options or may display new options.

2. Verify the selections, and then select **Install**.

3. When the installation process completes, select **Close**.

**See also**

- [System requirements overview](#) on page 13
- [Enable the Windows Firewall](#) on page 19
Configure the Windows Server 2016 operating system for the eProcedure Server

Use Windows Server Manager to configure the Windows Server 2016 operating system when installing eProcedure Server.

To configure the Windows Server 2016 operating system for the eProcedure Server:

1. Configure the following values for the eProcedure Server:
   a. In Server Manager Dashboard, select Add Roles and Features.
   b. In Add Roles and Features Wizard, select Next.
   c. For Installation Type, select Role-based or feature-based installation.
   d. For Server Selection, select Select a server from the server pool, and then select the appropriate server in the Server Pool list.
   e. For Server Roles, select Web Server (IIS).
      Tip: If asked, accept the Web Server (IIS) defaults and click Add Features.
   f. In the Select Server Roles window, click Next.
   g. In the Select features window, select the following:
      • .NET Framework 3.5 Features
      • .NET Framework 4.6 Features > ASP.NET 4.6
   h. Click Next.
   i. In the Web Server Role (IIS) window, click Next.
   j. In the Select role services window, select the following options:
      • Web Server > Common HTTP Features > Static Content
      • Application Development:
      • .NET Extensibility 3.5
      • .NET Extensibility 4.6
      • ASP
      • ASP .NET 3.5
      • ASP .NET 4.6
      • Management Tools > IIS6 Management Compatibility
      • IIS6 Metabase compatibility
Install FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver

Chapter 5

• IIS6 Management Console

**Important:** Selecting certain options may automatically select new additional options or may display new options. Click **Add Features** to add the option defaults.

2. Click **Next**.

3. In the **Confirm installation selections** window, select **Install**.

4. When the installation process completes, select **Close**.

See also

- [System requirements overview](#) on page 13
- [Enable the Windows Firewall](#) on page 19

Configure the Windows desktop operating system for the Batch and eProcedure Servers

Use the following procedure to configure the Windows desktop operating system for the eProcedure Server. Use the **Turn Windows Features On or Off** dialog box for this configuration process.

**Tip:** FactoryTalk Batch does not require any configuration for Windows desktop operating systems.

**To configure Windows desktop operating systems for the eProcedure Server:**

1. On the computer where the eProcedure Server will be installed, configure the following features.

   **Tip:** To identify the features already installed, select the plus sign beside the box. Gray boxes indicate an installed feature. The feature is still installed even if the lower child components are not selected.

   • **Internet Information Services:**
     - Web Management Tools
     - IIS 6 Management Compatibility
       - IIS 6 Management Console
       - IIS 6 Metabase and IIS 6 configuration compatibility
     - IIS Management Console

   • For Windows 7:
     - **World Wide Web Services**
       - Application Development Features
         - .NET Extensibility
         - ASP
2. Select **OK** to enable the features and close the dialog box.

**See also**

- [Configure the Windows Server operating system for the Batch and eProcedure Servers](#) on page 30
- [Allow Active Server Pages](#) on page 35
Allow Active Server Pages

Before installing the eProcedure Client on a Windows operating system, configure the computer to allow active server pages.

To allow Active Server Pages:

Windows Server 2008:

1. Access Control Panel > Administrative Tools > Internet Information Services (IIS) Manager.
2. Select the ISAPI and CGI Restrictions item.

Windows Server 2012, Windows 7, and Windows 8.1:

1. Access Control Panel > Administrative Tools > Internet Information Services (IIS) Manager.
2. Double-click the ISAPI and CGI Restrictions item.
3. If the Active Server Pages Restriction column indicates Allowed, exit the tool.
4. If the Active Server Pages Restriction column does not indicate Allowed, select the Active Server Pages option that states Not Allowed, and then select Edit.
5. Select Allow extension path to execute, and then select OK.

See also

Install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver components on page 35

Install FactoryTalk Batch

Use this procedure to install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver components.

Tip: Prerequisite checks run automatically to ensure a successful installation. If a problem occurs, any issues to address display.

To install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver components:

1. Run Setup.exe.
2. On the Setup page, select Next.
3. On the Customize page, select the components to install:
• FactoryTalk Batch Server Components only. The FactoryTalk Batch Client Components are also available for installation
• FactoryTalk Batch Server Components and eProcedure Server Components
• FactoryTalk Event Archiver Database and Management Tool components

4. On the **Permission Requested** page, select the **Yes, allow changes to this computer** check box, and then select **Next**.

5. On the **Options** page, select a FactoryTalk directory for the FactoryTalk Batch components, and then select **Next**.

6. On the **System Details** page, select the following:
   
   • In the **Name** box, enter the name of the FactoryTalk Batch system, if adding this computer to an existing FactoryTalk Batch system.
   
   • In the **User Name** box, enter the domain name\user name used to install FactoryTalk Batch.
   
   • In the **Password** field, enter the password for the user installing FactoryTalk Batch.
   
   • Select **Next**.

7. (optional) When installing FactoryTalk Event Archiver, do the following:
   
   a. In the **Server Name** box, enter the SQL Server name.
   
   b. In the **Instance Name** box, enter the instance name if using a named instance.

   **Tip:** If using a single SQL Server installation for recipes, Batch reports, and materials, use the default instance name MSSQLSERVER. The FactoryTalk Batch Material Server supports only default instances.

   If using multiple SQL Server installations, FactoryTalk Event Archiver’s Batch Reports support named instances.

   c. In the **Data Source Name** box, enter the data source name.

   d. Select **Include Batch Reports**.

   e. Select **Use SQL Authentication** if using SQL Server authentication.

8. On the **End User License Agreements** page, review the agreement and select **Accept all**.
9. (optional) If prompted on the Almost There page, select the activation option, and then select Next.

10. If prompted on the That’s it page, restart the computer.

See also

- System requirements overview on page 13
- Pre-installation administrative tasks on page 17
- Uninstall the FactoryTalk Batch components on page 79

Post-FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver installation

Perform post-installation configuration of the Batch server computer.

- Configure the BatchHistory database.
- Share the FactoryTalk Batch directory on the SQL Server computer.
- Set event logs.
- Create a shared directory.
- Configure redundant servers.
- Create an area model in FactoryTalk Batch Equipment Editor.
- Create recipes in FactoryTalk Batch Recipe Editor.
- Configure server options.
- Start or restart the FactoryTalk Batch Server.
- Set security on logs and journals folders.
- Configure Internet Explorer (if eProcedure Client is on the same computer).
- Configure compatibility view settings.

Configure SQL Server to enable FactoryTalk Event Archiver with Reporting Services

Configure SQL Server to enable FactoryTalk Event Archiver with Reporting Services to connect to and insert records into the FactoryTalk Batch database. Set up permissions for the BatchHistoryEx database in SQL Server Management Studio. FactoryTalk Event Archiver with Reporting Services writes data to the BHBatchHis SQL table in the BatchHistoryEx database.

Tip: This procedure applies to versions of SQL Server prior to SQL Server 2014. See Configure SQL Server 2014 to enable FactoryTalk Event Archiver with Reporting Services.
Chapter 5  Install FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver

**Important:** All users of the FactoryTalk Batch Reporting Services must have a user login and read and write access to the source databases, such as BatchHistoryEx or the FactoryTalk® Alarms and Events FTAE_Historian databases. Add any additional users or groups when adding the login account for the FactoryTalk Batch Server.

**To configure SQL Server to enable FactoryTalk Event Archiver with Reporting Services:**

1. Open the SQL Server Management Studio.

2. In the Security > Logins folder on the SQL Server instance, do the following:
   a. Add a FactoryTalk Batch Server user login to the Security > Logins folder on the SQL Server instance.
   b. Set the default database to BatchHistoryEx.
   c. Under User Mapping, select the BatchHistoryEX database.
   d. Select db_datareader, db_datawriter, and select OK.

3. In Databases, right-click the BatchHistory or BatchHistoryEx database, and select Properties.
   a. Grant INSERT privilege for the FactoryTalk Batch Server user account on the BatchHistoryEX database.
   b. Under BatchHistoryEX\Programmability, add the EXECUTE permission for the FactoryTalk Batch Server user account to dbo.BHInsert properties.
   c. For BatchHistoryEX\Programmability, add the EXECUTE permission for the FactoryTalk Batch Server user account to dbo.BHRecovery properties.

See also

Configure SQL Server 2014 to enable FactoryTalk Event Archiver with Reporting Services on page 39
Configure SQL Server 2014 or SQL Server 2016 to enable FactoryTalk Event Archiver with Reporting Services

Configure SQL Server to enable FactoryTalk Event Archiver with Reporting Services to connect to and insert records into the FactoryTalk Batch database. Set up permissions for the BatchHistory or BatchHistoryEx database in SQL Server Management Studio. See the FactoryTalk Event Archiver User Guide to configure the reporting option for End of Batch or Incremental.

**Tip:** This procedure only applies to SQL Server 2014 and SQL Server 2016. See Configure SQL Server to enable FactoryTalk Event Archiver with Reporting Services to configure using versions prior to SQL Server 2014.

**Important:** All users of the FactoryTalk Batch Reporting Services must have a user login and read and write access to the source databases, such as BatchHistoryEx or the FactoryTalk® Alarms and Events FTAE_Historian databases. Add any additional users or groups when adding the login account for the FactoryTalk Batch Server.

To configure SQL Server 2014 or SQL Server 2016 to enable FactoryTalk Event Archiver with Reporting Services

1. From SQL Server Management Studio, add a FactoryTalk Batch Server user login to the **Security > Logins** folder on the SQL Server instance.

2. Set the default database to **BatchHistory** or **BatchHistoryEx**.

3. Under **User Mapping**, select the **BatchHistory** or **BatchHistoryEx** database.

4. Select **db_datareader**, **db_datawriter**, and select **OK**.

5. In **Databases**, right-click the **BatchHistory** or **BatchHistoryEx** database, and select **Properties**.

6. Select **Permissions**.

7. Select the Batch Server user in the list.

8. Grant **Execute**, **Insert**, and **Connect** permissions.

**See also**

Configure SQL Server to enable FactoryTalk Event Archiver with Reporting Services on page 37
Chapter 5  Install FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver

**FactoryTalk Batch directory on the SQL Server computer**

By default, the Batch directory on the SQL Server computer is not shared to domain users. Therefore, domain users cannot access the appropriate application .log file when an error message refers them to it. For domain users to read application logs, share the Batch directory on the SQL Server computer in the FactoryTalk Batch system to domain users and give the share Read-Only permissions.

**Shared directory**

If installing FactoryTalk Batch in a networked environment, and project files are installed to a directory that is not located in the BATCHCTL share, create a share for that project directory. For more information about creating a shared directory, see Create a shared directory in the FactoryTalk Batch Administrator Guide.

**Server options**

Prior to configuring the FactoryTalk Batch Server, ensure that all project directories are shared. Configure the FactoryTalk Batch Server using the FactoryTalk Batch Equipment Editor’s Server Options dialog box.

Tip: In FactoryTalk Batch Equipment Editor, access Options > Server Options, Project Settings tab. Verify that the location listed in Initialization File Name is where the batchsvr.ini resides on the computer. The batchsvr.ini file contains all the necessary information. Check to see that it is correct for the operating system running on the computer.

Configure the FactoryTalk Batch Server to allow each network computer to read from and write to the appropriate project directories, as well as the FactoryTalk Batch Server and Archiver initialization files. For information on the Server Options dialog box, see The FactoryTalk Batch Server in the FactoryTalk Batch Administrator Guide.

**Redundant servers (optional)**

Configure FactoryTalk Batch to store batch journals and batch restart information in two separate locations. If there is a hardware failure on the primary FactoryTalk Batch Server computer, using a secondary server allows for a manual failover. The second computer must be capable of running the server. Redundant servers are defined by specifying the primary and secondary restart paths. If the system experiences a failure, these paths indicate where system files are written. If a secondary path is not specified, FactoryTalk Batch does not write any secondary files. (For more information about redundant servers, see Define redundant servers in the FactoryTalk Batch Administrator Guide.)

**Area model in the FactoryTalk Batch Equipment Editor**

Open FactoryTalk Batch Equipment Editor and then create the area model. (See the FactoryTalk Batch Equipment Editor User Guide for more information.)

See also

Create recipes in the FactoryTalk Batch Recipe Editor on page 41
Create recipes in FactoryTalk Batch Recipe Editor

Open FactoryTalk Batch Recipe Editor to create recipes. See the FactoryTalk Batch Recipe Editor User Guide for more information.

Start or restart the FactoryTalk Batch Server

After installing the FactoryTalk Batch Material Manager Server, the FactoryTalk Batch Server needs to be stopped and then restarted to recognize the addition of the Material Server.

To start or restart the FactoryTalk Batch Server:

1. Select Start > All Programs > Rockwell Software > FactoryTalk Batch Suite > FactoryTalk Batch, and then select Batch Service Manager.

   Important: If running on Windows 7 or Windows Server 2008, right-click Batch Service Manager and select Run as administrator.

2. In the FactoryTalk Batch Service Manager, select the FactoryTalk Batch Server if it is not listed in the Service box. If the name of the computer where the FactoryTalk Batch Server is installed does not display in the Computer box, select the Select Computer.

3. In the Select Computer dialog box under Enter the object name to select, enter the name of the computer where the Batch Server is installed (or select Advanced to search for a computer). Select OK.

   Tip: The FactoryTalk Batch Service Manager must communicate with the Windows Service Manager of the selected computer to determine what services are available. There may be a noticeable delay when establishing communications. If the Service Manager cannot communicate with the Windows Service Manager of the selected computer, a message displays.

4. To start the FactoryTalk Batch Server in Demo mode, select Allow Demo Mode.

5. Select the method to use for booting the server:

   Cold Boot Restarts the FactoryTalk Batch Server in a cold state; erases all journal data or recipe content upon startup.

   Warm Boot Restarts the FactoryTalk Batch Server, restoring the set of batches that were on the batch list when the server previously terminated.

   Warm All Boot Restarts the FactoryTalk Batch Server only if it is able to restore all of the batches to the batch list.

6. Select Start/Continue. The Service State area changes from STOPPED to START PENDING. After a few moments, RUNNING displays and the light changes to green.
7. (optional) Select Close to close the FactoryTalk Batch Service Manager.

See also

Post Material Manager Server installation on page 58

Post FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver installation on page 37

Security on Logs and Journals folders

Set security permissions on the folder to prevent losing data in the log files and the event journal (.evt) files. The system administrator determines who needs access to these files and assigns the appropriate permissions. The account(s) under which the FactoryTalk Batch Server and FactoryTalk Event Archiver are running must be given full access to these folders. (For more information about security on folders and files, see Set security on folders or files in the FactoryTalk Batch Administrator Guide.)

Set the Internet Explorer home page for eProcedure Clients

The eProcedure Client install sets the home page only for the user who installed the product. Any other users who will be using the eProcedure Client on that computer must set the Client as the home page.

To set the Internet Explorer home page for eProcedure Clients:

1. From Internet Explorer, select Tools > Internet Options.

2. In the Home page box, enter http://<computer name>/eProcedure/ (where <computer name> is the name of the Server where the eProcedure Server is installed), and then select OK.

See also

Correct error messages when viewing eProcedure pages in Internet Explorer on page 52
Configure Compatibility View settings

Configure Internet Explorer’s **Compatibility View settings** for the eProcedure Client to ensure the following:

- The eProcedure Client command buttons work and display correctly.
- The current user displays and has permissions to view the batch list.
- The buttons on the left side are all the same size.

**To configure Compatibility View settings:**

1. In Internet Explorer, select **Tools > Compatibility View settings**.
2. In **Add this website**, enter the eProcedure server name and select **Add**.

**See also**

[Correct error messages seen when view eProcedure pages in Internet Explorer](#) on page 52
Chapter 6

Install FactoryTalk Batch Client components

Before beginning the installation, complete all the pre-installation administrative tasks.

Install the FactoryTalk Batch Server components before installing FactoryTalk Batch Client components.

**Important:** Use the default installation directories for all components.

Follow these guidelines when installing FactoryTalk Batch Client components.

- Before installing the FactoryTalk Batch Clients, install and configure the Windows operating system, and install other required software that will be used with the FactoryTalk Batch system. For information about supported operating systems, see the System requirements overview section.

- Instructions for installing the FactoryTalk Batch Clients are based on installing Clients on a computer networked with other FactoryTalk Batch system computers. Before beginning the installation, complete these pre-installation procedures. To exit the installation process at any time, close the installation wizard.
See also

Install the FactoryTalk Batch Server, Procedure Server, and FactoryTalk Event Archiver components on page 35

System requirements overview on page 13

User groups on page 17

Enable the Windows Firewall on page 19

Install the FactoryTalk Batch Client

Use this procedure to install the FactoryTalk Batch Client.

Tip: Prerequisite checks run automatically to ensure a successful installation. If a problem occurs, any issues to address display.

To install the FactoryTalk Batch Client:

1. Run Setup.exe.

2. On the Setup page, select Next.

3. On the Customize page, select FactoryTalk Batch Client Components, and clear the FactoryTalk Batch Server Components selection, and then select Next.

4. On the Options page, select a FactoryTalk directory for the FactoryTalk Batch components, and then select Next.

5. On the System Details page, select the following:
   a. In the Name box, enter the name of the computer where the FactoryTalk Batch Server is installed.
   b. In the User Name box, enter the domain name\user name used to install the FactoryTalk Batch Server.
   c. Select Install.

6. On the End User License Agreements page, review the agreement and select Accept all.

7. If prompted on the That's it page, restart the computer.

See also

System requirements overview on page 13
Post-FactoryTalk Batch Client component installation

Perform post-installation configuration of the FactoryTalk Batch Client computer.

- Create an area model in FactoryTalk Batch Equipment Editor.
- Create recipes in FactoryTalk Batch Recipe Editor.

See also

Area model in the FactoryTalk Batch Equipment Editor on page 40
Recipes in the FactoryTalk Batch Recipe Editor on page 41
Install eProcedure Client components

Before beginning the installation, complete all the pre-installation administrative tasks.

Install the FactoryTalk Batch Server and eProcedure Server components before installing eProcedure Client components.

**Important:** To run the eProcedure Client on a Windows Server machine and to obtain the required privileges to execute the eProcedure Client, right-click the eProcedure Client icon and select **Run as administrator.**

**Important:** Use the default installation directories for all components.

![Diagram](image)
See also

Install the FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver components on page 35

System requirements overview on page 13

Administrator privileges on target computer on page 17

Implementation recommendations for eProcedure Clients

Set up one eProcedure Client per computer to prevent multiple parameter or material submissions. If more than one Client runs the same batch, and receives and submits an instruction, the Client that submitted the instruction refreshes before other Clients. This may result in confusion as to whether the instruction was performed.

If operators on multiple Clients attempt to Submit on the same step, only one submit is allowed. A warning that the step completed displays on all other Client computers. If two or more operators select Submit at the same time, all of the events are logged as a single event in the event log.

**Important:** The domain name and server name must contain only the alphanumeric characters a through z, 0 through 9, the dash (-) and period (.). If the server name contains other characters, such as an underscore (_), Internet Explorer blocks cookies from that server. If a server or domain name does contain unsupported characters, the eProcedure Client does not retain the name of the logged on user.

**Refresh**

If two or more eProcedure Clients view the same batch in the Instructions view, only the Instructions view where the acknowledgments and submits occur stays up-to-date. Other users should press F5 to refresh the Instructions views to ensure accurate information.

Refresh the page often, especially if there are several reports or data entry fields in the current step. The HTML-based Instructions view does not automatically query the server for update information.

**For process engineers**

When configuring Equipment Phases with the FactoryTalk Batch Equipment Editor, leave enough physical space between icons to allow for status notices and user-defined hyperlinks in the browser-based eProcedure Equipment view.
Install the eProcedure Client

The eProcedure Client is a web-based application that creates and commands batches. A batch is composed of a combination of process-connected phase logic and instruction files that step the operator through the manual process of producing a batch of products.

Tip: Prerequisite checks run automatically to ensure a successful installation. If a problem occurs, any issues to address display.

To install the eProcedure Client Components:

1. Run Setup.exe.
2. On the Setup page, select Next.
3. On the Customize page, select eProcedure Client Components, and then select Next.
4. On the Options page, select a FactoryTalk directory for the FactoryTalk Batch components, and then select Next.
5. On the System Details page, select the following:
   - In the Name box, enter the name of the computer that hosts the FactoryTalk Batch Server.
   - In the User Name box, enter the domain name\user name used to install the FactoryTalk Batch Server.
   - Select Install.
6. On the End User License Agreements page, review the agreement and select Accept all.
7. If prompted on the That's it page, restart the computer.

See also

System requirements overview on page 13
Pre-installation administrative tasks on page 17
Uninstall the FactoryTalk Batch components on page 79
Correct error messages seen when viewing eProcedure pages in Internet Explorer

Error messages may display when viewing eProcedure pages in Internet Explorer.

Possible messages include the following:

- An ActiveX control on this page might be unsafe to interact with other parts of the page. Do you want to allow this interaction?
- An add-on for this website failed to run. Check the security settings in Internet Options for potential conflicts.

To correct error messages seen when viewing eProcedure pages in Internet Explorer:

Create eProcedure Client settings that are specific for the current user.

1. From Internet Explorer, from the Tools menu, select Internet Options. If using the global policy editor, use gedit.msc.

2. Select the Security tab.

3. Select Trusted sites, and then select Sites. The Trusted sites dialog box opens.

4. Verify that Require server verification (https:) for all sites in this zone is disabled.

5. In the Add this Web site to the zone box, type http://computer_name. (Computer name is the name of the computer on which eProcedure Server is installed.)

6. Select Add. The Web site is added to the Web sites box.

7. In the Add this Web site to the zone box, type about: blank. Select Add. The about: blank is added to the list of websites.

8. Close the Trusted sites dialog box.

9. In the Internet Options dialog box, select Custom Level. The Security Settings dialog box opens.

10. Select Enable for the following options:
• Download signed ActiveX controls
• Download unsigned ActiveX controls
• Initialize and script ActiveX controls not marked safe
• Run ActiveX controls and plug-ins
• Script ActiveX controls marked safe for scripting

11. Select **OK**. A confirmation message is displayed.

12. Select **Yes** to change the security settings. The **Security Settings** dialog box closes.

13. Select **OK**. If prompted to do so, restart your computer.

**See also**

[Troubleshoot Batch components installation](#) on page 83

[Configure Internet Explorer](#) on page 42

---

**Configure Internet Explorer compatibility view settings**

Use the following instruction to configure the Internet Explorer compatibility view settings.

**To configure Internet Explorer compatibility view settings:**

1. From Internet Explorer, select **Tools > Compatibility View Settings**.

2. In **Add this website**, enter the eProcedure server name as `http://<computer name>`, and select **Add**.

3. Refresh the Internet Explorer browser.

**Tip:** To enable the current user to maintain a separate set of eProcedure Client security settings than those for the local computer, see **Configure Internet Explorer security settings for Trusted Sites**.

**See also**

[Configure Internet Explorer to view eProcedure pages](#) on page 52
Chapter 8

Install FactoryTalk Batch Material Manager Server components

This section provides instructions on how to install the Material Manager Server. The installation process has the following steps:

Important: Use the default installation directories for all components.

See also

Pre-installation administrative tasks on page 17
Configure Microsoft Queuing Service and COM+ Network Access for Material Server on page 56
Install the Material Manager Server on page 57

Pre-installation configuration

This section describes steps to perform before installing the software.
Configure Microsoft Queuing Service and COM+ Network Access for Material Server

Before installing FactoryTalk Batch Material Manager Server, configure the Microsoft Message Queuing Service (MSMQ) and COM+ Network Access.

**Important:**
- On Windows Server 2016, COM+ Network Access is enabled in the registry instead of the **Server Manager**.

**Prerequisites:**
- Log on to Windows with administrator privileges. Close any open applications. Make sure the logged in user has local administrator rights on the computer where the Material Server is being installed.

**To configure Microsoft Queuing Service and COM+ Network access for Material Server:**

1. Configure the following values for **Windows 7, 8.1, 10, and Windows Server 2008**:
   a. Navigate to the **Turn Windows Features On or Off** dialog box.
   b. Expand **Microsoft Message Queue (MSMQ) Server**.
   c. Select **Microsoft Message Queue (MSMQ) Server Core**.

2. Configure the following values for **Windows Server 2012 and 2016**:
   a. Navigate to **Server Manager**.
   b. Select **Add Roles and Features**.
   c. For **installation type**, select **Role-based or feature-based installation** installation type.
   d. Select a server from the server pool, and then select a server from the **Server Pool** list.
   e. For **Message Queuing**:
      - Select **Message Queuing Services**.
      - Clear any other check boxes under **Message Queuing Services**.
   f. (**Windows Server 2012 only**) For **Application Server**, select **COM+ Network Access** (Installed).
3. Select OK.

4. Complete the installation process, and then select Close.

5. For Windows Server 2016, enable the COM+ Network Access in the registry.
   a. Open the Registry Editor.
   b. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\COM3
   c. Double-click the RemoteAccessEnabled DWORD.
   d. In the Value box, enter 1.
   e. Click OK.

See also

Install FactoryTalk Batch Material Manager Server on page 55
Install the Material Manager Server on page 57

Install the Material Manager Server

Use this procedure to install the Material Manager Server.

Tip: Prerequisite checks run automatically to ensure a successful installation. If a problem occurs, any issues to address display.

To install the Material Manager Server:

1. Run Setup.exe.

2. On the Setup page, select Next.

3. On the Customize page, select FactoryTalk Batch Material Manager Server Components. Select Next.

4. On the Permission Requested page, select Yes, allow changes to this computer. Select Next.

5. On the Options page, select Add this computer to an existing FactoryTalk Batch System to connect the Material Manager Server to a computer running the FactoryTalk Batch Server. Select Next.

6. On the System Details page, select the following:
a. In the Name box, if selecting to add this computer to an existing FactoryTalk Batch system, enter the name of the computer where FactoryTalk Batch resides.

b. In the User Name box, enter the domain name\user name used for the Material Server.

c. In the Password box, enter the password for the Material Server user.

d. Select Next.

7. On the End User License Agreements page, review the agreement and select Accept all.

8. If prompted on the That's it page, restart the computer.

See also

Install FactoryTalk Batch Material Manager Server on page 55

Post-Material Manager Server installation

Perform post-installation configuration of the Material Server computer.

Start or restart the FactoryTalk Batch Server

After installing the FactoryTalk Batch Material Manager Server, the FactoryTalk Batch Server needs to be stopped and then restarted to recognize the addition of the Material Server.

To start or restart the FactoryTalk Batch Server:

1. Select Start > All Programs > Rockwell Software > FactoryTalk Batch Suite > FactoryTalk Batch, and then select Batch Service Manager.

   Important: If running on Windows 7 or Windows Server 2008, right-click Batch Service Manager and select Run as administrator.

2. In the FactoryTalk Batch Service Manager, select the FactoryTalk Batch Server if it is not listed in the Service box. If the name of the computer where the FactoryTalk Batch Server is installed does not display in the Computer box, select the Select Computer.

3. In the Select Computer dialog box under Enter the object name to select, enter the name of the computer where the Batch Server is installed (or select Advanced to search for a computer). Select OK.
Tip: The FactoryTalk Batch Service Manager must communicate with the Windows Service Manager of the selected computer to determine what services are available. There may be a noticeable delay when establishing communications. If the Service Manager cannot communicate with the Windows Service Manager of the selected computer, a message displays.

4. To start the FactoryTalk Batch Server in Demo mode, select Allow Demo Mode.

5. Select the method to use for booting the server:

- **Cold Boot**: Restarts the FactoryTalk Batch Server in a cold state; erases all journal data or recipe content upon startup.
- **Warm Boot**: Restarts the FactoryTalk Batch Server, restoring the set of batches that were on the batch list when the server previously terminated.
- **Warm All Boot**: Restarts the FactoryTalk Batch Server only if it is able to restore all of the batches to the batch list.

6. Select Start/Continue. The Service State area changes from STOPPED to START PENDING. After a few moments, RUNNING displays and the light changes to green.

7. (optional) Select Close to close the FactoryTalk Batch Service Manager.

See also

- Post Material Manager Server installation on page 58
- Post FactoryTalk Batch Server, Procedure Server, and FactoryTalk Event Archiver installation on page 37

### Identify the material database

Configure the Material Manager Server with the location of the SQL database that contains the materials for the recipes.

**To identify the material database:**

1. Navigate to All Programs > Rockwell Software > FactoryTalk Batch Suite > Material Manager, and select Network Editor. The Network Editor window opens with the Material Server selected by default.

2. Click Configure. The Configure MaterialTrack dialog box opens. The default database is materialbasedrecipe.

3. In the MaterialTrack Database box, type the name of the database, and click OK.
**Important:** The **Network Editor** does not verify database names. Changes made to the database name are immediate for the clients and servers. If the database name is invalid, the **Material Editor** will not open. Before changing the database name, check the spelling of the database name and synchronize the **Network Editor**. After changing the database name, confirm that the **Material Editor** opens and reads the databases.

4. Click **Synchronize**.

5. Select **File > Exit**, and click **Yes** to exit the **Network Editor**.

See also

[After Material Server and Client computer installation](#) on page 58
Chapter 9

Install FactoryTalk Batch Material Manager Client components

This section provides instructions on how to install the Material Manager Client components.

Important: Use the default installation directories for all components.

See also

Pre-installation administrative tasks on page 17
Install the Material Manager Client on page 61

Install the Material Manager Client

Use this procedure to install the Material Manager Client.

Tip: Prerequisite checks run automatically to ensure a successful installation. If a problem occurs, any issues to address display.

To install the Material Manager Client:

1. Run Setup.exe.
2. On the Setup page, select Next.
3. On the Customize page, select **FactoryTalk Batch Material Manager Client Components**, and then select **Next**.

4. On the **System Details** page, select the following:
   a. In the **Name** box, enter the name of the computer that hosts the Material Manager Server.
   b. In the **User Name** box, enter the domain name\user name for the Material Server.
   c. In the **Password** box, enter the password for the Material Server user.
   d. Select **Next**.

5. On the **End User License Agreements** page, review the agreement and select **Accept all**.

6. If prompted on the **That's it** page, restart the computer.

See also

Install FactoryTalk Batch Material Manager Client on page 61
FactoryTalk Activation

FactoryTalk Activation Manager is the license application for FactoryTalk Batch and FactoryTalk eProcedure. FactoryTalk Activation Manager is not necessary on client installations or any FactoryTalk Batch Material Manager installations.

The FactoryTalk Batch Server computer requires the FactoryTalk Activation Manager to enable communication with the FactoryTalk Activation Server. FactoryTalk Activation Manager is installed automatically on computers where the FactoryTalk Batch Server or FactoryTalk eProcedure Server reside. FactoryTalk Activation Manager can be installed on all FactoryTalk Batch Server computers.

**FactoryTalk Activation Manager for FactoryTalk Batch and FactoryTalk eProcedure**

1. Server that includes:
   - FactoryTalk Batch Server
   - FactoryTalk Activation Client
   - FactoryTalk eProcedure Server
2. FactoryTalk Batch Material Manager Server and Client
3. (optional) FactoryTalk Activation Server
4. Activation files for FactoryTalk Batch and FactoryTalk eProcedure
5. Client computer that includes:
   - FactoryTalk Batch Client
   - FactoryTalk eProcedure Client
Chapter 10  FactoryTalk Activation

Important: The FactoryTalk Batch Server checks for valid licenses and the correct number of unit licenses for FactoryTalk Batch and FactoryTalk eProcedure at start up.

FactoryTalk Activation Licensing for the FactoryTalk Batch Server

Follow these licensing guidelines:

- To obtain activation files for FactoryTalk Batch components, identify the Host ID of the FactoryTalk Activation Server computer.

Important: In this scenario, the FactoryTalk Batch Server starts only if it finds valid activation files for FactoryTalk Batch.

If a license does not exist on the designated FactoryTalk Activation Server, a prompt asks for a serial number and product key. The installer attempts to download the license from the licensing service. If an Internet connection is not available, (skip the activation and) obtain activation files (in one of the following ways) by performing one of the following:

- Go to: http://www.rockwellautomation.com/global/support/activations.page?
- Use the FactoryTalk Activation Manager on a computer that has Internet access.
- If Internet access is not available, call Rockwell Automation Technical Support to obtain an activation file via e-mail.

See also

FactoryTalk Batch Server, eProcedure Server, and FactoryTalk Event Archiver component installation overview

Cumulative unit licensing

Software licenses are split into a product license and a number of unit licenses. For example, a 30-unit FactoryTalk Batch product contains a 30-unit FactoryTalk Batch Server license, which includes a bundled license for FactoryTalk Batch Server, FactoryTalk eProcedure Server, and FactoryTalk Batch Material Manager Server, and 30 new unit licenses.

The FactoryTalk Batch Server performs a license check when it starts to determine which applications have a license. It then attempts to check out individual unit licenses up to the number of units specified in the area model. The FactoryTalk
Batch Server then sets the maximum number of allowable units to the total number of successful individual unit license checkouts.
Upgrade FactoryTalk Batch

This section provides instructions on how to upgrade FactoryTalk Batch. The upgrade process has three steps:

1. Pre-upgrade tasks
2. Upgrade the FactoryTalk Batch components
3. Post-upgrade tasks

See also

Pre-upgrade tasks on page 67
Upgrade the FactoryTalk Batch components on page 71
Post upgrade tasks on page 71

Pre-upgrade tasks

This section describes steps to perform before upgrading the software

• Allow the Message Queue to clear (Material Manager).
• If using XML or RDB recipes, export them to binary.
• Back up existing data files.
• Uninstall previous versions of FactoryTalk Batch components.

Allow the Message Queue to clear for Material Manager

Allow the message queues for communication to clear between the Material Server and the Material Activity Journal.

Important: This procedure applies to Material Manager only.

To allow the Message Queue to clear:

1. Navigate to Computer Management.
2. In the Computer Management window, expand Services and Applications > Message Queuing, and then select the Private Queues folder. The list of queues displays in the right pane.
Chapter 11  Upgrade FactoryTalk Batch

3. Wait until the number of messages in the Material, Material_0, and material_track0-4 queues reaches 0.


See also

Upgrade FactoryTalk Batch components on page 67

Export XML or RDB recipes to binary

When upgrading earlier versions of FactoryTalk Batch components to a later version, export recipes to binary format and delete any RDB recipe database in use.

To export XML or RDB recipes to binary:

1. Export all XML or RDB recipes to binary format and back up both the original and binary recipes:
   a. Back up all existing XML or RDB recipes to a new location.
   b. Open FactoryTalk Batch Recipe Editor.
   c. Select File > Export from Working Set.
   d. Select Binary Files and set the path to a location to store the binary files.
   e. Select Export.

   Important: Before upgrading, convert recipes stored in RDB format to binary. The upgrade procedure does not upgrade database recipe formats.

2. When installing FactoryTalk Batch 13.00.02 with RDB support, FactoryTalk Batch recreates the default MasterRecipes database.

   FactoryTalk Batch does not recreate any custom database that stores recipes during installation.

   Important: When storing recipes from FactoryTalk Batch Recipe Editor on a remote SQL Server, run the Windows Firewall Configuration Utility to add TCP Port 1433 as an exception in the Windows Firewall. For more information, see Manually configure the Windows Firewall.

See also

Convert binary recipes to XML or RDB on page 75

Manually configure the Windows Firewall on page 83
Back up files

Before uninstalling previous versions of FactoryTalk Batch components, back up the following files. Close all applications, and stop all FactoryTalk Batch services, including the eProcedure Server.

**Batch Server files**

- `Batcharc.ini` file (Batch\bin folder) (if customized)
- `Batchmbs.ini` (Batch\bin folder)
- `Batchsim.ini` file (Batch\bin folder)
- `Batchsvr.ini` file (Batch\bin folder)
- `BatchIDCreation.dll` (Batch\bin folder) (if customized)
- BatchID Custom folder (if customized)
- Simulator configuration files (.sim files in any folder)
- DSDF files (Batch\Data Servers folder) (if customized)

**Batch Client files**

- Area models (Batch\<project name>\recipes folder)

  **Tip:** If the area model has members of the PHASE_FAILURES enumeration set with ordinals greater than 32767 or less than 0 (zero), edit the ordinals so that they are in the range from 0 through 32767 before migrating the area model to a newer version of FactoryTalk Batch.

- Recipes folders and contents (Batch\<project name>\recipes folder)

  **Important:** If using Security Authority to secure area models and recipes, back up the FactoryTalk Network Directory Security Authority Identifier (SAI). This provides a means of recovery to any binary area models or recipes linked to an SAI that would otherwise not be opened if the SAI was lost.

- Customized *.bmp files (Batch\bmp folder)
- `Batcheqp.ini` file (Batch\bin folder)
- `Batchrcp.ini` file (Batch\bin folder)
- `Batchvew.ini` (Batch\bin folder)

**eProcedure files**

Close all applications and stop all Batch services before backing up files.

- Customized Instruction files
- Customized User.asp files
• Any other customized files that support the customized User.asp

Material Manager databases and files

Close all applications and stop all Batch services before backing up files.

• Customized Instruction files
• MaterialBasedRecipe database
• MaterialBasedRecipe_MAJ database
• Sample2_Materials database (if used)
• Any other material-based recipe databases unique to the facility

FactoryTalk Event Archiver database and files

• BatchHistory or BatchHistoryEx database
• Customized reports

Uninstall the previous version of FactoryTalk Batch

Uninstall FactoryTalk Batch components from version 13.0. Uninstall each component one at a time until all components are removed from the computer.

Prerequisites

• Back up all files and database(s) associated with these applications.
• Close all applications.
• Stop all Batch services.

Tip: Users must have administrative privileges on the target computer to uninstall the software.

To uninstall the previous version of FactoryTalk Batch components:

1. Navigate to Control Panel > Programs and Features, and then select Uninstall a Program.

2. Select a FactoryTalk Batch component and select Uninstall.

3. On the Programs and Features dialog box, select Yes.

4. If the User Account Control dialog box prompts (you) to confirm the removal, select Yes. The uninstall program removes the FactoryTalk Batch component.
Tip: If the uninstall program stops, check to see if any modal dialog boxes appear behind the uninstall dialog box. Select **OK** on any message box to allow the uninstall to finish.

5. Perform this uninstall procedure on each of the components to uninstall.

6. Restart the computer after uninstalling the last component from the computer.

See also

- [Back up files](#) on page 69

### Upgrade the FactoryTalk Batch components

After backing up files and uninstalling the previous version of FactoryTalk Batch, install the latest versions of FactoryTalk Batch components to upgrade FactoryTalk Batch to the latest version.

See also

- [Install the FactoryTalk Batch Server, Procedure Server, and FactoryTalk Event Archiver components](#) on page 35
- [Install the FactoryTalk Batch Client](#) on page 46
- [Install the Procedure Client](#) on page 51
- [Install the Material Manager Server](#) on page 57
- [Install the Material Manager Client](#) on page 61

### Post-upgrade tasks

This section describes steps to perform after upgrading the software.

- Restore back up files.
- Migrate area models and binary recipes, including XML or RDB recipes that were exported to binary before the upgrade.
- (Optional) Convert binary recipes back to XML or RDB.
Chapter 11  Upgrade FactoryTalk Batch

**Restore back up files**

Before opening the FactoryTalk Batch Recipe Editor or the FactoryTalk Batch Equipment Editor, restore backed up files to their original locations.

Do not delete installed FactoryTalk Batch, eProcedure or Material Manager product files from their installed locations. If installed product files are deleted from their original location, the Microsoft® Install Resiliency feature can cause unexpected failures and error messages. However, files can be replaced or overwritten with other files of the same name. For example, BatchIDCreation.dll, RAMSCustom.dll, and other hot fix files may be overwritten, but should NEVER be deleted and then replaced. To remove a product completely, access the Control Panel programs and features and choose to Uninstall the product.

**Batch Server and Client files**

Restore the following FactoryTalk Batch files by placing them into the appropriate directories.

- *.bmp files
- binary recipes (if using XML or RDB, first update the exported binary versions after upgrading the FactoryTalk Batch software and then export them back to XML or RDB format)
- area models
- BatchIDCreation.dll (if customized)
- DSDF files (if customized)

Do not restore the FactoryTalk Batch 12.01 module .ini files. The .ini files are backed up in the event that the installation is reverted to the previous installation.

- batcharc.ini (if customized). If no customization exists, do not restore the batcharc.ini file. Prior to restoring a customized batcharc.ini file, open the newly installed batcharc.ini file and copy the ArchiverTableName and ArchiverConnectionString lines. Paste these lines into the back up batcharc.ini file and then use that file as the restore file. Restoring the batcharc.ini file without copying these lines may revert the newly created connection string. If this occurs, restore the new connection string by using the Archiver Setup application.

**Material Manager files**

Restore the following Material Manager files and databases to their original locations:

- Materialserver.log file (Batch\bin folder)
MaterialBasedRecipe database

MaterialBasedRecipe_MAJ database

Sample2_Materials database (if used)

Any other material-based recipe databases unique to the facility

Tip: After restoring the material database, use the SQL Server Enterprise Manager to run the `MaterialTrack_db_schema_Procedures.sql` script, which deletes the old stored procedures and adds the new stored procedures. The script is located at: \Program Files\Rockwell Software\Batch\Scripts.

eProcedure files

Restore the following eProcedure files to their original locations:

- Instruction files
- User.asp files
- Any customized files that support the User.asp

FactoryTalk Event Archiver files

During FactoryTalk Event Archiver installation, the existing BatchHistory (or BatchHistoryEx) database is detected and any existing data is migrated to the new FactoryTalk Batch 13.00.02 database. This new database contains any stored procedures. Restore the following FactoryTalk Event Archiver files to their original locations:

- Customized reports

Migrate area models from FactoryTalk Batch version 13.0

To migrate area models from FactoryTalk Batch version 13:

1. Open FactoryTalk Batch Equipment Editor.
2. Select File > Open.
3. Navigate to and select the version 13 area model.

Prerequisites

- Use the FactoryTalk’ Administration Console to confirm that any linked FactoryTalk and Windows® users and groups that are required by signature templates are configured in the FactoryTalk Network Directory.
4. When prompted to update the equipment database, select **Yes**.

   If the area model uses signature templates and no FactoryTalk users and groups match, the **Security Permissions** in the signature template will be empty and require configuration. FactoryTalk Batch Equipment Editor displays a list of signature templates on which translation of security descriptors failed in the **Invalid Signoffs** dialog box.

5. Make a note of the affected templates and select **OK**. The migration completes.

   **Important:** If the Phase Failure enumeration set of an area model has ordinal values greater than 32767, reconfigure the values after migration. See **System enumeration sets** in the *FactoryTalk Batch Equipment Editor User Guide*.

6. Save the area model.

7. Open each signature template and configure the **Signoff Permissions**. See **Create a Signature Template** in the *FactoryTalk Batch Equipment Editor User Guide* for detailed instructions.

**See also**

*Migrate recipes from FactoryTalk Batch version 13* on page 74

The FactoryTalk Batch recipe schema changed from version 12.01.

The following instructions are for recipes stored in the default binary files and for migrating the binary recipes export of XML or RDB recipes.

**To migrate recipes from FactoryTalk Batch version 12.01:**

1. Open FactoryTalk Batch Recipe Editor.

2. If prompted to translate recipes, select **Yes**.

3. (optional) If auditing is enabled, enter appropriate comments in the **Audit Comments** dialog box.
4. Select **OK**. The **Recipes Requiring Verification** dialog box displays all of the recipes that require verification.

5. (optional) Select **Verify All** to verify the listed recipes. The **Verification Process Results** dialog box opens. If any errors occur during translation, they appear in the top portion of the dialog box.

6. Double-click an error message to open the recipe to the error.

   **Tip:** Select all of the error or warning text and copy it to a text editor to use the list while addressing the errors.

7. (optional) Close the dialog box. The verified recipes are copied back into the working set of recipes.

8. (optional) If auditing is enabled, the **Audit Comments** dialog box opens prior to saving the recipes. Enter appropriate comments, and select **OK**.

See also

**Export XML or RDB recipes to binary** on page 68

### Convert binary recipes to XML or RDB

After installing the latest version of FactoryTalk Batch components and migrating the area model, convert binary recipes and translate them to the applicable format (if using RDB or XML). This involves opening the binary files created in the **Export XML or RDB recipes to binary** section.

**To convert binary recipes to XML or RDB:**

1. Open FactoryTalk Batch Equipment Editor.

2. Select **Options > Server Options**.
3. In the Store Recipes Using section of the Server Options dialog box, select Binary Files and set the path to the binary files created in the Export XML or RDB recipes to binary section.

4. Open the binary area model that was backed up before upgrading. FactoryTalk Batch Equipment Editor prompts to migrate the area model. Accept the migration and then save the file. For more information about migrating area models, see Migrate area models from FactoryTalk Batch version 13.

5. If errors occur during migration, stop and fix the errors in the area model.

6. Open FactoryTalk Batch Recipe Editor. FactoryTalk Batch Recipe Editor automatically detects that the area model changed and prompts the start of recipe translation.

   Tip: FactoryTalk Batch Recipe Editor cannot open if the area model has not been migrated to the latest version in FactoryTalk Batch Equipment Editor.

7. Select Verify All. FactoryTalk Batch Recipe Editor attempts to verify all recipes. If the recipes have any verification errors, resolve any issues before proceeding.

8. Close FactoryTalk Batch Recipe Editor. If using binary format for the database, the recipe migration is finished.

See also

Convert migrated recipes back to XML format on page 76

Convert migrated recipes back to RDB format on page 86

Migrate area models from FactoryTalk Batch version 13 on page 73

---

**Convert migrated recipes back to XML format (optional)**

Use this procedure to convert updated binary recipes back to XML format.

**To convert migrated recipes back to XML format:**

1. Open FactoryTalk Batch Equipment Editor.

2. Select Options > Server Options.

3. In the Store Recipes Using section of the Server Options dialog box, select XML Files and set the path to the XML recipe location.

4. Open FactoryTalk Batch Recipe Editor and select File > Import Recipe Into Working Set.
5. In the **Import Recipe into XML directory** dialog box, select **Binary Files** and set the path to the location of the translated binary files.

6. Select all the recipes in the **Recipe Name** list, and then select **Import**. Recipes are imported into the working set of recipes in XML format.

**See also**

[Convert binary recipes to XML or RDB on page 75](#)

**Convert migrated recipes back to RDB format (optional)**

Use this procedure to convert migrated binary recipes back to RDB format.

**To convert migrated recipes back to RDB format:**

1. In FactoryTalk Batch Equipment Editor, select **Options > Server Options**.

2. In the **Server Options** dialog box, under **Store Recipes Using**, select **SQL Server Database**.

3. Select the node and database to store recipes.
   
   **Tip:** The default database is **masterrecipes**. Substitute a different database name, if needed.

4. Open FactoryTalk Batch Recipe Editor and select **File > Import Recipe Into Working Set**.

5. In the **Import Recipe into Database** dialog box, select **Binary Files** and set the path to the location of the migrated binary files.

6. Select all the recipes in the **Recipe Name** list, and then select **Import** to convert the recipes to RDB format and store in the database.

**See also**

[Convert binary recipes to XML or RDB on page 75](#)

**Recipe storage**

In the FactoryTalk Batch Equipment Editor, **Server Options** dialog box, under **Store Recipes Using** select one of the following options for storing recipes:

- **Binary Files (default format)**: Stores recipes in separate files according to the recipe level and specified directory:
  - Stores procedures as .bpc files
  - Stores unit procedures as .upc files
  - Stores operations as .uop files

- **Microsoft SQL Server Database**: Stores recipes in a SQL Server database.
Tip: If SQL Server is not installed on the same computer as the Batch Client, perform a custom install of SQL Server and install the Client Tools Connectivity option. This displays a list of available SQL Server databases in the Server Options dialog box.

- **XML Files**: Stores recipes in separate .xml files:
  - Stores procedures as .pxml files
  - Stores unit procedures as .uxml files
  - Stores operations as .oxml files
Uninstall FactoryTalk Batch version 13.00.02

This section describes how to uninstall FactoryTalk Batch version 13.00.02.

**Tip:** Users must have administrative privileges on the target computer to uninstall the software.

Use this procedure to uninstall all FactoryTalk Batch components on the computer at once.

**Prerequisites**

- Close all FactoryTalk Batch applications.
- Stop all Batch services.

**To uninstall the FactoryTalk Batch System:**

1. Navigate to Control Panel > Programs and Features, and then select Uninstall a Program.

2. On the Uninstall or change a program page, select FactoryTalk Batch system and select Uninstall. The Uninstall page opens with all FactoryTalk Batch installed components on the computer selected.

3. Select Uninstall. The uninstall program removes all FactoryTalk Batch components.

4. Select Close.

**See also**

- Uninstall the FactoryTalk Batch components on page 71
- Uninstall Material Manager on page 80
- Delete the default directories on page 81
- Delete databases on page 81
Uninstall the FactoryTalk Batch components

Use this procedure to uninstall individual FactoryTalk Batch components such as the FactoryTalk Batch Server, FactoryTalk Batch Client, and so on. To uninstall more than one component, select multiple components to uninstall from the Uninstall page. To uninstall all components at once, refer to the Uninstall FactoryTalk Batch System section.

Prerequisites

- Close all FactoryTalk Batch applications.
- Stop all Batch services.

To uninstall the FactoryTalk Batch components:

1. Navigate to Control Panel > Programs and Features, and then select Uninstall a Program.

2. On the Uninstall or change a program page, select the FactoryTalk Batch component and select Uninstall. The FactoryTalk Batch Uninstall dialog box opens.

3. On the Uninstall page, select the check box beside each component to remove.

4. Select Uninstall. The uninstall program removes the FactoryTalk Batch components.

5. Select Close.

See also

Uninstall Material Manager on page 80

Uninstall FactoryTalk Batch System on page 79

Delete the default directories on page 81

Delete databases on page 81

Uninstall Material Manager

Use this procedure to uninstall Material Manager to move it to another server or to permanently uninstall Material Manager.

Prerequisites

- Close all FactoryTalk Batch applications.
- Stop all Batch services.
- Allow the Message Queue to clear
To uninstall Material Manager:

1. Navigate to Control Panel > Programs and Features, and then select Uninstall a Program.

2. On the Uninstall or change a program page, select FactoryTalk Batch Material Manager and select Uninstall.

3. On the Uninstall page, verify the Material Manager option is selected, and then select Uninstall. The uninstall program removes Material Manager.

4. Select Close.

See also

- Uninstall the FactoryTalk Batch components on page 71
- Uninstall FactoryTalk Batch System on page 79
- Delete the default directories on page 81
- Delete databases on page 81

Delete the default directories (optional)

Use this procedure to delete the default directories or the directories of the FactoryTalk Batch components.

To delete the default directories:

1. In Windows Explorer, expand the Program Files (x86) folder, and select the Rockwell Software folder. The Batch folder displays in the right pane.

2. Right-click the Batch folder and select Delete. A message box confirms the deletion.

3. Select Yes.


See also

- Uninstall the FactoryTalk Batch components on page 71
- Uninstall Material Manager on page 80
- Uninstall FactoryTalk Batch System on page 79
Delete databases (optional)

After uninstalling FactoryTalk Batch, delete any remaining databases in SQL Server.

To delete databases:

1. Open SQL Server Management Studio and expand **Databases**.

2. Right-click each of the following databases, if they exist, and select **Delete**:
   - BatchHistory or BatchHistoryEx
   - MaterialBasedRecipe
   - MaterialBasedRecipe_MAJ
   - Sample2_Materials

3. Click **OK**.

See also

- Uninstall the FactoryTalk Batch components on page 71
- Uninstall Material Manager on page 80
- Uninstall FactoryTalk Batch System on page 79
Chapter 13

Troubleshoot Batch installation or upgrade

Use this section to troubleshoot installation or upgrade issues:

- Manually configure the Windows Firewall
- Define or reset a disabled Administrator account
- Communication with Batch Server times out
- Configure Internet Explorer security settings for Trusted Sites
- Internet Explorer’s intranet zone
- Run as Administrator for eProcedure Client on Windows Server operating systems

See also

Manually configure the Windows Firewall on page 83
Define or reset a disabled FactoryTalk Administrator account on page 84
Communication with Batch Server times out on page 85
Configure Internet Explorer security settings for Trusted Sites on page 85

Manually configure the Windows Firewall

If the Windows Firewall is enabled, and not externally controlled, the Windows Firewall Configuration Utility runs automatically. If this utility does not run automatically, manually run it on each computer in the FactoryTalk Batch system after installing servers or clients.

To manually configure the Windows Firewall:

1. Navigate to All Programs > Rockwell Software > FactoryTalk Tools > Windows Firewall Configuration Utility. The configuration utility starts.

2. If the firewall is not enabled, a dialog box may open. Select Yes to enable the firewall and continue.

3. On the Rockwell Software Windows Firewall Configuration Utility dialog box, review the list of suggested changes and select Accept.
4. On the **Confirm Windows Firewall Changes** dialog box, verify that the **New Firewall State** is set to **On with Exceptions** and select **OK**.

For a complete list of the exceptions made by the **Windows Firewall Configuration Utility**, refer to **FactoryTalk Batch Windows Firewall exceptions** in the *FactoryTalk Batch Administrator Guide*.

**See also**

*Enable the Windows Firewall on page 19*

**Define or reset a disabled FactoryTalk Administrator account**

The **FactoryTalk Directory Configuration Wizard** runs silently during the FactoryTalk Service Platform installation or upgrade. Run the wizard manually to define or reset a disabled Administrator account. FactoryTalk Batch and FactoryTalk Batch ActiveX Controls store client configuration settings in the Local and Network Directory.

To define or reset a disabled FactoryTalk Administrator account:

1. Open the **FactoryTalk Directory Configuration Wizard** located within the installed FactoryTalk Batch applications. The **FactoryTalk Directory Configuration Wizard** opens.

2. Select one or more options, and then select **Next**.

   - **Configure the FactoryTalk Network Directory**
   - **Configure the FactoryTalk Local Directory**

3. Complete one or more pages:

   - In **Reconfigure FactoryTalk Network Directory**, enter the User name and Password for an existing Network administrator account. Re-enter the password in the **Confirm password** box, and then select **Next**.
   - In **Reconfigure FactoryTalk Local Directory**, enter the User name and Password for an existing Local administrator account. Re-enter the password in the **Confirm password** box, and then select **Next**.

4. On the **Summary** window, select **Close**.
Communication with Batch Server times out

If the FactoryTalk Batch and eProcedure Servers run on a workgroup, add an Incoming Firewall Rule to allow the FactoryTalk Batch Service Manager to connect to the Server in a timely manner. For more information about adding an Incoming Firewall Rule, see Add an incoming firewall rule.

Disable Administrative Approval Mode for all administrators on the FactoryTalk Batch Server when running on a workgroup. This ensures that administrators do not have to install or run programs using elevated privileges. For more information about disabling Administrative Approval, see Disable Administrative Approval Mode.

See also

Add an incoming firewall rule on page 20

Disable Administrative Approval Mode on page 21

Configure Internet Explorer security settings for Trusted Sites

Use the following instructions to configure Internet Explorer security settings for Trusted Sites.

To configure Internet Explorer security settings for Trusted Sites:

1. Using Internet Explorer, navigate to Tools > Internet Options.
2. Select the Security tab.
3. Select Trusted sites.
4. Under Security level for this zone, drag the slider to lower the Security Level for the Trusted sites zoneto Low or Medium-low.
5. If the eProcedure Trusted sites differ from the default installation, verify that the eProcedure Server computer and about:blank sites appear in the Trusted sites > Sites list.

See also

Internet Explorer's intranet zone on page 86
Internet Explorer’s intranet zone

The installation of the eProcedure Server installs a `Security_HKLM_Only` key and sets the key to 1 (enabled). The key exists in the location:

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Current Version\Internet Settings

Internet Explorer uses intranet security settings when:

- The `Security_HKLM_Only` key is 0 (disabled) or removed
- The eProcedure Server name does not appear on the list of trusted sites
- The site qualifies as an intranet site

Configure the ActiveX settings for the intranet zone.

See also

Configure Internet Explorer security settings for Trusted Sites on page 85

Run as Administrator on eProcedure Client on Windows Server operating systems

Run the eProcedure Client on a Windows Server machine and obtain the required privileges to execute the eProcedure Client.

To run as Administrator on Windows Server operating systems:

- Right-click the eProcedure Client icon and select Run as administrator.

Manually recreate the masterrecipes database

If the database name is not `masterrecipes`, follow these steps to edit the .bat file and the `createmasterrecipedb.sql` script to specify the name of the database and recreate it. If the database needs to be recreated at any time, the .bat file can also be used to recreate it.

Tip: If Store recipes in RDB format was selected when installing FactoryTalk Batch, running the `createmasterrecipedb.bat` file is not required.

Prerequisites

- Use the `Rockwell Software\Batch\Scripts\createmasterrecipedb.bat` file to recreate the recipe database.
Tip: This batch file uses the default database name `masterrecipes`. It executes the following SQL scripts in the Batch\Scripts folder to create the database and tables:
- `createmasterrecipedb.sql`
- `createrecipetables.sql`

To manually recreate the `masterrecipes` database:

1. Edit `Batch\Scripts\createmasterrecipedb.bat` using a text editor. Replace `masterrecipes` with the database filename.

2. Edit the `createmasterrecipedb.sql` script using either SQL Server Management Studio or another editor to specify the database file name.

3. Run the `Batch\Scripts\createmasterrecipedb.bat` file to create the database and tables.
Legal Notices

Copyright notice

Copyright © 2018 Rockwell Automation Technologies, Inc. All Rights Reserved. Printed in USA.

This document and any accompanying Rockwell Software products are copyrighted by Rockwell Automation Technologies, Inc. Any reproduction and/or distribution without prior written consent from Rockwell Automation Technologies, Inc. is strictly prohibited. Please refer to the license agreement for details.

End User License Agreement (EULA)

You can view the Rockwell Automation End-User License Agreement (“EULA”) by opening the License.rtf file located in your product's install folder on your hard drive.

Trademark Notices

Allen-Bradley, CompactLogix, ControlLogix, Connected Components Workbench, eProcedure, FactoryTalk, GuardLogix, GuardPLC, Micro800, MicroLogix, MobileView, MobileView Guard, PanelBuilder, PanelView, PhaseManager, PlantLink, PlantPAx, PLC-2, PLC-3, PLC-5, PowerMonitor, RSBizWare, RSBizWare BatchHistorian, RSBizWare Historian, RSBizWare MaterialTrack, RSLinx, Rockwell Automation, Rockwell Software, SLC, SoftLogix, Studio 5000, and X Mare trademarks of Rockwell Automation, Inc.

Any Rockwell Automation software or hardware not mentioned here is also a trademark, registered or otherwise, of Rockwell Automation, Inc.

For a complete list of products and their respective trademarks, go to: http://www.rockwellautomation.com/rockwellautomation/legal-notices/overview.page#tab4

Warranty

This product is warranted in accordance with the product license. The product’s performance may be affected by system configuration, the application being performed, operator control, maintenance, and other related factors. Rockwell Automation is not responsible for these intervening factors. The instructions in this document do not cover all the details or variations in the equipment, procedure, or process described, nor do they provide directions for meeting every possible contingency during installation, operation, or maintenance. This product’s implementation may vary among users.
This document is current as of the time of release of the product; however, the accompanying software may have changed since the release. Rockwell Automation, Inc. reserves the right to change any information contained in this document or the software at any time without prior notice. It is your responsibility to obtain the most current information available from Rockwell when installing or using this product.

**Environmental compliance**


**Contact Rockwell Automation**

Customer Support Telephone — 1.440.646.3434

Index

C
correct messages when viewing eProcedure pages 50

T
troubleshoot
correct messages when viewing eProcedure pages 50
Rockwell Automation support

Rockwell Automation provides technical information on the web to assist you in using its products. At http://www.rockwellautomation.com/support you can find technical and application notes, sample code, and links to software service packs. You can also visit our Support Center at https://rockwellautomation.custhelp.com for software updates, support chats and forums, technical information, FAQs, and to sign up for product notification updates.

In addition, we offer multiple support programs for installation, configuration, and troubleshooting. For more information, contact your local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/services/online-phone.

Installation assistance

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can contact Customer Support for initial help in getting your product up and running.

<table>
<thead>
<tr>
<th>United States or Canada</th>
<th>1.440.646.3434</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States or Canada</td>
<td>Use the Worldwide Locator available at <a href="http://www.rockwellautomation.com/locations">http://www.rockwellautomation.com/locations</a>, or contact your local Rockwell Automation representative.</td>
</tr>
</tbody>
</table>

New product satisfaction return

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. However, if your product is not functioning and needs to be returned, follow these procedures.

<table>
<thead>
<tr>
<th>United States</th>
<th>Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to your distributor to complete the return process.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States</td>
<td>Please contact your local Rockwell Automation representative for the return procedure.</td>
</tr>
</tbody>
</table>

Documentation feedback

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, complete the feedback form, publication RA-DU002.

www.rockwellautomation.com