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Chapter

1 Installing RSView32 
RecipePro

About RSView32 RecipePro
RSView32 RecipePro™ extends the functionality of RSView32™ with 
advanced recipe management. RSView32 RecipePro integrates directly with 
the RSView32 Project Manager window. With RSView32 RecipePro, you can 
configure multiple recipe projects and easily transfer recipe process data to and 
from your automation equipment.

System requirements
RSView32 RecipePro requires RSView32 version 7.60.00. Recommended 
requirements for RSView32 RecipePro are based on the requirements for 
RSView32.

Recommended hardware. Personal computer with 200 MHz Intel® 
Pentium® processor and 64 MB of RAM. Individual applications may require 
a faster processor or more RAM. For detailed recommendations consult the 
publication "Getting Results with RSView32" or check the RSView32 Support 
Library on the Rockwell Software website.

Recommended operating systems. Microsoft® Windows® Server 2003 R2 
Standard Edition with Service Pack 2, Windows XP Professional with Service 
Pack 1 or later, Microsoft Windows 2000 Server with Service Pack 4 or 
Windows 2000 Professional with Service Pack 4; Windows Vista Business with 
Service Pack 1 or later (32-Bit) or Windows Vista Home Basic with Service 
Pack 1 or later (32-Bit); Windows 7 Professional (32-Bit); and Windows Server 
2008 Standard Edition with Service Pack 2 (32-Bit) are supported. 
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Installing RSView32 RecipePro
As part of the installation process, RSView32 RecipePro creates program 
folders and modifies registry entries in your computer's operating system. 
When installing RSView32 RecipePro, you must be logged in as a user with 
administrator rights to allow the installation program to modify the registries.

RSView32 RecipePro installs as an extension to RSView32 and does not 
require separate activation.

To configure and run RecipePro projects, install the full RSView32 RecipePro 
development and runtime software on the same computer where RSView32 is 
installed. 

Installing RSView32 RecipePro with RSView32 
Active Display System
RSView32 Active Display System™ is a client/server option that allows you to 
interact with your RSView32 applications remotely-across either a Local Area 
Network or the Internet. For information about installing and using RSView32 
Active Display System, refer to the publication, "Getting Results with 
RSView32 Active Display System."

To use RSView32 RecipePro with RSView32 Active Display System:

1. Install the full RSView32 RecipePro development and runtime software on 
the same computer where RSView32 and the RSView32 Active Display 
System Server are installed. (During installation, select "Full Install.")
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2. Install the RSView32 RecipePro ActiveX™ control on each computer 
where an RSView32 Active Display Client is installed. (During installation, 
select "Controls Only.")

Installation steps
The steps below explain how to install RSView32 RecipePro software from a 
CD ROM to your computer. Before installing RSView32 RecipePro, be sure 
that either RSView32 7.60.00 or RSView32 Active Display System is installed 
on the computer.

1. Close all open Windows programs.

2. Place the RSView32 RecipePro CD-ROM in your CD-ROM drive. The 
CD-ROM should start running automatically.
If the CD-ROM does not start automatically, run D:\SETUP.EXE where 
D is the drive containing the CD-ROM.

3. Follow the on-screen instructions. 

4. In the Select Components window, select either Full Install or Controls 
Only. 

 To install the complete RSView32 RecipePro development and runtime 
system, select Full Install.

 To install the RSView32 RecipePro ActiveX control with the RSView32 

So that client windows always reflect the most up-to-date 
information, change your system Internet settings to check 
for newer versions each time a display is opened. The steps 
to do this vary, depending on the browser installed on your 
computer.
The steps below apply to Microsoft Internet Explorer 4.x, 
5.x and 6.x:
1. From the Start menu, select Settings > Control Panel > 

Internet.

2. Click the General tab.

3. In the Temporary Internet files area, click the Settings 
button.

4. Select the option: Every visit to the page.

TIP
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Active Display System client, select Controls Only.

5. After installation is complete, shut down and restart your computer before 
running RSView32.
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Chapter

2 Getting started with 
RSView32 RecipePro

Welcome to RSView32 RecipePro
RSView32 RecipePro extends the functionality of RSView32 with advanced 
recipe management. With RSView32 RecipePro, you can configure multiple 
recipe projects and easily transfer recipe process data to and from your 
automation equipment. Each recipe project includes ingredients, tag sets 
(which specify destinations for ingredient values), data sets (which specify 
values for ingredients), and recipe units (which link data sets and tag sets for 
uploading and downloading), all arranged in an easy-to-use spreadsheet. 
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RecipePro allows you to easily import existing WINtelligent Recipe™ and 
other RecipePro recipe files into new RecipePro projects. RecipePro also 
provides a quick and easy way to print a detailed report of all of the elements 
in a recipe file.

The runtime operator interface to RecipePro functionality is through an 
ActiveX control that you insert in a standard RSView32 graphic display. 

Exploring RSView32 RecipePro
RSView32 RecipePro integrates with the RSView32 Project Manager.

RSView32 RecipePro consists of these parts:

 RecipePro Setup. Define project-level default settings.

 RecipePro Editor. Configure recipe files, download and upload recipe 
values, import WINtelligent Recipe files, and generate and print recipe 
reports.

 RecipePro Operator Control Panel. Configure the runtime operator 
interface. 

 RecipePro commands. Upload and download recipe units and edit the 
recipe file during runtime.
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RecipePro Setup 
Use RecipePro Setup to configure optional project-level defaults. Project-level 
settings include selecting the text color that displays in RecipePro spreadsheets, 
sending detailed messages to the RSView32 Activity Log to help debug recipe 
scenarios, setting the level of communication testing before downloads, and 
enabling or disabling download scaling. Project-level scaling controls whether 
operators can enter a scale factor, to proportionally modify all scalable 
ingredients in a recipe by a specified percentage, when downloading.

RecipePro Editor
Use the RecipePro Editor to configure recipe files, each of which can include 
up to 5000 ingredients, 1000 data sets, 500 tag sets, and 5000 recipe units. An 
ingredient is the starting point of a RecipePro file. A tag set is a collection of 
RSView32 tags, one tag for each ingredient, which specifies the destinations for 
ingredient values. A data set is a collection of values, one value for each 
ingredient. The data can be a numeric value, such as 137; a string value, such as 
"stop process"; a 0 or 1 for a digital ingredient such as add or don't add, mix or 
don't mix; or the name of an RSView32 tag. 
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A recipe unit links any tag set to any data set in a recipe file for uploading and 
downloading recipe values to your automation equipment.

For example, suppose a facility mixes two different products on the same line 
during different shifts. By creating separate data sets for each product, you can 
download different ingredient values to the same line (identified by one tag set).

A recipe unit includes:

 Security. Uses RSView32 security codes to control which recipe units 
individual operators can use at runtime.

 Scale default. Proportionally modifies scalable ingredient values by a 
specified percentage for adjustable batch sizes.

 Commands. Runs specified RSView32 commands before or after each 
download or upload. For example, increment a memory tag to log the 
number of times a recipe unit is downloaded or uploaded.

RecipePro Operator Control Panel ActiveX control
Insert the RecipePro Operator Control Panel ActiveX control in an RSView32 
graphic display to configure the runtime operator interface.  
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Possible runtime functions include:

 downloading and uploading recipe units

 uploading a tag set's values into a new data set and creating a corresponding 
new recipe unit

 proportionally scaling recipe unit values on downloads

 manually entering new recipe unit values before downloading

 previewing and verifying uploaded and downloaded values

Only those ingredients for which the operator has security authorization are 
listed in the Preview and Manual Entry windows.

RSView32 RecipePro commands
Installing RecipePro adds new commands to RSView32. 

 RecipeProEdit. Opens the RecipePro Editor for the specified RecipePro 
file.

 RecipeProDownloadUnit. Downloads a recipe unit, sending the values 
specified in a data set to the locations specified in a tag set.

 RecipeProUploadUnit. Uploads a recipe unit, sending data from the 
locations specified in a tag set to the values specified in a data set.

Quick Start steps
The following steps guide you through configuring and running a simple 
RecipePro project, using the RecipePro Sample project (RecipePro 
Sample.rsv). In this scenario, we create one recipe file with two recipe units that 
hold the instructions for mixing two types of cookies using the same set of 
process tags. The recipe file also holds instructions for applying a chocolate 
coating to one type of cookie. 

For details and more information as you work through these
steps, click the Help button on any tab.

TIP
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Step 1   Create a new recipe file 
A RecipePro recipe file contains all of the information about a recipe, including 
its ingredients, data sets, tag sets, and recipe units. Recipe files use the extension 
.RDB.

1. Start RSView32 and open the project named RecipePro Sample.rsv.

2. From the RSView32 Project Manager, double-click the RecipePro Editor 
to create a new recipe file.

3. To save the new recipe file, select File > Save As. Type the name Quick 
Start. (If a file with that name already exists, click Yes to replace it with 
your new recipe file.)

Step 2    Create ingredients 
A RecipePro ingredient is the starting point of a recipe file. An ingredient might 
be an element in a product, such as flour, sugar, pigment, or binding agent, or 
it might be an element in a process, such as temperature, mixing speed, or 
bottle size. 

1. On the Ingredients tab, click the New Ingredient button.

2. In the Ingredients' Name box, type Chocolate Chips. Leave the other 
default values unchanged, and click Apply.
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3. Create the following ingredients in the same way:

 Coconut

 Batter Base

4. Create another ingredient named Chocolate Coating. In the Ingredients' 
datatype box, select Digital. Click Apply.
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5. Create a last ingredient named Cookie Name. In the Ingredients' datatype 
box, select String. Click OK.

6. To see all of the information about your new ingredients, click and drag 
column dividers in the spreadsheet.

Step 3    Create a tag set
A RecipePro tag set is a collection of RSView32 tags, one tag for each 
ingredient in a recipe file, which specifies the destinations for ingredient values. 
A single list of ingredients can use multiple tag sets.

1. On the Ingredients tab, click the New Tag Set button.
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2. So that you can see the new tag set column, click and drag the column 
divider.

3. To change its name, double-click the Tag Set column heading. In the 
Name box, type Cookie Process Tags. Click OK.

4. Attach RSView32 tags to each ingredient. In the first row of the 
spreadsheet, right-click [Undefined] in the Cookie Process Tags (tag set) 
column. From the context menu, select Tag Browser.
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5. In the Folders pane of the Tag Browser window, open the QuickStart 
folder. In the Tags pane, select the tag QuickStart\ChocChips. Click 
OK.

6. For each of the other ingredients, attach a corresponding tag from the 
QuickStart folder.

Step 4    Create a data set
A data set is a collection of values, one value for each ingredient in a recipe file. 
The data can be a numeric value, such as 137; a string value, such as "stop 
process"; a 0 or 1 for a digital ingredient such as add or don't add, mix or don't 
mix; or the name of an RSView32 tag. Data values must be consistent with the 
ingredient's data type. A single list of ingredients can use multiple data sets.

1. On the Ingredients tab, click the New Data Set button.
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2.To change its name, double-click the Data Set column heading. In the Name 
box, type ChocoChews data. In the Description box, type Chewy 
chocolate cookies. Click OK.

3. In the Data Set column, type the following values to correspond with each 
ingredient:

 Chocolate chips - 90

 Coconut - 33

 Batter base - 40

 Chocolate coating - 0
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 Cookie name - "ChocoChews" (be sure to use quotation marks)

4. Create another new data set to hold ingredient values for chewy coconut 
cookies. Click the New Data Set button. Change the data set name to 
CocoNummies data and the description to Chewy coconut cookies.

5. In the CocoNummies data set column, type the following values to 
correspond with each ingredient:

 Chocolate chips - 0

 Coconut - 80

 Batter base - 20

 Chocolate coating - 1

 Cookie name - "CocoNummies" (be sure to use quotation marks)
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Step 5    Create a recipe unit
A RecipePro recipe unit links any tag set, which specifies where to download 
each ingredient value, with any data set, which holds the value for each 
ingredient in a recipe. 

1. In the RecipePro Editor, click the Units tab.

2. To create a new recipe unit for chewy chocolate cookies, click the New 
button.

3. In the Unit Properties window, make these entries, and then click OK.

 Name - ChocoChews

 Tag set - Cookie Process Tags

 Data set -  ChocoChews data

4. To create a new recipe unit for chewy coconut cookies, click the New 
button.

5. In the Unit Properties window, type these entries, and then click OK.

 Name -  CocoNummies

 Tag set -  Cookie Process Tags

 Data set -  CocoNummies data
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6. To save the recipe file, select File > Save. Then click the Close button.

Step 6    Configure an Operator Control Panel
The RecipePro Operator Control Panel is an ActiveX control that you insert 
inside an RSView32 graphic display. How you configure the control's 
properties determines which RecipePro functions operators have available at 
runtime.

1. Open the graphic display named Quick Start.

2. Insert the RecipePro Operator Control Panel ActiveX control.

Use the ActiveX Toolbox to insert an ActiveX control, or from the 
RSView32 menu, select Objects > ActiveX Control.

3. To edit its properties, double-click the RecipePro Operator Control Panel.
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4. In the Default Recipe Database File box, select Quick Start. In the 
Display area, select Units. Leave the other entries set to the defaults. Click 
OK.

5. Save and close the graphic display.

Step 7    Run your RecipePro project 
1. Run the RSView32 RecipePro project. 

2. From the project main display, click Quick Start Project.

3. On the ReicpePro Operator Control Panel, select the ChocoChews recipe 
unit.

4. Click the Download button. Notice the process values change in the 
hoppers for each ingredient.

5. On the RecipePro Operator Control Panel, select the CocoNummies 
recipe unit.
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6. Click the Download button. Notice the process values change in the 
hoppers for each ingredient.

7. On the RecipePro Operator Control Panel, change the Download Scale 
Factor to 50%, and then click Download.

8. In the Mode box, select Manual Entry, and then click Download. Change 
several ingredient values, and then click Download again.

9. When you finish experimenting with your project, click the Close button. 
Stop the project and return to Edit Mode.

To check your results against a completed Quick Start 
project, click the Show Finished Quick Start Display 
button.

TIP
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Chapter

3 Getting the information 
you need

Using RSView32 RecipePro online help
RSView32 RecipePro online help provides overviews, reference information, 
and step-by-step procedures for working with all of the features in RSView32 
RecipePro. To open online help while running RSView32 you can: 

 click the Help button on any window

 on the RSView32 menu bar, click Help>Contents. 

GR-PRro-062399.book  Page 21  Thursday, July 14, 2011  7:43 AM



22     Getting Results with RSView32 RecipePro 

Viewing and printing the help contents
For an overview of the RSView32 RecipePro help, click the Contents tab, and 
then double-click the RSView32 RecipePro book.

To print a group of help topics, select a book from the Contents tab, and then 
click the Print button. All of the individual topics contained within that book 
will print.
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Using the index
The help index is similar to an index in a book, listing keywords for topics in 
the help. To see the index, click the Index tab.

To see a topic, double-click the topic, or highlight the topic and click Display. 
If the index entry refers to more than one topic, the Topics Found box opens. 
Double-click a topic, or select a topic and click Display.

Finding RSView32 RecipePro version information
To find the RSView32 RecipePro version number and serial numbers, click 
Help>About RSView32 and click the Add-ons button. Select RSView32 
RecipePro, and then click the Details button.
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Exploring the RSView32 RecipePro sample project
Installing RSView32 RecipePro also installs a sample project that you can use 
to learn how to customize your own applications. To see a RecipePro project 
in action, and to get ideas for building your own RecipePro application in 
RSView32, tour the RSView32 RecipePro Sample project. In the directory 
where you installed RSView32 RecipePro, look for this file: RecipePro 
Sample.rsv.

To step through configuring and running a simple RecipePro project on your 
own, follow the Quick Start steps found in Chapter 2 of this guide, or available 
in the RecipePro online help.

For more information
For information about RSView32, refer to the following publications. 

If you have a web browser installed on your computer and a current Internet 
connection, you can find a wealth of information available on the Rockwell 
Software website. In RSView32, click Help>Rockwell Software on the Web, 
and select a home page to view. 

Getting Results with RSView32

Rockwell Software
Publication ID: VW32-GR001E-

EN-E

Getting Results with RSView32 

Active Display system

Rockwell Software
Publication ID:VW32AD-

GR001D-EN-E 

RSView32 User’s Guide

Rockwell Software
Publication ID: VW32-UM001E-

EN-E  

Also available on the RSView32 

installation CD-ROM and from the 

Programs>Rockwell Soft-

ware>RSView32 menu.
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Technical support
If you have a question about RSView32 RecipePro, please consult this guide or 
the RSView32 RecipePro online help. If you cannot find the answer, call 
Rockwell Software Technical Support: 440-646-3434.

When you call, you should be at a computer running RSView32 RecipePro and 
be prepared to give the following information:

 RSView32 and RecipePro product version numbers

 hardware you are using

 exact wording of any messages that appeared on the screen

 description of what happened when the problem occurred

 description of how you tried to solve the problem
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