Important user information

Read this document and the documents listed in the additional resources section about installation, configuration, and operation of this equipment before you install, configure, operate, or maintain this product. Users are required to familiarize themselves with installation and wiring instructions in addition to requirements of all applicable codes, laws, and standards.

Activities including installation, adjustments, putting into service, use, assembly, disassembly, and maintenance are required to be carried out by suitably trained personnel in accordance with applicable code of practice. If this equipment is used in a manner not specified by the manufacturer, the protection provided by the equipment may be impaired.

In no event will Rockwell Automation, Inc. be responsible or liable for indirect or consequential damages resulting from the use or application of this equipment.

The examples and diagrams in this manual are included solely for illustrative purposes. Because of the many variables and requirements associated with any particular installation, Rockwell Automation, Inc. cannot assume responsibility or liability for actual use based on the examples and diagrams.

No patent liability is assumed by Rockwell Automation, Inc. with respect to use of information, circuits, equipment, or software described in this manual.

Reproduction of the contents of this manual, in whole or in part, without written permission of Rockwell Automation, Inc., is prohibited.

Throughout this manual, when necessary, we use notes to make you aware of safety considerations.

![WARNING](image)

**WARNING:** Identifies information about practices or circumstances that can cause an explosion in a hazardous environment, which may lead to personal injury or death, property damage, or economic loss.

![ATTENTION](image)

**ATTENTION:** Identifies information about practices or circumstances that can lead to personal injury or death, property damage, or economic loss. Attentions help you identify a hazard, avoid a hazard, and recognize the consequence

**Important:** Identifies information that is critical for successful application and understanding of the product.

Labels may also be on or inside the equipment to provide specific precautions.

![SHOCK HAZARD](image)

**SHOCK HAZARD:** Labels may be on or inside the equipment, for example, a drive or motor, to alert people that dangerous voltage may be present.

![BURN HAZARD](image)

**BURN HAZARD:** Labels may be on or inside the equipment, for example, a drive or motor, to alert people that surfaces may reach dangerous temperatures.

![ARC FLASH HAZARD](image)

**ARC FLASH HAZARD:** Labels may be on or inside the equipment, for example, a motor control center, to alert people to potential Arc Flash. Arc Flash will cause severe injury or death. Wear proper Personal Protective Equipment (PPE). Follow ALL Regulatory requirements for safe work practices and for Personal Protective Equipment (PPE).

Allen-Bradley, Rockwell Software, Rockwell Automation, and TechConnect are trademarks of Rockwell Automation, Inc.

Trademarks not belonging to Rockwell Automation are property of their respective companies.
# Table of contents

## Preface
- About this guide .................................................................................................................... 7
- Intended audience ................................................................................................................... 7
- Document conventions ......................................................................................................... 7
- Commonly used terms ........................................................................................................... 7
- Legal Notices .......................................................................................................................... 7

## Chapter 1
- System requirements .......................................................................................................... 11
- Activation ............................................................................................................................... 12
- System installation ............................................................................................................... 12
  - Install and activate RSLogix 500 or RSLogix Micro ...................................................... 13
  - Upgrade FactoryTalk Services Platform ......................................................................... 17
  - Import a security configuration ........................................................................................ 17
  - Configure FactoryTalk Security ....................................................................................... 19
    - Set security policies for RSLogix 500 ......................................................................... 19
    - Secure Actions for RSLogix 500 ................................................................................. 21
    - Set global security ......................................................................................................... 21
    - Set controller security to not inherit permissions ................................................... 21
  - Launch the application ...................................................................................................... 22
  - Troubleshoot the installation .......................................................................................... 22

## Chapter 2
- Explore RSLogix 500 and RSLogix Micro ........................................................................... 26
- Quick Start Steps ................................................................................................................ 26
  - Configure a driver in RSLinx Classic ............................................................................ 26
  - Configure system communications ............................................................................... 28
  - Create a new project or open an existing project .......................................................... 28
    - Create a new project ..................................................................................................... 28
    - Open an existing project .............................................................................................. 28
    - The project tree .......................................................................................................... 28
    - Open Multiple Files .................................................................................................... 28
  - Create program and data table files ............................................................................... 29
  - Define chassis and modules ............................................................................................ 29
  - Enter rungs in the program .............................................................................................. 29
  - Add documentation to your logic instructions ............................................................... 30
  - Verify your project .......................................................................................................... 30
  - Configure communication channel, download and go online ...................................... 31
  - Monitor data files ............................................................................................................. 31
  - Search and replace instructions ...................................................................................... 31
  - Print a report ..................................................................................................................... 32
## Table of contents

### Chapter 3

**Chassis and module setup**
- Power supply loading ................................................................. 33
- Analog and specialty modules ............................................... 33
- Automatic I/O configuration .................................................... 33

**Enter ladder logic**
- Back up your work ............................................................................. 35
- Crash Recovery .................................................................................. 35
- Quick instructions entry ................................................................. 36
- Addressing ......................................................................................... 36
- Branching .......................................................................................... 36
  - Add a branch .................................................................................... 36
  - Move a branch ................................................................................ 36
  - Expand a branch ............................................................................ 37
  - Nested branches ............................................................................ 37
  - Parallel branches ........................................................................... 37
  - Copy branch leg ............................................................................. 37
  - Copy entire branch structure .......................................................... 37
  - Delete a branch .............................................................................. 38
  - Branching restrictions ................................................................. 38
- Undo operation ................................................................................ 38
- Online editing .................................................................................. 38
  - Lowercase zone markers ............................................................... 38
  - Uppercase zone markers ................................................................. 39
  - Online editing example ................................................................. 39
  - Online editing restrictions ............................................................ 40
- ASCII Editor ..................................................................................... 40
- Configure interrupts ........................................................................ 41
  - Selectable Timed Interrupt ............................................................. 41
  - Discrete Input Interrupt/Event Input Interrupt ......................... 41
- Floating instruction palette ......................................................... 42

### Chapter 4

**Import and export a database**
- Import database ............................................................................. 43
  - A.I. project documentation database ........................................ 43
  - APS project documentation database ...................................... 43
  - Documentation database ............................................................ 44
  - Comma Separated Values (CSV) file ......................................... 44
  - ASCII delimited text file ............................................................. 44
Chapter 6

Export database

Example text files ................................................................. 47
Address symbols and descriptions (.EAS files) ...................... 47
Page title and rung descriptions (.ERP files) ......................... 47
Instruction comments (.EIC files) ......................................... 48
Symbol groups (.ESG files) .................................................. 48
A.I. ASCII delimited text file examples .................................. 49
Address symbols and descriptions (.EAS files) ...................... 49
Page title and rung descriptions (.ERP files) ......................... 49
APS ASCII delimited text file ................................................. 49
CSV format ........................................................................... 49

Chapter 7

Monitor Data

Multipoint Monitor ............................................................... 51
Forces .................................................................................. 52
Custom Data Monitor (CDM) ................................................ 52
Custom Graphical Monitor .................................................. 53
Recipe Monitor .................................................................... 53
Trends .................................................................................. 53
Histograms .......................................................................... 53
Data Logging ........................................................................ 54
Cross Reference ................................................................... 54

Chapter 8

Save and load SLC libraries

Export libraries ..................................................................... 57
Import libraries ..................................................................... 57

Chapter 9

Developer features

Visual Basic for Applications support .................................... 59
Custom Graphical Monitor .................................................. 59
Edit databases with Excel .................................................... 59
Logic Trace .......................................................................... 60
How logic trace works ........................................................ 60

Chapter 10

For more information

User Application Help .......................................................... 63
Instruction Set Help ............................................................... 63

Index
About this guide

This *Getting Results Guide* provides information on how to install and navigate RSLogix 500®. This guide includes troubleshooting information and tips on how to effectively use RSLogix 500. It explains how to access and navigate the online help.

Intended audience

We assume that you are a controls engineer familiar with:

- Microsoft® Windows.
- Rockwell Automation® SLC™ 500 and MicroLogix™ families of controllers.

Document conventions

This guide uses the following conventions:

- **Bold** characters represent keystrokes used to execute a function. When more than one key is to be pressed at a time, the keys are separated by a plus sign. For example, `Ctrl + v` means hold down the `Ctrl` key and press the `v` key.
- **Bold** characters represent menu choices.

Commonly used terms

The following terms are used in this book.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>activation files</td>
<td>Text files required for the software to properly function. Activation files cannot be copied to another computer.</td>
</tr>
<tr>
<td>library</td>
<td>A file to store portions of ladder logic.</td>
</tr>
<tr>
<td>mnemonic</td>
<td>An easy to remember abbreviation for an instruction. SLC instructions are typically represented by a three-letter mnemonic.</td>
</tr>
<tr>
<td>project</td>
<td>All of the files that make up the SLC 500 logic program including the documentation files.</td>
</tr>
<tr>
<td>upload</td>
<td>Access an SLC processor and save a copy of the project.</td>
</tr>
<tr>
<td>verification</td>
<td>An analysis of the ladder program files that results in the display of any programming errors.</td>
</tr>
<tr>
<td>zone</td>
<td>Portion of the ladder logic identified by a marker indicating the edited state of the file.</td>
</tr>
</tbody>
</table>

Legal Notices

Copyright notice

Copyright © 2018 Rockwell Automation Technologies, Inc. All Rights Reserved. Printed in USA.

This document and any accompanying Rockwell Software products are copyrighted by Rockwell Automation Technologies, Inc. Any reproduction and/or distribution without prior written consent from Rockwell Automation...
Technologies, Inc. is strictly prohibited. Please refer to the license agreement for details.

**End User License Agreement (EULA)**

You can view the Rockwell Automation End-User License Agreement ("EULA") by opening the License.rtf file located in your product’s install folder on your hard drive.

**Open Source Licenses**

The software included in this product contains copyrighted software that is licensed under one or more open source licenses. Copies of those licenses are included with the software. Corresponding Source code for open source packages included in this product are located at their respective web site(s).

Alternately, obtain complete Corresponding Source code by contacting Rockwell Automation via the Contact form on the Rockwell Automation website: [http://www.rockwellautomation.com/global/about-us/contact/contact.page](http://www.rockwellautomation.com/global/about-us/contact/contact.page) Please include "Open Source" as part of the request text.

A full list of all open source software used in this product and their corresponding licenses can be found in the OPENSOURCE folder included with the product’s Release Notes. The default installed location of these licenses is C:\Program Files (x86)\Rockwell Software\RSLogix 500 English\RSLogix 500 Release Notes\OPENSOURCE\index.htm.

**Trademark Notices**


Any Rockwell Automation software or hardware not mentioned here is also a trademark, registered or otherwise, of Rockwell Automation, Inc.

**Other Trademarks**

Microsoft, Excel, Visual Basic, Windows and ActiveX are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Adobe, Reader, and Acrobat are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.
Intel is either a registered trademark or trademark of Intel Corporation in the United States and/or other countries.

All other trademarks are the property of their respective holders and are hereby acknowledged.

Warranty

This product is warranted in accordance with the product license. The product’s performance may be affected by system configuration, the application being performed, operator control, maintenance, and other related factors. Rockwell Automation is not responsible for these intervening factors. The instructions in this document do not cover all the details or variations in the equipment, procedure, or process described, nor do they provide directions for meeting every possible contingency during installation, operation, or maintenance. This product’s implementation may vary among users.

This document is current as of the time of release of the product; however, the accompanying software may have changed since the release. Rockwell Automation, Inc. reserves the right to change any information contained in this document or the software at any time without prior notice. It is your responsibility to obtain the most current information available from Rockwell when installing or using this product.

Environmental compliance


Contact Rockwell Automation

Customer Support Telephone — 1.440.646.3434

Online Support — http://www.rockwellautomation.com/support/
Chapter 1

Installation

This chapter describes how to install and start RSLogix 500 and RSLogix Micro. This includes information on the following:

- System requirements.
- Installation methods.
- Activation overview and methods.
- Installation and activation procedures.
- Startup procedures.
- Troubleshooting installation and activation.


**Important:** You must have administrator privileges in order to install RSLogix 500 or RSLogix Micro. For more information, contact your system administrator.

**System requirements**

Your personal computer must meet the following hardware and software requirements:

**Hardware requirements**

- Intel® Core 2 Duo, 2.8 Ghz processor
- 2 GB of RAM or more
- at least 2.5 GB of available hard disk space
- 256-color SVGA graphics adapter with 800 x 600 resolution
- any Windows-compatible mouse or other pointing device

We recommend a 2.8 Ghz Core computer with 2 GB RAM or greater for optimal performance.
Software requirements

- Windows 7 Professional with Service Pack 1 (32-bit, 64-bit)
- Windows 7 Enterprise with Service Pack 1 (32-bit, 64-bit)
- Windows 10 Professional (32-bit, 64-bit)
- Windows 10 Enterprise (32-bit, 64-bit)
- Windows 10 IoT Enterprise 2016 Long Term Servicing Branch (LTSB) Embedded
- Windows Server 2008 R2 Standard with Service Pack 1 (64-bit)
- Windows Server 2008 R2 Enterprise with Service Pack 1 (64-bit)
- Windows Server 2012 Standard (64-bit)
- Windows Server 2012 Datacenter (64-bit)
- Windows Server 2012 R2 Standard (64-bit)
- Windows Server 2012 R2 Datacenter (64-bit)
- Windows Server 2016 Standard (64-bit)
- Windows Server 2016 Datacenter (64-bit)
- RSLinx Classic Lite or RSLinx.
- FactoryTalk Services Platform for RSLinx 500 only. Install FactoryTalk Services Platform if you intend to use FactoryTalk Security to control access to features of RSLinx 500 and establish user accounts to restrict access to the software.
- FactoryTalk Activation Manager
- Security Server Client for RSLinx 500 only. Install if you intend to use the Rockwell Automation Security Server to control access to features of RSLinx 500. You also need to configure your Security Server to allow users

Important: For the latest information regarding software platform support, refer to http://www.rockwellautomation.com/compatibility/#/scenarios.

Activation

Software activation verifies that a legal copy of RSLinx 500 or RSLinx Micro is installed. Activation works through an activation file that unlocks the software. RSLinx 500 and RSLinx Micro use FactoryTalk Activation Manager.

System installation

RSLinx 500 and RSLinx Micro require the following software:

- RSLinx Classic Lite or RSLinx.
- FactoryTalk Services Platform for RSLinx 500 only. Install FactoryTalk Services Platform if you intend to use FactoryTalk Security to control access to features of RSLinx 500 and establish user accounts to restrict access to the software.
- FactoryTalk Activation Manager
- Security Server Client for RSLinx 500 only. Install if you intend to use the Rockwell Automation Security Server to control access to features of RSLinx 500. You also need to configure your Security Server to allow users
to access the software. We recommend that you use FactoryTalk Security instead of the Security Server.

- **FactoryTalk Security** for RSLogix 500 only. This is installed with the FactoryTalk Services Platform but you must configure it to restrict access to features of RSLogix 500.

- **RSLogix 500** or **RSLogix Micro**.

**Install and activate RSLogix 500 or RSLogix Micro**

The following steps use RSLogix 500 installation as an example. The installation steps of RSLogix 500 and RSLogix Micro slightly vary. Unless noted otherwise, each step applies to RSLogix 500 and RSLogix Micro installation.

To install RSLogix 500 or RSLogix Micro:

1. Log on to the computer as an administrator or as a user with administrative privileges.

2. Insert the installation DVD into the computer’s DVD drive, or double-click `Setup.exe` within the installation packages.

3. (Optional) On the **Welcome** page, select a language to be shown during the installation process. By default, your system language is selected.
4. To install all components available in the selected software using the recommended settings, click **Install now** and go to step 11.

5. To select which components to install, click **Customize**.

6. On the **Customize** page, select the components. There may be two options shown:

   - **Mandatory** (grayed-out and selected check box) indicates software that will be automatically installed as part of the selected application.
   - **Optional** (clear check box) indicates software that you may wish to include depending on your system. Select the box to include the software during installation.

7. Select the location for Rockwell Automation software. The default location is C: \.

8. Click **Next**. The **RSLogix 500 Security Configuration Selection** page opens only if you are installing RSLogix 500.
9. (For RSLogix 500 only) In the **Security options** box, select the options as needed. If you do not want to use FactoryTalk Security, clear the **Enable FactoryTalk® Security** check box.

![RSLogix 500 Security Configuration Selection]

For information on how to configure security in RSLogix 500, read the "How To Set Up Security in RSLogix.htm" Tech Note that is available in CD image of this install program.

**Important:** (RSLogix 500 only) If you select the **Enable FactoryTalk® Security** check box in the installation process, you need to modify the FactoryTalk Security settings to restrict access to the RSLogix 500 functions. Initially the AllUsers account allows access to all features in the FactoryTalk Directory. The AllUsers account can be restricted for the FactoryTalk system if you modify the System Policies or for individual products if you modify the Product Policy settings. For information about configuring FactoryTalk Security, see FactoryTalk Help. Click **Start > All Programs > Rockwell Software > FactoryTalk Tools** and then click **FactoryTalk Help**.

If you need to disable FactoryTalk Security, you must uninstall RSLogix 500 and re-install it. If you have used the Rockwell Software Security Server and you have enabled FactoryTalk Security, you can import your Security Server database into FactoryTalk Security. See Import a security configuration.

10. Click **Install**.

11. In the **End User License Agreements** dialog box, click **Accept all** to start the installation, or click **Decline** to return to the last step.
12. After the installation completes, the **Activation** page opens. You can activate the software now or later.

![Activation Page](image)

To proceed directly to activate the installed software, select **Activate your software** and then click **Next**, the **Software Activation** dialog box opens.

   a. In the **Serial number** box, enter the serial number.

   b. In the **Product key** box, enter the product key.

   c. In the **Earliest version** box, select the earliest version of RSLogix 500 you will use.

   d. Select **Activate locally** or **Activate using a dongle**.

   e. Click **Continue**.

You will be prompted to restart the computer after the activation.
14. To finish the installation without activation, select **Skip activation** and then click **Next**.

- To view the installation details, click **Installation Summary**.
- To receive the latest product updates and patch notification, click **Register for updates**.
- To install the latest version of Adobe® Acrobat® Reader®, click **Download it free** and follow the on-screen instructions.

**Upgrade FactoryTalk Services Platform**

If you are upgrading FactoryTalk Services Platform, you must follow specific procedures. For information about upgrading the FactoryTalk Services Platform, see **FactoryTalk Help**. Click **Start > All Programs > Rockwell Software > FactoryTalk Tools** and then click **FactoryTalk Help**.

**Import a security configuration**

If you have used the Rockwell Automation Security Server to control access to user actions in RSLogix 500 and you have enabled FactoryTalk Security, you can import your security configuration from the Security Server into FactoryTalk Security. The import process imports users, user groups, and ACLs from the Security Server.

To import the security configuration from the Rockwell Automation Security Server into FactoryTalk Security:

1. Because the import process writes to the FactoryTalk Directory, it is important that you backup your FactoryTalk Directory before beginning the import.
   a. Run the FactoryTalk Administration Console by clicking Start > Programs > Rockwell Software > FactoryTalk Administration Console.
   b. Log onto the FactoryTalk Directory where you are using FactoryTalk Security.
   c. Right-click the top-level object in the Explorer tree (this is the Network or Local object, depending on whether you are viewing the Network or Local directory), and then click Backup.
   d. In the Backup dialog box, type a name for the backup file in the Specify archive name box. In the Specify archive location box, enter the path to where you want to save the backup file. Click the browse (...) button to browse for a folder.
   e. Click OK.

2. In the Security Server Configuration Explorer, export your security database to a file by clicking File > Export Database.

3. After exporting the database, close the Configuration Explorer.

4. Click Start > Programs > Rockwell Software > FactoryTalk Tools > Import RS Security Configuration. This starts the FactoryTalk Security Import utility.

5. In the import utility, enter the path to the file you exported from the Security Server in the Select RS Security Server backup database to import box. If you prefer, click Browse and locate the file.

6. From the Destination Directory list, select the FactoryTalk Directory that you are using with FactoryTalk Security. Select Network or Local.

7. If you have actions in your Security Server database that do not have security rights granted or denied, you can grant access to those actions to
users by default by selecting the **Add implicitly grant access** box. If you do not select this box, those actions will be denied to users by default.

8. If you want to display a log file of what happens during the import, select the **Display log on completion** box.

9. Click **OK**.

10. The import utility warns that you should back up your FactoryTalk Directory. If you have backed up your FactoryTalk Directory, click **Yes**.

11. Log onto the FactoryTalk Directory where you will be using FactoryTalk Security.

12. The import process runs. Depending on the contents of the file you are importing and of your FactoryTalk Directory, you may receive a warning message during the import. If this happens, review the information and click **OK** to continue the import process.

13. When the process is complete, the import utility displays a dialog box that indicates whether it was successful or unsuccessful. Click **OK**.

14. If you chose to display a log file at the end of the import, the log file opens.

### Configure FactoryTalk Security

FactoryTalk Security lets you to control access to features and functions of RSLogix 500.

**Tip:** The FactoryTalk Security component in FactoryTalk Services Platform installs an **All Users** account that allows any FactoryTalk user access to all features. To restrict access to RSLogix 500 policies and actions the All Users account must be denied access. See FactoryTalk Help for more information.

To open FactoryTalk online Help, click **Start**, point to **All Programs > Rockwell Software > FactoryTalk Tools** and then click **FactoryTalk Help**.

There are two methods for controlling access to the features and functions of RSLogix 500:

- **Policies** are features and functions that are controlled globally. When you set access rights to an RSLogix 500 policy, those rights affect users without respect to the controllers they are using.

- **Actions** are features and functions that can be secured globally, but can also be set on a controller-by-controller basis.

### Set security policies for RSLogix 500

Security policies control features globally. If a user can access a feature controlled by a policy, the user can access that feature regardless of the controller.

RSLogix 500 security policies control the following features:
### Policy

<table>
<thead>
<tr>
<th>Policy</th>
<th>If granted</th>
<th>If denied</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allow the installation of RSLogix 500</td>
<td>Can install RSLogix 500.</td>
<td>Cannot install RSLogix 500.</td>
</tr>
<tr>
<td>Allow the un-installation of RSLogix 500</td>
<td>Can uninstall RSLogix 500.</td>
<td>Cannot uninstall RSLogix 500.</td>
</tr>
<tr>
<td>Change Report Settings</td>
<td>Can change reporting settings.</td>
<td>Cannot change reporting settings.</td>
</tr>
<tr>
<td>Change Software Properties</td>
<td>Can access and change the software configuration options (the Tools &gt; Options menu item). Also allows access to the properties for ladder files, data table files, force files, and database files.</td>
<td>Cannot access or change software configuration options.</td>
</tr>
<tr>
<td>Compare Utility</td>
<td>Can use the Compare utility.</td>
<td>Cannot use the Compare utility.</td>
</tr>
<tr>
<td>Enable VBA Editor (RSLogix 500 Professional only)</td>
<td>Can use the Visual Basic® for Applications (VBA) editor.</td>
<td>Cannot use the VBA editor.</td>
</tr>
<tr>
<td>Enable/Disable VBA (RSLogix 500 Professional only)</td>
<td>Can run VBA scripts.</td>
<td>Cannot run VBA scripts.</td>
</tr>
<tr>
<td>Generate Report</td>
<td>Can generate reports.</td>
<td>Cannot generate reports.</td>
</tr>
<tr>
<td>Prompt for audit comment on File New</td>
<td>If configured to audit user actions, prompt the user for a comment when creating a new file.</td>
<td>The user is not prompted for a comment when creating a new file.</td>
</tr>
<tr>
<td>Prompt for audit comment on File Open</td>
<td>If configured to audit user actions, prompt the user for a comment when opening a file.</td>
<td>The user is not prompted for a comment when opening a file.</td>
</tr>
<tr>
<td>Prompt for audit comment on File Save</td>
<td>If configured to audit user actions, prompt the user for a comment when saving a file.</td>
<td>The user is not prompted for a comment when saving a file.</td>
</tr>
</tbody>
</table>

To set security policies for RSLogix 500:

1. Start the FactoryTalk Administration Console by clicking Start > Programs > Rockwell Software > FactoryTalk Administration Console.

2. If you are not automatically logged onto the FactoryTalk Directory Server, log onto the server with an account that has the rights to change security settings.

3. Click the System > Policies > Product Policies > RSLogix 500 folder, and then open the Feature Security object.
Tip: To use RSLogix 500, users or user groups must have the Read right to the Feature Security object for RSLogix 500. To configure security for RSLogix 500, users must be FactoryTalk administrators.

If users do not have the Read right to the Feature Security object, the FactoryTalk Directory will not allow them to read what rights they have in RSLogix 500, and secured features do not function for those users.

4. In the Feature Security Properties dialog box, click the function, and then click (...).

5. Configure the access for the function.

If you need more information about configuring FactoryTalk Security, click Help on the Feature Security Properties dialog box.

Secure Actions for RSLogix 500

Secured actions are functions that are secured either globally (affecting all controllers) or that are secured on a controller-by-controller basis. Whether the security settings apply globally or not depends on whether controllers inherit their security settings from the Networks and Devices object in the FactoryTalk Directory.

**Set global security**

This section describes how to set global security for actions.

1. Start the FactoryTalk Administration Console by clicking Start > Programs > Rockwell Software > FactoryTalk Administration Console.

2. If you are not automatically logged onto the FactoryTalk Directory Server, when prompted, log onto the server with an account that has the rights to change security settings.

3. Right-click the Networks and Devices folder, and then click Security.

4. Select the user or user groups.

5. (optional) To add a user or user group, click Add.

6. Open the RSLogix 500 list by clicking the plus sign (+).

7. Select the Allow or Deny check box for each task.

**Set controller security to not inherit permissions**

Controllers inherit their security settings from the Networks and Devices object. However, you can configure security for a controller.

To set security for a controller so that it does not inherit its settings from the Network and Devices object:

1. Start the FactoryTalk Administration Console by clicking Start > All Programs > Rockwell Software > FactoryTalk Administration Console.
2. If you are not automatically logged onto the FactoryTalk Directory Server, when prompted, log onto the server with an account that has the rights to change security settings.

3. Browse to the controller and in the **Explorer** tree of the **Administration Console** under the **Networks and Devices** object, right-click the controller, and then click **Security** to open the **Security Settings for Networks and Devices** dialog box.

4. Select the **Do not inherit permissions** check box.

5. Choose whether you want to copy the permissions from the parent object (the Networks and Devices object) or remove all inherited permissions from the object (the controller). If you have already configured security for the Networks and Devices object and want to use most of that configuration for the controller, copy the permissions. Otherwise, remove the inherited permissions.

6. Select the user or user group.

7. (optional) To add a user or user group, click **Add**.

8. Open the **RSLogix 500** list by clicking the plus sign (+).

9. Select **Allow** or **Deny**.

### Launch the application
You can now launch RSLogix 500 or RSLogix Micro.

- To start RSLogix 500, click **Start > All Programs > Rockwell Software > RSLogix 500 > RSLogix 500**.
- To start RSLogix Micro, click **Start > All Programs > Rockwell Software > RSLogix Micro > RSLogix Micro**.

### Troubleshoot the installation
If RSLogix 500 or RSLogix Micro does not start up or does not run properly:

- Verify that RSLinx Classic or RSLinx Classic Lite installed. It’s recommended to install the latest version of RSLinx Classic or RSLinx Classic Lite.
- Verify that your computer has enough memory. Check the hardware requirements for memory requirements.
- (RSLogix 500 only) Is FactoryTalk Security or Security Server support enabled? If so:
• If FactoryTalk Security support is enabled, are you disconnected from your network and unable to access your FactoryTalk Directory Server? Is FactoryTalk Security configured to allow you to have access to RSLogix 500 functions?

• If Security Server support is enabled, are you disconnected from your network and unable to access your Security Server(s)? Is the Security Server configured to allow you to have access to RSLogix 500 functions?

Contact your server administrator for more information.
Get started

RSLogix 500 is a ladder logic programming package for the SLC 500 and MicroLogix processors. RSLogix 500 is compatible with SLC 500 and MicroLogix programs created with any Rockwell Automation programming packages. RSLogix Micro is also a ladder logic programming package for MicroLogix processors.

RSLogix 500 and RSLogix Micro software include:

- A free-form ladder editor.
- A project verifier to build a list of errors that you can navigate to make corrections.
- Drag-and-drop editing to move data table elements from one data file to another, rungs from one subroutine or project to another, or instructions from rung to rung within a project.
- An address wizard that reduces keying errors.
- Search and replace to change occurrences of a particular address or symbol.
- A point-and-click interface to access all of the project’s folders and files.
- A custom data monitor to view separate data elements together and observe interactions.
- Trending and histogram reports for monitoring and displaying process data.
- (RSLogix 500 only) SLC libraries for storing and retrieving portions of ladder logic for use across any Rockwell Automation SLC programming software.
- A compare utility that lets you view project differences.
- A function of exporting project files to an ACD or L5K format that can be used in Studio 5000 Logix Designer®.


Explore RSLogix 500 and RSLogix Micro

An example of an RSLogix 500 or RSLogix Micro project view:

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Menu bar</td>
<td>Menu selections.</td>
</tr>
<tr>
<td>2</td>
<td>Icon bar</td>
<td>The icon bar displays common functions. Hover your cursor over an icon to view a tool tip.</td>
</tr>
<tr>
<td>3</td>
<td>Online bar</td>
<td>Indicates the processor mode and whether online edits or forces are present, and the communications driver and node number.</td>
</tr>
<tr>
<td>4</td>
<td>Project tree</td>
<td>The project's folders and files. You can usually click an icon in this tree and then right-click to open a menu that applies to the item.</td>
</tr>
<tr>
<td>5</td>
<td>Status bar</td>
<td>Indicates status information and system prompts.</td>
</tr>
<tr>
<td>6</td>
<td>Instruction toolbar</td>
<td>Displays instruction mnemonics in tabbed categories. Click an instruction to insert it in your ladder program.</td>
</tr>
<tr>
<td>7</td>
<td>Ladder view</td>
<td>This is where you edit your ladder logic. You can view several program files at the same time.</td>
</tr>
<tr>
<td></td>
<td>Results pane</td>
<td>Displays the results of a search or a verification procedure at the bottom of the window. You can hide this pane or reposition it on your screen.</td>
</tr>
</tbody>
</table>

Tip: To launch a floating instruction palette, press Alt+4.

Quick Start Steps

The following steps describe how to get up and running with RSLogix 500 or RSLogix Micro.

Configure a driver in RSLinx Classic

RSLinx Classic Lite comes with RSLogix 500 and RSLogix Micro. This Lite version provides the communication drivers necessary to use RSLogix 500 and RSLogix Micro. RSLinx Classic Lite will not, however, provide communications
through DDE or OPC. To use DDE or OPC communication, you need to install RSLinx Classic.

The RSLinx Classic driver provides the connection between your computer and the processor. You have to tell RSLinx Classic what driver you want to use to make that connection.

The driver you use depends on the physical connection between the processor and the computer. You need to know the type of connection your system is using and how the physical connection is configured.

You also need to know the parameters of the physical connections. For example, if you are connecting through a 1784-KTX card, you need to know how your KTX card is configured, the station numbers of the processors on your DH-485 network, and how fast your processors are communicating on the network.

To configure a driver in RSLinx Classic:

1. Click Start > Programs > Rockwell Software > RSLinx > RSLinx Classic. RSLinx Classic starts in a minimized mode, with an RSLinx icon in the Windows notification area.

2. In RSLinx Classic, click Communications > Configure Driver, to open the Configure Drivers dialog box.

3. In the Configure Drivers dialog box, select the driver.

4. Click Add New.

5. RSLinx Classic prompts you to name the driver. You can use the default name, or enter a name. Click OK to open the driver’s configuration dialog box.

6. Configure the driver to match your connection to the processor.

7. The driver appears in the Configured Drivers list of the Configure Drivers dialog box. Click Close.

8. To verify that the driver is working properly, click Communications > RSWho. This function shows what processors and other communications devices are available through the driver.

9. In the RSWho tree, open the driver you configured and verify that the processor is one of the displayed devices.

10. If you cannot see the processor, the driver is not configured correctly or there is a communication problem. Correct the problem before proceeding. See the RSLinx Classic online Help for information.
Configure system communications

There are two kinds of communications configurations in RSLogix 500 and RSLogix Micro.

- **System communications** is set globally. When you set system communications parameters, those parameters are the default for all new projects.

- **Controller communications** is specific to a given project. When you set controller communications for a project, those settings overwrite the system communications settings.

It is recommended that you set the system communications parameters before creating your first project.

To set the system communications parameters:

1. From the Comms menu, click System Comms, to open the Communications dialog box. If RSLinx Classic is not running, it starts.

2. Open the driver you configured. The processor you want to program should be visible. Click the processor, then click OK.

   **Tip:** To change the system communications settings, click Comms > System Comms.

   If you want to set different communications parameters for a given project but leave the system communications settings alone, open the properties for the project’s controller. See the online help for more information.

Create a new project or open an existing project

To create a new project, click File > New. Enter the type of processor you communicate with and the system creates a project tree. The project tree provides access to the program, data table, and database files.

To open an existing project, click File > Open, and select the project to open.

The project tree displays the program and data table files in your project.

**Tips:** You can hide any program file (except system files) in the project tree. This can be useful once you have completed editing a program file and do not want to accidentally select it and making changes. Click on the file in the project tree, right-click and click Hide.

Compare project files by clicking Tools > Compare. Then select the projects you want compared. You can print the results in a graphical display or save it to a report and print it later.

Open Multiple Files

To open multiple files within the same project split the viewing window. Click and drag the double bars at the top of the window.
You cannot view program files from different projects from one application. To work on two projects at a time, open two instances of RSLogix 500. Once you have the projects opened, you can drag-and-drop instructions and data between them.

**Create program and data table files**

To create a new file, right-click the Program Files or Data Files icon and then click New from the menu. You are prompted to enter information about the file.

Program files contain controller information, the main ladder program, and any subroutine programs. The maximum number of program files in a project depends on the type of controller.

Data table files contain the status information associated with external I/O and all other instructions you use in your main and subroutine ladder program files. In addition, these files store information concerning controller operation. You can also use the files to store recipes and look-up tables.

**Define chassis and modules**

You need to define your chassis, identify the I/O cards and their chassis positions, and select a power supply for each chassis.

Access the chassis's I/O Configuration dialog box by double-clicking the I/O Configuration icon in the project tree. Then click and drag a module into the appropriate slot position.

From the I/O Configuration dialog box, click Power Supply to view the power load on the rack based on your chassis configuration.

For more information about the I/O Configuration dialog box refer to Chassis and module setup.

**Enter rungs in the program**

When you open a new program file, the ladder file opens in the right pane of the application window.

Click the end rung and from the toolbar click the New Rung icon to add a rung. To place an instruction on the rung, click the button for the instruction.

You can place several instructions on a rung.

The application features a file-based editor, you can:

- Create and edit multiple rungs at a time.
- Enter addresses before you create data table files for your I/O.
- Enter symbols before you have assigned addresses for them in the database.
- Enter instructions without having to provide addresses until file validation.

To add addresses, click an instruction then type the address in the empty text box. You can also drag and drop addresses from a data table file onto instructions.
Tip: An address-entry wizard opens with list of valid options. If you want to close the wizard press Esc. To open the wizard press Insert.

Use the right mouse menu to access functions. The right mouse provides you with context menus that list editing options. Click F1 or the Help button while an instruction is selected to access online Help.

You can also press the Shift + F10 to access a context menu.

Tip: Select multiple rungs by holding down the Ctrl key and left-clicking each rung. You can also select a range of rungs by holding down the Shift key and clicking the beginning rung and ending rung.

For more information about entering ladder logic including information about branching, addressing, and performing program edits online, refer to the Entering ladder logic.

Add documentation to your logic instructions

There are several ways to add symbols and descriptions to addresses in the database.

- Modify symbols and descriptions from within a program file. Right-click the address in the instruction, then click Edit Symbol or Edit Description.
- Modify assigned documentation of an address in the data file. Double-click the data file in the project tree, and then click on an address within the grid on the Data File dialog box. Enter documentation in the text boxes at the bottom of the dialog box.
- Modify the database using the database editor. In the Database folder of the project tree, double-click an icon.
- Enter a symbol while creating new instructions, then assign an address to the symbol using the database symbol/description editor.
- View and edit the project database using Microsoft Excel® (RSLogix 500 Professional version only).

For information about database import and export options refer to Importing or exporting the documentation database.

Verify your project

Before you can compile and download your project, you must validate, or verify, the project. You can verify a single program file or you can verify the project. To verify a file, click the Verify File icon or click Edit > Verify File. To verify the project, click the Verify Project icon or click Edit > Verify Project.

The Verify Results output window provides information about errors that would prevent compilation.

Click on a result item to go to that location in the program.
Configure communication channel, download and go online

Before going online you must define processor communication settings, such as baud rate, and also decide certain system and protocol controls. Depending on the type of processor that you are using and the method of communication (direct, networked, or modem), the complexity of this procedure varies.

**Tip:** If you are developing the program offline you may want to override system communication settings. You can override the system communication settings from the Controller Properties dialog box, Controller Communications tab. Settings made here override any driver and node settings.

1. Double-click the channel configuration icon in the project tree to make these settings. If you need information about any parameter, click Help on the Channel Configuration dialog box.

2. Click Download > Comms to download the current offline program into the controller. Click Yes to go online.

Monitor data files

While monitoring data files you can:

- Define the selection grid display.
- Change values in the data table.
- Change the display radix.
- Show which addresses are used in your ladder logic.
- Switch between files.
- Jump to another address in another data table file.
- Cross reference data.

To monitor a data table file, click the Data File icon of the file to monitor. You can have multiple data table files opened at the same time.

You can also choose to cascade or tile all the windows opened in your project by clicking the Window menu item and clicking Arrange.

Data changes made offline only affect the disk file unless the program is restored to the processor.

Data changes made online only affect the processor file unless the program is saved or uploaded while online to update the disk file.

For more information on how to create and monitor lists of related addresses, refer to Monitoring data.

Search and replace instructions

Use Find to locate instructions, addresses, and symbols in program files. Use Replace to search and replace items. You can use wildcards in a search.
From the **Search** menu, click **Find** or **Replace**. Enter the mnemonic (XIC, TON, etc.), the address (B3/4, etc.) or both mnemonic and address (XIC B3/4), or mnemonic and symbol (XIC SYMBOL).

**Tip:** Jump to a program file, rung, address, symbol or data table file. Press Ctrl+G. The **Goto** dialog box open.

---

**Print a report**

You can print various elements of your project such as program files, data table files, and processor information. To select report options, click **File > Report Options**.
Chapter 3

Chassis and module setup

For each project, you need to define your chassis, identify the I/O cards and their positions in the chassis, and select a power supply.

From the project tree, double-click the I/O configuration icon to open the I/O Configuration dialog box.

From the I/O Configuration dialog box:

- Check if the planned power supply is sufficient for the modules in the rack.
- Configure analog and other specialty modules.
- Read the existing I/O configuration of a processor node on the network.

Power supply loading

To open the Power Supply Loading dialog box, from the I/O Configuration dialog box, click Power Supply. Use the dialog box to examine the power load on a rack, based on the module configuration.

Analog and specialty modules

Specialty I/O Modules have additional parameters to configure. Enter this information in the Advanced I/O Configuration dialog box. From the I/O Configuration dialog box, click Adv Config.

Click Help or press F1 to open online Help for parameter information.

Automatic I/O configuration

If programming an SLC 5/03, SLC 5/04, SLC 5/05, or MicroLogix processor offline with communications configured for the processor, you can have the processor read the I/O configuration for the processor and reflect that information on the I/O Configuration dialog box. To enable this, click the Read I/O Config button on the I/O Configuration dialog box.
Enter ladder logic

This chapter provides information on editing ladder logic. Shortcuts are available for most editing functions. See the list of shortcuts in the online help by searching for *shortcuts*.

Back up your work

Remember to back up your work as you develop your ladder logic programs. There are two types of backup files that you can access at any time, and provide an auto-recovery file in the event of a power failure. All of these files contain the description database associated with the project.

- Auto-Backup files are created each time you save a project. Set the number of backup files to retain for a project by entering a **Number of Backups** on the **System Preferences** tab of the **System Options** dialog box. Open this tab from the **Tools** menu. Then click **Options** and select the **System Preferences** tab. Auto-backup files have the letters BAK and a series of numbers (000 to 999) appended to the filename. For example, an auto-backup created for project TEST.RSS might be identified as TEST_BAK000.RSS, and a more recent backup might be identified as TEST_BAK001.RSS.

- Compressed Format Backup files are typically generated for archiving or giving to another user. Compressed format backup files include the .RSS and all database files for the project compressed into a single .RS1 file. From the **File** menu click **Backup Project** to generate a compressed-format backup file.

Crash Recovery

If you experience a power interruption, the system provides you with a recent backup file containing current edits.

RSLogix 500 and RSLogix Micro automatically create file backups while you are working with a project and when you save the project. This auto-generated recovery file is only available to you the next time you open a project if you have a system crash or your power is interrupted. After attempting to open a project after a power failure the software prompts you with choices.

You can open:
• The auto-saved file, ensuring retention of any edits made before the power interruption.

• The last backup that you made, when you clicked **Save** before the power interruption.

  **Tip:** You must save or close the file you are working on at least one time for the auto-recovery process to work. Therefore, it is good practice to save the file immediately after beginning a new project. This ensures that your auto-recovery process can begin properly.

You can set the interval between auto-recovery saves in the **Preferences** dialog box. The auto-recovery process ensures that you will retain any work that had been done on the file between the time of the power interruption and the last manual save.

**Quick instructions entry**

You can map any available alphabet key (A-Z) on your computer keyboard to a ladder logic programming instruction.

Open a program file and from the **View** menu click **Properties**. Then click **Quick Key Mapping**.

  **Tip:** You can jump to any rung in your project by clicking the Search menu, and then clicking **Goto**. You can go to a rung in the current program file or you can go to a rung in another program file within the same project. Keyboard users can press **Ctrl+G** to access the **Goto Rung** dialog box.

**Addressing**

There are several methods to address instructions. You can enter an address by:

• Typing the address.

• Dragging addresses from data files or the Custom Data Monitor.

• Copying and pasting from program to program.

  **Tip:** You can drag-and-drop rungs, branches, instructions, and addresses from file to file or from the database to a file. Red boxes indicate valid drop locations, and turn green when selected.

**Branching**

**Add a branch**

Click to place a branch in your ladder logic. If your cursor is on an instruction, the branch is placed immediately to the right of the instruction. If your cursor is on the rung number, the branch is placed first on the rung.

**Move a branch**
Click the upper left corner of a branch to move the entire branch structure to another location in your ladder logic program.

**Expand a branch**

Click the right leg of the branch, and then drag the leg to the right or left. Valid release points are visible on the ladder display.

**Nested branches**

Place the cursor at the upper left corner of a branch leg, click the right mouse button, and click **Append New Branch** to place another branch structure within the original branch structure.

**Parallel branches**

Place the cursor at the bottom left corner of a branch leg and click the right mouse button and click **Extend Branch Leg Up** or **Extend Branch Leg Down**.

**Copy branch leg**

Click the left edge of the branch leg to copy. In the picture at the left this is the center leg. Then right-click and click **Copy**. Click a rung or instruction in your logic, and then right-click and click **Paste** to insert the rung leg.

**Copy entire branch structure**

Select the right leg of the branch structure, then right-click and click **Copy**. Click a rung or instruction in your logic, and then right-click and click **Paste** to insert the rung structure.
Delete a branch

Place the cursor anywhere on the branch, right-click and then click **Delete**. All instructions on the branch are deleted.

Branching restrictions

You are limited to 75 parallel branches and four nested branches. (SLC 5/02 and higher and MicroLogix).

Undo operation

An undo reverses your last action, and up to 200 previous actions.

If you want to undo a move operation, click **Undo** twice. A move consists of two actions, copy and cut.

Online editing

The online editing function lets you monitor and correct your ladder program when you are connected to an SLC 5/03, SLC 5/04, SLC 5/05, MicroLogix 1100, or MicroLogix 1400 processor.

Online editing includes inserting, replacing, and deleting rungs in a program while online with the processor.

Markers in the left margin signify edit zones. They indicate the type of ladder program edit that exists in the program.

Lowercase zone markers indicate edits that exist only in the computer memory. Uppercase zone markers indicate edits that exist in the processor memory. After successfully assembling the edited rungs, the zone markers disappear.

**Tip:** Search for zone markers in your project the same way you search for an instruction or an address. Click **Special** on the **Find** dialog box.

**Lowercase zone markers**

- **e** Online and offline, all controllers. Rungs are currently under edit within the computer RAM. If you are working offline, after program verification the lowercase e disappears and the edits are incorporated into the program. If you are working online, after accepting the rung, the lower-case e will be replaced by an uppercase I indicating that the rung is now in the controller’s memory and will be inserted into the program file.

- **i** Online Editing, SLC 5/03, 5/04 and 5/05 controllers only. Rungs will be inserted into the program. Rungs currently exist in the computer memory and will not be entered into the controller until the rung is accepted. After the rung is accepted, the i is replaced by an uppercase I.

- **r** Online Editing, SLC 5/03, 5/04 and 5/05 controllers only. Rungs will be replaced in the ladder program. Rungs currently exist in the computer memory and will not be entered into the controller until the rung is accepted. An r rung is always preceded by an e rung. After the rung is accepted, the r is replaced by an uppercase R.

- **d** Online Editing, SLC 5/03, 5/04 and 5/05 controllers only. These rungs have been deleted in memory and will be deleted from the program. Deletions in the controller will happen when the rung is accepted, and the d is replaced by an uppercase D.
Uppercase zone markers

I Online Editing, SLC 5/03, 5/04 and 5/05 controllers only. Rungs have been inserted in the controller’s logic program. You can test the edits by selecting the Edit menu and clicking Test Edits to see how the rung works in the online ladder program. Click Assemble Edits to finalize the rung insertion and complete the editing process.

R Online Editing, SLC 5/03, 5/04 and 5/05 controllers only. Rungs have been replaced in the controller’s logic program. Rungs continue to function in the program until you select Test Edits to see how the new rung works in the online program. Click Assemble Edits to finalize the replacement and complete the editing process.

D Online Editing, SLC 5/03, 5/04 and 5/05 controllers only. Rungs have been deleted in the controller’s logic program. Rungs continue to function in the program until you select Test Edits to see how the program functions without the rungs in the online program. Click Assemble Edits to delete the rungs and complete the editing process.

Online editing example

This example replaces an XIC instruction with an XIO instruction with the same address while online.

1. Select the rung in the program that requires editing and then from the Edit menu, click Start Rung Edits from the main menu or click Start Rung Edits from the right mouse menu. A duplicate of the selected rung (preceded by the e edit zone marker) shows in your program. This is the rung that all edits are performed on. The r edit zone marker precedes the original rung (rung to be replaced).

2. Make the edits to the rung. The lower-case edit markers do not change since they represent changes that only exist in the computer memory; these changes are not yet a part of the online program in the controller. (At this step you can click Cancel Rung Edits to cancel the edits you have made to the rung.)
Chapter 4  Enter ladder logic

3. Select **Accept Rung**. This changes the edit zone markers and places both rungs in the controller memory. The upper-case I represents the rung that has been inserted into the online program. The upper-case R represents the online rung that is to be replaced. At this time the R rung is still operating in the program.

4. Select **Test Edits**. The I-marked rung takes precedence. The program in the controller operates with the inserted rung, and the R-marked rung is ignored. Alternately you can click **Cancel Edits** to cancel the accepted I-marked rung and retain the originally programmed R-marked rung.

5. Select **Assemble Edits**. All edit zone markers disappear and the edits are incorporated into the online program. There is no Undo option after online edits are assembled.

Going from online to offline with rungs under edit removes the RAM online edits. Make sure you have accepted edits before going offline if you want any changes retained in the processor.

**Online editing restrictions**

Your programming terminal must be connected to an SLC 5/03, SLC 5/04, SLC 5/05, MicroLogix 1100, or MicroLogix 1400 processor. During an online editing session you cannot:

- Resize data table files.
- Create or delete program files.
- Change program file protection.
- Change index across file boundaries flag.
- Reconfigure the I/O.
- Select force protection.

**ASCII Editor**

ASCII Editor lets you modify instructions using ASCII instruction mnemonics instead of having to modify instructions using the ladder editor.

To open the ASCII Editor, double-click a rung number in the left margin. If you double-click a rung with logic already on it, you see the mnemonics for the existing instructions and can modify or add to them. If you double-click an empty rung,
you get an empty editing box into which you can type the mnemonics that represent the logic you want placed on the rung.

**Tip:** To open the ASCII text editor you can click the rung number and then press the forward slash key (/).

### Configure interrupts

Use interrupts to stop the scan of the main program so as to accomplish a certain task. Programming requires you to enter essential criteria for the interrupt to function properly. Depending on the processor you are using, this criteria is entered into the Status file by accessing it directly (all SLC processors and MicroLogix 1000 processors) or by entering the appropriate data in the Function File utility (MicroLogix 1100, 1200, 1400 and 1500 processors only).

### Selectable Timed Interrupt

Use the Selectable Timed Interrupt (STI) function to interrupt the scan of the main program file automatically, on a periodic basis, in order to scan a specified subroutine file. You specify the time interval when your selectable timed interrupt routine executes.

**Processor Type** | **Action**
--- | ---
All SLC and MicroLogix 1000 | Select a program file for the STI by double-clicking the S2 data file icon in the project tree. Then click the STI tab and enter the information needed to define the STI. Press the Help button if you need more information.

MicroLogix 1100, 1200, 1400 and 1500 | Select a program file for the STI by double-clicking the Function Files icon in the project tree. Then click the STI tab and enter the information needed to define the STI. Press the Help button if you need more information.

### Discrete Input Interrupt/Event Input Interrupt

Use these functions for high-speed processing applications or any application that needs to respond to an event quickly. Use the Discrete Input Interrupt (DII) for SLC 500 processors and the Event Input Interrupt (EII) for MicroLogix controllers. The DII function allows the SLC 500 processor to execute a ladder subroutine when the input bit pattern of a discrete I/O card matches a compare value that you programmed. Similarly, the EII function allows the MicroLogix controller to execute a ladder subroutine when an assigned embedded input changes.

**Processor Type** | **Action**
--- | ---
All SLC | Double-click the S2 data file icon in the project tree. Then click the DII tab and enter the information needed to define the DII. Click Help if you need more information.
Chapter 4

Enter ladder logic

Double-click the Function Files icon in the project tree to select a program file for the EII. Then click the EII tab and enter the information needed to define the EII. Click Help if you need more information.

Floating instruction palette

You can open a floating instruction palette. From the View menu click Instruction Palette or click the palette icon.
Chapter 5

Import and export a database

To open the database import and export utilities from the Tools menu click Database. Click Import when you want to apply existing documentation to a project. Click Export to make your database documentation available to other projects.

Tip: RSView products can read the documentation database directly from your RSLogix 500 and RSLogix Micro projects.

Import database

You can apply documentation to newly created logic files by importing existing database documentation. The existing documentation might come from:

- Projects developed using Rockwell Automation AI or APS DOS-based programming software.
- An RSLogix 500 or RSLogix Micro project.
- A spreadsheet application saved as a .CSV file.
- An ASCII text file.

When you import a documentation database, there may be a collision, conflicting entries in the import file and the database. Before importing, you can select if you want the imported database instance or the current database instance discarded if collisions occur.

A.I. project documentation database

Choose the Native Import option in the Database menu to import database documentation consisting of:

- Address symbols and descriptions (.DSC files).
- Page title and rung descriptions (.RPD files).

APS project documentation database

Click the Native Import option in the Database menu to import database documentation consisting of:

- Address symbols and descriptions.
- Page title and rung descriptions.
Import and export a database

• Instruction comments.

By default the file type selected for import is an .OP$ file. The .OP$ file is the database control file. It references individual database files (for example the symbol/description file or the page title/rung description file) that reside in the same folder as the .OP$ file. After an import completes, the software creates a log file that informs you which database files successfully imported and which database files contained errors and could not successfully be imported.

**Documentation database**

Click the **Native Import** option in the **Database** menu to import database documentation consisting of:

• Address symbols and descriptions.
• Page title and rung descriptions.
• Instruction comments.
• Symbol groups.

By default the file type selected for import is a .CTD file. The .CTD file is the database control file. It references individual database files (for example the symbol/description file or the page title/rung description file) that reside in the same folder as the .CTD file. After an import completes, the software creates a log file that informs you which database files successfully imported and which database files contained errors and could not successfully be imported. For a complete list of file extensions for individual database documentation refer to the online Help and search *file extensions*.

**Comma Separated Values (CSV) file**

Click **ASCII Import** from the **Database** menu to import database documentation contained in a .CSV file and consisting of:

• Address symbols and descriptions.
• Instruction comments.
• Symbol groups.

For an example of a .CSV file, refer to the online Help and search *CSV format for import/export*.

**ASCII delimited text file**

You can import documentation files that were created using RSLogix 500, RSLogix Micro, or AI Series software and exported and saved as ASCII delimited files. ASCII delimited means that the fields for each database record are enclosed in quote marks and separated by commas.

Choose the ASCII Import option in the Database menu to import database documentation contained in an ASCII delimited text file. Choose from:

• Address symbols and descriptions (.EAS files).
• Page title and rung descriptions (.ERP files).
• Instruction comments (.EIC files).
• Symbol groups (.ESG files).

Users can specify any extension instead of the default extension for each file type (shown above in parenthesis) when using AI Series, RSLogix 500, or RSLogix Micro software.

Find examples of these files in the **ASCII Export** section of this guide.
Export database

Use Export to make the current database documentation of the project available to other projects.

You can select the display format for descriptions in the exported file. Choose descriptions as five, 15-character lines of text if you are exporting a database to be used by Rockwell Automation AI or APS programming packages.

You can export documentation to the following formats:

- ASCII delimited RS500.
- ASCII delimited AI.
- ASCII delimited APS.
- Comma Separated Value (.CSV file).

Edit the ASCII file with a text editor, or load the file into another database.

When you export database documentation to AI or APS ASCII delimited format, the symbols, descriptions, and instruction comments may be truncated due to size restrictions imposed by the AI/APS databases. This may result in conflicts in the exported data.

The examples in this section show how the documentation would be represented in an exported ASCII text file, using the RS500 output format.

Each field in a line of ASCII text is enclosed with quotation marks and separated by a comma.

Example text files

Address symbols and descriptions (.EAS files)

<table>
<thead>
<tr>
<th>ASCII Field</th>
<th>Maximum Length</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>39 characters</td>
<td>Address</td>
</tr>
<tr>
<td>2</td>
<td>--</td>
<td>Scope (0=global, 2-255=local program file #)</td>
</tr>
<tr>
<td>3</td>
<td>20 characters</td>
<td>Symbol</td>
</tr>
<tr>
<td>4</td>
<td>20 characters</td>
<td>Description line 1</td>
</tr>
<tr>
<td>5</td>
<td>20 characters</td>
<td>Description line 2</td>
</tr>
<tr>
<td>6</td>
<td>20 characters</td>
<td>Description line 3</td>
</tr>
</tbody>
</table>
### ASCII Field  
Maximum Length  
Contents
---
7  
20 characters  
Description line 4
8  
20 characters  
Description line 5
9  
12 characters  
Device code (always 0 for addresses that are not real I/O)
10  
9 characters  
Device description above
11  
9 characters  
Device description below
12  
--  
Disable xref flag, (0=enabled, 1=disabled)
13  
20 characters  
Symbol group name

## Page title and rung descriptions

(.ERP files)

<table>
<thead>
<tr>
<th>ASCII Field</th>
<th>Maximum Length</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>39 characters</td>
<td>Data table address or rung identifier</td>
</tr>
<tr>
<td>2</td>
<td>--</td>
<td>Page title</td>
</tr>
<tr>
<td>3</td>
<td>20 characters</td>
<td>Rung description</td>
</tr>
</tbody>
</table>

## Instruction comments (.EIC files)

"B3/0","XIC","ins comment","","",""

<table>
<thead>
<tr>
<th>ASCII Field</th>
<th>Maximum Length</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>39 characters</td>
<td>Address</td>
</tr>
<tr>
<td>2</td>
<td>3 characters</td>
<td>Instruction type</td>
</tr>
<tr>
<td>3</td>
<td>20 characters</td>
<td>Comment line 1</td>
</tr>
<tr>
<td>4</td>
<td>20 characters</td>
<td>Comment line 2</td>
</tr>
<tr>
<td>5</td>
<td>20 characters</td>
<td>Comment line 3</td>
</tr>
<tr>
<td>6</td>
<td>20 characters</td>
<td>Comment line 4</td>
</tr>
<tr>
<td>7</td>
<td>20 characters</td>
<td>Comment line 5</td>
</tr>
</tbody>
</table>

## Symbol groups (.ESG files)

"GROUP_NAME","description"

<table>
<thead>
<tr>
<th>ASCII Field</th>
<th>Maximum Length</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>20 characters</td>
<td>Symbol group name</td>
</tr>
<tr>
<td>2</td>
<td>80 characters</td>
<td>Symbol group description</td>
</tr>
</tbody>
</table>
A.I. ASCII delimited text file examples

These examples show how a line might appear in an ASCII text file exported using the AI output format. Each field in a line of ASCII text is enclosed by quotes and separated by a comma.

"B3/0","0","SYMBOL","description","","","","0","","0"

The field breakdown of AI ASCII delimited text is the same as shown for RS500 ASCII output format, except the symbol and description fields are limited to 15 characters and there is no symbol group field.

"RUNG000002-000002","page title","rung comment\"

<table>
<thead>
<tr>
<th>ASCII Field</th>
<th>Maximum Length</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>39 characters</td>
<td>Data table address or rung identifier</td>
</tr>
<tr>
<td>2</td>
<td>--</td>
<td>Page title</td>
</tr>
<tr>
<td>3</td>
<td>20 characters</td>
<td>Rung description</td>
</tr>
</tbody>
</table>

APS ASCII delimited text file

APS documentation database files saved to ASCII text format contain keywords. Keywords tell the software whether the information immediately following the keyword is a rung comment, an instruction comment, an address comment, or a symbol. Symbol and address comment examples are shown below.

SYM      B3/0      SYMBOL
AC       B3/0      description

Refer to your APS programming manual for a complete list of keywords and an explanation of how an APS ASCII text file is built.

CSV format

Search CSV format for import/export in the online Help for complete details.
Monitor Data

There are a variety of ways to monitor data in your data table files.

- Multipoint Monitor
- Custom Data Monitor
- Custom Graphical Monitor (RSLogix Professional version only)
- Recipe Monitor
- Histograms
- Trending
- Data Logging (MicroLogix 1100, 1400, and 1500LRP only)
- Cross Reference Report

Use the Multipoint Monitor and Custom Data Monitor to compose lists of addresses that you monitor frequently, or lists of addresses with interrelated functionality.

The Custom Graphical Monitor interprets the Custom Data Monitor graphically with buttons, sliders, gauges and charts.

The Recipe Monitor is a variation of the Custom Data Monitor for monitoring groups of related indirect addresses with a common index.

When online, use histograms and trends to see how your program is behaving over time, by examining bits as the program runs in the SLC controller. A trend logs the data for more than one address (typically related) over a period of time. A histogram logs the data contained in a single address over a period of time.

The data logging feature lets you use ladder logic to enable recording data for predefined sets of addresses. Your data can be date and time stamped.

The Cross Reference report lists every occurrence of all logical addresses in your project.

The Multipoint Monitor is only available with MicroLogix 1000, SLC 5/03 - OS302, SLC 5/04 - OS401 and OS410, and SLC 5/05 controllers. The Multipoint Monitor can only be used to monitor bit addresses. If you want to monitor word addresses, use the Custom Data Monitor.
Bit addresses in a multipoint list can come from any data table file. The addresses do not have to come from the same data table file.

Use a multipoint list to:

- Change the on/off state of bits.
- Set and clear forces on I/O points.
- Define separate descriptions for on and off state.
- Write protect a bit.

To access the Multipoint Monitor, from the project tree double-click the Multipoint Monitor icon.

<table>
<thead>
<tr>
<th>Point</th>
<th>Address</th>
<th>State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>B3/12</td>
<td>0</td>
<td>Motor 1 off</td>
</tr>
<tr>
<td>1</td>
<td>B3/3</td>
<td>0</td>
<td>Motor 1 off</td>
</tr>
<tr>
<td>2</td>
<td>B3/11</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>T4.0/0N</td>
<td>1</td>
<td>begin cooling</td>
</tr>
<tr>
<td>4</td>
<td>B3/9</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>B3/4</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The offline multipoint list is stored in the project file. It is not part of the processor image. The online multipoint list is stored in the processor memory and is cleared whenever the processor memory is cleared.

When using the MicroLogix controller, descriptions are stored in the .RSS file. With SLC 5/03, 5/04 and 5/05 controllers the descriptions are stored in the processor.

To monitor forces, from the project tree, double-click the input or output force file.

**Important:** All force functions can result in sudden machine movement, possibly injuring personnel or causing equipment damage. Use caution when working with forces.

You can also use the Forces dialog box to install and enable or disable forces while monitoring your file offline, or in any processor mode while monitoring your file online. Right-click on a bit in the Forces dialog box to force the bit on or off. For more information about forces, refer to the online Help.

**Custom Data Monitor (CDM)**

Use the Custom Data Monitor to review bit addresses and word addresses.

Addresses in a custom data monitor list can come from any data table file. The addresses do not have to come from the same data table file.

Features of the custom data monitor:
• CDM lists can contain bit addresses or word addresses.
• CDM lists can contain ASCII comments to help you clarify bit listings.
• Define up to 255 (CDM) lists per project.
• The CDM name is limited to 20 characters.
• The CDM description is limited to 59 characters.
• Click and drag addresses from the data tables to the CDM file.
• Use the Ctrl+Shift keys to drag more than one address at a time from the data tables.

To open the Custom Data Monitor, from the project tree double-click the CDM file icon.

Custom Graphical Monitor

The Custom Graphical Monitor provides graphical data monitoring. Use the Custom Graphical Monitor, to place buttons, sliders, gauges, charts, text, and imported images.

Recipe Monitor

Use the Recipe Monitor to review groups of related, indirect addresses with a common index.

Some SLC and MicroLogix projects use data tables in which each element is relevant for a different mode of operation. When these data tables are grouped such that element one of each file corresponds to mode one of the assembly line used to make product one, this is referred to as a recipe. The easiest way to keep track of recipes is to use a common reference address with indirect addresses to each of the related data files.

To open the Recipe Monitor, from the project tree double-click the Recipe folder.

Trends

A Trend logs the data for more than one address (typically related) over a period of time.

This option provides the features of the RSTrendX Viewer plus remote trending capability. The RSTrendX Viewer is an ActiveX® control for displaying process data in a trend or strip chart recorder format. It is based on the Viewer display in the RSTrend Data Acquisition and Trending software.

To create a Trend chart, from the project tree right-click the Trends folder and click New. Trends are saved with the project. Logged data is not retained. You can create a trend configuration while offline or online, however you must be online to update the trend data.

Histograms

Histograms show changes to an address’s data value over time.
Access Histograms while online with an SLC controller. To open the **Histogram** dialog box, from the **Comms** menu click **Histogram**.

Click **Start**, the Histogram sends a message to the SLC controller to log data. Each time the address value changes, the controller stores the address value in a histogram buffer. The Histogram logs both the new value and the time interval between value changes. This data is represented at the top of the histogram display window.

To save Histogram configurations, right-click and click **Save**.

**Data Logging**

Use data logging to define and edit data sets for later retrieval by a communication device. The data is retained in the controller through power cycles. The following processors support data logging: MicroLogix 1500LRP, 1100, and 1400.

Access data logging from the project tree’s **Data Logging** folder. Click the **Configuration** icon, then right-click on **Data Log Configuration** and click **New**.

**Cross Reference**

A Cross Reference report lists the project’s logical addresses and the location of every occurrence of each address. The report includes the following: address, symbol, instruction mnemonic, file number and name, and rung number. You can sort the Cross Reference report by symbol or by address.

As an alternative to a Cross Reference report, you can choose to display cross reference information on the ladder view. To use this feature, click **View > Properties**, and click the **Address Display** tab. Make sure either or both check boxes are checked in the **Cross Reference Display** area of the dialog box.
Tip: You can disable cross references to get online faster. Click **Tools > Options.** Click the XRef/Address Wizard tab and clear the **Enable Cross Reference Online** box.
Save and load SLC libraries

SLC library files are text files of the processor memory that contain the ladder logic, data table file, and force tables. By exporting and importing these SLC files, you can reuse existing work. SLC files can be opened in a text editor and modified for use in projects.

About library files:

- Only verified project data can be saved to an .SLC file.
- Exported SLC libraries limit symbols to 15 characters. If you have a project file with database symbols that are 20 characters in length, exporting the project to a SLC library will truncate the symbols to 15 characters.
- Graphics characters are not allowed.
- The file name of the file can contain up to eight characters consisting of (A-Z, 0-9, or the underscore character).
- The file extension of the processor memory file must be .slc.
- The text editor you use must produce only printable ASCII characters, with no control characters or hidden characters.

Tip: You can examine any error messages resulting after an import or export operation by examining the .LOG file. This file is stored in the folder named on the Preferences tab accessed by clicking the Tools > Options.

Export libraries

You can save entire projects or partial libraries. To save a partial library, select the rungs that you want to save in the library. To save a project, do not select any rungs. Then right-click and click Copy to SLC Library. Enter the path and filename, then click Save.

You can enter a description in the in the Library Description box. The description appears when you import the library.

Import libraries

To import a library file, open the project where you want to load the library. Then right-click and click Paste from SLC Library.
If you are loading a complete program image into an existing project, data table values in the library overwrite values in the base program, and incoming rungs will be appended to existing program files.

If you are loading a partial library, select the rung that you want the library rungs to precede. Data table values from the library overwrite existing data table values for those addresses already present in the base project.
Chapter 9

Developer features

RSLogix 500 comes in two editions: a Standard edition that provides basic ladder logic editing functions, and a Professional edition that provides additional functions to expand your automation solutions. RSLogix Micro also comes in a Starter edition that provides basic ladder logic editing and a Developer edition that provides expanded features. This chapter briefly describes the features included in RSLogix 500 Professional and RSLogix Micro Developer.

Visual Basic® for Applications (VBA) allows you to add and edit Visual Basic code within the RSLogix 500 or RSLogix Micro development environment. RSLogix 500 Professional and RSLogix Micro Developer include an object model that you can access through VBA. VBA code created through RSLogix 500 Professional or RSLogix Micro Developer is stored in the .RSP files for your projects.

You can run VBA code with RSLogix 500 Standard and RSLogix Micro Starter, but to create or edit VBA code you must use RSLogix 500 Professional or RSLogix Micro Developer.

For more information about using VBA in your automation solutions refer to publication number LOGIX-RM001B-EN-P, RSLogix Automation Interface Reference Manual.

Custom Graphical Monitor

The Custom Graphical Monitor provides graphical data monitoring. Use the Custom Graphical Monitor, to place buttons, sliders, gauges, charts, text, and imported images.

Edit databases with Excel

Use Microsoft Excel® to view and edit project databases. Microsoft Excel 97 (and later versions) comes with an ActiveX® control that enables database editing. You must have Excel installed on the same computer as RSLogix 500 Professional or RSLogix Micro Developer.

The Excel ActiveX control includes search and replace, and let you modify multiple records at the same time. This control minimizes the need to import and export the database.

To access the Excel editor, click Tools > Database > Edit Using Excel. The Address/Symbol Editor opens in Excel.
The system displays the Excel menus and toolbars. You can also access Excel functions by using the right-mouse button menus while working in the editor.

Use Excel to edit the database:

- When you open the Excel editor, the contents of the Address/Symbol database is loaded into the control.
- Changes made within the Excel editor are not applied to the Address/Symbol database until you click **Apply** or **OK**. When you apply changes, the entire Address/Symbol database are overwritten with the contents of the Excel editor.
- Empty rows within the Excel editor are ignored when applying the contents to the database.
- If records are added, removed, or moved within the Excel editor, they are sorted when the contents are applied to the Address/Symbol database.
- Records with errors such as illegal characters, fields with too many characters, and duplicate records will not be written to the database.
- Errors and Illegal records are logged and displayed in a separate window. You can save this information to a file.
- The Excel editor is limited to approximately 64,000 rows per sheet. Databases with more than 50,000 records will have their contents spanned to multiple Excel sheets.

**Logic Trace**

Logic Trace lets you navigate through your ladder logic as if using a Web browser. As you move your cursor through a ladder logic project, the Logic Trace feature keeps track of where you have been. You can then use the Logic Trace toolbar to navigate back to previous positions, or from earlier positions to later ones.

Turn the logic trace toolbar on or off by clicking **View > Toolbars** and selecting or clearing the **Logic Trace toolbar** check box.

**How logic trace works**

As you move your cursor through the ladder logic, the software records the positions of your cursor. When no back or forward history is available, the logic trace arrow buttons are disabled.

Actions that create a back navigation history include cross reference navigation, program file display change, clicking your mouse on ladder logic rung/instruction
elements, searching ladder logic, using the **Goto Rung** function, using dot commands, etc. Keyboard arrow keys will not generate a navigation history.

Actions that create a forward navigation history are limited to clicking an enabled back toolbar button or clicking on a location from the back-button menu.

When you click a back button, the cursor moves to the previous location in the navigation history. Once you move backward in the navigation history, clicking the forward button moves the cursor forward through your navigation history.

The menus are limited to a maximum of 10 entries. Each entry lists a rung/instruction location. While the menus are limited to showing a maximum of 10 entries, the arrows allow you to go much farther back.

If you delete an instruction or rung that is in the history, that item is removed from the logic trace navigation history. If you edit a rung or instruction that is in the navigation history, it remains in the history.
For more information

Find out more about RSLogix 500 or RSLogix Micro with:

- Online help
- Technical support services

**User Application Help**

Add reference source to a project with User Application Help. Use any document format that your computer can open.

User Application Help file is saved with the project. Specify one User Application Help file per project.

To set up the User Application Help file:

1. Create the source file for the User Application Help.
2. From the project tree, under the Help folder, right-click User Application Help and click Properties to open the User Application Help dialog box.
3. Enter the path and file name, or browse for the source file and click OK.
4. (optional) To specify a different source file, go back to the Properties dialog box and enter a new path and name.

**Instruction Set Help**

Each of the instructions has context-sensitive help. Click an instruction in your ladder logic for help about the instruction.

Online Help provides information about which processors can use the instruction.
Index

A
activations 12
addressing 36
ASCII editing 40

B
back up 35
auto-backup 35
compressed format 35
branching 36
add a branch 36
copy branch leg 37
copy entire branch structure 37
delete a branch 38
expand a branch 37
move a branch 36
nested branches 37
parallel branches 37
restrictions 38

C
CDM 52
CGM 53
chassis 33
communications driver 27
compare projects 28
compressed format 35
configure communication channel 31
copy protection, see activation 12
creating 29
data table files 29
program files 29
project files 28
cross reference 54
custom data monitor 52
custom graphical monitor 53

D
D in rung margin 39
data logging 54
data table files
  contents of 29

creating 29
monitoring 31
DII 41
documentation 44
  adding 30
documentation database 44
  editing with Excel 59
  export 47
  import 43

e in rung margin 38
editing
  ASCII editor 40
database with Excel 59
editing with Excel 59
  online example 39
  online restrictions 40
enter ladder logic 35
Excel 59
  using to edit project databases 59
export 47
  A.I. ASCII delimited text file 49
  about 47
  RS500 ASCII delimited text file 47

F
FactoryTalk Activation 12
files
  back-up files 35
  recovery 35
forces 52

G
get started 25
go online 31
goto 31

H
help
  about instructions 63
  hiding program files 28
Index

histogram 53

I
I in rung margin 39
I/O configuration 29
  automatic 35
I/O modules 33
icon bar 26
import 43
  A.I. ASCII delimited text file 49
  A.I. database 43
  APS database 43
  CSV (Comma Separated Values) file 44
  RSLogix 500 database 44
installing
  RSLogix 500 13
instruction palette 26
instruction toolbar 26
instructions
  how to enter 29
  quick entry 36
  quick key mapping 36
  search and replace 31
interrupts
  configuring 28
  DII 41
  STI 41

L
ladder view 26
logic trace 60

M
menu bar 26
module selection 29
  analog and speciality 33
monitoring data 31
multiple rungs
  selecting 29
multipoint monitor 51

O
online bar 26
online editing 38, 39
  restrictions 40

P
policies 19
power supply 29
  loading 33
print a report 32
program files
  contents of 29
  creating 29
project files
  compare projects 28
  creating 29
  opening 28
project tree 26

Q
quick start 26

R
R in rung margin 39
rack selection 29
recipe monitor 53
recovery after power interrupt 35
reports
  previewing 32
  printing 32
results pane 26
RSLinx Classic
  configuring driver 27
RSWho 27

S
search and replace 31
secured actions 21
security policies 19
Security Server
  importing database from Security Server 17
SLC Libraries 57
software requirements 11
status bar 26
STI 41
symbols
  adding to project 30
system communications
  configuring 28

T
  toolbars
    icon bar 26
    instruction bar 26
    logic trace 60
    menu bar 26
    online bar 26
    project tree 26
    status bar 26
    tracing logic 60

V
  VBA 59
  Visual Basic for Applications support 59

Z
  zone marker
    d 38
    D 39
    e 38
    i 38
    l 39
    r 38
    R 39
Rockwell Automation support

Rockwell Automation provides technical information on the web to assist you in using its products. At http://www.rockwellautomation.com/support you can find technical and application notes, sample code, and links to software service packs. You can also visit our Support Center at https://rockwellautomation.custhelp.com for software updates, support chats and forums, technical information, FAQs, and to sign up for product notification updates.

In addition, we offer multiple support programs for installation, configuration, and troubleshooting. For more information, contact your local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/services/online-phone.

Installation assistance

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can contact Customer Support for initial help in getting your product up and running.

<table>
<thead>
<tr>
<th>United States or Canada</th>
<th>1.440.646.3434</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States or Canada</td>
<td>Use the Worldwide Locator available at <a href="http://www.rockwellautomation.com/locations">http://www.rockwellautomation.com/locations</a>, or contact your local Rockwell Automation representative.</td>
</tr>
</tbody>
</table>

New product satisfaction return

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. However, if your product is not functioning and needs to be returned, follow these procedures.

<table>
<thead>
<tr>
<th>United States</th>
<th>Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to your distributor to complete the return process.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States</td>
<td>Please contact your local Rockwell Automation representative for the return procedure.</td>
</tr>
</tbody>
</table>

Documentation feedback

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, complete the feedback form, publication RA-DU002.

Rockwell Otomasyon Ticaret A.Ş., Kar Plaza İş Merkezi E Blok Kat:6 34752 İçekenköy, İstanbul, Tel: +90 (216) 5698 400

www.rockwellautomation.com