Connected Components Workbench® Release Notes (Release 6.01)

January 2014

Contents

Support information
New features and enhancements
Extended controller and device support
System requirements
Working with projects in Connected Components Workbench
Installation and upgrades
Helpful resources
Important considerations
Resolved anomalies
Known anomalies
Application notes

Support information

For technical information and assistance about Connected Components Workbench (CCW):

Support phone:  +1-440-646-3434

Website:  http://www.rockwellautomation.com/support

For information about additional support options you can access from the Help menu, see Access user assistance.
Extended controller and device support

Micro820 controllers

New capabilities provided by Micro820 controllers

Plug-in modules

Safety Relay

Kinetix 3

PanelView Component updates

This release of Connected Components Workbench supports new controllers and devices while continuing to support all controllers and devices from previous releases.

Micro820 controllers

Each Micro820 20-point programmable controller supports a different I/O configuration, and is available with fixed or removable terminal blocks. The catalog model numbers for controllers with removable terminal blocks end with an R. For communication, the Micro820 controllers use Ethernet or the USB port available with the optional remote LCD.

Tip: To communicate using the Ethernet port, you may need to add an Ethernet driver. See Connecting to a Micro800 controller using the Ethernet connection.

For more information about Micro820 controllers, see the manuals available from Help > User Manuals > Controllers > Micro820.

<table>
<thead>
<tr>
<th>Controller</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2080-LC20-20QWB</td>
<td>Micro820 20 digital I/O points, 12 inputs: 8 - 24V DC Sink/Source; 4 - DC/Analog 8 outputs: 7 – Relay; 1 – Analog 24V DC</td>
</tr>
<tr>
<td>2080-LC20-20QBB</td>
<td>Micro820 20 digital I/O points: 12 inputs: 8 - 24V DC Sink/Source; 4 - DC/Analog 8 outputs: 7 - DC FET; 1 – Analog 24V DC</td>
</tr>
<tr>
<td>2080-LC20-20AWB</td>
<td>Micro820 20 digital I/O points 12 inputs: 8 - 120V AC; 4 – Analog 8 outputs: 7 – Relay; 1 – Analog 120V AC</td>
</tr>
</tbody>
</table>
## New capabilities provided by Micro820 controllers

The following table lists the new features and capabilities provided by Micro820 controllers.

<table>
<thead>
<tr>
<th>Capability</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Memory card for backing up and restoring controller projects</strong></td>
<td>The microSD card can be used to backup and restore controller projects, and to store data log files and recipe files. Use the Memory Card configuration to initiate the backup and restore actions.</td>
</tr>
<tr>
<td><strong>Remote LCD for monitoring and configuring machines</strong></td>
<td>This release supports a 2080-REMLCD, which connects to a Micro820 controller through the RS232 port and provides the ability to monitor and configure machines that use the Micro820 controller.</td>
</tr>
<tr>
<td><strong>Data logging and recipe support</strong></td>
<td>The Micro820 controllers provide the ability to configure data logging and to create and store recipes. Use the Data Log feature to create data sets to record date, timestamps, global variables and local variables from the Micro800 controller to the microSD card. Use the Recipe feature to create and store recipes, to load a list of data to a recipe file, to load a list of data from a recipe file, and to retrieve Recipe data from the microSD card and upload it.</td>
</tr>
</tbody>
</table>

## Plug-in modules

This release supports the following plug-in modules.

<table>
<thead>
<tr>
<th>Plug-in module</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2080-DNET20</td>
<td>Communication plug-in module that adds DeviceNet capability to the controller.</td>
</tr>
<tr>
<td>2080-MOT-HSC</td>
<td>Specialty plug-in module that can function as a motion feedback axis or as a High Speed Counter (HSC) for the controller.</td>
</tr>
</tbody>
</table>
Device firmware requirements

Some devices available in Connected Components Workbench must use a specific firmware release to take advantage of CCW’s newest features. Each device’s release notes, which are available from the Rockwell Automation Literature Library, identifies the specific firmware requirements. For instructions on accessing the latest release notes and other documents, see Resources available from the Literature Library.

<table>
<thead>
<tr>
<th>Device</th>
<th>Firmware &amp; Release Notes</th>
<th>Website location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Safety Relay (440C) series</td>
<td>See RN 440R-RN001-EN-P</td>
<td><a href="http://ab.rockwellautomation.com/Relays-and-Timers/Safety-Relays">http://ab.rockwellautomation.com/Relays-and-Timers/Safety-Relays</a></td>
</tr>
<tr>
<td>Kinetix 3</td>
<td>FW V3.06 2071-RN002-EN-P</td>
<td><a href="http://ab.rockwellautomation.com/Motion-Control/Kinetix-3-Servo-Drive#/tab6">http://ab.rockwellautomation.com/Motion-Control/Kinetix-3-Servo-Drive#/tab6</a></td>
</tr>
<tr>
<td>PanelView Component</td>
<td>FW V1.80 2711C-RN010-EN-E</td>
<td><a href="http://ab.rockwellautomation.com/graphic-terminals/2711p-panelview-plus-6-terminals">http://ab.rockwellautomation.com/graphic-terminals/2711p-panelview-plus-6-terminals</a></td>
</tr>
</tbody>
</table>

Safety Relay

The Guardmaster 440C-CR30 Software Configurable Safety Relay (440C) can be used to monitor multiple safety devices. Using simple logic configuration, it can control multiple independent safe outputs. For additional information, see the following documents available from the Rockwell Automation Literature Library.

- For details about the Safety Controller, see the GSR830 Programmable Safety Controller User Manual (440R-UM010A-EN-P)
- For specific device firmware requirements and other Safety Relay requirements, see the 440C-CR30 Software Configurable Safety Relay Release Notes, Catalog Number 440C-CR30-22BBB (440R-RN001-EN-P)
- For information about working with the device in Connected Components Workbench, see the Safety Relay section available from Help > View Help.

Kinetix 3

The Kinetix 3 is a single-axis component servo drive. For additional information, see the following documents available from the Rockwell Automation Literature Library.

- For details about Kinetix 3 drives, see documents available from Help > User Manuals > Drives > Kinetix Drives.
- For specific device firmware requirements and other Kinetix 3 requirements, see the Kinetix 3 Release Notes (2071-RN002-EN-P).

PanelView Component updates

PanelView Component includes a new Catalog Change function and an enhanced Download function. For additional information, see the following documents available from the Rockwell Automation Literature Library.

- For details about PanelView Components, see the documents available from Help > User Manuals > Graphic Terminals.
- For specific device firmware requirements and other PVc requirements, see the PVc Release Notes (2711C-RN010-EN-E).
New features and enhancements

Password protection for programs and UDFBs

Initial values (for UDFB variables)

Aliasing for Micro800 variables

Change Controller

New function blocks

Multiple session support

Usability enhancements

Password protection for programs and UDFBs

The ability to password-protect your Micro800 programs and user-defined function blocks (UDFBs) has been added to the Developer edition in this release. Password protection prevents unauthorized access to programs and user-defined function blocks and protects your intellectual property from being used or changed without your consent.

To configure a program or user-defined function block password

- From the Project Organizer, right-click the saved program or user-defined function block and select Password.

Initial values (for UDFB variables)

If you change the UDFB definition from a previous release, you can use the Refactoring window to reset initial values for variables in a user-defined function block definition. You can reset specific instances or reset all instances of user-defined function blocks from Release 4 or earlier projects.

To open the Refactoring window

- From the Project Organizer, right-click the function block definition and select Refactor > Reset Initial Values of Instances.

Aliasing for Micro800 variables

If you are using Alias names or plan to use them to further describe local and global variables, you can reference the variables while developing your program by selecting the Alias name from the auto-complete drop-down list in a Language Editor. The Alias name is listed in the following format:

    AliasName(VariableName) where
    AliasName is the alias associated the variable’s VariableName.

Alias names are particularly useful for placing application specific names on I/O variables. When the Alias name is used to reference a variable for a programming element, the element label shows the Variable name and the Alias name.

If you previously used an Alias name that was not unique, it will be flagged in the variable view and you will be asked to make it unique. To avoid confusion, we suggest that you eliminate duplicate aliases. If you choose to use duplicates, however, the application will still build without an associated error.
**Change Controller**

You can now change the current controller type or update the current controller project with the latest controller revision. Changing the controller type saves the current controller project and creates another controller project based on the target controller type. The program elements, user-defined function blocks and user-defined data types from the current controller project are saved in the target controller project and the latest controller revision is applied to the target. If the current project contains devices such as Graphic Terminals or Drives, the configurations are copied to the Connected Components Workbench project.

**To open the Change Controller window**

- From the Project Organizer, right-click the Micro800™ controller and select **Change Controller**.

**New function blocks**

<table>
<thead>
<tr>
<th>Function block</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RCP</td>
<td>The recipe function block allows you to save and restore a list of data to and from the SD memory card recipe file.</td>
</tr>
<tr>
<td>DLG</td>
<td>The data logging function block can be used to write variable values from the run-time engine into a data logging file on an SD card.</td>
</tr>
<tr>
<td>PWM</td>
<td>The pulse width modulation turns the PWM output for a configured PWM channel on or off.</td>
</tr>
<tr>
<td>KEY_READ_REM</td>
<td>The key read remote function block checks the Key status on a Remote LCD module when the user display is active.</td>
</tr>
<tr>
<td>LCD_REM</td>
<td>The LCD remote function block displays user strings on the Remote LCD when it is present and connected.</td>
</tr>
<tr>
<td>LCD_BKLT_REM</td>
<td>The LCD backlight remote function block sets the remote LCD backlight parameters in a user program.</td>
</tr>
</tbody>
</table>

**Multiple session support**

You can create or open separate projects at the same time using different sessions of Connected Components Workbench, which allows you to open an existing project, and then, without closing the existing session, start another session and use it to create a new project by copying and pasting programming and some configuration objects from one project to another project.
**Usability enhancements**

This release includes the following usability enhancements.

<table>
<thead>
<tr>
<th>Interface element</th>
<th>Description of updates since previous release</th>
</tr>
</thead>
<tbody>
<tr>
<td>New user interface</td>
<td>Quick Tips initial screen that provides information for the most common tasks.</td>
</tr>
<tr>
<td><strong>Toolbar and toolbox changes</strong></td>
<td></td>
</tr>
<tr>
<td>Device Toolbox</td>
<td>Plug-in Modules folder and Expansion Modules folder added under the Controllers folder.</td>
</tr>
<tr>
<td><strong>Windows and dialog boxes</strong></td>
<td></td>
</tr>
</tbody>
</table>
| Project Organizer          | • Refactor (existing UDFBs)  
• Change Controller  
• Password protection (Developer edition only)                                                          |
| Installation               | Setup is now more modular so you can add and/or upgrade drives and other devices independently from a Connected Components Workbench release.  
The setup executable name CCWSetup.exe has been changed to Setup.exe to be consistent with Microsoft Windows® software naming conventions. |
System requirements

Hardware requirements

Operating system requirements

Micro800 firmware revision compatibility

For the latest Rockwell Automation product compatibility information

Rockwell Automation® software compatibility

RSNetWorx compatibility requirements

Hardware requirements

To use this release of Connected Components Workbench effectively, your personal computer should meet the following minimum hardware requirements:

<table>
<thead>
<tr>
<th>Component</th>
<th>Minimum requirement</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processor</td>
<td>Pentium 3 or better</td>
<td>Pentium 4 or better</td>
</tr>
<tr>
<td>RAM memory</td>
<td>1 GB</td>
<td>2.0 GB or more</td>
</tr>
<tr>
<td>Hard disk space</td>
<td>9.0 GB free</td>
<td>10.0 GB free or more</td>
</tr>
<tr>
<td>Optical drive</td>
<td>DVD-ROM</td>
<td>DVD-ROM</td>
</tr>
<tr>
<td>Pointing device</td>
<td>Any Microsoft Windows®-compatible pointing device</td>
<td>Any Microsoft Windows®-compatible pointing device</td>
</tr>
</tbody>
</table>

Operating system requirements

This release is supported on the following operating systems:

- Microsoft Windows 7® (32-bit and 64-bit)
- Microsoft Windows 2008® (R2)

Additionally, Internet Explorer, which is installed with the operating system, is required to view the Connected Components Workbench help.

Micro800 firmware revision compatibility

The following table identifies the major firmware revisions that can be used for each of the Micro800 controller types.

<table>
<thead>
<tr>
<th>Controller type</th>
<th>Major firmware revisions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Micro810</td>
<td>1.xxx and 2.xxx</td>
</tr>
<tr>
<td>Micro820</td>
<td>6.xxx</td>
</tr>
<tr>
<td>Micro830</td>
<td>1.xxx, 2.xxx, 4.xxx, and 6.xxx</td>
</tr>
<tr>
<td>Micro850</td>
<td>2.xxx, 4.xxx, and 6.xxx</td>
</tr>
</tbody>
</table>
To view the latest Micro800 controller firmware information

See Micro800 Programmable Controllers Release Notes (2080-RN001_.pdf) located in the following locations:

- Release Notes folder on your installation media, or
- Program Files\Common Files\Rockwell\Help folder after you install Connected Components Workbench.

To obtain the latest drivers and firmware updates

Go to http://www.rockwellautomation.com/rockwellautomation/support/overview.page

For the latest Rockwell Automation product compatibility information

Connected Components Workbench has been tested to interoperate with most Rockwell Automation software.

For the latest information about software platform support:

Go to http://www.rockwellautomation.com/rockwellautomation/support/pcdc.page

For the latest drivers and firmware updates:

Go to http://www.rockwellautomation.com/rockwellautomation/support/overview.page

Rockwell Automation® software compatibility

This release has been successfully tested with the Rockwell Automation software products listed in the following table.

<table>
<thead>
<tr>
<th>Software</th>
<th>Tested version</th>
</tr>
</thead>
<tbody>
<tr>
<td>RSLinx® Classic</td>
<td>V3.60.01</td>
</tr>
<tr>
<td>ControlFLASH™</td>
<td>V12.00.01</td>
</tr>
</tbody>
</table>

RSLinx Classic compatibility requirements

RSLinx Classic v3.60.01, which is included with Connected Components Workbench, is not compatible with the following product versions:

- RSNetWorx v11.00 or earlier
- DeviceNet Tag Generator v11.0 or earlier

RSNetWorx compatibility requirements

If an incompatible version of RSNetWorx (v11.00 or earlier) is detected during installation, the installation will not continue. You will need to either remove the incompatible version or upgrade RSNetWorx to v21.00 or later.

RSNetWorx compatibility product notice

The current version of RSNetWorx v11 and Prior Incompatibility with Rockwell Automation Software Products is available from the Rockwell Automation Support Center, as Product Notice ID 56697.

Upgrading RSNetWorx

If you are under a current technical support contract, you may download RSNetWorx v21 from the Rockwell Automation Compatibility and Download Center.
To download RSNetWorx

- Click the Download Software Updates link and enter your Rockwell Automation Member identification.
- Enter your Company Name and the Software Serial Number for your current RSNetWorx.
- Follow the instructions to download and install the updated software product.

If you are not under a current technical support contract, you may purchase an update for RSNetWorx by contacting Rockwell Automation sales.

Note: RSNetWorx v21.00 is also available in Studio Professional v21.00.

Working with projects in Connected Components Workbench

Using existing projects in current release

Using different account types

Localized versions of Connected Components Workbench

Using existing projects in current release

You can open a project created in a previous release without updating the controller firmware or performing a manual project conversion. However, if you want to use the most current features, you must convert the project using the Change Controller feature. If you do not update the controller revision to the latest, new features will not be available. See the Convert a project to the current release in this document for more information.

Using different account types

When you create new projects or open existing projects, we recommend you do not use the default Guest user account, and that you do use the same type of account you used when you installed Connected Components Workbench. That is, if you were logged in under an administrator account when you installed CCW, you should log in with an account that has administrator privileges when you use Connected Components Workbench.

To change to an administrator account

1. Navigate to: \Program Files > Rockwell Automation > CCW
2. Right-click CCW.Shell.exe, select Run as..., select Administrator user.
3. Click OK.
To create a new Guest user account

1. Open the New User dialog box:
2. Right-click Users and then select New User.
3. In the New User dialog box, enter the new user name and password and click Create.
4. Click Groups to display the group types.
5. Double-click the Guests group to open the Guests Properties dialog box.
6. Click Add, and enter the location and name information for the newer user you created in previous steps.
7. Click Check Names to verify the information is correct.
8. Click OK to add the new guest user to the Guest group.
9. Click OK to close the dialog box.

Localized versions of Connected Components Workbench

Some features within CCW may only appear in English, even in the localized versions of the software. For example, the DeviceLogix editor, which is used for PowerFlex drives is only available in English.
Installation and upgrades

Installing Connected Components Workbench

Upgrading to the current release of Connected Components Workbench

Opening existing projects

Converting an existing project to the current release

Removing Connected Components Workbench

Installing a different language edition of Connected Components Workbench

Installing newest PanelView Component firmware

Installing Connected Components Workbench

Follow these steps to install Connected Components Workbench.


2. Launch Setup.exe.

3. Follow the prompts in the Connected Components Workbench Setup window. **Note:** CCW determines the correct components to upgrade and/or install. If there is a reboot requirement, reboot the operating system so the install can complete successfully.

4. When the installation is complete, click **Finish**.

**Tip:** Some Microsoft components may require a restart before the full CCW installation is complete. If Connected Components Workbench does not install completely, restart the computer and then re-install CCW. After the Connected Components Workbench installation completes, the computer background will return to its default setting.

Upgrading to the current release of Connected Components Workbench

Follow these steps to upgrade a previous release of Connected Components Workbench to the current release.

<table>
<thead>
<tr>
<th>To upgrade from</th>
<th>To</th>
<th>Do this…</th>
</tr>
</thead>
</table>
Perform an upgrade |
| From a non-English version | An English version | Obtain the latest ENG installation of Connected Components Workbench  
(Standard Edition or Developer Edition) |
Before you begin

Record device configuration information related to Modbus mapping, Interrupts, Serial Port settings and Embedded I/O for all existing projects.

To upgrade

1. Launch Setup.exe.
2. Follow the prompts in the Connected Components Workbench Setup window.  
   **Note:** Connected Components Workbench determines the correct components to upgrade.
3. Click **Finish** when the upgrade is complete.
4. If you are prompted to select Online or Local Help the first time you launch the Help, select Local.
5. If you want to use the most current features on projects created in previous releases of CCW, follow the steps in **Converting an existing project to the current release**.

Opening existing projects

An existing project that is converted to the current release, or opened and saved in the current release, or downloaded to a Micro800 controller cannot be opened in a previous release. If a project is shared, all users must upgrade to the current release of Connected Components Workbench to continue using the project.

Converting an existing project to the current release

When you open a project that was created in a previous release of Connected Components Workbench, the project database is automatically updated to the current release. However, to use new features associated with the current release, you must use the **Change Controller** feature to update the controller firmware revision. For the specific firmware revisions that can be used for each controller type, see **Micro800 firmware revision compatibility**.

To convert an existing project

1. Open the existing project in the current version of Connected Components Workbench.
2. **Recommendation:** Record device configuration information related to Modbus mapping, Interrupts, Serial Port settings and Embedded I/O for the project.
3. Use the **Change Controller** feature update the controller firmware revision.
4. If necessary, manually reconfigure Modbus mapping, Interrupts, Serial Port settings and Embedded I/O for the project.

   **Note:** Modbus mapping information is stored in the MbSrvConf.XML file located in the CCW project structure: CCW\<projectname>\controller\controller and can be copied from original project to the newer one.

Removing Connected Components Workbench

Follow these steps to remove Connected Components Workbench only. For other components, remove each component separately **after** removing Connected Components Workbench.

1. Uninstall Connected Components Workbench.
2. Verify Connected Components Workbench does not appear in the list of installed programs.
3. Remove other components as necessary. See Components installed with Connected Components Workbench.

Installing a different language edition of Connected Components Workbench

Follow these steps to install a language edition of Connected Components Workbench that is different from the one currently or previously installed. For example, to install Connected Components Workbench (English) on a computer that previously had Connected Components Workbench (French) installed.

To remove Connected Components Workbench and Microsoft VS Shell SP

IMPORTANT: Remove CCW before you remove Microsoft Visual Studio Shell or you will not be able to remove CCW.

1. Uninstall Connected Components Workbench.
2. Verify Connected Components Workbench does not appear in the list of installed programs.

To install English Connected Components Workbench

There are two installation options: Standard Edition or the Developer Edition, which requires an activation key.

1. Obtain the full installation of the Connected Components Workbench edition you wish to install.
2. Launch Setup.exe, which will re-install Connected Components Workbench and the correct version of Microsoft Visual Studio Shell.
3. Follow the prompts in the Connected Components Workbench Setup window.
4. When the installation is complete, click Finish.

Installing newest PanelView Component firmware

PanelView Component DesignStation, which can be used to use to create, configure, and monitor Graphic Terminal devices, is installed with Connected Components Workbench and can be accessed from the Project Organizer after you add a Graphic Terminal device.

An upgrade of your PanelView component firmware is not required, but it is recommended, and may be needed for newer features. You can download the latest PanelView Component firmware from the following location:

http://ab.rockwellautomation.com/Graphic-Terminals/2711C-PanelView-Component-C400-Terminals#/tab6

Note: This latest firmware v1.80 is required to use new features such as the enhanced Download function, which can be used to download your PVc from CCW.
## Components installed with Connected Components Workbench

The following additional components are installed with Connected Components Workbench Standard and Developer Editions. However, these components will not be removed if you uninstall Connected Components Workbench because other software may be using them.

<table>
<thead>
<tr>
<th>Type</th>
<th>Includes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rockwell Automation</td>
<td>• ControlFLASH™ 12.00.01&lt;br&gt;• Rockwell Windows Firewall Configuration Utility 1.00&lt;br&gt;• Rockwell Automation USB CIP Driver Package (x86) or Rockwell Automation USB Driver Package (x64)&lt;br&gt;• RSLinx Classic 3.60.01&lt;br&gt;• Unified Device Configuration files</td>
</tr>
<tr>
<td>Microsoft .NET Framework</td>
<td>• Microsoft .NET Framework 4 Client Profile&lt;br&gt;• Microsoft .NET Framework 4 Extend</td>
</tr>
<tr>
<td>Microsoft Visual Studio 2010 Isolated Shell – ENU</td>
<td>• Microsoft .NET Framework 4 Multi-Targeting Pack&lt;br&gt;• Microsoft SQL Server 2008 R2 Management Objects&lt;br&gt;• Microsoft SQL Server System CLR Types&lt;br&gt;• Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729&lt;br&gt;• Microsoft Visual C++ 2010 X86 Runtime - 10.0.40219&lt;br&gt;• Microsoft Visual Studio 2010 Shell (Isolated) –ENU</td>
</tr>
<tr>
<td>Microsoft – other</td>
<td>• MSXML 4.0 SP2 Parser and SDK&lt;br&gt;• Microsoft Help Viewer 1.1&lt;br&gt;• Microsoft SQL Server Compact 4.0.8482.1</td>
</tr>
<tr>
<td>Other</td>
<td>• OPC Core Components Redistributable (x86) 101.2 or OPC Core Components Redistributable (x64) 101.2 (if the operating system is 64-bit)&lt;br&gt;• Virtual COM Port Device Driver 6.3a&lt;br&gt;• Adobe Reader 11.0</td>
</tr>
<tr>
<td>Connected Components Workbench Developer Edition only</td>
<td></td>
</tr>
<tr>
<td>Microsoft Visual Studio 2010 SP1</td>
<td>• Microsoft Visual Studio 2010 Tools for Office Runtime (x86)&lt;br&gt;• Microsoft Visual Studio 2010 Service Pack 1</td>
</tr>
<tr>
<td>FactoryTalk</td>
<td>• FactoryTalk Activation Manager v3.60.00 (CPR 9 SR 6)&lt;br&gt;• FactoryTalk Diagnostics v2.60.00 (CPR 9 SR 6)</td>
</tr>
</tbody>
</table>
Helpful resources

User assistance available in the application
Accessing Rockwell Automation support websites
Rockwell Automation Knowledgebase
Rockwell Automation Literature Library

User assistance available in the application

Use the Help menu to access online information such as user manuals, user forums, support e-mail, and the Rockwell Automation Knowledgebase.

Click F1 to open a topic specific to a user the user interface item you have selected.

**Tip:** If the user interface item does not display a topic, click Help > Search and enter a subject in the search box to locate a relevant topic in the help.

**Tip:** Connected Components Workbench uses local help only. If the Online Help Consent dialog box appears when you press F1, click No, and verify the I want to use local help option is selected.

Accessing Rockwell Automation support websites

With the exception of the manuals, you must register (Become a Member) to access, free of charge, Rockwell Automation support websites. Register at:

http://ab.rockwellautomation.com/

Rockwell Automation Knowledgebase

The Rockwell Automation Knowledgebase contains product notices, technotes, and FAQs that you can access after you log into the Knowledgebase.

To access articles from the Rockwell Automation Knowledgebase

2. Log in.
3. Enter the article ID (for example: 116930) in the Search box.

Knowledgebase articles

<table>
<thead>
<tr>
<th>Article</th>
<th>ID number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Micro800 basic FAQ</td>
<td>Answer ID 116930</td>
</tr>
<tr>
<td>Micro800 extended technical FAQ</td>
<td>Answer ID 118815</td>
</tr>
<tr>
<td>RSNetWorx v11 and Prior Incompatibility with Rockwell Automation Software Products</td>
<td>Product Notice ID 56697</td>
</tr>
</tbody>
</table>
Rockwell Automation Literature Library
You can view or download publications from the Rockwell Automation Literature Library, including the following:

- PanelView Component DesignStation Release Notes (2711C-RN010-EN-E)
- Kinetix 3 user manuals
- Kinetix Rotary Motion Specifications
- Safety relay user manual
- Non-English language versions of user manuals

To access manuals from the Rockwell Automation Literature Library

2. Click Advanced Search.
3. Enter the product information and other search criteria, and click Search.

To access non-English language versions of user manuals

2. Select the language from the Publication Language drop-down box (right corner).
3. Enter the full or partial device catalog number the Search box. For example, enter 2080-LC30 to view Micro830 user manuals.
Important considerations

IEC-61131 standards

Programming, configuring and debugging

Uploading, downloading and building

IEC-61131 standards

Connected Components Workbench adheres to the IEC-61131 standards for programming. If you do not have previous experience with IEC-style concepts and programming, we recommend you review the “Getting Started with Developing” section in the software help. The topics, which step you through the process of creating a basic sample application, are intended to introduce you to IEC-style programming within the Connected Components Workbench environment.

Programming, configuring and debugging

- Unless specifically stated in user documentation, do not change attributes in Property dialogs for Micro800 controllers.
- Some features that should be disabled appear available while the debugger is operating. A small subset of these features may cause Connected Components Workbench to close unexpectedly. If you recently started the debugger, ensure you stop it before performing other software operations.
- Connected Components Workbench does not automatically update every instance of a changed UDFB (User-Defined Function Blocks) referenced in an existing program. If you change a UDFB definition, you should update each individual instance of the UDFB. To do so, locate it each instance, double-click it, and then build the program.

Uploading, downloading and building

- When you build a controller project with Connected Components Workbench, all changes are immediately committed to your hard drive or to your designated storage device so you will not be able to undo any changes. To ensure you can return your project to a prior state, save the project using a different name after making changes.
- If the Upload or Download options are not available in the Device Configuration toolbar, select the Micro800 controller from the Project Organizer, and then click Upload or Download. If this does not activate upload/download, rebuild the project by right-clicking the controller in the Project Organizer and selecting Build.
Resolved anomalies

Resolved projects, documentation and tools anomalies

Resolved controllers and devices anomalies

Resolved data types and variables anomalies

Resolved instruction block anomalies

Resolved program anomalies

Resolved import and export anomalies

Resolved build, debug, download and upload anomalies

This section identifies anomalies that have been resolved since the last release of Connected Components Workbench.

Resolved projects, documentation and tools anomalies

The **Edit -> Find** function now locates sub-members of variables in LD and FBD POUs. [APBC00011723]

If you configure the appearance of an object in a PVC application using the transparency background color, it now appears transparent in the software, and the object background is also transparent when the application runs on the terminal. [APBC00014590]

The Alias attribute in the Variable Editor windows can now be used as an alias to represent a variable name. For example, if Alias is "A1" for the "_IO_EM_DO_00" variable, you can select "A1" or "_IO_EM_DO_00" from the variable list. See the Aliasing for Micro800 variables topic in this document for more information about using an alias. [APBC00010009]

Resolved controllers and devices anomalies

The Interrupt table is refreshed after you delete a POU in which an interrupt is configured, so the deleted Interrupt will not appear and you will not receive an error message in the Output window. [APBC00011477 APBC00015554]

If you save your project using **Save Project As** while the Quick Tips window is open, or you open and close controller projects and drive projects, Connected Components Workbench will no longer shut down unexpectedly. [APBC00017249 APBC00017489]

In this release of Connected Components Workbench, if you attempt to open a controller project that is not compatible with the current version of Connected Components Workbench, the error message more clearly identifies the compatibility issue. Previous releases are not affected, however. For example, if you attempt to open a CCW R6.00 controller project with CCW R5.01, you may not be able to, and the error message will not identify the reason. [APBC00017132]
Resolved controllers and devices anomalies

If you open an existing project, and then change the type of controller to one that does not support all of the functions blocks used in the program, the error will now point to the specific cause for the build failure. [APBC00016715]

When a project is renamed in Connected Components Workbench the spy lists are retained, including the system variables such as __SYSVA_CYCLEDATA. [APBC00014923]

When you make changes to the fields in the parameter editor view for the Block Selector window, the changes are accurately reflected in the editor. [APBC00014948]

If you double-click a Return element or a Jump element in the LD Toolbox, the element you select will be added to the Ladder Diagram program. [APBC00016631]

Resolved data types and variables anomalies

Previously, when data retrieved from an OPC Server was of a REAL data type, multiplication actions performed on the data would not always yield the correct results. The issue has been resolved by converting the data from Big-endian format to Little-endian format before converting it to float so multiplication computations are now correct. [APBC00018426]

If you enter a DINT constant in a hexadecimal, octal or binary base you will no longer receive the following error message: “Expecting a DINT type variable or constant.” [APBC00008422]

System variables now display properly within the Cross Reference Browser. [APBC00010624]

If you set the Initial Value of a string data type, and then change the string size, the new string size will immediately display in the variable grid. [APBC00016383]

The Retained and Address columns are no longer displayed in the Global Variables and Local Variables Editors after discovering a Micro830 or Micro850 controller in Connected Components Workbench. [APBC00015319]

If you attempt to modify system variables while the controller is in run mode, you will receive a warning message, but you will be able to continue. [APBC00011076]

If you assign an initial value to a UDFB variable, the value will be copied to any new instances of the UDFB when you refactor. [APBC00011728]

Previously, when you were in debugging mode, the logical value for a variable in the Variable Monitoring window displayed as OFFLINE, which was not accurate. In this release, the value for the variable displays correctly. [APBC00011612]

After adding a new array element variable and assigning it a value, you are able to use the up or down arrow key to change focus in the Variables grid. [APBC00007299]
Resolved data types and variables anomalies

In the **Variable Editor**, if you copy and paste the initial value of a nested array or nested structure with a sub array type, and then Build the project, the project will build successfully. [APBC00015104]
Resolved instruction block anomalies

In Connected Components Workbench R6.00, the instruction execution optimization produced anomalous results under the following circumstances.

- The controller project version was R6 and Micro800 firmware was version 6.011.
- The ladder logic rung was implemented in a User-Defined Function Block (UDFB).
- The rung contained a Compare operator (\(=\), \(>\), \(>=\), \(<\), \(<=\)).
- The Compare block had an input condition that was FALSE (disabled), which should have disabled the block and made the output condition FALSE (disabled).

**Recommendation:** If you have Micro800 applications you built using Connected Components Workbench R6.00, rebuild your R6.00 programs using Connected Components Workbench R6.01. Then, download and debug the R6.01 versions of your programs to verify the programs execute correctly. [APBC00019745]

If you add an HSC instruction block to a Ladder Diagram rung, and then cut and paste the entire rung (including the HSC instruction block) to a new rung, an \_ADI\_plsData parameter no longer unexpectedly appears on the second HSC instruction block. [APBC00011375]

Previously, the **EN/ENO** checkbox did not display in the Block Selector after uploading. The **EN/ENO** check box now appears in the window after you uploading a project to a Micro800 controller. [APBC00014922]

In the Block Selector, if you click the **Show Parameters** button and then resize the Block Selector window, the Instructions and the Parameters correctly display together in the window. [APBC00014821]

You can now name a variable in a UDFB the same as a global variable without receiving an error message when you build your project. [APBC000011074]

Resolved import and export anomalies

In previous releases, if an imported file contained a variable with the same name as a variable in the existing project, a duplicate variable was created in the project. In this release, the existing variable is replaced by the imported variable. [APBC00015903]

When you import a compatible exchange file, you will no longer receive the following error message:

“The target used in exchange file must match the one used by the project.” [APBC00011731]

If, after building your program, you receive errors, the location of the errors reported in the Error List will now be correct, and the Find Errors in code button in the Output window will respond when you click it to locate the errors. [APBC00016767]

If you keep the cursor focused on any cell within a variables editor, and then build the project, the Start Debugging and/or Download options will now be available. [APBC00005218]
Resolved import and export anomalies

Previously, if you imported or opened a project that was created in an earlier release, you could not build the project, and received the following error message:

“Embedded file size beyond limit”.

In this release, the files used for importing and exporting are in XML format, and the embedded zip file stored on the controller is smaller. [APBC00014949]
Resolved build, debug, download and upload anomalies

The **Change Controller** feature allows you to update the controller project with the latest controller revision so newer features will be available in the project, which will reduce compatibility when you build the project. [APBC00015097]

If, while downloading, you disconnect the controller cable, and then reconnect it, the controller will no longer be left in an indeterminate state, and you will not receive an exception error when you attempt to upload a project. [APBC00004904]

Previously, if a project failed to build, you could not upload the project. In this release, you can upload a project. [APBC00010402].

If you repeatedly change the controller mode switch while in debug mode, Connected Components Workbench no longer unexpectedly closes. [APBC00011465]

If you view an array variable in UDFB using a language editor, the value now updates correctly. [APBC00015320]
Known anomalies

Installation

Projects, documentation and tools

Controllers and devices

Data types and variables

Instruction blocks

Programs

Import and export

Build, debug, download and upload

This section describes known anomalies in this release and, if needed, provides workarounds.

Installation

If you install Connected Components Workbench without installing RSLinx, the Micro830 and Micro850 controllers with firmware revision 4.x are not recognized when you open RSLinx Classic. In CCW you can connect, upload, download, and debug functions using the unrecognized device.[APBC00015286]

**Workaround:** If this happens, you can register the Electronic Data Sheets (EDS) files for the controllers with firmware revision 4.x so they are recognized in RSLinx Classic.

1. Navigate to: 
   C:\Program Files\Rockwell Software\RSCommon
2. Use the **RSHWare.exe** to register the EDS files.

If you install Connected Components Workbench on a Microsoft Windows® operating system using an account that does not have administrator privileges, which is not recommended, the following message appears:

"Do you want to allow the following program to make changes to this computer?"

If you continue the installation, you must enter a user name and password associated with an account that has administrator privileges, and then click **OK**.

When the installation is complete, note the "CCW", "CHMI", "Rockwell Automation" and "Visual Studio 2010" folders are all created in the Administrator user path. "\Users\<administrator name>\Documents"

These folders should be created in the standard user path: "\Users\<standard username>\Documents" [APBC00012930]
Projects, documentation and tools

The user manual for the Guardmaster_440C_CR30 is not yet available from the Help > User Manuals menu. [APBC00018733]

Workaround: You can obtain the user manual from the Literature Library.

- See the Safety Relay topic in this document for information on obtaining the user manual.
- Additionally, you can view related help by clicking Help > View Help and locating the Safety Relay book in the help table of contents.

If you click a hyperlink on the MSP module page on a computer that does not have IE Explorer installed, Connected Components Workbench may stop responding or shut down. [APBC00019002].

If you create a project, leave the project open, switch to a different user, open a new instance of Connected Components Workbench and create another project, you may receive a catalog error and you will not be able to create a new project. [APBC00017014]

If, after creating a project, you select a newly created variable in the Global Variables window, and then select Tools -> Document Generator, the generated document may be empty even when it should contain device information. [APBC00013525]

The following content in the Document Generator appears in English in the non-English versions of Connected Components Workbench 3.0: ToolTips for None and Scale. [APBC00013946]

The Tools -> Execution Order feature may not be available or work properly on a program that is password protected. [APBC00018113]

Workaround: To modify the execution order, remove the program password, change the execution order, and then re-apply the program password.

If, after you install the English version of CCW, you change the language format text to the Turkish language, you may receive unexpected results including the following:

- Broken help links when you reopen a project.
- Non-English characters that display when you debug your program.
- Inability to use the filter feature in a language editor for certain characters.
- Failed build because the project name or folder name contains invalid characters. [APBC00015798], [APBC00016210], [APBC00015727], [APBC00015858], [APBC00016400]

If, while using the English version of CCW, you enter non-English characters in a string variable, the characters may not display properly after you save, close and then reopen the project. [APBC00015937]

Workaround: In your operating system, select the language version of non-Unicode programs that will be used in the Language for non-Unicode programs.
If you perform a Save Project As and use a capital "I" (language set to English) or a "i1" (language set to Turkish) in the project filename, you may receive the following unexpected results, which will generate a “Opening application failed” error message.

A duplicate project folder may be created that uses the same folder name, but with a lower case "i".

You will not be able to expand the nodes under the graphic terminal in the Project Organizer.

If you customize the grid columns in a variable grid and then select Save as default layout settings, the settings will be retained even after you click Tools > Import and Export Settings and select the No, just reset settings overwriting my current settings option.

If you open multiple projects on a network drive using File > Recent Projects, and then exit or close CCW, the application may not close immediately.

Context-sensitive help may not be available for all elements in the Structured Text editor.

**Workaround:** Click Help > View Help and use the Help search box to locate the topic.

Content for the instruction block tooltips, and in the Category and Comment columns of the Instruction Block Selector appear in English in the non-English versions of Connected Components Workbench. [APBC00013270] [APBC00012607]

If you add a Block element to a Program (POU) in the non-English versions of Connected Components Workbench, rename the POU in the Project Organizer and then click Save or Build a “Detected… modification” error may appear.

**Workaround:** Close the error dialog and continue.

If you use the Document Generator to create documentation for Programs (POU) that contain large Ladder Diagrams, the generated document might incorrectly display the picture of the Ladder Diagram as a black image.

**Workaround:** Use a different document viewer or create a partial report by selecting individual sections of the project to generate. [APBC00013865]

The labels for Browse and No header or footer in the Document Generator for the non-English versions of Connected Components Workbench may be truncated. For example, the label 'Durchsuchen' appears as 'Durchsuche'. [APBC00013944]
The Quick Find and Quick Replace features (Ctrl+F and Ctrl+H) are limited to logic editor. They do not work with devices, global variables or UDFBs. Additionally, Quick Find has the following limitations:

- It does not find any items when the Look In selection is Current Project or Entire Solution.
- It may not locate all instruction blocks within all containers in the project.
- It does not find all instances of the same Array element variable in all the programs within a project.

**Workaround:** To find items in the project, click Edit > Find and Replace > Quick Find, and click Current Document or All Open Documents in the Look In drop-down box.

The Quick Find and Quick Replace features will be enhanced in a future release.

If the appearance settings in your operating system uses a high-contrast color theme, some workspace elements will display incorrectly. For example, ladder rungs and connectors in the program editors, graphics and toolbar in the Controller Details view, and the Device Toolbox. 

**Workaround:** Do not use a high-contrast color scheme.

If you select View > Document Overview while in the Structured Text language editor, the Document Overview displays a blank page.

---

### Controllers and devices

If you select the following Load from Memory Module options in the Controller - Startup/Faults window:

- **Load Always** - selected
- **Load on Memory Error** - cleared
- **Load Ethernet Settings** - selected

And then build, download and backup a project to a SD memory card, the Load Ethernet Settings option will always appear disabled.

If you remove all the characters in the Name textbox in the Controller Configuration pane, you might receive the following error message:

“Controller name cannot be empty,” even though you may just be about enter a name.

After you save a project using Save As, the controller changes from connected to disconnected.
When you configure an Event Input Interrupt (EII), you can specify which input to use from the **Configure Event Input Interrupt (EII)** dialog box. You cannot, however, specify the edge triggering type (rising or falling edge) from the same dialog box. [APBC00005579]

**Workaround:** To specify the EII edge triggering type (rising or falling edge), click **Embedded I/O** in the controller tree and configure the Properties in **Input Latch and EII Edge**.

You cannot view or configure parameters for Micro810 LCD modules within Connected Components Workbench. [APBC00005458]

**Workaround:** To configure LCD module setup parameters:

1. Download the program to the controller.
2. Configure the setup parameters using the LCD module.
3. Upload the program to Connected Components Workbench.
4. Save the program.

While in PanelView, if you create decimal values while the regional setting is set to English, and then change the setting to Spanish, the PanelView Component incorrectly displays integer values. [APBC00005484] [APBC00005485]

**Workaround:** Change the regional settings before making any application changes.

If your project contains configured HSC interrupts, and you change the controller type to one that does not support HSC interrupts, the following message, which is not accurate, appears in the Controller Change output.

**Warning:** Target controller supports a smaller number of HSC interrupts. Deleting HSC0.”

Instead, the message should read:

"Information: HSC interrupt type is not supported and its configuration is discarded."[APBC00017248]

In the **Variable Editor**, when viewing a user-defined function block that contains multiple nested functions or function blocks, the nested variables may not align correctly within the **Logical Value** column. If you hide the Logical Value column and then show the column, it is moved to the rightmost position in the **Variable Editor** and the values for the nested variables may not show in the column. [APBC00014339]

If you use single quotes in a variable within an array element even when the data type is String, the build may fail. [APBC00011206]

**Workaround:** Do not use single quotes in array element variables.

If you create a string array using the **Global Variables** grid, the maximum length is 252 characters. If you create a string array using the **Data Types** grid, the maximum length is 255 characters. [APBC00010227]

**Workaround:** Make all string arrays 252 characters or less.
The SAFEBOOL data type appears as an option in the Arrays grid, but SAFEBOOL is not supported by Micro800 controllers. [APBC00010414]

**Workaround:** Do not select SAFEBOOL as a data type.

The maximum number of words for the MSG_MODBUS ElementCnt parameter is 123 even though the LocalAddr specifies 125 words. If you use a value of 124 or 125 for the ElementCnt you will receive an error indicating a bad MSG file parameter exists. [APBC00003889]

**Workaround:** Verify the ElementCnt variable uses a value of 123 words or less.

Data types and variables

If you attempt to copy and paste a variable that uses an initial value from one open session of Connected Components Workbench to another open session, you may receive an error message similar to one of the following, and the paste operation will not be successful.

- “Warning: The variable you are pasting having the data type ‘aa’ is non-existent in the current project. Therefore, the variable shall be created as an undefined type.
- The importation of the symbol Controller.Micro850.Micro850.Prog1.v1 was unable to set the field TextInitialValue(1.65) -> Exception Message: The value does not match the format of the data type.”

When you copy and paste from one project to another project, CCW may not copy all the properties of the object. If the new project does not have all the property objects defined, such as a data type, errors may occur.

**Workaround:** Copy all data type definitions to the project before you copy the variable. [APBC00018350]

If you monitor a variable with an array data type, the variable may display WAIT for its value.

**Workaround:** Use the variable view to monitor the values for the array [APBC00018556].

In this release, some of the vendor specific instruction blocks and other program elements have not been identified as reserved words. When you name a variable, CCW may allow you to name a variable the same as an instruction block even though it should not be allowed. When you attempt to build a program with duplicate names, the error message will identify the instruction name as the problem rather than the user variable. [APBC00017881].

If you name a variable the same as an existing program name, you will receive an error when you attempt to build the project. You can disregard the error message as a program and a variable can use the same name since they are different object types. Duplicate names in this situation will not prevent the project from building. [APBC00018410].

If you attempt to set the **logical value** for a sub-element of a data type that contains a nested array/structure, you may need to click more than once to enable the selection. [APBC00017133]
After the Key Read function block is triggered, its output will not reset even after the rung goes false. Normally, the output will not be wired to an input, but you can check the Status bit, which works correctly, to verify the output results. [APBC00019913]

In some instances, the Enter password dialog box may appear when you are working on a UDFB even though you did not modify the program. For example, it may appear when you select EN/ENO in a UDFB. [APBC00018411]

If you import a UDFB into a password-protected program that already contains an instance of the same UDFB, you will not be prompted to enter the program password even though the UDFB instance in the program will be replaced by the newly imported UDFB instance. [APBC00018245]

If you create a Ladder Diagram and add an instance of a COP instruction block with string type input variables assigned to the Scr and Dest parameters, the yellow warning images may not disappear as expected after you build the program. [APBC00015311]

**Workaround:** Save, close, and then re-open the project to refresh the display.

If you rename a user-defined function block instance that is referenced in a program and then build the controller project, the following error message appears:

“A function, function block, or operator is not defined“.

UDFB instances must have the same definition to successfully build the controller project. [APBC00016939]

**Workaround:** Open the program and reselect the UDFB.

After building a program that uses an ANY_TO_WORD, ANY_TO_DWORD, or ANY_TO_LWORD operator that does not have the correct data type defined for the output variable, you might receive the following error message:

“Expecting a UINT type variable,” even though the output parameters all use a WORD data type. [APBC00007106]

**Note:** The error message should state that a WORD type variable is expected.

After completing a successful build, a yellow warning icon may appear on the instruction block. [APBC00007405]

**Workaround:** The warning does not impact program execution. It is a warning to identify potential problems due to lack of variables being passed to input parameters.

In a Function Block Diagram program, if you connect the output of an ANY_TO_WORD operator to the input of a UDFB, the compiler will display a false positive error that the data types do not match. [APBC00005062]

**Workaround:** Use an intermediary variable to transfer a value between the instructions.
If you use a Remote Desktop Connection to access a CCW program, the font for some of the comments in the program may change and be difficult to read. [APBC00017812]

**Workaround:** Double-click the comment to restore the original font.

When the Recipe function block continuously writes recipe data files to the Recipe sub-folder, the number of files created may exceed the maximum allowed limit of 50 files.

**Workaround:** See the Micro820 controller user manual for more information about maximum limits. The manual is available from Help > User Manuals > Controllers > Micro820. [APBC00017884]

If you enter more than the maximum allowed number of characters in the comment area for a Ladder Diagram program, and then save or build the project, the extra characters will not be removed, and a yellow warning icon will continue to display in the language editor. [APBC00011542]

**Workaround:** Close and reopen the Ladder Diagram view to refresh the display.

If you use the AWT command to send characters when the RX (receive) buffer is empty, the characters will not be sent. [APBC00017012]
**Import and export**

If you import a UDFB while an instance variable structure is being viewed, the instruction values may not refresh properly within the language editor. [APBC00018349]

**Workaround:** Close and reopen the FB editor.

In the Import and Export Setting Wizard, if you reset all settings and select the option, **No, just reset settings, overwriting my current settings**, some items may not appear in the **File** and **Help** menus as expected. [APBC00015185]

**Workaround:** If this happens follow these steps:

1. **Save** your project.
2. **Close**, and reopen Connected Components Workbench to display all the menu items.

If, while importing variables into a password-protected POU, you click **Cancel** in the **Enter Password** dialog box, the import will be canceled, which is expected behavior. However, you still may receive an **Import was successful** message in the output window, which is incorrect. [APBC00016089]

If you try to Import a Micro800 program that contains a password and the program is not compatible with the version of Connect Components Workbench that you are using, the **Password required** dialog box appears. After you enter the password, the **Unable to start importing** dialog appears. [APBC00014022]

If you import a POU that contains an instruction that is not supported in the target Micro800 project, you will receive an error when you build the project, which is expected behavior. However, if you double-click the error item, it will not navigate to the error location in the project. [APBC00014443]

If you import a UDFB program into a project that contains a user-defined data structure or array with the same name as the UDFB, the project build will fail, which is expected behavior. However, the error message may indicate a FB symbol duplication error, which is incorrect. [APBC00015612]

**Build, debug, download and upload**

If you attempt to download a PVc application from a terminal that does not have firmware version 1.80 or later installed, the download may fail. [APBC00018812]

**Workaround:** Verify that any terminal from which you will download a PVc application has firmware version 1.80 or later installed.
**Build, debug, download and upload**

If you enter Debug mode after running Connected Components Workbench for an extended period of time, a red X may appear in the language editor, and you may receive the following error message:

"CCW.shell has encountered a problem. We apologize for the inconvenience. Please tell ISaGRAF about this problem" [APBC00018407]

**Workaround:** If this occurs, close the language editor, verify you are in Debug mode, and then reopen the language editor.

**Note:** Any message that identifies ISaGRAF as a contact should actually identify Rockwell Automation as the contact. See the Support information topic in this document for contact information.

You may experience the following intermittent issues related to removing the SD memory card while it is being accessed by the Micro800 controller:

- If you remove the SD memory card while uploading or deleting a data log, the **Refresh** link may become unavailable.
- If you remove the SD card while searching a data log, and then click the **Refresh** link, the link may disappear, and then still not appear after you insert the SD memory card.
- If you remove the SD memory card while deleting a recipe, the Search result may return a negative value.
- If you remove the SD memory card while downloading a recipe, buttons and items on the **Download** window may be disabled for 60 seconds or longer. [APBC00018115]

If your program calls nested UDFBs, build results may take a long time to appear in the output window, or not show at all when you build the program if you do the following:

- Expand the view of a UDFB instance variable.
- Delete the last UDFB at the bottom of the nested call sequence.
- Expand the instance again in the program. [APBC00018116]

If you open a project created in a CCW R2.0 or CCW R4.0, then set the initial value of a UDFB and perform a Refactor operation, you may receive an error indicating the initial value has an incorrect format, similar to the following, when you build the project.

The initial value: TRUE of _FB_INIT_CONST_0000003 -> MODBUSLOCADDR -> UINT[2] has an incorrect format. [APBC00017736]

**Workaround:** Open the UDFB, double click the instruction, reselect the instruction in the UDFB, and then set the initial value and perform a Refactor operation.
Build, debug, download and upload

If you attempt to build a project that has an invalid Motion Engine Execution Time, you will receive a build error, which is expected behavior. If you then delete the Motion Axis without first correcting the Engine Execution Time and build the project again, the build will still fail.

**Note:** When you enter an invalid value, the field is outlined in red indicating an error. [APBC00011576]

**Workaround:** Follow these steps to resolve the error:

1. Add an Axis, and enter a valid Motion Engine Execution Time.
2. Save the project.
3. Delete the Axis and then save the project again.
4. Re-build the project.

If you build and download a project that contains invalid configuration information, you might continue to receive error messages when you build and download the project even, after entering valid configuration information. [APBC00009321]

**Workaround:** Follow these steps to resolve the error:

1. Close Connected Components Workbench and then restart it.
2. Update the configuration information, and save the project.
3. Rebuild and download your project again.
Repairing Visual Studio Service Pack 1

If Connected Components Workbench is installed on a computer on which Visual Studio 2010 Service Pack 1 was previously installed, you may receive an error message when you start Connected Components Workbench. If this occurs, follow these steps:

1. Close all Visual Studio products.
3. If the Setup starts in Maintenance mode, select Repair.

Maximum number of parameters for a UDFB

If the project contains a UDFB with too many total parameters, you might receive a build error even though the total number of input and output parameters seems within range. This can happen because the UDFB local variables are included in the total. Limit the total number of parameters for each UDFB to a total of 128.

Modifying existing UDFBs

Connected Components Workbench does not automatically update the instances of the modified UDFBs referenced in existing programs. To update every instance of the UDFB, search for it and update each one manually.

MOV instruction and Assignment operator

The MOV instruction displays in the Block Selector when it is launched from a LD POU or a FBD POU, but it does not display in a ST POU. ST programs use the “=” assignment operator instead of the MOV function [APBC00014308]

Connecting to a Micro800 controller on a virtual machine

If you install RSLinx Classic on a virtual machine (for example, VMWare), make sure to disable RSLinx Classic on the host computer before you plug the USB cable that is attached to your Micro800 controller into the host computer. If you ignore this step, the host computer will
obtain the driver for the Micro800 controller, and the virtual machine may not be able to detect the Micro800 controller.

**Connecting to a Micro800 controller using the Ethernet connection**

If you use the Ethernet instead of a USB to connect to the controller, you may need to add the Ethernet driver. Unless you are using DHCP or assigning static IP addresses, your computer and the Micro800 controller will default to IP addresses that will allow them to communicate.

**To add an Ethernet driver and connect to a controller**

Follow these steps to add the Ethernet/IP driver so the RSLinx can detect the controller.

1. Click **Communications > Configure** to open the **Configure Drivers** dialog box.
2. In **Available Driver Types**, select **Ethernet/IP Driver**.
3. Click **Add New**, and type a name for the driver or accept the default name.
4. If prompted, enter the Ethernet/IP adapter selection. **Note**: If connecting using CAT5-style cabling, be sure to select the correct port (it may not be the Windows default).
5. Click **Connect** to open the **Connection Browser**.
6. Expand the Ethernet driver you previously added.
7. Select the controller that you want to connect to from your project.
8. Click **OK**.

**Accessing projects remotely**

If you create or open projects on a remote mapped drive, or on a network PC Sharename, you may receive any of the following Catalog errors unless you configure remote access for the computer:

- IDF Catalog Error
- Failed to find or create a project for the device
- The catalog failed to match the selection to a provider

**To access CCW projects on a network PC Sharename**

If you are using a network PC Share name, establish a Full Trust relationship with the PC and the shared location. For detailed information, see Microsoft KB article: [http://support.microsoft.com/kb/320268/](http://support.microsoft.com/kb/320268/)

**To establish a trust relationship (excerpt from the KB article)**

Use the following command shell (Start Menu/Run cmd) command to establish the needed trust relationship:

```
drive_letter:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\caspol.exe -m -ag 1 -url "file:///\network_pc_name\share_name\*" FullTrust -exclusive on
```

**For example:**

```
C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\caspol.exe -m -ag 1 -url "file:///\devlabpc\CCWInstall\*" FullTrust -exclusive on
```
Connected Components Workbench sample projects

This release includes several Micro800 controller sample projects that are installed with Connected Components Workbench in one of the following folders.

\Users\current user\Documents\CCW\Sample Projects

VMware compatibility

Compatibility with VMware® has not been formally tested, but it has been used extensively with Connected Components Workbench.

- If you experience poor performance using VMware with a Window 7 guest, you may need to upgrade VMware or run Connected Components Workbench on the host operating system. Connected Components Workbench and other software may try to access the networks, to ensure optimal system performance, you may need to disable network adapters.
- If you use Connected Components Workbench with VMware, you may have to manually connect USB devices. When a virtual machine is running, its window is the active window and a USB device is plugged into the host computer, the device automatically connects to the guest instead of the host. This autoconnect feature can be disabled in the USB Controller panel of the virtual machine settings editor (VM > Settings). If all of the virtual machine's USB ports are already occupied when it is trying to connect automatically to a new device, a dialog box gives you a choice: you can either disconnect one of the existing USB devices to free its port or ignore the new device, allowing the device to connect to the host.

Manually connecting a virtual machine to a USB device

- Choose VM > Removable Devices to connect specific USB devices to your virtual machine. If the physical USB devices are connected to the host computer through a hub, the virtual machine sees only the USB devices, not the hub.
- There is a menu item for each of the USB ports. Move the mouse over one of these items to see a cascading menu of devices that are plugged into your host computer and available for use. To connect a device to the virtual machine, click its name.
- If a device is already connected to that port, click the name of a new device to release the first device and connect the new one.
- To release a connected device, click None on the cascading menu for the port to which it is connected.
- If you physically plug a new device into the host computer and the autoconnect feature does not connect it to a virtual machine, the device is initially connected to the host. Its name is also added to the VM > Removable Devices menu so you can connect it to the virtual machine manually.