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Chapter 1 

Overview 

In this document you will find information on how to upgrade your 
FactoryTalk Historian SE 2.1/2.2 to FactoryTalk Historian SE 3.01. 

FactoryTalk Historian SE (FTHSE) 2.1/2.2 is a 32-bit application 
that could run on either a 32-bit or 64-bit server operating system. 
FactoryTalk Historian SE 3.01 is a 64-bit application that runs only 
on a 64-bit server operating system, specifically Microsoft Windows 
Server 2008 R2 with Service Pack 1 (W2008R2SP1). 

Upgrading from a 32-bit application to a 64-bit application and 
upgrading from a previous version to the new version of FactoryTalk 
Historian SE involves multiple steps. Due to the complexity of the 
process and the fact that it may require setting up a computer with 
W2008R2SP1, we refer to the process as the Historian server 
migration. 

IMPORTANT The add-ons to the Historian server listed below constitute in 
FactoryTalk Historian SE 3.01 a collection of Advanced Server 
components: 
ACE, JDBC Data Provider, ODBC, OLE DB Provider, OPC DA Server, OPC 
HDA Server, OPC HDA DA Server, WebServices, Notifications. 
If you have been using any of them with your Historian server and you 
still want to use them in FactoryTalk Historian SE 3.01, see "Advanced 
Server Components (page 8)" for more information. 

The migration may be performed from the following versions of 
FactoryTalk Historian SE: 

• FTHSE 2.1 with PI Server version 3.4.375 32-bit. 

• FTHSE 2.2 with PI Server version 3.4.375 32-bit. 
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On a high level, the Historian server migration involves: 

1. Backing up FTHSE 2.1/2.2 configuration and archive files. 

2. Removing FTHSE 2.1/2.2 and all Historian components. 

3. Installing an intermediate release of Historian (PI Server 
version 3.4.375 64-bit) to convert the application files so that 
they become 64-bit compatible. 

4. Upgrading from the intermediate Historian release to FTHSE 
3.01 (PI Server version 3.4.385 64-bit). 

The migration may be performed for a single Historian server (page 
21) as well as for a collective of Historian servers (page 73). 

FactoryTalk Historian SE 3.01 introduces the following features: 

• FactoryTalk Historian Asset Framework (AF) Server as a 
prerequisite and Microsoft SQL Server Database for its data. 

• The security authentication that replaces FactoryTalk Security 
with Windows authentication, using either Active Directory 
(AD) or local Windows security. 

• Advanced Server logic (page 8). 
 

Advanced Server is a collection of add-on components to 
FactoryTalk Historian SE Server. The Advanced Server includes: 

• ACE Advanced Computation Engine for Visual Basic 
calculations on Historian data 

• Data Access 

• JDBC Data Provider 

• ODBC 

• OLE DB Provider 

• OPC DA Server 

New Features in 
FactoryTalk Historian SE 
3.01 

Advanced Server 
Components 
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• OPC HDA Server 

• OPC HDA DA Server 

• WebServices 

• Notifications for using Microsoft Lync Unified 
Communication Server 

New users may activate the Advanced Server components with the 
FTHSE.Advanced license activation. 

For the users upgrading their license activations from FactoryTalk 
Historian SE 2.2/2.1, the Advanced Server components are 
activated automatically when the total license count of the FHLD 
and PTY3 license activations is at least 250. 

NOTE For more information on the Advanced Server components, refer to the 
user documentation available in the Redist\Docs\Advanced Server 
Options folder on the FactoryTalk Historian SE installation DVD. 
To acquire a license for this option, contact your Rockwell Automation 
sales representative. 

 
 

The following migration paths (Use Cases) are supported: 

• In Use Case 1, the FTHSE server is migrated from its current 
host computer to a new computer running a 64-bit Microsoft 
Windows Server 2008 R2 with Service Pack 1 
(W2008R2SP1). 

The process involves moving the Historian server to another 
machine and updating it to version 3.01. It may also involve a 
transition from a 32-bit to 64-bit operating system. 

From: To: 
W 2003 R2 32-bit W 2008 R2 SP1 64-bit 
W 2008 SP2 32-bit 
W 2008 R2 64-bit 

Migration Use Cases 
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• In Use Case 2, the FTHSE server is already installed on a 
computer running a 64-bit Microsoft Windows Server 2008 
R2 (W2008R2). 

The process involves installing Service Pack 1 on the server 
host computer and updating the Historian server to version 
3.01. 

From: To: 
W 2008 R2 64-bit W 2008 R2 SP1 64-bit 

 

 

Before starting the migration process, make sure the following 
prerequisites are met: 

• Your FactoryTalk Historian SE system is healthy, that is : 

• All FactoryTalk Historian interfaces are functioning 
properly (page 12). 

• There are no stale and bad points in the system (page 12). 

• Using the System Management Tools, you have deleted all 
unnecessary archives and message logs from the Historian 
server. 

For more information, refer to the FactoryTalk Historian SE 
2.20 Server Management Guide. 

• You have created a backup of your system (page 13). 

• Service Pack 1 for the Microsoft Windows Server 2008 R2 is 
installed on the computer that will host the FTHSE server. 

• IT personnel is available to perform administrative tasks, such 
as: 

• Adding/removing computers from the domain. 

• Adding security groups/users to the domain. 

Migration Prerequisites 
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• Renaming computers. 

• Managing SQL Server databases. 

• You have a portable storage device, such as a USB drive or an 
external hard drive, or a shared folder in your network, to 
which you will save a complete backup of the existing 
Historian and a copy of the Historian installation DVD. 

You will need to have write access to the storage device and/or 
the shared folder on every computer on which you will 
perform the migration. 

You will need at least 8 GB of storage space, of which 4 GB 
will be taken by the copy of the installation DVD, and the rest 
by the archives. 

Check the size of your archives to calculate the total amount of 
storage space you need. 

• The computers on which you will install FactoryTalk 
Historian SE 3.01 are configured to handle short file names. 

NOTE For more information, refer to the Microsoft TechNet 
(http://technet.microsoft.com/en-us/library/cc778996(v=ws.10).a
spx) article. 

• You have the FactoryTalk Historian SE 3.01 installation 
DVD. 

• You have copied the entire content of the FactoryTalk 
Historian SE 3.01 installation DVD to your portable storage 
device or shared folder. 

• You have checked the KB article 491889 
(https://rockwellautomation.custhelp.com/app/answers/
detail/a_id/491889) for the latest version of this document 
and the migration scripts.  

• You have printed a copy of this document and read it before 
you start the migration. 

 

http://technet.microsoft.com/en-us/library/cc778996(v=ws.10).aspx
http://technet.microsoft.com/en-us/library/cc778996(v=ws.10).aspx
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/491889
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/491889
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To verify that the FactoryTalk Historian interfaces are updating 
data: 

1. On the computer with your Historian server installed, go to 
Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under Collectives and Servers, select the Historian server 
whose data you want to check. 

3. Under System Management Plug-Ins, select Data > Archive 
Editor. 

4. In the (Tag Not Specified) tab, click . The Tag Search 
dialog box appears. 

5. In the Tag Mask text box, type the name of the tag from the 
interface whose performance you want to check, and click 
Search. 

The tag appears in the search results list. 

6. Click OK. 

If the interface functions properly, the list of events of the 
selected tag is displayed in the tab in the right pane of the 
System Management Tools dialog box. 

NOTE For more information on the Archive Editor available with the 
System Management Tools, click . 

7. Repeat the steps for all other interfaces that collect data. 
 

To verify that there are no stale and bad points in your Historian 
system: 

1. On the computer with your Historian server installed, go to 
Start > All Programs > Rockwell Software > FactoryTalk 

Verify That All Historian 
Interfaces are Functioning 
Properly 

Verify That There Are No 
Stale and Bad Points in Your 
Historian 
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Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under Collectives and Servers, select the Historian server 
whose data you want to check. 

3. Under System Management Plug-Ins, select Points > Stale 
and Bad Points. 

4. On the toolbar, click . 

If your Historian system is free from stale and bad points, a 
confirmation message is displayed under Session Record. 

 
If any bad or stale points have been detected in your Historian 
system, you need to decide whether you want to perform the 
migration. 

To create a backup of your Historian system: 

1. Open the Command Prompt window. 

2. Navigate to: 

• On a 32-bit operating system: 
C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\PI\adm 

• On a 64-bit operating system: 
C:\Program Files (x86)\Rockwell Software\FactoryTalk 
Historian\Server\PI\adm 

3. Run the pibackup command with the following syntax: 

pibackup <CompletePathToTheBackupFolder> 
<NumberOfArchivesToBackUp> 

For example: pibackup c:\backup 3. 

Press Enter. 

Create a Backup of Your 
Historian 
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4. Wait until the backup is complete. 

5. Copy the backup to your portable storage device or shared 
folder in your network. 

 

If you want to perform the migration and minimize the loss of the 
data collected by your interfaces, you can do either of the following: 

• Configure buffering for the interfaces. See "Configure 
Buffering for Interfaces (page 14)" for details. 

• Configure redundant interfaces. See the KB article 59932 
(https://rockwellautomation.custhelp.com/app/answers/detai
l/a_id/59932) for details. 

By configuring redundant interfaces you will eliminate any loss 
of data during the migration. 

If you choose to use redundant interfaces during the 
migration, you will need to migrate the interfaces after you 
have migrated the Historian server. See "Checklist: Migration 
of Live Data Redundant Interfaces (page 83)" for details. 

 

 

Before you configure and use buffering on your interfaces during the 
migration, you need to make sure that you have sufficient disk space 
available on the computers on which you have the interfaces 
installed. 

If we assume the following: 

• A single event takes 26 bytes in the buffer. 

• An interface collects 10000 points per second. 

Minimizing Data Loss 
during Migration 

Configure Buffering for 
Interfaces 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/59932
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/59932
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We can use the following equation to calculate the required disk 
space for 8 hours: 

10000 * 26 bytes * 60 seconds * 60 minutes * 8 hours = 7.4 GB 

The resulting disk space is required for a single Historian server. If 
you have a collective of Historian servers, this amount of disk space 
will be consumed by each Historian server in the collective. 

To configure buffering on the interface: 

1. Go to Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > Interface Configuration Utility. The Interface 
Configuration Utility dialog box appears. 

2. From the menu bar, select Interface > SDK Connections. 
The Connection Manager dialog box appears. 

3. Select the existing collective or server, or add a new one. 

TIP See the Connection Manager Help for more information. To 
access it, select Help > Contents and Index from the menu 
bar of the dialog box. 

4. Click Save and Close to exit the dialog box. 

5. From the menu bar, select Tools > Options. The Options 
dialog box appears. 

6. Click the Load interfaces from a selected list of PI Servers 
option and click the check box next to the name of the server 
that you want to select. 

7. Click OK. 

8. From the menu bar, select Tools > Buffering. The Buffering 
dialog box appears. 

9. Click Enable buffering with PI Buffer Subsystem. 
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10. In the message box, click Yes. 

 
11. Wait until the status at the bottom of the dialog box is 

changed to Current Configuration: Good. 

12. In the message dialog box, click OK. 

 
13. From the left pane, click Buffered Servers, and select the 

name of the FactoryTalk Historian SE server from the 
Buffering to collective/servers list. 

14. Click OK to save the changes. 

15. In the message box, click Yes. 
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16. In the Interface Configuration Utility dialog box, click 
Close. 

17. Repeat the steps for each interface computer including 
redundant interfaces. 

 

The migration process is based on the following assumptions: 

• The migration must be performed by an administrator. 

• During the migration, the communication with the Historian 
server is blocked, either by disconnecting the computer from 
the network or using a firewall to block the 5450 TCP port. 

• If the FactoryTalk Activation server is installed on the FTHSE 
server computer and a new computer will be used for 
FactoryTalk Historian SE 3.01, the activations will need to be 
rehosted to the new computer. 

IMPORTANT It is recommended that you follow all the steps in the order and 
as they are described in the instructions so as to ensure a 
successful completion of the migration process. 

• If the FactoryTalk Directory is installed on the FTHSE server 
computer and a new computer will be used for FactoryTalk 
Historian SE 3.01, the FactoryTalk Directory will need to be 
backed up and restored to the new computer. 

• If the FactoryTalk Directory is being shared with other 
Rockwell Software products, you will need to determine if 
those products need to be upgraded as well. 

• If the FactoryTalk Directory is not installed on the Historian 
server computer, you need to update FactoryTalk Services 
Platform and FactoryTalk Activation Manager on the 
computer on which the FactoryTalk Directory is installed. 

Migration Assumptions 
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The migration may be partially automated using the migration 
scripts (.BAT files) included on the FactoryTalk Historian 
installation DVD, in the Redist\Migration\Scripts folder. 

Use this script: To: 
0_Locations.bat (page 29) Configure: 

1. The location in which the .BAT files are stored. 
2. The path to the location in which FactoryTalk Historian 

SE 2.1/2.2 is installed. 
3. The letter of the drive on which the backup is to be 

stored. 
4. The path to the location in which the backup is to be 

stored. 
5. The location of the Historian archives, if the archives are 

stored in another location than <DriveLetter>:\Program 
Files\Rockwell Software\FactoryTalk 
Historian\Server\dat. 

6. The letter of the drive on which FactoryTalk Historian SE 
3.01 is to be installed. 

Set environment variables necessary for the migration 
process. 

1_PreMigrationBackup.bat 
(page 32) 

1. Create the directory structure for the backup. 
2. Create the archive log file. 
3. Stop the Historian server. 
4. Stop the FTLDIntAgent service. 
5. Disable the PI Network Manager service. 
6. Back up the FactoryTalk Historian SE 2.1/2.2 server. 

2_TargetFolderStruct.bat 
(page 40) 

For the migration on a single computer: 
1. Rename the folder of FactoryTalk Historian SE 2.1/2.2. 
2. Rename the PIPC.ini file. 

For all migration scenarios: 
3. Create the folder structure for the FactoryTalk Historian 

SE 3.01. 

3_RestorePIPart.bat (page 
44) 

1. Restore the server from the backup. 
2. Rename the pirunonce.dif file. 

4_StartAndConfigPIX64.bat 
(page 45) 

1. Start the intermediate PI server. 
2. Modify tuning parameters applying to the location of 

the archives. 

5_RestoreRAPart.bat (page 
53) 

1. Restore the Historian server .XML files. 
2. Start the FactoryTalk Historian SE 3.01 services. 
3. Update database security settings. 

Migration Scripts 
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Use this script: To: 
6_EnvVarsCleaning.bat 
(page 71) 

1. Remove the environment variables used by the 
migration scripts from the operating system. 
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Chapter 2 

Migrating a Single Historian Server 

The migration may be performed: 

• On a single computer. (page 21) 

• From one computer (source) to another (target). (page 23) 
 

IMPORTANT To perform this procedure, administrative rights are required. 
To execute .BAT files with administrative privileges on the Microsoft 
Windows Server 2008 R2 operating system, you need to right-click the 
file and select Run as administrator. Otherwise the file execution will 
fail. 

To perform migration on a single computer: 

• Check the KB article 491889 
(https://rockwellautomation.custhelp.com/app/answers/detai
l/a_id/491889) for the latest version of the FactoryTalk 
Historian SE Upgrade and Migration Guide and the migration 
scripts.  

1. Stop local interfaces (page 26). 

2. Block the FactoryTalk Historian server from communicating 
with the interfaces and clients (page 28). 

3. Confirm the event queue is empty (page 28). 

4. Copy the migration scripts to the computer (page 28). 

5. Edit and execute the 0_Locations.bat file (page 29). 

6. Shift the Historian archives (page 30). 

7. Prepare the registration .BAT file (page 31). 

8. Execute the 1_PreMigrationBackup.bat file (page 32). 

Checklist: Migration on a 
Single Computer 

Pre-migration steps 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/491889
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/491889
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9. Remove FactoryTalk Historian SE 2.1/2.2 from the computer 
(page 37). 

10. Install FactoryTalk Services Platform (page 39). 

11. Install RSLinx Enterprise (page 39) (Optional). 

12. Execute the 2_TargetFolderStruct.bat file (page 40). 

13. Install the intermediate PI Server FTHSE 22 x64 (page 41). 

14. Execute the 3_RestorePIPart.bat file (page 44). 

15. Execute the 4_StartAndConfigPIX64.bat file (page 45). 

16. Register the archives (page 47). 

17. Remove old references to the archives (page 48). 

18. Stop the intermediate server (page 49). 

19. Install FactoryTalk Historian Asset Framework (page 49). 

20. Install FactoryTalk Historian Management Tools (page 50). 

21. Start the intermediate server (page 50). 

22. Prepare MDB to AF synchronization (page 51). 

23. Stop the intermediate server (page 49). 

24. Upgrade the Historian server to version 3.01 (page 51). 

25. Check if the communication with the FactoryTalk Historian 
server is blocked (page 53). 

26. Perform either of the following: 

For the collective secondary 
server upgrade: 

For all other use cases and 
computers: 

Restore and Rename Files (page 54). Execute the 5_RestoreRAPart.bat file 
(page 53). Merge Customized .BAT Files (page 54). 

27. Complete and verify the MDB to AF synchronization (page 
55). 

28. Migrate local FTLD interfaces (if applicable) (page 57). 

Migration steps 

Post-migration steps 
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29. Verify that Historian services are running (page 58). 

30. Verify that the Historian server is updating data for default 
tags (page 59). 

31. Create a transitory security configuration for the Historian 
environment (page 60). 

32. Disable virus scanning (page 62). 

33. Restore the FactoryTalk Historian server communication with 
the interfaces and clients (page 62). 

34. Migrate FactoryTalk Services Platform users to the integrated 
Windows authentication (page 64). 

35. Execute the 6_EnvVarsCleaning.bat file (page 71). 

36. Create a backup of your migrated FactoryTalk Historian (page 
71). 

 

IMPORTANT To perform this procedure, administrative rights are required. 
To execute .BAT files with administrative privileges on the Microsoft 
Windows Server 2008 R2 operating system, you need to right-click the 
file and select Run as administrator. Otherwise the file execution will 
fail. 

Perform the following steps on the source computer: 

1. Check the KB article 491889 
(https://rockwellautomation.custhelp.com/app/answers/detai
l/a_id/491889) for the latest version of the FactoryTalk 
Historian SE Upgrade and Migration Guide and the migration 
scripts.  

2. Back up FactoryTalk Directory and FactoryTalk Diagnostics 
Viewer (page 26). 

3. Stop local interfaces (page 26). 

4. Block the FactoryTalk Historian server from communicating 
with the interfaces and clients (page 28). 

5. Confirm the event queue is empty (page 28). 

Checklist: Migration from a 
Source to Target Computer 

Pre-migration steps 

https://rockwellautomation.custhelp.com/app/answers/detail/a_id/491889
https://rockwellautomation.custhelp.com/app/answers/detail/a_id/491889
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6. Copy the migration scripts to the computer (page 28). 

7. Edit and execute the 0_Locations.bat file (page 29). 

8. Shift the Historian archives (page 30). 

9. Prepare the registration .BAT file (page 31). 

10. Execute the 1_PreMigrationBackup.bat file (page 32). 

11. Rename the source computer. (page 37) 

Perform the following steps on the target computer: 

1. Rename the target computer (page 37). 

2. Copy the migration scripts to the computer (page 28). 

3. Edit and execute the 0_Locations.bat file (page 29). 

4. Install FactoryTalk Services Platform (page 39). 

5. Install RSLinx Enterprise (page 39) (Optional). 

6. Configure FactoryTalk Directory and FactoryTalk Activation 
Manager (page 40). 

7. Execute the 2_TargetFolderStruct.bat file (page 40). 

8. Block the FactoryTalk Historian server from communicating 
with the interfaces and clients (page 28). 

9. Install the intermediate PI Server FTHSE 22 x64 (page 41). 

10. Execute the 3_RestorePIPart.bat file (page 44). 

11. Execute the 4_StartAndConfigPIX64.bat file (page 45). 

12. Register the archives (page 47). 

13. Remove old references to the archives (page 48). 

14. Stop the intermediate server (page 49). 

15. Install FactoryTalk Historian Asset Framework (page 49). 

16. Install FactoryTalk Historian Management Tools (page 50). 

17. Start the intermediate server (page 50). 

Pre-migration steps 

Migration steps 
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18. Prepare MDB to AF synchronization (page 51). 

19. Stop the intermediate server (page 49). 

20. Upgrade the Historian server to version 3.01 (page 51). 

21. Check if the communication with the FactoryTalk Historian 
server is blocked (page 53). 

22. Perform either of the following: 

For the collective secondary 
server upgrade: 

For all other use cases and 
computers: 

Restore and Rename Files (page 54). Execute the 5_RestoreRAPart.bat file 
(page 53). Merge Customized .BAT Files (page 54). 

23. Complete and verify the MDB to AF synchronization (page 
55). 

24. Migrate local FTLD interfaces (page 57) (if applicable). 

25. Verify that Historian services are running (page 58). 

26. Verify that the Historian server is updating data for default 
tags (page 59). 

27. Create a transitory security configuration for the Historian 
environment (page 60). 

28. Disable virus scanning (page 62). 

29. Restore the FactoryTalk Historian server communication with 
the interfaces and clients (page 62). 

30. Reconfigure FactoryTalk Historian ME data transfer settings 
(page 62) (if applicable). 

31. Migrate FactoryTalk Services Platform users to the integrated 
Windows authentication (page 64). 

32. Execute the 6_EnvVarsCleaning.bat file (page 71). 

33. Create a backup of your migrated FactoryTalk Historian (page 
71). 

Post-migration steps 
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The migration of a single Historian server consists of the following 
stages: 

1. Pre-migration steps (page 26). 

2. Migration steps (page 37). 

3. Post-migration steps (page 55). 
 

In the following sections you will find detailed instructions of 
pre-migration steps. 

 

Perform the following steps if you migrate the server from a 
source to target computer: 

1. If FactoryTalk Directory is located on the source computer, 
back up the entire FactoryTalk Directory. 

NOTE For more information, refer to section "Back up an entire 
FactoryTalk Directory" of FactoryTalk Help (go to Start > All 
Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk 
Help). 

2. Export and back up messages from the FactoryTalk 
Diagnostics Viewer. 

NOTE For more information, refer to section "Export diagnostic messages 
to XML" of FactoryTalk Diagnostics Viewer Help (go to Start > All 
Programs > Rockwell Software > FactoryTalk Tools > Diagnostic 
Viewer to open the viewer, and on the menu bar click Help > 
FactoryTalk Diagnostics Viewer Help). 

 

You should stop all the local interfaces for collecting data. Typical 
local interfaces are: 

• FTLD 

• OPC 

• PI Batch Generator 

Migration Steps: Single 
Historian Server 

Pre-migration Steps 

Source to Target: Back up 
FactoryTalk Directory and 
FactoryTalk Diagnostics 
Viewer 

Stop Local Interfaces 
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• PI Ramp Soak Simulator 

• PI Random Simulator 

• PI-piperfmon_basic 

The interfaces may be stopped using System Management Tools in 
FactoryTalk Historian and/or Administrative Tools in Control 
Panel. Depending on the method you have used to register them, 
you may need to use both tools to stop all the interfaces. 

To stop the interfaces using the System Management Tools: 

1. Click Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under Collectives and Servers, select the server for which you 
want to stop the interfaces. 

3. Under System Management Plug-Ins, select Interfaces > 
Interface List. 

4. Click the name of the interface and click  on the toolbar to 
stop it. 

5. Repeat the steps for other interfaces in the interface list. 

6. Under System Management Plug-Ins, select Operation > PI 
Services. 

7. Click the name of the interface and click  on the toolbar to 
stop it. 

8. Repeat the steps for other interfaces in the interface list. 

To stop the interfaces using the Administrative Tools program 
of Control Panel: 

1. Click Start > All Programs > Administrative Tools > Services. 
The Services dialog box appears. 

2. Right-click the name of the interface, and select Stop. 
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3. Wait until the status of the service changes to Stopped. 

4. Repeat the steps for other interfaces in the interface list. 
 

In order to block the Historian server from communicating with 
remote interfaces and clients, you need to perform either of the 
following: 

• Disconnect the Historian server computer from the network. 

• Block the 5450 TCP port on the firewall that runs on the 
Historian server computer. 

For more information, refer to the firewall documentation. 

By blocking this port you will ensure that the remote interfaces 
begin buffering data locally. 

To confirm that the Event Queue is empty and no new events are 
being generated: 

1. Run the System Management Tools. 

2. Under System Management Plug-Ins, select Operation > 
Snapshot and Archive Statistics. 

3. Click  several times. 

4. Verify that the archived events value is no longer increasing. 

NOTE For more information on the Event Queue, refer to the Introduction 
to FactoryTalk Historian SE System Management. 

 

 

To copy the migration scripts to your computer: 

1. Open the copy of the FactoryTalk Historian SE 3.01 
installation DVD on your portable storage device or shared 
folder. 

Block the Communication 
with the Historian Server 

Confirm the Event Queue is 
Empty 

Copy Migration Scripts to 
the Computer 
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2. Go to Redist > Migration. 

3. Copy the Scripts folder. 

4. Paste the folder to a disk on your computer. 

Make sure the path to the folder does not contain any blank 
spaces, for example: H:\Scripts. 

You will execute the scripts from this location during the 
migration. 

IMPORTANT The path to your local copy of the migration scripts and the Historian 
backup cannot contain any blank spaces. Otherwise the migration may 
fail. 
Examples of correct paths: H:\Scripts, H:\FTHSEv2_Backup. 

In this file you will set the environment variables to define paths to 
files that will be used in the migration process. 

To edit the 0_Locations.bat file: 

1. Open your local copy of the migration scripts. 

2. Edit the 0_Locations.bat file with administrative privileges. 

3. Edit the following: 

Item Description 
H:\Scripts Type the path to the location in which 

the migration .BAT files are stored. 
H: Type the letter of the drive on which you 

will store the backup. 
H:\FTHSEv2_Backup Type the path to the location in which 

you will store the backup. 
C: The letter of the drive on which the 

FactoryTalk Historian SE 3.01 is to be 
installed. 

Edit and Execute the 
0_Locations.bat File 
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4. If your Historian archives are stored in a location other than 

the default one: 

1. Remove the REM comment from the following line: 

REM set uFTHSEv2ArchiveFolder=D:\archives. 

 
2. Replace the sample path (D:\archives) with the actual path 

to your Historian archives. 

5. Save the file. 

6. Execute the file with administrative privileges. 
 

To shift the primary archive: 

1. Go to Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE System Management Tools. The System 
Management Tools dialog box appears. 

2. Under Collectives and Servers, select the Historian server 
whose archives you want to shift. 

3. Under System Management Plug-Ins, select Operation > 
Archives. 

Shift the Historian Archives 
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4. Under Archive File, select the primary archive and click . 

5. Click Yes in the confirmation message box. 

6. Wait until the archive is shifted. 
 

NOTE Skip these steps, if you have stored your Historian archives in 
another location than the default one and the location of the 
archives before and after the migration is the same, for example: 
D:\Historian_archives. 
The default locations of Historian archives are the following: 
• For 32-bit operating systems: 

C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\PI\dat 

• For 64-bit operating systems: 
C:\Program Files(x86)\Rockwell Software\FactoryTalk 
Historian\Server\PI\dat 

To prepare the registration .BAT file: 

1. Click Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under Collectives and Servers, select the server for which you 
are performing the migration. 

3. Under System Management Plug-Ins, select Operation > 
Archives. 

4. Click any of the archives listed. 

5. On the toolbar, click , and then select Registration BAT 
file. The Create piartool registration BAT file dialog box 
appears. 

6. Navigate to the location on your shared folder or the portable 
storage device that you are using for the migration. 

7. Click Save. 

8. Exit the System Management Tools and the FactoryTalk 
Administration Console if you have it open. 

Prepare the Registration 
.BAT File 



Chapter 2 Migrating a Single Historian Server 

 
 

32 Rockwell Automation Publication HSE-RM001A-EN-E–December 2012 

 

9. Go to the location in which you have saved the file and edit it 
in a text editor. 

10. Modify the location paths in all the lines except for those 
starting with the REM comment: 

Replace this path: With: 
C:\Program Files (x86)\Rockwell 
Software\FactoryTalk 
Historian\Server\PI\ 

C:\Program Files\Rockwell 
Software\FactoryTalk Historian\Server\ 

C:\Program Files\Rockwell 
Software\FactoryTalk 
Historian\Server\PI\ 

11. Put each location path in quotation marks. 

The figure below presents a modified registration .BAT file. 
The location paths point to the new default location of the 
archives, and they are placed in quotation marks. 

 
12. Save the file. 

 

Do either of the following: 

• Execute the 1_PreMigrationBackup.bat file from your local 
copy of the migration scripts. 

• Perform these steps manually: 

1. Create the directory structure for the backup (page 33). 

Execute 
1_PreMigrationBackup.bat 
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2. Create the archive log file (page 34). 

3. Stop the Historian server (page 34). 

4. Stop the FTLDIntAgent service (page 35). 

5. Disable the PI Network Manager service (page 35). 

6. Back up the Historian 2.1/2.2 server (page 35). 
 

IMPORTANT The path to your Historian backup cannot contain any blank spaces. 
Otherwise the migration may fail. 
A correct path to the backup would be, for example: 
H:\FTHSEv2_Backup. 

In these steps you will prepare and perform a backup of the 
Historian data. 

If you perform the steps manually, first you need to create a backup 
folder structure that would reflect the original structure of 
FactoryTalk Historian folders that you are about to back up. 

Create the following folder structure: 

 

1_BAT: Create the Directory 
Structure for the Backup 
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If you migrate the Historian server from a source to target computer, 
and on both computers you use a location for your Historian 
archives that is different from the default one, you will also need to 
create a backup folder for your archives, for example: 
FTHSEv2_Backup\Archives. 

NOTE %piserver% and %pihome% are path variables that point to specific 
locations in the FactoryTalk Historian system. 

 
 

To create the archive log file: 

1. Open the Command Prompt window with administrative 
privileges. 

2. Type cd /d %piserver%\adm and press Enter. 

3. At the command prompt, type piartool -al > 
<FullPathToTheFile>\<filename>.txt and press Enter. 

For example: piartool –al > c:\backup\archivelog.txt. 

The archive log file will be created. 

The file stores a list of all Historian archives. You will need this 
file when registering archives of the PI Server (page 44). 

To stop the Historian server: 

1. Click Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > Stop FactoryTalk Historian SE system. The 
Command Prompt window appears and a series of commands 
is executed. 

2. Wait until the Command Prompt window is closed and the 
server is stopped. 

1_BAT: Create the Archive 
Log File 

1_BAT: Stop the Historian 
Server 
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To stop the FTLDIntAgent service: 

1. Go to Start > All Programs > Administrative Tools > Services. 
The Services dialog box appears. 

2. Right-click FTLDIntAgent and select Stop. 

3. Wait until the service is stopped. 
 

NOTE The following steps are required to be performed on the source 
computer only, during the migration from the source to target 
computer. 

To disable the PI Network Manager service: 

1. In the Services dialog box, right-click PI Network Manager 
and select Properties. 

2. From the Startup type list, select Disabled. 

3. Click Apply. 

Disabling this service ensures that the PI server on the source 
computer is not restarted automatically. 

In this step, you will copy FactoryTalk Historian files to your 
backup location. 

Copy these files: From these source folders: 
All configuration .XML files. • On a 32-bit operating system: 

C:\Program Files\Rockwell 
Software\FactoryTalk Historian\Server 

• On a 64-bit operating system: 
C:\Program Files (x86)\Rockwell 
Software\FactoryTalk Historian\Server 

Server-related files: • %piserver% 
• Data  
• All files except pisubsys.cfg and 

pilicence.dat. 
• %piserver%\dat 

1_BAT: Stop the 
FTLDIntAgent Service 

1_BAT: Disable the PI 
Network Manager Service 

1_BAT: Back up the 
Historian 2.1/2.2 Server 
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Copy these files: From these source folders: 
• Scripts  
• All .BAT files. • %piserver%\adm 

• %piserver%\bin 
• Logs  
• All .DAT files. • %piserver%\log 

FTLD interface-related files:  
• Configuration .BAT files. • %pihome%Interfaces\LDInterface 

PIPC logs: • %pihome%\dat 

(Optional) If your Historian archives are not in the default location: 
• Archive and annotation files. • The folder in which you keep your 

Historian archives. 

See the following example to learn how to copy the files using the 
xcopy command. 

In this example, we will copy the .BAT files from the 
%piserver%\adm folder to the 
H:\FTHSEv2_Backup\Server\adm backup folder. 

To back up .BAT files from the %piserver%\adm folder: 

1. Open the Command Prompt window. 

2. Type cd /d %piserver%\adm and press Enter. 

3. Type xcopy /O *.bat h:\FTHSEv2_Backup\Server\adm and 
press Enter. 

The files that have been copied are listed in the Command 
Prompt window. 

4. Repeat the steps for the other folders that you need to back up. 

NOTE It is recommended to use the xcopy /O command in order to retain 
extended permissions to the folders being copied. 
For more information, see the Microsoft Knowledgebase article 
(http://support.microsoft.com/kb/323007). 

 
 

http://support.microsoft.com/kb/323007
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NOTE It is recommended that you change both the name and the IP address 
of the source computer so that you can transfer the original name and 
IP to the target computer. If the target computer has a different IP 
address than the source computer has originally had, you will need to 
update all the trusts in the Historian environment that make references 
to the original IP address. 

Perform the following steps on the source computer: 

1. Rename the source computer (with FactoryTalk Historian SE 
2.1/2.2) so that you can use the original name for the target 
computer (with FactoryTalk Historian SE 3.01). 

2. Restart the computer. 

3. Move the backup files from the source to the target computer. 

4. Turn off the source computer. 
 

Perform the following steps on the target computer: 

1. Set the name of the target computer as it originally was on the 
source computer. 

2. Restart the computer. 
 

In the following sections you will find detailed instructions on 
migration steps. 

 

To prepare a single computer for the upgrade: 

1. Remove the Historian server from the computer. 

1. Go to Start > All Programs > Rockwell Software > 
FactoryTalk Historian SE > Uninstall FactoryTalk 
Historian SE. The removal wizard appears. 

2. Follow the on-screen instructions to complete the process. 

Source to Target: Rename 
the Source Computer 

Source to Target: Rename 
the Target Computer 

Migration Steps 

Remove Historian 2.1/2.2 
from the Computer 



Chapter 2 Migrating a Single Historian Server 

 
 

38 Rockwell Automation Publication HSE-RM001A-EN-E–December 2012 

 

During the removal process, make sure to click Yes, OK, and 
Uninstall in the following message boxes: 

 

 

 
2. Remove any other FactoryTalk Historian components, such as 

FactoryTalk Historian ActiveView, FactoryTalk Historian 
DataLink, FactoryTalk Historian ProcessBook, and 
FactoryTalk Historian Management Tools. 

3. Remove any applications whose names begin with OSIsoft or 
PI. 

4. Verify in Control Panel that all components whose names 
begin with FactoryTalk Historian, OSIsoft, or PI have been 
removed. 

5. Restart the computer. 
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NOTE FactoryTalk Historian Live Data Interfaces of FactoryTalk Historian SE 
3.01 are supported on FactoryTalk Services Platform SR4, SR5 and 
SR5.1. If you currently have either SR4 or SR5 installed, it is your choice 
whether to upgrade to SR5.1 or not. Typically, this is dependant upon 
what type of the Data server you have installed on the computer and its 
compatibility with FactoryTalk Services Platform. In general, it is 
considered best practice to upgrade FactoryTalk Services Platform to 
the latest version. 

To install FactoryTalk Services Platform: 

1. On the FactoryTalk Historian SE 3.01 installation DVD, click 
Install FactoryTalk Historian Site Edition > Install FactoryTalk 
Services Platform > Install FactoryTalk Services Platform. 

2. Follow the on-screen instructions to complete the process. 

NOTE You can choose to restart the computer later, after you have 
installed FactoryTalk Activation Manager. 

 

 

To install RSLinx Enterprise: 

1. On the FactoryTalk Historian SE 3.01 installation DVD, click 
Install FactoryTalk Historian Site Edition > Install RSLinx 
Enterprise. 

2. Follow the on-screen instructions to complete the process. 

NOTE You can choose to restart the computer later, after you have 
installed FactoryTalk Activation Manager. 

 

 

Install FactoryTalk Services 
Platform 

Install RSLinx Enterprise 
(Optional) 
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Perform the following steps on the target computer: 

1. If the target computer functions also as the FactoryTalk 
Directory, restore the backup files from the exported data of 
FactoryTalk Services Platform. 

2. If the target computer does not function as the FactoryTalk 
Directory, specify the location of the FactoryTalk Directory 
using the Specify FactoryTalk Directory Location utility. 

NOTE For more information, refer to the FactoryTalk Historian SE 
Installation and Configuration Guide, section "Specify FactoryTalk 
Directory Server Location". 

3. If the target computer does not function as the FactoryTalk 
Activation server, run the FactoryTalk Activation Manager 
and specify the FactoryTalk Activation server that stores 
Historian licenses. 

NOTE For more information, refer to the FactoryTalk Activation leaflet 
available with your FactoryTalk Historian SE package and the 
FactoryTalk Activation Manager Help. 

4. If the target computer functions also as the FactoryTalk 
Activation server: 

1. Get new license activations for the target computer or 
rehost the existing activations using the FactoryTalk 
Activation Manager. 

2. Save the new activations in the location indicated by the 
FactoryTalk Activation Manager. 

NOTE For more information, refer to the FactoryTalk Activation leaflet 
available with your FactoryTalk Historian SE package and the 
FactoryTalk Activation Manager Help. 

 

Do either of the following: 

• Execute the 2_TargetFolderStuct.bat file from your local 
copy of the migration scripts. 

• Perform the steps described below manually. 

Source to Target: Configure 
FactoryTalk Directory and 
FactoryTalk Activation 
Manager on the Target 
Computer 

Execute 
2_TargetFolderStruct.bat 
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NOTE Perform the steps 1 and 2 of the following procedure for the migration 
on a single computer only. 

To create the target folder structure: 

1. Rename the C:\Program Files\Rockwell 
Software\FactoryTalk Historian\Server\PI folder so that 
archives from the folder do not get automatically registered 
after the upgrade. 

2. Rename the PIPC.ini file in the C:\Windows directory. 

3. Create the following paths: 

• C:\Program Files\Rockwell Software\FactoryTalk 
Historian\PIPC 

• C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server 

• C:\Program Files (x86)\Rockwell Software\FactoryTalk 
Historian\PIPC 

NOTE: For more information, refer to the Microsoft support 
(http://support.microsoft.com/kb/142982/en-us) article. 

 

 

NOTE During this installation, we will accept the majority of the default 
settings, except when defining the paths. 

To install the PI server: 

1. Open the copy of the FactoryTalk Historian SE 3.01 
installation DVD on your portable storage device or shared 
folder. 

2. Go to the Redist\Migration\PI375x64 folder, and 
double-click setup.exe. The PI Server X64 Setup installation 
wizard appears. 

Install the Intermediate PI 
Server FTHSE 22 x64 (PI 
Server 3.4.375x64) 

http://support.microsoft.com/kb/142982/en-us
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3. Follow the on-screen instructions to complete the process. 

• On the License Agreement page, where you are prompted 
for the license file folder, navigate to the 
Redist\Migration\Licenses\Intermediate folder on your 
copy of the installation DVD. The system will use the 
pilicense.dat file that is stored in the folder. 

• On the User Information page, for the serial number, type 
1. 

• On the Default Interface Destination page: 

• For the 64-bit path, point to 
C:\Program Files\Rockwell Software\FactoryTalk 
Historian\PIPC 

• For the 32-bit path, point to 
C:\Program Files (x86)\Rockwell Software\FactoryTalk 
Historian\PIPC 

 
• On the Destination Folder page, for the destination folder 

of the PI server, type the short file path name to the 
location in which the intermediate PI server. 

For example: C:\Progra~1\Rockwe~1\Factor~1\Server\ 

 

NOTE The number after the tilde may differ for each folder in the 
path. See "Check the Short Name of Folders (page 43)" for 
details. 

4. Accept the remaining default settings and follow the 
instructions on the screen to complete the installation. 



Migrating a Single Historian Server Chapter 2 

 
 

Rockwell Automation Publication HSE-RM001A-EN-E–December 2012 43 

 

NOTE Do not restart the server after the installation is complete. 

 

 

To check the short names of folders: 

1. Open the Command Prompt window. 

2. Navigate to the parent folder of the folder whose short name 
you want to check. 

3. Type dir <FirstLettersOfFolderName>*.* /x and press Enter. 

4. In the information that is displayed, check the short name of 
the folder you have indicated. 

5. Repeat the steps for all other folders in the location path to the 
PI server. 

In the example presented below, we will check the short name of the 
Program Files folder. 

To check the short name of the Program Files folder: 

1. Open the Command Prompt window. 

2. Navigate to the root level of the drive, on which you want to 
install the intermediate PI server. 

3. Type dir prog*.* /x and press Enter. 

4. In the information that is displayed, check the short name of 
the 64-bit Program Files folder. 

Check the Short Name of 
Folders 
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In this example, the short name for the Program Files folder is 
PROGRA~2. 

Do either of the following: 

• Execute the 3_RestorePIPart.bat file from your local copy of 
the migration scripts. 

• Perform the steps described below manually. 

NOTE Perform these steps without starting the server. 

To copy and rename backed up files: 

1. Copy the backup files using the xcopy /O/Y command, 
overwriting the existing ones, if prompted: 

Go to individual folders (Server\dat, Server\bin, 
Server\adm, and Server\log) in your backup directory, and 
copy all the backup files to respective folders: 

• The files from Server/dat copy to C:\Program 
Files\Rockwell Software\FactoryTalk Historian\Server\dat. 

• The files from Server/bin copy to C:\Program 
Files\Rockwell Software\FactoryTalk Historian\Server\bin. 

• The files from Server/adm copy to C:\Program 
Files\Rockwell Software\FactoryTalk Historian\Server\adm. 

Execute 
3_RestorePIPart.bat 
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• The files from Server/log copy to C:\Program Files\Rockwell 
Software\FactoryTalk Historian\Server\log. 

• (Optional). If you migrate the Historian server from a 
source to target computer, and on both computers you use a 
location for your Historian archives that is different from 
the default one: 

1. Create the target folder in which you want to keep the 
Historian archives on a disk, for example: 
G:\HistorianArchives. 

2. Copy the files from the FTHSEv2_Backup\Archives 
folder to the target folder. 

2. Rename the pirunonce.dif file located under C:\Program 
Files\Rockwell Software\FactoryTalk Historian\Server\adm so 
it will not be executed during the first start of the server. 

 

Do either of the following: 

• Execute the 4_StartAndConfigPIX64.bat file from your 
local copy of the migration scripts. 

• Perform the steps described below manually. 

To start and configure the intermediate PI server: 

1. Start the intermediate PI server using the pisrvstart.bat 
command: 

1. Open the Command Prompt window. 

2. Navigate to 
C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\adm. 

3. Type pisrvstart and press Enter. 

4. Wait until the server is started. 

Execute 
4_StartAndConfigPIX64.bat 
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2. Modify the tuning parameters in the PI System Management 
Tools: 

1. Go to Start > All Programs > PI System > PI System 
Management Tools. The System Management Tools 
dialog box appears. 

2. Under System Management Plug-Ins, go to Operation > 
Tuning Parameters. 

3. Go to the Archive tab, and double-click 
Archive_AutoArchiveFileRoot. The parameter dialog box 
appears. 

4. Under Value, update the location so that it points to: 

• For archives stored in the default location: 

C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\dat\piarch_ 

• For archives stored in another location than the default 
one: 

<ArchiveLocation>\piarch_ 

For example: D:\Historian_archives\piarch_ 

5. Go to the Snapshot tab, select 
Snapshot_EventQueuePath, and set Value to the 
following location: 

C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\dat\ 

6. Click OK. 
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NOTE Skip the following steps, if you have stored your Historian archives in 
another location than the default one and the location of the archives 
before and after the migration is the same, for example: 
D:\Historian_archives. 
The default locations of Historian 2.1/2.2 archives are the following: 
• For 32-bit operating systems: 

C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\PI\dat 

• For 64-bit operating systems: 
C:\Program Files(x86)\Rockwell Software\FactoryTalk 
Historian\Server\PI\dat 

To register and verify the server archives: 

1. Run the registration .BAT file that you have created in 
"Prepare the Registration .BAT File (page 31)". The files are 
registered. 

2. Go to Start > All Programs > PI System > PI System 
Management Tools. The System Management Tools dialog 
box appears. 

3. Under System Management Plug-Ins, go to Operation > 
Archives. 

A list of the archives registered with the registration .BAT file 
is displayed. 

4. Check if the list of the archives is the same as it was before the 
migration. 

Register the Archives 



Chapter 2 Migrating a Single Historian Server 

 
 

48 Rockwell Automation Publication HSE-RM001A-EN-E–December 2012 

 

 

NOTE Skip these steps, if you have stored your Historian archives in another 
location than the default one and the location of the archives before 
and after the migration is the same, for example: D:\Historian_archives. 
The default locations of Historian archives are the following: 
• For 32-bit operating systems: 

C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\PI\dat 

• For 64-bit operating systems: 
C:\Program Files(x86)\Rockwell Software\FactoryTalk 
Historian\Server\PI\dat 

To remove old references to the archives: 

1. Open the archivelog.txt file from your backup on the portable 
storage device or shared folder. 

From this file, you will copy the locations of all the archives 
listed there. 

 
2. Open the Command Prompt window. 

3. At the command prompt, go to Program Files\Rockwell 
Software\FactoryTalk Historian\Server\adm. 

4. Execute the piartool command so that it points to your old 
location of the archive, following the syntax: 

Remove Old References to 
the Archives 
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piartool –au “OldPathToTheArchive\ArchiveFileName.arc” 

Make sure to place the path to the archive in quotation marks. 

The example below presents the piartool command pointing 
to the archive file located in the old archive directory, (i.e., 
C:\Program Files(x86)\Rockwell Software\FactoryTalk 
Historian\Server\PI\dat). 

 
5. Press Enter and wait until the reference to the archive is 

removed from the system. 

6. Repeat the steps for all the other archives listed in the 
archivelog.txt file. 

 

To stop the server: 

1. Open the Command Prompt window. 

2. Navigate to C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\adm. 

3. Type pisrvstop and press Enter. 

4. Wait until the server is stopped. 
 

Install Microsoft SQL Server and FactoryTalk Historian Asset 
Framework Server. 

To install Microsoft SQL Server: 

1. Run the FactoryTalk Historian SE installation DVD. 

2. On the welcome page of the installation wizard, click Install 
FactoryTalk Historian SE > Install FactoryTalk Historian Asset 
Framework > Install Microsoft SQL Server 2008 Express. 

The installation wizard appears. 

Stop the Intermediate 
Server 

Install FactoryTalk 
Historian Asset Framework 
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3. Follow the on-screen instructions to complete the process. 

To install FactoryTalk Historian Asset Framework Server: 

1. Run the FactoryTalk Historian SE installation DVD. 

2. On the welcome page of the installation wizard, click Install 
FactoryTalk Historian SE > Install FactoryTalk Historian Asset 
Framework > Install FactoryTalk Historian AF Server. 

3. Follow the on-screen instructions to complete the process. 
 

To install FactoryTalk Historian Management Tools: 

1. If your System Management Tools application is still open, 
close it before you start the installation. 

2. Run the FactoryTalk Historian SE installation DVD. 

3. On the welcome page of the installation wizard, click Install 
FactoryTalk Historian Site Edition > Install FactoryTalk 
Historian Management Tools. 

4. Follow the on-screen instructions to complete the process. 

5. If prompted, restart the computer. 
 

To start the server: 

1. Open the Command Prompt window. 

2. Navigate to C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\adm. 

3. Type pisrvstart and press Enter. 

4. Wait until the server is started. 

Install FactoryTalk 
Historian Management 
Tools 

Start the Intermediate 
Server 
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To prepare the MDB to AF synchronization: 

1. Click Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under System Management Tools, select Operation > MDB 
to AF Synchronization. 

3. On the toolbar, click . The PI MDB to AF Preparation 
Wizard appears. 

4. Follow the on-screen instructions to complete the process. 
 

To stop the server: 

1. Open the Command Prompt window. 

2. Navigate to C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\adm. 

3. Type pisrvstop and press Enter. 

4. Wait until the server is stopped. 
 

To upgrade the Historian server to version 3.01: 

1. Open your copy of the FactoryTalk Historian installation 
DVD. 

2. Go to Setup\InstallationManager\InstallationConfiguration. 

3. Open the FTHistorianSE.xml file for editing. 

Prepare MDB to AF 
Synchronization 

Stop the Intermediate 
Server 

Upgrade the Historian 
Server to Version 3.01 
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4. Set the RESTARTSRV parameter to NO so that the server is 
not restarted after the installation, and default settings are not 
loaded. 

 
5. On your copy of the FactoryTalk Historian installation DVD, 

click Setup.exe to install the FactoryTalk Historian SE 3.01 
server: 

1. Click Install FactoryTalk Historian Site Edition > Install 
FactoryTalk Historian Server. 

2. Follow the on-screen instructions to complete the process. 

IMPORTANT Do not reboot computer, even if prompted, and do not start 
the Historian server. 
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During the installation of the Historian server the 5450 TCP port is 
automatically open for accepting incoming connections. 

If you have blocked the communication with the Historian server by 
blocking the 5450 TCP port, make sure that the port is still blocked 
on the firewall after the FactoryTalk Historian SE 3.01 is installed. 

For more information, refer to the firewall documentation. 

Do either of the following: 

• Execute the 5_RestoreRAPart.bat file from your local copy of 
the migration scripts. 

• Perform these steps manually: 

1. Restore and rename files (page 54). 

2. Merge customized .BAT files (page 54). 

3. Start the Historian server (page 55). 

4. Update database security settings (page 55). 

ATTENTION When upgrading the secondary server in a collective, do not 
execute the 5_RestoreRAPart.bat file. Instead, perform 
the following steps manually: 
1. Restore and rename files (page 54). 
2. Merge customized .BAT files (page 54). 

 

 

Check if the Communication 
to the Historian Server is 
Blocked 

Execute 
5_RestoreRAPart.bat 
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Restore the Historian server configuration .XML files stored in the 
XMLconfig folder to the C:\ProgramData\Rockwell 
Automation\FactoryTalk Historian folder. 

NOTE In certain configurations of the Windows operating system, the 
ProgramData directory may be hidden from the user. In such a case, 
you may need to change the Windows settings so that the folder 
becomes visible and accessible to you. 

 

 

WARNING The following steps should be performed by advanced users only. 

 

During the installation of FactoryTalk Historian SE 3.01, the .BAT 
files stored in the following folders have been overwritten. 

• C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\adm\ 

• C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\bin\ 

If you customized the .BAT files for FactoryTalk Historian SE 
2.1/2.2 and you want to use the customized settings from these files 
in FactoryTalk Historian SE 3.01: 

1. Compare the .BAT files that you have backed up from the 
adm and bin folders to your backup directory (page 35) with 
the current .BAT files for the version 3.01. 

2. Merge the content that you want to use for the 3.01 server in 
the current files. 

 

5_BAT: Restore Files 

5_BAT: Merge Customized 
.BAT Files 
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To start the Historian server: 

1. Go to Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > Start FactoryTalk Historian SE. 

2. Wait until the server is started. 
 

To update database security settings for new objects: 

1. At the command prompt, type piconfig < migration.dif, and 
press Enter. 

2. Wait until the security settings of new database tables are 
updated. 

3. Check if the new database security settings are consistent with 
those migrated from the database security model of 
FactoryTalk Historian SE 2.1/2.2. Adapt the settings in case 
of inconsistencies. 

 

In the following sections you will find detailed instructions of 
post-migration steps. 

 

 

To complete the MDB to AF synchronization: 

1. Create a security mapping for the FTHEngineers group. In 
FactoryTalk Historian SE 2.1/2.2 this group was assigned to 
manage the MDB. 

1. On the Active Directory, create an FTHEngineers group. 

2. On the Historian server computer, go to Start > All 
Programs > Rockwell Software > FactoryTalk Historian SE 
> System Management Tools. The System Management 
Tools dialog box appears. 

5_BAT: Start the Historian 
Server 

5_BAT: Update Database 
Security Settings 

Post-migration Steps 

Complete and Verify the 
MDB to AF Synchronization 
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3. Under System Management Tools, select Security > 
Mappings & Trusts. 

4. On the toolbar, click . The Add New Mapping dialog 
box appears. 

5. Click Browse next to Windows Account. The Select 
User, Computer, or Group dialog box appears. 

6. Select the FTHEngineers group that you have created on 
the Active Directory computer. 

7. Click OK. 

8. Click Browse next to PI Identity. The Select PI Identity, 
PI Group, or PI User dialog box appears. 

9. Under Type, select PI Groups. 

10. Under Name, select FTHEngineers, and click OK. 

11. Click OK. 

2. Using System Management Tools, restart the PI AF Link 
Subsystem service: 

1. Under System Management Tools, select Operation > PI 
Services. 

2. Right-click PI AF Link Subsystem, and click Stop Service. 

3. Wait until the service is stopped. 

4. Right-click the service again, and click Start Service. 

5. Wait until the service is started. 

3. Using System Management Tools, verify the MDB to AF 
synchronization: 

1. Under System Management Tools, select Operation > 
MDB to AF Synchronization. 

If the synchronization is operating correctly, a green icon 
 appears next to the name of the server. 
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NOTE For collectives, this step is required for the primary server only.  

To migrate FTLD local interfaces: 

1. Copy the backed up interface .BAT file to C:\Program Files 
(x86)\Rockwell Software\FactoryTalk 
Historian\PIPC\Interfaces\LDInterface. 

2. Run the Interface Configuration Utility and restore the local 
interface: 

1. Go to Start > All Programs > Rockwell Software > 
FactoryTalk Historian SE > Interface Configuration Utility. 
The Interface Configuration Utility dialog box appears. 

2. From the Interface list, select the local FTLD interface. 

3. In the error message box that appears, click OK. 

 
4. On the toolbar, click . The interface you have selected 

gets unregistered. 

5. Click . The Open Interface Configuration File dialog 
box appears. 

6. Navigate to and select the .BAT file you have just copied. 

7. Click Open. The interface settings are displayed in the 
Interface Configuration Utility dialog box. 

8. Click Service, and check the service-related settings. 
Modify them, if necessary. 

Migrate Local FTLD 
Interfaces (If Applicable) 
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9. Under Service Configuration, change Display name to 
FTLDx, where x is your interface ID number, for example: 
FTLD1. 

10. Click Create to create a service for the interface. 

11. In the message box that appears, click Yes or No depending 
on how you want the interface service to be configured. 

12. Click FTLDInt, and type /MultiCOM at the beginning of 
the parameter list. 

13. Click Apply. 

14. On the toolbar, click  to start the interface service. 
 

Use Historian Services in System Management Tools to view, 
configure, start and stop Historian services for each connected 
Historian server. The status of each service is updated every 30 
seconds by default. You may change this refresh rate. You can also 
view the status, errors, and thread details for services used by the 
connected Historian server, and export a list of Historian services. 

To open Historian services: 

1. Click Start > Program Files > Rockwell Software > FactoryTalk 
Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under Collectives and Servers, select the server for which you 
want to view the information. 

3. Under System Management Tools, select Operation > PI 
Services. 

4. Verify that the following Historian services and default 
interfaces are running: 

• Archive Subsystem 

• Backup Subsystem 

Verify that Historian 
Services are Running 
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• Base Subsystem 

• License Manager 

• Network Manager 

• Ramp Soak Simulator (rmp_sk) Interface 

• Random Simulator (random) Interface 

• Snapshot Subsystem 

• SQL Subsystem 

• Update Manager 

Depending on your license, you might see additional services. 

To verify that the Historian server is updating data for default 
tags: 

1. On the computer with the Historian server installed, go to 
Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under Collectives and Servers, select the Historian server 
whose data you want to view. 

3. Under System Management Tools, select Data > Archive 
Editor. 

4. In the (Tag Not Specified) tab, click . The Tag Search 
dialog box appears. 

5. In the Tag Mask text box, type cdt158, and click Search. 

The cdt158 tag appears in the search results list. 

6. Click OK. 

The list of events of the selected tag is displayed in the tab in 
the right pane of the System Management Tools dialog box. 

Verify that the Historian 
Server is Updating Data for 
Default Tags 
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NOTE For more information on the Archive Editor, click . 

 
 

Perform the following steps to ensure communication between the 
upgraded Historian server and the computers that communicate 
with the server. 

To create a transitory security configuration: 

1. Go to Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under System Management Tools, select Security > 
Mappings & Trusts. 

3. Click the Trust tab, and then  on the toolbar. The Add 
Trust Wizard appears. 

4. Fill in the following information: 

For: Type: 
Trust Name Subnetwork 
Trust Description This is a transitory solution after the migration. 

5. Click Next until the Specify Client Connection 
Information page appears. 

6. Fill in the following information: 

For: Do: 
Network Path Leave this box empty. 
IP Address Type the IP address of your subnetwork. 

For example: If you have a subnetwork IP address 
192.168.1.x, where x is a range from 1 to 255, you will type 
192.168.1.0. 

NetMask Type the net mask for your subnetwork. For the example 
presented above, it would be 255.255.255.0. 

Click Next. 

Create a Transitory Security 
Configuration for the 
Historian Environment 
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7. On the Select PI User page, click Browse next to PI Identity. 
The Select PI Identity, PI Group, or PI User dialog box 
appears. 

8. Under Type, select PI Users. 

9. Under Name, select piadmin, and click OK. 

10. Click Finish to close the wizard. 

The trust has been added to the trust list. 
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Rockwell Automation considers it a good practice to exclude the 
following directories from anti-virus software scanning: 

• On Historian server computers, exclude the Server\dat 
directory and any directory where archive or event queue files 
are located. 

• For Interface nodes, exclude the pipc\dat and pipc\log 
directories, as well as the directory where buffer queue files are 
located. 

By excluding these directories you avoid random signature match 
incidents, potential performance impacts, and conflicts with locked 
files. 

NOTE For more details, see the FT Historian SE Server Reference Guide, 
available in the Redist\Docs folder on the FactoryTalk Historian SE 
installation DVD and in the Common Files\Rockwell\Help folder in 
your Program Files directory. 

 

 

In order to restore the communication of the Historian server with 
remote interfaces and clients, you need to unblock the 5450 TCP 
port on the firewall that runs on the computer hosting the server. 

For more information, refer to the firewall documentation. 

Disable Virus Scanning 

Restore the Communication 
to the Historian Server 
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If you transfer data from Historians ME to your Historian SE and 
you have changed the IP address of your Historian SE server during 
the migration, you need to update the data transfer configuration of 
your Historians ME so that it points to the new IP address of the 
Historian SE server. 

To update the Historian ME data transfer configuration: 

1. Open Microsoft Internet Explorer. 

2. In the address bar, type the IP address of your Historian ME 
module, and then press Enter. 

3. On the logon page, type your user ID and password, and then 
press Enter. 

4. Click Configure Historian. 

5. Click Data Transfer. 

6. Under Data Transfer, in the Host Server text box type the 
new IP address of your Historian SE server. 

7. Click Test Connection. 

8. Once the connection to the Historian SE server is established, 
click Save. 

Changing the IP address results in stopping the data transfer. 

When prompted, restart the data transfer: 

1. Under Data Transfer Parameters, click Start. 

When the data transfer is restarted, its status changes to 
Running. 

9. Repeat the steps for all other Historians ME that you use. 
 

Source to Target: 
Reconfigure Historian ME 
Data Transfer (If Applicable) 
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ATTENTION Before performing the following procedure, verify if your Historian 
computer supports the integrated Windows authentication. 
To check the Windows authentication support on your Historian 
computer, see "Verify if the FactoryTalk Historian Computer Supports 
Windows Authentication (page 68)". 
If it does not support it, you will need to create an explicit trust for this 
Historian computer. 
To learn how to create an explicit trust, see "Create a Trust for a 
Historian Computer without Windows Authentication Support (page 
69)". 

 

Perform the following steps to migrate FactoryTalk Services 
Platform users to the integrated Windows authentication. 

The steps use the FTHAdministrators group as the example. Make 
sure to repeat the steps for all other FTH groups, (i.e., 
FTHEngineers, FTHOperators, and FTHSupervisors). 

Map this group: To these PI users: 
FTHAdministrators piadmin 
FTHEngineers FTHEngineer 
FTHSupervisors FTHSupervisor 
FTHOperators FTHOperator 

To migrate PI users to the integrated Windows authentication: 

1. Go to Start > All Programs > Rockwell Software > FactoryTalk 
Administration Console. The FactoryTalk Administration 
Console dialog box appears. 

Migrate FactoryTalk 
Services Platform Users to 
the Integrated Windows 
Authentication 
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2. In the Explorer tree, go to Systems > Users and Groups > 
User Groups. 

 
3. Double-click FTHAdministrators. The properties dialog box 

appears. 
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4. On the Active Directory computer, create the 
FTHAdministrators group. The example below presents the 
group created with the Administrative Tools > Computer 
Management tool. 

 
5. On the Active Directory, create users with the same names and 

passwords as those that are assigned to the 
FTHAdministrators group in the FactoryTalk Services 
Platform. 

6. Assign the users to the FTHAdministrators group you have 
created on the Active Directory computer. 
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The example below presents the FTHAdministrators group 
and the users assigned to the group on the Active Directory 
computer. 

 
7. On the FactoryTalk Historian SE server computer, go to Start 

> All Programs > Rockwell Software > FactoryTalk Historian 
SE > System Management Tools. The System Management 
Tools dialog box appears. 

8. Under System Management Tools, select Security > 
Mappings & Trusts. 

9. On the toolbar, click . The Add New Mapping dialog box 
appears. 

10. Click Browse next to Windows Account. The Select User, 
Computer, or Group dialog box appears. 

11. Select the FTHAdministrators group that you have created 
on the Active Directory computer. 

12. Click OK. 

13. Click Browse next to PI Identity. The Select PI Identity, PI 
Group, or PI User dialog box appears. 

14. Under Type, select PI Users. 

15. Under Name, select piadmin, and click OK. 
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16. Click OK to close the wizard. 

The mapping has been added to the mapping list. 

 
17. Repeat the steps for the rest of the FTH groups assigning them 

to the appropriate PI users, as specified at the beginning of the 
procedure. 

18. Disable the transitory security trust for Historian computers 
(page 60): 

1. Under System Management Tools, select Security > 
Mappings & Trusts. 

2. In the Trusts tab, double-click the subnetwork trust you 
have created. 

3. In the trust properties dialog box of the subnetwork trust, 
check Trust is disabled. 

4. Click OK. 
 

To check if your Historian computer supports the integrated 
Windows authentication: 

1. Open AboutPI-SDK. 

2. From the menu bar, click File > Connections. The 
Connection Manager dialog box appears. 

Verify if the Historian 
Computer Supports 
Windows Authentication 
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3. From the menu bar, click Tools > Options. The Connection 
Options dialog box appears. 

4. Under Specify Authentication Procedure, make sure that 
the Windows Security item is listed as a protocol order. 

 
 

To create an explicit trust for a Historian computer: 

1. Go to Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under System Management Tools, select Security > 
Mappings & Trusts. 

Create a Trust for a 
Historian Computer 
without Windows 
Authentication Support 
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3. Click the Trust tab, and then  on the toolbar. The Add 
Trust Wizard appears. 

4. Complete the following: 

For: Type: 
Trust Name A name for the trust, for example: FactoryTalk Historian 

Client Trust. 
Trust Description A description of the trust (optional). 

5. Click Next until the Specify Client Connection 
Information page appears. 

6. Complete the following: 

For: Do: 
Network Path Leave this box empty. 
IP Address Type the IP address of the Historian computer, for example 

192.168.1.123. 
NetMask Type the net mask for your subnetwork. For the example 

presented above, it would be 255.255.255.255. 
Click Next. 

7. On the Select PI User page, click Browse next to PI Identity. 
The Select PI Identity, PI Group, or PI User dialog box 
appears. 

8. Under Type, select PI Users. 

9. Under Name, select piadmin, and click OK. 

10. Click Finish to close the wizard. 
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The trust has been added to the trust list. 

 
 

Execute the 6_EnvVarsCleaning.bat file from your local copy of 
the migration scripts. 

The script removes from your operating system the environment 
variables that have been set by the 0_Locations.bat file for the 
purposes of the migration. 

Execute 
6_EnvVarsCleaning.bat 
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To create a backup of your migrated Historian system: 

1. Open the Command Prompt window. 

2. Navigate to C:\Program Files\Rockwell Software\FactoryTalk 
Historian\Server\adm. 

3. Run the pibackup command with the following syntax: 

pibackup <CompletePathToTheBackupFolder> 
<NumberOfArchivesToBackUp> 

For example: pibackup c:\backup 3. 

Press Enter. 

4. Wait until the backup is complete. 

 

Create a Backup of Your 
Migrated Historian 
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Chapter 3 

Migrating a Collective of Historian 
Servers 

This instruction is based on the following assumptions: 

• The collective consists of two FactoryTalk Historian SE 
2.1/2.2 servers. 

• The machines constituting a collective should be in the same 
domain. 

• The FactoryTalk Activation Manager must be installed on 
every migrated server and it should search for FactoryTalk 
Directory machine for licenses. As a result, the licenses are 
visible on both nodes of the collective. 

• The migration is performed in the following order so that the 
work of the collective is undisturbed: 

1. The primary server in the collective is isolated and 
migrated. In the meantime, the secondary server is 
collecting data and communicating with clients and 
interfaces. 

2. The network communication is restored on the primary 
server. The primary server starts collecting data and 
receiving data from the buffering. The collective members 
are not able to communicate with one another in such a 
configuration. 

3. The secondary server in the collective is isolated and 
migrated. In the meantime, the primary server is collecting 
data and communicating with clients and interfaces.  

4. The secondary server is reinitialized. 



Chapter 3 Migrating a Collective of Historian Servers 

 
 

74 Rockwell Automation Publication HSE-RM001A-EN-E–December 2012 

 

NOTE To perform this procedure, administrative rights are required. 

 

 

Perform the following migration steps: 

1. Block the primary server from incoming process data (page 
74). 

2. Migrate the primary server (page 75). 

3. Restore the communication between the primary server and 
the network (page 75). 

4. Block the secondary server from incoming process data (page 
74). 

5. Migrate the secondary server (page 75). 

6. Restore the communication between the secondary server and 
the network (page 75). 

7. Reinitialize the secondary server (page 76). 

8. Verify communication between collective members (page 78). 

9. Verify the replication of configuration changes in the primary 
server (page 80). 

 

Before upgrading the Historian server, you need to isolate it from all 
incoming process data, from client applications such as FactoryTalk 
Historian ProcessBook, and from other members of the collective. 

During the migration, users and applications fail over to the other 
member of the collective. 

NOTE The isolation methods have no effect on the communication between 
the Historian server and the Asset Framework server. The 
communication between those two is required by the Historian MDB 
to AF Preparation wizard. 

Checklist: Migration of a 
Historian Server Collective 

Block the Historian Server 
from Incoming Process Data 
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To isolate the Historian server, use either of the following: 

• A Windows Firewall or another commercial firewall to block 
port 5450. 

Refer to the firewall documentation for details. 

• The Firewall tool in the System Management Tools (SMT) to 
set up a Historian firewall. 

1. Go to Start > All Programs > Rockwell Software > 
FactoryTalk Historian SE > System Management Tools. The 
System Management Tools dialog box appears. 

2. Under Collectives and Servers, select the server for which 
you want to set up a firewall. 

3. Under System Management Tools, go to Security > 
Firewall. 

4. Configure a firewall for the selected server. 

NOTE Refer to the System Management Tools User Guide for more 
information. Click  on the toolbar in the System 
Management Tools to open the guide. 

 

 

Follow the steps described in "Upgrade the Historian Server to 
Version 3.01 (page 51)" to migrate the primary and secondary 
Historian servers to version 3.01. 

 

 

To restore the communication to the Historian server use either 
of the following: 

• A Windows Firewall or another commercial firewall to 
unblock port 5450. 

Migrate Historian Servers to 
Version 3.01 

Restore the Communication 
Between the Historian 
Server and the Network 
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Refer to the firewall documentation for details. 

• The Firewall tool in the System Management Tools (SMT) to 
disable the Historian firewall. 

1. Go to Start > All Programs > Rockwell Software > 
FactoryTalk Historian SE > System Management Tools. The 
System Management Tools dialog box appears. 

2. Under Collectives and Servers, select the server for which 
you want to set up a firewall. 

3. Under System Management Tools, go to Security > 
Firewall. 

4. Disable the firewall for the selected server. 

NOTE Refer to the System Management Tools User Guide for more 
information. Click  on the toolbar in the System 
Management Tools to open the guide. 

 

 

To reinitialize the secondary Historian server: 

1. Make sure that the secondary Historian server is isolated from 
the primary server in the collective. 

See "Isolate the Historian Server from Incoming Process Data 
(page 74)" for more information. 

2. Log on to a computer that has access to all members of the 
collective. 

3. Click Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > Collective Manager. The Collective Manager 
dialog box appears. 

4. Click the icon of the secondary server to select it. 

Reinitialize the Secondary 
Historian Server 
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Under Connection Status, the values of CommStatus and 
SyncStatus indicate that communication with the secondary 
server has been disrupted. For example: 

 
5. From the menu bar, click Edit > Reinitialize Secondary 

Server. 

6. When prompted to select archives to copy to the secondary 
server, select the primary archive and any archives that have 
been added or changed since the primary Historian server was 
upgraded. 

NOTE By default, Collective Manager selects all existing archives to be 
copied. It is not necessary to copy all archives when reinitializing, 
but only those that have changed since the primary Historian server 
was upgraded. 

7. Click Next. 

8. Follow the on-screen instructions to complete the process. 

9. Click Finish. 

In the Connection Status group, the values of CommStatus 
and SyncStatus change to show that the secondary server is 
successfully communicating with the primary server. 
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For example: 

 
 

Use the Collective Manager to verify that the members of your 
collective are communicating. 

To check communication of the members of a collective: 

1. Click Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > FactoryTalk Historian SE System > Collective 
Manager. The Collective Manager dialog box appears. 

If the collective does not appear under Collectives, you must 
enable communication between the Collective Manager and 
the collective: 

1. Select File > Connections. The Connection Manager 
dialog box appears. 

2. Click the check box next to the name of the collective to 
select it. 

If the collective is not listed in the Connection Manager, 
add it: 

1. Select Server > Add Server. 

Verify Communication 
Between Server Collective 
Members (Migration Guide) 
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2. In Network Node, type the fully qualified domain name 
(FQDN) for the primary server in the collective. 

3. Click OK. 

3. Select the collective. 

4. Click Save to close the Connection Manager. 

2. Under Collectives, select your collective. 

The right pane of the dialog box displays the current status of 
the connection between the members of the selected collective. 
The Collective Manager shows a diagram of collective 
members. An icon represents each server in the collective. A 
green check mark on the icon indicates that the server is 
communicating correctly. A red X indicates that the server is 
not communicating correctly. 

 
If a server icon is not communicating correctly, you can: 

• Wait a few moments. Occasionally, the status of the 
secondary server will get updated at the next attempt to 
synchronize. 

• Try to reinitialize the server. To do so, right-click the server 
icon and select Reinitialize Server. 
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To verify that a Historian server collective replicates primary server 
configuration changes to all secondary servers, you can edit a point 
on the primary server and verify the change on the secondary server 
in the collective. 

To verify configuration replication in a Historian server 
collective: 

1. Click Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > System Management Tools. The System 
Management Tools dialog box appears. 

2. Under Collectives and Servers, select all the servers that are 
members in the collective. 

3. Under System Management Tools, select Points > Point 
Builder. 

4. Add a point found in all the servers to the list of points: 

1. On the toolbar, click . The Tag Search dialog box 
appears. 

2. In Tag Mask, type sinusoid. 

3. Click Search to find all instances of this built-in point on 
the selected servers. 

4. Click Select All to choose all instances. 

5. Click OK to add these points to the list of points in the 
Point Builder. 

5. Edit the point on the primary server: 

1. Select the point on the primary server. 

The Point Builder shows the configuration of the selected 
point in the tabs at the bottom of the System Management 
Tools dialog box. 

Verify Replication of 
Configuration Changes in 
the Primary Server 
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2. In the General tab, change the text in the Descriptor text 
box. For example, change 12 Hour Sine Wave to 12-hour 
sine wave. 

3. Click . 

The Point Builder shows the updated Descriptor text for 
this point on the primary server. 

6. Click . 

If the replication is working properly, the modified 
Descriptor text appears for the sinusoid point on all the 
servers in the collective. 

If the replication fails, refer to the FT Historian High 
Availability Administrator Guide, section "Historian 
Collective Health". 
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Chapter 4 

Upgrading FactoryTalk Historian Live 
Data Interface 

The migration and upgrade to FactoryTalk Historian SE 3.01 
requires that you upgrade your FactoryTalk Historian Live Data 
Interface. 

The migration may be performed: 

• For a single Live Data interface with buffering (page 83). 

• For Live Data redundant interfaces with buffering (page 83). 
 

Perform the following migration steps: 

1. Remove the Live Data interface. (page 84) 

2. Upgrade FactoryTalk Services Platform (page 84). 

3. Install the new Live Data interface (page 85). 

4. Verify the buffering configuration (page 88). 

5. Create and run the Live Data interface service (page 89). 
 

On the computer with the primary interface installed: 

1. Remove the Live Data interface. (page 84) 

2. Upgrade FactoryTalk Services Platform (page 84). 

3. Install the new Live Data interface (page 85). 

4. Verify the Phase 2 failover configuration (page 87). 

5. Verify the buffering configuration (page 88). 

6. Create and run the Live Data interface service (page 89). 

Checklist: Migration of a 
Single Live Data Interface 

Checklist: Migration of Live 
Data Redundant Interfaces 
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On the computer with the secondary interface installed: 

1. Repeat the same steps like for the primary interface. 
 

To remove the Live Data interface: 

1. On the computer with the Live Data interface installed, go to 
Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > Uninstall FactoryTalk Historian SE. 

2. In the message box that appears, click Yes to confirm that you 
want to remove the product. The installation wizard appears. 

3. On the Welcome page, click Next. 

4. On the Program Maintenance page, click Next. 

5. On the Remove the Program page, click Remove. 

6. In the message box that appears, click OK to continue with the 
removal process. 

The Uninstalling page presents the status of the removal 
process. 

7. On the InstallShield Wizard Completed page, click Finish. 
 

To upgrade FactoryTalk Services Platform: 

1. On the FactoryTalk Historian SE 3.01 installation DVD, click 
Install FactoryTalk Historian Site Edition > Install FactoryTalk 
Services Platform > Install FactoryTalk Services Platform. 

2. Follow the on-screen instructions to complete the process. 

NOTE During the installation, the previous version of the component is 
removed from the computer and the new version is installed. 

 

 

Remove the Live Data 
Interface 

Upgrade FactoryTalk 
Services Platform 
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To install the FactoryTalk Historian Live Data Interface: 

1. Run the FactoryTalk Historian SE installation DVD. 

2. On the welcome page of the installation wizard, click Install 
FactoryTalk Historian SE > Install FactoryTalk Historian Live 
Data Interface. 

The installation wizard appears. 

If there are any software prerequisites missing from the 
computer, they are listed in red at the bottom of the 
installation wizard Welcome page. Click Cancel and Finish 
to exit the wizard, install the prerequisites, and start the 
installation wizard again. 

3. On the Welcome... page, click Next. 

4. On the License Agreement page, read and accept the terms of 
the license agreement, selecting the I accept... option. 

5. Click Next. 

6. On the Review Component Installation page, review the list 
of the components that are already installed and those that will 
be installed during the installation process. 

Click Next. 

7. On the Destination Drive page, select the drive on which you 
want to install the product. 

If the space available on the drive is not sufficient for the 
installation, a warning message will appear below the 
Installation drive list. In such a case, select another drive or 
increase the available space on the drive you have originally 
selected. 

NOTE You can choose the destination drive only if you install the 
component on the selected machine for the first time. If there have 
been any FactoryTalk Historian components installed on the 
machine before, the Installation drive list will not be enabled. 

Click Next. 

Install FactoryTalk 
Historian Live Data 
Interface 
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The Installation Progress page appears. It lists the 
components that are going to be installed. The status of the 
installation is displayed in the Status column of the 
component table. 

8. Click Install to start the installation. 

9. Wait until the components are installed. The installation time 
will vary depending on the number of components being 
installed and the computer performance. The installation 
status is displayed below the component table. 

During the installation process, the Release Notes appear. Close 
the dialog box to proceed with the installation. 

If the FactoryTalk Activation Manager has not been installed 
yet, the wizard for installing USB dongles software appears. 

The FactoryTalk Activation Manager installation wizard 
appears with a list of prerequisite packages. 

Click Continue. 

10. In the message box that appears: 

• Click Yes, if you want to install the software for Rockwell 
Automation USB dongles. 

The drivers are used to support mobile activations which 
are locked in a hardware dongle. 

Follow the on-screen instruction to install the software. 

• Click No, if you want to skip this step. 

The installation wizard appears. 

11. Follow the instructions displayed on the screen to complete 
the installation. 

12. In the FactoryTalk Directory Server Location Utility dialog 
box, verify that it points to the correct computer that hosts the 
FactoryTalk Directory server. 
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13. On the Installation Wizard Completed page, click Show the 
installation log, if you want to view the installation log after 
the installation wizard closes. 

If any of the installed components requires rebooting the 
computer, a relevant message will appear on the installation 
wizard page, and you will be prompted to restart the machine 
after the installation wizard closes. 

14. Click Finish to exit the installation wizard. 

15. If prompted, restart the computer. 
 

To verify the phase 2 failover configuration: 

1. Go to Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > Interface Configuration Utility. The Interface 
Configuration Utility dialog box appears. 

2. From the Interface list, select the interface that you have 
upgraded. 

3. On the left pane, click Failover. 

4. Under UniInt Failover, verify that the following settings are 
correct: 

• The phase 2 is selected. 

• The failover IDs point to the correct interface machines. 

• The UFO Type is set to HOT. 

Verify the Phase 2 Failover 
Configuration 
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• The synchronization file path is set correctly. 

 

NOTE For more information on configuring phase 2 failover, see the 
FactoryTalk Historian SE Installation and Configuration Guide, 
chapter "Configuring Live Data Interface Redundancy". 

 

 

To verify the buffering configuration: 

1. Go to Start > All Programs > Rockwell Software > FactoryTalk 
Historian SE > Interface Configuration Utility. The Interface 
Configuration Utility dialog box appears. 

2. From the Interface list, select the interface that you have 
upgraded. 

3. On the left pane, click Service. 

Verify the Buffering 
Configuration 
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4. Under Service Configuration, make sure that PIBufss is 
listed as one of the dependencies. 

 
 

To create and run the Live Data interface service: 

1. In the Interface Configuration Utility, select the interface you 
have upgraded. 

2. On the left pane, click FTLDInt. 

3. Under Additional parameters, type /MultiCOM. 

 
4. On the left pane, click Service. 

5. Under Service Configuration, perform the following actions: 

• For a single Live Data Interface: 

In this text box: Do the following: 
Display name Change to FTLD1. 

• For Live Data interfaces in a failover mode: 

In this text box: Do the following: 

Create and Run the Live 
Data Interface Service 
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In this text box: Do the following: 
Display name Change to FTLD1. 
Log on as Type the name of the user that has access to the .DAT 

file (page 87) specified in the synchronization file path. 
Password Type the password for the user. 
Confirm password Retype the password. 

 
6. Click Create, and then Apply. 

The interface service is created and the status at the bottom of 
the dialog box changes to Ready. 

7. From the toolbar, click  to start the interface. 

8. In the message box that appears, click Yes to start the PIBufss 
service. 

9. The interface service is started and the status at the bottom of 
the dialog box changes to Running. 

NOTE To verify if the interface is functioning properly, refer to the 
FactoryTalk Historian SE Installation and Configuration Guide, 
chapter "Configuring Live Data Interface Redundancy". 
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Chapter 5 

Upgrading Engineering Workstations 

NOTE FactoryTalk Historian Management Tools of FactoryTalk Historian SE 3.01 
are supported on FactoryTalk Services Platform SR4, SR5 and SR5.1. If 
you currently have either SR4 or SR5 installed, it is your choice whether 
to upgrade to SR5.1 or not. In general, it is considered best practice to 
upgrade FactoryTalk Services Platform to the latest version. 

The migration and upgrade to FactoryTalk Historian SE 3.01 
requires that you upgrade your engineering workstations on which 
you have FactoryTalk Historian Management Tools installed. 

To upgrade engineering workstations: 

1. Remove FactoryTalk Historian Management Tools 2.2/2.1. 

1. Go to Start > All Programs > Rockwell Software > 
FactoryTalk Historian SE Uninstall FactoryTalk Historian 
SE Management. The installation wizard appears. 

2. Follow the on-screen instructions to complete the process. 

2. (Optional) Upgrade FactoryTalk Services Platform. 

1. On the FactoryTalk Historian SE 3.01 installation DVD, 
click Install FactoryTalk Historian Site Edition > Install 
FactoryTalk Services Platform > Install FactoryTalk Services 
Platform. 

2. Follow the on-screen instructions to complete the process. 

3. Install FactoryTalk Historian Management Tools 3.01. 

1. On the FactoryTalk Historian SE 3.01 installation DVD, 
click Install FactoryTalk Historian Site Edition > Install 
FactoryTalk Historian Management Tools. 

2. Follow the on-screen instructions to complete the process. 

Upgrade Steps 
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3. If prompted, restart the computer. 
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