**Important user information**

Read this document and the documents listed in the additional resources section about installation, configuration, and operation of this equipment before you install, configure, operate, or maintain this product. Users are required to familiarize themselves with installation and wiring instructions in addition to requirements of all applicable codes, laws, and standards.

Activities including installation, adjustments, putting into service, use, assembly, disassembly, and maintenance are required to be carried out by suitably trained personnel in accordance with applicable code of practice. If this equipment is used in a manner not specified by the manufacturer, the protection provided by the equipment may be impaired.

In no event will Rockwell Automation, Inc. be responsible or liable for indirect or consequential damages resulting from the use or application of this equipment.

The examples and diagrams in this manual are included solely for illustrative purposes. Because of the many variables and requirements associated with any particular installation, Rockwell Automation, Inc. cannot assume responsibility or liability for actual use based on the examples and diagrams.

No patent liability is assumed by Rockwell Automation, Inc. with respect to use of information, circuits, equipment, or software described in this manual.

Reproduction of the contents of this manual, in whole or in part, without written permission of Rockwell Automation, Inc., is prohibited.

Throughout this manual, when necessary, we use notes to make you aware of safety considerations.

---

**WARNING:** Identifies information about practices or circumstances that can cause an explosion in a hazardous environment, which may lead to personal injury or death, property damage, or economic loss.

**ATTENTION:** Identifies information about practices or circumstances that can lead to personal injury or death, property damage, or economic loss. Attentions help you identify a hazard, avoid a hazard, and recognize the consequence.

**Important:** Identifies information that is critical for successful application and understanding of the product.

Labels may also be on or inside the equipment to provide specific precautions.

**SHOCK HAZARD:** Labels may be on or inside the equipment, for example, a drive or motor, to alert people that dangerous voltage may be present.

**BURN HAZARD:** Labels may be on or inside the equipment, for example, a drive or motor, to alert people that surfaces may reach dangerous temperatures.

**ARC FLASH HAZARD:** Labels may be on or inside the equipment, for example, a motor control center, to alert people to potential Arc Flash. Arc Flash will cause severe injury or death. Wear proper Personal Protective Equipment (PPE). Follow ALL Regulatory requirements for safe work practices and for Personal Protective Equipment (PPE).

---

Allen-Bradley, Rockwell Software, Rockwell Automation, and TechConnect are trademarks of Rockwell Automation, Inc.

Trademarks not belonging to Rockwell Automation are property of their respective companies.
## Table of contents

### Chapter 1

**What you need to get started**
- Required software............................................................ 9
- Recommended hardware and supported operating systems.......................... 10
  - Logix5000 controllers......................................................... 10
  - Compatible firmware .......................................................... 12
  - Older controllers ................................................................. 12
- How to get the information you need...................................................... 12

### Chapter 2

**Overview of FactoryTalk Alarms and Events services**
- Choose between HMI Tag Alarm Monitoring and FactoryTalk Alarms and Events........ 16
- Where to start.............................................................................. 18
- FactoryTalk Alarms and Events components ........................................ 19
- About monitoring for alarm conditions.............................................. 21
  - About device-based alarm monitoring........................................ 21
    - Device-based alarm monitoring workflow.................................. 21
  - About software-based alarm monitoring...................................... 23
    - Tag-based alarm monitoring workflow..................................... 23
- Choose between device-based and tag-based alarm monitoring..................... 24
- Graphic objects in FactoryTalk Alarms and Events.................................... 24

### Chapter 3

**Plan your system**
- Decide what type of application you are building..................................... 25
- Decide what type of alarm monitoring you need........................................ 26
- What you need.............................................................................. 26
- Follow these steps.......................................................................... 27
- Install and activate FactoryTalk software............................................. 27
  - Typical stand-alone system......................................................... 28
- Install FactoryTalk software............................................................ 28
- Install Microsoft SQL Server .......................................................... 29

### Chapter 4

**Define device-based alarms in Logix5000 controllers**
- Alarm buffering during loss of connection to the controller....................... 31
- Before you begin............................................................................ 32
- What you need.............................................................................. 32
- Follow these steps.......................................................................... 33
- Define a digital alarm...................................................................... 33
  - Configure the alarm and download to the controller.......................... 33
- Define an analog alarm................................................................... 45
# Table of contents

Configure the alarm and download it to the controller ........................................ 46

## Chapter 5

**Add a device server for Logix5000, PLC-5, or SLC 500 controllers**

- Before you begin .................................................................................................. 59
- What you need .................................................................................................... 59
- Follow these steps ............................................................................................... 60
- Add a device server ............................................................................................ 60

## Chapter 6

**Add an OPC Data Server for third-party controllers**

- Before you begin ................................................................................................. 71
- What you need .................................................................................................... 71
- Follow these steps ............................................................................................... 72
- Add an OPC Data Server to an application ....................................................... 72

## Chapter 7

**Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers**

- Before you begin ................................................................................................. 77
- What you need .................................................................................................... 77
- Follow these steps ............................................................................................... 78
- Create an application .......................................................................................... 78
- Add a data server ............................................................................................... 81
- Add a Tag Alarm and Event Server ................................................................... 84
- Define alarm conditions ...................................................................................... 85
- Next steps ............................................................................................................ 88

## Chapter 8

**Set up graphic displays**

- Before you begin ............................................................................................... 89
- What you need .................................................................................................... 89
- Follow these steps ............................................................................................... 90
- Create a graphic display ...................................................................................... 90
- Create an Alarm and Event Summary ................................................................. 92
- Create an Alarm and Event Banner display ..................................................... 95
- Create a startup macro for the Banner display ................................................. 101
- Use color animation to indicate alarm state changes ....................................... 104
- Next steps ............................................................................................................ 113

## Chapter 9

**Monitor and interact with alarms at run time**

- Before you begin ............................................................................................... 115
- What you need .................................................................................................... 115
- Follow these steps ............................................................................................... 116
- Create and then run a FactoryTalk View Client configuration ....................... 116
- Monitor alarms and events .................................................................................................................. 125
- Security for alarms and events ............................................................................................................... 126
- Acknowledge an alarm ............................................................................................................................. 126
  - Acknowledge the selected alarm ........................................................................................................... 126
  - Acknowledge the selected alarm and enter a comment ........................................................................ 127
  - Acknowledge all of the alarms displayed on the page ................................................................. 128
  - Acknowledge all of the alarms in the event list .............................................................................. 129
- Disable or enable an alarm ...................................................................................................................... 129
  - Disable selected alarms ....................................................................................................................... 130
  - Enable selected alarms ....................................................................................................................... 131
- Suppress or unsuppress an alarm ........................................................................................................... 132
  - Suppress an alarm ............................................................................................................................... 133
  - Unsuppress an alarm ........................................................................................................................... 133
- Shelve or unshelve an alarm .................................................................................................................... 135
  - Shelve an alarm ................................................................................................................................. 135
  - Unshelve an alarm ............................................................................................................................ 137

**Chapter 10**

- Set up historical alarm and event logging
  - Before you begin .................................................................................................................................. 142
  - What you need ..................................................................................................................................... 142
  - Follow these steps ............................................................................................................................... 143
  - Confirm that the SQL Server software is installed ........................................................................... 143
  - Add a database definition to your FactoryTalk system ................................................................... 144
  - Associate a database definition with an alarm server ..................................................................... 147
  - Create an Alarm and Event Log Viewer display ............................................................................... 152
    - Create a button to open the Alarm and Event Log Viewer display ............................................. 155
  - Create a startup macro for the Menu Bar display ........................................................................... 161
  - View historical alarm data in a FactoryTalk View SE Client ............................................................ 163
    - Run the application ......................................................................................................................... 163
      - Start the FactoryTalk View SE Client from within FactoryTalk View Studio .................................... 163

**Chapter 11**

- Configure redundancy for alarms and events
  - FactoryTalk server redundancy ........................................................................................................... 167
  - Develop and test your application without redundancy .................................................................... 167
  - Before you begin .................................................................................................................................. 168
  - What you need ..................................................................................................................................... 169
  - Follow these steps ............................................................................................................................... 170
  - Upgrade an existing device-based alarm server .................................................................................. 171
  - Upgrade an existing tag-based alarm server ...................................................................................... 174
  - Check the status of an alarm server ..................................................................................................... 175
Appendix A

Before you begin .............................................................................................................. 177
What you need ................................................................................................................. 178
Follow these steps ............................................................................................................ 179
Create device-based alarm messages ............................................................................. 179
  Translate alarm messages using import and export ...................................................... 180
    Translate alarm messages in RSLogix 5000 version 16 or earlier .......................... 180
    Translate alarm messages using RSLogix 5000 version 17 or later ..................... 183
Create tag-based alarm messages ................................................................................ 186
  Enter text strings in FactoryTalk View Studio ......................................................... 186
Add languages to the application .................................................................................. 191
Add buttons to a graphic display to switch languages at run time .............................. 193
Enter alarm messages in other languages ................................................................... 198
Create a Display Client configuration file to test alarm messages .............................. 208
Test alarm messages at run time .................................................................................... 215
Summary and tips for setting up language switching .................................................. 218
  Text that supports language switching ...................................................................... 218
  Text that does not support language switching ....................................................... 218
  Alarm and Event Summary and Alarm and Event Banner ...................................... 219
  Alarm and Event Log Viewer ..................................................................................... 219

Appendix B

System performance and limits

Controller specifications ................................................................................................ 221
  Controllers with revision 24 and later ..................................................................... 221
  Controllers with revision 20 or earlier .................................................................... 221
Tested system limits ....................................................................................................... 222
  Tested topology: redundant ....................................................................................... 223

Appendix C

Install FactoryTalk Alarms and Events manually

Summary of steps .......................................................................................................... 225
Confirm that FactoryTalk Services Platform is installed ............................................. 226
Install FactoryTalk Alarms and Events ....................................................................... 226

Appendix D

Install SQL Server 2014 SP2 Express

Operating systems .......................................................................................................... 227
Summary of steps .......................................................................................................... 228
  Step 1. Open the FTView folder ................................................................................. 228
  Step 2. Install the .NET Framework ........................................................................ 228
  Step 3. Run the SQL Server Install batch file (not the .exe) ...................................... 229
  Step 4. Configure the Windows firewall ................................................................... 230
Appendix E

Use an Existing SQL Server database

Supported SQL Server databases ................................................................. 233
Remote connections to the SQL Server database ........................................... 233
Summary of steps........................................................................................... 233
  Step 1. Install SQL Server Management Tools ............................................. 233
  Step 2. Specify Mixed Mode authentication for the SQL Server database ... 234
  Step 3. Configure TCP/IP protocol for the database .................................. 235
  Step 4. Enable the SQL Server Browser service ......................................... 235
  Step 5. Configure the Windows Firewall ..................................................... 235

Appendix F

Alarm time stamping

Overview of time keeping.............................................................................. 237
  Coordinated System Time (CST) ................................................................. 237
  Coordinated Universal Time (UTC) ............................................................. 238
  Local Time (Wall Clock Time) ................................................................. 238
  ALMD and ALMA alarm blocks ............................................................... 239
    Insert time stamps manually ................................................................. 242
  Example .................................................................................................... 242

Time synchronization

Coordinate multiple controller wall clocks .................................................... 243
Install the Logix5000 Clock Update Tool ..................................................... 244
Start the Logix5000 Clock Update Tool ....................................................... 244
  Start the Update Tool automatically ....................................................... 244
Use the Logix5000 Clock Update Tool ........................................................ 245
Synchronize devices on a schedule .............................................................. 245
  Create a synchronization schedule ......................................................... 246
    Create a synchronization schedule .................................................... 246
    Remove a synchronization schedule .................................................... 246
    Modify a synchronization schedule ..................................................... 247
    Enable or disable a synchronization schedule .................................. 247
Add devices ................................................................................................ 247
  To add a device: ...................................................................................... 247
Remove a device .......................................................................................... 248
View details about a device ...................................................................... 249
Assign devices to synchronization schedules ............................................ 249
Synchronize devices manually ................................................................. 250
View the log file ......................................................................................... 250
  Change the location of the log file ......................................................... 250
Time stamps with tag-based alarms .......................................................... 251
Supported devices ..................................................................................... 251
Appendix H

Reference for building a distributed system

When installing FactoryTalk Alarms & Events .......................................................... 253
Typical distributed system on a network ................................................................. 253

Appendix I

Language identifiers for language switching

Language identifiers .................................................................................................. 255

Appendix J

Glossary

Legal Notices

Index
Chapter 1

What you need to get started

The FactoryTalk® System Configuration Guide describes the tasks that are required to install, configure, and use FactoryTalk Alarms and Events services as part of a FactoryTalk-enabled automation system. This guide also includes references to additional documentation that provides more detail.

Important: This guide describes how to set up a local station application. However, the procedure for setting up a network station application or network distributed application is similar. This guide provides information about the latter two applications where it is necessary. See the Help included with the individual software products used to configure and use Alarms and Events services.

The following software is required to configure and operate FactoryTalk Alarms and Events services:

<table>
<thead>
<tr>
<th>Software</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>FactoryTalk Services Platform</td>
<td>2.10 or later</td>
</tr>
<tr>
<td>FactoryTalk Alarms and Events</td>
<td>2.10 or later (included with FactoryTalk View Site Edition and RSLinx® Enterprise)</td>
</tr>
<tr>
<td>RSLinx Enterprise</td>
<td>5.00 or later</td>
</tr>
<tr>
<td>Logix5000™</td>
<td>16.03 or later (or the Logix Designer application version 21.00 or later)</td>
</tr>
<tr>
<td>Logix Designer</td>
<td>21.00 or later (or RSLinx 500® software version 16.03 or later)</td>
</tr>
<tr>
<td>RSLinx 500</td>
<td>Version that supports FactoryTalk Services Platform 2.10 or later</td>
</tr>
<tr>
<td>RSLinx 5</td>
<td>Version that supports FactoryTalk Services Platform 2.10 or later</td>
</tr>
<tr>
<td>FactoryTalk View SE</td>
<td>5.00 or later</td>
</tr>
<tr>
<td>FactoryTalk View Studio</td>
<td>5.00 or later</td>
</tr>
<tr>
<td>RSLinx Classic (used for Logix programming)</td>
<td>2.50.20 or later</td>
</tr>
<tr>
<td>ControlFLASH™</td>
<td>4.00.09 (used to download firmware)</td>
</tr>
<tr>
<td>SoftLogix™</td>
<td>16.03 or later</td>
</tr>
<tr>
<td>Microsoft® SQL Server®</td>
<td>Version that supports FactoryTalk Alarms and Events historical logging. For more information, see Supported SQL Server databases on page 233. SQL Server 2014 SP2 Express is provided on the FactoryTalk View installation DVD for CPR 9 SR 9. For installation instructions, see Install Microsoft SQL Server 2014 SP2 Express on page 227.</td>
</tr>
</tbody>
</table>
Recommended hardware and supported operating systems

Logix5000 controllers

The hardware and supported operating systems that are recommended to run FactoryTalk Alarms and Events are the same as those recommended to run FactoryTalk View Site Edition. For details, see the FactoryTalk View Site Edition Installation Guide. To access the guide, in the FactoryTalk View Studio toolbar click Help, point to Online Books, and then click Installation Guide.

The Logix5000 controllers listed in the following table support FactoryTalk Alarms and Events services. When you use built-in alarm instructions in Logix5000 controllers, these controllers require a firmware update to revision 16.20 or later (excluding 21 to 23). If you do not want to update the firmware in your controllers, use a Tag Alarm and Event Server for software-based alarms and events. See Decide what type of alarm monitoring you need on page 26.

<table>
<thead>
<tr>
<th>Catalog number</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1756-L61</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>1756-L62</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>1756-L63</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>1756-L64</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>1756-5555</td>
<td>5555 ControlLogix Processor</td>
</tr>
<tr>
<td>1768-L43</td>
<td>CompactLogix L43 Controller</td>
</tr>
<tr>
<td>1769-L31</td>
<td>CompactLogix L31 Controller</td>
</tr>
<tr>
<td>1769-L32C</td>
<td>CompactLogix L32C Controller</td>
</tr>
<tr>
<td>1769-L32E</td>
<td>CompactLogix L32E Controller</td>
</tr>
<tr>
<td>1769-L35CR</td>
<td>CompactLogix L35CR Controller</td>
</tr>
<tr>
<td>1769-L35E</td>
<td>CompactLogix L35E Controller</td>
</tr>
<tr>
<td>1794-L34</td>
<td>FlexLogix L34 Controller</td>
</tr>
<tr>
<td>1756-L61S</td>
<td>ControlLogix Safety Processor</td>
</tr>
<tr>
<td>1756-L62S</td>
<td>ControlLogix Safety Processor</td>
</tr>
<tr>
<td>PowerFlex 700S 2</td>
<td>DriveLogix5370</td>
</tr>
<tr>
<td>1789-L60</td>
<td>SoftLogix5800</td>
</tr>
<tr>
<td>EMULATE</td>
<td>RSLinx Emulate 5000</td>
</tr>
</tbody>
</table>

The following controllers with firmware revision 24 and later support FactoryTalk Alarms and Events services:

<table>
<thead>
<tr>
<th>Catalog number</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>ControlLogix 1756-L71 Series B</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L71S Series B</td>
<td>ControlLogix Safety Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L72 Series A</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L72 Series B</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>GuardLogix 1756-L72S Series B</td>
<td>ControlLogix Safety Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L73 Series A</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L73 Series B</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L73XT Series B</td>
<td>ControlLogix Processor</td>
</tr>
</tbody>
</table>
### What you need to get started

#### Chapter 1

**GuardLogix 1756-L73S Series B**
- ControlLogix Safety Processor

**GuardLogix 1756-L73SXT Series B**
- ControlLogix Safety Processor

**ControlLogix 1756-L74 Series A**
- ControlLogix Processor

**ControlLogix 1756-L74 Series B**
- ControlLogix Processor

**ControlLogix 1756-L75 Series A**
- ControlLogix Processor

**ControlLogix 1756-L75 Series B**
- ControlLogix Processor

**CompactLogix 1769-L16ER-BB1B**
- CompactLogix L16ER-BB1B Controller

**CompactLogix 1769-L18ER-BB1B**
- CompactLogix L18ER-BB1B Controller

**CompactLogix 1769-L18ERM-BB1B**
- CompactLogix L18ERM-BB1B Controller

**CompactLogix 1769-L24ER-QB1B**
- CompactLogix L24ER-QB1B Controller

**CompactLogix 1769-L24ER-QBFC1B**
- CompactLogix L24ER-QBFC1B Controller

**CompactLogix 1769-L27ERM-QBFC1B**
- CompactLogix L27ERM-QBFC1B Controller

**CompactLogix 1769-L30ER**
- CompactLogix L30ER Controller

**CompactLogix 1769-L30ER-NSE**
- CompactLogix L30ER-NSE Controller

**CompactLogix 1769-L30ERM**
- CompactLogix L30ERM Controller

**CompactLogix 1769-L33ER**
- CompactLogix L33ER Controller

**CompactLogix 1769-L33ERM**
- CompactLogix L33ERM Controller

**CompactLogix 1769-L36ERM**
- CompactLogix L36ERM Controller

**SoftLogix 1789-L60**
- SoftLogix5800

---

**Tip:** Firmware revisions 21 to 23 do not support the new alarms functionality.

The following controllers with firmware revision 29 introduce support for FactoryTalk Alarms and Events services:

<table>
<thead>
<tr>
<th>Catalog number</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>ControlLogix 1756-L81E</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L82E</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L83E</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L84E</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>ControlLogix 1756-L85E</td>
<td>ControlLogix Processor</td>
</tr>
<tr>
<td>CompactLogix 5069-L306ER</td>
<td>CompactLogix L306ER Controller</td>
</tr>
<tr>
<td>CompactLogix 5069-L306ERM</td>
<td>CompactLogix L306ERM Controller</td>
</tr>
<tr>
<td>CompactLogix 5069-L310ER</td>
<td>CompactLogix L310ER Controller</td>
</tr>
<tr>
<td>CompactLogix 5069-L310ERM</td>
<td>CompactLogix L310ERM Controller</td>
</tr>
<tr>
<td>CompactLogix 5069-L310ER-NSE</td>
<td>CompactLogix L306ER-NSE Controller</td>
</tr>
<tr>
<td>CompactLogix 5069-L320ER</td>
<td>CompactLogix L320ER Controller</td>
</tr>
<tr>
<td>CompactLogix 5069-L320ERM</td>
<td>CompactLogix L320ERM Controller</td>
</tr>
<tr>
<td>CompactLogix 5069-L330ER</td>
<td>CompactLogix L330ER Controller</td>
</tr>
<tr>
<td>CompactLogix 5069-L330ERM</td>
<td>CompactLogix L330ERM Controller</td>
</tr>
</tbody>
</table>
Chapter 1  What you need to get started

The following controllers with firmware revision 30 introduce support for FactoryTalk Alarms and Events services:

<table>
<thead>
<tr>
<th>Catalog number</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>CompactLogix 5069-L340ER</td>
<td>CompactLogix L340ER Controller</td>
</tr>
<tr>
<td>CompactLogix 5069-L340ERM</td>
<td>CompactLogix L340ERM Controller</td>
</tr>
</tbody>
</table>

The controller firmware revisions listed in the following table are compatible with FactoryTalk Alarms and Events services:

<table>
<thead>
<tr>
<th>Controller</th>
<th>Firmware revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>ControlLogix</td>
<td>16.20 or higher (excluding 21 to 23)</td>
</tr>
<tr>
<td>CompactLogix L3x and L4x</td>
<td></td>
</tr>
<tr>
<td>DriveLogix</td>
<td></td>
</tr>
<tr>
<td>ControlLogix Redundant Systems</td>
<td>16.60 or higher (excluding 21 to 23)</td>
</tr>
<tr>
<td>SoftLogix</td>
<td>16.03 or higher (excluding 21 to 23)</td>
</tr>
</tbody>
</table>

These controllers also support FactoryTalk Alarms and Events services:

- Logix5000 controllers that communicate with RSLinx Enterprise, using Tag Alarm and Event Servers.
- PLC-5® and SLC™ 500 controllers that communicate with RSLinx Enterprise (or RSLinx Classic to bridge from Ethernet to DH+™ or DH-485 networks), using Tag Alarm and Event Servers.
- Third-party PLCs that communicate with OPC® Data Servers such as KEPWare, using Tag Alarm and Event Servers.

For more information about the products and components discussed in this guide, the following manuals and Help files are available:

- FactoryTalk Help (Start > All Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk Help)
- RSLinx 5000 Help (for help with developing a controller project)
- RSLinx 5000 Quick Start
- RSLinx 5000 Online Books

Compatible firmware

Older controllers

How to get the information you need


• RSLinx Classic Help (for help with configuring drivers and creating topics)

• RSLinx Classic Quick Start Guide

• RSLinx Enterprise Getting Results Guide

• RSLinx Enterprise Help
Overview of FactoryTalk Alarms and Events services

FactoryTalk Alarms and Events was introduced with FactoryTalk Services Platform 2.0 (CPR 9) and FactoryTalk View Site Edition 5.0 (CPR 9) to provide a common, consistent view of alarms and events throughout a FactoryTalk system. Beginning with FactoryTalk Alarms and Events 2.30 (CPR 9 SR 3), device-based and tag-based servers support redundant server configuration.

FactoryTalk View Site Edition HMI tag alarm monitoring is still supported to maintain compatibility with existing applications.

FactoryTalk Alarms and Events supports two types of alarm monitoring:

- **Device-based alarm monitoring.** Built-in alarm instructions, that are available in the Logix Designer application (RSLogix 5000 software version 16 or later), are programmed in a logic project and then downloaded to a Logix5000 controller. The controller detects alarm conditions and publishes event information, which can be displayed and logged.

- **Tag-based alarm monitoring.** If you are not using Logix5000 controllers, or if you do not want to use the built-in alarm instructions that are available with the Logix Designer application, tag-based alarm monitoring offers the equivalent of HMI tag alarm monitoring, but with an expanded feature set. Software-based Tag Alarm and Event servers monitor controllers for alarm conditions through data servers and publish event information that can be displayed and logged. Tag-based alarm monitoring is supported for Logix5000 controllers, PLC-5, and SLC 500 devices communicating through Rockwell Automation device servers (RSLinx Enterprise), or for third-party controllers communicating through OPC Data Servers.

FactoryTalk Alarms and Events:

- **Provides a single, integrated set of alarm information.** All participating FactoryTalk products work together to provide a consistent way to define, manage, log, and view alarm and event information across a FactoryTalk application.

- **Streamlines alarm programming and eliminates polling with device-based alarm monitoring.** If your automation system includes Logix5000 controllers, you can use pre-built alarm instructions, available in
the Logix Designer application (RSLogix 5000 software version 16 or later),
to simplify coding, and then download them to the controller. Device-based
alarm monitoring eliminates the need for duplicating alarm tags in an HMI
server and requires fewer controller communication resources by
eliminating polling.

- **Supports other controllers in the integrated system with tag-based
  alarm monitoring.** If your automation system includes other Rockwell
  Automation controllers, such as PLC-5s or SLC 500s, or if you prefer not to
  use the new alarm instructions with Logix5000 controllers, software-based
tag servers monitor controllers for alarm conditions and publish event
information.

- **Monitors alarms and events from third-party controllers.** Tag-based
  alarm monitoring also makes it possible to monitor alarm conditions from
  third-party controllers, which communicate through OPC Data Servers.

- **Provides accurate time stamps on alarm conditions** that are generated
  from Logix5000 controllers using device-based alarm monitoring. When
  you use device-based alarm monitoring, timestamps are applied immediately
  in the controller and are not delayed until alarms reach an HMI server. To
  make sure that the timestamps on device-based alarms are accurate,
synchronize the clocks of all controllers that produce alarms. The event
time is propagated throughout the FactoryTalk Alarms and Events system,
so inaccurate timestamps can affect where alarms are displayed in the Alarm
and Event Summary or the Alarm and Event Banner as well as reports about
the alarm and event history. For more information about synchronizing
controller clocks, see [Time synchronization on page 243.](#)

- **Sends process data with events and messages.** You can associate up to
  four tags with each alarm to include process data with event information
  and alarm messages.

- **Secures access to alarm and event operations** through integration with
  FactoryTalk Security.

- **Generates messages for logging.** Log messages include audit messages
  that track operator actions, system-related diagnostic messages, and historical
  alarm and event messages.

- **Shows alarm messages and status information** at run time, in FactoryTalk
  View graphic displays.

**Choose between HMI Tag
Alarm Monitoring and
FactoryTalk Alarms and
Events**

HMI tag alarm monitoring and FactoryTalk Alarms and Events are two separate
alarm monitoring systems that do not share alarm information with each other.
FactoryTalk tag-based and device-based alarm information can only be displayed
in the FactoryTalk alarm and event objects. FactoryTalk View HMI tag alarm
information cannot be displayed in FactoryTalk alarm and event objects.
If you are already using HMI tag alarm monitoring in existing applications you can continue using it. However, to take advantage of the new features of FactoryTalk Alarms and Events you will need to migrate your existing alarm monitoring system to FactoryTalk Alarms and Events.

Migrate to FactoryTalk Alarms and Events if you want to:

- Use device-based alarm monitoring. You can use a Logix5000 controller not only to detect alarms, but also to monitor alarms. This keeps all alarm and event processing in the controller. To use device-based alarm monitoring, add the built-in alarm instructions, available in the Logix Designer application (or RSLogix 5000 software version 16 or later), to a logic project and then download the project to a Logix5000 controller. The controller detects alarm conditions and publishes event information, which can be displayed and logged.

- Use language-switching with alarm messages. Language switching is not supported for alarm messages when you use HMI tag alarm monitoring in FactoryTalk View Site Edition. FactoryTalk View Machine Edition supports language-switching with alarm messages in version 5.0 or later.

- Take advantage of the richer feature set offered by FactoryTalk Alarms and Events, including:
  - Redundant software-based Tag Alarm and Event servers that monitor controllers for alarm conditions through data servers and publish event information that can be displayed and logged.
  - Configurable Alarm and Event Summary that includes the ability to suppress alarms directly from the summary, without the use of separate commands.
  - Alarm and Event Banner, Alarm and Event Log Viewer, and Alarm Status Explorer objects that are hosted in graphic displays. You can use the **Alarm Status Explorer** to enable or disable alarms, suppress or unsuppress alarms, shelve or unshelve alarms, and view operator comments.
  - System-wide views in the Alarm and Event Banner, rather than just the alarms in a single HMI server exposed by the system\AlarmBanner system tag.
Where to start

Here is an overview of the sections covered in this guide:
The following diagram shows a high-level view of the components of the FactoryTalk Alarms and Events system. For more detailed information, see FactoryTalk Alarms and Events Help. In Windows, click Start > All Programs > Rockwell Software > FactoryTalk Alarms and Events > User Documentation > FactoryTalk Alarms and Events Help.

1. **Device-based alarm monitoring**

   To configure device-based alarm monitoring, you program alarm instructions available in the Logix Designer application (RSLogix 5000 software version 16 or later), and then download them to Logix5000 controllers. The controller detects alarm conditions and notifies a Rockwell Automation device server (RSLinx Enterprise) of alarm states. RSLinx Enterprise extracts the alarm information and publishes it to FactoryTalk Alarms and Events services.

   Use device-based alarm monitoring with:
• Logix5000 controllers, that you have programmed with the Logix Designer application (RSLogix 5000 software version 16 or later), and Rockwell Automation device servers (RSLinx Enterprise).

2. **Tag-based alarm monitoring**

The Tag Alarm and Event Server uses tags to monitor programmable controllers for alarm conditions. When an alarm condition is detected, the server publishes the information to FactoryTalk Alarms and Events services.

Use tag-based alarm monitoring with:
• PLC-5 or SLC 500 devices, and Rockwell Automation device servers (RSLinx Enterprise)
• RSLinx Classic or RSLinx Gateway
• Third-party controllers and OPC Data Servers
• Logix5000 controllers

3. **FactoryTalk Alarms and Events services**

Both device-based and tag-based alarms and events are published to FactoryTalk Alarms and Events services, which then routes the information to FactoryTalk Alarms and Events objects hosted in FactoryTalk View, to the alarm and event history log, and to diagnostic logs and audit logs.

4. **Alarm and Event Historian and Log**

The Alarm and Event Historian is a logging component that installs silently as part of the alarms and events software. It manages connections between alarm servers and databases and logs data from each alarm server to an alarm history database. You can use the Alarm and Event Log Viewer to view and print data from alarm history databases. Third-party database tools can also retrieve, view, analyze, and print alarm history information.

To use alarm and event logging, install Microsoft SQL Server separately, or use an existing Microsoft SQL Server database.

5. **Diagnostic and audit logs**

FactoryTalk Diagnostics routes messages generated by FactoryTalk Alarms and Events to local logs on the computers hosting FactoryTalk components, and optionally to a centralized database log. Audit messages are also routed to the local log and to the FactoryTalk Audit Log if FactoryTalk AssetCentre is installed.
6. **Alarm and event setup and monitoring**

FactoryTalk Alarms and Events includes a number of software components that allow engineers and operators to define alarm conditions, set up alarm servers, view and interact with alarm conditions, and view and run reports on historical alarm information:

<table>
<thead>
<tr>
<th>Component Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm and Event Summary</td>
<td>Use the Alarm and Event Summary object, embedded in a FactoryTalk View graphic display, to view and interact with the most recent unacknowledged alarms.</td>
</tr>
<tr>
<td>Alarm and Event Banner</td>
<td>Use the Alarm and Event Banner object, embedded in a FactoryTalk View graphic display, to monitor and respond to the most serious alarms that require immediate attention.</td>
</tr>
<tr>
<td>Alarm Status Explorer</td>
<td>Use the Alarm Status Explorer object, embedded in a FactoryTalk View graphic display, to view and interact with all alarms.</td>
</tr>
<tr>
<td>Database definitions</td>
<td>Use database definitions to define logging options from an alarm server to a Microsoft SQL Server database.</td>
</tr>
<tr>
<td>Alarm and Event Log Viewer</td>
<td>Use the Alarm and Event Log Viewer object, embedded in a FactoryTalk View graphic display, to view and filter historical alarm information stored in Microsoft SQL Server databases.</td>
</tr>
<tr>
<td>Diagnostics Viewer</td>
<td>Use the Diagnostics Viewer to view, filter, and export system-generated diagnostic messages. Run the Diagnostics Viewer from either FactoryTalk View Studio or FactoryTalk Administration Console.</td>
</tr>
<tr>
<td>FactoryTalk Audit Log</td>
<td>Use the FactoryTalk Audit Log to view and manage audit messages routed by FactoryTalk Diagnostics. To access the Audit Log, use the FactoryTalk AssetCentre software.</td>
</tr>
</tbody>
</table>

**About monitoring for alarm conditions**

You can monitor for alarm conditions in either of two ways--using device-based alarm monitoring, or software-based alarm monitoring.

**About device-based alarm monitoring**

With device-based alarm monitoring, detection and monitoring for alarm conditions are both done in the controller. This is in contrast to software-based alarm monitoring, where alarm detection occurs in the controller, but alarm monitoring is performed by software-based servers.

**Device-based alarm monitoring workflow**
This approach has several advantages over tag- or software-based alarm detection:

- Alarm instructions are programmed only once, and then downloaded to the controller, which reduces programming effort and errors.
- Alarm conditions are detected more quickly.
- Alarms are detected at the same time the logic is being executed.
- HMI tags or alarms in a Tag Alarm and Event Server are not required, which reduces overhead and potential tag mapping errors.
- Alarm state is managed, processed, and preserved by controllers, even if a computer is stopped.
- Data polling is eliminated and Alarm status is communicated only when state changes, which reduces network overhead, controller processing, and improves overall system performance.
- Time stamps on alarm conditions are precise, because they are applied in the controller, and not delayed until they reach the HMI software or Tag Alarm and Event Server. However, all controllers that produce alarms must have their clocks synchronized because device-based alarms are stamped with the controller’s time. The event time is published throughout the FactoryTalk Alarms and Events system, so inaccurate time stamps can affect where alarms are displayed in the Alarm and Event Summary, the Alarm and Event Banner, or in reports based on the alarm and event history. For more information about synchronizing controller clocks, see Time synchronization on page 243.
HMI tag alarm monitoring, offered by FactoryTalk View Site Edition (SE), and tag-based alarm monitoring, offered by FactoryTalk Alarms and Events, are both examples of software-based alarm monitoring.

Software-based alarm monitoring is a generic way of monitoring alarms from legacy or third-party controllers.

With software-based alarm monitoring, alarm detection occurs in the controller, but alarm monitoring is performed by software-based servers.

This approach has several disadvantages:

- Programming is required in both the controller, and the HMI software or Tag Alarm and Event Server.
- Tags must be duplicated in the HMI server and mapped to the controller. For Tag Alarm and Event Servers, controller tags must be mapped to alarms—which can be a tedious, error-prone process.
- Alarms are detected and processed twice, first in the controller logic and then again in the HMI software or Tag Alarm and Event Server.
- Polling between the HMI server or Tag Alarm and Event Server and controller tags increases network overhead.
- Alarm time stamps are delayed because they are applied by the HMI server or Tag Alarm and Event Server after polling and processing, rather than immediately when they occur. Time stamps are not synchronized among multiple alarm servers.
- Alarm acknowledge and enable states are held in the computer, and not in the controller. If the computer fails, alarm state information is lost.
Choose between device-based and tag-based alarm monitoring

Use device-based alarm monitoring with:

- Logix5000 controllers, using downloaded alarm instructions programmed with the Logix Designer application (or RSLogix 5000 software version 16 or later)

Use tag-based alarm monitoring with:

- Logix5000 controllers
- PLC-5, SLC 500 devices
- Third-party controllers that communicate through OPC Data Servers

FactoryTalk Alarms and Events graphic objects are on the Objects menu in the graphics editor in FactoryTalk View Site Edition. The HMI tag alarm monitoring objects remain available for compatibility with existing applications.

<table>
<thead>
<tr>
<th>To do this</th>
<th>In HMI tag alarm monitoring, you do it this way</th>
<th>With FactoryTalk Alarms and Events, you do it this way</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acknowledge, disable, suppress, filter, and sort alarms at run time</td>
<td>HMI Tag Alarm Summary</td>
<td>Alarm and Event Summary</td>
</tr>
<tr>
<td>Enable or disable alarms, suppress or unsuppress alarms, and view operator comments</td>
<td>HMI Tag Alarm Summary (suppress only, using the Execute feature) SuppressOn and SuppressOff commands Suppressed list</td>
<td>Alarm and Event Summary (suppress only; to unsuppress alarms, use the Alarm Status Explorer)</td>
</tr>
<tr>
<td>Monitor and respond to the most serious alarms that require immediate attention</td>
<td>Alarm system tags</td>
<td>Alarm and Event Banner</td>
</tr>
<tr>
<td>View, filter, and print historical alarm information</td>
<td>HMI Tag Alarm Log Viewer Alarms are logged to a proprietary format, and can be exported to an ODBC-compliant database.</td>
<td>Alarm and Event Log Viewer Historical alarm information is stored in Microsoft SQL Server databases.</td>
</tr>
</tbody>
</table>
Chapter 3

Plan your system

Before you build and deploy FactoryTalk Alarms and Events as part of a local or network application, consider which computer hardware and operating systems you plan to use, and where to install the various hardware and software components. The information in this chapter offers some guidelines as you begin planning. See also Required software on page 9 and Recommended hardware and supported operating systems on page 10.

You must decide whether you are building a local station application or network station application on a stand-alone computer, or a network distributed application distributed across multiple computers. This system configuration guide primarily discusses how to install, configure, and use software on a stand-alone system.

Important: FactoryTalk Alarms and Events is not supported for use with FactoryTalk View Machine Edition.

- **Network distributed applications** are held in a FactoryTalk Network Directory. Participating software products can be located on multiple computers, distributed across a network. All of the computers participating in a particular network distributed application share a common Network Directory Server located on a network computer. See Typical distributed system on a network on page 253 for a graphical overview.

  The application you create in the Network Directory can be divided into any number of areas. Each area can contain one or more sub-areas and one or more data servers. Each area or sub-area can contain only one HMI server. A network distributed application supports FactoryTalk Alarms and Events redundancy.

- **Network station applications** are held in a FactoryTalk Network Directory. All participating software products (except for data servers) must be installed on the same computer. Network station applications can connect to data servers that are located on different machines. All of the computers participating in a particular network station application share a common Network Directory Server located on a network computer. See Typical stand-alone system on page 28 for a graphical overview.

  The application you create in the Network Directory can be divided into any number of areas. Each area can contain one or more sub-areas and one or more data servers. A network station application consists of only one
Chapter 3 Plan your system

HMI server. You can add the HMI server in the root area or within the areas you have created. A network station application supports FactoryTalk Alarms and Events redundancy.

- **Local station applications** are suitable for self-contained, stand-alone processes that do not interact with other processes or systems. Local station applications are held in a FactoryTalk Local Directory and are accessible only from the local computer where they reside. Even if the computer is connected to a network and even if a network application resides on the same computer, the applications you create in the FactoryTalk Local Directory remain self-contained and do not share data or project elements.

Local station applications do not support areas, and all application components and participating software products are located on a single computer. See Typical stand-alone system on page 28 for a graphical overview.

**Important:**
To use FactoryTalk Alarms and Events with a local station application, install all software on the same computer.
FactoryTalk Alarms and Events redundancy is only supported in network station applications and network distributed applications.

**Decide what type of alarm monitoring you need**

FactoryTalk Alarms and Events supports two types of alarm monitoring:

- **Device-based alarm monitoring.** Built-in alarm instructions, that are available in the Logix Designer application (RSLogix 5000 software version 16 or later), are programmed in a logic project and then downloaded to a Logix5000 controller. The controller detects alarm conditions and publishes event information, which can be displayed and logged.

- **Tag-based alarm monitoring.** Software-based tag alarm and event servers monitor controllers for alarm conditions through data servers and publish event information, which can be displayed and logged. Tag-based alarm monitoring is supported for Logix5000, PLC-5, and SLC 500 devices communicating through Rockwell Automation device servers (RSLinx Enterprise), or for third-party controllers that communicate through OPC Data Servers.

You can use a mix of both types of alarm monitoring. Choose tag-based alarm monitoring if you do not want to change the logic in your programmable controllers, or if you do not want to update the firmware in Logix5000 controllers.

**What you need**

- Decide what type of application you are building.
- Decide what type of alarm monitoring you need.
- Install and activate FactoryTalk software.
Follow these steps

- Update Logix5000 firmware to revision 16.20 or later (excluding 21 to 23), if you plan to use device-based alarm monitoring and alarm instructions that are built into Logix5000 controllers. If you do not plan to use device-based alarm instructions, you can skip this step and use tag-based alarm monitoring with a Tag Alarm and Event Server instead.

Install and activate FactoryTalk software

Follow these procedures to install and activate the software products required for FactoryTalk Alarms and Events.
Important: This guide describes how to set up a local station application. The procedure to set up a network station application or network distributed application is similar. This guide provides additional information about the two applications where it is necessary. See also Reference for building a distributed system on page 253.

For more information about each software product, see its respective product Help.

Typical stand-alone system

To use FactoryTalk Alarms and Events with a local station application or a network station application as part of a stand-alone FactoryTalk system, install all software on the same computer. Use this diagram only as a starting point--your own system will vary.

Install FactoryTalk software

For specific installation instructions, refer to the installation guide for each product.

- To develop or run local station applications, install all the necessary software components on one computer.
- To develop or run network station applications, install all the necessary software components (except for data servers) on one computer. Network station applications can connect to data servers that are located on different machines.
- To develop or run network distributed applications, install different combinations of software on each computer, depending on your needs. For
To set up a FactoryTalk system, install the following software:

- FactoryTalk Services Platform
- FactoryTalk Activation
- FactoryTalk View Site Edition
- RSLinx Enterprise
- RSLinx Classic
- The Studio 5000 Logix Designer application (known previously as RSLogix 5000 software)
- Update Logix5000 firmware to revision 16.20 or later (excluding 21 to 23). If you plan to use device-based alarm monitoring see Decide what type of alarm monitoring you need on page 26.

Tip: To take advantage of the new alarms functionality in the v24 firmware, we recommend you install FactoryTalk Services Platform v2.71 or later and update your controller firmware to revision 24 or later.

Install Microsoft SQL Server

If you plan to log historical alarm and event messages to a database, you must install Microsoft SQL Server software on the computer you want to use for logging. If you do not have Microsoft SQL Server software installed, see Install Microsoft SQL Server 2014 SP2 Express on page 227.

Tip: If you already have Microsoft SQL Server installed, you may need to change the configuration options to log alarm and event messages. For configuration instructions, see Use an existing Microsoft SQL Server database on page 233.
Define device-based alarms in Logix5000 controllers

To set up device-based alarm monitoring, you program alarm instructions that are available with the Logix Designer application (RSLogix 5000 software version 16 or later), and download them to a Logix5000 controller. The controller detects alarm conditions and notifies alarms and events services of alarm states. Software components publish this information to a device server, where it can be logged to a database, and viewed, acknowledged, suppressed, enabled, disabled, shelved, or unshelved from FactoryTalk View graphic displays.

FactoryTalk Alarms and Events can handle many different types of alarms. The controller limits the alarms to digital and analog. An analog alarm instruction monitors two types of alarm conditions: Level and Rate of Change. A tag-based alarm server supports three alarm types: Digital, Level, and Deviation.

A digital alarm instruction is based on the input rung state (in ladder logic) or on the alarm input (for function block). The trigger condition compares the value of the tag to either zero or one.

An analog alarm defines a condition that evaluates a single analog tag against up to four limit values (high-high to low-low) and up to two rate of change limits (positive and negative).

**Tip:** If your FactoryTalk application does not include Logix5000 controllers, or if your controllers are not programmed with the alarm instructions included in the Logix Designer application (RSLogix 5000 software version 16 or later), see Add an OPC Data Server for third-party controllers on page 71 and Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.

To receive device-based alarms, the alarm server (RSLinx Enterprise) establishes a subscription to the alarms in the Logix controller. The controller maintains a connection to each subscriber and monitors the status of that connection.

As alarm state changes occur, the controller caches information such as timestamps, alarm state and associated tag values, and transmits the information to all of the subscribers.

If any subscriber fails to confirm the receipt of the alarm information, or if the connection to a subscriber is not good, the controller stores the undelivered alarm...
information in a 100 KB buffer. Each subscriber has its own buffer and communication problems with one subscriber do not interfere with alarm delivery to other subscribers. When the buffer is full, newer alarm information is discarded and a FactoryTalk Diagnostics message is logged. The buffer is created when the subscriber establishes its initial connection, and is maintained for a length of time after a subscriber loses its connection. The length of time is specified in the Buffer Timeout setting on each RSLinx Enterprise device shortcut. See step 3, "Create a new shortcut to the controller," in Add a device server on page 60.

**Important:** Firmware revision 21 to revision 23 do not support the new alarms functionality. The buffer timeout setting is not available to controllers with firmware revision 24 or later. For controllers with version 20 or earlier, we recommend that you do not change the default buffering time unless instructed by Technical Support.

### Before you begin
- Review Plan your system on page 25.
- Verify that you have installed and activated the software listed in the next section under What you need on page 32.
- Verify that the Logix5000 firmware has been updated to revision 16 or later (excluding revisions 21 to 23).

**Tip:** To take advantage of the new alarms functionality in the revision 24 firmware, we recommend you install FactoryTalk Services Platform software version 2.71 or later, and update your controller firmware to revision 24 or later.

### What you need
- Logix Designer application (RSLogix 5000 software)
- ControlFLASH
- RSLinx Classic
Define device-based alarms in Logix5000 controllers

Chapter 4

Follow these steps

Define a digital alarm

Digital tags are either on or off. They have states instead of limits. The alarm trigger condition compares the value of the tag to the configured alarm state. An alarm can be triggered if the digital alarm is in one of these two states:

- The rung evaluation or input tag is equal to zero
- The rung evaluation or input tag is not equal to zero

Tip: If your FactoryTalk application does not include Logix5000 controllers, or if your controllers are not programmed with the alarm instructions included in the Logix Designer application (RSLogix 5000 software version 16 or later), see Add an OPC Data Server for third-party controllers on page 71 and Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.

Configure the alarm and download to the controller

This example uses the ladder logic editor that comes with the Logix Designer application (RSLogix 5000 software) to define a digital alarm. You can also configure digital alarms in function blocks or structured text.

Step 1. Create a rung of logic that will trigger the alarm

1. Create a new project with default settings. In this example, we use West_Plant_Controller.
2. In the left pane, expand the folders Tasks > MainTask > MainProgram, and then double-click MainRoutine.

3. On the Language Element toolbar, click the Examine-on instruction button ⌁ to add it to a rung on the ladder project.
4. At the top of the Examine-on instruction, click the question mark to select it. On the File menu, click New Component, and then click Tag.

5. In the New Tag dialog box, type a name for the tag, choose BOOL as the data type, and then click Create.
In our example, we name the tag **alarm_active**.
Step 2. Add a digital alarm instruction to the rung

1. On the Language Element toolbar, click the Alarms tab, and then click the ALMD button. The instruction block is placed in the ladder logic.

If you are using RSLogix 5000 version 20 or earlier, the instruction block is like this:

2. Inside the alarm instruction, beside ALMD, select the question mark.
3. On the **File** menu, click **New Component**, and then click **Tag**.

4. In the dialog box that opens, type a name for the digital alarm tag, and then click **Create**.

In our example, we named the tag **DigitalAlarm1**.

![New Parameter or Tag dialog box](image)

**Step 3. Specify a tag for each of the digital alarm's operands, or just enter 0**

1. Inside the alarm instruction, select the **ProgAck** operand.

2. On the **File** menu, click **New Component**, and then click **Tag**.

3. In the **New Tag** dialog box, type a name for the tag, select **BOOL** as the data type, and then click **Create**.
In our example, we named the tag **DigitalAlarm1_Ack**. For details about using the **New Tag** dialog box, click **Help**.

If you are using RSLogix 5000 version 20 or earlier, the instruction block is like this:
4. Create tags for the ProgReset, ProgDisable, and ProgEnable operands. When you are finished, the alarm instruction should resemble the one shown here:

If you are using RSLogix 5000 version 20 or earlier, the instruction block is like this:

Step 4. Configure the properties of the new digital alarm tag

1. Inside the alarm instruction, click the **Browse** button (...).
2. In the **ALMD Properties** dialog box, specify configuration settings, and then click **OK**. For help with specifying configuration settings, click **Help**.
If you are using RSLogix 5000 version 20 or earlier, the **ALMD Properties** dialog box is like this:

![ALMD Properties dialog box](image)

**Tip:** To create a text message with embedded variables for each alarm, click the **Message box** **Browse** button (...). At run time, these messages appear in Alarm and Event graphic objects, such as the Alarm and Event Summary. The maximum length of an alarm message is 255 characters. When importing alarm messages, the Logix Designer application (or RSLogix 5000 software) will verify the message length and display a warning if the alarm message exceeds the character limit.

**Step 5. Download the program containing the ladder logic to the controller**

1. If it is not already running, start **RSLinx Classic** to establish communications between the controller and the Logix Designer application (or RSLogix 5000 software).
2. On the Logix Designer application menu, click **Communications > Who Active**.

3. If it is not already highlighted, select the controller to which you want to download the project.

In this example, use the same controller you configured for the **West_Plant_Controller** project in the first step: "Create a rung of logic that will trigger the alarm."
4. Click **Download**. At the prompt, click **Download** again. The controller is placed in Program mode.

Step 6. Test the alarm instruction by switching to run mode and triggering the alarm

1. On the Logix Designer application menu, click **Communications > Run Mode**. Click **Yes** to switch the controller to run mode.
2. To trigger the alarm, right-click the contact on the rung (the one named `alarm_active`), and then click **Toggle Bit**. The contact should change from a blue highlight to a green highlight.

![Image of Logix5000 controller software interface]

**Define an analog alarm**

An analog alarm defines a condition that evaluates a single analog tag against up to four limit values (high-high, hi, low, and low-low) and up to two rate of change limits (positive and negative).

**Tip:** If your FactoryTalk application does not include Logix5000 controllers, or if your controllers are not programmed with the alarm instructions included in the Logix Designer application (RSLogix 5000 software version 16 or later), see Add an OPC Data Server for third-party controllers on page 71 and Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.
Configure the alarm and download it to the controller

This example uses the Function Block editor that comes with the Logix Designer application (RSLogix 5000 software). You can also configure analog alarms in ladder logic or structured text.

Step 1. Define a new routine

1. Create a new project with default settings. In this example, we use East_Plant_Controller.

2. Expand the Tasks folder in the left pane, right-click MainProgram, click Add, and then click New Routine.

3. In the New Routine dialog box, type a name for the routine. We use alarm_active.
4. In the Type list, click **Function Block Diagram**.

5. Select the **Open Routine** check box, and then click **OK**.

The new routine appears in the Tasks folder under **MainRoutine** and the routine opens on the right side of the Logix Designer window:

![Diagram of Logix Designer window](image)

**Step 2. Build the function block logic**

1. To add an alarm block, go to the tabs in the center right area (Favorites, Add-On, and so on) as shown in the following illustration. Scroll to the right, and then click the **Alarms** tab.
2. On the toolbar, click the **ALMA** button to add an Analog Alarm block.
If you are using RSLogix 5000 version 20 or earlier, the Analog Alarm block appears this way:
3. Using the same Alarm objects on the **Language Element** toolbar, click the **Input Reference** icon ![Input Reference icon](image). An Input Reference tag appears in the Function Block editor:
4. Right-click the single question mark inside the symbol and then click **New Tag**.

5. In the **New Tag** dialog box, type a name for the tag and then click **Create**.
In this example, we use **AnalogAlarm1**.
The screen should resemble the one shown in the following illustration:
6. Connect the input reference block to the Input of the ALMA block, as shown in the following illustration, by dragging the block’s contact point to the contact point on the ALMA block.

Step 3. Configure the properties of the alarm block

1. Click the **Browse** button (…) on the alarm block.
2. In the ALMA Properties dialog box, set the Input Levels as shown in the following illustration and then click OK. To require that an operator acknowledge the alarm at run time, make sure the Acknowledgement Required check box is selected.
If you are using RSLogix 5000 version 20 or earlier, this is the ALMA Properties dialog box:

**Tip:** To enter alarm messages and add variables for analog alarms, select the Messages tab. To create a text message with embedded variables, click the Browse button (...) beside the Level field, or beside the Rate of Change field. At run time, alarm messages are displayed in Alarm and Event graphic objects such as the Alarm and Event Summary.

**Step 4. Add a JSR instruction to the MainRoutine to run the function block**

1. Double-click **MainRoutine** to open it.
2. Right-click the first rung and then click **Add Ladder Element**.
3. In the Add Ladder Element dialog box, scroll down to the Program Control folder and then double-click the folder to expand the list of controls.

4. Select JSR and then click OK.

5. In the JSR instruction, double-click Routine Name and then click alarm_active.

6. On the toolbar, click the Save button to save the configuration.
Step 5. Download the program to the controller

1. If it is not already running, start RSLinx Classic to establish communications between the controller and the Logix Designer application (RSLogix 5000 software version 16 or later).

2. On the Logix Designer application menu, click Communications > Who Active.

3. Select the controller to which you want to download the project.

4. Click Download. At the prompt, click Download again.

5. To switch the controller to run mode, click Communications > Run Mode.

Step 6. Finish creating alarms, and next steps

- Define additional digital alarms or analog alarms using either ladder logic, function block, or structured text, and download the logic to the controller.

- When you finish defining alarms, create a device-based alarm server, and then configure it to subscribe to events detected by the Logix5000 controller. See Add a device server for Logix5000, PLC-5, or SLC 500 controllers on page 59.
Chapter 5

Add a device server for Logix5000, PLC-5, or SLC 500 controllers

Add a device server to your application to use:

- Device-based alarms in Logix5000 controllers.
- Tag-based alarms in PLC-5, SLC 500, or Logix5000 controllers.
- If you are using device-based alarms, define your alarms, as described in Define device-based alarms in Logix5000 controllers on page 31.
- If you are using tag-based alarms, you create a controller program to detect alarm conditions, and then associate those conditions with tags that are monitored by the FactoryTalk Tag Alarm and Event Server.

Before you begin

- RSLinx Enterprise
- FactoryTalk View Studio or FactoryTalk Administration Console

What you need

Tip: This guide uses FactoryTalk View Studio to define a device server. You can also use FactoryTalk Administration Console. For more information, in the FactoryTalk Administration Console menu bar, select Help > Contents.
Chapter 5  Add a device server for Logix5000, PLC-5, or SLC 500 controllers

Follow these steps

Add a device server

In this section, you will create a Rockwell Automation device server (RSLinx Enterprise) and then configure it to subscribe to alarms that will be detected by a Logix5000 controller.

Important: If you are using third-party controllers, you do not need a device-based alarm server. Instead, go to Add an OPC Data Server for third-party controllers on page 71.

Step 1. Create an application in FactoryTalk View Studio

This example shows how to create a local station application.

1. To start FactoryTalk View Studio, click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.
2. In the **Application Type Selection** window, select **View Site Edition (Local Station)** and then click **Continue**.

![Application Type Selection window]

**Important:** FactoryTalk Alarms and Events is not supported for use with FactoryTalk View Machine Edition.

3. In the **New/Open Site Edition (Local Station) Application** dialog box, click the **New** tab.

![New/Open Site Edition (Local Station) Application dialog box]
4. In the **Application name** field, type a name for the new local station application. In this example, we name the application **My Local Site**.

5. Leave the **Description** field blank, or type a description for the application. For example, you can use this field to record revisions to the application, or contact information for technical support.

6. If it is not already selected, select the default language for the application. This is the language in which you are creating the application.

7. Click **Create**.

8. In the **Add Controller Instruction Faceplates** dialog box, click **Clear All** and then click **OK**.

![Add Controller Instruction Faceplates](image)
Add a device server for Logix5000, PLC-5, or SLC 500 controllers

Chapter 5

Tip: If you have cleared the Display this dialog when creating a new application check box, the Add Controller Instruction Faceplates dialog box does not open automatically. To open it manually, in the Explorer window right-click the HMI server, and then select Add Controller Instruction Faceplates.

Step 2. Configure the device server

1. In the Explorer window, right-click the new application My Local Site, point to Add New Server, and then click Rockwell Automation Device Server (RSLinx Enterprise).

2. In the RSLinx Enterprise Server Properties dialog box, click the General tab, type a name for the new server, and then click Apply. In this example, we name the server FTAE Server. Leave this dialog box open for the moment.

3. Do one of the following:
Chapter 5  Add a device server for Logix5000, PLC-5, or SLC 500 controllers

- If you plan to use tag-based alarms, you can skip the rest of the steps in this section, and go on to the next major step: "Step 3. Create a new shortcut to the controller." Click **OK** to close the **RSLinx Enterprise Server Properties** dialog box.

- If you are using built-in alarm instructions in Logix5000 controllers, continue with the steps in this section.

4. On the **Alarms and Events** tab, select the **Enable alarm and event support** check box.

5. Clear the **Enable history** check box and then click **OK**. For information about historical logging, see **Set up historical alarm and event logging** on page 141.
The new server is added to the **My Local Site** application:

![FactoryTalk View Studio - View Site Edition](image)

**Step 3. Create a new shortcut to the controller**

1. In the **Explorer** window, double-click the new RSLinx Enterprise server and then double-click **Communication Setup**.

![Communication Setup](image)
2. In the **Communication Setup** dialog box, click the **Add** button, and then type a name for the new shortcut. We use **FTAE_Controller**.

Some options in this dialog box might be different if you are using PLC-5 or SLC 500 controllers.

The warning icon beside the **OK** button indicates that changing values in this dialog box at run time can cause unexpected results. For details, click **Help**.
3. Skip this step if you do not plan to use Logix5000 controllers with built-in alarm instructions. In the Enable list, click Yes to enable Alarms and Events:

If you do not see the Enable list, then Enable alarm and event support was not selected in the previous step 4.
Add a device server for Logix5000, PLC-5, or SLC 500 controllers

Tip: Set Buffer Timeout (min.) for the length of time (zero to 120) you want to cache alarm information if the connection to the controller is lost. To disable alarm buffering, set the value to zero. See Alarm Buffering during loss of connection on page 31.

4. On the Primary tab, expand the list of networks and devices until the controller you plan to use is visible, and then click the controller.

5. To set the path to the primary controller, click the Apply button.

6. To save the shortcut configuration and close the Communication Setup dialog box, click OK.

Important: FactoryTalk Alarms and Events server redundancy is only supported in network station applications and network distributed applications.

Step 4. Finish creating data servers, and next steps

1. If your FactoryTalk application includes third-party OPC-DA controllers, add an OPC Data Server, create a tag-based alarm server, and then define alarms. See Add an OPC Data Server for third-party controllers on page 71 and Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.

2. If your FactoryTalk application is communicating with PLC-5 or SLC 500 controllers, or Logix5000 controllers that are not using built-in alarm instructions, you must add a device server (RSLinx Enterprise) to your application and then create a tag-based alarm server and define alarms. See
Add a device server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.

3. After you create data servers and alarms, add FactoryTalk Alarms and Events objects to graphic displays. See Set up graphic displays on page 89.

4. If your FactoryTalk network distributed application or network station application plan calls for data redundancy, you will want to configure your device-based alarm server for redundancy. We recommend leaving this step until after the FactoryTalk application is fully configured and all HMI features have been tested using non-redundant servers. Adding data server redundancy does not affect the configuration of the graphic displays in the HMI application. See Configure redundancy for alarms and events for more information, on page 167.

**Important:** FactoryTalk data server redundancy is only supported in network station applications and network distributed applications.
Chapter 6

Add an OPC Data Server for third-party controllers

To monitor alarms in a third-party controller, create a controller program to detect alarm conditions and communicate them through tags. Use an OPC Data Server (for example, KEPWAre server) to obtain tag values from the controller, and use a Tag Alarm and Event Server to monitor those tags for alarm conditions.

This chapter shows an example using RSLinx Classic as an OPC Data Server. In most situations RSLinx Enterprise is used to communicate with a PLC-5 or SLC 500 controller. However, at times RSLinx Classic is used to communicate with a controller that is bridged over Ethernet to a DH+ or DH-485 network.

Before you begin

- Review Plan your system on page 25.
- Verify that you have installed and activated the software listed under What you need on page 71.

What you need

- PLC-5, SLC 500 or third-party OPC-DA programmable controller
- RSLogix 5 or RSLogix 500 software
- RSLinx Classic software
- RSLinx Enterprise software
- FactoryTalk View Studio or FactoryTalk Administration Console
When you add a data server to an application or area, tags published by the data server can be accessed by any client—in this case, the Tag Alarm and Event Server.
Important: This guide uses FactoryTalk View Studio to add a data server. You can also use FactoryTalk Administration Console. For more information, select Help > Contents from the FactoryTalk Administration Console window.

Step 1. Open an existing application in FactoryTalk View Studio

1. To run FactoryTalk View Studio, click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. In the Application Type Selection window, select View Site Edition (Local Station) and then click Continue.

3. In the New/Open Site Edition (Local Station) Application dialog box, click the Existing tab and select the application you created in Add a device server for Logix5000, PLC-5, or SLC 500 controllers on page 59 (we use My Local Site).
Step 2. Add a data server

1. In the Explorer window, right-click the application, point to Add New Server, and then click OPC Data Server.

2. In the OPC Data Server Properties dialog box, type a name for the server. We use My OPC Server.

3. Beside the OPC Server name (ProgID) field, click the Browse button.

4. In the Available OPC Data Servers dialog box, select RSLinx OPC Server, and then click OK.

   Tip: When creating a network station application or network distributed application, select RSLinx Remote OPC Server.

5. Click OK to close the OPC Data Server Properties dialog box.
6. Next, add a Tag Alarm and Event Server and define alarm conditions. See Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.

7. If your FactoryTalk network station application or network distributed application plan calls for data redundancy, you will want to configure your tag-based alarm server for redundancy. We recommend completing this step after the FactoryTalk application is fully configured and all HMI features have been tested using non-redundant servers. Adding data server redundancy does not affect the configuration of the graphic displays in the HMI application.

---

Important: FactoryTalk Alarms and Events server redundancy and data server redundancy are only supported in network station applications and network distributed applications.
Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers

FactoryTalk Tag Alarm and Event Servers provide software-based alarms and events. Use tag alarm and event servers to monitor alarm conditions in Logix5000 controllers, PLC-5, SLC 500, or third-party OPC-DA programmable controllers.

Tip: If your FactoryTalk system does not include PLC, SLC, or third-party controllers, you can skip this chapter.

A FactoryTalk Tag Alarm and Event Server provides a link between a hardware device that contains data and the FactoryTalk Directory. This includes third-party controllers. All that is required is a data server (such as KEPWare) to communicate with the controller.

FactoryTalk Tag Alarm and Event Servers can be used to provide an alternative to device-based alarms--alarms provided by devices such as Logix5000 controllers or sensors using built-in alarm instructions.

Before you begin

- If you are using third-party controllers, you do not need a device-based alarm server. Instead, go to Add an OPC Data Server for third-party controllers on page 71.

What you need

- Logix5000 controllers, PLC-5, or SLC 500 devices communicating through Rockwell Automation device servers (RSLinx Enterprise)
- RSLinx 5 or RSLinx 500 software
- RSLinx Enterprise, RSLinx Classic (or RSLinx Classic for bridging from Ethernet to DH+ or DH-485 networks)
- FactoryTalk View Studio or FactoryTalk Administration Console
Follow these steps

Create an application

In this section, you will create a Rockwell Automation device server (RSLogix Enterprise) and then configure it to subscribe to alarms that will be detected by a...
Logix5000 controller. In this example, the Rockwell Automation device server (RSLinx Enterprise) is used as a data server for tag values, not as an alarm server.

**Create an application in FactoryTalk View Studio**

**Tip:** If you created a local station application previously, you can skip the steps in this section. Open the application you created and go on to the next section *Add a data server*.

This example shows how to create a local station application.

1. To start FactoryTalk View Studio, in Windows, click **Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio**.

2. In the **Application Type Selection** window, select **View Site Edition (Local Station)** and then click **Continue**.
3. In the **New/Open Site Edition (Local Station) Application** dialog box click the **New** tab.

4. In the **Application name** field, type a name for the new application. In this example, we name the application **My Local Site**.

5. Leave the **Description** field blank, or type a description for the application. For example, you can use this field to record revisions to the application, or contact information for technical support.

6. If it is not already selected, select the default language for the application. This is the language in which you are creating the application.

7. Click **Create**.
8. In the Add Controller Instruction Faceplates dialog box, click Clear All and then click OK.

Tip: If you have cleared the Display this dialog when creating a new application check box, the Add Controller Instruction Faceplates dialog box does not open automatically. To open it manually, in the Explorer window right-click the HMI server and then select Add Controller Instruction Faceplates.

Add a data server

Step 1. Configure the device server (RSLinx Enterprise)

When you add a data server to an application or area, tags published by the data server can be accessed by any client—in this case, the Tag Alarm and Event Server.

Important: This guide uses FactoryTalk View Studio to add a data server. You can also use FactoryTalk Administration Console. For more information, select Help > Contents from the FactoryTalk Administration Console window.

In this example a device server (RSLinx Enterprise) is added to the application to act as a data server.
1. In the Explorer window, right-click the application (My Local Site), point to Add New Server, and then click Rockwell Automation Device Server (RSLinx Enterprise).

2. In the RSLinx Enterprise Server Properties dialog box, click the General tab, type a name for the server, and then click Apply. In this example, we name the server FTAE Server.

The new server is added to the My Local Site application:
Step 2. Create a new shortcut to the controller

Tip: If you already created a shortcut to the controller in a previous chapter, you can skip this step.

1. In the Explorer window, double-click the new RSLinx Enterprise server and then double-click Communication Setup.

2. In the Communication Setup dialog box, click the Add button and then type a name for the new shortcut. We use FTAE_Controller.
Some options in this dialog box might be different if you are using PLC-5 or SLC 500 controllers.

The warning icon beside the OK button indicates that changing values in this dialog box at run time can cause unexpected results. For details, click Help.

3. On the Primary tab, expand the list of networks and devices until the controller is visible, and then click the controller. To set the path to the primary controller, click the Apply button.

4. To save the shortcut configuration and close the Communication Setup dialog box, click OK.

Add a Tag Alarm and Event Server

To create a server and define alarm conditions that monitor tags for PLC-5, SLC 500 controllers, or Logix5000 controllers, complete the following steps.

These instructions apply to FactoryTalk View Studio. For help with FactoryTalk Administration Console, click Start > All Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk Help.

Add a Tag Alarm and Event Server

1. In the Explorer window, right-click the application. Point to Add New Server, and then click Tag Alarm and Event Server.

2. In the Tag Alarm and Event Server Properties dialog box, click the General tab.
3. Type a name for the server, and then click OK. In this example, we use TagAE.

![Tag Alarm and Event Server Properties](image)

4. On the Priorities and History tab, clear the Enable history check box.

The Priorities and History tab is used to configure alarm and event logging. Set up historical alarm and event logging on page 141 describes how to set up alarm logging for a Tag Alarm and Event Server.

5. To create the Tag Alarm and Event Server and close the dialog box, click OK.

**Define alarm conditions**

After you create a Tag Alarm and Event Server, you define the conditions that will trigger alarms at run time.

This example shows how to create a digital alarm in a Tag Alarm and Event Server.

1. In the Explorer window, expand the TagAE server, and then double-click Alarm and Event Setup.
2. In the **Alarm and Event Setup** dialog box, click the **New** button on the toolbar, and then click **Digital**.

3. In the **Digital Alarm Properties** dialog box, type a name for the alarm. In this example we use **Valve1FTO**.

4. To select an **Input Tag** for the alarm, click the **Browse** button (...), and then expand the folder tree until you can select the online tag you plan to monitor.
5. Select the tag you plan to monitor and then click **OK**. In this example we used **Valve1FTO_alm**.

![Select Tag dialog box](image)

6. In the **Digital Alarm Properties** dialog box, type a message. In this example, in the **Message** field we type **The valve failed to open**.

You can also embed variables within the message. For details, click **Help** on any tab in the **Alarm Setup** dialog box.

![Digital Alarm Properties dialog box](image)

7. To close the **Digital Alarm Properties** dialog box, click **OK**.
8. To save the alarm and start monitoring for the alarm condition, click **Save**.

**Next steps**

Do the following:

1. Define additional alarms and (optionally) define alarm groups.

2. After you define alarms and groups, you can add FactoryTalk Alarms and Events objects to graphic displays. See **Set up graphic displays** on page 89.

3. If your FactoryTalk network station application or network distributed application plan calls for data redundancy, you will want to configure your tag-based alarm server and tag data servers for redundancy. We recommend completing this step after the FactoryTalk application is fully configured and all HMI features have been tested using non-redundant servers. Adding data and alarm server redundancy does not affect the configuration of the graphic displays in the HMI application. See **Configure redundancy for alarms and events** on page 167 for more information.

**Important:** FactoryTalk Alarms and Events redundancy and data server redundancy are only supported in network station applications and network distributed applications.
Chapter 8

Set up graphic displays

Create graphic displays in FactoryTalk View Studio. These are containers for objects, such as the FactoryTalk Alarm and Event Summary object. Add FactoryTalk Alarms and Events objects to graphic displays so that an operator can monitor and interact with both device-based and tag-based alarms at run time.

Other graphic objects (for example, objects representing equipment) can be animated (for example, to change color) using FactoryTalk View Site Edition expression functions that monitor the state of alarms. See Use color animation to indicate alarm state changes on page 104. Also see FactoryTalk View Site Edition Help.

This section describes how to create graphic displays, and then create and configure the FactoryTalk Alarms and Events graphic objects and macros that determine how the graphic displays open in the FactoryTalk View Site Edition Client. This section is one example of how you might create your graphic displays.

Before you begin

- Define the alarms you plan to use, as described in Define device-based alarms in Logix5000 controllers on page 31.
- Add the required device server, as described in Add a device server for Logix5000, PLC-5, or SLC 500 controllers on page 59 or Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.

What you need

- RSLinx Enterprise software
- FactoryTalk View Studio software
Follow these steps

Create a graphic display

Create a graphic display to host FactoryTalk Alarms and Events objects, such as the Alarm and Event Summary.

Step 1. Open an existing application in FactoryTalk View Studio

1. To run FactoryTalk View Studio, click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. In the Application Type Selection window, select View Site Edition (Local Station) and then click Continue.
3. In the **New/Open Site Edition (Local Station) Application** dialog box, click the **Existing** tab, and select the application you created in *Add a device server for Logix5000, PLC-5, or SLC 500 controllers* on page 59 (we used My Local Site).

![New/Open Site Edition (Local) Application](image)

**Step 2. Create a graphic display to host FactoryTalk Alarms and Events objects**

1. In the **Explorer** window, expand the **Graphics** folder, right-click **Displays**, and then click **New**.

![Explorer - My Local Site](image)
A blank display appears in the workspace. Next, add FactoryTalk Alarm and Event objects to the graphic display.

**Create an Alarm and Event Summary**

Use the Alarm and Event Summary object to view and interact with a summary of all the current alarms and events in an application. You can acknowledge, suppress, disable, shelve, or unshelve alarms.

*Tip:* You cannot use the Alarm and Event Summary to enable or turn alarm suppression off. To enable or turn alarm suppression off, use the **Alarm Status Explorer**. See Monitor alarms and events on page 125. To silence an alarm, use the Alarm and Event Banner.

You can use FactoryTalk Security to control which users can acknowledge, enable, disable, reset, suppress, shelve, or unshelve alarms at run time in an application (or in an area). To do this, right-click the application (or area) and then click **Security**. For details, see the FactoryTalk Security System Configuration Guide.

**Step 1. Add an Alarm Summary to a graphic display**

1. On the **Objects** menu, point to **Alarm and Event**, click **Summary** (or on the toolbar, click the **Alarm and Event Summary** button), and then place the cursor approximately where the object is to be on the display.

2. Hold the left mouse button down and drag it to create a rectangle the size that the Alarm and Event Summary object should be.
3. When the object is the desired size, release the left mouse button. The Alarm and Event Summary object is drawn on the display.

Step 2. Change the settings of the Alarm and Event Summary display

1. On the menu bar, click **Edit > Display Settings**.
2. In the Display Settings dialog box, on the Properties tab, make the following changes and then click OK.

- Under Cache After Displaying, click Yes and then select the Always Updating check box.
  
  When you set Cache After Displaying to Yes, the display stays in memory cache when you close it. This shortens the time required to open the graphic display the next time.
  
  When you select the Always Updating check box, the display continues to be updated with changes in alarm states when it is cached. This shortens the time necessary to update the Alarm and Event Summary with current alarms when you open it again.
  
  If Cache After Displaying is set to No, and the Always Updating check box is cleared, every time you close the graphic display, all alarms are removed from the Alarm and Event Summary. When you re-open the graphic display, the Alarm and Event Summary is blank, and then begins to receive the most recent alarms when they occur.

- Clear the Title Bar check box.

- Select the Size to Main Window at Runtime check box.

- Select the Allow Display to be Resized check box.

- Under When Resized, select the Scale check box if it is not already selected.

Step 3. Save the display

1. On the File menu, click Save.

2. In the Save dialog box, type a name for the new display and then click OK.
We use **Alarm and Event Summary** in this example.

3. Close the graphic object.

**Create an Alarm and Event Banner display**

This section describes how to add an Alarm and Event Banner object to a graphic display, and then create a startup macro that docks the Banner to the bottom of the FactoryTalk View Site Edition Client window.

**Step 1. Create a new graphic display**

1. In the **Explorer** window, expand the **Graphics** folder.

2. Right-click **Displays**, and then click **New**.
Step 2. Add an Alarm and Event Banner object to the display

1. On the Objects menu, point to Alarm and Event, click Banner (or, on the toolbar, click the Alarm and Event Banner button), and then place the cursor approximately where the object is to be on the display.

2. Hold the left mouse button down and drag it to create a rectangle the size that the Alarm and Event Banner should be.
3. When the object the desired size, release the left mouse button. The Alarm and Event Banner object is drawn on the display.

4. Resize the graphic display so that the Banner fills the graphic display (do not leave white space). Do so because the Banner displays no more than five alarms at a time.

Step 3. Configure the properties of the Alarm and Event Banner

1. To open the **Alarm and Event Banner Properties** dialog box, double-click the Alarm and Event Banner object. For details about all of the properties in the dialog box, click **Help**.
2. On the **General** tab, click the **Browse** button (...) under **Alarm and Event Summary** command.

   ![Image of Alarm and Event Banner Properties](image)

   This opens the **Command Wizard** where you will create a command to start the Alarm and Event Summary graphic display from the Alarm and Event Banner.

3. Scroll down the list of commands on the right side of the wizard, select **Display**, and then click **Next**.

   ![Image of Command Wizard Step 1 of 2](image)
4. In the File list, click Alarm and Event Summary.

5. Select the Window Position check box. Scroll down the list on the right and then click Centered of the screen.

6. Click Finish to save the Display command and add it to the Alarm and Event Banner Properties dialog box.
7. Click **OK** to close the dialog box.

**Step 4. Change the display settings for the Alarm and Event Banner display**

1. On the **Edit** menu, click **Display Settings**.

2. In the **Display Settings** dialog box, on the **Properties** tab, make the following changes, and then click **OK**:

   - Clear the **Title Bar** check box.
   - Select **Size to Main Window at Runtime**.
   - Select **Allow Display to be Resized**.
   - Under **When Resized**, select **Scale** if it is not already selected.

3. The Alarm and Event Banner graphic display is always visible because it is docked. You do not need to turn on **Cache After Displaying**, as you did for the Alarm and Event Summary object. See step 2: “Change the settings of the Alarm and Event Summary display” in Create an Alarm and Event Summary on page 92.

**Step 5. Save the graphic display**

1. On the **File** menu, click **Save**.
2. In the **Save** dialog box, type a name for the graphic display and then click **OK**.

In this example, we use **Alarm and Event Banner**.

![Save dialog box](image)

3. Close the graphic display.

This section describes how to create a startup macro. You will use the macro when you configure the FactoryTalk View Site Edition Client. See **Monitor and interact with alarms at run time** on page 115.

**Step 1. Configure a startup macro**

This startup macro docks the Banner display to the bottom of the FactoryTalk View SE Client window.
1. In FactoryTalk View Studio, in the Explorer window, right-click Macros and then click New to open the editor.

![FactoryTalk View Studio Explorer window](image1)

![Macro editor window](image2)

2. To open the Command Wizard, double-click anywhere in the body of the macro editor.
3. In the **Command Wizard**, scroll down the list of commands on the right side of the wizard, click **Display**, and then click **Next**.

![Command Wizard Step 1 of 2](image1)

4. In the **File** list, click **Alarm and Event Banner**.

![Command Wizard Step 2 of 2](image2)

5. Select the **Window Position** check box. Scroll down the list on the right and then select **Docked to the bottom**.

6. To save the Display command and add it to the macro, click **OK**.

**Step 2. Save the macro**

1. On the **File** menu, click **Save**.
2. In the `Save` dialog box, type a name for the new macro and then click `OK`. In this example, we use `Start Alarm and Event Banner`.

![Save dialog box](image)

**Use color animation to indicate alarm state changes**

In this section, you use alarm expressions in FactoryTalk View to animate a rectangle on a graphic display so that it changes color when the alarm state changes at run time:

- If there are active unacknowledged alarms, the rectangle flashes red.
- If all active alarms have been acknowledged, the rectangle is a steady red.
- If there are no active alarms but there are normal unacknowledged alarms, the rectangle is yellow.
- If there are no active or unacknowledged alarms, the rectangle is green.

**Step 1. Create a new graphic display**

1. In the `Explorer` window, expand the `Graphics` folder.

2. Right-click `Displays`, and then click `New`.

**Step 2. Add an Alarm and Event Summary to the graphic display**

1. On the `Objects` menu, point to `Alarm and Event`, and then click `Summary` (or on the toolbar, click the `Alarm and Event Summary` button).

2. Hold the left mouse button down and drag it to create a rectangle the size that the Alarm and Event Summary object should be.
3. When the object is the desired size, release the left mouse button. The Alarm and Event Summary object is drawn on the display.

4. If necessary, resize either the Alarm and Event Summary object or the graphic display to expose enough white space at the top, bottom, or on one side to add a rectangle object that will be the alarm status indicator.

5. On the **Objects** menu, point to **Drawing** and then click **Rectangle**.
6. In the graphic display, hold down the left mouse button and then drag the mouse to draw a box for the alarm status indicator.

![Graphic Display Illustration]

**Step 3. Add an expression to animate the rectangle**

1. Right-click the rectangle, point to **Animation** and then click **Color**.

   To create an expression for the color animation, you can compose the expression step by step, as explained in the following steps, or you can type the following expression in the **Expression** box:

   
   ```vba
   If AE_InAlmUnackedCount("*") > 0 Then 0 Else If AE_InAlmAckedCount("*") > 0 Then 1 Else If AE_NormalUnackedCount("*") > 0 Then 2 Else 3
   ```
Tip: In the preceding expression, "*" means include all alarms that are in the same location (area) as the HMI server. If the preceding expression is used in a network station application or network distributed application with areas, the expression would include all alarms from the alarm servers that are located in the same area as the HMI server.

If you want to include alarms from other areas, use the absolute path syntax. For example, ("/AreaName:*").

If you type the expression instead of composing it, skip to the next major step "Step 4. Set up colors for the alarm states" to apply colors to each state.

2. In the Animation dialog box, click Expression.

3. In the Expression Editor, click the If button and then click If to add the IF condition.

4. In the Expression Editor, click Functions.

5. In the Functions dialog box, in the list of Function Categories, click Alarm and Event.
The HMI Tag Alarming category contains functions that apply only to HMI tags located in an HMI server. Because our alarm data is coming from a controller or a FactoryTalk Tag Alarm and Event Server, we use the **Alarm and Event** expressions.

6. In the list of functions on the right, click **AE_InAlmUnackedCount(AlarmName)**, and then click **OK**.

7. In the **Expression Editor**, the **AE_InAlmUnackedCount()** function appears in the **Expression** box, with the cursor between the parentheses. Next, type `*` to return a count of all alarms that are in the same location (area) as the HMI server and are in the In Alarm and Unacknowledged state. Next, move the cursor to the right of the closing parenthesis.

   To count the number of instances of a specific alarm, you can type a tag name instead of the asterisk.

   To include alarms from other areas, use the absolute path syntax. For example, `("/AreaName::*")`.

8. Click **Relational** and then click **> GT** for **greater than**.
9. In the Expression box, type 0, click If and then click Then to add a THEN condition.

This completes the IF condition: “If the number of In Alarm, Unacknowledged alarms is greater than 0 . . .”

10. In the Expression box, type 0, click If and then click Else to add an ELSE condition.

This completes the THEN condition: “If the number of In Alarm, Unacknowledged alarms is greater than 0, then animate the rectangle to show the colors for state 0.”

11. Follow the same process, substituting the necessary selections to add the remaining two expressions, and then click OK.

   If AE_InAlmAckedCount("*" ) > 0 Then 1 Else (animates the rectangle to show the colors for state 1)
If AE_NormalUnackedCount("*") > 0 Then 2 Else 3 (animates the rectangle to show the colors for state 2. If none of the conditions are true, the expression animates the rectangle to show the colors for state 3.)

Step 4. Set up colors for the alarm states

This step describes how to set up colors for the rectangle for each solution to the expression.

1. In the Animation dialog box, under Expression, click state A.

![Animation dialog box]

2. In the Value box, type 0.

3. Beside Fill, select the Blink check box. A colored box is displayed so that you can specify an alternative color.

4. Beside Fill, make sure the colored boxes are set to red (for the fill color) and black (for the blink alternative color).

5. Set up the colors for the remaining states:
   - State B: Value = 1, Line = Black, Fill = Red
   - State C: Value = 2, Line = Black, Fill = Yellow
   - State D: Value = 3, Line = Black, Fill = Green

6. When you are finished setting up the colors, click Apply and then click Close.

Step 5. Save the graphic display

1. On the File menu, click Save.
2. In the **Save** dialog box, type a name for the graphic display and then click **OK**.

In this example, we use **Alarm Status Indicator**.

![Save dialog box](Image)

**Step 6: Test run the display**

1. On the **View** menu, click **Test Display**, or click the **Test Display** button (shown at left) on the toolbar.

If there are unacknowledged alarms whose alarm condition is In Alarm, the rectangle flashes red.

![Alarm Status Indicator](Image)
2. Right-click one of the alarms, and then click **Ack All**. Because all active alarms have been acknowledged, the rectangle changes to a steady red.

3. Continue experimenting to observe the effects of acknowledging alarms:
   - If there are no active alarms, but there are normal unacknowledged alarms, the rectangle is yellow.
   - If there are no active or unacknowledged alarms, the rectangle is green.
4. When you are finished, on the View menu, click Edit Display, or click the Edit Display button on the toolbar.

Next steps

Do one of the following:

- Use the graphic displays you just created to monitor and interact with alarms and events. See Monitor and interact with alarms at run time on page 115.
- Set up historical alarm and event logging. See Set up historical alarm and event logging on page 141.
Monitor and interact with alarms at run time

To interact with alarms and events at run time, set up a FactoryTalk View Site Edition Client and configure one or more graphic displays that host Alarm and Event objects. Next, run the client and then monitor the alarms and events that are shown.

Before you begin

- Be sure you have defined alarms as described in Define device-based alarms in Logix5000 controllers on page 31.
- Add the appropriate device server as described in Add a device server for Logix5000, PLC-5, or SLC 500 controllers on page 59 or Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.
- Set up and configure any graphic display objects as described in Set up graphic displays on page 89.

What you need

- RSLinx Enterprise software
- FactoryTalk View SE software
- FactoryTalk View SE Client software
To run an application and monitor graphic displays for alarm messages, start the FactoryTalk View Site Edition Client.
Step 1. Create a FactoryTalk View Site Edition Client configuration file

1. To open the FactoryTalk View SE Client Wizard, in Windows, click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Site Edition Client.

2. In the FactoryTalk View SE Client Wizard, click New.
3. In the **FactoryTalk View SE Client Configuration Name** dialog box, type a name for the configuration file. In this example, we used **Alarms and Events Demo**. Keep the default path for the configuration file and click **Next**.

![FactoryTalk View SE Client Configuration Name dialog box](image)

For details about using the FactoryTalk View Site Edition Client Wizard, click **Help** in the wizard.
4. In the **FactoryTalk View SE Client Application Type** dialog box, select **Local Station** and then click **Next**.

5. In the **FactoryTalk View SE Client Application Name** dialog box, select the name of the application you plan to connect to, and then click **Next**.
In this example, use the **My Local Site** application created in [Set up graphic displays](#) on page 89.

![FactoryTalk View SE Client Application Name](image)

- Type the name of the application you want to connect to: 
- Open FactoryTalk View SE Client as view-only
- Enable on-screen keyboard
- Allow display code debugging
- Maintain Client Tag Connections

Select the initial runtime language:

- [Help](#)  [About...](#)  [Cancel](#)  [Next >](#)
6. In the **FactoryTalk View SE Client Components** dialog box, select the FactoryTalk View components that run when the FactoryTalk View Site Edition Client starts. In the **Startup macro** list, select **Start Alarm and Event Banner**, and then click **Next**.

![FactoryTalk View SE Client Components dialog box](image)
7. In the **FactoryTalk View SE Client Window Properties** dialog box, configure how the FactoryTalk View SE Client window will look at run time. In this example, we entered **Show Me Alarms** in the **Title bar text** field. At run time, this text is displayed at the top of the Client window. Do not change any of the other settings in this dialog box. Click **Next**.
8. In the **FactoryTalk View SE Client Auto Logout** dialog box, you can configure the Client to log out automatically after a period of inactivity. In this example, we accept the default setting. Click **Next**.

![FactoryTalk View SE Client Auto Logout dialog box](image)

9. In the **FactoryTalk View SE Client Completion Options** dialog box, select **Save configuration and open FactoryTalk View SE Client now**, and then click **Finish**.

![FactoryTalk View SE Client Completion Options dialog box](image)
The Client window opens with the Alarm and Event Banner docked at the bottom.

Step 2. Open the Alarm and Event Summary from the Alarm and Event Banner

In the Alarm and Event Banner, click the **Alarm and Event Summary** button (shown at left). The Alarm and Event Summary opens, and is similar to the following graphic display.

![Alarm and Event Summary](image)

Step 3. Next steps

Do either of the following:

- Monitor and interact with alarms and events as shown in the next section.
- Set up historical logging for alarms and events using the graphic displays and startup macros created in this chapter and in **Set up graphic displays** on page 89. See **Set up historical alarm and event logging** on page 141.
Monitor alarms and events

The data fields in the Alarm and Event Banner window are organized in columns, and represent various alarm and event data. At run time, only the columns that were configured at design time to be visible are displayed in the Alarm and Event Banner.

In this example, the alarm list shows these columns:

- **Priority** - Medium
- **Alarm State** - In Alarm and Unacknowledged
- Event time and date stamp
- Message

The status bar shows (from left to right):

- The connection status of the Tag Alarm and Event Server -- whether connected or disconnected from the Alarm and Event Banner. The green icon shows that the Tag Alarm and Event Server is connected. When disconnected, the icon flashes red.
- The number of alarms that are In Alarm and Unacknowledged
- The number of alarms that are In Alarm and Acknowledged
- The number of alarms that are Normal and Unacknowledged
- The number of alarm faults

For all of the possible priorities and alarms states that can be shown in the Alarm and Event objects, see FactoryTalk Alarms and Events Help:

1. In Windows, click **Start > All Programs > Rockwell Software > FactoryTalk Alarms and Events > User Documentation > FactoryTalk Alarms and Events Help.**

2. In the section "Monitor alarms during run time," see these topics:
   a. Alarm and Event Summary > About the columns in the Alarm and Event Summary
b. Alarm Status Explorer > About the columns in the Alarm Status Explorer

c. Alarm and Event Log Viewer > About the columns in the Alarm and Event Log Viewer

Security for alarms and events

You can use FactoryTalk Security to control which users can acknowledge, enable, disable, reset, suppress, or shelve alarms at run time in an application (or in an area).

To do this, in FactoryTalk View Studio or FactoryTalk Administration Console, right-click the application (or area) where the alarms are located and then click Security. For details, see the FactoryTalk Security System Configuration Guide. In Windows, click Start > Rockwell Software > FactoryTalk Tools > FactoryTalk Security System Configuration Guide.

 Acknowledge an alarm

When you acknowledge an alarm it does not correct the condition causing the alarm, but it indicates that an operator is aware of the alarm.

Tip: The Digital Alarm Properties, Level Alarm Properties, and Deviation Alarm Properties dialog boxes each contain a Control Tags tab that allows you to acknowledge alarms by using tags in the controller (remote acknowledgment).

- At runtime, the alarm state in graphic objects changes to Acknowledged when the remote acknowledge tag value is changed to positive.

- The alarm import and export functions support remote acknowledgment.

See FactoryTalk Alarms and Events Help for more information on using the Control Tags tab.

A single tag might have several alarm conditions In Alarm. Each alarm condition must be acknowledged separately. For example, a tag that monitors a temperature might trigger HI and HIHI alarm conditions by the time it is acknowledged. The alarm could also go In Alarm and Out of Alarm several times before it is acknowledged.

Previous occurrences of an alarm that have gone Out of Alarm and then back In Alarm cannot be acknowledged. These older occurrences are referred to as out of scope and are displayed in the alarm list with a different icon. When the most recent occurrence of an alarm is acknowledged, previous occurrences are removed from the alarm list.

Acknowledge the selected alarm

In the Alarm and Event Summary event list, do one of the following:

- Select the alarms you want to acknowledge, and then click the Acknowledge selected alarm button.
Monitor and interact with alarms at run time

Chapter 9

Select the alarms you want to acknowledge, right-click the selected alarms, and then click Ack.

1. In the Alarm and Event Summary event list, do one of the following:
   - Select the alarms you want to acknowledge, and then click Acknowledge selected alarm with comment.
   - Select the alarms you want to acknowledge, right-click the selected alarms, and then click Ack Comment.
2. In the **Acknowledge Alarm with Comment** dialog box, type a comment, and then click **Acknowledge**. If historical logging is set up, the comment is displayed in the Alarm and Event Log as part of the Tracking event that is generated from the Acknowledge command.

![Acknowledge Alarm with Comment dialog box](image)

**Tip:** You can view the last comment that was entered for an operation (for example, ack, disable, suppress) in the **Alarm Details** dialog box. To view a comment associated with an alarm state, select an alarm and then click the **Show details for the selected alarm** button on the toolbar. In the **Alarm Details** dialog box, expand an alarm state (Disabled, Suppressed, Acknowledged, and so on) to view the comment associated with that state.

### Acknowledge all of the alarms displayed on the page

In the **Alarm and Event Summary** toolbar, do one of the following:

- Click **Ack page of alarms**. All alarms currently visible in the event list are acknowledged.
- Right-click one of the alarms and then click **Ack Page**.
Acknowledge all of the alarms in the event list

In the **Alarm and Event Summary** toolbar, do one of the following:

- Click **Acknowledge all alarms contained in list**. All alarms in the event list are acknowledged, even if they are not all visible. However, if the list is filtered, alarms that are filtered out are not acknowledged.

- Right-click one of the alarms, and then click **Ack All**.

Disable or enable an alarm

When an alarm is disabled the operator is not notified when the alarm condition occurs and the alarm is removed from the Alarm and Event Banner.

- An alarm that is disabled is effectively turned off in the controller.
- The alarm condition is no longer monitored and notifications are not generated by the controller.
- Disabled alarms do not sound the alarm bell in the Alarm and Event Banner.
- Unacknowledged disabled alarms are displayed in the Alarm and Event Summary.

Unlike a silenced alarm, a disabled alarm does not trigger the alarm bell in the Alarm and Event Banner if the alarm condition occurs again after the alarm was disabled.

**Tip:** Disable alarms that are related to equipment that is being shut down or serviced.

To enable alarms, use the **Alarm Status Explorer**. See [Enable selected alarms](#) on page 131.
When an alarm is enabled, the operator is notified when the alarm condition occurs. Enabled alarms sound the alarm bell, and continue appearing as new events in the Alarm and Event Summary, unless they are suppressed.

**Important:** You can use FactoryTalk Security to control who can disable or suppress alarms. If a user attempts to perform an operation for which they do not have the required security rights, the operation will fail and a message will be displayed stating that the user has insufficient rights to perform the operation. To add another level of security, the Alarm and Event Summary can be configured not to show the toolbar buttons, which also hides those operations on the context (shortcut) menu.

### Disable selected alarms

1. In the Alarm and Event Summary event list, do one of the following:
   - Select the alarms you want to disable, and then on the toolbar, click the **Disable selected alarm** button.
   - Select the alarms you want to disable, right-click the selected alarms, and then click **Disable**.
2. In the Disable Alarm dialog box, type a comment (for example, to explain why the alarm is disabled) and then click Disable.

   ![Disable Alarm dialog box](image)

   This comment is stored with the alarm and is logged to the Comment field in the Alarm and Event Log, which you can view using the Alarm and Event Log Viewer.

   **Tip:** Any alarms you disable stay in that state until you enable them again. You must use the Alarm Status Explorer to enable alarms.

**Enable selected alarms**

1. In the Alarm and Event Summary window, do one of the following:

   - If it is visible on the toolbar, click the Display the Alarm Status Explorer button.
   - If the toolbar button is not visible, right-click an alarm in the Alarm and Event Summary event list, and then click Alarm Status.
Chapter 9  Monitor and interact with alarms at run time

2. In the **Alarm Status Explorer** window, select the alarms you want to enable and then click the **Enable selected alarm** button.

Any alarms you enable stay in that state until you disable them again.

For details about the other features of the **Alarm Status Explorer**, click **Help** in the dialog box.

**Suppress or unsuppress an alarm**

You can suppress an alarm that is not needed temporarily, for example, suppress an alarm that is caused by another alarm that you are already addressing. You can suppress or unsuppress up to 2000 alarms at one time.

- A suppressed alarm is not displayed in the Alarm and Event Banner.
  
  If an alarm is displayed in the Alarm and Event Banner and then suppressed, it is removed from the alarm list.

- An unacknowledged suppressed alarm is displayed in the Alarm and Event Summary.
  
  If an alarm is displayed in the Alarm and Event Summary and then suppressed, it is *only* removed from the alarm list when it is acknowledged.

- A suppressed alarm continues to be logged in the alarm history log, which you can view using the Alarm and Event Log Viewer. See **Set up historical alarm and event logging** on page 141 for more information.

- A suppressed alarm also continues to set the appropriate InAlarm parameters of an alarm instruction in the controller.

Disable an alarm instead of suppressing it if you want to completely turn off the alarm detection logic for the alarm source and prevent the alarm from being detected. See **Disable selected alarms** on page 130.
Monitor and interact with alarms at run time

Chapter 9

Suppress an alarm

1. In the **Alarm and Event Summary** event list, do one of the following:

   - Select the alarms you want to suppress and then click the **Suppress selected alarm** button.
   - Select the alarms you want to suppress, right-click the selected alarms, and then click **Suppress**.

   ![Alarm and Event Summary](image)

2. In the **Suppress Alarm** window, optionally type a comment, and then click **Suppress**.

   ![Suppress Alarm](image)

   A comment is stored with the alarm and is logged to the **Comment** field in the Alarm and Event Log, which you can view using the Alarm and Event Log Viewer.

Unsuppress an alarm

Unsuppress an alarm that was previously suppressed if it now needs to be monitored again. For example, an operator might have suppressed an alarm because the alarm was caused by another alarm that an operator was already attending to.
An unacknowledged suppressed alarm is displayed in the Alarm and Event Summary.

To unsuppress an alarm, follow these steps:

1. In the **Alarm and Event Summary**, right-click an alarm and then click **Alarm Status**.

2. In the **Alarm Status Explorer** window, select the alarm or alarms you want to unsuppress, and then on the toolbar click the **Unsuppress selected alarm** button.
Monitor and interact with alarms at run time

Chapter 9

Tip: You can filter alarm sources to make it easier to find the alarm you want. In the Name box, type all or part of an alarm name, or select an alarm status from the list. You can use the * and ? wildcard characters in the filter. For details about filtering alarm sources, see FactoryTalk Help. In Windows, click Start > All Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk Help.

3. In the Unsuppress Alarm dialog box, optionally type a comment on why the alarm is unsuppressed, and then click Unsuppress.

![Unsuppress Alarm dialog box]

This comment is stored with the alarm and is logged to the Comment field in the Alarm and Event Log, which you can view using the Alarm and Event Log Viewer if historical logging has been configured.

For details about the other features of the Alarm Status Explorer, click the Help button.

**Shelve or unshelve an alarm**

Shelving an alarm temporarily suppresses it. When shelving, the operator specifies a duration for the alarm to remain shelved. The alarm is automatically unshelved when the duration runs out.

Tip: Shelving is supported in the Logix Designer application version 21 or later.

A shelved alarm is displayed in the Alarm and Event Summary or Alarm Status Explorer. However, a shelved alarm is not displayed in the Alarm and Event Banner.

Disable an alarm, instead of shelving it, if you want to completely turn off the alarm detection logic for the alarm source, and prevent the alarm from being detected. See Disable selected alarms on page 130 for more information.

**Shelve an alarm:**

1. In the Alarm and Event Summary event list, do one of the following:
• Select the alarm you want to shelve and click the **Shelve selected alarm** button on the toolbar.

• Right-click the alarm you want to shelve and select **Shelve**.

2. The **Shelve Alarm** dialog box appears.

In the dialog box, enter the following information if desired:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm name</td>
<td>Shows the name of the selected alarm. If multiple alarms are selected, this shows as Multiple (x alarms selected) where x is the total count of selected alarms.</td>
</tr>
</tbody>
</table>
| Shelve duration | Specifies the period of time the alarm should be shelved. Once the shelve duration expires, the alarm is unshelved. The value must be a whole number.  
    * Default: 1  
    * Minimum: 1  
    * Maximum: 2147483647 |
Monitor and interact with alarms at run time

Field Description

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td><em>(optional)</em> Specifies the reason for shelving the alarm. The default value is empty. The maximum length is 512 characters. This comment is stored with the alarm and is logged to the UserComment field in the alarm database, which you can view using the Alarm and Event Log Viewer.</td>
</tr>
</tbody>
</table>

3. When complete, click **Shelve**.

When you reshelve alarms, the conditions vary depending on the type of alarms:

<table>
<thead>
<tr>
<th>Alarm type</th>
<th>Alarm condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>A digital alarm</td>
<td>The alarm is shelved with the new specified duration. The alarm unshelve time is also updated accordingly.</td>
</tr>
<tr>
<td>An analog alarm</td>
<td>If one or more of the alarm conditions you reshelve were previously shelved, the alarm condition is shelved with the new specified duration and the alarm unshelve time is also updated accordingly. If none of the alarm conditions you reshelve were previously shelved, the alarm condition is shelved targeting to the old unshelve time.</td>
</tr>
</tbody>
</table>

**Unshelve an alarm**

If alarms that were previously shelved need to be monitored again, you can unshelve the specified alarms in the **Alarm Status Explorer**.

1. In the Alarm and Event Summary window, right-click an alarm and then click **Alarm Status**.
2. In the **Alarm Status Explorer**, select the alarm or alarms you want to unshelve, and then click the **Unshelve selected alarm** button on the toolbar.

![Alarm Status Explorer](image)

3. In the **Unshelve Alarm** dialog box, optionally enter a comment about why the alarm is unshelved, and then click **Unshelve**.

![Unshelve Alarm](image)

The comment is stored with the alarm and is logged to the **Comment** field in the Alarm and Event Log, which you can view using the Alarm and Event Log Viewer if historical logging has been configured.

You can also unshelve all shelved alarms in the Alarm and Event Summary:

1. In the Alarm and Event Summary event list, do one of the following:

2. On the toolbar, click the **Unshelve all alarms** button.
• Right-click an alarm in the list, and then click **Unshelve All**.

3. The **Unshelve All Alarms** dialog box appears. Optionally enter a comment on why the alarms are unshelved and then click **Unshelve All**.
Chapter 10

Set up historical alarm and event logging

Use the FactoryTalk Alarm and Event Log Viewer to view alarms and events that have been logged to a Microsoft SQL Server database that is configured to store historical alarm and event data.

Tip: If you do not have a Microsoft SQL Server database installed, we recommend that you install it using the batch file available on the FactoryTalk View installation DVD in the FTView/Redist folder. For installation instructions, see Install Microsoft SQL Server 2014 SP2 Express on page 227. If you already have Microsoft SQL Server installed, you may need to change the configuration options to log alarm and event messages. For configuration instructions, see Use an existing Microsoft SQL Server database on page 233.

Use the Alarm and Event Log Viewer to display entries corresponding to all event types or to filter the events you want to view. Alarms and events generated during run time can be logged to a Microsoft SQL Server database.

Important: Simple Events are not currently supported. A simple event describes a simple occurrence in the system, such as failure to access a computer or device. Condition-related events—those that relate to changes in alarm state, and tracking-related events—those that monitor audited changes to the system, are supported.

To set up historical alarm and event logging, here is an overview of the steps to follow. Each step is explained in detail in this chapter.

- Confirm that the Microsoft SQL Server software is installed.
- Add a database definition to your FactoryTalk system.
- Associate a database definition with an alarm and event server.
- Add an Alarm and Event Log Viewer object to a graphic display.
- Run the FactoryTalk View Site Edition Client software and then monitor the graphic display.
Chapter 10  Set up historical alarm and event logging

Before you begin

- If you do not already have Microsoft SQL Server software installed, you can install it from the FTView\Redist folder on the FactoryTalk View installation DVD. For installation instructions, see Install Microsoft SQL Server 2014 SP2 Express on page 227.

- Define alarms as described in Define device-based alarms in Logix5000 controllers on page 31 and Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.

- Add the appropriate device server as described in Add a device server for Logix5000, PLC-5, or SLC 500 controllers on page 59.

- Set up graphic display objects as described in Set up graphic displays on page 89.

What you need

- RSLinx Enterprise software
- FactoryTalk View Studio software
- FactoryTalk View SE Client software
- Microsoft SQL Server software
Set up historical alarm and event logging

Chapter 10

To log historical alarms and events, you can either install Microsoft SQL Server or you can use an existing SQL Server database already installed on your network. If you are using an existing SQL Server database you need to set up your database for alarm and event logging. See Summary of steps on page 233.

FactoryTalk Alarms and Events can log historical data to any of the supported SQL Server databases. For more information, see Supported SQL Server databases on page 233.

Follow these steps

Confirm that the SQL Server software is installed

To log historical alarms and events, you can either install Microsoft SQL Server or you can use an existing SQL Server database already installed on your network. If you are using an existing SQL Server database you need to set up your database for alarm and event logging. See Summary of steps on page 233.

FactoryTalk Alarms and Events can log historical data to any of the supported SQL Server databases. For more information, see Supported SQL Server databases on page 233.
Tip: SQL Server 2014 SP2 Express software is available on the FactoryTalk View installation DVD in the FTView\Redist folder. To install SQL Server 2014 SP2 Express, see Install SQL Server 2014 SP2 Express on page 227. If you are using an existing SQL Server database, see Use an existing SQL Server database on page 233.

Add a database definition to your FactoryTalk system

Create a database definition that specifies the connection information for the database and creates the required database objects.

Step 1. Open an existing application in FactoryTalk View Studio

1. To run FactoryTalk View Studio, from Windows, click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. In the Application Type Selection window, select View Site Edition (Local Station) and then click Continue.

3. In the New/Open Site Edition (Local Station) Application dialog box, click the Existing tab, and then select the My Local Site application that you created in Add a device server for Logix5000, PLC-5, or SLC 500 controllers on page 59.
Step 2. Create a new database connection

1. In the Explorer window, expand the folders System > Connections and then right-click the Databases folder. Click New Database.

2. In the Alarm and Event Historian Database Properties dialog box, configure properties for the new database definition.
In this example, we used `FTAE_History` for the definition name and database name, `FTAE_Historian` for the database user name, and `password` for the password. Select the version of SQL Server you are using. For details, click **Help** on the dialog box.
Tip: To improve efficiency when writing to the database, information is sent to a cache file located on the computer hosting the alarm server before writing to the database.

3. Click the Advanced tab. The system will attempt to create the database, the user account, and the tables that are necessary to store the alarm and event information. If the database or user does not already exist in SQL Server, you are prompted to create them. Click Yes.

4. Configure the settings for the Alarm and Event Historian Database.

5. If the connection to the database is lost, alarm and event information will continue to be cached to files. After the connection is restored, the cached information will be sent to the database.

   To limit how much information is cached, reduce the amount of days or % of available disk space for database buffering. When the limit is reached, the oldest information is overwritten.

6. When you finish, click OK. If you are prompted to create the database, click Yes. The database definition is added to the Databases folder and is ready for use.

Associate a database definition with an alarm server

To set up an RSLinx Enterprise device server (device-based server) or a FactoryTalk Tag Alarm and Event Server (tag-based server) to log historical alarm and event data to a database, you must associate a database definition with the alarm server.
If no alarm history database is associated with an alarm server, the alarm server does not log any historical data. You can associate different alarm servers with different alarm history databases, or you can have all alarm servers log their data to the same database.

For details about setting up alarm servers, see Add a device server for Logix5000, PLC-5, or SLC 500 controllers on page 59 or Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.

Step 1. Open an existing application in FactoryTalk View Studio

1. To run FactoryTalk View Studio, click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. In the Application Type Selection window, select View Site Edition (Local Station) and then click Continue.

3. In the New/Open Site Edition (Local Station) Application dialog box, click the Existing tab, and then select the My Local Site application that you created in Add a device server for Logix5000, PLC-5, or SLC 500 controllers on page 59.

Step 2. Configure the alarm server

1. In the Explorer window, expand the application tree until each alarm server is visible.
2. Right-click the alarm server named **FTAE Server** that you created in *Add a device server for Logix5000, PLC-5, or SLC 500 controllers* on page 59. Click **Properties**.
3. For an RSLinx Enterprise Device Server, do the following and then click **OK:**

![RSLinx Enterprise Server Properties](image)

- Enable alarm and event support
- Enable server-assigned priorities
  - **Urgent:** 751 - 1000
  - **High:** 501 - 750
  - **Medium:** 251 - 500
  - **Low:** 1 - 250
- Enable history
- **Database definition:** FTAE_History
- **Computer name:** IDEVSE1
- **Database name:** FTAE_History
- **Cache file path:** C:\Documents and Settings\All Users\Application Data\Rock
- **Log language:** English (United States). en-US

[OK] [Cancel] [Apply] [Help]
In the RSLinx Enterprise Server Properties dialog box, click the Alarms and Events tab.

Under Alarm and Event History, select the Enable history check box.

In the Database definition list, select a definition (for this example, we use FTAE_History).

4. For a Tag Alarm and Event Server, do the following and then click OK:

![Tag Alarm and Event Server Properties dialog box]

- Click the Alarms and Events tab.
- Under Alarm and Event History, select the Enable history check box.
- In the Database definition list, select a definition (for this example, we use FTAE_History).
- In the Tag Alarm and Event Server Properties dialog box, click the Priorities and History tab.
- Under Alarm History, select the Enable history check box.
- In the Database Definition list, select a definition. In this example, we use FTAE_History.

Create an Alarm and Event Log Viewer display

Use the Alarm and Event Log Viewer to view alarm and event information previously logged in a Microsoft SQL database configured to store historical data.

Step 1. Open an existing application in FactoryTalk View Studio

1. To run FactoryTalk View Studio, click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. In the Application Type Selection window, select View Site Edition (Local Station) and then click Continue.

3. In the New/Open Site Edition (Local Station) Application dialog box, click the Existing tab, and select the My Local Site application that you created in Add a device server for Logix5000, PLC-5, or SLC 500 controllers on page 59.

Step 2. Create a new graphic display

1. In the Explorer window, expand the Graphics folder, right-click Displays, and then click New.
A blank display appears in the workspace.

2. If necessary, resize the graphic display to about the same size as the one you created for the Alarm and Event Summary.

**Step 3. Add an Alarm and Event Log Viewer object to the display**

1. On the **Objects** menu, point to **Alarm and Event** and then click **Log Viewer** (or click the **Alarm and Event Log Viewer** toolbar button).

2. Hold the left mouse button down and drag the mouse to create a rectangle that is the size required for the Alarm and Event Log Viewer object.

3. When the object is the correct size, release the left mouse button. The Alarm and Event Log Viewer object is drawn on the graphic display.
Step 4. Configure the properties of the Alarm and Event Log Viewer

1. To open the **Alarm and Event Log Viewer Properties** dialog box, double-click the **Alarm and Event Log Viewer object**.

2. On the **General** tab, select the alarm log whose entries you want to view. In the previous example, we selected **FTAE_History**. This is the SQL database we created in Assoctiate a database definition with an alarm server on page 147.

3. Click the **Columns** tab, and then clear the **Area** check box.

4. On the other tabs, set properties to customize the Log Viewer display, as desired. For details, click **Help**.

5. When you are finished, click **OK** to close the dialog box.

Step 5. Save the graphic display

1. On the **File** menu, click **Save**.

2. In the **Save** dialog box, type a name for the new display and then click **OK**.

In this example, we use **Alarm and Event Log Viewer** for the name of the graphic display.

3. Close the graphic display.
In this section, we add a button to open the Alarm and Event Log Viewer display in the same FactoryTalk View Client window as the Alarm and Event Banner display.

**Step 1. Create a new graphic display**

1. In the Explorer window, expand the Graphics folder, right-click Displays, and then click New.

2. If necessary, resize the graphic display to about the same size as the one you created for the Alarm and Event Summary.

**Step 2. Add a button to the graphic display**

1. On the Objects menu, point to Push Button, and then click Button (or click the Button button on the toolbar).

2. Hold the left mouse button down and drag the mouse to create a rectangle the correct size for the button and then release the mouse button.
3. In the **Button Properties** dialog box, click the **Action** tab.
Step 3. Configure the button commands

1. Click the Browse button (…) to the right of the Press action field to open the Command Wizard.

2. In the Command Categories pane on the left, expand Graphics > Graphic Displays > Navigation.

3. In the list of commands on the right, click Display, and then click Next.

4. In the File list, select the name of the graphic display that is to open when the button is clicked.
In this example, we want the button to start the Alarm and Event Log Viewer, so we select **Alarm and Event Log Viewer**.

5. To close the **Command Wizard**, click **Finish**. In the **Button Properties** dialog box, the command **Display "Alarm and Event Viewer /CC"** appears in the **Press action** box.
6. Click the **Up Appearance** tab.

![Button Properties](image)

7. In the **Caption** box, type **Run the Alarm and Event Log Viewer**. Press the **Enter** key after the word **Alarm** so that the text wraps to the next line. This is the text that will appear on the button.

8. Click **OK** to save the button configuration. The button is drawn on the graphic display.
Step 4. Configure the properties of the graphic display

1. On the main menu bar Edit menu, click Display Settings.

2. In the Display Settings dialog box, make the following changes on the Properties tab:
   - Clear the Title Bar check box.
   - Select the Size to Main Window at Runtime check box.
   - Select the Allow Display to be Resized check box.
   - Under When Resized, select Scale option if it is not already selected.

   Click OK when finished.

Step 5. Save the graphic display

1. On the File menu, click Save.

2. In the Save dialog box, type a name for the new graphic display, and then click OK.

   In this example, we use Menu Bar for the name of the graphic display.
This section shows you how to modify the startup macro you created in Set up graphic displays on page 89. This example also shows you how to add commands to the startup macro that will open the button display you just created and dock it to the top of the client window.

**Step 1. Edit the startup macro**

1. In FactoryTalk View Studio, in the Explorer window, double-click the Start Alarm and Event Banner macro.

   The macro editor opens, showing the Banner display command **Display** "Alarm and Event Banner" /DB.

2. To open the Command Wizard, double-click anywhere in the body of the macro editor.

3. In the list of commands on the right, select **Display** and then click **Next**.
4. In the File list, click **Menu Bar**.

![Menu Bar Settings](image)

5. Select the **Window Position** check box. In the list of window positions, click **Docked to the Top**.

6. To save the configuration and display it in the macro editor, click **Finish**.

![Macro Editor](image)

**Step 2.** Save the startup macro in the application

1. On the **File** menu, click **Save**.

2. Close the macro editor.
View historical alarm data in a FactoryTalk View SE Client

Use the Alarm and Event Log Viewer—embedded in a FactoryTalk View graphic display—to view, sort, filter, and export historical alarm information stored in Alarm and Event Logs.

With the Alarm and Event Log Viewer, you can:

- Display alarm and event information that has been logged by the FactoryTalk Alarm and Event Historian.
- Define filters to determine which logged alarms and events will be displayed.
- Sort the alarms and events that will be displayed.

Run the application

You can open the FactoryTalk View Site Edition Client in these ways:

- From the Windows Start menu. See Monitor and interact with alarms at run time on page 115.
- From within FactoryTalk View Studio, which is covered in this section.
- By double-clicking a FactoryTalk View SE Client configuration file (*.cli).

1. If FactoryTalk View Studio is not still open, click Start > All Programs > Rockwell Software > FactoryTalk View Enterprise > FactoryTalk View Studio.

2. In the Application Type Selection window, select View Site Edition (Local Station) and then click Continue.

3. In the New/Open Site Edition (Local Station) Application dialog box, click Cancel.

4. In FactoryTalk View Studio, on the toolbar, click the Launch SE Client button.
5. In the **Launch FactoryTalk View SE Client** dialog box, select **Alarms and Events Demo.cli** and then click **OK**.

The FactoryTalk View SE Client opens after a few moments. The button appears at the top of the window and the Alarm and Event Banner appears at the bottom.
6. Click the Run Alarm and Event Log Viewer button to make the Log Viewer appear in the middle of the client window:

7. Click the Run Alarm and Event Summary button on the Banner display at the bottom of the window. The Summary display replaces the Log Viewer.
For details about enabling, disabling, suppressing, unsuppressing, shelving, unshelving, and acknowledging alarms, see Monitor and interact with alarms at run time on page 115.
Configure redundancy for alarms and events

This chapter describes how to configure FactoryTalk Alarms and Events device-based and tag-based alarm server redundancy.

Server redundancy is typically used to maximize system availability in case of:

- Computer hardware failure.
- Software failure on one server computer.
- Power failure on one server computer.

Redundancy requirements are unique to each application. The ideal redundant solution involves having at least two instances of everything—hardware, software, and networks. In practice, this is seldom necessary. Redundant FactoryTalk server components duplicate server information on a secondary computer that is used if a primary server computer fails.

FactoryTalk server redundancy can be configured for:

- FactoryTalk Alarms and Events servers
- Data servers (RSLinx Enterprise or OPC Data Server)
- FactoryTalk Site Edition HMI servers

**Important:** FactoryTalk Alarms and Events server redundancy and data server redundancy are only supported in network station applications and network distributed applications. FactoryTalk HMI server redundancy is only supported in network distributed applications.

For more information on planning and implementing a FactoryTalk distributed network application, see Reference for building a distributed system on page 253.

It is good practice when developing a FactoryTalk Alarms and Events application to develop and test with all alarm servers configured without redundancy. This approach effectively reduces the size and complexity of the application during the development and test phases.

Adding alarm server redundancy at the end of development to a properly planned network station application or network distributed application will not require any changes in graphic displays that are already developed and working properly.
Existing alarm servers and tag data servers can be configured to support redundancy if the distributed system supporting your FactoryTalk application has been adequately planned and prepared beforehand.

To implement redundant servers, the procedure depends on whether you are using a device-based alarm server or a tag-based alarm server.

- Plan and implement your FactoryTalk distributed system, taking into consideration which components require redundancy, the network layout of the components in the system, the CPU processing load that is expected for each component, and the software required to be installed on each component.

- Configure alarm servers and tag data servers as required. Initially, configure these servers without redundancy. Verify that all of the configured tags and alarms are working properly.

- Be sure all graphic displays are working properly on the FactoryTalk application with alarm servers configured without redundancy.

- For each redundant alarm server, determine if it will use favor primary or favor current switchover behavior.

  *Favor current.* When a redundant switchover occurs, the secondary server remains active in the application even after the primary server is recovered and available once again. This is the default behavior, set in the Server Properties dialog box Redundancy tab under Switchover options by selecting Continue using the secondary server even when the primary server becomes available again. When it is selected you can perform manual switchovers from primary to secondary and back again. This can be useful for testing redundant applications. You can change this selection at any time.

  *Favor primary.* After a redundant switchover has occurred, and the primary server is recovered and available again, control passes back to the primary server. This is set in the Server Properties dialog box Redundancy tab under Switchover options by selecting Switch over to primary server when it becomes available again.

You can change the redundant server configuration from favor current to favor primary any time that both servers are running and connected to the network station application or network distributed application.
What you need

If you are using device-based alarm servers

- RSLinx Enterprise and FactoryTalk Alarms and Events installed and running on the primary server computer, configured and working as a non-redundant component.
- RSLinx Enterprise and FactoryTalk Alarms and Events installed and running on the secondary server computer.
- FactoryTalk View Studio or FactoryTalk Administration Console running on a development station or other component connected in the FactoryTalk application.

If you are using tag-based alarm servers

- RSLinx Enterprise or OPC Data Server installed, configured, and running on a separate component configured in the FactoryTalk application, or configured for redundancy and running on the primary and secondary server computers as a redundant pair.
- FactoryTalk Alarms and Events installed and running on the primary server computer, configured and working as a non-redundant component.
- FactoryTalk Alarms and Events installed and running on the secondary server computer.
- FactoryTalk View Studio or FactoryTalk Administration Console running on a development station or other component configured in the FactoryTalk application.
Follow these steps

Chapter 4
Add a device-based alarm server

For device-based alarm servers

Start FactoryTalk View Studio and open the Site Edition Network application

Select the device alarm server

Configure the server properties

Open the Communication Setup editor

Configure the secondary path to the Logix5000 controller

Check the server status
In this section, you will upgrade a configured Rockwell Automation device-based alarm server (RSLinx Enterprise) to support redundancy using a secondary computer already configured in the FactoryTalk network distributed application.

**Step 1. Open the application in FactoryTalk View Studio**

This example shows how to open an existing network distributed application in FactoryTalk View Studio.

1. To run FactoryTalk View Studio, in Windows, click **Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.**
2. In the Application Type Selection window, select View Site Edition (Network Distributed) and then click Continue.

3. In the New/Open Site Edition (Network Distributed) Application dialog box with the Existing tab selected, under the heading Application Name, select the name of the existing application. In this example, we name the application My Network App.

4. Click Open.
Configure redundancy for alarms and events

Step 2. Select the device alarm server

In the Explorer window, open the application My Network App and find the device alarm server FTAE Server.

Step 3. Configure the alarm server properties

1. In the Explorer window, right-click the alarm server FTAE Server and then select Properties.

2. In the RSLinx Enterprise Server Properties dialog box, click the Redundancy tab. Select the Provide redundancy using a secondary server check box.

3. In the Redundancy tab, click Browse.

**Tip:** If your distributed network application has been planned and implemented beforehand as recommended, then the secondary server computer name will be listed in the Select Computer dialog box.

4. Select the name of the secondary server computer in the Select Computer dialog box and then click OK.

5. In the Redundancy tab, the switchover option Continue using the secondary server even when the primary server becomes available again is selected by default. This allows you to use manual switchover to test the redundant pair. You can change the selection when testing is complete. If you select Switch over to primary server when it becomes available again manual switchover is not available.

Step 4. Open the Communication Setup editor

1. In the Explorer window, click the RSLinx Enterprise server FTAE Server, and then double-click Communication Setup.

2. Before the Communication Setup dialog box appears, an RSLinx Enterprise information dialog box appears. To save the changes, click OK.

**Tip:** The secondary controller is normally the same device as the primary controller but a different path may be used on the Primary tab. For instance, the secondary path may pass through an alternate bridge device in order to provide redundancy at the communications level.

3. To set the path to the secondary controller, click the Apply button.

4. To save the shortcut configuration and close the Communication Setup dialog box, click OK.
Upgrade an existing
tag-based alarm server

In this section, you will upgrade a configured Rockwell Automation tag-based alarm server to support redundancy using a secondary computer configured in the FactoryTalk network distributed application.

**Step 1. Open the application in FactoryTalk View Studio**

This example shows how to open an existing network distributed application in FactoryTalk View Studio.

1. To start FactoryTalk View Studio, in Windows, click *Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio*.

2. In the **Application Type Selection** window, select **View Site Edition (Network Distributed)** and then click **Continue**.

3. In the **New/Open Site Edition (Network Distributed) Application** dialog box with the **Existing** tab selected, under the heading **Application Name**, select the name of the existing application. In this example, we name the application My Network App.

4. Click **Open**.

**Step 2. Select the tag alarm server**

In the **Explorer** window, open the application **My Network App** and find the tag-based alarm server, for example, **TagAE**.

**Step 3. Configure the alarm server properties**

1. In the **Explorer** window, right-click the alarm server **TagAE** and then select **Properties**.

2. In the **Tag Alarm and Event Server Properties** dialog box, click the **General** tab. Select the **Load when operating system initializes** startup type option.

   **Important:** The configuration options on the **Redundancy** tab will be disabled if the **Load when operating system initialized** option is not selected on the **General** tab. This is because redundant servers need to be running and available in order to exchange redundant information in preparation for an unexpected switchover, even when the HMI application is not actually running.

3. In the **Tag Alarm and Event Server Properties** dialog box, click the **Redundancy** tab.

4. Select the **Provide redundancy using a secondary server** check box.
5. Select the secondary server computer from the computer list and then click OK.

   **Tip:** If your distributed network application has been planned and implemented beforehand as recommended, then the secondary server computer name will be listed in the **Select Computer** dialog box.

6. In the **Tag Alarm and Event Server Properties** dialog box, the switchover option **Continue using the secondary server even when the primary server becomes available again** is selected by default. This allows you to use manual switchover to test the redundant pair. You can change the selection when testing is complete. If you select **Switch over to primary server when it becomes available again** manual switchover is not available.

Follow this example anytime you change the configuration properties and settings of an alarm server.

After changing the alarm server configuration you need to reboot the server computer. For a network distributed application or network station application, the recommended start up sequence is:

1. FactoryTalk Directory server
2. Primary server computers
3. Secondary server computers
4. Operator workstations

This example demonstrates how to check the status of a redundant alarm server in FactoryTalk View Studio using the device alarm server **FTAE Server** created in [Add a device server for Logix5000, PLC-5, or SLC 500 controllers](https://example.com) on page 59.

**Step 1. Open the application in FactoryTalk View Studio**

1. To start FactoryTalk View Studio, in Windows, click **Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio**.

2. In the Application Type Selection window, select **View Site Edition (Network Distributed)**, and then click **Continue**.

3. In the **New/Open Site Edition (Network Distributed) Application** dialog box, on the **Existing** tab, select the name of the existing application. In this example, we named the application **My Network App**.

4. Click **Open**.

---

**Check the status of an alarm server**

5. Select the secondary server computer from the computer list and then click OK.

   **Tip:** If your distributed network application has been planned and implemented beforehand as recommended, then the secondary server computer name will be listed in the **Select Computer** dialog box.

6. In the **Tag Alarm and Event Server Properties** dialog box, the switchover option **Continue using the secondary server even when the primary server becomes available again** is selected by default. This allows you to use manual switchover to test the redundant pair. You can change the selection when testing is complete. If you select **Switch over to primary server when it becomes available again** manual switchover is not available.

Follow this example anytime you change the configuration properties and settings of an alarm server.

After changing the alarm server configuration you need to reboot the server computer. For a network distributed application or network station application, the recommended start up sequence is:

1. FactoryTalk Directory server
2. Primary server computers
3. Secondary server computers
4. Operator workstations

This example demonstrates how to check the status of a redundant alarm server in FactoryTalk View Studio using the device alarm server **FTAE Server** created in [Add a device server for Logix5000, PLC-5, or SLC 500 controllers](https://example.com) on page 59.

**Step 1. Open the application in FactoryTalk View Studio**

1. To start FactoryTalk View Studio, in Windows, click **Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio**.

2. In the Application Type Selection window, select **View Site Edition (Network Distributed)**, and then click **Continue**.

3. In the **New/Open Site Edition (Network Distributed) Application** dialog box, on the **Existing** tab, select the name of the existing application. In this example, we named the application **My Network App**.

4. Click **Open**.
Step 2. Select the device alarm server

In the Explorer window, open the application My Network App and find the device alarm server, for example, FTAE Server.

Step 3. Check server status

1. In the Explorer window, right-click the alarm server FTAE Server, and then click Server Status.

   Tip: To test your redundant server configuration, trigger a manual switchover by clicking the Switchover button. The Switchover button is enabled if the server is configured for redundancy, the Switchover options selection is Continue using the secondary server, even when the primary becomes available again (default), and both the primary and secondary servers are currently available.

2. To close the Server Status dialog box without making any changes, click Cancel.
Get started with language switching

You can use language switching to display text strings that you define when you create an application, in up to 40 different languages. At run time, a FactoryTalk View SE Client can switch between any of the languages the application supports. In a network distributed application or network station application, multiple clients can run in different languages at the same time.

For more information on supported languages, see Language identifiers for language switching on page 255. For additional information about configuring language switching configuration in FactoryTalk View Studio, see "Setting up Language Switching" in the FactoryTalk View Studio Site Edition Help.

Important:
Time and date formats do not switch. Alarm and Event objects in FactoryTalk View always display the date and time format of the operating system. The rest of a FactoryTalk View application shows the format for the language FactoryTalk View is displaying.
Dialog boxes that are part of the graphical user interface of FactoryTalk Alarms and Events but not user configurable—for example, the Acknowledge with Comment dialog box—do not switch languages. They are displayed in the language of the operating system.
Historical alarm and event messages do not switch languages. They are displayed in the language in which they were logged.

Before you begin

To implement language switching, the procedure depends on whether you are using device-based alarm monitoring or tag-based alarm monitoring. If you are not sure what type of alarm monitoring to use, see Plan your system on page 25.

If you are using device-based alarm monitoring

- Review Define device-based alarms in Logix5000 controllers on page 31.
- Verify that you have installed and activated the software listed in What you need on page 32.
- Verify that the Logix5000 firmware has been updated to revision 16 or later (excluding 21 to 23).

If you are using tag-based alarm monitoring

- Review Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.
If your alarms and events system uses a data server, review Add an OPC Data Server for third-party controllers on page 71.

**What you need**

*If you are using device-based alarms*

- The Logix Designer application (or RSLogix 5000 software version 16 or later)
- ControlFLASH
- RSLinx Classic
- RSLinx Enterprise
- FactoryTalk View Studio
- FactoryTalk View SE Client

*If you are using tag-based alarms*

- PLC-5, SLC 500, third-party, or Logix5000 controllers that have not been programmed with alarm instructions included in the Logix Designer application (or RSLogix 5000 software version 16 or later)
- RSLogix 5 or RSLogix 500 software
- RSLinx Enterprise, RSLinx Classic (for bridging from Ethernet to DH+ or DH-485 networks), or a third-party OPC Data Server (for example, KEPCWare server) for communicating with third-party controllers
- FactoryTalk View Studio or FactoryTalk Administration Console
- Microsoft Excel* (for editing exported alarm messages in multiple languages)
Follow these steps

Create device-based alarm messages

To create device-based alarm messages in multiple languages you can use the import and export features in the Logix Designer application (or RSLogix 5000 software). At run time, alarm messages located in Logix5000 controllers can be displayed in the language of the FactoryTalk View application in which they are displayed.

When RSLinx Enterprise connects to the controller, all alarm messages and their languages are uploaded from the controller. When a FactoryTalk View SE Client runs, the FactoryTalk Alarms and Events objects (Alarm and Event Summary, for example) connect to the FactoryTalk Alarms and Events system and request alarm messages in the current language. When you switch languages on the client computer, the alarm monitoring system and all of the client screens switch to the appropriate language on that specific client.

Important: Historical alarm messages are logged in the language currently associated with the Alarm and Event Log. The Alarm and Event Log displays messages in the language in which they were logged. For example, a message logged in English will be displayed in English, even if the language is switched to Italian.
Translate alarm messages using import and export

A system may have thousands of alarm messages that need to be translated. To simplify this process, you can export alarm messages to a file, add translated messages in multiple languages to the file, and then import the file back into your project. Any of the languages you translate the strings into must be supported by FactoryTalk View.

You can enter text strings in multiple languages in two ways.

1. In RSLogix 5000 software version 16 or earlier, create alarm messages in one language, and use the RSLogix 5000 Export tool to export the project’s tags, logic comments, descriptions and alarm messages from RSLogix 5000 to a comma-separated value (*.csv) file or a text (*.txt) file. The text strings can be translated into other languages and added to the file. Then use the RSLogix 5000 Import tool to import the strings back into the project.

2. In RSLogix 5000 software version 17 or later, you select a language for the project, and then in the Project Documentation Language Configuration dialog box you export a localization file that contains documentation from the project. The documentation included in the text (*.txt) file includes user-defined logic comments, component names, and alarm messages. The text strings can be translated into other languages and added to the file. Use the Project Documentation Language Configuration dialog box to import strings back into the project. See Translating alarm messages using RSLogix 5000 version 17 or later on page 183.

Translate alarm messages in RSLogix 5000 version 16 or earlier

To translate alarm messages using RSLogix 5000 software version 16 or earlier, complete the following steps. To translate alarm messages in RSLogix 5000 software version 17 or later, using the project documentation language feature, see Translating alarm messages using RSLogix 5000 version 17 or later on page 183.

**Step 1. Export alarm messages from RSLogix 5000**

1. Start RSLogix 5000 (version 16 or earlier) and open the West_Plant_Controller project you created in Define device-based alarms in Logix5000 controllers on page 31. If you have not yet created the project, do so before continuing.
2. In the RSLogix 5000 window, on the **Tools** menu, click **Export**.

3. In the **Export** dialog box, click **Export**.

   If your RSLogix 5000 project includes a large number of programs, and you want to translate alarm messages from only one of them, you can make selections in the **Export** dialog box to limit the data that is exported. For details, click **Help**.

   **Tip:** When translating to or from Unicode character sets (for example, Asian languages), you must export and then import the RSLogix 5000 tag database as a .txt file. The .csv format does not support Unicode character sets. This limitation does not apply to Tag Alarm and Event Servers.

### Step 2. Translate the exported alarm messages

1. In Windows Explorer, locate the file you exported and then double-click it to open it in Notepad. You can also edit the file using Microsoft Excel.

   The last line of text in the file is the alarm definition. The first element from the left is the instruction type (**ALMMSG:**) and the language string for the alarm message (**en-us** for English in the United States).
The alarm message text appears as the fourth element from the left (Tank Temperature is High).

2. Copy the ALMMSG line and paste it at the end of the file.

3. Change en-us to it-it (for Italian in Italy), and then change the alarm message text to read La temperatura del serbatoio è alta.

4. Paste another copy of the ALMMSG line at the end of the file.

5. Change en-us to de-de (for German in Germany), and change the alarm message text to read Hohe Tanktemperatur!

6. On the File menu, click Save.

Tip: When you import alarm messages, the system verifies the message length and displays a warning if the alarm message exceeds the character limit.

Step 3. Import the translated alarm messages

1. In the RSLogix 5000 software, on the Tools menu, click Import.

2. In the Import window, select the file you modified and then click Import.
The import process produces warnings because it overwrites existing tags.

Step 4. Download the project to the controller

To update the controller with additional alarm messages in the new languages, download the project to the controller.

Next, either continue setting up tag-based alarm messages, or set up a graphic display for language switching. See Add buttons to a graphic display to switch languages at run time on page 193.

The steps in this procedure apply to RSLogix 5000 software version 17 and later, and the Studio 5000 Logix Designer application version 21 and later, both referred to in this procedure as the application.

To translate alarm strings use the project documentation import and export feature. Only the information that is necessary for localization is included in the exported file.

Step 1. Export alarm messages

1. Run the application and open the West_Plant_Controller project you created in Define device-based alarms in Logix5000 controllers on page 31. If you have not created the project, do so before continuing.
2. To open the **Project Documentation Language** dialog box, click the **Documentation Language Configuration** icon or click **Documentation Languages** on the Tools menu.

3. To associate the existing product documentation with a language, select a language from the **Select a language** list or click **Custom** and then add a custom language. For example, select **English (United States)** from the list and then click **OK**.

4. After you select a language for the project, the **Project Documentation Language Configuration** dialog box opens. If the dialog box does not open after a short time, click **Documentation Languages** on the Tools menu. To export a localization file, click **Export**.
5. In the **Export Project Documentation** dialog box, select the languages to include in the localization file and then click **Next**. For example, select German (Germany) and Italian (Italy) if the project documentation will be translated into German and Italian.

6. To add the configuration information to the localization file, click **Next**.

7. Specify the name and location of the exported localization file and then click **Export**.

8. Click **OK**.

### Step 2. Translate the exported alarm messages

1. In Windows Explorer, locate the file you exported. Right-click the file, point to **Open With** and then click **Microsoft Excel**.

   ![Excel Spreadsheet](image)

   The first column contains the instruction type **ALMMSG**. Column C is labeled **KEY:en-US [English (United States)]** and the alarm message is displayed in English.

   Column D is labeled **de-DE [Deutsch (Deutschland)]**, and Column E is labeled **it-IT [italiano (Italia)]**. These are the languages you selected for the export.

2. Type **Hohe Tanktemperatur!** in column D in the same row that shows **Tank Temperature is High**.

3. Type **La temperatura del serbatoio e alta** in column E in the same row that shows **Tank Temperature is High**.

4. On the **File** menu, click **Save**.
Step 3. Import the translated alarm messages

1. In the application, on the Tools menu, click Documentation Languages.

2. In the Project Documentation Language Configuration dialog box, click Import.

3. In the Select File dialog box, select the file you modified and then click Import.

4. Verify the languages you want to import in the Import Project Documentation dialog box, and then click Import.

5. Click OK.

Tip: When you import alarm messages, the application verifies the message length and displays a warning if the alarm message exceeds the 255 character limit.

Step 4. Download the project to the controller

To update the controller with additional alarm messages in the new languages, download the project to the controller.

Next, either continue with setting up tag-based alarm messages, or set up a graphic display for language switching. See Add buttons to a graphic display to switch languages at run time on page 193.

Create tag-based alarm messages

The alarm messages in a tag-based alarm server also support language switching. As with device-based alarms, in FactoryTalk View you can also enter text strings in multiple languages in two ways:

1. The messages in the Alarm and Event Setup editor are saved in the language you select when opening an application in FactoryTalk View.

2. After creating alarm messages in one language, you can export them from FactoryTalk View to a Microsoft Excel (*.xls) or XML file (*.xml), add translated versions of the strings to the exported file, and then import them into FactoryTalk View again.

The maximum length for alarm messages is 255 characters. When you import alarm messages, anything over 255 characters is truncated.

Enter text strings in FactoryTalk View Studio
Step 1. In FactoryTalk View Studio, choose a language in which to open an application

1. To start FactoryTalk View Studio, in Windows click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. In the Application Type Selection window, select View Site Edition (Local Station) and then click Continue.
3. In the **New/Open Site Edition (Local Station) Application** dialog box, click the **Existing** tab, select the application you created in **Add a device server for Logix5000, PLC-5, or SLC 500 controllers** on page 59 (we used **My Local Site**).

4. In the **Language** list, select the language in which you are creating your application (in this example, **English (United States), en-US**), and then click **Open**.

**Step 2. Create a digital alarm**

This section uses the FactoryTalk Tag Alarm and Event Server you created in **Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers** on page 77. If you have not yet created the server, do so before continuing.
1. In the **Explorer** window, expand the new **Tag Server**, and then double-click **Alarm and Event Setup**.

![FactoryTalk View Studio - Site Edition (Local) Explorer](image)

In the **Alarm Setup** dialog box, click the **Digital** tab.

![Alarm and Event Setup - RNAi/SGlobal/FTYE_APPLICATION/FTAE_SERVICE](image)

2. On the toolbar, click the **New** button.

![New button](image)
3. In the **Digital Alarm Properties** dialog box, in the **Name** box, type **TankTempThreshold**.
4. In the **Input Tag** field, type `system\Second`. This tag uses the second count from the computer’s internal clock to trigger the alarm. You can also click the **Browse** button (...) beside the **Input Tag** field to select the `system\Second` tag and then click **OK**.

![Select Tag dialog box](image)

5. In the **Digital Alarm Properties** dialog box, in the **Condition** list, select **Input = 0**. This triggers the alarm every time the value of the `system\Second` tag is 0, which happens every minute.

6. In the **Message** field, type **Tank Temperature is High**, and then click **OK**.

7. Close the **Alarm and Event Setup** editor and save your changes.

![Alarm and Event Setup editor](image)

---

**Add languages to the application**

1. In FactoryTalk View Studio, on the **Tools** menu, click **Languages**.
2. In the **Language Configuration** dialog box, select the **Display undefined strings using the default language** check box, and then click **Add**.

When the **Display undefined strings using the default language** check box is selected, any strings that are not defined in the current language are displayed in the default language at run time.

When this check box is not selected, any strings that are not defined in the current language are displayed as question marks (???) at run time.

3. In the **Add Language** dialog box, click **German (Germany)** and then click **OK**.

4. In the **Language Configuration** dialog box, click **Add** to add the next language.
5. In the Add Language dialog box, click Italian (Italy) and then click OK.

![Language Configuration dialog box](image)

6. In the Language Configuration dialog box, click OK.

In this section, we add a button to a graphic display which can be used to switch among available languages at run time.

**Step 1. Create a new graphic display**

1. In FactoryTalk View Studio, in the Explorer window, expand the Graphics folder.

2. Right-click Displays, and then click New.

![Explorer window](image)

**Step 2. Add buttons to the graphic display**

1. On the Objects menu, click Button and then click Push Button.
2. In the graphic display, hold down the left mouse button and then drag the mouse to draw a box for the button.

3. On the Edit menu, click Copy.

4. On the keyboard, press Ctrl-V twice, to paste two more copies of the button in the graphic display.

5. Drag the copies of the button apart on the display.

6. On the keyboard, press Ctrl-A to select all of the buttons.

7. On the Arrange menu, click Align Top to align the tops of the buttons.
8. On the **Arrange** menu, click **Space Horizontal** to space the buttons equally apart.

Step 3. Add captions to the buttons

1. Double-click the first button to edit it.
2. In the **Button Properties** dialog box, click the **Action** tab.
3. Click the **Browse** button to the right of the **Release action** field. The **Command Wizard** opens.
4. In the **Command Categories** pane on the left, expand **All Commands and Macros**.
5. In the list of commands on the right, click **Language**, and then click **Next**.
6. In the **Language ID** list, select the name of the language and then click **Finish**.
In this example, we are using English (United States), en-US.

7. In the Button Properties dialog box, click the Up Appearance tab.

8. In the Caption field, type English and then click OK.

9. Repeat the steps above to add captions to the other two buttons:
• For the second button, the press action is **Language it-IT** (Italian for Italy).
• For the second button, the caption is **Italiano**.
• For the third button, the press action is **Language de-DE** (German for Germany).
• For the third button, the caption is **Deutsch**.

Step 4. Add an Alarm and Event Summary to the graphic display

1. On the **Objects** menu, point to **Alarm and Event**, and then click **Summary** (or on the toolbar, click the **Summary** button).

2. In the graphic display, hold the left mouse button down and drag the mouse to create a box for the Alarm and Event Summary object.
3. When you have the object the required size, release the left mouse button. The Alarm and Event Summary object is drawn on the display.

![Image of Alarm and Event Summary object]

**Step 5. Save and then close the graphic display**

1. On the **File** menu, click **Save**.

2. In the **Save** dialog box, type a name for the graphic display and then click **OK**.

   In this example, we used **Alarm Summary Multilingual**.

![Save dialog box]

3. On the **File** menu, click **Close** to close the graphic display.

**Enter alarm messages in other languages**

In this section, we edit our application twice. The first time, we open the application in Italian, and enter the Italian alarm message in the **Alarm Properties** dialog box.

Next, we export the alarms and events to an Excel spreadsheet, enter the German alarm message in Excel, and then import the alarm messages again into our application.

When you enter alarm messages in multiple languages in Excel, you can add the text strings for all languages to one Excel file, and then import the translated text for all languages into the application in one operation.
When you import alarm messages, the maximum length that is allowed is 255 characters. Alarm messages longer than 255 characters are truncated.

**Step 1. Open the application in a new language**

1. On the **File** menu, click **Close Application**.

2. In the **New/Open Site Edition (Local Station) Application** dialog box, click the **Existing** tab.

3. In the list of applications, click the name of your application (in this example, **My Local Site**).

4. In the **Language** list, select **Italian (Italy)**, it-IT and then click **Open**.
Step 2. Enter the alarm message for the digital alarm

1. In the **Explorer** window, expand the **Tag Server**, and then double-click **Alarm and Event Setup**.

2. In the **Alarm and Event Setup** editor, click the **Digital** tab and then double-click the **TankTempThreshold** alarm to edit it.
3. In the **Digital Alarm Properties** dialog box, in the **Message** field, type *La temperatura del serbatoio è alta* and then click **OK**.

   ![Digital Alarm Properties dialog box](image)

   **Step 3. Export alarm messages to an Excel spreadsheet**

   1. Right-click the Tag Alarm and Event Server where the alarms are defined, and then click **Import and Export**.
In this example, right-click the Tag Alarm and Event Server called Tag Server.

2. In the Alarm Import Export Wizard - Operation Type window, leave Export alarm configuration to Excel file selected and then click Next.
3. In the **Alarms to Export** window, leave the **TankTempThreshold** alarm in the list of alarms to export and then click **Next**.

If you have many alarms and you want to export only some of them, you can filter the list of alarms to find the ones you want, and then you can include only those alarms you need in the exported file. For details, click **Help**.

4. In the **Messages to Export** window, leave **Export messages for all alarms** selected, leave all of the languages selected, and then click **Next**.

In this window you can choose whether to export all alarm messages, the messages for only the alarms you selected in the previous step, or no alarm messages, which then exports only the alarm data. If you are exporting alarm messages, you can also select which languages you want to export.
5. In the Specify Output File window, leave the file name as it is. You can specify a location where you want the file to be save or use the default location that is displayed, and then click Finish.

To browse for a location, click the Browse button.

![Specify Output File Window](image)

6. After the export is complete, click OK.

Step 4. Enter alarm messages in Excel

1. Locate the exported alarm file and then double-click it to open it in Microsoft Excel. The default location is in your My Documents folder. In this example, the file is called My Local Site_Tag Server_AlarmExport.xls.

![Excel Spreadsheet](image)

Each alarm is located in a new row in the spreadsheet. The column names correspond to the settings for each alarm. At the bottom of the Excel window there are tabs that organize the alarms by type (Digital, Level, Deviation).

Two additional tabs contain the alarm messages and the tag update rates. These items are located on their own tabs because they can apply to multiple alarms.
For example, if you had 50 alarms, you could use the same alarm message for 10 of them, but have different messages for the rest. Instead of editing the same alarm message 10 times, you only need to edit it once. Each alarm message has its own numeric identifier (in the Message column located in column H in our example), which links a message to each alarm (level alarms can have a different message for each level).

The maximum length for an alarm message is 255 characters. Messages that are longer than 255 characters are truncated when they are imported.

2. At the bottom of the Excel window, click the Messages tab.

3. To add a new language for messages, add a new column and then type the associated language identifier as the column heading. For example, click cell D1 and then type de-DE. This is the language identifier for German.

For example, the column heading, en-US is the language identifier for English (United States). For more information, see Language identifiers for language switching on page 255.

4. To add messages, type the new message in a row under the column specified for that language. For example, click cell D2 and then type *Hohe Tanktemperatur*!
5. At the bottom of the Excel window, click the **Tag Update Rates** tab. The columns are labeled with the update rates. For example cell A-1, is labeled **0.10 Seconds** and cell E-1 is labeled **2 Seconds**.

6. To update an input tag every 2 seconds, enter the name of the input tag in the column labeled **2 Seconds**.

7. To save your changes, on the **File** menu, click **Save**.


### Step 5. Import the alarm messages

1. In FactoryTalk View Studio, right-click the Tag Alarm and Event Server where the alarms are defined, and then click **Import and Export**.

In this example, right-click the Tag Alarm and Event Server called **Tag Server**.
2. In the **Alarm Import Export Wizard**, in the **Operation Type** window, select **Import alarm configuration from Excel file** and then click **Next**.

![Alarm Import Export Wizard - Operation Type](image)

3. In the **File to Import** window, select the Excel spreadsheet to which you added the German alarm message and then click **Next**.

   To browse for the file, click the **Browse** button.

![Alarm Import Export Wizard - File to Import](image)

4. In the **Alarms to Import** window, select **Import only alarm messages**, and then click **Next**.

![Alarm Import Export Wizard - Alarms to Import](image)

In this window you can choose to overwrite any existing alarms, add only the new alarms—leaving all existing alarms unchanged, or delete all existing alarms and then import only those that are in the import file.
5. In the **Messages to Import** window, select **Update existing messages and create new messages from the import file**, and then click **Finish**.

Do not select either of the other two options in this window. In our Excel spreadsheet, we added a language to an existing alarm message; we did not create a new alarm message. If you do not choose to update existing messages, the translated text will not appear in your alarm messages.

6. After the import is complete, click **OK**.

Because the Language command is ignored when you test run an application, you need to run the application from the FactoryTalk View Site Edition Client.

**Step 1. Run FactoryTalk View Site Edition Client**

1. In Windows, click **Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Site Edition Client**. The FactoryTalk View SE Client Wizard opens.
Step 2. Create a FactoryTalk View Site Edition Client configuration file

1. In the FactoryTalk View Client Wizard, click **New**.

2. In the FactoryTalk View SE Client Configuration Name window, type a name for the configuration file. In this example, we used **Multilingual Alarms**. Keep the default path for the configuration file and then click **Next**.

For details about using the FactoryTalk View Site Edition Client Wizard, click **Help** in the wizard.
3. In the FactoryTalk View SE Client Application Type window, click Local Station and then click Next.

4. In the FactoryTalk View SE Client Application Name window, select the name of the application you want to connect to, and then click Next.
In this example, we used the **My Local Site** application that we created in [Set up graphic displays on page 89](#).

![FactoryTalk View SE Client Application Name dialog box](image)

*Type the name of the application you want to connect to:*

- [ ] Open FactoryTalk View SE Client as view-only
- [ ] Enable on-screen keyboard
- [ ] Allow display code debugging
- [x] Maintain Client Tag Connections

*Select the initial runtime language:*

[Help] [About...] [Cancel] [< Back] [Next>]

---

Get started with language switching
5. In the FactoryTalk View SE Client Components window, select the FactoryTalk View components that run when the FactoryTalk View Site Edition Client starts. In the Initial display list, click Alarm Summary Multilingual, and then click Next.
6. In the **FactoryTalk View SE Client Window Properties** window, you configure how the FactoryTalk View SE Client window will look at run time. In this example, we entered **Show Me Alarms** in the **Title bar text** field. At run time, this text is displayed at the top of the Client window, and does not switch languages. Do not change any of the other settings in this window. Click **Next**.
7. In the **FactoryTalk View SE Client Auto Logout** window, you can configure the Client to log out automatically after a period of inactivity. In this example, we accepted the default setting. Click **Next**.

8. In the **FactoryTalk View SE Client Completion Options** window, click **Save configuration and open FactoryTalk View SE Client now**, and then click **Finish**.
**Test alarm messages at run time**

For details about triggering an alarm in the Logix Designer application (or RSLogix 5000 software), see step 6: “Test the alarm instruction by switching to run mode and triggering the alarm” in *Configure the alarm and download to the controller* on page 33.

In a Tag Alarm and Event Server, the TankTempThreshold alarm we created triggers automatically once every minute.

When an alarm conditions occurs, the alarm appears in the Alarm and Event Summary in the default run-time language (in this case, English for the United States).
When you click the **Italiano** button, the alarm message appears in Italian. Notice that the other parts of the Alarm and Event Summary (for example, the **Details** pane) currently appear in the language version of the FactoryTalk View software you have installed on your computer. However, you can make these items switch languages by editing the properties of the Alarm and Event Summary to modify the column heading text. You can also export the graphic display’s language strings in FactoryTalk View, and then translate them before importing them again.
The behavior of the display is the same when you click the Deutsch button to display the alarm message in German.

The labels on the buttons do not change when switching languages. This is the expected behavior because there are no translated strings for the buttons, and the Display undefined strings using the default language check box is selected. If you do not select this check box, undefined strings are displayed as question marks (?) at run time.
To set up language switching for an application:

1. Develop the application in a base language.

2. Export the application’s user-defined text strings.

   When translating to or from Unicode character sets (for example, Asian languages), you must export and then import the RSLogix 5000 tag database as a .txt file. The .csv format does not support Unicode character sets. This limitation does not apply to FactoryTalk Tag Alarm and Event Servers.

3. Translate the strings. You can use Notepad or Microsoft Excel. Excel is useful for large numbers of strings.

4. Import the translated strings back into the application.

   **Tip:** For more detailed information about setting up language switching, see the FactoryTalk View Site Edition Help in FactoryTalk View Studio. Also see the FactoryTalk View User’s Guide in FactoryTalk View—click Help > Online Books.

---

**Text that supports language switching**

In general, the user-defined strings that support language switching are those that an operator sees in an application at run time. Specifically, these are:

- Text you specify for graphic objects and global objects including captions, tool tip text, time and date embedded variables, and numeric embedded variables.

- Graphic and global object display titles specified in the **Display Settings** dialog box.

- Text objects created in graphic displays and global object displays.

---

**Text that does not support language switching**

Text that does not support language switching:

- Text that is part of the language version of the FactoryTalk View Studio Site Edition or Client software, such as information from system tags, which is displayed in the same language as the operating system. These are translated when FactoryTalk View is localized.

- Text that can be displayed at run time but is used to operate the application, such as the names of graphic displays, and command strings.

- Tag descriptions and string constants in expressions.

- Text in the title bar of a FactoryTalk View Site Edition Client window, which is part of the setup of the client, not part of the application.
If the Alarm and Event Summary or the Alarm and Event Banner is notified of a language switch, the contents are reloaded in the new language.

Any Alarm Fault List messages that you created in RSLogix 5000 (in the Alarm Properties dialog box) do not currently switch languages.

You can use the Alarm and Event Banner Properties dialog box to configure tooltips and panel captions in multiple languages. Define strings in one language at a time. FactoryTalk View controls which language is displayed. You cannot switch the text labels for the alarm states and priorities.

Tip: When configuring language switching for the Alarm and Event Banner, see the FactoryTalk View Site Edition Help in FactoryTalk View Studio.

You can use the Alarm and Event Log Viewer to configure column headings, button captions, and button tooltips in multiple languages. Define strings in one language at a time. FactoryTalk View controls which language is displayed.

When the Alarm and Event Log Viewer is notified of a language switch, the contents of the viewer, which consists of report data, are not translated. This data continues to be displayed in the language that was used when the alarm or event was logged.

If text for a language is not available, the text for the default language is used.

Tip: When configuring language switching for the Alarm and Event Log Viewer, see the FactoryTalk View Site Edition Help in FactoryTalk View Studio.
Appendix B

System performance and limits

FactoryTalk Alarms and Events has been tested to conform to the following performance limits.

Tip: All testing was performed with the recommended hardware. For details, see the FactoryTalk View Site Edition Installation Guide.

Controller specifications

The specifications vary depending on the controller firmware revisions.

Controllers with revision 24 and later

<table>
<thead>
<tr>
<th>Specification</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of subscribers (RSLogix Enterprise servers) per controller</td>
<td>3</td>
</tr>
<tr>
<td>Typical number of alarm state transitions per subscriber</td>
<td>1000</td>
</tr>
<tr>
<td>Recommended maximum number of alarms per controller</td>
<td>3000</td>
</tr>
<tr>
<td>Approximate controller memory used for each alarm</td>
<td>Digital 1 KB</td>
</tr>
<tr>
<td></td>
<td>Analog 2.5 KB</td>
</tr>
<tr>
<td></td>
<td>Using associated tags, string tags consume 750-1600 bytes per string tag depending on the alarm type.</td>
</tr>
<tr>
<td>Supported languages for alarm messages</td>
<td>All languages supported by FactoryTalk View.</td>
</tr>
</tbody>
</table>

Execution times for alarms

<table>
<thead>
<tr>
<th>Rung State</th>
<th>Execution times</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALMD instruction</td>
<td>ALMA instruction</td>
</tr>
<tr>
<td>False with no alarm state change</td>
<td>7 µs</td>
</tr>
<tr>
<td>False with alarm state change</td>
<td>16 µs</td>
</tr>
<tr>
<td>True with no alarm state change</td>
<td>7 µs</td>
</tr>
<tr>
<td>True with alarm state change</td>
<td>16 µs</td>
</tr>
</tbody>
</table>

Controllers with revision 20 or earlier

<table>
<thead>
<tr>
<th>Specification</th>
<th>Value</th>
</tr>
</thead>
</table>
Appendix B  
System performance and limits

| Number of subscribers (RSLinx Enterprise servers) per controller | 3 |
| Controller memory used for buffering by each subscriber (RSLinx Enterprise) | 100KB |
| Typical number of alarm state transitions per subscriber | 1000 |
| Recommended maximum number of alarms per controller | 2000 |
| Approximate controller memory used for each alarm | Digital 1 KB, Analog 2.2 KB, Using associated tags, string tags consume 750 - 1600 bytes per string tag depending on the alarm type. |
| Supported languages for alarm messages | All languages supported by FactoryTalk View. |

### Execution times for alarms

<table>
<thead>
<tr>
<th>Rung State</th>
<th>Execution times</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ALMD instruction</td>
</tr>
<tr>
<td>False with no alarm state change</td>
<td>8 μs</td>
</tr>
<tr>
<td>False with alarm state change</td>
<td>35 μs</td>
</tr>
<tr>
<td>True with no alarm state change</td>
<td>8 μs</td>
</tr>
<tr>
<td>True with alarm state change</td>
<td>35 μs</td>
</tr>
</tbody>
</table>

Scan times increase during a scan when many alarms change state at the same time. An alarm state change is any event that changes the condition of the alarm. Minimize the potential for large alarm bursts by creating dependencies on related alarms. Large alarm bursts can have a significant impact on application code scan time.

**Tip:** Firmware revisions 21 to 23 do not support the new alarms functionality.

### Tested system limits

In this topology, FactoryTalk Alarms and Events has been tested with the following tested system limits:

<table>
<thead>
<tr>
<th>Tested limit</th>
<th>Value in this release</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Rockwell Automation Device Servers per application</td>
<td>10 pairs</td>
</tr>
<tr>
<td>Number of alarms per Rockwell Automation Device Server (RSLinx Enterprise)</td>
<td>10,000</td>
</tr>
<tr>
<td>Number of Tag Alarm and Event Servers per application</td>
<td>10 pairs</td>
</tr>
<tr>
<td>Number of alarms per Tag Alarm and Event Server</td>
<td>10,000</td>
</tr>
<tr>
<td>Number of alarms per FactoryTalk application</td>
<td>100,000</td>
</tr>
<tr>
<td>Alarm burst (number of alarms occurring at once)</td>
<td>3,000</td>
</tr>
<tr>
<td>Simultaneous alarm operations (for example, enabling, disabling, acknowledging, or suppressing alarms)</td>
<td>2,000</td>
</tr>
<tr>
<td>Number of alarms the alarm summary can display at once</td>
<td>2,000</td>
</tr>
</tbody>
</table>
Number of clients simultaneously connected to the application | 50

For historical alarm logging, you must be able to log on to a Microsoft SQL Server database.

When a controller has been disconnected and then reconnected to alarm servers on the network, alarms start appearing in clients within 30 seconds. It may take up to 2 minutes to fully recover, depending on the computer hardware and the number of controllers and alarms in the system. In a redundant application, the active server failover and manual switchover recovery time is the same as the controller reconnect time.

**Tested topology: redundant**
Install FactoryTalk Alarms and Events manually

FactoryTalk Alarms and Events software is installed when you install FactoryTalk View Site Edition and RSLinx Enterprise software. It is not installed as part of the FactoryTalk Services Platform. If you installed the platform on a computer where FactoryTalk View Site Edition and RSLinx Enterprise are not installed, you will not have the FactoryTalk Alarms and Events software and must install it manually.

The following illustration shows a sample FactoryTalk system with Alarms and Events installed on various computers.

**Summary of steps**

**Step 1.** Confirm that FactoryTalk Services Platform is installed on the computer
where you are going to install FactoryTalk Alarms and Events.

**Step 2.** Install FactoryTalk Alarms and Events.

FactoryTalk Services Platform must be installed before installing FactoryTalk Alarms and Events.

To check if you have FactoryTalk Services Platform:

1. On the Start menu, click Control Panel and then click Programs and Features.
2. In the list, look for FactoryTalk Services Platform 2.10 (CPR 9) or later. If it is not in the list, install it. For instructions, see either the FactoryTalk View Site Edition Installation Guide or the RSLinx Enterprise installation instructions.

Log in as a user with administrative rights before you begin the installation. As part of the installation process, FactoryTalk Alarms and Events creates program folders and modifies registry entries. To make these modifications, the user that is currently logged in must have administrative rights on the computer on which FactoryTalk Alarms and Events is installed.

1. Close any open programs.
2. At the root of the FactoryTalk View SE or RSLinx Enterprise DVD, open the FTAE folder and then double-click Setup.exe.
3. If the .NET 4.6 Framework is not already installed on your computer, you are prompted to install it. Follow the instructions on the screen.
4. In the Welcome dialog box, click Next.
5. Click the option to accept the End User License Agreement and then click Next.
6. Select the Complete Installation option and then click Next.
7. Click Install to begin the installation.
8. When the installation is finished, click Finish to close the window.
Install SQL Server 2014 SP2 Express

FactoryTalk Alarms and Events uses Microsoft SQL Server as the database engine for logging alarm and event information. You can connect to an existing SQL Server database. You can also install SQL Server 2014 SP2 Express, which is included in the FTView\Redist folder on the FactoryTalk View installation DVD.

If you do not have an existing SQL Server database, or do not plan to use it, follow the instructions outlined in this chapter to make sure that SQL Server 2014 SP2 Express is installed with the correct features enabled. See Summary of Steps on page 228 for details.

You can install the database on the same computer used to host other FactoryTalk servers, or on a separate computer. Depending on the size of your system, you might choose to use a separate computer as a dedicated logging computer to balance processing power.

For more information on using an existing SQL Server database, see Use an existing SQL Server database on page 233.

Operating systems

Microsoft SQL Server works with the following Microsoft Windows versions:

- Windows Server 2012 R2 Datacenter Edition (64-bit only)
- Windows Server 2012 Datacenter Edition (64-bit only)
- Windows Server 2012 R2 Standard Edition (64-bit only)
- Windows Server 2012 Standard Edition (64-bit only)
- Windows Server 2008 R2 Enterprise Edition SP1 (64-bit only)
- Windows Server 2008 R2 Standard Edition SP1 (64-bit only)
- Windows 10 Professional and Enterprise Editions (32- and 64-bit)
- Windows 8.1 Professional and Enterprise Editions (32- and 64-bit)
- Windows 8 Professional and Enterprise Editions (32- and 64-bit)
- Windows 7 Professional, Enterprise, and Ultimate Editions, SP1 (32- and 64-bit)
Summary of steps

The following is a summary of the steps required to install SQL Server 2014 SP2 Express. Each step is described in more detail on the following pages.

**Step 1. Open the FTView folder**

Open the FTView folder, which is at the root of the FactoryTalk View installation DVD. The subfolders Redist contains the software for SQL Server 2014 SP2 Express.

**Step 2. Install the .NET Framework.**

The SQL Server 2014 SP2 Express installation fails without this component.

**Step 3. Run the SQL Server Install batch file to install and configure SQL Server 2014 SP2 Express.**

**Step 4. Configure the Windows firewall if you want to allow for remote connections.**

Step 1. Open the FTView folder

The FTView folder is located at the root of the FactoryTalk View installation DVD and contains the following folders:

<table>
<thead>
<tr>
<th>Folder Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redist\DotNETFX_4.6*</td>
</tr>
<tr>
<td>Description: Installation for Microsoft .NET Framework version 4.6. You might already have the .NET Framework software on your computer, but verify the correct version is installed or the SQL Server install fails.</td>
</tr>
<tr>
<td>Redist\SQLServerEXPR_2014SP2</td>
</tr>
<tr>
<td>Description: Installation for SQL Server 2014 SP2 Express.</td>
</tr>
</tbody>
</table>

(*) This software component is a prerequisite that must be installed before you install SQL Server 2014 SP2 Express. If the installation program identifies other missing components, download them from the Microsoft website.

Step 2. Install the .NET Framework

The Microsoft .NET Framework version 4.6 is a prerequisite for SQL Server 2014 SP2 Express. You need to manually install it if it is not installed.

**Tip:** If you have .NET Framework 1.2 or any version before 2.0.50727, you must uninstall it (versions 1.0 and 1.1 do not have to be uninstalled) before installing the correct version.

To determine which .NET Framework versions are on your computer, see Microsoft Knowledge Base article 318785.

To install the .NET Framework version 4.6

1. At the root of the FactoryTalk View installation DVD, open the \FTView\Redist\DotNETFX_4.6 folder and then double-click NDP46-KB3045557-x86-x64-AllOS-ENU.exe.

2. Follow the on-screen instructions.
Step 3. Run the SQL Server Install batch file (not the .exe)

The batch file installs SQL Server 2014 SP2 Express on your computer with the correct settings for logging alarms and events. The batch file configures the following settings for SQL Server:

- Allow remote connections to the database using the TCP/IP protocol.
- Enable SQL Server Browser.

To install SQL Server 2014 SP2 Express

1. Close any open programs.

2. At the root of the FactoryTalk View installation DVD, open the `FTView\Redist\SQLServerEXPR_2014SP2` folder and then double-click `SQL Server Install.bat`.

3. In the **Setup Support Rules** window, click **OK**.

4. In the **Product Key** window, click **Next** (SQL Server 2014 SP2 Express does not need a product key).

5. Review the End User License Agreement, select the check box to accept it, and then click **Next**.

6. In the **Setup Support Files** window, click **Install**.

   If the system configuration check identifies any missing software components, installation fails, and the missing components show in the System Configuration window. Download the missing components listed from the Microsoft web site.

7. In the **Setup Support Rules** window, click **Next**.

8. In the **Feature Selection** window, click **Next**.

9. In the **Instance Configuration** window, click **Next**.

10. In the **Disk Space Requirements** window, click **Next**.

11. In the **Server Configuration** window, specify a service account for the SQL Server Database Engine. Click **Next**.

12. In the **Database Engine Configuration** window, select **Mixed mode** and then enter a password for the built-in SQL Server system administrator account. If there is no user listed in the **Specify SQL Server administrators** edit box, you must add a user. Click **Next**.
13. In the **Error and Usage Report** window, leave the check boxes unselected, and then click **Next**.

14. In the **Installation Rules** window, click **Next**.

15. In the **Ready to Install** window, click **Install**.

16. When the components finish installing, click **Next**.

17. In the **Complete** window, click **Close**.

**Step 4. Configure the Windows firewall**

If you want to allow remote connections to the SQL Server database, the database engine service and the SQL Server Browser service must be added to the Windows Firewall Exception List. Perform these steps if you:

- Have remote clients (for example, a log viewer) that needs access to the database.
- Want to configure the database remotely.

**To configure the Windows firewall**

1. In Windows, click **Start > Control Panel > Windows Firewall**.

2. On the **Exceptions** tab, SQL Server (sqlservr.exe) might be listed in the Programs and Services box, but not selected as an exception. If you select the check box, Windows will open port 1433 to allow TCP requests. Alternatively, if you do not see SQL Server listed:
   - Click the **Add Program** button.
   - Click the **Browse** button.
   - Open the folder at `<drive letter>:\Program Files\Microsoft SQL Server\MSSQL12.SQLEXPRESS\MSSQL\Binn.`
   - Select **sqlservr.exe** and then click **Open**.
   - In the **Add Program** dialog box, click **OK**. **Sqlservr.exe** is displayed in the list with a check mark beside it.

3. To add the SQL Server Browser service to the exception list:
- Click the **Add Program** button.
- Click the **Browse** button.
- Open the folder at `<drive letter>:\Program Files\Microsoft SQL Server\90\Shared`.
- Select `sqlbrowser.exe`, and then click **Open**.
- In the **Add Program** dialog box, click **OK**. `Sqlbrowser.exe` is displayed in the list with a check mark beside it.

4. Click **OK** to accept the changes and close the **Windows Firewall** dialog box.
Use an Existing SQL Server database

FactoryTalk Alarms and Events can use an existing Microsoft SQL Server as the database engine for logging alarm and event information.

You must set up the correct settings for logging alarm and event data if you are using an existing SQL Server database. For more information on the settings, see Summary of steps on page 233.

Supported SQL Server databases

FactoryTalk Alarms and Events can use any of the following SQL Server databases:

- SQL Server 2014 Standard (64-bit)
- SQL Server 2012 Standard SP2 (32-bit or 64-bit)
- SQL Server 2008 R2 Standard SP3 (32-bit or 64-bit)
- SQL Server 2008 Standard SP4 (32-bit)

Remote connections to the SQL Server database

To allow remote connections to the database you must configure the TCP/IP protocol, the SQL Server Browser, and the Windows Firewall. Perform these steps if you:

- Have remote clients (for example, a log viewer) that needs access to the database.
- Want to configure the database remotely.

Summary of steps

Step 1. Install SQL Server Management Tools on page 233

Step 2. Specify Mixed Mode authentication for the SQL Server database on page 234

Step 3. Configure TCP/IP protocol for the database on page 235

Step 4. Enable the SQL Server Browser service on page 235

Step 5. Configure the Windows Firewall on page 235

Step 1. Install SQL Server Management Tools

To add the SQL Server Management Tools to an existing instance of SQL Server, complete these steps:
1. Close any open programs.

2. In Windows, open Control Panel, and then open Programs and Features.

3. In the list that appears, double-click your SQL Server version.

4. For SQL Server 2008 R2, follow these steps:
   a. On the SQL Server 2008 R2 page, click Add.
   b. Enter the location of the Setup.exe file on the SQL Server installation media, and then click OK to open the Microsoft SQL Server Installation Wizard.
   c. Follow the instructions in the wizard until you get to the Feature Selection page.
   d. In the Feature Selection page, select the Management Tools - Basic check box. If you do not want to install the complete management tools, clear the Management Tools - Complete check box.
   e. Click Next.

5. Follow the remaining instructions in the wizard to complete the installation. If you are prompted to restart, click Yes.

To change the authentication mode and configure the sa login, complete these steps:

1. Open SQL Server Management Studio.

2. In Object Explorer, right-click the server node, and then click Properties.

3. On the Security page, under Server authentication, select SQL Server and Windows Authentication mode, and then click OK.

4. In Object Explorer, expand Security, expand Logins, right-click sa, and then click Properties.

5. On the General page, you may have to create and confirm a password for the sa login.

6. On the Status page, under Login, click Enabled, and then click OK.

7. If you changed the authentication mode, restart the server. In Object Explorer, right-click the server node, and then click Restart.
To configure TCP/IP protocol for the database, complete these steps.

If you are using SQL Server 2008:

1. Click Start > All Programs > Microsoft SQL Server 2008 > Configuration Tools > SQL Server Configuration Manager.

2. In Object Explorer, click SQL Server Network Configuration, and then click Protocols for SQLServer/myinstancename.

3. In the details pane, right-click TCP/IP, and then click Enabled.

4. Set all other protocols listed in the details pane to Disabled.

5. To finish, restart the SQL Server. In Object Explorer, right-click on the SQL Server instance, and then click Restart.

To enable the SQL Server Browser service, complete these steps.

If you are using SQL Server 2008 R2:

1. Click Start > All Programs > Microsoft SQL Server 2008 > Configuration Tools > SQL Server Configuration Manager.

2. Click SQL Server Services.

3. In the details pane, right-click SQL Server Browser. Click Properties.

4. In the Properties dialog box, on the General tab, set Startup type to Automatic, and then click OK.

To configure the Windows Firewall, perform the following steps:

1. Click Start > Control Panel > Windows Firewall.

2. On the Exceptions tab, SQL Server (sqlservr.exe) might be listed in the Programs and Services box, but not selected as an exception. If you select the check box, Windows will open port 1433 to allow TCP requests.

3. Click OK to accept the changes and close the Windows Firewall dialog box.

If SQL Server is not listed it must be added:

4. Click the Add Program button.

5. Click the Browse button.
6. Open the folder at `<drive letter>:\Program Files\Microsoft SQL Server\MSSQL10.SQLEXPRESS\MSSQL\BINN`.

   If you use SQL Server 2014 SP2 Express, open the folder at `<drive letter>:\Program Files\Microsoft SQL Server\MSSQL12.SQLEXPRESS\MSSQL\BINN`.

7. Select `sqlservr.exe`, and then click `Open`.

8. In the `Add Program` dialog box, click `OK`.
   * `sqlservr.exe` is displayed in the list with a check mark beside it.

   Now add the SQL Server Browser service to the exception list:

9. Click the `Add Program` button.

10. Click the `Browse` button.

11. Open the folder at `drive:\Program Files\Microsoft SQL Server\90\Shared`.

12. Select `sqlbrowser.exe`, and then click `Open`.

13. In the `Add Program` dialog box, click `OK`.
   * `Sqlbrowser.exe` is displayed in the list with a check mark beside it.

14. Click `OK` to accept the changes and close the `Windows Firewall` dialog box.
Alarm time stamping

FactoryTalk Alarms and Events provides excellent time-stamp accuracy compared with traditional alarm monitoring systems, and you can obtain better time-stamp resolution in some cases by using time stamps directly retrieved from peripheral devices such as I/O cards or other time-stamping hardware.

When an analog (ALMA) or digital (ALMD) alarm instruction executes as an alarm event occurs, the current Universal Coordinated Time (UTC) value of the controller’s wall clock is captured and delivered to the FactoryTalk Alarms and Events system with the alarm.

This appendix shows how to replace the controller’s wall clock time in an alarm event with a time stamp from an external source.

You can take events from an I/O card such as a 1756-IB16ISOE and use the 50-microsecond accuracy from the card’s time stamp when delivering an alarm to the rest of the alarm monitoring system.

Resolve these points when you replace the normal time stamp provided with the alarm instructions:

- Alarm time stamps must be in UTC with no time zone or daylight savings time offset included (these offsets are automatically added to the time stamp when it is displayed).
- The alarm time stamp is usually represented as a long integer (LINT) data type, occupying one 64-bit word. Most I/O cards stamp time using two double integers (DINT), occupying two 32-bit words.

Overview of time keeping

In the RSLogix 5000 environment, time is represented in three different ways: Local Time, Coordinated System Time, and Universal Coordinated Time.

Coordinated System Time (CST)  
Coordinated System Time is provided by a free-running backplane clock that starts counting the first time the system is powered up. CST is used for time stamping, event tracking between processors and I/O cards, as well as for motion planning among multiple motion modules. CST has no relevance to real-world time, but can be converted to Coordinated Universal Time (UTC) using an offset. CST time stamps must be converted to UTC before passing them to the alarm monitoring system.
Coordinated Universal Time (UTC)

Coordinated Universal Time is a real-world time relative to a time constant, but with no time zone information and no daylight saving time offsets. It is the raw value used to represent time and also the value required for time stamps in the FactoryTalk Alarms and Events system. UTC is equivalent to Greenwich Mean Time, with no daylight savings time offsets.

Advantage of using UTC for time stamps is that distributed events can be compared, regardless of their geographical location or where they are, relative to Daylight Savings Time (DST). The software reading the time stamp can then convert UTC time stamps to local time. Logix 5000 and FactoryTalk Alarms and Events graphic objects convert UTC time stamps to the local time of the workstation running the software application.

Time stamps from different sources may or may not be returned in UTC format, depending on the device generating the time stamp and how it is configured. For example, a 1756-IB16ISOE module can return time in UTC if configured to do so.

In the RSLogix 5000 software, time is often returned as two 32-bit DINT data types instead of one 64-bit LINT data type. The FactoryTalk Alarms and Events system requires the time stamps to use the LINT data type. If a module (for example, the 1756-IB16ISOE module) returns the time stamp in two DINTs instead of a LINT, you will have to convert the time format into a LINT. To perform this conversion, an Add-On Instruction is available for download from the RSLogix 5000 sample code website in the Rockwell Automation Sample Code Library. You can locate this code by performing a search for LINT on the search page.

Local Time (Wall Clock Time)

Local time (often referred to as Wall Clock Time) is the time in the real world where the controller is located. This means that Wall Clock time is UTC, but with time zone and Daylight Savings Time (DST) offsets added.

Local Time is typically used to trigger local events (like turning on a pump at 1:00AM during shift change). Local time values must be converted to UTC before passing them to an alarm monitoring system.
You can see the calculated result in RSLogix 5000, in the **Controller Properties** dialog box, on the **Date/Time** tab, as shown in the following illustration.

![Controller Properties Dialog Box](image)

We recommend using local time only to drive events from the controller, and not to time-stamp alarms.

**ALMD and ALMA alarm blocks**

When the controller detects a condition that causes an In Alarm event, the controller stores the current UTC value in the backing tag for the alarm.
1. The alarm is provided by ladder logic that includes the ALMD or ALMA instructions:
2. In the ALMD Properties dialog box, in the Configuration tab, click the Browse button (...) to edit the alarm message sent when the alarm is triggered.

3. On the Status tab, time stamps appear when the alarm is triggered, acknowledged, returns to normal, or when the alarm count is reset.

4. On the Parameters tab, these UTC time stamps are automatically transferred to tags that you can then use in logic of your own.
For details about adding an Alarm and Event Summary object to a graphic display in FactoryTalk View, see Set up graphic displays on page 89.

Insert time stamps manually

To insert a time stamp manually, in the ALMD Properties dialog box, on the Tag tab, enter the new time under the .ProgTime element. Set the boolean .UseProgTime in the backing tag for the alarm before the actual alarm instruction is triggered.

Example
Time synchronization

FactoryTalk Alarms and Events provides excellent resolution and accuracy for alarms and events time stamps. You can build a very accurate time sequence for events that led to a failure, or simply to diagnose the exact order of their occurrence. Because the alarms are generated by the controller, the time-stamp accuracy is a function of the rate of the controller’s ability to scan the alarm instruction, plus the accuracy of the controller’s wall clock.

When an alarm instruction is evaluated in code and an alarm transition event occurs (goes into alarm, or is acknowledged, suppressed, and so on), the instruction immediately records the current value of the controller’s wall clock. This 64-bit, microsecond-resolution number reflects the time of the event relative to the controller’s wall clock in UTC time (no time zone or daylight savings information is included). When you view this time stamp, either in the Logix Designer application (RSLogix 5000 software) or in FactoryTalk View Site Edition, the time zone of the computer running the software is used to visualize the time value. You can use a distributed system that covers multiple time zones to display a valid sequence of events at an operator or maintenance station independently of the time zone the time stamps are captured in.

Because alarm events can originate in multiple controllers distributed over an enterprise, it is important to provide a common time reference to set these clocks. A controller with a wall clock that is out of synchronization with the rest of the enterprise can potentially log events out of the time sequence in which they actually occurred, relative to the other controllers.

Setting the controllers’ wall clocks individually by hand is inefficient. Additionally, clock drift naturally causes these clocks to record time further and further apart from each other. There are several automated methods to manage the wall clocks on multiple controllers, the easiest and most cost-effective of which is the Logix5000 Clock Update Tool.

The Logix5000 Clock Update Tool lets you view and synchronize the system time of the controllers and devices on a network, using any computer running Microsoft Windows and RSLinx Classic. You can also schedule automatic synchronization of all devices. See [Create a synchronization schedule](#) on page 246.

The accuracy of time synchronization varies based on many factors, including the network path and what the controller is doing when the time synchronization takes place. Typical systems using the Logix5000 Clock Update Tool coordinate
clocks to approximately 300ms. If you need greater accuracy for clock synchronization than the Logix5000 Clock Update Tool can provide, there are several other hardware-based options to improve the accuracy of time stamps in the control system. These include IRIGB, NTP, GPS, and IEEE 1588 Ethernet.

This stand-alone tool is included with the RSLogix 5000 software. Using RSLinx to browse to multiple controllers, this tool synchronizes multiple wall clocks at a user-defined rate in a variety of controllers, including PLC-5, SLC 500s, MicroLogix, and all Logix5000 controllers (except the SoftLogix controller which typically obtains the time from the clock in the computer where the controller is installed).

1. On the RSLogix 5000 software install media, open the Tools folder and then double-click Setup.exe. You can also install this tool when installing the RSLogix 5000 software (the Logix Designer application).

2. Follow the instructions on the screen to install the Logix5000 Clock Update Tool.

- Click Start > All Programs > Rockwell Software > RSLogix 5000 Tools > Logix5000 Clock Update Tool > Logix5000 Clock Update Tool.

You can start the Logix5000 Clock Update Tool automatically when you start Windows.

- In the Logix5000 Clock Update Tool, on the File menu, click Start the application when Windows starts.

The next time you start Windows, the Clock Update Tool opens automatically.
Use the Logix5000 Clock Update Tool

The Logix5000 Clock Update Tool lets you view and synchronize the system time of the controllers and devices on a network, using any computer running Microsoft Windows and RSLinx Classic. You can also schedule automatic synchronization of all devices.

The left pane of the Clock Update Tool window contains a tree view, with these items:

- **Scheduled Synchronizations** lists synchronization schedules that have been configured. Right-click an individual schedule for more options.
- **Devices** lists devices that have been configured. Right-click an individual device for more options.
- **Log** contains a log of the most recent events. The path indicated under the list of events contains the location of the complete log file for the day.

Synchronize devices on a schedule

To synchronize devices on a schedule, complete these steps:

1. Create a synchronization schedule. This schedule determines when synchronization takes place.

2. Create a list of devices you want to synchronize and then add them to synchronization schedules. Devices that are not included in this list are not synchronized.

3. Optionally, match existing devices with existing synchronization schedules. Skip this step if you specified a synchronization schedule when you added
the device. Devices that are not matched to any synchronization schedule are not synchronized.

This section includes information about each of these steps.

**Create a synchronization schedule**

A synchronization schedule determines when devices are synchronized. For example, you can schedule devices to be synchronized on a fixed time interval. You can also configure a synchronization schedule to expire on a particular date.

1. In the Logix5000 Clock Update Tool window, in the left pane, click **Scheduled Synchronizations**.

2. Right-click the right pane and then click **Add Event**.

3. In the **Update Date and Time Interval** dialog box, set up a schedule for synchronizing the date and time, and then click **OK**.

The new schedule information appears, as shown in the following example:

**Remove a synchronization schedule**
To remove a synchronization schedule from the list:

1. Right-click the synchronization schedule you want to remove and then click **Remove Event**.

2. Any devices that were associated with this synchronization schedule are no longer associated with a schedule.

**Modify a synchronization schedule**

1. To modify an existing synchronization schedule, right-click the synchronization schedule and then click **Modify Event**.

2. In the **Update Date and Time Interval** dialog box, modify the schedule information, and then click **OK**.

**Enable or disable a synchronization schedule**

Occasionally, you might want to temporarily disable a synchronization schedule, rather than permanently delete it.

- To disable a synchronization schedule, right-click the synchronization schedule you want to disable and then click **Disable Event**.

- To enable a synchronization schedule, right-click the disabled synchronization schedule you want to enable, and then click **Enable Event**.

**Add devices**

After creating one or more synchronization schedules, add the devices you want to include in the schedules.

When you add a device, you can also match it to a synchronization schedule, or you can add all of the devices first and then match them to synchronization schedules later. If you add the devices later, you can add all of the devices to a single synchronization schedule in one step.

You can add a device to only one synchronization schedule.

**To add a device:**

1. In the Logix5000 Clock Update Tool, in the left pane, click **Devices**.
2. Right-click anywhere in the right pane and then click **Add New Device** or click the **Add Device** button.

3. In the **RSLinx** dialog box, browse to the device you want to add, select it, and then click **OK**.

   **Tip:** You cannot click **OK** unless you have selected a device that is capable of being synchronized and has not already been configured.

4. In the **Add Device to Schedule** list, select the synchronization schedule to which you want to add the device, and then click **OK**.

   The device is added to the list. Because this device has not yet been synchronized, question marks (?????) appear in the **Last Update** column.

---

**Remove a device**

- To remove a device from the list, right-click the device you want to remove, and then click **Remove Device**. You can also select the device your want to remove, and then click the **Remove Device** button. If the device is associated with a particular synchronization schedule, it is removed from that schedule.
If you want to remove all devices from the list, right-click in the Device pane and then click **Remove All Devices**. All devices are removed from the list, as well as from their respective synchronization schedules.

**View details about a device**

To view the details of a particular device, right-click the device and then click **Device Properties**. This shows major and minor firmware revision information, Computer Time, Device Time, Response Time, and the Time Difference between the computer and the device.

**Assign devices to synchronization schedules**

When a synchronization schedule is selected in the left pane, the Device pane lists all of the devices that are configured.

**Tip:** When you add a new device, you can assign it to a specific schedule at that time. See **Add devices** on page 247.

- To add a device to the selected synchronization schedule, select the check box to the left of the device. To remove the device from the synchronization schedule, clear the check box.
To add all devices to the specified schedule, select the Select All check box at the bottom of the list.

**Synchronize devices manually**

In addition to scheduling automatic synchronization, you can synchronize devices manually. Either:

- Click the Synchronize All Devices button on the toolbar.
- Right-click a device and then click Synchronize Device or right-click anywhere in the Device pane and then click Synchronize All Devices.

Any errors in synchronization are saved to the log file. In addition, an icon appears in the device list and in the main tree view to indicate the error. The log file indicates a specific cause for the error, where one is known.

**View the log file**

To view a log of the most recent events, in the left pane click Log. The path shown under the list of events contains the location of the complete log file for the day. The log file is saved in .txt and .xml format.

The default location for the synchronization log file is C:\Program Files\Rockwell Software\RSLogix 5000 Tools\Logix5000 Clock Update Tool.

To change the location of the log file:

1. On the Log menu, click Change Log File Location (or to the right of the Path box at the bottom of the Update Tool window, click the Browse button ...).
2. In the **Browse for Folder** dialog box, select the new folder for the log files, and then click **OK**. To create a new folder for the log file, click **Make New Folder**.

### Time stamps with tag-based alarms

If your FactoryTalk Alarms and Events system includes tag-based alarm servers, the time stamps for those alarms come from the computer that hosts the server that provides tags to the alarm server (for example, RSLinx Enterprise or a third-party Data Server). To ensure that alarms are ordered properly by time, you must synchronize the computer’s clock with the controllers’ clocks.

The simplest way to solve this synchronization problem is to run the Logix5000 Clock Update Tool on the same computer as the RSLinx Enterprise alarm server. This ensures that the controller clocks all synchronize with the computer’s tag-based alarm server. Typical systems using this method commonly achieve 300ms synchronization.

If it is not possible to install the Logix5000 Clock Update Tool on the same computer that hosts the data server that provides tags for the tag-based alarm server, try to synchronize the computer’s clock with the same NTP server that is used to synchronize the control network, with similar network latencies.

For details about tag-based alarms, see Add a tag-based alarm server for Logix5000, PLC-5, SLC 500, or third-party controllers on page 77.

### Supported devices

The Logix5000 Clock Update Tool supports the following controller families:

- ControlLogix
- CompactLogix
Appendix G

Time synchronization

- All CompactLogix processors can be used with ENI. CompactLogix L32E and CompactLogix L35E can be directly connected via Ethernet or with ENI.
- Make sure that the CompactLogix port is set up for DF1 full-duplex.
- Make sure routing is enabled on NET-ENI. Net-ENI works with Ethernet devices drivers and not with EtherNet/IP drivers.
- DriveLogix
- FlexLogix
- PLC-5
- SLC
- MicroLogix
- PowerMonitor
Reference for building a distributed system

This system configuration guide primarily focuses on building an alarms and events system on a single computer.

When building a distributed system on multiple computers on the network, keep the following guidelines in mind.

When installing FactoryTalk Alarms & Events

FactoryTalk Alarms and Events is installed with FactoryTalk View and RSLinx Enterprise. There is no need to install FactoryTalk Alarms and Events separately unless you have installed FactoryTalk Services Platform on a computer where you have not installed FactoryTalk View or RSLinx Enterprise.

For details, see Install FactoryTalk Alarms and Events manually on page 225.

Typical distributed system on a network

In the sample distributed automation system shown next, FactoryTalk Services Platform is installed on every computer in the network.
The diagram shows just one example of a possible network layout for a group of computers and software products participating in a FactoryTalk Alarms and Events system using a FactoryTalk Network Directory. Use this diagram only as a starting point--your own distributed system will vary.
Appendix I

Language identifiers for language switching

With the FactoryTalk View language switching feature, run-time operators can view the text strings defined in an application in up to 40 different languages. FactoryTalk View SE Clients can run in any of the languages an application supports. In a network distributed application or network station application, multiple clients can run in different languages at the same time.

The languages in the following table are supported for language switching by the application at run time. Be sure that these languages are installed on the development and client computers before trying to switch languages.

To find out which languages are installed on a computer, open Control Panel. Click Region and Language.

Installed languages are listed in the dialog box. The language that has a check mark beside it is the default language.

For more information on adding alarm messages in multiple languages to a FactoryTalk Tag Alarm and Event Server, see Enter alarm messages in other languages on page 198.

The following table lists the language identifiers:

<table>
<thead>
<tr>
<th>Language</th>
<th>ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>Afrikaans (South Africa)</td>
<td>af-ZA</td>
</tr>
<tr>
<td>Albanian (Albania)</td>
<td>sq-AL</td>
</tr>
<tr>
<td>Arabic (Algeria)</td>
<td>ar-DZ</td>
</tr>
<tr>
<td>Arabic (Bahrain)</td>
<td>ar-BH</td>
</tr>
<tr>
<td>Arabic (Egypt)</td>
<td>ar-EG</td>
</tr>
<tr>
<td>Arabic (Iraq)</td>
<td>ar-IQ</td>
</tr>
<tr>
<td>Arabic (Jordan)</td>
<td>ar-JO</td>
</tr>
<tr>
<td>Arabic (Kuwait)</td>
<td>ar-KW</td>
</tr>
<tr>
<td>Arabic (Lebanon)</td>
<td>ar-LB</td>
</tr>
<tr>
<td>Arabic (Libya)</td>
<td>ar-LY</td>
</tr>
<tr>
<td>Arabic (Morocco)</td>
<td>ar-MA</td>
</tr>
<tr>
<td>Arabic (Oman)</td>
<td>ar-OM</td>
</tr>
<tr>
<td>Arabic (Qatar)</td>
<td>ar-QA</td>
</tr>
<tr>
<td>Arabic (Saudi Arabia)</td>
<td>ar-SA</td>
</tr>
<tr>
<td>Language (Syria)</td>
<td>ID</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Arabic (Syria)</td>
<td>ar-SY</td>
</tr>
<tr>
<td>Arabic (Tunisia)</td>
<td>ar-TN</td>
</tr>
<tr>
<td>Arabic (U.A.E.)</td>
<td>ar-AE</td>
</tr>
<tr>
<td>Arabic (Yemen)</td>
<td>ar-YE</td>
</tr>
<tr>
<td>Armenian (Armenia)</td>
<td>hy-AM</td>
</tr>
<tr>
<td>Azeri (Cyrillic)</td>
<td>az-Cyril-AZ</td>
</tr>
<tr>
<td>Azeri (Latin)</td>
<td>az-Latn-AZ</td>
</tr>
<tr>
<td>Basque</td>
<td>eu-ES</td>
</tr>
<tr>
<td>Belarusian</td>
<td>be-BY</td>
</tr>
<tr>
<td>Bosnian (Cyrillic, Bosnia and Herzegovina)</td>
<td>bs-Cyril-BA</td>
</tr>
<tr>
<td>Bosnian (Latin, Bosnia and Herzegovina)</td>
<td>bs-Latn-BA</td>
</tr>
<tr>
<td>Bulgarian</td>
<td>bg-BG</td>
</tr>
<tr>
<td>Catalan</td>
<td>ca-ES</td>
</tr>
<tr>
<td>Chinese (Hong Kong S.A.R.)</td>
<td>zh-HK</td>
</tr>
<tr>
<td>Chinese (Macau S.A.R.)</td>
<td>zh-M0</td>
</tr>
<tr>
<td>Chinese (PRC)</td>
<td>zh-CN</td>
</tr>
<tr>
<td>Chinese (Singapore)</td>
<td>zh-SG</td>
</tr>
<tr>
<td>Chinese (Taiwan)</td>
<td>zh-TW</td>
</tr>
<tr>
<td>Croatian (Croatia)</td>
<td>hr-HR</td>
</tr>
<tr>
<td>Czech (Czech Republic)</td>
<td>cs-CZ</td>
</tr>
<tr>
<td>Danish (Denmark)</td>
<td>da-DK</td>
</tr>
<tr>
<td>Divehi (Maldives)</td>
<td>dv-MV</td>
</tr>
<tr>
<td>Dutch (Belgium)</td>
<td>nl-BE</td>
</tr>
<tr>
<td>Dutch (Netherlands)</td>
<td>nl-NL</td>
</tr>
<tr>
<td>English (Australia)</td>
<td>en-AU</td>
</tr>
<tr>
<td>English (Belize)</td>
<td>en-BZ</td>
</tr>
<tr>
<td>English (Canada)</td>
<td>en-CA</td>
</tr>
<tr>
<td>English (Caribbean)</td>
<td>en-029</td>
</tr>
<tr>
<td>English (Ireland)</td>
<td>en-IE</td>
</tr>
<tr>
<td>English (Jamaica)</td>
<td>en-JM</td>
</tr>
<tr>
<td>English (New Zealand)</td>
<td>en-NZ</td>
</tr>
<tr>
<td>English (Philippines)</td>
<td>en-PH</td>
</tr>
<tr>
<td>English (South Africa)</td>
<td>en-ZA</td>
</tr>
<tr>
<td>English (Trinidad )</td>
<td>en-TT</td>
</tr>
<tr>
<td>English (United Kingdom)</td>
<td>en-GB</td>
</tr>
<tr>
<td>English (United States)</td>
<td>en-US</td>
</tr>
<tr>
<td>English (Zimbabwe)</td>
<td>en-ZW</td>
</tr>
<tr>
<td>Estonian (Estonia)</td>
<td>et-EE</td>
</tr>
<tr>
<td>Faroese (Faroe Islands)</td>
<td>fo-FO</td>
</tr>
<tr>
<td>Farsi</td>
<td>fa-IR</td>
</tr>
<tr>
<td>Filipino (Philippines)</td>
<td>fil-PH</td>
</tr>
<tr>
<td>Language</td>
<td>ID</td>
</tr>
<tr>
<td>---------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Finnish (Finland)</td>
<td>fi-FI</td>
</tr>
<tr>
<td>French (Belgium)</td>
<td>fr-BE</td>
</tr>
<tr>
<td>French (Canada)</td>
<td>fr-CA</td>
</tr>
<tr>
<td>French (France)</td>
<td>fr-FR</td>
</tr>
<tr>
<td>French (Luxembourg)</td>
<td>fr-LU</td>
</tr>
<tr>
<td>French (Monaco)</td>
<td>fr-MC</td>
</tr>
<tr>
<td>French (Switzerland)</td>
<td>fr-CH</td>
</tr>
<tr>
<td>Frisian (Netherlands)</td>
<td>fy-NL</td>
</tr>
<tr>
<td>FRYO (Macedonian)</td>
<td>mk-MK</td>
</tr>
<tr>
<td>Galician</td>
<td>gl-ES</td>
</tr>
<tr>
<td>Georgian</td>
<td>ka-GE</td>
</tr>
<tr>
<td>German (Austria)</td>
<td>de-AT</td>
</tr>
<tr>
<td>German (Germany)</td>
<td>de-DE</td>
</tr>
<tr>
<td>German (Liechtenstein)</td>
<td>de-LI</td>
</tr>
<tr>
<td>German (Luxembourg)</td>
<td>de-LU</td>
</tr>
<tr>
<td>German (Switzerland)</td>
<td>de-CH</td>
</tr>
<tr>
<td>Greek (Greece)</td>
<td>el-GR</td>
</tr>
<tr>
<td>Gujarati (India)</td>
<td>gu-IN</td>
</tr>
<tr>
<td>Hebrew (Israel)</td>
<td>he-IL</td>
</tr>
<tr>
<td>Hindi (India)</td>
<td>hi-IN</td>
</tr>
<tr>
<td>Hungarian (Hungary)</td>
<td>hu-HU</td>
</tr>
<tr>
<td>Icelandic (Iceland)</td>
<td>is-IS</td>
</tr>
<tr>
<td>Indonesian (Indonesia)</td>
<td>id-ID</td>
</tr>
<tr>
<td>Inuktitut (Latin, Canada)</td>
<td>iu-Latn-CA</td>
</tr>
<tr>
<td>Irish (Ireland)</td>
<td>ga-iE</td>
</tr>
<tr>
<td>Italian (Italy)</td>
<td>it-IT</td>
</tr>
<tr>
<td>Italian (Switzerland)</td>
<td>it-CH</td>
</tr>
<tr>
<td>Japanese (Japan)</td>
<td>ja-JP</td>
</tr>
<tr>
<td>Kannada (India)</td>
<td>kn-IN</td>
</tr>
<tr>
<td>Kazakh (Kazakhstan)</td>
<td>kk-KZ</td>
</tr>
<tr>
<td>Konkani (India)</td>
<td>kok-IN</td>
</tr>
<tr>
<td>Korean (Korea)</td>
<td>ko-KR</td>
</tr>
<tr>
<td>Kyrgyz (Cyrillic)</td>
<td>ky-KG</td>
</tr>
<tr>
<td>Latvian (Latvia)</td>
<td>lv-LV</td>
</tr>
<tr>
<td>Lithuanian (Lithuania)</td>
<td>lt-LT</td>
</tr>
<tr>
<td>Luxembourgish (Luxembourg)</td>
<td>lb-LU</td>
</tr>
<tr>
<td>Malay (Brunei Darussalam)</td>
<td>ms-BN</td>
</tr>
<tr>
<td>Malay (Malaysia)</td>
<td>ms-MY</td>
</tr>
<tr>
<td>Maktese</td>
<td>mt-MT</td>
</tr>
<tr>
<td>Maori</td>
<td>mi-NZ</td>
</tr>
<tr>
<td>Mapudungun (Chile)</td>
<td>arm-CL</td>
</tr>
<tr>
<td>Language</td>
<td>ID</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>----------</td>
</tr>
<tr>
<td>Marathi (India)</td>
<td>mr-IN</td>
</tr>
<tr>
<td>Mohawk (Mohawk)</td>
<td>moh-CA</td>
</tr>
<tr>
<td>Mongolian (Cyrillic)</td>
<td>mn-MN</td>
</tr>
<tr>
<td>Norwegian (Bokmal)</td>
<td>nb-NO</td>
</tr>
<tr>
<td>Norwegian (Nynorsk)</td>
<td>nn-NO</td>
</tr>
<tr>
<td>Polish (Poland)</td>
<td>pl-PL</td>
</tr>
<tr>
<td>Portuguese (Brazil)</td>
<td>pt-BR</td>
</tr>
<tr>
<td>Portuguese (Portugal)</td>
<td>pt-PT</td>
</tr>
<tr>
<td>Punjabi</td>
<td>pa-IN</td>
</tr>
<tr>
<td>Quechua (Bolivia)</td>
<td>quz-BO</td>
</tr>
<tr>
<td>Quechua (Equador)</td>
<td>quz-EC</td>
</tr>
<tr>
<td>Quechua (Peru)</td>
<td>quz-PE</td>
</tr>
<tr>
<td>Romanian (Romania)</td>
<td>ro-RO</td>
</tr>
<tr>
<td>Romansh (Switzerland)</td>
<td>rm-CH</td>
</tr>
<tr>
<td>Russian (Russia)</td>
<td>ru-RU</td>
</tr>
<tr>
<td>Sami, Inari (Finland)</td>
<td>smn-FI</td>
</tr>
<tr>
<td>Sami, Lule (Norway)</td>
<td>smj-NO</td>
</tr>
<tr>
<td>Sami, Lule (Sweden)</td>
<td>smj-SE</td>
</tr>
<tr>
<td>Sami, Northern (Finland)</td>
<td>se-FI</td>
</tr>
<tr>
<td>Sami, Northern (Norway)</td>
<td>se-NO</td>
</tr>
<tr>
<td>Sami, Northern (Sweden)</td>
<td>se-SE</td>
</tr>
<tr>
<td>Sami, Skolt (Finland)</td>
<td>sms-FI</td>
</tr>
<tr>
<td>Sami, Southern (Norway)</td>
<td>sma-NO</td>
</tr>
<tr>
<td>Sami, Southern (Sweden)</td>
<td>sma-SE</td>
</tr>
<tr>
<td>Sanskrit – India</td>
<td>sa-IN</td>
</tr>
<tr>
<td>Serbian (Cyrillic)</td>
<td>sr-Cyril-CS</td>
</tr>
<tr>
<td>Serbian (Cyrillic, Bosnia and Herzegovina)</td>
<td>sr-Cyril-BA</td>
</tr>
<tr>
<td>Serbian (Latin)</td>
<td>sr-Latin-CS</td>
</tr>
<tr>
<td>Serbian (Latin, Bosnia and Herzegovina)</td>
<td>sr-Latin-BA</td>
</tr>
<tr>
<td>Sesotho sa Leboa (South Africa)</td>
<td>ns-ZA</td>
</tr>
<tr>
<td>Sestswana (South Africa)</td>
<td>tn-ZA</td>
</tr>
<tr>
<td>Slovak</td>
<td>sk-SK</td>
</tr>
<tr>
<td>Slovenian (Slovenia)</td>
<td>sl-SI</td>
</tr>
<tr>
<td>Spanish (Argentina)</td>
<td>es-AR</td>
</tr>
<tr>
<td>Spanish (Bolivia)</td>
<td>es-BO</td>
</tr>
<tr>
<td>Spanish (Chile)</td>
<td>es-CL</td>
</tr>
<tr>
<td>Spanish (Colombia)</td>
<td>es-CO</td>
</tr>
<tr>
<td>Spanish (Costa Rica)</td>
<td>es-CR</td>
</tr>
<tr>
<td>Spanish (Dominican Republic)</td>
<td>es-DO</td>
</tr>
<tr>
<td>Spanish (Ecuador)</td>
<td>es-EC</td>
</tr>
<tr>
<td>Spanish (El Salvador)</td>
<td>es-SV</td>
</tr>
<tr>
<td>Language</td>
<td>ID</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Spanish (Guatemala)</td>
<td>es-GT</td>
</tr>
<tr>
<td>Spanish (Honduras)</td>
<td>es-HN</td>
</tr>
<tr>
<td>Spanish (International Sort)</td>
<td>es-ES</td>
</tr>
<tr>
<td>Spanish (Mexico)</td>
<td>es-MX</td>
</tr>
<tr>
<td>Spanish (Nicaragua)</td>
<td>es-NI</td>
</tr>
<tr>
<td>Spanish (Panama)</td>
<td>es-PA</td>
</tr>
<tr>
<td>Spanish (Paraguay)</td>
<td>es-PY</td>
</tr>
<tr>
<td>Spanish (Peru)</td>
<td>es-PE</td>
</tr>
<tr>
<td>Spanish (Puerto Rico)</td>
<td>es-PR</td>
</tr>
<tr>
<td>Spanish (Traditional Sort)</td>
<td>es-ES_tradnl</td>
</tr>
<tr>
<td>Spanish (Uruguay)</td>
<td>es-UY</td>
</tr>
<tr>
<td>Spanish (Venezuela)</td>
<td>es-VE</td>
</tr>
<tr>
<td>Swahili (Kenya)</td>
<td>sw-KE</td>
</tr>
<tr>
<td>Swedish (Finland)</td>
<td>sv-FI</td>
</tr>
<tr>
<td>Swedish</td>
<td>sv-SE</td>
</tr>
<tr>
<td>Syriac (Syria)</td>
<td>syr-SY</td>
</tr>
<tr>
<td>Tamil (India)</td>
<td>ta-IN</td>
</tr>
<tr>
<td>Tatar (Russia)</td>
<td>tt-RU</td>
</tr>
<tr>
<td>Telugu (India)</td>
<td>te-IN</td>
</tr>
<tr>
<td>Thai (Thailand)</td>
<td>th-TH</td>
</tr>
<tr>
<td>Turkish (Turkey)</td>
<td>tr-TR</td>
</tr>
<tr>
<td>Ukrainian (Ukraine)</td>
<td>uk-UA</td>
</tr>
<tr>
<td>Urdu (Pakistan)</td>
<td>ur-PK</td>
</tr>
<tr>
<td>Uzbek (Cyrillic)</td>
<td>uz-Cyr-UZ</td>
</tr>
<tr>
<td>Uzbek (Latin)</td>
<td>uz-Latn-UZ</td>
</tr>
<tr>
<td>Vietnamese (Vietnam)</td>
<td>vi-VN</td>
</tr>
<tr>
<td>Welsh</td>
<td>cy-GB</td>
</tr>
<tr>
<td>Xhosa</td>
<td>xh-ZA</td>
</tr>
<tr>
<td>Zula</td>
<td>zu-ZA</td>
</tr>
</tbody>
</table>

For more information, see [Enter alarm messages in other languages](#) on page 198.
Glossary

Alarm history log
A Microsoft SQL Server database that is configured to accept alarm and event data from the FactoryTalk Alarms and Events system.

Analog alarm
An analog alarm defines a condition that evaluates a single analog tag. The trigger condition compares the value of the tag against a defined static value using an operator: equal to, not equal to, greater than or equal to, less than or equal to, greater than, or less than.

Application
An application organizes project information, including elements such as data servers, HMI servers, and alarm and event servers, and makes the information available to all software products and computers participating in a FactoryTalk system.

- Network distributed applications are held in a FactoryTalk Network Directory. Project information and participating software products can be located on multiple computers distributed across a network. All of the computers participating in a particular network distributed application share a common Network Directory Server located on a network computer.

- Network station applications are held in a FactoryTalk Network Directory. All participating software products (except for data servers) must be installed on the same computer. Network station applications can connect to data servers that are located on different machines. All of the computers participating in a particular network station application share a common Network Directory Server located on a network computer.

- Local station applications are held in a FactoryTalk Local Directory. Project information is located on a stand-alone computer and is available only to software products installed on that same local computer. Local station applications cannot be accessed remotely and cannot share project information with a network distributed application or network station application.
Area

Areas subdivide and organize a distributed network application into logical or physical divisions. For example, separate areas might correspond with separate manufacturing lines in a facility, separate plants in different geographical locations, or different manufacturing processes.

Areas are not available with local station applications.

Condition-related event

An event associated with a change in the state of an alarm. For example, a condition-related event is triggered when an alarm condition changes to In Alarm, Acknowledged, Return to Normal, or Disabled.

Data server

Data servers serve tags, or data items, contained in OPC-DA (Data Access) servers. Clients that need access to data items, such as FactoryTalk View Studio and FactoryTalk Transaction Manager, use data server application elements referenced from the FactoryTalk Directory to locate the computers that are hosting OPC-DA 2.0 compliant data servers.

Deviation alarm

A deviation alarm defines a condition that evaluates a single analog tag. A trigger condition compares the value of a tag against a deviation from a target value.

Device server

A server process that connects to devices (controllers) and subscribes to alarm, status, and diagnostic information. A device server processes this data and publishes it to client processes for graphic display and logging. RSLinx Enterprise is one common example of a device server. See also data server.

Device-based alarm monitoring

With device-based alarm monitoring, pre-built alarm instructions, available in RSLinx 5000 v. 16 or later, are programmed in a logic project and then downloaded into a Logix5000 controller. The controller detects alarm conditions and publishes event information, which is routed through the system for display and logging.

Digital alarm

A digital alarm defines a condition that evaluates a single digital tag. The trigger condition compares the value of the tag to either zero or one.
Docked

A graphic display that is fixed to the top, bottom, left or right side of a FactoryTalk View SE client window.

Dongle

A dongle is a security or copy protection device for commercial computer programs. When required by a program, a dongle must be connected to an input/output port, such as USB or parallel port of the computer, to allow the program to run. Programs that use a dongle query the port at start-up and at programmed intervals thereafter, and terminate if the dongle does not respond with the expected validation code.

Enabled

When an alarm is enabled, it is running its condition detection logic. Enabled alarms cannot be edited or deleted.

HMI server

HMI servers, also called FactoryTalk View SE Servers, store and serve HMI projects, which contain displays, alarms, tags and other services, to HMI clients such as FactoryTalk View Studio and FactoryTalk View SE Clients. HMI clients use FactoryTalk Directory to locate the computers that are hosting HMI servers.

Level alarm

A level alarm defines multiple conditions that evaluate a single level tag (sometimes called an analog tag). Each level can uniquely identify an alarm threshold, a severity, and an alarm message.

Offline data item

In RSLinx Classic, offline data points are read directly from a processor’s project file defined in the RSLinx Classic DDE/OPC Topic Configuration (Use Symbols option).

In RSLinx Enterprise, offline data points are read directly from a processor’s project file defined in the device shortcut. For ControlLogix, offline tag browsing requires firmware version 10 or higher.

Online data item

Online data items are read directly from a processor, exactly as they are defined in that processor.
Using a Logix5000 controller you can create tags right in the controller and use RSLinx Classic or RSLinx Enterprise to access those tags directly. As a result, you can work with symbol names in a Logix5000 processor both online and offline.

In a traditional PLC-5 or SLC 500 processor, tags are not created in the controller—instead symbol and tag names are associated with predefined PLC addresses. These associations are held in the logic program and are referenced by RSLinx Classic or RSLinx Enterprise. When reading data points online, only the PLC addresses exist inside the controller. You must work with RSLinx Classic offline data items to use ladder logic symbol names with these types of controllers.

OPC

OPC (OLE (Object Linking and Embedding) for Process Control) is a non-proprietary technical specification that defines a set of standard interfaces based on Microsoft’s OLE/COM (Component Object Model) technology. Applying OPC standards makes interoperability possible among automation and control applications, field systems and devices, and business and office applications.

The FactoryTalk Services Platform supports and extends the OPC 2.0 specification, which includes the ability to browse data items.

Policy

A set of system-wide rules governing how security is implemented, such as rules related to password length and complexity.

RSLinx

RSLinx Classic and RSLinx Enterprise are families of software products that link networks and devices to products such as the FactoryTalk View family of HMI software and the RSLogix family of device-programming software.

Two versions of RSLinx are commonly used in FactoryTalk systems:

- **RSLinx Classic**: an OPC-DA 2.0 data server.
- **RSLinx Enterprise**: a FactoryTalk Live Data server and Alarms and Events server.

RSLogix

The RSLogix family of software products provides programming software for control devices, including the Logix5000 series, PLC-5, and SLC 500. Use either of these two control programming tools to set up device-based alarm monitoring in FactoryTalk Alarms and Events:
• Studio 5000 Logix Designer application, version 21.00.00 and later.
• RSLogix 5000 software, version 16.00.00 and later.

Simple event

Any event describing a simple occurrence in the system. Example: failure to access a computer or device.

Tag update rate

The rate at which a tag is scanned for changes to its value. To reduce the quantity of network traffic, set the tag update rate to be as long as possible. For example, because an operator cannot respond to tag values that change faster than once every second, it is seldom necessary to set a tag update rate faster than once every few seconds. Set a faster tag update rate only if the system is programmed to respond automatically to tag values that change so quickly, bearing in mind the load this places on the network.

Tag-based alarm monitoring

Software-based Tag Alarm and Event Servers monitor controller tags for alarm conditions through data servers and publish event information for display and logging. Tag-based alarm monitoring is used for Logix5000 controllers, PLC-5, and SLC 500 devices communicating through Rockwell Automation Device Servers (RSLinx Enterprise), or for third-party controllers communicating through OPC data servers.

Tracking-related event

An event that tracks changes made to the system over time. Examples: an event describing the acknowledgment of an alarm by an operator, or the modification of a tag value by an operator.
Legal Notices

Copyright notice

© 2016 Rockwell Automation, Inc. All rights reserved. Printed in USA.

This document and any accompanying Rockwell Software products are copyrighted by Rockwell Automation, Inc. Any reproduction and/or distribution without prior written consent from Rockwell Automation, Inc. is strictly prohibited. Please refer to the license agreement for details.

End User License Agreement (EULA)

You can view the Rockwell Automation End-User License Agreement ("EULA") by opening the License.rtf file located in your product's install folder on your hard drive.

Other Licenses

Distributed under the Boost Software License, version 1.0. See accompanying file LICENSE_1_0.txt at http://www.boost.org/LICENSE_1_0.txt.

Trademark Notices

Allen-Bradley, CompactLogix, ControlLogix, DriveLogix, DH+, FactoryTalk, FlexLogix, GuardLogix, Logix5000, MicroLogix, PLC-5, PowerFlex, Rockwell Automation, RSLogix, RSLinx, SLC, SoftLogix, and Studio 5000 are trademarks of Rockwell Automation, Inc.

Any Rockwell Automation software or hardware not mentioned here is also a trademark, registered or otherwise, of Rockwell Automation, Inc.

Other Trademarks

Excel, Microsoft, SQL Server, Windows, Windows Vista, and Windows Server are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

OPC is a registered trademark of the OPC Foundation in the United States and/or other countries.

All other trademarks are the property of their respective holders and are hereby acknowledged.
Warranty

This product is warranted in accordance with the product license. The product’s performance may be affected by system configuration, the application being performed, operator control, maintenance, and other related factors. Rockwell Automation is not responsible for these intervening factors. The instructions in this document do not cover all the details or variations in the equipment, procedure, or process described, nor do they provide directions for meeting every possible contingency during installation, operation, or maintenance. This product’s implementation may vary among users.

This document is current as of the time of release of the product; however, the accompanying software may have changed since the release. Rockwell Automation, Inc. reserves the right to change any information contained in this document or the software at any time without prior notice. It is your responsibility to obtain the most current information available from Rockwell when installing or using this product.

Environmental compliance

Rockwell Automation maintains current product environmental information on its website at


Contact Rockwell Automation

Customer Support Telephone — 1.440.646.3434

Online Support — http://www.rockwellautomation.com/support/
Index

A
about
acknowledging alarms 124
Alarm and Event Banner 19
Alarm and Event Historian 19
Alarm and Event Log Viewer 19
Alarm and Event Summary 19
Alarm Status Explorer 19
Coordinated System Time 233
database definitions 142
deviation alarms 77
device-based alarm monitoring 21
FactoryTalk Audit Log 19
FactoryTalk Diagnostics 19
graphic displays 89
HMI Tag Alarm Monitoring 23
Local applications 25, 60, 79
logging alarm and event history 19
monitoring for alarm conditions 113
Network distributed applications 25
OPC data servers 15
process data 15
security for alarms and events 15
setting up FactoryTalk Alarms and Events 19
software-based tag servers 15
Tag Alarm and Event Servers 77
tag-based alarm monitoring 23
time stamps for alarms 233
warning icons 60, 81
acknowledge alarms 124
alarm monitoring
about device-based alarm monitoring 21
about HMI Tag Alarm Monitoring 16
about tag-based alarm monitoring 23
adding Tag Alarm and Event Servers 77
choosing between tag- and device-based 24
application 9
availability 165

B
background color
in Alarm and Event Summary 104
of severities 104
buffered data 31
buttons
adding captions 190
adding to graphic displays 153, 190
Open Alarm and Event 153

C
clear
alarm 123
color
blink 104
in graphic objects 104
comment 125
communication 169
components of FactoryTalk Alarms and Events 19
controllers
finding with RSLinx Classic 33
linking tags with FactoryTalk Directory 72
coordinated system time
about 233
create
database 142
new alarm 33, 45, 85
new alarm message 85

data server 81
deviation 85
device-based alarm monitoring 21
choosing over tag-based 24
compared with software-based 21
definition of 21
how it works 21
RSLogix 5000 24

E
enabling/disabling 127

F
FactoryTalk Services Platform 224
version required 9
FactoryTalk View SE
documentation 12
graphic objects in 90
version required 9

FactoryTalk View SE Client
  docking displays in 114
  setting up security for 124

FactoryTalk View Studio
  Alarm Setup 85
  workspace in 90

glossary 257

HMI Tag Alarm Monitoring 16

installation
  manual installation 224
  recommended hardware 10
  required software 9

Logix Designer
  Logix Designer projects 33
  version required 9
Logix5000 Clock Update Tool
  starting automatically 240
  synchronizing clocks 241

monitor alarms 123
  acknowledge an alarm 124, 125, 126, 127
  enable an alarm 128, 129
  shelve an alarm 133, 135
  suppress an alarm 131

overview
  choosing alarm monitoring options 21, 24
  device-based alarm monitoring 21
  FactoryTalk Alarms and Events 15

install 28
logging alarm and event history 141
monitoring for alarm conditions 114
parts of FactoryTalk Alarms and Events 19
securing access to alarms and events 124
tag-based alarm monitoring 23

redundancy 165
RSLogix 5000 9, 33

security 124
  for alarms and events 124
software 9
supported devices 10, 12
system requirements 9, 10, 219, 229

tag-based alarm monitoring
  adding Tag Alarm and Event Servers 84
  creating alarms in Tag Alarm and Event Servers 85
  definition of 15
  how it works 23
  Logix5000 controllers 60
  OPC data servers 71
  third-party controllers 72
  tags
    in RSLogix 5000 46, 81
    using in editors 85

wall clock time 234

Windows
  docked to bottom of screen 101
  docking to top of screen 159
  setting up for language switching 251
Rockwell Automation support

Rockwell Automation provides technical information on the web to assist you in using its products. At http://www.rockwellautomation.com/support you can find technical and application notes, sample code, and links to software service packs. You can also visit our Support Center at https://rockwellautomation.custhelp.com for software updates, support chats and forums, technical information, FAQs, and to sign up for product notification updates.

In addition, we offer multiple support programs for installation, configuration, and troubleshooting. For more information, contact your local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/services/online-phone.

Installation assistance

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can contact Customer Support for initial help in getting your product up and running.

<table>
<thead>
<tr>
<th>United States or Canada</th>
<th>1.440.646.3434</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States or Canada</td>
<td>Use the Worldwide Locator available at <a href="http://www.rockwellautomation.com/locations">http://www.rockwellautomation.com/locations</a>, or contact your local Rockwell Automation representative.</td>
</tr>
</tbody>
</table>

New product satisfaction return

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. However, if your product is not functioning and needs to be returned, follow these procedures.

<table>
<thead>
<tr>
<th>United States</th>
<th>Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to your distributor to complete the return process.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States</td>
<td>Please contact your local Rockwell Automation representative for the return procedure.</td>
</tr>
</tbody>
</table>

Documentation feedback

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, complete the feedback form, publication RA-DU002 http://literature.rockwellautomation.com/idc/groups/literature/documents/du/ra-du002_en-e.pdf.

Rockwell Otomasyon Ticaret A.Ş., Kar Plaza İş Merkezi E Blok Kat:6 34752 İçerenköy, İstanbul, Tel: +90 (216) 5698400

www.rockwellautomation.com

Power, Control and Information Solutions Headquarters
American: Rockwell Automation, 1201 South Second Street, Milwaukee, WI 53204-2496 USA, Tel: (1) 414.382.2000, Fax: (1) 414.382.4444

Europe/Middle East/Africa: Rockwell Automation NV, Pegasus Park, De Kleetlaan 12a, 1831 Diegem, Belgium, Tel: (32) 2 663 06 00, Fax: (32) 2 663 06 10

Asia Pacific: Rockwell Automation, Level 14, Core E, Cyberport 3, 100 Cyberport Road, Hong Kong, Tel: (852) 2887 4788, Fax: (852) 2508 1846