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MENUS AND COMMANDS

DriveExecutive
INTERFACE

DriveExecutive contains the following menus and commands:
With commands in the File menu, you can perform these tasks:
• Create a new drive node file offline
• Open an existing drive node file, Drive Manager 32 v2.50 file, or DriveExplorer v2+ file
• Save an offline file or online drive configuration 
• Upload/download a group of drives (in same folder)
• Print node data
• Open a recent file or re-connect to a recent connection
• Save an online shortcut*
• Use recent files or connections

With commands in the Edit menu, you can perform these tasks:
• Undo/redo parameter and link edits
• Parameter Find*

With commands in the View menu, you can perform these tasks:
• Turn the toolbar and status bar on and off
• Customize the view options to user preferences

With commands in the Drive menu, you can perform these tasks:
• Connect to a drive
• Create a new database
• Connect to the last connected drive
• Upload/download parameter values and link settings from/to drives
• Refresh online connections to detect the addition/removal of peripherals.
• View and clear fault and alarm conditions
• Work with non-volatile memory options in a product
• Work with custom groups
• View drive properties or a drive’s web page
• Program datalinks* 
• View diagnostic items 

With commands in the Peripheral menu, you can perform these tasks:
• Add/delete a peripheral to/from a file
• Upload/download parameter values and link settings from/to peripheral
• Work with custom groups
• View peripheral properties
• View diagnostic items 
• Display events 

With commands in the Tools menu, you can perform these tasks:
• Change the device configuration of an offline node file
• Parameter and link comparison tool*
• Launch Wizards
• Launch DriveObserver (if available)

With commands in the Window menu, you can perform these tasks:
• Open a new drive node window
• Arrange drive node windows
• Switch between open drive node window

With commands in the Help menu, you can perform these tasks:
• Display the DriveExecutive online help
• Connect to DriveTools SP’s Internet site
• Display version and component information about DriveExecutive
• View device help files

* Feature not available in DriveExecutive Lite

Important: Click a plus
sign to expand a
branch. Click a minus
sign to close a branch.

Number Name Description

1 Menus Contains the commands that you use to perform tasks. For example, you can select File > Save to save parameter data 
to a file.

2 Tool Bar The tool bar contains shortcuts to several commonly used commands.
3 Drive Node Window Contains information about the drive node that you are connected to or the file that you have opened offline.
4 Title Bar Contains the path of a connection from the PC to an online drive or the filename for an offline drive.
5 Drive Status Displays the most significant information in the drive status word.  The entire word can be displayed by clicking 

on this dropdown box.
6 Communication Status This animated display informs you that the PC is communicating with a drive. Displayed parameters are updated 

only when their respective values have changed.
7 Drive Protocol Displays the protocol of the drive that you are connected to (SCANport™ or DPI™).
8 Device Pane Contains information abut the active drive node.  Important: A plus sign indicates that there are additional items 

under the item. Click the plus sign to view those items.
9 Node Displays the network node number of the drive.
10 Drive The product port number and name.
11 Diagrams Firmware illustrations that combine block diagram layout with parameters and contacts that update online. 

(Full version only).
12 Linear List A linear list of parameters (1, 2, 3…).
13 Files and Groups Logically ordered collections of the parameters.  Important: Not all products group their parameters.
14 Peripherals Port numbers and names of connected communication adapters and PowerFlex™ LCD HIMs.
15 Table View Displays the information for the selected node, port, linear list, file, group, or diagram.
16 Parameter Display Displays the parameters that are in the linear list or group. The user can customize this display to turn columns on and off, re-order columns, and change

color schemes.
17 View Selection When multiple views are available, select a different tab to change the view.  
18 Status Bar The status bar provides brief descriptions and contains the parameter color descriptions for the parameter display.
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SOFTWARE INSTALLATION
INSTRUCTIONS
SYSTEM REQUIREMENTS
To install software, you will need a Pentium 100MHz processor with at least 32 MB of RAM, 90 MB of available hard disk space (more hard disk
space may be required for specific application features), a 16-color, SVGA display with 800 by 600 or greater resolution, and a mouse or other
Windows-compatible pointing device.  This version will not run on Alpha, MIPS, or Power PC processors.

Microsoft™ Internet Explorer™ version 6.0 (included on CD) or later and a compatible version of RSLinx Lite (included on CD) must be installed on
your PC prior to installing DriveTools SP, DriveExecutive, or DriveExecutive Lite.  

Supported environments: 
Operating System DriveExecutive/DriveExecutive Lite DriveTools SP
Windows NT Version 4.0 (Service Pack 6 or later) Yes Yes
Windows 2000 (Service Pack 2 or later) Yes Yes
Windows XP Professional/Home (Service Pack 1 or later) Yes Yes

Installation Procedure
Note: It is strongly recommended that you quit all Windows programs before running the Setup.

1. If you have DriveExecutive V2.02 or earlier installed on your PC:
a. Open the Windows Control Panel.
b. Double-click on Add/Remove Programs.
c. Select DriveTools 2000 and then click Add/Remove.  Respond to the prompts to remove it.

2. If you have a version of RSLinx earlier than 2.41 installed on your PC:
a. In Windows, select Start > Programs > Rockwell Software > RSLinx > Backup Restore Utility.
b. At the RSLinx Backup/Restore dialog, click Backup.  Then, give the file a name and location that you will

remember.  Click Save.
c. Click OK when you are told that the operation completed successfully.  Click Close to close the RSLinx 

Backup/Restore dialog.
d. Open the Windows Control Panel.
e. Double-click on Add/Remove Programs.
f. Select RSLinx and then click Add/Remove.  Respond to the prompts to remove it

3. If you removed an application in step 1 or 2, restart your PC.
4. If you are using Windows NT 4.0 and the service pack is less than 6, you must first install service pack 6 before 

proceeding.  For your convenience, NT4 SP6 Low Encryption has been included on the installation CD for your 
convenience (…\NT4SP6\I386\UPDATE\UPDATE.EXE).  For other versions, visit www.microsoft.com.  
After installing the service pack, restart your PC.

5. Insert the DriveExecutive installation CD into the CD-ROM drive.  The installation application should open 
automatically if autorun is enabled on your PC.  If the installation application does not open automatically, 
run …\DriveExecutive\setup.exe or …\DriveTools\setup.exe on your CD.

6. Follow the instructions in the Setup Wizard and respond to the prompts.  The serial number for DriveExecutive 
or DriveTools SP is provided in the packaging.  For DriveExecutive Lite, use your RSLogix 5000 or RSNetworx 
MD serial number.

7. Restart your PC 
8. If you do not already have Microsoft Internet Explorer version 6 or later installed on your PC, 

run …\IE60\IE6setup.exe on your CD.  (Internet Explorer is required to use help and other features of the 
software.)  Follow the instructions in the Setup Wizard and respond to prompts.  

9. If you do not have RSLinx V2.41 or later previously installed, run …\ RSLinx_2.41\Setup.exe.  Follow the 
instructions in the Setup Wizard and respond to the prompts.  When installing RSLinx Lite, be sure to:
• Select Setup Type = “Custom Location Selection and/or Custom Feature Selection”
• Under “Electronic Data Sheets,” turn on installation for “Drives Communication Modules” and for any of the 

supported devices that you will be using (i.e. 1305, 1336 PLUS II, 1336 IMPACT).
10. Setup RSLinx communication drivers for each type of communications that you plan to use (see instructions on 

the opposite page) or if you saved previous RSLinx driver settings to a file in step 2, do the following:
a. In Windows, select Start > Programs > Rockwell Software > RSLinx > Backup Restore Utility.
b. At the RSLinx Backup/Restore dialog, click Restore.
c. Select the backup file saved in step 2 above and click Open.
d. Click OK when you are told that the operation completed successfully.  Click Close to close the RSLinx 

Backup/Restore dialog.
11. Launch DriveExecutive and/or DriveObserver.

SETTING UP RSLINX COMMUNICATION DRIVERS
Note: You typically need to only setup RSLinx drivers before running DriveExecutive or DriveObserver
the first time. After RSLinx communication is setup, you will only need to launch RSLinx to make driver
additions, edits, and deletions to reflect changing communication needs.
1. In the Windows Start menu, select Programs > Rockwell Software > RSLinx > RSLinx to launch RSLinx.
2. In the RSLinx program menus, select Communications > Configure Drivers to open the Configure Drivers

dialog box.  (The Configure Drivers dialog box, provides a list of previously configured drivers and their status.)

Note: For directions on adding, editing, and deleting RSLinx drivers, click the Help button.

3. Adding a Serial Driver for Connecting to a 1203-SSS Adapter or 160-RSI Adapter
A. From the Configure Drivers dialog box, select the "RS-232 DF1 devices" driver from the Available Drivers list.
B. Click Add New. The configuration dialog box for that driver appears.
C. Enter the following parameters in the configuration dialog box:

Comm Port: Comm port on your PC
Device: 1770-KF2/1785-KE/SCANport
Baud Rate: Baud Rate of the Adapter
Station Number: 00
Parity: None
Error Checking: BCC
Stop Bits: 1
Protocol: Full Duplex

D. Click OK to close the dialog box. 

Drivers for Other Communications
If your PC is connected to: Driver:
1770-KF2, -KFC RS-232 DF1 devices
1784-KT, -KTX, -KTXD, -PCMK 1784-KT/KTX(D)/PKTX(D)/PCMK for DH+/DH-485 devices
1784-KTC, -KTCX 1784-KTC(X) for ControlNet™ devices
1784-PCD, -PCIDS, 1770-KFD DeviceNet™ Drivers (1784-PCD/PCIDS, 

1770-KFD, SDNPT drivers)
A TCP/IP Ethernet card Ethernet devices
Ethernet (TCP/IP) to RSLinx or Remote Devices via Linx Gateway
ControlLogix Gateways

Note: For detailed instruction on how to configure drivers for other communications (listed above)
click the Help button in the RSLinx Configure Drivers dialog.

Additional information / updates are available at www.ab.com/drives/drivetools
ControlNet is a trademark of ControlNet International Ltd. DeviceNet is a trademark of the Open DeviceNet Vendor Association. DPI, DriveExecutive, DriveTools, PowerFlex, and SCANport are
trademarks of Rockwell Automation. RSLinx is a trademark of Rockwell Software. Internet Explorer, Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation.
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MENUS AND COMMANDS

DriveObserver INTERFACE

DriveObserver contains the following menus and commands:
With commands in the File menu, you can perform these tasks:
• Create a new chart
• Open an existing chart to view data or to use its configuration for 

collection new data
• Save a chart, save chart data to a *.csv file 

With commands in the View menu, you can perform these tasks:
• Zoom In/Out on the time scale
• Overlap or isolate Y-axis scaling
• Use the time and value bars
• Turn the toolbar and status bar on and off
• Customize the view options to user preferences

With commands in the Chart menu, you can perform these tasks:
• Add and remove traces (also add non-recorded traces such as gains for easy edits)
• Edit trace formatting (line type, markers, color)
• Start and stop real-time data collection
• View and edit Sample Rate and Chart Properties

With commands in the Window menu, you can perform these tasks:
• Open a new window
• Arrange windows
• Switch between open windows

With commands in the Help menu, you can perform these tasks:
• Display the DriveObserver online help
• Connect to DriveTools SP’s Internet site
• Display version and component information about DriveObserver
• View device help files

Important: Click a plus sign to expand a branch. Click a minus sign to close a branch.

Note: Software installation instructions can be found in the DriveExecutive Software and Reference Card.

Number Name Description

1 Menus Contains the commands that you use to perform tasks.  For example, you can select File>New to create a new chart.
2 Tool Bar The tool bar contains shortcuts to several commonly used commands.
3 Chart Window Displays information about the traces you are monitoring and the real-time data that has been collected.
4 Chart The chart is where you will view a graphical display of the collected data.
5 Y-Axis The trace scaling information.
6 X-Axis The time axis.
7 Trace A parameter for which you are collecting data.
8 Table View Displays information about the traces that you are monitoring with in-place editing of min/max while running. Also provides node status (running,

faulted, not communicating, etc.)
9 Status Bar The status bar provides brief descriptions.
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