## Table of contents

### Preface
- What’s in this Installation and Deployment Guide? .......................... 9
- About the FactoryTalk View documentation ................................ 9
- Finding information in the FactoryTalk View Installation ................. 10
- What’s in this manual ..................................................................... 10
- Other Documents ........................................................................ 11
- Open FactoryTalk View manuals .................................................. 11
- Contacting Rockwell Automation Technical Support ....................... 11
  - When you call Rockwell Automation Technical Support ............... 12
- Legal Notices ............................................................................ 12

### Chapter 1
- What is FactoryTalk View SE? .................................................... 17
  - About the architecture of your FactoryTalk View system ............. 18
  - FactoryTalk View Studio Enterprise ........................................ 18
  - FactoryTalk View SE Server ................................................... 19
  - FactoryTalk View SE Client ..................................................... 19
  - FactoryTalk View SE Station .................................................. 20
  - Stand-alone RSLinx Enterprise Server ..................................... 21
  - FactoryTalk Services Platform ................................................. 21
    - FactoryTalk Administration Console .................................... 21
    - FactoryTalk Directory ......................................................... 21
    - FactoryTalk Alarms and Events .......................................... 22
    - FactoryTalk Security ........................................................... 22
    - FactoryTalk Live Data ......................................................... 22
    - FactoryTalk Diagnostics ...................................................... 22
    - FactoryTalk Activation ....................................................... 22
  - Connectivity ........................................................................... 22
    - RSLinx Enterprise ............................................................. 23
    - RSLinx Classic ................................................................. 23
  - Installation DVD ...................................................................... 23

### Chapter 2
- What is in this chapter? ............................................................. 25
- What can I install and run on one server? .................................. 25
- Review hardware requirements .................................................. 26
- Review operating system requirements ...................................... 26
  - Operating system recommendations for application servers ....... 27
- Set up the Windows domain or workgroup .................................. 28
  - Domain controller requirements ........................................... 29
  - About synchronizing time on application computers ............... 29
  - Windows workgroup requirements ........................................ 29
## Table of contents

Set up computers with names to be used in production.................... 30

### Chapter 3

Checklist for preparing the computer for installation....................... 31
Disable automatic Windows updates........................................... 31
Turn off simple file sharing and fast user switching........................ 32
Disable operating system themes................................................ 32
Manually configure NICs and switch ports.................................... 33
  Set up the NIC link speed and duplex...................................... 34
  Disable power saving for the NIC ........................................... 35
Disable or uninstall third-party firewalls...................................... 35
Install Microsoft Internet Information Services............................ 36
  Guidelines for different operating systems............................... 36
  About uninstalling IIS........................................................... 37
Remove Internet Explorer Enhanced Security Configuration.............. 37
Set up Data Execution Prevention.............................................. 39
Remove unnecessary DCOM networking protocols.......................... 40

### Chapter 4

Steps to install FactoryTalk View SE......................................... 41
Deciding which FactoryTalk View SE components to install.............. 42
Preparing for installation......................................................... 43
Launching Setup Wizard and selecting what to install..................... 43
Common setup and IIS install.................................................... 44
  FactoryTalk Activation Warning............................................ 45
  Microsoft Internet Information Services (IIS) check and installation....... 45
  Dependent software process termination warning........................ 46
Providing information for the install.......................................... 47
  End User License agreement.................................................. 48
  File location for product installation..................................... 49
  Select Setup Type.................................................................... 49
  SQL Server sign-in or installation.......................................... 50
  Configuring Products............................................................. 53
Checking selections and starting the installation process................. 54
  Installation of selected software............................................ 55
Installation complete.................................................................... 55
Installing SE clients in a distributed system.................................. 56
Post-installation procedures....................................................... 57
  Specifying the Network Directory server location....................... 57
# Table of contents

## Chapter 5

Activating FactoryTalk View software

- About FactoryTalk Activation Manager .................................................................. 59
- What happens if FactoryTalk View is not activated? ........................................... 59
- Set up client computers to obtain floating activations ................................. 60
- Ensure that network application components stay activated ......................... 61
- Borrow activations for development computers ............................................. 61
- Activation keys for FactoryTalk View software components ..................... 61
  - Sharing keys among multiple software components .............................. 62
  - Read-write versus view-only activations .............................................. 63

## Chapter 6

Deploying network distributed applications

- Overview of tasks .............................................................................................. 65
- Task checklist .................................................................................................. 65
- Back up the network distributed application ............................................... 66
- About backing up System information with an application ....................... 66
  - Back up a network distributed application ........................................ 67
- Restore the network distributed application ............................................... 67
  - Restore RSLinx Enterprise configurations ........................................ 69
  - Back up and restore RSLinx Classic configurations .......................... 69
- Renew data server shortcuts, topics, and device paths ............................ 70
  - To renew RSLinx Enterprise device paths ........................................ 70
  - To verify RSLinx Classic topics ............................................................. 70
- Set up additional HMI server properties ..................................................... 70
  - Synchronizing redundant HMI servers and projects ............................ 74
- Set up FactoryTalk View SE Clients .............................................................. 74
  - Create a new FactoryTalk View SE Client file .................................. 75
  - Copy existing FactoryTalk View SE Client files ................................ 75
  - Lock operators into the run-time environment ...................................... 76
  - Run the FactoryTalk View SE Clients .................................................... 76
  - Log on to the FactoryTalk View SE Client .......................................... 77

## Chapter 7

Deploying network station applications

- Overview of tasks .............................................................................................. 79
- Task checklist .................................................................................................. 79
- Move the network station application ........................................................... 80
- Specify the Network Directory location on application computers .......... 81
- Move the application’s data server files ......................................................... 81
  - Back up and restore RSLinx Classic configurations .......................... 82
  - Specify data server host computer names ........................................... 83
    - To change the RSLinx Enterprise server computer name .......... 83
    - To change the RSLinx Classic server computer name ............... 84
- Renew data server shortcuts, topics, and device paths ............................ 85
<table>
<thead>
<tr>
<th>Table of contents</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deploying local station applications</td>
<td>61</td>
</tr>
<tr>
<td>Chapter 8</td>
<td>91</td>
</tr>
<tr>
<td>Overview of tasks</td>
<td>91</td>
</tr>
<tr>
<td>Task checklist</td>
<td>91</td>
</tr>
<tr>
<td>Move the local station application</td>
<td>92</td>
</tr>
<tr>
<td>About restoring System information with the application</td>
<td>93</td>
</tr>
<tr>
<td>Move data servers and change their properties</td>
<td>93</td>
</tr>
<tr>
<td>Back up and restore RSLinx Enterprise files</td>
<td>93</td>
</tr>
<tr>
<td>Back up and restore RSLinx Classic configurations</td>
<td>94</td>
</tr>
<tr>
<td>Specify OPC data server host computer names</td>
<td>95</td>
</tr>
<tr>
<td>To change the RSLinx Classic server computer name</td>
<td>95</td>
</tr>
<tr>
<td>Specify when HMI server components start or stop</td>
<td>95</td>
</tr>
<tr>
<td>To open the HMI Server Properties dialog box</td>
<td>96</td>
</tr>
<tr>
<td>How HMI server components start and stop</td>
<td>96</td>
</tr>
<tr>
<td>Set up the FactoryTalk View SE Client</td>
<td>97</td>
</tr>
<tr>
<td>Create a new FactoryTalk View SE Client file</td>
<td>97</td>
</tr>
<tr>
<td>Lock operators into the run-time environment</td>
<td>98</td>
</tr>
<tr>
<td>Run the FactoryTalk View SE Client</td>
<td>98</td>
</tr>
<tr>
<td>Log on to the FactoryTalk View SE Client</td>
<td>99</td>
</tr>
<tr>
<td>Administer deployed applications</td>
<td>99</td>
</tr>
<tr>
<td>To open a local station application in FactoryTalk View Studio</td>
<td>100</td>
</tr>
<tr>
<td>Chapter 9</td>
<td>102</td>
</tr>
<tr>
<td>Finding out about features in the new product version</td>
<td>102</td>
</tr>
<tr>
<td>Overview: Upgrading a redundant network distributed application</td>
<td>103</td>
</tr>
<tr>
<td>Part 1: Prepare for the upgrade</td>
<td>103</td>
</tr>
<tr>
<td>Part 2: Set up a separate, partially upgraded system</td>
<td>103</td>
</tr>
<tr>
<td>Part 3: Upgrade remaining computers and restore redundancy</td>
<td>104</td>
</tr>
<tr>
<td>About upgrading a non-redundant network application</td>
<td>104</td>
</tr>
<tr>
<td>Part 1: Prepare for the upgrade</td>
<td>105</td>
</tr>
<tr>
<td>Step 1 – Upgrade Preparation</td>
<td>105</td>
</tr>
</tbody>
</table>
**Step 2** – Back up the deployed application .................................. 107

**Part 2: Set up a temporary system and perform a partial upgrade** ... 109
  - **Step 3** – Set up a temporary upgrade system .......................... 110
  - **Step 4** – Upgrade software components on Server #2 ............ 115
  - **Step 5** – Upgrade software components on Workstation #1 ....... 115
  - **Step 6** – Migrate the FactoryTalk View SE application .......... 117
  - **Step 7** – Upgrade software on selected run-time clients .......... 118
  - **Step 8** – Test the migrated FactoryTalk View SE application ... 120

**Part 3: Upgrade Server #1 and remaining clients** .................... 121
  - **Step 9** – Upgrade remaining client computers ..................... 121
  - **Step 10** – Upgrade software components on Server #1 .......... 122
  - **Step 11** – Restore Server #1 as the primary application server .. 122
  - **Step 12** – Set up redundancy for the upgraded system ........... 126
  - **Step 13** – Restart the entire upgraded application .................. 129

**Appendix A**

**Common upgrade procedures**
- Recreate SQL Server 2008 R2 Express instance .......................... 131
- Installing product updates .................................................. 132

**Appendix B**

**FactoryTalk tools and utilities**
- FactoryTalk View tools ...................................................... 135
- FactoryTalk tools .......................................................... 136

**Appendix C**

**Install Microsoft Internet Information Services**
- Install IIS on Windows 8.1, Windows 8, or Windows 7 ............... 139
- To install IIS on Windows Server 2008 or Windows Server 2012 ... 140

**Appendix D**

**Use unattended installation**
- Perform unattended installation .......................................... 143
- Parameters .......................................................................... 144
- Examples ............................................................................. 146
  - Example 1 ........................................................................ 146
  - Example 2 ........................................................................ 147
Preface

What’s in this Installation and Deployment Guide?

This manual describes the FactoryTalk View Product and System, the tasks to be performed on a system before installation, the detailed installation steps, how to use FactoryTalk Activation to license the installed product, tasks for deploying applications, and how to upgrade an existing system.

The contents of this Installation and Deployment guide appear in the order you would use during installation on new or existing systems:

- FactoryTalk View basics describes the software components and layout of the system (Chapter 1).
- Hardware, operating system and domain information identifies requirements for the computers and operating systems (Chapter 2).
- Preparing for installation gives you the information you need to get your computer systems ready for a new installation or an upgrade (Chapter 3).
- Installation procedures walk you through the screens you will see during a complete installation (Chapter 4).
- Activating the software is required to get software license information onto all the computers in your system (Chapter 5).
- Deploying new applications covers several deployment types you may need (Chapter 6, 7, and 8).
- Upgrading existing applications if you already have an installed HMI application and are upgrading to FactoryTalk View 8.1 (Chapter 9).

In addition to FactoryTalk View Installation Guide, the FactoryTalk View documentation set includes:

  
  The User's Guide is available in PDF format, from the Help menu in FactoryTalk View Studio, on the disc containing the Setup Wizard, and from the Rockwell Automation Literature Library.

- Release Notes. Read the Release Notes before you begin installing or working with FactoryTalk View and supporting software.
  
  Release Notes for FactoryTalk View SE, RSLinx Enterprise, and RSLinx Classic are available from the FactoryTalk View Installation DVD.

  Release Notes for the FactoryTalk Services Platform are available from the Contents page in the FactoryTalk Help. To open the Help, select Start > All Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk Help.
• **Help.** Procedures and reference information are available from the Help menu in FactoryTalk View Studio, and from editors and dialog boxes used to develop FactoryTalk View SE applications.

**Finding information in the FactoryTalk View Installation**

Most of the dialog boxes during the installation include the selection View Installation Guide. Clicking **View Installation Guide** opens the Installation Guide PDF file.

You can also open the application release notes that contain the latest information about updates and program features. Click **View Release Notes** for Selected Product.

**What’s in this manual**

The Installation Guide is available in PDF format from the FactoryTalk View Installation DVD, from the Help menu in FactoryTalk View Studio, and from the Rockwell Automation Literature Library.

**Tip:** In the Literature Library, to find the current version of the Installation Guide and the User’s Guide, search for publication numbers containing the string **VIEWSE**.

Chapters in this manual describe how to:

- Set up the computers that will run FactoryTalk View SE.
- Install FactoryTalk View SE and supporting software.
- Activate the FactoryTalk View SE software.
- Deploy FactoryTalk View SE network and local applications.
- Upgrade FactoryTalk View SE components.

Each chapter includes a task check list, which you can use to create customized procedures suited to the needs of your application.

**Other Documents**

<table>
<thead>
<tr>
<th>Document</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FactoryTalk Alarms and Events System Configuration Guide Publication FTAE-RM-001</td>
<td>Describes the tasks to install, configure, and use FactoryTalk Alarms and Events services as part of a FactoryTalk-enabled automation system.</td>
</tr>
<tr>
<td>Activation Instructions Publication FTA-QS002</td>
<td>Getting and installing activations for all the computers in your system.</td>
</tr>
</tbody>
</table>

**Open FactoryTalk View manuals**


To open the manuals:

1. Open FactoryTalk View Studio.

2. From the **Help** menu, select **Online Books**, and then select the manual you want to open.

   **Tip:** During installation, Adobe Reader may be installed on the computer so that you can view online manuals. For information about using Adobe Reader, see the product documentation.

**Contacting Rockwell Automation Technical Support**

If you cannot find the answer to your question in the documentation or on the Internet, contact Rockwell Automation Technical Support, using any of these methods:

- Telephone: 1-440-646-3434
- Online: [http://support.rockwellautomation.com](http://support.rockwellautomation.com)
Support staff are available Monday to Friday from 8:00 a.m. to 5:00 p.m. local time (North America only), except on statutory holidays.

**When you call Rockwell Automation Technical Support**

When you call, it is recommended that you be at your computer and ready to provide the following information:

- The product’s Serial Number and Product Key, which are printed on the Activation Certificate enclosed with the product software DVD.
- The FactoryTalk View product version number.
- FactoryTalk Services Platform version number.
- The connectivity (RSLinx Enterprise or RSLinx Classic) version number.
- The type of hardware you are using.
- The names of other Rockwell Automation products installed on the computer.
- The exact wording of any messages shown on the computer.
- A description of what happened and what you were doing when the problem occurred.
- A description of how you tried to solve the problem.

If you are running a FactoryTalk View SE network distributed application, also note:

- How many computers are participating in the network application.
- Whether computers on the network are connected using a Windows domain controller or a workgroup.
- Which FactoryTalk View SE components are installed on participating computers.
- Which computers are running servers (the Network Directory server, HMI servers, data servers, or tag alarm and event servers), and whether the servers are set up with redundancy.
- Which computers are running clients (FactoryTalk View SE Client or FactoryTalk View Studio).

**Legal Notices**

**Copyright notice**

© 2015 Rockwell Automation, Inc. All rights reserved. Printed in USA.
This document and any accompanying Rockwell Software products are copyrighted by Rockwell Automation, Inc. Any reproduction and/or distribution without prior written consent from Rockwell Automation, Inc. is strictly prohibited. Please refer to the license agreement for details.

**End User License Agreement (EULA)**

You can view the Rockwell Automation End-User License Agreement ("EULA") by opening the License.rtf file located in your product’s install folder on your hard drive.

**Trademark Notices**

Allen-Bradley, ControlLogix, Data Highway Plus, DH+, Data Highway II, FactoryTalk, Logix5000, PanelBuilder, PanelView, PLC-2, PLC-3, PLC-5, Rockwell, Rockwell Automation, Rockwell Software, RSLinx, RSLogix, RSNetWorx, RSVIEW, SLC, Studio 5000, VersaView, and XM are trademarks of Rockwell Automation, Inc.

Any Rockwell Automation software or hardware not mentioned here is also a trademark, registered or otherwise, of Rockwell Automation, Inc.

**Other Trademarks**


Adobe, Acrobat, and Reader are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and other countries.

Oracle is a registered trademarks of Oracle Corporation.

ControlNet is a registered trademark of ControlNet International.

DeviceNet is a trademark of the Open DeviceNet Vendor Association, Inc. (ODVA).

Ethernet is a registered trademark of Digital Equipment Corporation, Intel, and Xerox Corporation.

OLE for Process Control (OPC) is a registered trademark of the OPC Foundation.

All other trademarks are the property of their respective holders and are hereby acknowledged.
Warranty

This product is warranted in accordance with the product license. The product’s performance may be affected by system configuration, the application being performed, operator control, maintenance, and other related factors. Rockwell Automation is not responsible for these intervening factors. The instructions in this document do not cover all the details or variations in the equipment, procedure, or process described, nor do they provide directions for meeting every possible contingency during installation, operation, or maintenance. This product’s implementation may vary among users.

This document is current as of the time of release of the product; however, the accompanying software may have changed since the release. Rockwell Automation, Inc. reserves the right to change any information contained in this document or the software at any time without prior notice. It is your responsibility to obtain the most current information available from Rockwell when installing or using this product.

Environmental compliance

Rockwell Automation maintains current product environmental information on its website at

Contact Rockwell

Customer Support Telephone — 1.440.646.3434
Online Support — http://www.rockwellautomation.com/support/
http://www.rockwellautomation.com/support/
Chapter 1

FactoryTalk View basics

FactoryTalk View, including FactoryTalk View SE (Site Edition) and FactoryTalk View ME (Machine Edition), are HMI (human-machine interface) software products designed with a common look, feel, and navigation to help speed HMI application development and training time.

Supporting the Rockwell Automation Integrated Architecture, FactoryTalk View is part of the scalable and unified suite of monitoring and control solutions designed to span stand-alone machine-level applications up through supervisory-level HMI applications across a network. This suite offers you a common development environment, application reuse, and architecture so you can increase productivity, reduce operation costs, and improve quality.

FactoryTalk View includes the PC-based development tool FactoryTalk View Studio as well as FactoryTalk View ME and FactoryTalk View SE.

FactoryTalk View SE is an integrated software package for developing and running HMI applications that can involve multiple users, clients, and servers, distributed over a network.

FactoryTalk View SE provides all the tools you need to create powerful, dependable process monitoring and supervisory control applications.

A FactoryTalk View SE System is more than the HMI Server and Clients. It also includes FactoryTalk Services Platform and Data Communication products such as RSLinx Enterprise and RSLinx Classic.

What is FactoryTalk View SE?
About the architecture of your FactoryTalk View system

A network distributed FactoryTalk View SE system consists of several components as shown below.

This example of a distributed system includes a FactoryTalk Directory Server, FactoryTalk View SE Server and Client, RSLinx Enterprise Data Server, and FactoryTalk View Studio for application development and configuration.

FactoryTalk View Studio Enterprise

FactoryTalk View Studio Enterprise is the configuration software for developing and testing FactoryTalk View SE network distributed, network station, local station, and FactoryTalk View ME applications.
FactoryTalk View Studio contains editors for creating complete applications, and includes client and server software for testing the applications you create. Use the editors to create applications that are as simple or as complex as you need.

**FactoryTalk View SE Server**

FactoryTalk View SE Server, also called the HMI server, stores HMI project components (for example, graphic displays) and supplies them to clients. The server also contains a database of tags, and performs alarm detection and historical data logging.

The FactoryTalk View SE Server has no user interface. Once installed, it runs as a set of headless Windows services that supply information to clients as they request it.

**FactoryTalk View SE Client**

FactoryTalk View SE Client is software for viewing and interacting with FactoryTalk View SE local station, network station, and network distributed applications at run time.

Use the FactoryTalk View SE Client Wizard to create client configuration files that can be deployed to client host computers. For details, see the FactoryTalk View SE Client Help.
**FactoryTalk View SE Station**

FactoryTalk View SE Station is a supervisory HMI software package for enterprise solutions. SE Station is a single-computer HMI that can be operated in either a Local or a Network FactoryTalk Directory. There are key differences between View SE Distributed and View SE Station:

- View SE Distributed can share HMI screens and data with multiple clients.
- View SE Station does not allow sharing of HMI screens or data to other View SE Stations.

A Network Station deployment (below) can include several HMI stations using a single Directory server and a single RSLinx communication server. While each HMI station can access the same controller data, through the shared RSLinx Enterprise server, and the same Directory resources through the shared Directory server, they can only access their own HMI data such as graphics, macros, and datalogs.

A Local Station FactoryTalk View SE system (below) can include several HMI computers, each with its own FactoryTalk Directory server and data server connection to the controllers.
Stand-alone RSLinx Enterprise Server

RSLinx Enterprise is a FactoryTalk Live Data server and can be enabled as a FactoryTalk Alarms and Events server. Your applications use RSLinx Enterprise to communicate with devices such as controllers and I/O scanners. This enables you to see values, such as sensor readings and other controller data from your plant floor devices, on your desktop computer or dedicated PanelView Plus terminal.

FactoryTalk Directory provides a central lookup service for a FactoryTalk system so all definitions do not have to exist in a single physical project file. References saved by FactoryTalk Directory are used by FactoryTalk-enabled products and FactoryTalk services to locate definitions when they are needed. It allows clients to locate key configuration information such as system organization, server locations, and policy information. FactoryTalk Directory provides a common address or phone book of factory resources that are shared among FactoryTalk-enabled applications in a distributed system.

FactoryTalk Services Platform provides a set of common services (such as diagnostic messages, health monitoring services, and access to real-time data) for all the FactoryTalk products and applications used in a control system.

FactoryTalk Services Platform is installed automatically with any FactoryTalk-enabled product.

FactoryTalk Administration Console

FactoryTalk Administration Console is a stand-alone tool for developing, managing, and securing multiple FactoryTalk View applications.

To open the Administration Console, select **Start > All Programs > Rockwell Software > FactoryTalk Administration Console.**

FactoryTalk Directory

The FactoryTalk Directory centralizes access to system resources and names for all FactoryTalk products and components participating in an automated control system.

FactoryTalk Alarms and Events

FactoryTalk Alarms and Events, which installs behind the scenes during FactoryTalk View SE installation, provides system-wide alarm monitoring and control centralized at the FactoryTalk Directory.

To distribute device- and tag-based alarms in a FactoryTalk View SE application, you can set up FactoryTalk Alarms and Events servers in the application.

FactoryTalk Security

FactoryTalk Security centralizes user authentication and authorization at the FactoryTalk Directory.

FactoryTalk Live Data

FactoryTalk Live Data manages connections between FactoryTalk products and data servers.

FactoryTalk Diagnostics

FactoryTalk Diagnostics collects and provides access to activity, status, warning, and error messages generated throughout a FactoryTalk system.

FactoryTalk Activation

FactoryTalk Activation services provide a secure, software-based system for activating Rockwell Software products and managing software activation files.

How you plan to obtain data for an application will determine which communications software you install.

You can use the RSLinx Enterprise or RSLinx Classic software shipped with FactoryTalk View SE, or use other software and devices that support OPC (OLE for Process Control) communications.

Tip: RSLinx Enterprise is automatically installed for FactoryTalk View applications. You may also choose to include RSLinx Classic during the installation procedure.
RSLinx Enterprise

RSLinx Enterprise is a communication server built around FactoryTalk technology to assist in developing and running your FactoryTalk View SE applications.

For communications with Allen-Bradley local and remote devices, particularly with Logix5000 controllers, RSLinx Enterprise is the recommended data communications software for FactoryTalk View applications.

However, RSLinx Enterprise does not allow you to create alias topic shortcuts, or to perform online tasks such as uploading and downloading RSLogix 5000 files. If you need these capabilities, you may use RSLinx Classic as your data communications server instead.

RSLinx Classic

RSLinx Classic is software that provides communications to a wide range of devices, such as Logix5000 processors. RSLinx Classic is an OPC Data Access v2.05a-compliant data server that can serve FactoryTalk Live Data tags from an HMI Tag database or RSLinx Enterprise. RSLinx Classic is available for personal computers only.

For example, install and use RSLinx Classic to serve data through DH+ (Data Highway +) networks, to support complex bridging and routing, and to support unsolicited messaging from a controller to RSLinx.

RSLinx Classic also allows you to create alias topic shortcuts, and to perform online tasks such as uploading and downloading RSLogix 5000 files.

Installation DVD

The FactoryTalk View DVD provides all the software you need to develop and run local applications confined to a single computer, or distributed control systems that involve several computers, connected over a network.

Depending on needs, the architecture of a FactoryTalk View distributed application can involve multiple clients and servers that represent different parts of your plant or process. To accommodate those requirements, these FactoryTalk View programs are included in this Setup Wizard:

- Studio Enterprise
- Server
- Client
- Station
- Stand-alone RSLinx Enterprise Server
• Stand-alone FactoryTalk Directory Server

Tip: Three other applications can also be installed from this Setup Wizard for FactoryTalk View ME applications:
  • Studio for Machine Edition
  • Machine Edition Station for Windows
  • Stand-alone ME Transfer Utility
Chapter 2

Hardware, operating system, and domain information

This section explains computer and Microsoft Windows support information for a FactoryTalk View SE System.

Determining what computers should be used:

- Review computer hardware requirements.
- Review operating system requirements.

Determining Windows Domain or Workgroup usage:

- Set up the Windows domain or workgroup.

Determining computer names:

- Set up computers with names to be used in production.

In a network application, it is possible for a single server computer that meets the listed hardware requirements to host all of the following components:

- One FactoryTalk View SE Server
- One RSLinx Enterprise data server (which can also be set up as FactoryTalk Alarms and Events device-based alarm server)
- One RSLinx Classic OPC-DA server (or some other OPC data server)
- One FactoryTalk Alarm and Event Tag based alarm Server
- The FactoryTalk Network Directory

**Note:** Running more than one HMI server on a single computer is not recommended. If you plan to deploy a network distributed application that uses more than two servers (or two pairs of redundant servers) and 20 clients, it is recommended that you contact your local Rockwell Automation Sales office for architectural assistance. For information about setting up redundant FactoryTalk View SE Servers, see Chapter 14, Setting up FactoryTalk system availability in the FactoryTalk View User’s Guide VIEWSE-UM006.
Review hardware requirements

The computer hardware you choose to install and operate your FactoryTalk View SE System should be adequately sized for the demands of each component. These specifications are based on the hardware that the FactoryTalk View product and its supported operating systems require.

Typically, application servers such as FactoryTalk View SE Server, FactoryTalk Alarms and Events, and RSLinx Enterprise will need to be sized with faster CPUs and more RAM than operator or engineering workstations. The greater the demand, the more powerful a system you need.

You should also specify a hard drive that has enough disk space to provide virtual memory that is at least twice the size of the physical RAM.

For FactoryTalk View software upgrades in this release, we recommend upgrading your hardware to these levels.

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>CPU</th>
<th>RAM</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operator Workstation</td>
<td>FactoryTalk View SE Client or FactoryTalk View SE Station</td>
<td>Intel Core 2 Duo and greater</td>
<td>2 GB or more</td>
</tr>
<tr>
<td>Engineering Workstation</td>
<td>FactoryTalk View Studio Enterprise RSLinx Classic RSLinx Enterprise Studio 5000</td>
<td>Intel Core 2 Duo and greater</td>
<td>4 GB or more</td>
</tr>
<tr>
<td>Application Server</td>
<td>FactoryTalk View SE Server FactoryTalk View Studio Enterprise FactoryTalk Alarms &amp; Events Tag Based Server RSLinx Enterprise Data Server with FactoryTalk Alarms and Events enabled</td>
<td>Smaller System: Intel Core 2 Duo and greater</td>
<td>2 GB or more</td>
</tr>
<tr>
<td></td>
<td>Medium to larger systems: Quad core Intel Xeon family or greater</td>
<td></td>
<td>4 GB or more</td>
</tr>
</tbody>
</table>

Note: Do not run FactoryTalk Alarms and Events servers (Rockwell Automation Device Server or Tag Alarm and Event Server) on the computers that meet only minimum server requirements.

Review operating system requirements

FactoryTalk View SE software is designed to run on Microsoft Windows operating systems, including:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>32-bit</th>
<th>64-bit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 8.1 Professional</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Windows 8.1 Enterprise</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Windows 8 Professional</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Windows 8 Enterprise</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Windows 7 Professional</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Windows 7 Professional with Service Pack 1</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Hardware, operating system, and domain information

Chapter 2

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Supported</th>
<th>Recommended</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7 Enterprise with Service Pack 1</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Windows 7 Ultimate with Service Pack 1</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Windows Server 2012 R2 Standard</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Windows Server 2012 R2 Datacenter</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Windows Server 2012 Standard</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Windows Server 2012 Datacenter</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Windows Server 2008 R2 Standard</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Windows Server 2008 R2 Standard with Service Pack 1</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Windows Server 2008 R2 Enterprise with Service Pack 1</td>
<td></td>
<td>Yes</td>
</tr>
<tr>
<td>Windows Server 2008 Standard with Service Pack 2</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Windows XP Professional with Service Pack 3</td>
<td></td>
<td>Yes</td>
</tr>
</tbody>
</table>

The choices you make will depend in part on whether the computer is to host an application client or server. You might choose to run operator or engineering workstations in a Windows Server operating system, but that is not required.

Recommended specifications for application servers are not as flexible, because server computers are more likely to host critical components and to handle more of the processing load in a FactoryTalk View SE application.

**Note:** FactoryTalk View SE software is tested and supported on Windows operating systems installed from original Microsoft media only. Using unsupported operating systems is not recommended.

Operating system recommendations for application servers

For computers hosting application servers (HMI servers, data servers, or Tag Alarm and Event Servers), operating system requirements depend on whether the server will support more or fewer than 10 client connections.

A client can be any of FactoryTalk View SE Client, FactoryTalk View Studio, the FactoryTalk View SE Administration Console, a FactoryTalk Transaction Manager connector, or another FactoryTalk View SE Server.

For application servers that support:

- **More than 10 client connections**, the recommended operating systems (with the appropriate number of CAL (client access licenses) installed)
• Windows Server 2012 Standard Edition (64-bit)
• Windows Server 2012 R2 Standard Edition (64-bit)
• Windows Server 2008 Service Pack 2 (32-bit or 64-bit)
• **10 or fewer client connections**, the minimum requirement is
  • Windows 8.1 Professional (32-bit or 64-bit)
  • Windows 8 Professional (32-bit or 64-bit)
  • Windows 7 Professional (32-bit or 64-bit)
  • Windows XP Professional with Service Pack 3 (32-bit).

  **Note:** Do not run the primary and secondary servers in a redundant server pair on the computers that have different operating systems. For example, do not run the primary server on a Windows Server 2008 computer and the secondary server on a Windows Server 2012 computer.

**Set up the Windows domain or workgroup**

The number of computers participating in a FactoryTalk View SE network application determines whether the computers can belong to a Windows domain or a workgroup.

Workgroups can be used only in applications that include 10 or fewer computers. Do not use Windows Workgroups with more than 10 computers, a Windows domain is recommended in that case.

For more information about setting up domains and workgroups, see the document, *FactoryTalk View SE Distributed System Design Considerations*, attached to Rockwell Automation Knowledgebase Answer ID 32549.

• A domain controller makes it possible to administer the network and user accounts from a central location. FactoryTalk Security, which manages centralized security services, supports Windows-linked accounts that are managed and authenticated by the Windows operating system, but have separate permissions for accessing the automation system.

• Name resolution is required for the computers to communicate with each other on the network.

• All computers participating in a single FactoryTalk system must be members of the same Windows domain.

• Do not locate the domain controller on the same computer as any FactoryTalk software. Microsoft recommends against third party software being installed on a domain controller.
Domain controller requirements

For network applications consisting of more than 10 computers, the use of a domain controller is recommended.

The following domain controllers are supported:

- Windows Server 2012 (Standard Edition)
- Windows Server 2012 R2 (Standard Edition)
- Windows Server 2008 with Service Pack 2 (Standard Edition)
- Windows Server 2008 R2 with Service Pack 1 (Standard Edition)

For more information about Windows operating systems and Service Pack compatibility, see Rockwell Automation Knowledgebase Answer ID 20450.

Note: Do not install FactoryTalk Directory, FactoryTalk View SE Server, or any other application software on the same computer as the Windows domain controller. This configuration is not supported.

About synchronizing time on application computers

In a networked system, to ensure that time stamps on alarms, historical data, and diagnostics are accurate, it is highly recommended that time synchronization be configured on all application computers.

For more information about synchronizing application computer clocks to an authoritative time server, see FactoryTalk View SE Design Considerations, attached to Rockwell Automation Answer ID 32549.

Windows workgroup requirements

For network applications consisting of 10 or fewer computers, you can run FactoryTalk View SE in a Windows workgroup network environment.

For workgroup applications running in Windows XP, you must turn off simple file sharing and fast user switching on each computer in the workgroup.

- Name resolution is required for the computers to communicate with each other on the network.
- Workgroups do not use a domain controller, so central network administration is not available. This means that security and network communications (for example, name resolution) must be handled at each individual computer in the workgroup.

- Each workstation in a workgroup must have the same user accounts, with the same user names and passwords on each machine, for all machines participating in a client-server environment.

- All users in a workgroup should have Administrative rights assigned to them.

- FactoryTalk Directory provides centralized security services without requiring a Windows Server and domain controller. When setting up centralized security in a FactoryTalk Network Directory for Windows Workgroups, do not use Windows-linked accounts. Instead, create user accounts that are managed and authenticated by FactoryTalk Security.

Set up computers with names to be used in production

When you install the FactoryTalk Services Platform with FactoryTalk View SE, the program creates a FactoryTalk account for the current computer, under the Local and Network FactoryTalk Directories.

As a result, if you rename the computer after installing FactoryTalk View SE or when you deploy an application, the FactoryTalk Directory will not recognize the new name.

To avoid this problem, it is recommended that you give the application client and server host computers the names they will use in a production setting, before you install the FactoryTalk View SE software.

Tip: If you must rename a computer and you encounter problems, for assistance, see Rockwell Automation Answer ID 35169 (for FactoryTalk View SE network applications), or Answer ID 38775 (for FactoryTalk View SE local and ME applications).
Chapter 3

Pre-installation configuration

This section will guide you through the steps for preparing your computer for installation of the FactoryTalk View SE product and supporting software.

- **Disable automatic Windows updates** on page 31
- **Turn off simple file sharing and fast user switching** on page 32 (Windows XP only)
- **Disable operating system themes** on page 32
- **Manually configure NICs and switch ports** on page 33
- **Disable or uninstall third-party firewalls** on page 35
- **Install Microsoft Internet Information Services** on page 139 (Windows XP only).
- **Remove Internet Explorer Enhanced Security Configuration** on page 37
- **Set up Internet Explorer for optimal access to components**
- **Set up Data Execution Prevention** on page 39 if needed
- **Remove unnecessary DCOM networking protocols** on page 40

When you install Microsoft Service Pack releases and other Windows operating system updates, you introduce new software that could affect the operation of FactoryTalk View SE components on the computer.

**Note:** Windows updates should be disabled in all production computers. Updates can cause unexpected behaviors, including shutting down running applications and automatic computer reboots.

1. Open the Windows Update window:
   - (Windows 7 or Windows Server 2008) Select **Start > All Programs > Windows Update**.
   - (Windows 8.1, Windows 8, or Windows Server 2012) Press the Windows button+X, select **Control Panel > Windows Update**.

2. In the left column, select **Change settings**.
3. In the Important Updates drop down, select Never check for updates.

4. Select the check box Give me recommended updates the same way I receive important updates.

5. Clear the check box Allow all users to install updates on this computer.

For Windows XP:

1. Open the Windows Control Panel, and then double-click System.

2. In the Automatic Updates tab, select the option Turn off Automatic Updates.

For more information about Windows operating systems and Service Pack compatibility, see Rockwell Automation Knowledgebase Answer ID 20450.

This step only applies to Windows XP.

To turn off simple file sharing:

1. On the desktop or in Windows Explorer, right-click My Computer, and then select Explore.

2. From the Tools menu, select Folder Options.

3. In the View tab, under Advanced settings, clear the check box, Use simple file sharing.

To turn off fast user switching:

1. Open the Windows Control Panel, and then double-click User Accounts.

2. Click the link, Change the way Users Log on and Off.

3. Clear the check box, Use Fast User Switching, and then click Apply Options.

Disable operating system themes

Operating system themes, which allow for effects such as sounds, icons, and other elements that personalize the computer, can cause heavy loads on the computer’s processor when running some FactoryTalk View SE graphic components, such as alarm summaries.

For best performance, disable all themes. Follow the steps below.

1. Open Control Panel:
• (Windows 7 or Windows Server 2008)
  Select **Start > Control Panel**.

• (Windows 8.1, Windows 8, or Windows Server 2012)
  Press the Windows button+X, select **Control Panel**.

2. In Control Panel, click **Appearance and Personalization**.

3. Under Personalization, click **Change the theme**.

   On the Themes tab, in the Theme list, click **Windows Classic**, and then click **OK**.

**For Windows XP:**

1. Select **Start > Control Panel**.

2. In Control Panel, double-click **Displays**.

3. On the **Themes** tab, from the **Theme** list, select **Windows Classic**, and then click **OK**.

---

**Manually configure NICs and switch ports**

The NIC (Network Interface Card) is the hardware in a computer that lets it connect to other devices on the network. A switch manages traffic on the Ethernet network. Some switches allow ports (physical connections) to be configured individually.

The link speed and duplex settings for network connections can be auto-negotiated (the device determines the best way to communicate), or manually configured (settings are hard coded).

Many NICs also offer a power-saving feature that turns off the network card if it is not being used. This setting sometimes interferes with the ability of the computer to receive data, causing errors such as wireframes, stale data, and other failures. To prevent these errors, disable power saving for your computer’s network interface cards. For details, see [Disable power saving for the NIC](#) on page 35.

For FactoryTalk View SE applications, it is recommended that you use managed switches across the control system network and that you manually configure the same link speed and duplex setting for all network connections into the managed switches.

It is also recommended that you manually configure the managed switch ports, using the same settings. To learn how to configure switch ports, see the product documentation provided with the switches you are using.

For an overview of best practices for connecting devices over a network, see the *Ethernet Design Considerations Reference Manual* document in the
Rockwell Automation Literature Library. (Search for publication ENET-RM002.)

Note: If you are using unmanaged switches, the NIC settings must remain auto-negotiated. Connecting an auto-negotiated device to a manually configured device can result in network communication errors and is not recommended.

Set up the NIC link speed and duplex

The steps vary slightly for some of the Windows operating systems. See the sections that apply to the operating systems you are using. Follow the steps below.

1. Open Windows Control Panel, and then click Network and Internet.
2. From the list of categories, select Network and Sharing Center.
3. From the list of Tasks on the left, select Change adapter settings (or Manage network connections).
4. From the list of network connections, right-click Local Area Connection (or Ethernet), and then select Properties.
5. In the Networking tab, click Configure.
6. In the Properties dialog box for the device, click the Advanced tab.
7. From the list of properties for the device, select Link Speed & Duplex (or Speed & Duplex).
8. From the Value list, select the highest possible value for the connection, and then click OK.

For Windows XP:

1. Open the Windows Control Panel, and then double-click Network Connections.
2. Right-click Local Area Connection, and then select Properties.
3. In the General tab, beside the network device name, click Configure.
4. In the Properties dialog box for the device, click the Advanced tab, and then select Speed & Duplex.
5. In the Value list box, select the highest possible value for the connection—either 100 Mb Full or 1000 Mb without a duplex setting.

**Disable power saving for the NIC**

The steps vary slightly for some of the Windows operating systems. See the sections that apply to the operating systems you are using. Follow the steps below.

1. Open Windows Control Panel, and then click **Network and Internet**.
2. From the list of categories, select **Network and Sharing Center**.
3. From the list of **Tasks** on the left, select **Change adapter settings** (or **Manage network connections**).
4. From the list of network connections, right-click **Local Area Connection** (or **Ethernet**), and then select **Properties**.
5. In the **Networking** tab, click **Configure**.
6. In the **Properties** dialog box for the device, click the **Power Management** tab.
7. Clear the **Allow the computer to turn off this device to save power** check box, and then click **OK**.

For Windows XP:

1. Open the Windows Control Panel, and then double-click **Network Connections**.
2. Right-click **Local Area Connection**, and then select **Properties**.
3. In the **General** tab, beside the network device name, click **Configure**.
4. In the **Properties** dialog box for the device, click the **Advanced** tab, and then select **Speed & Duplex**.
5. Clear the **Allow the computer to turn off this device to save power** check box, and then click **OK**.

**Disable or uninstall third-party firewalls**

FactoryTalk View SE is compatible only with the built-in Windows firewall and should not be used with third-party firewalls because this can cause unexpected results.

Before installing FactoryTalk View SE, disable or uninstall all third-party firewalls on the computer. For details, see the documentation supplied with your firewall product.
Install Microsoft Internet Information Services

Microsoft Internet Information Services (IIS) is a critical service for a Distributed FactoryTalk View SE System. Because of this, the Setup Wizard detects whether Microsoft IIS is available on the computer and shows the status of that installation to the user.

The following table shows whether IIS is required on your computers:

<table>
<thead>
<tr>
<th>IIS required</th>
<th>IIS not needed</th>
</tr>
</thead>
<tbody>
<tr>
<td>• FactoryTalk View SE Server</td>
<td>• FactoryTalk View SE Client</td>
</tr>
<tr>
<td>• FactoryTalk View Studio that needs to remotely connect to a Network FactoryTalk View SE system.</td>
<td>• FactoryTalk View Studio</td>
</tr>
<tr>
<td></td>
<td>• Stand Alone RSLinx Enterprise Server</td>
</tr>
<tr>
<td></td>
<td>• Stand Alone FactoryTalk Directory Server</td>
</tr>
</tbody>
</table>

Guidelines for different operating systems

Because of different versions and configurations for IIS, you may need to perform manual steps for older operating systems before installing FactoryTalk View SE. Microsoft has also changed its policy of including a key IIS component, WebDAV, in various operating systems. This also will require manual steps to download and install WebDAV for older operating systems.

- Need to manually install and configure IIS for Windows XP.
- IIS is installed by FactoryTalk View Setup Wizard automatically in the other supported operating systems.

Tip: If you have problems with the IIS setting, refer to Install Microsoft Internet Information Services on page 139.

- Need to manually download WebDAV from Microsoft and install for Windows Server 2008 with Service Pack 2.

To install IIS on Windows XP

1. Close all open Windows programs.
2. Place your Windows XP DVD in the computer’s DVD drive.
3. Open the Windows Control Panel, and then double-click Add or Remove Programs.
4. On the left side of the Add or Remove Programs window, click Add/Remove Windows Components.
5. After the Windows Components Wizard starts, select the check box, Internet Information Services (IIS), and then click Details.
6. In the Internet Information Services (IIS) dialog box, select the check boxes, **Common Files**, **Internet Information Services Snap-In**, and **World Wide Web Server**.

7. Click **OK**, and then click **Next**.

To finish installing IIS, follow the instructions in the wizard.

**About uninstalling IIS**

If for some reason, you need to uninstall and then reinstall IIS, after reinstallation, you need to recreate the virtual directories in IIS.

To recreate the virtual directories, in Windows Explorer, open `C:\Program files\Rockwell Software\RSView Enterprise` and double-click `RSViewWebManager.exe`.

Internet Explorer Enhanced Security Configuration (ESC) is a group of default security settings for Windows Server 2008 and Windows Server 2012 that protects servers by limiting the ways users can browse Internet and Intranet Web sites on the computer.

If installed on a computer with FactoryTalk View SE software components, the Internet Explorer ESC can interfere with the ability of FactoryTalk View SE Clients to connect to application servers.

To avoid unexpected behavior, it is recommended that you remove the ESC from computers running FactoryTalk View SE.

**To remove ESC in Windows Server 2008:**

1. Select **Start > Administrative Tools > Server Manager**.
2. In the Server Manager window, under Security Information, click Configure IE ESC.

3. In the Internet Explorer Enhanced Security Configuration dialog, select Off to turn off IE Enhanced Security for Administrators and for users, and then click OK.

To remove ESC in Windows Server 2012:

1. On the Windows taskbar, select the Server Manager icon.
2. In the **Server Manager Dashboard** window, on the left side, click **Local Server**.

3. On the right side of the **Local Server** window, under **Properties**, locate **IE Enhanced Security Configuration** and click **On**.

4. In the **Internet Explorer Enhanced Security Configuration** dialog, select **Off** to turn off IE Enhanced Security for Administrators and for users, and then click **OK**.

Data Execution Prevention (DEP) is a Microsoft Windows security feature in Windows XP (with Service Pack 3), Windows 7 Professional, and Windows Server 2008. DEP is intended to protect programs and services from viruses and other security threats.

The DEP settings determine which programs and services are covered by DEP protection. On computers running FactoryTalk View SE components, it is recommended that DEP be turned on for essential Windows programs and services only.

The steps vary slightly for some of the Windows operating systems. See the sections that apply to the operating systems you are using.

**For Windows XP:**

1. Open Windows Control Panel, select **Control Panel Home > System and Maintenance**.

2. Click **System**.

3. From the list of tasks on the left, select **Advanced system settings**.

4. In the **System Properties** dialog box, click the **Advanced** tab.

5. In the **Advanced** tab, under **Performance**, click **Settings**.

6. In the **Performance Options** dialog box, click the **Data Execution Prevention** tab.

7. Select the option, **Turn on DEP for essential Windows programs and services only**, and then click **OK**.
If multiple DCOM protocols are installed and configured on the computer, performance of communications in a FactoryTalk View SE system can be adversely impacted. To ensure that DCOM communications function correctly, and do not affect the performance of the system, remove all protocols other than TCP/IP.

To remove unnecessary DCOM protocols:

1. Select Start > Run.
2. In the Run dialog box, type dcomcnfg, and then click OK.
3. In the Component Services tool, expand Component Services, open the Computers folder, right-click My Computer, and then select Properties.
4. Click the Default Protocols tab. If the DCOM Protocols list shows protocols in addition to TCP/IP, remove those unnecessary protocols. For example, remove the protocol Connection-oriented SPX.
Installing FactoryTalk View

The FactoryTalk View installation DVD provides all the software you need to develop and run distributed systems involving multiple computers on a network, or local applications confined to a single computer using FactoryTalk View Site Edition (SE).

This chapter uses FactoryTalk View Studio Enterprise to illustrate the installation steps, because it includes all mandatory and optional installation choices included with the other selections on the welcome screen.

To learn about upgrading an existing version of FactoryTalk View SE, see Upgrading an operating FactoryTalk View SE application on page 101.

FactoryTalk View supports two installation methods: Setup wizard installation and unattended installation.

The unattended installation reduces user interaction and provides command line parameters to install FactoryTalk View products. See Use unattended installation on page 143.

This chapter uses the Setup wizard installation method to illustrate the steps. The overall installation process includes:

1. Deciding which FactoryTalk View SE components to install on page 42
2. Preparing for installation on page 43
3. Launching Setup Wizard and selecting what to install on page 43
4. Common setup and IIS install on page 44
5. Providing information for the install on page 47
6. Checking selections and starting the installation process on page 54
7. Installation complete on page 55
8. Installing SE clients in a distributed system on page 56
9. Post-installation procedures on page 57
Deciding which FactoryTalk View SE components to install

The FactoryTalk View Setup Wizard offers several options for installing the FactoryTalk View Site Edition software. You can select:

- Studio Enterprise
- Site Edition Server
- Site Edition Client
- Site Edition Station
- Stand-alone RSLinx Enterprise Server
- Stand-alone FactoryTalk Directory Server

The option you choose depends on the type of FactoryTalk View Site Edition application or software component you plan to run on the computer and on the design of your control system.

For each selection on the Welcome Screen, the following table shows the mandatory, recommended and optional software components to install.

<table>
<thead>
<tr>
<th>Selected Application</th>
<th>Mandatory Applications</th>
<th>Recommended and Optional</th>
</tr>
</thead>
<tbody>
<tr>
<td>Studio Enterprise</td>
<td>FactoryTalk View Studio Enterprise</td>
<td>FactoryTalk View SE Server</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Services Platform</td>
<td>FactoryTalk View SE Client</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Activation Manager</td>
<td>Device Status and Diagnostics Faceplates</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Alarms and Events</td>
<td>RSLinx Classic</td>
</tr>
<tr>
<td></td>
<td>RSLinx Enterprise</td>
<td>FactoryTalk Historian Connectivity</td>
</tr>
<tr>
<td>Site Edition Server</td>
<td>FactoryTalk View SE Server</td>
<td>FactoryTalk View SE Client</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Services Platform</td>
<td>RSLinx Classic</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Activation Manager</td>
<td></td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Alarms and Events</td>
<td></td>
</tr>
<tr>
<td></td>
<td>RSLinx Enterprise</td>
<td></td>
</tr>
<tr>
<td>Site Edition Client</td>
<td>FactoryTalk View SE Client</td>
<td>FactoryTalk Historian Connectivity</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Services Platform</td>
<td></td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Activation Manager</td>
<td></td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Alarms and Events</td>
<td></td>
</tr>
<tr>
<td>Site Edition Station</td>
<td>FactoryTalk View SE Server</td>
<td>FactoryTalk View Studio</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk View SE Client</td>
<td>Device Status and Diagnostics Faceplates</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Services Platform</td>
<td>RSLinx Classic</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Activation Manager</td>
<td>FactoryTalk Historian Connectivity</td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Alarms and Events</td>
<td></td>
</tr>
<tr>
<td></td>
<td>RSLinx Enterprise</td>
<td></td>
</tr>
<tr>
<td>Stand-alone RSLinx Enterprise Server</td>
<td>RSLinx Enterprise</td>
<td>FactoryTalk Alarms and Events</td>
</tr>
<tr>
<td>Stand-alone FactoryTalk Directory Server</td>
<td>FactoryTalk Services Platform</td>
<td></td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Activation Manager</td>
<td></td>
</tr>
<tr>
<td></td>
<td>FactoryTalk Alarms and Events</td>
<td></td>
</tr>
<tr>
<td></td>
<td>RSLinx Classic</td>
<td></td>
</tr>
</tbody>
</table>
Preparing for installation

- Ensure that the user installing the software has administrative rights in Windows.
- If installing FactoryTalk View Studio Enterprise, locate the serial number because you will be prompted for it during the installation. Serial numbers are generally on the original packaging of the installation media.
- Schedule downtime for the system if you are upgrading operating applications or replacing computers during the installation.

Launching Setup Wizard and selecting what to install

1. Close all open Windows programs.

2. Place the FactoryTalk View Installation DVD in the computer’s DVD drive. The installation should start automatically.

   If the installation does not start, run D:\Setup.exe, where D:\ is the drive containing the DVD.

   After launching, the Setup Wizard automatically installs the necessary software and prerequisites if needed:

   - Windows Installer 4.5
   - Microsoft XML 4.0 SP2

   **Tip:** On Windows XP, you must install a new driver certification for DriverPkgx64.msi and the 32-bit USBCIP Driver. The installer automatically detects if the system contains this certification. If not, the following message opens. Click Yes to continue.

   In order to continue FactoryTalk® Services installation, this system must be updated with a current software publisher root certificate. With this update your system will trust drivers from Rockwell Automation, as well as other software publisher.

   The welcome screen offers a pull down menu to select the products you would like to install.

   ![Welcome screen](image)

   3. Select the appropriate product for the computer you are upgrading or installing.
4. Adobe Reader will be installed unless you clear the check box. Adobe Reader is required to open the Installation Guide, User Guide, and other documents.

5. After you make the selection from the list, the Setup Wizard will automatically offer different choices for the software products to install. Make your choices and click Next. The applications you have selected will determine the sequence of installation.

Follow the prompts for the product you have selected.

**Common setup and IIS install**

On the dialog box that prompts you to Please select Software Products to Install there may be three different options displayed:

- **Mandatory** (greyed-out and checked) software that will be automatically installed as part of the selected application.
  
  **Tip:** If a product is already installed, it will be greyed out with an unchecked check box.

- **Recommended** (check box with a green check) indicates software that Rockwell recommends for the application. You may decide to uncheck the box so the software does not install.

- **Optional** (clear check box) indicates software that you may wish to include depending on your system. Check the box to include the software during installation.
When a new product from the middle selection box is selected, version and upgrade information is shown in the right text box. If applicable, information about the previous version is also displayed in the right text box.

In the example above, Factory Talk Services Platform v2.70.00 is available to be installed.

Make any changes desired and click Next to proceed.

**FactoryTalk Activation Warning**

Some products require activation using FactoryTalk Activation Manager. Even if you previously used a different method of activation, all FactoryTalk View software must be activated using FactoryTalk Activation Manager. Click Next to proceed.

**Microsoft Internet Information Services (IIS) check and installation**

The Setup Wizard automatically installs Microsoft Internet Information Services (IIS) if needed on all supported operating systems except Windows XP. Click Install IIS to proceed.
Tip: For procedures to install IIS on Windows XP, see Install Microsoft Internet Information Services on page 36.

After selecting Install IIS, you will see the text appear in this screen at the top:

*Installing IIS - This may take several minutes, please wait...*

Once the IIS installation is complete, the text will appear in this screen at the top:

*IIS is installed correctly, please click Next to continue.*

Tip: For Windows Server 2008 SP1 and SP2 running network applications, the WebDAV module must be installed in IIS. Click on Download WebDAV to download and install the extension from the Microsoft website.

After IIS and WebDAV are installed as needed, click Next to proceed.

**Dependent software process termination warning**

During the installation, the Setup Wizard identifies Rockwell Automation software that will be replaced. The program automatically terminates the programs listed on the following dialog box.
Note: This procedure could shut down your process applications! Depending on which applications you are installing or upgrading, it is possible that your factory automation system will become inoperable, shutting down your processes. Be certain you have prepared for this downtime and all of your company’s systems are prepared for these applications to be terminated.

Click Next to proceed.

Providing information for the install

The Setup Wizard will only show this Serial Number entry page when FactoryTalk View Studio Enterprise is selected for installation. All other product serial numbers will be entered through the FactoryTalk Activation Manager after the installation is complete.
User name and organization are optional and not required for all installations. A serial number reveals which edition of FactoryTalk View you purchased. Valid serial numbers are important to get activation keys and call Technical Support. If you do not enter a valid serial number, you will be allowed to proceed with the installation. Serial number information is available from the product packaging.

Enter the serial registration information and click **Next**.

**End User License agreement**

End-user license agreements (EULA) spell out your rights and responsibilities. Depending on the applications being installed, it is possible that there may be more than one license agreement on this page. The individual license agreements are listed above the text box.

Some software products may be delivered or made available only after you agree to the terms and conditions of each of the license agreements.

**To accept the license agreements:**

1. Select an agreement at the top of the dialog box to read the license agreement.

2. Repeat for each license agreement.

3. When all license agreements have been read, click **Accept All** to agree with the terms of all the listed license agreements and continue.

   If you do not accept the terms of the license agreements click **Decline**. The Setup Wizard will end.
To return to the previous screen, click **Back**.

**File location for product installation**

Select the location for Rockwell Automation software. If needed, select the pull down menu to browse to another drive location.

Once the drive is selected, click **Next**.

**Select Setup Type**

This dialog box allows you to select the most appropriate type of installation for your applications.

- **Complete** installs all the components available in the Setup Wizard.
- **Custom** allows you to select optional components such as Help and demo applications.
Select a setup type and click Next.

SQL Server sign-in or installation

During the installation, the Setup Wizard determines whether a compatible SQL server is available on the computer.

FactoryTalk View Site Edition tag database supports the following editions:

- SQL Server 2008 R2 Express (32-bit or 64-bit)
- SQL Server 2008 R2 Standard (32-bit or 64-bit)
- SQL Server 2008 R2 Enterprise (32-bit or 64-bit)
If a supported edition of FTVIEWx64TagDB instance exists, the installer skips the SQL configuration step.

If it is not already installed, the Setup Wizard will prompt for a new password and will ask to verify the password as shown above.

**Tip:** To use other compatible SQL Server editions, you need to manually install it. Click **Compatible Editions** for instructions or see **Install other compatible SQL Server editions** on page 52.

New passwords must be **strong passwords**. Click **Guidelines** to review the requirements for strong passwords.

Enter and verify the password, then click **Next**.

**Note:** The chosen password should be recorded and saved along with other administrator passwords for system maintenance personnel.

**Strong Password Guidelines**

Strong passwords are not readily guessed by a person, and are not easily hacked using a computer program. Strong passwords cannot use prohibited conditions or terms, including:

- A blank or NULL condition
- **Password**
- **Admin**
- **Administrator**
- **sa**
- **sysadmin**

A strong password cannot be the following terms associated with the installation computer:

- The name of the user currently logged onto the machine
- The computer name

A strong password must be more than 8 characters in length and satisfy at least three of the following four criteria:

- It must contain uppercase letters
- It must contain lowercase letters
- It must contain numbers
It must contain non-alphanumeric characters; for example, #, %, or ^

**Install other compatible SQL Server editions**

FactoryTalk View Site Edition provides a batch file that you can use to install the SQL Server edition with minimal user intervention. Follow the steps below:

1. Close all open Windows programs, including FactoryTalk View setup program.

2. Open the **Command Prompt** window:
   - (Windows Server 2012, Windows 8.1, and Windows 8) Press the Windows button + R, and in the Open text box, input cmd and click OK.
   - (The other supported operating systems) From the Windows Start menu, select All Programs > Accessories > Command Prompt.

3. In the **Command Prompt** window, navigate to the following directory where D:\ is the drive containing the disk:

   D:\Redist\SQLServerEXPR_2008R2SP2

   In this example, type cd /D "D:\Redist\SQLServerEXPR_2008R2SP2" and press Enter.

4. Type a command line with the following syntax:

   "Install Compatible SQL.bat" [SQL setup.exe path] [Product key] [SA password]

   All parameters are required.

   - [SQL setup.exe path] Specifies the full path of SQL Server setup.exe, for example, E:\setup.exe.
   - [Product key] Specifies the SQL Server product key.
   - [SA password] Specifies the SQL Server System Administrator (SA) password.

**Example:**

If your SQL Server setup.exe is under the drive E:, the product key is 01234-56789-ABCDE-FGHIJ-KLMNO, and the SA password is mySaPwd@123, type the following command:

"Install Compatible SQL.bat" E:\setup.exe 01234-56789-ABCDE-FGHIJ-KLMNO mySaPwd@123
5. Press **Enter**. The installation starts. Follow the on-screen instruction to complete the installation.

**Configuring Products**

If you selected the **Custom** setup, you can decide whether to install the demo applications and help files when performing a FactoryTalk View Studio Enterprise installation.

Under the FactoryTalk View Site Edition Server application, you can also decide whether to install the client install portal feature. The feature allows you to install Site Edition Client through a web browser in a distributed system. For more information about the feature, see [Installing SE clients in a distributed system](#) on page 56.
Tip: Make sure to select the Client Install Portal check box at the first time if you plan to use this feature. Otherwise, you will not be able to add and install it in the Program Maintenance mode.

Some other applications may not provide any choices.

Click Next to continue.

Checking selections and starting the installation process

Once all the selections are made, the Setup Wizard displays the prerequisites and Rockwell software that will be installed.

- **Configuration Summary** indicates the software that will be included in the installation process.

- **Prerequisite Software** is required on the computer to support the Rockwell Software applications.

- **Rockwell Software** applications are the Rockwell applications queued for installation.

This step shows you the list of software that will be installed based on the selections made in the Setup Wizard.

Select the software names to show descriptions in the bottom text window.

To make a different product selection, click Back.

If everything in the list looks okay, click Install to start the installation process.
Installation of selected software

After installing prerequisites, the installer automatically installs all the Rockwell Software applications selected previously. Installation is automatic and does not require any input from the user.

Installation status updates are provided at the bottom, just above the progress bar.

When the installation of FactoryTalk View SE Software Setup completes, the Setup Complete dialog box opens.

To receive the patch notification when you install Rockwell software, click Register for updates and subscribe.
To proceed directly to activation of the installed components, click **Finish**. You can also clear the check box for **Activate products using FactoryTalk Activation** to finish without activation. See **Activating FactoryTalk View software** on page 59.

After you click **Finish**, you will be prompted to restart the computer. Click **Yes** to restart now. Click **No** to restart later.

In a distributed system, after installing the server computer with the client install portal feature, you can install SE clients through the web browser.

**To install the SE client application:**

1. On the client computer, open Internet Explorer.

2. In the Address field of Internet Explorer, type the following address:

   \[ \text{http://servername/ftviewclient} \]

   where `servername` is the name of your FactoryTalk View SE server computer.

   For example, if your FactoryTalk View SE server is called MYSERVER, type:

   \[ \text{http://MYSERVER/ftviewclient} \]

   If you are using SSL, then begin with `https://` instead.

3. Press **Enter**.

   Internet Explorer displays a page from the server that allows you to install the FactoryTalk View Site Edition Client application.
Tip: If Internet Explorer displays an error message that it cannot connect to the install web page, try adding the FactoryTalk View Site Edition website (URL above) to your local intranet site list.

To do this, in Internet Explorer, click Tools > Internet Options > Security tab > Local intranet > Sites > Advanced, and add the website to the list. For more information about the local intranet, refer to Windows Help and Support.

4. Microsoft .NET Framework 4.0 is required before you can install FactoryTalk View Client. If it is not installed, click Install .NET Framework 4.0 on this computer. The option is not shown if it is already installed.

5. Follow the on-screen instructions. If prompted to restart your computer, click Restart Now.

6. Once the computer has restarted, repeat steps 1 to 4.

7. To install SE Client, click Install FactoryTalk View Site Edition Client on this computer. Follow the on-screen instructions. If you are displaying data from FactoryTalk Historian on trends, click Install FactoryTalk Historian Connectivity tools. Follow the on-screen instructions to complete the installation.

Tip: FactoryTalk Historian Connectivity allows the TrendX object to retrieve data from a Historian SE Server or Historian ME Module. It makes updates to FactoryTalk Administration Console and FactoryTalk View SE Studio to display an Historian icon for both Historian SE and Historian ME when they are registered. You can use it to create new Historian SE points from TrendX and select existing Historian points from Historian SE or Historian ME.

Post-installation procedures

Now that FactoryTalk View product has been installed, there may be several final setup steps that must be completed:

- Installing product updates on page 132
- Specifying the Network Directory server location on page 57

Specifying the Network Directory server location

Use the FactoryTalk Directory Server Location Utility on all application server and client computers to specify the computer that will host the FactoryTalk Network Directory server.
To set up the local computer as the Network Directory server

1. On the Network Directory computer, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.

You will have to log on as an administrator on the local computer.

2. If localhost is displayed in the field under Computer hosting directory server, the computer is already specified as the Network Directory host. You can close the utility.

   If localhost is not displayed, click the Browse button.

3. In the FactoryTalk Directory Server Configuration dialog box, click This computer, and then click OK.

4. Click OK again, to close the FactoryTalk Directory Server Location Utility.

To specify the Network Directory on client and server computers

1. On the Network Directory computer, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.

2. If a remote computer is hosting the Network Directory server, click the Browse button beside the field, Computer hosting directory server.


4. Type the name of the Network Directory server computer, or click the Browse button to find and select the computer, and then click OK.

   You will have to log on as an administrator on the remote computer.

5. Click OK again, to close the FactoryTalk Directory Server Location Utility.

Repeat steps 1 to 5 on all client and server computers that will participate in the deployed network distributed application.
Chapter 5

Activating FactoryTalk View software

For continuous use of FactoryTalk View SE and other Rockwell Software products, computers running the software must have access to activation files.

To manage and provide activations for FactoryTalk View SE software components, use the FactoryTalk Activation Manager installed with FactoryTalk View.

FactoryTalk Activation Manager provides a secure, software-based system for activating Rockwell Software products and managing software activation files.

With FactoryTalk Activation Manager, there is no need for a physical master disk or any physical media; instead, activation files are generated and distributed electronically.

FactoryTalk View SE products use two types of activations:

- **Floating** concurrent activations are checked out of an activation server located on the network, and require a continuous network connection.
- **Borrowed** concurrent activations are time-expiring activations checked out of an activation server on the network, and do not require a continuous network connection.

For standard installations of the product software, FactoryTalk View SE supports only the use of both types of **shared concurrent** activations. Node-locked activations are not supported.

**Tip:** To learn about the types of activation that other Rockwell Automation products can use, see the product documentation or contact your local Rockwell Automation Sales office.

What happens if FactoryTalk View is not activated?

If the FactoryTalk View components you have installed cannot be activated, for example, because the activation server is unavailable or because borrowed activations have expired, the software will continue to run for up to seven days.
The seven-day grace period allows time to correct the problem with acquiring activations without disrupting critical applications. If activation is restored within seven days, normal operations will resume.

If activation is not restored, the grace period will expire. After the grace period expires, if you restart FactoryTalk View SE and activation remains unavailable, the software will run for two hours in demo mode.

With a FactoryTalk View SE network distributed application, running in demo mode, you can:

- Create or load up to five HMI servers locally in FactoryTalk View Studio.
- Create or load up to five graphic displays per HMI server.
- Run a local station FactoryTalk View application for up to two hours. In demo mode, remote clients cannot connect to a FactoryTalk View server.
- In Symbol Factory, import only the first graphic in each category.

Floating concurrent activations are assigned automatically to clients that need them, and returned automatically to the activation server pool when FactoryTalk View SE stops running on the client, or when the client computer shuts down.

Client computers must be set up to obtain floating activations from the activation server.

If you prefer to use borrowed activations for clients, skip to Borrow activations for development computers on page 61.

After you set up the activation server (or servers), you can specify which server each client computer will obtain activations from.

Once a client is connected to a server, all you have to do is to run the FactoryTalk View software (for example, the FactoryTalk View SE Client), and the server will issue available activations automatically.

A continuous network connection is required for an activation client to use floating activations. After a client obtains a floating activation, when the activation server detects that the client has been disconnected, the activation is returned to the server pool.

To ensure that critical software components (redundant HMI servers, for example) can always obtain the necessary activations, set up an activation server on the computer where the software is running.

Set up client computers to obtain floating activations
Ensure that network application components stay activated

To ensure that critical software components in a network application using floating activations can always obtain the necessary activations, even if the network is disrupted, set up a FactoryTalk Activation server on every computer where the FactoryTalk View SE software is running. This includes all clients and all servers, whether redundant or not.

For example, to ensure that a redundant FactoryTalk View SE Server remains activated, install the activation server on both computers hosting the redundant server pair, and then add the necessary activations to those computers.

If it is not convenient for a development computer to remain connected to the network where the activation server resides, you can connect to the activation server temporarily, borrow a concurrent activation for a limited amount of time, and then disconnect. When the time-limited activation expires, its associated software is no longer activated, and the activation automatically becomes available again from the server's activation pool.

Borrow activations for development computers

Only the FactoryTalk View Studio activation keys can be borrowed. While developing Network applications disconnected from the network, the FactoryTalk View Studio activation key is shared by any test clients and HMI servers in your application, allowing all necessary components to run for development purposes.

Note: To use borrowed activations, you must upgrade to FactoryTalk Activation Manager version 3.30 or later (included on any FactoryTalk CPR 9 SR 4 product's DVD) on all server and client computers where the borrowed activations will be used.

Activation keys for FactoryTalk View software components

The activation files you download from the Rockwell Software Activation Website contain the activation keys you purchased, in encrypted form. The activation key is the software that activates FactoryTalk View SE components. Following is a list of activation keys used by the FactoryTalk View SE and ME products.

Tip: For information about the keys required to activate other Rockwell Automation products in your application, see the product documentation.

<table>
<thead>
<tr>
<th>To activate this software product or component</th>
<th>Use this key</th>
</tr>
</thead>
<tbody>
<tr>
<td>FactoryTalk View Studio*</td>
<td>RSV.STUDIO</td>
</tr>
<tr>
<td>*Includes software for developing and testing FactoryTalk View Site Edition and Machine Edition applications</td>
<td></td>
</tr>
<tr>
<td>FactoryTalk View SE Server (network distributed applications), unlimited displays</td>
<td>RSVSESERV.MAX</td>
</tr>
<tr>
<td>FactoryTalk View SE Server (network distributed applications), 250 displays</td>
<td>RSVSESERV.250</td>
</tr>
</tbody>
</table>
### Sharing keys among multiple software components

Multiple FactoryTalk View SE software components can function using one activation key in the following cases:

- **Multiple instances of FactoryTalk View Studio or the FactoryTalk View SE Client** running on the same computer can use a single key (RSV.STUDIO or RSVSECLI), as long as the components are not running in a Terminal Services session.

- **In the network application of FactoryTalk View SE versions earlier than 6.10, for development and testing purposes**, one FactoryTalk View Studio key activates a FactoryTalk View SE Client and SE Server on the same computer. Remote clients and servers require component-specific activations.

  **Note:** In version 6.10 or higher, one FactoryTalk Studio key can no longer activate the local server or client to run in test run mode.

- **Local applications** use a single key (RSVSE.*) to activate both the FactoryTalk View SE Client and the FactoryTalk View SE Server at run time. These components running together are also known as FactoryTalk View SE Station.

  **Tip:** FactoryTalk View SE Server activations—known as capacity activations because they are based on the number of displays in an application—cannot be shared.
Read-write versus view-only activations

In a network application, FactoryTalk View SE Clients can use two types of activation:

- **Read-write** keys (RSVSECLL.RW) allow full read-write privileges.
- **View-only** keys (RSVSECLL.RO) allow view-only privileges.

Whether a FactoryTalk View SE Client runs in read-write or in view-only mode depends on the type of activation key available for the client to use, and whether the client itself is set up as read-write or view-only:

- If the activation server can only provide view-only licenses, and a read-write client obtains one of these licenses, then the activation overrides the client’s configuration, and the client runs in view-only mode.
- If the activation server can only provide read-write licenses, and a view-only client obtains one of these licenses, then the client’s configuration overrides the activation, and the client runs in view-only mode.
- Do not rely on available activation keys to determine whether the FactoryTalk View SE Client runs in read-write or view-only mode. Instead, to ensure that a client always runs in view-only mode, choose the view-only option when setting up the client’s configuration file. For details, click Help in the FactoryTalk View SE Client wizard.
Chapter 6

Deploying network distributed applications

After developing and testing a FactoryTalk View Site Edition network distributed application, you can deploy it to run in a live setting, such as the plant floor. Deploying a network distributed application often involves installing FactoryTalk View SE software components on multiple client and server computers.

For details about installing the software, see Installing FactoryTalk View on page 41. For information about upgrading a network distributed application that is already deployed, see Upgrading an operating FactoryTalk View SE application on page 101.

For details about the structure and content of network distributed applications, see Chapter 6, Working with network distributed applications in the FactoryTalk View Site Edition User’s Guide.

Overview of tasks

The checklist in this section summarizes the basic tasks involved in deploying a FactoryTalk View SE network distributed application. Each task is described in detail in the rest of this chapter. Add or remove steps as necessary to create a customized procedure that reflects the design and content of your FactoryTalk View application. For example, your application might include additional communications or database servers.

For details about deploying FactoryTalk Alarms and Events servers, see the FactoryTalk Alarms and Events Configuration Guide by selecting Start > All Programs > Rockwell Software > FactoryTalk Tools > FactoryTalk Alarms and Events Configuration Guide.

Task checklist

- Back up the network distributed application on page 66.
- Restore the network distributed application on page 67.
- Renew data server shortcuts, topics, and device paths on page 70.
- Set up additional HMI server properties on page 70.
- Set up the FactoryTalk View SE Clients on page 74.
- Run the FactoryTalk View SE Clients on page 76 to test the application.
When deploying a FactoryTalk View SE network distributed application, it is important to back it up properly to ensure that all its components are stored securely. However, security topics are not backed up and need to be manually resynchronized if changed.

**Back up the network distributed application**

Use the Distributed Application Manager tool to back up a FactoryTalk View SE network distributed application. The archive includes all FactoryTalk Directory-like accounts, passwords, policies, and security settings. It also includes all application contents like application configurations, HMI servers, data servers, and tag Alarm and Event servers.

- **Tip:** You need to manually back up RSLinx Classic topic names if you have RSLinx Classic OPC server configured in your application. For more information, see Back up and restore RSLinx Classic configurations on page 69.
- For information about backing up and restoring files that belong to FactoryTalk Tag Alarm and Event Servers, see the FactoryTalk Alarms and Events Help.

**About backing up System information with an application**

The following illustration shows what a FactoryTalk View SE network distributed application looks like when opened in FactoryTalk View Studio.

The FactoryTalk Network Directory (also called the Network Directory) is represented at the top of the application hierarchy. One level down, the System folder stores settings for all the applications that belong to the same Network Directory.

For example, FactoryTalk user and computer accounts set up for each application are stored in the System folder.
Note: RSLinx Enterprise device paths are also saved with System information, and might not be correct for the computer where the application will be restored. For information about checking device paths after restoring an application, see Verify RSLinx Enterprise shortcuts on page 118.

Back up a network distributed application

Before backing up an application, record the user names and passwords of administrative users set up for the application, in case you need this information after restoring the application.

To back up an application, select Start > All Programs > Rockwell Software > FactoryTalk View > Tools > Distributed Application Manager, select the application, and follow the wizard.

Tip: To back up a network distributed application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

The following example shows an overview of the tool when creating a backup. For more information, refer to Distributed Application Manager Help.

Restore the network distributed application

Before restoring the network distributed application, all client and server computers in the application must point to the same FactoryTalk Directory server.

You can restore the application to an existing or a new FactoryTalk
Directory. You can choose to restore the HMI project files only, the application only, the application with FactoryTalk Directory, or the application with FactoryTalk Directory and security identifier.

During the restore operation, you can also:

- Specify HMI server host computer names.
- Specify data server host computer names.
- Specify tag alarm and event server host computer names.
- Restore both the primary and secondary servers at the same time when restoring an archive with redundant servers.

To restore an application, select Start > All Programs > Rockwell Software > FactoryTalk View > Tools > Distributed Application Manager, select the application, and follow the wizard.

**Note:** Restoring archived application with FactoryTalk Directory System information replaces existing FactoryTalk Directory System settings on the computer. When deploying a FactoryTalk View SE network distributed application, it is recommended that you do not restore FactoryTalk Directory System information with the application, as this will remove existing computer accounts and prevent users from logging on to the Network Directory.

Include FactoryTalk Directory System information in the restore operation only if there are no applications using the current Network Directory, or if the effect on existing applications will be minimal.

The following example shows an overview of the tool when restoring an archive. For more information, refer to Distributed Application Manager Help.
**Restore RSLinx Enterprise configurations**

When you back up a FactoryTalk View SE network distributed application, the archive includes RSLinx Enterprise shortcut names, but does not include device path information.

After restoring the application, you must open the Communications Setup editor in FactoryTalk View Studio, and re-apply the device path for each configured shortcut.

For details, see [Renew data server shortcuts, topics, and device paths](#) on page 70.

**Back up and restore RSLinx Classic configurations**

RSLinx Classic configuration files are not included when you back up an application. You have to back up, move, and restore the files manually.

If RSLinx Classic is installed on the development and production computers, you can use the RSLinx Classic Backup/Restore tool to back up and restore configuration files.

**Tip:** You can also restore RSLinx Classic configuration files from the Wizard Completed window of the RSLinx Classic software setup program.

**To move RSLinx Classic configuration files:**

1. On the development computer, click **Start > All Programs > Rockwell Software > RSLinx**, and then click **RSLinx Classic Backup Restore Utility**.

2. In the RSLinx Classic Backup/Restore tool, click **Backup**.

3. Select a folder for the backup file, type a file name, and then click **Save**.

4. In Windows Explorer, copy the backup file (with .rsx extension), and then paste it into a location on the data server production computer.
5. On the production computer, click **Start > All Programs > Rockwell Software > RSLinx**, and then click **RSLinx Classic Backup Restore Utility**.

6. In the RSLinx Backup/Restore tool, click **Restore**.

7. Find and select the backup file you just pasted, and then click **Open**.

After restoring RSLinx data servers in the application, renew or verify the topics, shortcuts, and device paths associated with each data server, as needed.

If you are restoring redundant data servers, then the device paths must be confirmed and reapplied for both the primary and the secondary server.

### Renew data server shortcuts, topics, and device paths

#### To renew RSLinx Enterprise device paths

1. Open the restored application in the FactoryTalk Administration Console.

2. In the Explorer window, expand the data server (RSLinx Enterprise), and then double-click **Communications Setup**.

3. In the Communications Setup editor, select each configured RSLinx Enterprise shortcut, point the shortcut at the correct device, and then click **Apply**.

4. Save the configuration, and then close the **Communications Setup** editor.

#### To verify RSLinx Classic topics

1. On the data server computer, click **Start > All Programs > Rockwell Software > RSLinx**, and then click **RSLinx Classic**.

2. On the DDE/OPC menu, click **Topic Configuration**.

3. In the Topic List, select each configured topic and confirm that the corresponding data source updates correctly.

4. Click the **Advanced Communication** tab, confirm that there is a device path specified for Remote Addressing, and then click **Done**.

After restoring the application, you can open the HMI server properties dialog box in FactoryTalk View Studio to verify the HMI server settings and set up the following HMI server properties, as needed.

- In the **General** tab, to determine when the HMI server will load, select
You can specify that the HMI server will load when the first client attempts to connect to it (On demand) or when the host computer starts up (Load and run startup components when operating system initializes). The second option is recommended for production HMI servers, and required for an HMI server that is part of a redundant pair.
In the Redundancy tab, to set up redundancy for the HMI server, first select the check box, Provide redundancy using a secondary server; then, specify the name the computer that will host the secondary server, and select a switchover option.
Tip: Before you can specify the secondary server in a redundant pair, you must manually copy the HMI project files to the secondary server computer.

- In the Components tab, select the application components that will start automatically when the HMI server starts, and select the macro that will run when the server shuts down. You can also start or stop components manually.

If the HMI server is redundant, you can also start and stop components for the primary and the secondary server, and select On active and On standby macros.

You must set up the HMI server properties separately, for each server in the FactoryTalk View SE network distributed application you are deploying. You can do this on the computer running the HMI server, or from a remote computer.

For details about setting up HMI server properties, see Chapter 6, Working with network distributed applications in the FactoryTalk View Site Edition User’s Guide. For details about setting up redundant HMI servers, see Chapter 14, Setting up FactoryTalk system availability in the FactoryTalk View Site Edition User’s Guide.
Synchronizing redundant HMI servers and projects

After setting up redundancy for an HMI server, to ensure that identical copies of the HMI server and project files are running on the primary and the secondary computers, replicate changes from the primary to the secondary server.

The replicate operation copies the primary server’s configuration files, including settings in the Components tab, to the secondary server.

For example, if an On Active and a Shutdown macro are selected for the primary server, the settings will be replicated to the secondary. This means that the same macros specified for the primary server will run when the secondary server becomes active or shuts down.

Information that is not included in the replicate operation includes datalog files generated at run time, the current value of HMI memory tags, retentive tags, and the HMI tag alarm suppressed list.

Note: For the replicate operation to succeed, a copy of the HMI project files must already exist on the secondary server computer. In addition, the state of the primary server must be Active, and the state of the secondary server must be Standby, for the duration of the operation.

To replicate changes from the primary to the secondary server:

1. Open the restored application in the FactoryTalk View Studio Enterprise.
2. In the Explorer window, right-click the HMI server’s name, and then click Properties.
3. Click the Redundancy tab, and then click Replicate Primary to Secondary.

Tip: If a secondary server is not specified, the Replicate Primary to Secondary button will not be available in the Redundancy tab.

To finish replicating, follow the on-screen instructions. After the replicate operation is complete, the secondary server is restarted.

Set up FactoryTalk View SE Clients

The FactoryTalk View SE Client provides a complete and secure run-time environment for a local application. For example, operators can use the client to:

- Load, view, and interact with graphic displays from any HMI server in the application.
- Monitor and control alarms (HMI tag alarms and FactoryTalk Alarms and Events).
- View and interact with trends.
- Adjust set points.
- Start and stop server components.

In a network distributed application, FactoryTalk View SE Clients, HMI servers, and data servers can run on multiple computers, connected over a network.

If you have already set up FactoryTalk View SE Client files for a network distributed application, you can copy the files to the production computers. Otherwise, you can create new client files.

Create a new FactoryTalk View SE Client file

FactoryTalk View SE Client configuration files specify the name of the application the client will connect to, the components that start when the connection is made, and how the client will behave at run time.

To create a new client file, use the FactoryTalk View SE Client Wizard. You can also use the wizard to modify or run an existing client file, or to remove a client from the list of available files.

**Tip:** It is not necessary to start the HMI server if you want to use the FactoryTalk View SE Client Wizard.

**To create a new FactoryTalk View SE Client file:**

1. On the desktop, click **Start > All Programs > Rockwell Software > FactoryTalk View**, and then click **FactoryTalk View Site Edition Client**.

2. In the FactoryTalk View SE Client Wizard, click **New**, and then follow the on-screen instructions. For details about options in the wizard, click **Help**.

   The client file is created with a .cli extension, in the location you specified.

Copy existing FactoryTalk View SE Client files

When setting up the FactoryTalk View SE Clients for a network distributed application, you can copy existing client files from the development computer to the client production computers.

You can run the client configuration from the desktop, or from any other location on the client computer.
By default, client configuration files are saved to these locations:

- \Users\Public\Public Documents\RSView Enterprise\SE\Client
- (Windows XP) \Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\Client

**Lock operators into the run-time environment**

To lock operators into the FactoryTalk View SE Client at run time, for example, to prevent access to other programs on the computer, try one or more of the following methods:

- **Limit the ability to manipulate graphic displays**, by removing the title bar or minimize and maximize buttons from selected displays. To do this, in the Display Settings dialog box, clear the check boxes **Title Bar, Minimize Button, and Maximize Button**. For details, see Chapter 16, Creating graphic displays in the *FactoryTalk View Site Edition User’s Guide*.

- **Limit the ability to manipulate the client window**, by removing the title bar or minimize and maximize buttons from the client. To do this, in the FactoryTalk View SE Client wizard, clear the check boxes **Show title bar, and Show system menu and close button**. For details, click **Help** in the FactoryTalk View SE Client wizard.

- **Prevent switching to other applications**. To do this, in the FactoryTalk View SE Client wizard, select the check box **Disable switch to other applications**. For details, click **Help** in the FactoryTalk View SE Client wizard.

- **Restrict access to the desktop**, using the DeskLock tool.

  To open Desklock, on the desktop click **Start > All Programs > Rockwell Software > FactoryTalk View > Tools**, and then click **DeskLock**. For details about using DeskLock, click **Help** within the tool.

  **Note:** Do not enable DeskLock until you read the help for the tool and understand how it works. Otherwise, you could end up locking yourself out of the desktop.

**Run the FactoryTalk View SE Clients**

Once the network distributed application is fully deployed, test it by running the FactoryTalk View SE Clients.
Note: To connect a FactoryTalk View SE Client to a network distributed application, all client and server computers in the application must point at the same FactoryTalk Network Directory server. For details, see Specify the Network Directory location on application computers on page 81.

For tips to help you get communications working between clients and servers, see the FactoryTalk View Site Edition Help.

To run an SE Client using the .cli file:

Double-click the client setup file (.cli), in the following default folders:

- \Users\Public\Public Documents\RSView Enterprise\SE\Client
- (Windows XP) \Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\Client

To run an SE Client from FactoryTalk View Studio:

1. In FactoryTalk View Studio, on the Tools menu, click Launch SE Client.

2. In the FactoryTalk View SE Client Wizard dialog box, select the client configuration file from the list of most recently used files and click Run. To search for and select another file, click the browse button.

To run an SE Client when Windows starts:

1. Create a shortcut to the .cli file (on the desktop, for example).

2. Move the shortcut to the Windows Startup folder.

For information about adding shortcuts to the Startup folder, see the Windows Help

Log on to the FactoryTalk View SE Client

To start the FactoryTalk View SE Client, or to change users while the client is running, the user logging on must have the necessary security permissions.
If the user does not have the necessary permissions, the FactoryTalk View SE Client login dialog box opens, to let another user log on.
Deploying network station applications

After you finish developing and testing a FactoryTalk View Site Edition network station application, you can deploy it to run in a live setting, such as the plant floor. Deploying a network station application involves installing all FactoryTalk View SE software components on the application’s host computer.

For details about installing the software, see Installing FactoryTalk View on page 41.

For details about the structure and content of network station applications, see Chapter 7, Working with network station applications in the FactoryTalk View Site Edition User’s Guide.

Overview of tasks

The checklist in this section summarizes the basic tasks involved in deploying a FactoryTalk View SE network station application. Use the checklist to guide you through the tasks you need to perform. Each task is described in detail in the rest of this chapter.

If appropriate, add or remove details to create a customized procedure that reflects the design and content of your FactoryTalk View application. For example, your application might include additional communications or database servers so you may need to repeat these steps accordingly.

Tip: If your application includes Tag Alarm and Event Servers, see the FactoryTalk Alarms and Events Help for information about deploying these servers.

Task checklist

- Move the network station application on page 80
- Specify the Network Directory location on application computers on page 81 if necessary
- Move the application’s data server files on page 81
- Specify data server host computer names on page 83
- Renew data server shortcuts, topics, and device paths on page 70
Move the network station application

There are two steps involved in moving a network station application: on the development computer, back up the application; then, on the production computer, restore the application archive.

You can perform both of these steps in the Application Manager tool. For details about options in the Application Manager, click Help in the tool.

Note: Before backing up an application, record the user names and passwords of administrative users set up for the application, in case you need this information after restoring the application.

To back up a network station application:

1. On the desktop, click Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click Application Manager.

2. In the Application Manager, select Site Edition (Network Station), and then click Next.

   Tip: To back up a network station application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

3. Select the back up operation, and then follow the instructions in the Application Manager to complete the operation.

4. Copy the .apa file to the new (production) computer.

If you are restoring a network station application on a computer that contains a copy of the original application, ensure the application is not running, then use the Application Manager to delete (or rename) the original application, before you begin the restore operation.

To restore a network station application:

1. On the production computer, on the desktop, click Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click Application Manager.

2. Select Site Edition (Network Station), and then click Next.
Tip: To restore a network station application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

3. Select the restore operation, and then follow the instructions in the Application Manager to complete the operation.

4. Copy the backed up application to the new (production) computer.

If you have not done so already, use the FactoryTalk Directory Server Location Utility to specify the location of the FactoryTalk Network Directory server.

Performing this task might require more than one set of FactoryTalk security credentials:

- To use the FactoryTalk Directory Server Location Utility, you must have administrative rights on the local computer.
- To specify a remote location for the Network Directory, you must have administrative rights on the remote computer.

To specify the Network Directory on application computers:

1. On the client or server computer, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.

2. Click the Browse button beside the field, Computer hosting directory server.


4. Type the name of the Network Directory server computer, or click the Browse button to find and select the computer, and then click OK.

You will have to log on as an administrator on the remote computer.

5. Click OK again, to close the FactoryTalk Directory Server Location Utility.

After specifying the FactoryTalk Network Directory location on application computers, ensure that the required communications software (RSLinx Enterprise, RSLinx Classic, or other OPC software) is installed on computers that will run data servers.

Then, if necessary for the data servers you are deploying, move configuration files to the production computers, and then specify the new host computer names.

Specify the Network Directory location on application computers

Move the application’s data server files
Tip: For information about moving setup files for OPC data servers other than RSLinx Classic, see the product documentation for the OPC server.

Back up and restore RSLinx Classic configurations

RSLinx Classic configuration files are not included when you back up an application. You have to back up, move, and restore the files manually.

If RSLinx Classic is installed on the development and production computers, you can use the RSLinx Classic Backup/Restore tool to back up and restore configuration files.

Tip: You can also restore RSLinx Classic configuration files from the Wizard Completed window of the RSLinx Classic software setup program.

To move RSLinx Classic configuration files:

1. On the development computer, click **Start** > **All Programs** > **Rockwell Software** > **RSLinx**, and then click **RSLinx Classic Backup Restore Utility**.

2. In the RSLinx Classic Backup/Restore tool, click **Backup**.

3. Select a folder for the backup file, type a file name, and then click **Save**.

4. In Windows Explorer, copy the backup file (with .rsx extension), and then paste it into a location on the data server production computer.

5. On the production computer, click **Start** > **All Programs** > **Rockwell Software** > **RSLinx**, and then click **RSLinx Classic Backup Restore Utility**.

6. In the RSLinx Backup/Restore tool, click **Restore**.

7. Find and select the backup file you just pasted, and then click **Open**.
Specify data server host computer names

After moving data server configuration files to production computers, open the restored network station application, and in the Properties dialog box for each data server, specify the name of the server’s host computer.

Then, renew RSLinx shortcuts, topics, and device paths, as needed. For details, see Renew data server shortcuts, topics, and device paths on page 70.

For information about setting up other data server properties, click Help in the server’s Properties dialog box, or see the product documentation.

**Tip:** The first time you open an application after relocating a data server, if the server does not load, you should still be able to open the Properties dialog box and change the host computer name. After the computer name is updated, the server should load as expected.

To change the RSLinx Enterprise server computer name

1. Click Start > All Programs > Rockwell Software, and then click FactoryTalk Administration Console.

2. In the Select FactoryTalk Directory dialog box, select Network, and then click OK.
3. In the Explorer window, expand the name of the restored application, right-click the RSLinx Enterprise server’s name, and then click **Properties**.

![RSLinx Enterprise Server Properties](image)

4. In the **General** tab, in the field, **Computer hosting the RSLinx Enterprise server**, type the name of the production computer, or click **Browse** to find and select the computer, and then click **OK**. Acknowledge the warning if needed by clicking **OK**.

**To change the RSLinx Classic server computer name**

1. Open the restored application in the FactoryTalk Administration Console. To learn how to do this, see the previous task.

2. In the Explorer window, expand the name of the restored application, right-click the RSLinx Classic server’s name, and then click **Properties**.

3. In the General tab, in the field, **Computer that will run the OPC server**, type the name of the production computer, or click **Browse** to find and select the computer, and then click **OK**.
Renew data server shortcuts, topics, and device paths

After restoring RSLinx data servers in the application, renew or verify the topics, shortcuts, and device paths associated with each data server, as needed.

If you are restoring redundant data servers, then the device paths must be confirmed and reapplied for both the primary and the secondary server.

To renew RSLinx Enterprise device paths

1. Open the restored application in the FactoryTalk Administration Console.
2. In the Explorer window, expand the data server (RSLinx Enterprise), and then double-click Communications Setup.
3. In the Communications Setup editor, select each configured RSLinx Enterprise shortcut, point the shortcut at the correct device, and then click Apply.
4. Save the configuration, and then close the Communications Setup editor.

To verify RSLinx Classic topics

1. On the data server computer, click Start > All Programs > Rockwell Software > RSLinx, and then click RSLinx Classic.
2. On the DDE/OPC menu, click Topic Configuration.
3. In the Topic List, select each configured topic and confirm that the corresponding data source updates correctly.
4. Click the Advanced Communication tab, confirm that there is a device path specified for Remote Addressing, and then click Done.

Specify when HMI server components start or stop

In FactoryTalk View Studio, open the Properties dialog box for the HMI server in the application, to view the location of the HMI project files, the current number of displays in the application, and the maximum number of displays allowed.

You can add a description for the HMI server and, in the Components tab, select components that will start when the HMI server starts running.

To open the HMI Server Properties dialog box:

1. Click Start > All Programs > Rockwell Software, and then click FactoryTalk View Studio.
2. Select View Site Edition (Network Station), and then click Continue.

3. Click the Existing tab, select the network station application’s name, and then click Open.

4. In the Explorer window, right-click the HMI server’s name, and then click Properties.

How HMI server components start and stop

Use the HMI Server Properties dialog box to specify which components in a local station application will start automatically, when the HMI server starts running.

In a network station or local station application, the HMI server loads and the specified components start running when the FactoryTalk View SE Client connects to the application. When the client stops running, the HMI server is unloaded, and the specified shutdown macro is run.

You can also start or stop the HMI server components manually. To do this, in the Components tab, click Run Startup Components and Stop All Running Components, respectively.

To select HMI server startup and shutdown components:

1. In the HMI Server Properties dialog box, click the Components tab.

2. To specify startup components, select the component check boxes, and then select the components you want to start automatically, when the HMI server starts running.

3. To specify a shutdown macro, select the check box On shutdown macro, and then select the macro you want to run when the HMI server stops running.

The FactoryTalk View SE Client provides a complete and secure run-time environment for a network station or local station application. For example, operators can use the client to:

- Load, view, and interact with multiple graphic displays from the HMI server.
- Manage alarm information.
- View trends.
- Adjust set points.
- Start and stop server components.

Set up the FactoryTalk View SE Client
To run a network station or local station application, the FactoryTalk View SE Client must run on the same computer as the HMI server.

If you have already set up a FactoryTalk View SE Client file for the application, you can copy the file to the production computer. Otherwise, you can create a new client file.

Create a new FactoryTalk View SE Client file

FactoryTalk View SE Client configuration files specify the name of the application the client will connect to, the components that start when the connection is made, and how the client will behave at run time.

To create a new client file, use the FactoryTalk View SE Client Wizard. You can also use the wizard to modify or run an existing client file, or to remove a client from the list of available files.

Tip: It is not necessary to start the HMI server if you want to use the FactoryTalk View SE Client Wizard.

To create a new FactoryTalk View SE Client file:

1. On the desktop, click Start > All Programs > Rockwell Software > FactoryTalk View, and then click FactoryTalk View Site Edition Client.

2. In the FactoryTalk View SE Client Wizard, click New, and then follow the on-screen instructions. For details about options in the wizard, click Help.

The client file is created with a .cli extension, in the location you specified.

Lock operators into the run-time environment

To lock operators into the FactoryTalk View SE Client at run time, for example, to prevent access to other programs on the computer, try one or more of the following methods:

- Limit the ability to manipulate graphic displays, by removing the title bar or minimize and maximize buttons from selected displays.

To do this, in the Display Settings dialog box, clear the check boxes Title Bar, Minimize Button, and Maximize Button. For details, see Chapter 16, Creating graphic displays in the FactoryTalk View Site Edition User’s Guide.
- **Limit the ability to manipulate the client window**, by removing the title bar or minimize and maximize buttons from the client.

  To do this, in the FactoryTalk View SE Client wizard, clear the check boxes, **Show title bar**, and **Show system menu and close button**. For details, click **Help** in the FactoryTalk View SE Client wizard.

- **Prevent switching to other applications**. To do this, in the FactoryTalk View SE Client wizard, select the check box, **Disable switch to other applications**. For details, click **Help** in the FactoryTalk View SE Client wizard.

- **Restrict access to the desktop**, using the DeskLock tool.

  To open Desklock, on the desktop click **Start > All Programs > Rockwell Software > FactoryTalk View > Tools**, and then click **DeskLock**.

  For details about using DeskLock, click **Help** within the tool.

  **Note:** Do not enable DeskLock until you read the help for the tool and understand how it works. Otherwise, you could end up locking yourself out of the desktop.

### Run the FactoryTalk View SE Client

Once the application is deployed, test it by running the FactoryTalk View SE Client.

**To run an SE Client using the .cli file:**

Double-click the client setup file (.cli), in the following default folders:

- `\Users\Public\Public Documents\RSView Enterprise\SE\Client`
- `(Windows XP) \Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\Client`

**To run an SE Client from FactoryTalk View Studio:**

1. In FactoryTalk View Studio, on the Tools menu, click **Launch SE Client**.

2. In the **FactoryTalk View SE Client Wizard** dialog box, select the client configuration file from the list of most recently used files and click **Run**. To search for and select another file, click the browse button.

**To run an SE Client when Windows starts:**

1. Create a shortcut to the .cli file (on the desktop, for example).

2. Move the shortcut to the Windows Startup folder.
For information about adding shortcuts to the Startup folder, see the Windows Help.

Log on to the FactoryTalk View SE Client

To start the FactoryTalk View SE Client, or to change users while the client is running, the user logging on must have the necessary security permissions.

If the user does not have the necessary permissions, the FactoryTalk View SE Client login dialog box opens, to let another user log on.

![FactoryTalk View SE Client login dialog box](image)

To make minor changes to an application after it is deployed, use either FactoryTalk View Studio or the FactoryTalk View SE Administration Console. The SE Administration Console contains the following subset of editors.

<table>
<thead>
<tr>
<th>To do this in the SE Administration Console</th>
<th>Use this editor</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the properties of an HMI server.</td>
<td>HMI Server Properties</td>
</tr>
<tr>
<td>Change the properties of a data server.</td>
<td>Data Server Properties</td>
</tr>
<tr>
<td>Add FactoryTalk users to an application.</td>
<td>Runtime Security</td>
</tr>
<tr>
<td>Set up security for commands and macros.</td>
<td>Secured Commands</td>
</tr>
<tr>
<td>Run FactoryTalk View commands.</td>
<td>Command Line</td>
</tr>
<tr>
<td>Change how HMI tag alarms are logged.</td>
<td>Alarm Setup</td>
</tr>
<tr>
<td>Change the paths of data log models.</td>
<td>Data Log Paths</td>
</tr>
<tr>
<td>Manage HMI tag alarm log files.</td>
<td>Alarm Log Setup</td>
</tr>
<tr>
<td>Import and export HMI tags.</td>
<td>Tag Import and Export Wizard</td>
</tr>
</tbody>
</table>

For details about options in these editors, click Help.

To open a network station application in FactoryTalk View Studio

1. Click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. Select View Site Edition (Network Station), and then click Continue.
3. In the Existing tab, select the restored application’s name, and then click Open.
Chapter 8

Deploying local station applications

After you finish developing and testing a FactoryTalk View Site Edition local station application, you can deploy it to run in a live setting, such as the plant floor. Deploying a local station application involves installing all FactoryTalk View SE software components on the application’s host computer.

For details about installing the software, see Installing FactoryTalk View on page 41.

For details about the structure and content of local station applications, see Chapter 8, Working with local station applications in the FactoryTalk View Site Edition User’s Guide.

Overview of tasks

The checklist in this section summarizes the basic tasks involved in deploying a FactoryTalk View SE local station application. Use the checklist to guide you through the tasks you need to perform. Each task is described in detail in the rest of this chapter.

If appropriate, add or remove details to create a customized procedure that reflects the design and content of your FactoryTalk View application. For example, your application might include additional communications or database servers.

Tip: If your application includes Tag Alarm and Event Servers, see the FactoryTalk Alarms and Events Help for information about deploying these servers.

Task checklist

- Move the local station application on page 92
- Move data servers and change their properties on page 93
- Specify OPC data server host computer names on page 95
- Specify when HMI server components start or stop on page 85
- Set up the FactoryTalk View SE Client on page 86
- Run the FactoryTalk View SE Client on page 88 to test the application
Move the local station application

There are two steps involved in moving a local station application: on the development computer, back up the application; then, on the production computer, restore the application archive.

You can perform both of these steps in the Application Manager tool. For details about options in the Application Manager, click Help in the tool.

**Note:** Before backing up an application, record the user names and passwords of administrative users set up for the application, in case you need this information after restoring the application.

**To back up a local station application:**

1. On the desktop, click **Start > All Programs > Rockwell Software > FactoryTalk View > Tools**, and then click **Application Manager**.

2. In the Application Manager, select **Site Edition (Local Station)**, and then click **Next**.

   **Tip:** The logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

3. Select the back up operation, and then follow the instructions in the Application Manager to complete the operation.

4. Copy the .apa file to the new (production) computer.

If you are restoring a local station application on a computer that contains a copy of the original application, restart the computer, then use the Application Manager to delete (or rename) the original application, before you begin the restore operation.

**To restore a local station application:**

1. On the production computer, on the desktop, click **Start > All Programs > Rockwell Software > FactoryTalk View > Tools**, and then click **Application Manager**.

2. Select **Site Edition (Local Station)**, and then click **Next**.

   **Tip:** To restore a local station application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

3. Select the restore operation, and then follow the instructions in the Application Manager to complete the operation.
About restoring System information with the application

In FactoryTalk View Studio, in a local station application, the top-level System folder contains FactoryTalk Security information, including user accounts set up for all applications using the same FactoryTalk Local Directory (also called the Local Directory).

When you back up a local station application, this FactoryTalk system information is saved to the archive automatically. When you restore a local station application, you can choose whether to restore the system information with the application.

To restore FactoryTalk system information with the application:

In the Application Manager tool, after specifying the archive to restore, select the option, Restore the FactoryTalk View SE (local station) application and FactoryTalk Local Directory.

To complete the operation, the user logged on to the Application Manager must have FactoryTalk administrative rights at the Local Directory being restored.

A FactoryTalk View SE local station application can contain one RSLinx Enterprise data server, which must be located on the same computer as the application.

In addition, the local station application can contain one or more OPC data servers (RSLinx Classic, or some other OPC server), which can be located on remote computers.

After ensuring that the required communications software is installed on production computers, for each remote OPC data server you are deploying, move the configuration files to the production computer and specify the new host computer name.

Tip: For information about moving setup files for OPC data servers other than RSLinx Classic, see the product documentation for the OPC server.

After installing RSLinx Enterprise, RSLinx Classic, or some other OPC server software on the production computer, if necessary, you can move the data server’s setup files to the computer.

Move data servers and change their properties

Back up and restore RSLinx Enterprise files

When you back up a FactoryTalk View SE local station application, the archive includes RSLinx Enterprise shortcut names, but does not include device path information.
After restoring the application, you must open the Communications Setup editor in FactoryTalk View Studio, and re-apply the device path for each configured shortcut.

For details, see To renew RSLinx Enterprise device paths on page 70.

**Back up and restore RSLinx Classic configurations**

RSLinx Classic configuration files are not included when you back up an application. You have to back up, move, and restore the files manually.

If RSLinx Classic is installed on the development and production computers, you can use the RSLinx Classic Backup/Restore tool to back up and restore configuration files.

**Tip:** You can also restore RSLinx Classic configuration files from the Wizard Completed window of the RSLinx Classic software setup program.

**To move RSLinx Classic configuration files:**

1. On the development computer, click Start > All Programs > Rockwell Software > RSLinx, and then click RSLinx Classic Backup/Restore Utility.

2. In the RSLinx Classic Backup/Restore tool, click **Backup**.

3. Select a folder for the backup file, type a file name, and then click **Save**.

4. In Windows Explorer, copy the backup file (with .rsx extension), and then paste it into a location on the data server production computer.

5. On the production computer, click Start > All Programs > Rockwell Software > RSLinx, and then click RSLinx Classic Backup/Restore Utility.

6. In the RSLinx Backup/Restore tool, click **Restore**.
7. Find and select the backup file you just pasted, and then click **Open**.

After moving RSLinx Classic configuration files to production computers, open the restored local station application, and in the Properties dialog box for each data server, specify the name of the server’s host computer.

**Tip:** Unlike RSLinx Classic data servers, you do not have to change the computer names of RSLinx Enterprise data servers. The RSLinx Enterprise data server in a local station application must be located on the same computer as the application, and is always named localhost.

For information about setting up other data server properties, click **Help** in the server’s Properties dialog box, or see the product documentation.

**Tip:** The first time you open an application after relocating a data server, if the server does not load, you should still be able to open the Properties dialog box and change the host computer name. After the computer name is updated, the server should load as expected.

### Specify OPC data server host computer names

#### To change the RSLinx Classic server computer name

1. Open the restored application in the FactoryTalk Administration Console. To learn how to do this, see the previous task.

2. In the Explorer window, expand the name of the restored application, right-click the RSLinx Classic server’s name, and then click **Properties**.

3. In the General tab, in the field, **Computer that will run the OPC server**, type the name of the production computer, or click **Browse** to find and select the computer, and then click **OK**.

In FactoryTalk View Studio, open the Properties dialog box for the HMI server in the application, to view the location of the HMI project files, the current number of displays in the application, and the maximum number of displays allowed.

You can add a description for the HMI server and, in the Components tab, select components that will start when the HMI server starts running.

#### Specify when HMI server components start or stop

**To open the HMI Server Properties dialog box:**

1. Click **Start > All Programs > Rockwell Software**, and then click **FactoryTalk View Studio**.
2. Select View Site Edition (Network Station), and then click Continue.

3. Click the Existing tab, select the network station application’s name, and then click Open.

4. In the Explorer window, right-click the HMI server’s name, and then click Properties.

To open the HMI Server Properties dialog box

1. Click Start > All Programs > Rockwell Software, and then click FactoryTalk View Studio.

2. Select View Site Edition (Network Station), and then click Continue.

3. Click the Existing tab, select the network station application’s name, and then click Open.

4. In the Explorer window, right-click the HMI server’s name, and then click Properties.

   Tip: In a local station application, the HMI server and the application have the same name. The name cannot be modified in the HMI server’s Properties dialog box.

How HMI server components start and stop

Use the HMI Server Properties dialog box to specify which components in a local station application will start automatically, when the HMI server starts running.

In a network station or local station application, the HMI server loads and the specified components start running when the FactoryTalk View SE Client connects to the application. When the client stops running, the HMI server is unloaded, and the specified shutdown macro is run.

You can also start or stop the HMI server components manually. To do this, in the Components tab, click Run Startup Components and Stop All Running Components, respectively.

To select HMI server startup and shutdown components:

1. In the HMI Server Properties dialog box, click the Components tab.
2. To specify startup components, select the component check boxes, and then select the components you want to start automatically, when the HMI server starts running.

3. To specify a shutdown macro, select the check box **On shutdown macro**, and then select the macro you want to run when the HMI server stops running.

The FactoryTalk View SE Client provides a complete and secure run-time environment for a network station or local station application. For example, operators can use the client to:

- Load, view, and interact with multiple graphic displays from the HMI server.
- Manage alarm information.
- View trends.
- Adjust set points.
- Start and stop server components.

To run a network station or local station application, the FactoryTalk View SE Client must run on the same computer as the HMI server.

If you have already set up a FactoryTalk View SE Client file for the application, you can copy the file to the production computer. Otherwise, you can create a new client file.

### Create a new FactoryTalk View SE Client file

FactoryTalk View SE Client configuration files specify the name of the application the client will connect to, the components that start when the connection is made, and how the client will behave at run time.

To create a new client file, use the FactoryTalk View SE Client Wizard. You can also use the wizard to modify or run an existing client file, or to remove a client from the list of available files.

**Tip:** It is not necessary to start the HMI server if you want to use the FactoryTalk View SE Client Wizard.

**To create a new FactoryTalk View SE Client file:**

1. On the desktop, click **Start > All Programs > Rockwell Software > FactoryTalk View**, and then click **FactoryTalk View Site Edition Client**.
2. In the FactoryTalk View SE Client Wizard, click **New**, and then follow the on-screen instructions. For details about options in the wizard, click **Help**.

   The client file is created with a .cli extension, in the location you specified.

**Lock operators into the run-time environment**

To lock operators into the FactoryTalk View SE Client at run time, for example, to prevent access to other programs on the computer, try one or more of the following methods:

- **Limit the ability to manipulate graphic displays**, by removing the title bar or minimize and maximize buttons from selected displays.

  To do this, in the Display Settings dialog box, clear the check boxes **Title Bar**, **Minimize Button**, and **Maximize Button**. For details, see Chapter 16, Creating graphic displays in the *FactoryTalk View Site Edition User’s Guide*.

- **Limit the ability to manipulate the client window**, by removing the title bar or minimize and maximize buttons from the client.

  To do this, in the FactoryTalk View SE Client wizard, clear the check boxes **Show title bar**, and **Show system menu and close button**. For details, click **Help** in the FactoryTalk View SE Client wizard.

- **Prevent switching to other applications**. To do this, in the FactoryTalk View SE Client wizard, select the check box, **Disable switch to other applications**. For details, click **Help** in the FactoryTalk View SE Client wizard.

- **Restrict access to the desktop**, using the DeskLock tool.

  To open Desklock, on the desktop click **Start > All Programs > Rockwell Software > FactoryTalk View > Tools**, and then click **DeskLock**.

  For details about using DeskLock, click **Help** within the tool.

**Note:** Do not enable DeskLock until you read the help for the tool and understand how it works. Otherwise, you could end up locking yourself out of the desktop.

**Run the FactoryTalk View SE Client**

Once the application is deployed, test it by running the FactoryTalk View SE Client.
To run an SE Client using the .cli file:

Double-click the client setup file (.cli), in the following default folders:

- \Users\Public\Public Documents\RSView Enterprise\SE\Client
- (Windows XP) \Documents and Settings\All Users\Shared Documents\RSView Enterprise\SE\Client

To run an SE Client from FactoryTalk View Studio:

1. In FactoryTalk View Studio, on the Tools menu, click **Launch SE Client**.

2. In the **FactoryTalk View SE Client Wizard** dialog box, select the client configuration file from the list of most recently used files and click **Run**. To search for and select another file, click the browse button.

To run an SE Client when Windows starts:

1. Create a shortcut to the .cli file (on the desktop, for example).

2. Move the shortcut to the Windows Startup folder.

For information about adding shortcuts to the Startup folder, see the Windows Help

**Log on to the FactoryTalk View SE Client**

To start the FactoryTalk View SE Client, or to change users while the client is running, the user logging on must have the necessary security permissions.

If the user does not have the necessary permissions, the FactoryTalk View SE Client login dialog box opens, to let another user log on.

To make minor changes to an application after it is deployed, use either FactoryTalk View Studio or the FactoryTalk View SE Administration Console. The SE Administration Console contains the following subset of editors.
To do this in the SE Administration Console | Use this editor
---|---
Change the properties of an HMI server. | HMI Server Properties
Change the properties of a data server. | Data Server Properties
Add FactoryTalk users to an application. | Runtime Security
Set up security for commands and macros. | Secured Commands
Run FactoryTalk View commands. | Command Line
Change how HMI tag alarms are logged. | Alarm Setup
Change the paths of data log models. | Data Log Paths
Manage HMI tag alarm log files. | Alarm Log Setup
Import and export HMI tags. | Tag Import and Export Wizard

For details about options in these editors, click Help.

To open a local station application in FactoryTalk View Studio

1. Click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.
2. Select View Site Edition (Local Station), and then click Continue.
3. In the Existing tab, select the restored application’s name, and then click Open.
Chapter 9

Upgrading an operating FactoryTalk View SE application

Upgrading the FactoryTalk View Site Edition software in an automation and control application involves two core tasks: uninstalling the existing software, then installing the new version.

After installing the new software version, you should be able to open a FactoryTalk View SE application in FactoryTalk View Studio, and then run the application in a FactoryTalk View SE Client without any further intervention.

Tip: Applications developed on versions 6.0 and earlier may need to be converted using the Legacy Tag Database Conversion Utility. Start the utility by clicking Start > Rockwell Software > FactoryTalk View > Tools > Legacy Tag Database Conversion Utility. For details about using the utility, click Help.

However, depending on the design, content, and complexity of your control system, you might have to perform additional tasks to support the upgrade, especially if you are upgrading FactoryTalk View SE in a production environment. The information in this chapter will help you safeguard the live application, while ensuring that the upgrade process is efficient and successful.

To illustrate an upgrade path that includes such supporting tasks, this chapter describes how to upgrade a deployed network distributed application that consists of the following computers.
Example: a FactoryTalk View SE network distributed application with redundant servers

In this example, Server #1 is the name of the primary server computer, Server #2 is the name of the secondary server computer, and Workstation #1 is the name of the engineering workstation.

As there are many possible variations for this type of application, parts of the documented process might not apply directly to the application you are upgrading.

If you have questions about architectural elements not covered in this chapter, for example, because your application is more or less complex than the example provided, contact your local Rockwell Automation Sales office for assistance.

**Note:** Before installing FactoryTalk View applications or any supporting software, review [Hardware, operating system, and domain information](#) on page 25, and ensure that you have performed the tasks that are appropriate to the role and configuration of each application host computer.

Information to help you upgrade

You can also look for answers in other Rockwell Automation product documentation, and on the Rockwell Automation Web site. See [Open the FactoryTalk View online manuals](#) on page 11.

Finding out about features in the new product version

After upgrading all the software components in your deployed application, to find out about features in the new product version, see the product Release Notes. Release Notes for FactoryTalk View SE, Machine Edition, RSLinx Enterprise, and RSLinx Classic are available from the FactoryTalk View installation DVD.
During installation, many of the dialog boxes include a *View release notes* link.

Release Notes for the FactoryTalk Services Platform (and other FactoryTalk products) are available from the Contents page in the FactoryTalk Help. Click **Start > All Programs > Rockwell Software > FactoryTalk Tools**, and then click **FactoryTalk Help**.

**Tip:** RSView Enterprise is the former name of the FactoryTalk View family of software products. If you are upgrading from a version of RSView, the information in this chapter still applies, even though it refers to FactoryTalk View as the previous product version.

---

**Overview:**

Upgrading a redundant network distributed application

Use the following multi-step checklist as a guideline for upgrading your redundant network distributed application. Details about each step are provided in this chapter.

**Tip:** If you are upgrading a non-redundant application, see the next section, Upgrading a non-redundant network application on page 104, which is a simplified overview.

---

**Part 1: Prepare for the upgrade**

- **Step 1 – Upgrade Preparation** on page 105
- **Step 2 – Back up the deployed application** on page 107

  **Note:** You need to backup RSLinx Classic configuration files using the RSLinx Classic Backup Restore Utility before you upgrade. Otherwise, the RSLinx Classic configuration files will be lost.

---

**Part 2: Set up a separate, partially upgraded system**

- **Step 3 – Set up a temporary upgrade system** on page 110
- **Step 4 – Upgrade software components on Server #2** on page 115
- **Step 5 – Upgrade software components on Workstation #1** on page 115
- **Step 6 – Migrate the FactoryTalk View SE application** on page 117
- **Step 7 – Upgrade software on selected run-time clients** on page 118
• **Step 8** – Test the migrated FactoryTalk View SE application on page 120

Part 3: Upgrade remaining computers and restore redundancy

• **Step 9** – Upgrade remaining client computers on page 121
• **Step 10** – Upgrade software components on Server #1 on page 122
• **Step 11** – Restore Server #1 as the primary application server on page 122
• **Step 12** – Set up redundancy for the upgraded system on page 126
• **Step 13** – Restart the entire upgraded application on page 129

About upgrading a non-redundant network application

If your deployed network distributed application is non-redundant, some of the supporting tasks documented in this chapter might be irrelevant or unnecessary.

For example, there would be no need to set up a temporary system, with the secondary server as the primary server, or to disable and then restore redundancy.

To upgrade a non-redundant network application, use the following steps as a guideline, keeping the noted exceptions in mind:

• **Prepare for the upgrade.** See **Step 1** – Upgrade Preparation on page 105. Ignore the subsection about ensuring that the most recent application files are on the primary server computer.

• **Back up the deployed application.** See **Step 2** – Back up the deployed application on page 107. Ignore the tip about ensuring that the most recent application files are on the primary server computer.

• **Upgrade the engineering workstation.** See **Step 5** – Upgrade software components on Workstation #1 on page 115. Ignore the last subsection, about specifying Server #2 as the Network Directory location.

• **Migrate the deployed application.** See **Step 6** – Migrate the FactoryTalk View SE application on page 117.

• **Upgrade the application server.** See **Step 10** – Upgrade software components on Server #1 on page 122. For the non-redundant case, assume that the application server computer hosts the FactoryTalk...
Part 1: Prepare for the upgrade

Step 1 – Upgrade Preparation

Before getting started with the upgrade:

- **Schedule down time for the upgrade** on page 105
- **Log on with administrative rights** on page 105
- **Record the names and passwords of administrative users** on page 106
- **Perform set-up tasks on application computers** on page 106
- **Ensure that the latest application files are on the primary server** on page 106
- **Have the FactoryTalk View Installation DVD on hand** on page 106

**Schedule down time for the upgrade**

During the upgrade process described in this chapter, the deployed FactoryTalk View SE application needs to be shut down twice:

- During step 3, the application is shut down so that Server #2 can be set up as the temporary primary server.
- During steps 9 to 11 (or 12), the application is shut down so that the remaining application computers can be upgraded, and so application servers can be restored to their original roles.

In your upgrade process, be sure to schedule down time, and notify affected personnel about times when the application needs to be shut down.

**Log on with administrative rights**

To perform certain tasks, the user performing the upgrade must have administrative rights in Windows and at the FactoryTalk Network Directory.

Windows administrative rights are required to install FactoryTalk View and supporting software because the Setup Wizard creates program folders and modifies registry entries.
Chapter 9  Upgrading an operating FactoryTalk View SE application

FactoryTalk administrative rights are required to log on to the FactoryTalk Network Directory, for example, when you use the FactoryTalk Directory Server Location Utility.

To open the utility, you must log on as a FactoryTalk administrator on the local computer. To specify a remote Network Directory location, you must also have administrative rights on the remote computer.

FactoryTalk administrative rights are also required to back up and restore FactoryTalk View SE applications.

**Record the names and passwords of administrative users**

Before backing up the deployed application, ensure that you have recorded the user names and passwords of users that belong to the FactoryTalk administrators group.

Only members of the FactoryTalk administrators group can add, remove, or modify FactoryTalk user accounts, if this is necessary after restoring a backed-up application.

**Perform set-up tasks on application computers**

Before upgrading FactoryTalk View SE, review [Hardware, operating system, and domain information](#) on page 25.

The chapter contains information about tasks you can perform on application computers, to ensure that FactoryTalk View SE runs smoothly after it is installed. It also contains information about hardware and software requirements, and application limits.

**Ensure that the latest application files are on the primary server**

During the upgrade described in this chapter, the application and HMI project files backed up on the primary server (Server #1) are restored on the secondary server (Server #2), and then migrated in FactoryTalk View Studio on the upgraded engineering workstation (Workstation #1).

To ensure that you migrate and re-deploy the most recent application, ensure that the application and HMI project files you back up initially, on the primary server, are the most recent application files.

**Have the FactoryTalk View Installation DVD on hand**

The FactoryTalk View Installation DVD provides setup programs for installing the FactoryTalk View SE software components, the FactoryTalk Services Platform, and RSLinx Enterprise.
Step 2 – Back up the deployed application

To ensure that the most recent application data is available for the upgrade, to back up the deployed application on Server #1, perform these tasks:

- **Back up the HMI project** on page 107
- **Back up the application** on page 107

**Tip:** In this upgrade example, the initial back-up operations are performed on Server #1, assuming that the most recent application files are on the primary server. However, to guarantee that the most recent files are saved, it is recommended that you also back up files on the secondary server computer.

### Back up the HMI project

On Server #1, use the HMI Server Backup and Restore utility to back up the primary server’s HMI project. Click **Start > All Programs > Rockwell Software > FactoryTalk View > Tools > HMI Server Backup and Restore**. For details about using the utility, click the **Help** button.

For the upgrade process described in this chapter, the HMI Server Backup and Restore utility needs to be installed on Server #1 and on Server #2.

**Note:** Special procedures may be required if you are upgrading to a 64-bit operating system. If the application was designed in version 6.0 or earlier, you must run the Legacy Tag Database Conversion Utility on a computer having a 32-bit operating system.

Start the utility by clicking **Start > Rockwell Software > FactoryTalk View > Tools > Legacy Tag Database Conversion Utility**. For details about using the utility, click the **Help** button.

### Back up the application

On Server #1, use the FactoryTalk Administration Console to back up the deployed FactoryTalk View SE network distributed application.

The back-up operation creates an application archive that includes area names, server names, server properties, and application languages.

If the back-up operation includes System information, user and computer accounts, as well as other FactoryTalk system-level settings, are also archived. For more information, see the next section, "About backing up System information with an application."
Other application files, such as HMI project files, product activation, and logged historical data (trends, alarms, and diagnostic messages) must be backed up and restored separately.

**Tip:** For information about backing up and restoring files that belong to FactoryTalk Tag Alarm and Event Servers, see the FactoryTalk Alarms and Events Help.

**About backing up System information with an application**

The following illustration shows what a FactoryTalk View SE network distributed application looks like, in the Explorer window in FactoryTalk View Studio.

![Illustration of FactoryTalk View SE network applying](image)

The FactoryTalk Network Directory is represented at the top of application hierarchy.

One level down, the System folder stores settings that are used by all the applications that belong to the same Network Directory.

For example, FactoryTalk user and computer accounts set up for each application are stored in the System folder.

When you back up a network application, System information for the application is not archived automatically.

To save the System information, for example, in order to preserve user and computer accounts, you must select the check box, **Backup System in archive**.

If you do back up System information with a network application, when you restore the application, you can choose whether to restore the archived System information. Keep in mind that the restored System information will
not merge with existing FactoryTalk System settings held at the current FactoryTalk Network Directory.

Instead, if the Network Directory on the local computer is active, you will replace user and computer accounts set up for any other application using the directory.

**Note:** Before backing up an application, record the user names and passwords of administrative users set up for the application, in case this information is required for the restore operation.

**To back up a network distributed application:**

1. On Server #1, click **Start > All Programs > Rockwell Software**, and then click **FactoryTalk Administration Console**.

2. In the Select FactoryTalk Directory dialog box, select **Network**, and then click **OK**.

3. In the Explorer window, right-click the application you want to back up, and then click **Backup**.

4. Specify an archive name and location.
   
   To specify a location other than the default, type the path or click the **Browse** button to find and select a location.

5. Select the check box, **Backup System in archive** and then click **OK**.

   The back-up operation saves an application archive file with a .bak extension to the specified location. The default locations are:

   - C:\Users\Public\Documents
   - (Windows XP) C:\Documents and Settings\All Users\Documents

During Part 2 of the upgrade, a temporary system is set up to test a partial upgrade that involves Server # 2 (the secondary server), Workstation #1, and selected run-time clients. For the test, Server #2 is set up to function as the primary server.
Step 3 – Set up a temporary upgrade system

To set up a temporary system so that you can test a partial upgrade, perform these tasks:

- **Shut down all client computers** on page 110
- **Disable HMI and data server redundancy** on page 111
- **Set up Server #2 as the temporary primary server** on page 111
- **Restart Server #1 and all client computers** on page 114

**Note:** For this part of the upgrade, the FactoryTalk View SE application is shut down until the temporary FactoryTalk Network Directory can be set up. In your upgrade process, be sure to schedule down time, and notify affected personnel about times when the application needs to be shut down.

**Shut down all client computers**

To disconnect client and server computers, shut down all run-time client computers and Workstation #1.

**To shut down a client computer:**

Stop all software programs running on the computer, and then shut down the computer.
Disable HMI and data server redundancy

To ensure that Server #2 can be detached from the application for upgrading, open the application in FactoryTalk View Studio, and disable redundancy for the HMI server and data server.

To disable HMI and data server redundancy:

1. On Server #2, click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. In the Application Type Selection dialog box, select View Site Edition (Network Distributed), and then click Continue.

3. In the New/Open Site Edition (Network Distributed) Application dialog box, select the deployed application, and then click Open.

4. Right-click the HMI server, and then click Properties.

5. In the Redundancy tab, clear the check box, Provide redundancy using a secondary server, and then click OK.

6. In the Explorer window, right-click the data server (RSLinx Enterprise), and then click Properties.

7. In the Redundancy tab, clear the check box, Provide redundancy using a secondary server, and then click OK.

Set up Server #2 as the temporary primary server

Several tasks are involved in setting up Server #2 as the temporary primary server and FactoryTalk Network Directory.

As part of the process, the original HMI project and application files that were backed up on Server #1 are restored on Server #2. The restored application will be migrated later, after Workstation #1 is upgraded.

Note: To avoid introducing incompatible software component versions into a deployed production system, be sure to restore the HMI project and application files before upgrading any software

- Copy backed-up files to Server #2 on page 112
- Specify Server #2 as the Network Directory location on page 116
- Restore the HMI project files on page 112
- Restore the application files on page 113
- Disable redundancy and make Server #2 the primary server on page 114
For details, see the procedures that follow.

**To copy backed-up files to Server #2**

1. On Server #2, open Windows Explorer, browse to where the backed-up HMI project and application files are saved on Server #1, and then copy the files.

2. Open another instance of Windows Explorer, and then paste the backed-up HMI project and application files into the same location on Server #2.

**To specify Server #2 as the Network Directory location**

1. On Server #2, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.

   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. **Server #1** should be displayed in the field, Computer hosting directory server. Click the Browse button.

3. In the FactoryTalk Directory Server Configuration dialog box, click This computer, and then click OK.

   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).

4. Click OK, and then restart Server #2.

**To restore the HMI project files**

1. On Server #2, open the HMI Server Backup and Restore utility. Click Start > All Programs > Rockwell Software > FactoryTalk View > Tools > HMI Backup and Restore. For details about using the utility, click the Help button.

2. To restore the HMI project files copied from Server #1, follow the instructions in the wizard.

You may need to run the Legacy Tag Database Conversion Utility if the application you are restoring was created in FactoryTalk View 6.0 or earlier. Start the utility by clicking Start > Rockwell Software > FactoryTalk View > Tools > Legacy Tag Database Conversion Utility. For details about using the utility, click the Help button.
To restore the application files

1. On Server #2, click Start > All Programs > Rockwell Software, and then click FactoryTalk Administration Console.

2. Select Network, and then click OK.

3. In the Explorer window, right-click Network (THIS COMPUTER), and then click Restore.

4. Type the path to the application archive’s location, or click the Browse button to find and select the archive, and then click Next.

   Tip: Application archive files have a .bak extension. The default location for application files is:
   - C:\Users\Public\Documents
   - (Windows XP) C:\Documents and Settings\All Users\Documents

5. In this upgrade example, because System information was included when the application was backed up, Application and System should be displayed in the field, Archive type.

   Select the check box, Restore System, and then click OK.

   Note: Restoring System information replaces user and computer accounts as well as RSLinx Enterprise device paths which were set up in the FactoryTalk Directory on the local computer.
To disable redundancy and make Server #2 the primary server

1. On Server #2, open the restored application in FactoryTalk View Studio.

To open the Administration Console, click Start > All Programs > Rockwell Software > FactoryTalk View > FactoryTalk View Studio.

2. After the application opens, right-click the HMI server, and then click Properties.

3. In the Redundancy tab, clear the check box, Provide redundancy using a secondary server, and then click Apply.

4. In the General tab, in the field, Computer hosting the server, type Server #2, and then click OK.

5. In the Explorer window, right-click the data server (RSLinx Enterprise), and then click Properties.

6. In the Redundancy tab, clear the check box, Provide redundancy using a secondary server, and then click Apply.

7. In the General tab, in the field Computer hosting the RSLinx Enterprise server, type Server #2, and then click OK.

Restart Server #1 and all client computers

To restart the deployed application, restart Server #1, wait for Server #1 to finish starting, and then restart application client computers (Workstation #1 and all run-time clients).

Tip: The deployed application will run without redundancy with Server #1 as the active server, until the software on all computers is upgraded. After the software is upgraded, Server #1 and Server #2 can be restored to their original roles as primary and secondary servers, and the upgraded application can be started.

To confirm that Server #1 has finished starting:

1. Click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Diagnostics Viewer.

2. In the FactoryTalk Diagnostics Viewer, check for the following Diagnostics message:

   The HMI Server <ApplicationName>//Server #1 is the active server.
Tip: To find a message faster in the Diagnostics Viewer, on the View menu, click Options. Then, in the Filter tab, create a Message filter with one or more keywords from the message.

Step 4 – Upgrade software components on Server #2

*Install FactoryTalk View SE*

1. Close all open Windows programs.
2. Place the FactoryTalk View Installation DVD in the computer’s DVD drive.
3. If the DVD does not start automatically, run D:\Setup.exe, where D: is the drive containing the DVD. Select Site Edition Server and click Next.

*Install any necessary product updates*

For instructions, see Installing product updates on page 132.

Step 5 – Upgrade software components on Workstation #1

To upgrade FactoryTalk View SE and supporting software on Workstation #1, perform these tasks:

- Shut down software running on Workstation #1 on page 115
- Set up Workstation #1 as the Network Directory location on page 116
- Install FactoryTalk View SE on page 115
- Install any necessary product updates on page 115
- Specify Server #2 as the Network Directory location on page 116

*Shut down software running on Workstation #1*

Shut down all software programs that are currently running on Workstation #1.
Set up Workstation #1 as the Network Directory location

To prepare to upgrade the software on Workstation #1, specify Workstation #1 as the Network Directory location.

To specify Workstation #1 as the Network Directory:

1. On Workstation #1, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.

   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. Server #1 should be displayed in the field, Computer hosting the directory server. Click the Browse button.

3. In the FactoryTalk Directory Server Configuration dialog box, click This computer, and then click OK.

   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).

4. Click OK, and then restart Workstation #1.

Install FactoryTalk View SE

1. Close all open Windows programs.

2. Place the FactoryTalk View Installation DVD in the computer’s DVD drive.

3. If the DVD does not start automatically, run D:\Setup.exe, where D: is the drive containing the DVD. Select Site Edition Server and click Next.

Install any necessary product updates

For instructions, see Installing product updates on page 132.

Specify Server #2 as the Network Directory location

After upgrading the software on the client computer, specify Server #2 as the Network Directory location.

1. On Workstation #1, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.
To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. *Localhost* should be displayed in the field, Computer hosting directory server. Click the **Browse** button.

3. In the FactoryTalk Directory Server Configuration dialog box, type **Server #2**, and then click **OK**.

   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).

4. Click **OK**, and then restart the client computer.

**Step 6 – Migrate the FactoryTalk View SE application**

To migrate the FactoryTalk View SE application that was restored on Server #2, perform these tasks:

- [Open the application in FactoryTalk View Studio](#) on page 117
- [Verify RSLinx Enterprise shortcuts](#) on page 118
- [Test the migrated application](#) on page 118

For details, see the procedures that follow.

**Open the application in FactoryTalk View Studio**

To migrate the application, open it in the new version of FactoryTalk View Studio installed on upgraded Workstation #1.

**To open the application:**

1. On Workstation #1, click **Start > All Programs > Rockwell Software > FactoryTalk View**, and then click **FactoryTalk View Studio**.

2. Click **View Site Edition (Network Distributed)**, and then click **Continue**.

3. In the **Existing** tab, click the application name, select an application language, and then click **Open**.

   Wait until the HMI server and all project components in the application are loaded, and then leave the application open in FactoryTalk View Studio.
Verify RSLinx Enterprise shortcuts

To confirm that data communications are set up correctly in the migrated application, verify that RSLinx Enterprise shortcuts point at the correct devices.

To check RSLinx Enterprise shortcuts:

1. In FactoryTalk View Studio, expand the data server (RSLinx Enterprise), and then double-click Communications Setup.

2. In the Communications Setup editor, select each configured RSLinx Enterprise shortcut, and ensure that it points at the correct device.

3. Save the configuration and close the Communications Setup editor.

Test the migrated application

To test the migrated application, run the application on Workstation #1.

To run the migrated application:

Start a FactoryTalk View SE Client configuration on Workstation #1, and ensure that data communications are functioning as expected.

Step 7 – Upgrade software on selected run-time clients

To upgrade FactoryTalk View SE and supporting software on selected run-time clients, perform these tasks on each client computer:

Tip: It is recommended that you upgrade the software on some application clients, confirm that the upgraded application is running as expected, and then upgrade the software on the remaining clients. The number of clients to upgrade initially is left to your discretion.

- Shut down software running on the client on page 118
- Set up the client as the Network Directory location on page 119
- Install FactoryTalk View SE on page 115
- Install any necessary product updates on page 115
- Specify Server #2 as the Network Directory location on page 116

Shut down software running on the client

Shut down all software programs that are currently running on the client computer.
**Set up the client as the Network Directory location**

To prepare to upgrade the software on the client computer, specify the client as the Network Directory location.

**To specify the client computer as the Network Directory:**

1. On the client computer, click **Start > All Programs > Rockwell Software > FactoryTalk Tools**, and then click **Specify FactoryTalk Directory Location**.

   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. **Server #1** should be displayed in the field, Computer hosting directory server. Click the **Browse** button.

3. In the FactoryTalk Directory Server Configuration dialog box, click **This computer**, and then click **OK**.

   To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).

4. Click **OK**, and then restart the client computer.

**Install FactoryTalk View SE**

1. Close all open Windows programs.

2. Place the FactoryTalk View Installation DVD in the computer’s DVD drive.

3. If the DVD does not start automatically, run **D:\Setup.exe**, where **D:** is the drive containing the DVD. Select **Site Edition Server** and click **Next**.

**Install any necessary product updates**

For instructions, see **Installing product updates** on page 132.

**Specify Server #2 as the Network Directory location**

After upgrading the software on the client computer, specify Server #2 as the Network Directory location.

1. On Workstation #1, click **Start > All Programs > Rockwell Software > FactoryTalk Tools**, and then click **Specify FactoryTalk Directory Location**.
To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. *Localhost* should be displayed in the field, Computer hosting directory server. Click the **Browse** button.

3. In the FactoryTalk Directory Server Configuration dialog box, type **Server #2**, and then click **OK**.

To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer (local or remote).

4. Click **OK**, and then restart the client computer.

**Step 8 – Test the migrated FactoryTalk View SE application**

To test the migrated application before upgrading remaining application computers, perform these tasks:

- **Start Server #2 and wait for it to finish starting** on page 120
- **Run the migrated application on upgraded clients** on page 121
- **Verify that the system is functioning as expected** on page 121

**Start Server #2 and wait for it to finish starting**

If Server #2 is not already started, start the server and wait for the server to finish starting.

To confirm that Server #2 has finished starting:

1. Click **Start > All Programs > Rockwell Software > FactoryTalk Tools**, and then click **Diagnostics Viewer**.

2. In the FactoryTalk Diagnostics Viewer, check for the following Diagnostics message:

   The HMI Server <ApplicationName>//Server #2 is the active server.

   **Tip:** To find a message faster in the Diagnostics Viewer, on the View menu, click **Options**. Then, in the Filter tab, create a **Message** filter with one or more keywords from the message.
Run the migrated application on upgraded clients

On each of the upgraded run-time client computers, run the existing FactoryTalk View SE Client configuration file (.cli).

Verify that the system is functioning as expected

After the application starts running on the upgraded client computers, verify that display navigation, object animation, communications, alarming (if configured), and other applications features are functioning as expected.

Part 3 of the upgrade, illustrated next, involves upgrading Server #1 and remaining run-time clients, and restoring Server #1 to its intended role as the primary application server.

Note: For steps 9 to 11 (or 12) of the upgrade, the FactoryTalk View SE application is shut down until the remaining application computers can be upgraded and restored to their original roles in the application.
In your upgrade process, be sure to schedule down time, and notify affected personnel about times when the application needs to be shut down.

Step 9 – Upgrade remaining client computers

After testing the partially upgraded system, to upgrade the FactoryTalk View SE software on remaining run-time clients, follow steps 1 through 7 in Step 7 – Upgrade software on selected run-time clients on page 118.
Step 10 – Upgrade software components on Server #1

To upgrade FactoryTalk View SE and supporting software on Server #1, perform these tasks.

- Install FactoryTalk View SE on page 115
- Install any necessary product updates on page 115

Install FactoryTalk View SE

1. Close all open Windows programs.

2. Place the FactoryTalk View Installation DVD in the computer’s DVD drive.

3. If the DVD does not start automatically, run D:\Setup.exe, where D: is the drive containing the DVD. Select Site Edition Server and click Next.

Install any necessary product updates

For instructions, see Installing product updates on page 132.

Step 11 – Restore Server #1 as the primary application server

To restore Server #1 as the FactoryTalk Network Directory and the primary server, perform these tasks:

- On Server #2, back up the migrated application on page 122
- Copy backed-up application files to Server #1 on page 123
- On Server #1, restore the HMI project and application on page 124
- Specify Server #1 as the primary HMI and data server on page 125
- Specify Server #1 as the Network Directory for clients on page 125
- Test run the application from all upgraded clients on page 126

On Server #2, back up the migrated application

To prepare to move migrated application data to Server #1, back up the migrated HMI project and application files on Server #2.

For more information about the backup and restore operations, see Step 2 – Back up the deployed application on page 107.
Note: Before backing up an application, record the user names and passwords of FactoryTalk users with administrative rights, in case this information is required for the restore operation.

To back up the HMI project:

On Server #2, use the HMI Server Backup and Restore utility to back up the primary server’s HMI project. Click Start > All Programs > Rockwell Software > FactoryTalk View > Tools > HMI Server Backup and Restore. For details about using the utility, click Help.

To back up the application:

1. On Server #2, click Start > All Programs > Rockwell Software, and then click FactoryTalk Administration Console.
2. Select Network, and then click OK.
3. In the Explorer window, right-click the application you want to back up, and then click Backup.

   **Tip:** To back up a network application, the logged on user must have FactoryTalk administrative rights. If you receive a prompt to log on, check with your System Administrator.

4. Specify an archive name and location.

   To specify a location other than the default, type the path or click the Browse button to find and select a location.

5. Select the check box, Backup System in archive, and then click OK.

   **Tip:** Application archive files have a .bak extension. The default location for application files is:
   - C:\Users\Public\Documents
   - (Windows XP) C:Documents and Settings\All Users\Documents

**Copy backed-up application files to Server #1**

After backing up the migrated application and HMI project files on Server #2, copy the files to the same location on Server #1. Follow the steps below:

1. On Server #1, open Windows Explorer, browse to where the backed-up HMI project and application files are saved on Server #2, and then copy the files.
2. Open another instance of Windows Explorer, and then paste the backed-up HMI project and application files into the same location on Server #1.

**On Server #1, restore the HMI project and application**

Before restoring Server #1 to its original role as the FactoryTalk Network Directory and primary server, restore the migrated HMI project and application files on Server #1.

**To restore the HMI project files:**

1. On Server #1, open the HMI Server Backup and Restore utility. Click Start > All Programs > Rockwell Software > FactoryTalk View > Tools > HMI Backup and Restore. For details about using the utility, click the Help button.

2. To restore the HMI project files copied from Server #2, follow the instructions in the wizard.

**To restore the application files:**

1. On Server #1, click Start > All Programs > Rockwell Software, and then click FactoryTalk Administration Console.

2. Select Network, and then click OK.

3. In the Explorer window, right-click Network (THIS COMPUTER), and then click Restore.

4. Type the path to the application archive’s location, or click the Browse button to find and select the archive, and then click Next.

**Tip:** Application archive files have a .bak extension. The default location for application files is:
- C:\Users\Public\Documents
- (Windows XP) C:\Documents and Settings\All Users\Documents

5. In this upgrade example, because System information was included when the application was backed up (see **On Server #2, back up the migrated application** on page 122), Application and System should be displayed in the field, Archive Type.

For this example, select the check box Restore System, and then click OK.
Tip: When restoring your application, keep in mind that if you select the check box Restore System, and there are applications using the FactoryTalk Network Directory on the computer, the restore operation will replace user and computer accounts in all applications.

Specify Server #1 as the primary HMI and data server

To restore Server #1 to its original role as the primary server, specify Server #1 as the computer hosting the HMI and the data server.

To set up Server #1 as the primary server:

1. Close the FactoryTalk Administration Console, and then open the restored application in FactoryTalk View Studio.
2. Right-click the HMI server, and then click Properties.
3. In the box, Computer hosting the server, type Server #1, and then click OK.
4. In the Explorer window, right-click the data server (RSLinx Enterprise), and then click Properties.
5. In the field, Computer hosting the RSLinx Enterprise server, type Server #1, and then click OK.

Specify Server #1 as the Network Directory for clients

To restore Server #1 to its original role as the FactoryTalk Network Directory server, on run-time client computers and on Workstation #1, specify Server #1 as the Network Directory location.

To specify Server #1 as the Network Directory:

1. On the client computer, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.
   
   To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. Click the Browse button beside the field, Computer hosting directory server.


4. Type Server #1, and then click OK.
To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer. In this case, the new location is remote.

5. Click OK, and then restart the client computer.

6. Repeat steps 1 to 5 on all application run-time clients and on Workstation #1.

**Test run the application from all upgraded clients**

To ensure that Server #1 and the upgraded run-time clients are functioning as expected, run the existing FactoryTalk View SE Client configuration file on each client computer.

**Step 12 – Set up redundancy for the upgraded system**

To restore redundancy for application servers, perform these tasks:

- Specify Server #1 as the Network Directory for Server #2 on page 126
- Shut down all client computers on page 110
- Set up HMI server redundancy on page 127
- Set up data server redundancy on page 128
- Replicate primary server files to the secondary server on page 128

**Specify Server #1 as the Network Directory for Server #2**

Now that Server #1 is restored as the FactoryTalk Network Directory, set up Server #2 to point at that directory server location.

**To specify Server #1 as the Network Directory:**

1. On Server #2, click Start > All Programs > Rockwell Software > FactoryTalk Tools, and then click Specify FactoryTalk Directory Location.

To use the FactoryTalk Directory Server Location Utility, you have to log on as an administrator on the local computer.

2. Localhost should be displayed in the field, Computer hosting directory server. Click the Browse button.

4. Type Server #1, and then click OK.

To change the Network Directory location, you have to log on as an administrator on the new Network Directory computer. In this case, the new location is remote.

5. Click OK again, and then restart Server #2.

**Shut down all client computers**

To disconnect client and server computers, shut down all run-time client computers and Workstation #1.

To shut down a client computer:

Stop all software programs running on the computer, and then shut down the computer.

**Set up HMI server redundancy**

To restore Server #2 to its original role as the secondary HMI server, set up HMI server redundancy for Server #1.

To set up redundancy for the HMI server:

1. On Server #1, in FactoryTalk View Studio, open the restored, migrated application.

2. In the Explorer window, right-click the HMI server, and then click Properties.

3. In the General tab, ensure that the option, Load and run startup components when operating system initializes, is selected.

   **Tip:** Servers set up to start On demand cannot be made redundant.

4. Ensure that Server #1 is displayed in the field, Computer hosting the server.

5. In the Redundancy tab, select the check box, Provide redundancy using a secondary server.

6. In the field, Computer hosting the server, type Server #2.

7. Select a switchover option for the redundant HMI server pair, and then click OK.
Set up data server redundancy

To restore Server #2 to its original role as the secondary data server, set up data server redundancy for Server #1.

To set up redundancy for the data server:

1. On Server #1, in the FactoryTalk View SE Administration Console, right-click the data server (RSLinx Enterprise), and then click Properties.
2. In the General tab, ensure that Server #1 is displayed in the field, Computer hosting the RSLinx Enterprise server.
3. In the Redundancy tab, select the check box, Provide redundancy using a secondary server.
4. In the field, Computer running secondary server, type Server #2.
5. Select a switchover option for the redundant data server pair, and then click OK.

Replicate primary server files to the secondary server

Before restarting the entire application, synchronize server settings and content on Server #1 and Server #2, by replicating files from the primary to the secondary server.

The replicate operation copies the primary server’s configuration files, including settings in the Components tab, to the secondary server.

For example, if an On Active and a Shutdown macro are selected for the primary server, the settings will be replicated to the secondary. This means that the same macros specified for the primary server will run when the secondary server becomes active or shuts down.

Information that is not included in the replicate operation includes datalog files generated at run time, the current value of HMI memory tags, retentive tags, and the HMI tag alarm suppressed list.

For replication to succeed, the primary server must remain active and the secondary server must remain on standby, for the duration of the replicate operation.

To confirm the status of the primary and secondary servers:

On Server #1, in FactoryTalk View Studio, right-click the HMI server, and then click Server Status. In the Server Status dialog box:
The computer name and status of the primary server are displayed in the fields, Primary server and Primary status, respectively.

The computer name and status of the secondary server are displayed in the fields, Secondary server and Secondary status, respectively.

To replicate primary server files to the secondary:

1. On Server #1, in FactoryTalk View Studio, right-click the HMI server, and then click **Properties**.

2. In the Redundancy tab, click **Replicate Primary to Secondary**.

   **Tip:** The Replicate Primary to Secondary button is available only if the primary server is active when the Redundancy tab is selected.

Follow the instructions on screen. After the replicate operation is complete, the secondary server is restarted automatically.

**Step 13 – Restart the entire upgraded application**

The final step in the upgrade process is to restart the entire system. Perform these tasks:

- Start Server #1 and Server #2 on page 129
- Start all run-time clients on page 130

**Start Server #1 and Server #2**

To prepare to restart the entire system, first restart Server #1, and then start Server #2.

Wait for both servers to finish starting, and also confirm that they are functioning in their primary and secondary roles.

**To confirm that Servers #1 and #2 have finished starting:**

1. Click **Start > All Programs > Rockwell Software > FactoryTalk Tools**, and then click **Diagnostics Viewer**.

2. In the FactoryTalk Diagnostics Viewer, check for the following Diagnostics messages:

   The HMI Server <ApplicationName>//Server #1 is the active server.
   In service, the server RNA://$Global/<ApplicationName>:
<HMIServerName> on computer Server #2 (secondary) is now on standby.

Tip: To find a message faster in the Diagnostics Viewer, on the View menu, click Options. Then, in the Filter tab, create a Message filter with one or more keywords from the message.

**Start all run-time clients**

To ensure that the entire, upgraded application is functioning as expected, run the existing FactoryTalk View SE Client configuration file on each run-time client computer.
Common upgrade procedures

This section contains notes, common procedures and information from the Rockwell Automation Knowledgebase that you may find helpful during installation of FactoryTalk View products.

Procedures in this section are:

- [Recreate SQL Server 2008 R2 Express instance](#) on page 131.
- [Installing product updates](#) on page 132.

**Recreate SQL Server 2008 R2 Express instance**

SQL Server 2008 R2 Express instance *FTVIEWx64TagDB* is created to store all the FactoryTalk View SE Tags and HMI Alarms data, which HMI Server and View Studio will access. You need to recreate SQL Server 2008 R2 Express instance *FTVIEWx64TagDB* manually under the following cases:

- For some reason you need to uninstall SQL Server 2008 R2 Express instance *FTVIEWx64TagDB* and reinstall it.
- On a computer that has had only the FactoryTalk View SE Client installed previously.

A message shows up asking the user to recreate the SQL server instance if user has not done so.

**Tip:** If you are installing FactoryTalk View with an existing SQL server, see Rockwell Automation Knowledgebase Answer ID 463910


To recreate SQL Server 2008 R2 Express instance:

1. If necessary, close all open Windows programs, and then place the FactoryTalk View Site Edition DVD in the computer’s DVD drive.

2. Locate and run

   `D:\Redist\SQLServerEXPR_2008R2SP2\SQLServerInstall.exe`

   where `D:` is the drive containing the DVD.
Tip: Windows Installer 4.5 and .NET Framework 3.5 SP1 are required for this procedure.

3. Input and confirm a password for the SA account in the SQL Server Install window, and then click **OK**. Click **Guidelines** for quick reference of SQL SA User Strong Password Guidelines or see page 42.

4. To finish installing the software, follow the instructions in the wizard.

### Installing product updates

After installing FactoryTalk View SE, you should locate and install patches for the software products on your system. To locate patches, search the Rockwell Automation Knowledgebase for **Patch TOCs** (Tables of Contents). The TOCs contain lists of all available patches for your software. Go to [http://rockwellautomation.custhelp.com](http://rockwellautomation.custhelp.com) and select the **Search Knowledgebase** tab.

A Patch TOC describes updates released for a particular product and version, and provides instructions for downloading and installing the updates on computers where the software is installed.

**To find Patch TOCs in the Rockwell Automation Knowledgebase:**

1. In your Web browser address bar, type [www.rockwellautomation.custhelp.com](http://www.rockwellautomation.custhelp.com), then press **Enter**.

2. On the Rockwell Automation Support Center page, click the down arrow on the Search Knowledgebase tab. Select **By Product**.
3. Scroll down to **Software** and click on **FactoryTalk View SE**. In the Search box, type Patch TOC and click **Search**.

In the search results, look for Patch TOCs related to all the products you installed from the FactoryTalk View Site Edition DVD. If necessary, conduct additional searches for other newly-installed applications, including:

- SE Client
- SE Server
- SE Station
- Studio Enterprise
- FactoryTalk Services Platform
- FactoryTalk Alarms and Events
- RSLinx Enterprise
- RSLinx Classic
To run the following tool, select Start > All Programs > Rockwell Software > FactoryTalk View > Uninstall FactoryTalk View.

- **Uninstall FactoryTalk View** is a utility for uninstalling FactoryTalk View components that are already installed on your computer. It does not uninstall components, like RSLinx Classic and FactoryTalk Activation Manager, that are shared with other products. You need to manually uninstall them in Control Panel.

  You can also choose to remove all FactoryTalk View application files, for example, archives and HMI project files.

To run the following set of tools, select Start > All Programs > Rockwell Software > FactoryTalk View > Tools, and then click the tool you want to run.

- **Alarm Migration** is software to migrate traditional HMI alarms to FactoryTalk Alarms and Events tag-based alarms.

- **Application Documenter** is a stand-alone utility that provides detailed information on FactoryTalk View SE and ME applications. This utility is a browser that allows you to view the contents of the application’s components and the tags used in these components. You can also print and export the information.

- **Application Manager** is software for renaming, copying, deleting, backing up, and restoring FactoryTalk View SE Station and FactoryTalk View ME applications.

  For FactoryTalk View SE network applications, use the Application Manager to rename and delete an application only.

- **DeskLock** is software that prevents users of FactoryTalk View SE Client and FactoryTalk View ME from gaining access to the Windows desktop and system keys.

- **Distributed Application Manager** is software to back up or restore network distributed applications within a single tool at a time.

- **FactoryTalk View File Viewer** is software to view and save log files like SE datalog files, ME datalog files, ME alarm log files, dBASE file, and ME RecipePlus files.

- **FactoryTalk View SE Cache Management Tool** is software to manage the temporary files of HMI Server components.
- **FactoryTalk View SE Secure Web Site Setup** is software for setting up secure access to application components under IIS (Internet Information Services).

- **FTVIEWUSER Account Reset** is software for resetting the FTVIEWUSER SQL account back to its default.

- **HMI Server Backup and Restore** is a utility for backing up FactoryTalk View SE HMI servers while they are running. Use this utility when backing up or restoring a stand-alone system, or when deploying a distributed system from one set of computers to another.

- **Legacy Tag Database Conversion Utility** is software for converting your legacy tag database (before View 6.0) to a new format to work with Microsoft SQL database.

- **SE HMI Tag Alarm Log Setup** is software for setting up HMI tag alarm logging.

- **SE HMI Tag Alarm Log Viewer** is software for viewing the contents of HMI tag alarm log files.

- **SE Service Manager** is a tool that allows you to stop or start the FactoryTalk View HMI Service manually on the computer.

- **Tag Import and Export Wizard** is software for importing or exporting the FactoryTalk View SE Server’s tag database.

**FactoryTalk tools**

To run the following set of tools, select **Start > All Programs > Rockwell Software > FactoryTalk Tools**, and then click the tool you want to run.

- **Diagnostics Counter Monitor** is software to check the status of tags and to monitor the runtime values of counters and strings that are made available by network clients for diagnostic purposes.

- **Diagnostics Viewer** is software for viewing the contents of FactoryTalk Diagnostics logs, to help with troubleshooting the system.

- **FactoryTalk Directory Configuration Wizard** is software for setting up the FactoryTalk Network Directory or Local Directory on the computer.

- **Import RSSecurity Configuration** is software for importing RSSecurity setup information to FactoryTalk Security.

- **Log On to FactoryTalk** is software for logging users on and off the FactoryTalk Directory.

- **Rockwell Software Data Client** is diagnostic software for testing client and server data connections in an application.

- **RSSecurity Emulator Install** is software for installing the RSSecurity Emulator, which emulates an RSSecurity Server for legacy products.

- **Specify FactoryTalk Directory Location** is software for specifying which computer on the network contains the FactoryTalk Network Directory service.
- **Windows Firewall Configuration Utility** is software for configuring firewall settings for FactoryTalk View.
Install Microsoft Internet Information Services


You must install IIS for FactoryTalk View SE network applications:

- on all computers that will run FactoryTalk View SE Servers (also called HMI servers).
- on engineering workstations that will run all the FactoryTalk View SE software components.

You do not have to install IIS if you plan to develop and run only FactoryTalk View SE local applications.

If necessary, you can install IIS from your Microsoft Windows operating system DVD.

1. Open Windows Control Panel, and click Programs.

2. Under Programs and Features, click Turn Windows features on or off. The Windows Features dialog box will open.

3. Click the checkbox to the left of Internet Information Services to enable settings.

4. Expand the Web Management Tools folders, and then expand the IIS 6 Management Compatibility folder.

5. Select the IIS Metabase and IIS 6 configuration compatibility check box.

6. Expand the World Wide Web Services folder and then expand the Application Development Features folder.

7. Select the ASP check box. The ISAPI Extensions check box should then be selected automatically.

8. Under the World Wide Web Services folder, expand the Common HTTP Features folder.
9. Select the **WebDAV Publishing** checkbox.

10. Under **World Wide Web Services** folder, expand the **Security** folder.

11. Select the **Windows Authentication** and **URL Authorization** check boxes.

   **Tip:** If IIS is installed correctly, you should be able to open the HMI server status page on localhost first, then from another computer. To test this, open Internet Explorer, in the address field, type `http://localhost/rsviewse`, or `http://computername/rsviewse` then the Enter key.

---

**To install IIS on Windows Server 2008 or Windows Server 2012**

The steps vary slightly. Follow the on-screen instructions that apply to the operating systems you are using.

1. Select **Start > Administrative Tools > Server Manager**.

2. (Windows Server 2008) In the **Server Manager** window, under Roles Summary, click **Add Roles**.

   (Windows Server 2012) In the **Server Manager Dashboard** window, click **Add roles and features**.

3. Use the Add Roles Wizard (or Add Roles and Features Wizard) to add the **Web Server (IIS)** role.

4. To install the Web Server, some additional Windows features might need to be installed. In each case, click **Add Required Features**.

5. In the Add Role Services (or Add Server Roles) page, expand **Common HTTP Features**, and then select **WebDAV Publishing**.

   **Tip:** If you are running on Windows Server 2008 Standard Edition with Service Pack 2, the steps to install WebDAV are different. See [Installing WebDAV on Windows Server 2008 Standard Edition with Service Pack 2](#) on page 142.

6. Click to expand **Security**, and then select the **Windows Authentication** and **URL Authorization** check boxes.

7. Click to expand **Application Development**, and then select **ASP**.

8. When prompted to install ISAPI Extensions, click **Add Required Role Services**.
The following example shows the installation for Windows Server 2008.

9. Click to expand **Management Tools** and then expand **IIS 6 Management Compatibility**.

10. Under IIS 6 Management Compatibility, select **IIS 6 Metabase Compatibility**.

The following example shows the installation for Windows Server 2008.
11. Click Next, and then accept the default selections at each remaining step of the wizard by clicking Next until all of the steps are complete.

12. At the end of the wizard, click Install to install the Web Server role.

13. After you have installed the Web Server role, install WebDAV, as described in the next section.

Install WebDAV on Windows Server 2008 Standard Edition with Service Pack 2

WebDAV allows remote clients to connect to HMI servers located on a computer running Windows Server 2008 Standard Edition with Service Pack 2.

With Windows Server 2008 Standard Edition with Service Pack 2, Microsoft no longer automatically distributes the IETF WebDAV extensions to HTTP (as defined in RFC 2518). For Windows Server 2008 Standard Edition with Service Pack 2, download and then install these extensions from Microsoft at:

Microsoft WebDAV Extension for IIS 7.0 (x86 or x64)

http://www.iis.net/download/webDAV

Tip: If IIS is installed correctly, you should be able to open the HMI server status page. To test this, on the desktop click Start, click Run, type http://localhost/rsviewse, and then press Enter.
Use unattended installation

The unattended installation is an automated installation method that you can use to install FactoryTalk View. You can typically use the unattended installation during large-scale rollouts when it might be too slow and costly to have administrators or technicians interactively install the FactoryTalk View software on individual computers.

In the unattended installation, you enter a specified command line with multiple parameters. During the installation process, instead of prompting you for installation and configuration information interactively, the process follows the parameters you specified in the command lines.

Before installation, keep in mind:

- If you are using Windows XP, you need to install IIS manually. For detailed instructions, see Install Microsoft Internet Information Services on page 139.
- If you are using Windows Server 2008 SP2, you need to install WebDAV manually. For detailed instructions, see Installing WebDAV on Windows Server 2008 Standard Edition with Service Pack 2 on page 142.
- If you use RSNetWorx on your computer, RSNetWorx v10.00 or later is required. We recommend that you upgrade it to v21.00 or later.

Perform unattended installation

1. Close all open Windows programs.
2. Open the Command Prompt window:
   - (Windows Server 2012, Windows 8.1, and Windows 8) Press the Windows button+R. In the Open text box, input cmd and click OK.
   - (The other supported operating systems) From the Windows Start menu, select All Programs > Accessories > Command Prompt.
3. In the Command Prompt window, navigate to D:\, where D:\ is the drive containing the FTView installation DVD.
In this example, type D: and press Enter.

4. Type a command line with the following syntax:

```
Setup /Q
    /AcceptAllLicenseItems
    /Product=product_name
    [/AdobeReader]
    [/UserName=user_name]
    [/Organization=organization_name]
    [/SqlSaPwd=sql_server_password]
    [/SerialNumber=serial_number]
    [/ProductKey=product_key]
    [/AutoRestart]
```

After you press Enter, the installation process starts with the parameters you specified.

For detailed description about each parameter, see Parameters on page 144. You can also type Setup /? in the Command Prompt window, and press Enter to view the help information of all parameters and examples.

**Tip:** The User Account Control dialog box may show after you press Enter, click Yes to continue. The unattended installation requires the administrator permission.

### Parameters

The parameters and values are not case sensitive. If the value includes spaces, you need to enclose it in quotation marks (" ").

If your installation package is Personalized Edition, the following parameters will be ignored during installation:

- /UserName
- /Organization
- /SerialNumber
- /ProductKey

/\Q

(Required) Specifies whether to use the unattended installation.

If omitted, the other parameters will not take effect and the installation will start with Setup Wizard.

/\AcceptAllLicenseItems
Use unattended installation

Appendix D

(Required) Specifies that you read and acknowledge all license agreements, and agree to continue the unattended installation.

If omitted, you cannot continue the installation.

/Product=product_name

(Required) Specifies which product will be installed. The value must be quoted by quotation marks (" "), for example, /Product="Studio Enterprise".

The product name must be the one of following:

- Studio Enterprise
- Site Edition Server
- Site Edition Client
- Site Edition Station
- Stand-alone RSLinx Enterprise Server
- Stand-alone FactoryTalk Directory Server

/AdobeReader

(Optional) Specifies whether to install Adobe Reader.

If omitted, Adobe Reader will not be installed.

/UserName=user_name

(Optional) Specifies the user name.

/Organization=organization_name

(Optional) Specifies the organization name.

/SQLSAPWD=sql_server_password

(Optional) Specifies the password for the Microsoft SQL Server SA (System Administrator) account. The value must meet strong password policy requirements.

The parameter is required when you are installing one of the following products:
Appendix D  Use unattended installation

- Studio Enterprise
- Site Edition Server
- Site Edition Station

/SerialNumber=serial_number

(Optional) Specifies the product serial number.

If you want to get activation keys during installation, the parameter is required.

/ProductKey=product_key

(Optional) Specifies the product key.

If you want to get activation keys during installation, the parameter is required.

/AutoRestart

(Optional) Specifies whether to restart the computer automatically after the installation.

If it is specified, the computer will be restarted automatically after the installation.

If it is not specified, you will be prompted to restart the computer after the installation.

You can find the installation logs and check the installation status in the following directory:

- (32-bit operating systems) C:\Program Files\Common Files\Rockwell\Install Logs
- (64-bit operating systems) C:\Program Files (x86)\Common Files\Rockwell\Install Logs

Examples

The following examples show how to use the commands during the unattended installation.

Example 1

Setup /Q /AcceptAllLicenseItems /Product="Studio Enterprise" /AdobeReader /SqlSaPwd=myPassword@123 /SerialNumber=0123456789 /ProductKey=ABCDE-FGHIJ

means:
- FactoryTalk View Studio Enterprise will be installed.
- Adobe Reader will be installed.
- Microsoft SQL Server will be installed and the system administrator password will be *myPassword@123*.
- The setup will get activation keys during installation if the serial number 0123456789 and product key *ABCDE-FGHIJ* are valid.

**Example 2**

```
Setup /Q /AcceptAllLicenseItems /Product="Site Edition Client" /AutoRestart
```

means:

- FactoryTalk View Site Edition Client will be installed.
- The computer will be restarted automatically after the installation.
A

about
activation keys 61
Application Documenter 135
Application Manager 135
DeskLock 135
Diagnostics Viewer 136
FactoryTalk Activation 59
FactoryTalk Directory Configuration Wizard 136
FactoryTalk Services Platform 21
FactoryTalk View SE Cache Management Tool 135
FactoryTalk View SE Client 19
FactoryTalk View SE Secure Web Site Setup 135
FactoryTalk View SE Server 19, 20, 135
FactoryTalk View Studio 18
HMI servers 19, 20, 86
Import RSSecurity Configuration 136
Log On to FactoryTalk 136
Rockwell Software Data Client 136
RSSecurity Emulator Install 136
SE HMI Tag Alarm Log Setup 135
SE HMI Tag Alarm Log Viewer 135
SE Service Manager 135
Specify FactoryTalk Directory Location 136
Tag Import and Export Wizard 135
tools and utilities 136
unattended installation 41, 143
Uninstall FactoryTalk View 135
Windows Firewall Configuration Utility 136
activating 59
about keys 61
borrowed activation files 61
floating activation files 60, 63
grace period 59
read-write keys 63
sharing keys 62
troubleshooting 59, 61
view-only keys 63
activation files
floating 60, 63
read-write 63
troubleshooting 59, 61
upgrading to enable borrowing 61
view-only 63
activation keys 61
sharing 62
administrator rights
required for backing up and restoring 67, 122
required for upgrading 105
alarms and events
hardware requirements 26
Application Documenter 135
Application Manager 135
Application Documenter 80, 92
application servers
operating system requirements 27
applications
backing up 66
deploying local 79, 91
deploying network 65
hosting on Windows Vista 26, 36, 112, 142
redundancy 125, 126
restoring 80, 92
restoring local 80, 92
restoring network 67
run-time clients 74, 86
testing 120
troubleshooting 30, 45
upgrading 125, 126, 128
upgrading run-time clients 118, 121
archive files
names and extensions 122
auto-negotiation
of NIC for unmanaged switches 31, 33

B

backing up and restoring
archive files 122
data servers 81, 93
naming computers 83, 95
renewing shortcuts, topics, and device paths 70, 118
RSLinx Classic Backup Restore Utility 69
RSLinx Enterprise 67, 69, 93
servers 111, 114, 115, 122, 124
System folder 66, 67, 93, 124
troubleshooting 76
upgrading 107

C
checklists
deploying local applications 79, 91
deploying network applications 65
setting up application computers 31
clients
copying files 75
logging off 77
logging on 77
run-time 74, 86
shutting down for upgrade 110
starting at run-time 76, 88
troubleshooting 76
upgrading 118, 121
using floating activations 63
clocks
synchronizing time 29
compatibility
Windows 29, 32
components
choosing which ones to install 42
computer names 30
data servers 83, 95
troubleshooting 30, 45
computers
naming 30, 83, 95
synchronizing time 29
troubleshooting naming 30, 45, 46

data servers
backing up and restoring RSLogix Classic 69
installing 131
moving files 81, 93
redundancy 125, 126
renewing shortcuts, topics, and device paths 70, 118
RSLogix Enterprise 69, 93
troubleshooting loading 95
DCOM protocols
removing unnecessary 40
deploying local applications 79, 91
backing up 80, 92
backing up the Local Directory 93
creating new client files 75
moving RSLogix Classic files 69
moving RSLogix Enterprise files 93
restoring 80, 92
restoring the Local Directory 93
starting or stopping HMI servers 85
updating data server names 83
deploying network applications 65
backing up 66
changing HMI server properties 70
copying client files 75
creating new client files 75
moving RSLogix Enterprise files 69
restoring 67
synchronizing HMI servers with projects 74
updating data server names 83
DeskLock 76, 135
device paths
backing up and restoring RSLogix Enterprise 67
renewing after backup and restore 70, 118
Diagnostics Viewer 136
documentation 10, 11
FactoryTalk Security 65
FactoryTalk View SE 9
domains
controller requirements 29
design considerations 28
setting up 28
downtime
using scheduled for upgrades 110
duplex
setting up for NIC 34

e
engineering workstations
upgrading 115

F
FactoryTalk Alarms and Events
hardware requirements 26
FactoryTalk Diagnostics Viewer 114, 120, 129
FactoryTalk Directory 19
FactoryTalk Directory Configuration Wizard 136
Index

FactoryTalk Security
  System Configuration Guide  65
FactoryTalk Services Platform  21
    FactoryTalk Help  102
FactoryTalk tools and utilities  136
FactoryTalk View SE Cache Management Tool  135
FactoryTalk View SE Client  19
  copying client files  75
  creating new client files  75
  file locations  75, 76, 88
  logging off  77
  logging on  77
  setting up security  76
  starting  76, 88
  starting when Windows starts  88
  using .cli file  76, 88
FactoryTalk View SE Secure Web Site Setup  135
FactoryTalk View SE Server  19, 20
FactoryTalk View Site Edition  17
  documentation set ix  9
  installing  41
  release notes  9
  upgrading  101
FactoryTalk View Studio  18
fast user switching
  turning off  32
file locations
  SE Client files  75, 76, 88
finding information
  about FactoryTalk  102
  about FactoryTalk View SE  9
  on the Internet  11
  technical support  11
firewalls
  third-party incompatible  35
folders
  SE Client files  75, 76, 88

G
grace period
  activating FactoryTalk View SE  59

H
hardware requirements  26
FactoryTalk Alarms and Events  26
HMI Server Backup and Restore utility  107, 112, 122, 135
  archive file names  123
HMI servers  19, 20, 86
  hosting on Windows Vista  26, 27, 112
  restoring  112
  setting up properties  70
  starting or stopping  70, 86
  synchronizing with projects  74

I
Import RSSecurity Configuration  136
incompatible firewalls  35
installing
  choosing components  42
  data servers  131
  FactoryTalk View SE  41
  product updates  132
  troubleshooting  101, 131
  upgrading  101
Internet Explorer
  removing enhanced security configuration  37
Internet Information Services (IIS)
  configuring  36, 139
  uninstalling  37
Internet technical support  11

K
keys
  FactoryTalk Activation  61
  sharing for FactoryTalk Activation  62
knowledgebase  28, 29, 32, 132

L
loading
  data servers  83
local applications
  administering at run time  89
  run-time clients  86
  security  76
Local Directory
  restoring  93
Log On to FactoryTalk  136
logging off
  at run time 77
logging on
  at run time 77

M
moving files
  data servers 81, 83, 93, 95

N
naming
  backup archives 122
  computers 30, 83, 95
  data server computers 83, 95
  troubleshooting computer names 30, 45
network applications
  hosting on Windows Vista 26, 27, 36, 112
  run-time clients 74
  security 76
  troubleshooting 76
Network Directory
  setting up on clients and servers 58
  setting up server on local computer 58
  specifying location 57, 112, 119
network interface cards (NIC)
  disabling power saving 35
  duplex 34
  troubleshooting 33
network switches
  troubleshooting 33
networks
  removing unnecessary DCOM protocols 40

O
OLE for Process Control (OPC)
  renaming data servers 95
  using for communications 22
online Help
  FactoryTalk Services Platform 102
  FactoryTalk View SE 10
  release notes 9, 102
operating systems
  requirements 26
operator workstations
  upgrading 104, 118

overview
  deploying local applications 65, 79

P
ports
  troubleshooting on network switches 33
power saving
  disabling for NIC 35
product updates
  installing 132
project files
  backing up and restoring 112
  folder locations 75, 88

R
redundancy
  disabling for upgrade 111
  operating system requirements 28
  replicating changes 74, 128
  servers 111, 114, 115, 122, 124
  synchronizing servers and projects 74
  troubleshooting 70, 74
  upgrading 126, 128
release notes 9, 11, 102
  FactoryTalk View SE 9
replication
  of redundant servers 74, 128
restoring network applications 67
Rockwell Automation Knowledgebase 28, 29, 32, 132
Rockwell Automation Literature Library 10
Rockwell Software
  contacting 11
  Rockwell Software Data Client 136
RSLinx Classic
  Backup Restore Utility 69
RSLinx Enterprise
  backing up and restoring device paths 80
  RSSecurity Emulator Install 136
RSView SE Client 19
RSView SE Server 19
run time
  locations of SE Client files 75, 76, 88
  setting up FactoryTalk View SE Clients 74
S
scheduled downtime
    using for upgrades 110
SE HMI Tag Alarm Log Setup 135
SE HMI Tag Alarm Log Viewer 135
SE Service Manager 135
security
    DeskLock tool 76
    locking users into FactoryTalk View 76
    logging off 77
    logging off at run time 77
    logging on 77
    logging on at run time 77
    removing enhanced in Internet Explorer 37
servers
    backing up and restoring 111, 114, 115, 122, 124
    checking status 128
    disabling redundancy for upgrade 111
    loading 95
    operating system requirements for applications 27
    redundancy 111, 114, 115, 122, 124, 128
    replication 74, 128
    synchronizing redundant 74
    upgrading 111, 114, 115, 121, 122, 124
    verifying running 114, 120, 129
service packs
    Windows compatibility 29, 32
sharing activation keys 62
shortcuts
    renewing after backup and restore 70, 118
simple file sharing
    turning off 32
Specify FactoryTalk Directory Location 57, 112, 119, 136
status
    checking redundant servers 128
switches
    using unmanaged 31, 33
synchronizing
    redundant servers 74
    time on computers 29
    troubleshooting redundancy 74
System Configuration Guide
    for FactoryTalk Security 65
System folder
    backing up 66
    restoring 67, 93, 124
system requirements
    application servers 27
    domain controllers 29
    hardware 26
    operating systems 26
    redundancy 28
    workgroups 29
T
Tag Import and Export Wizard 135
technical support 11
    checklist for calling 12
testing
    upgraded applications 120
third-party firewalls
    incompatible 35
time
    synchronizing on computers 29
    using scheduled downtime for upgrades 110
tools and utilities 136
    Alarm Log Setup 135
    Alarm Log Viewer 135
    Application Documenter 135
    Application Manager 80, 135
    DeskLock 76, 135
    Diagnostics Viewer 136
    FactoryTalk 136
    FactoryTalk Directory Configuration Wizard 136
    FactoryTalk View SE Cache Management Tool 135
    FactoryTalk View SE Secure Web Site Setup 135
    HMI Server Backup and Restore 112, 135
    Import RSSecurity Configuration 136
    Log On to FactoryTalk 136
    Rockwell Software Data Client 136
    RSSecurity Emulator Install 136
    SE HMI Tag Alarm Log Setup 135
    SE HMI Tag Alarm Log Viewer 135
    SE Service Manager 135
    Specify FactoryTalk Directory Location 57, 112, 119, 136
    Tag Import and Export Wizard 135

Rockwell Automation Publication VIEWSE-IN003M-EN-E 153
Uninstall FactoryTalk View 135
Windows Firewall Configuration Utility 23, 136

topics
renewing after backup and restore 70, 118
troubleshooting
applications 76, 111
backing up and restoring 113
clients 76
data servers 95
FactoryTalk Activation 59
installing 131
network applications 76
network interface cards (NIC) 33
network switches 33
redundancy 70, 74
upgrading 111

U
Unattended installation 41, 143
Uninstall FactoryTalk View 135
unmanaged switches
auto-negotiation 31, 33
using 31, 33
upgrading 59, 101
about activation keys 60, 61, 63
backing up and restoring 107
disabling redundancy 111
from RSView Enterprise to FactoryTalk View 102
grace period 59
installing product updates 132
non-redundant applications 104
planning 105
read-write keys 63
run-time clients 118, 121
servers 111, 114, 115, 121, 122, 124
sharing activation keys 62
shutting down all clients 110
testing applications 120
troubleshooting 59, 61, 111
upgrading for borrowed activation files 61
using scheduled downtime 110
view-only keys 63
workstations 115, 118, 121
user switching
turning off in Windows 32

V
user’s guides 10

V
virtual directories
recreating in IIS 37

W
WebDAV
installing for Windows Server 2008 142
Windows
compatibility 29, 32
file locations 76, 88
firewall 35
installing WebDAV for Windows Server 2008 142
service packs 29, 32
starting SE Client with Windows 88
turning off fast user switching 32
turning off simple file sharing 32
Windows Firewall Configuration Utility 136
Windows Vista
cautions for using 26, 36, 112
workgroups
design considerations 28
setting up 28
system requirements 29
workstations
upgrading 115, 118, 121
Rockwell Automation support

Rockwell Automation provides technical information on the web to assist you in using its products. At http://www.rockwellautomation.com/support, you can find technical and application notes, sample code, and links to software service packs. You can also visit our Support Center at https://rockwellautomation.custhelp.com for software updates, support chats and forums, technical information, FAQs, and to sign up for product notification updates.

In addition, we offer multiple support programs for installation, configuration, and troubleshooting. For more information, contact your local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/services/online-phone.

Installation assistance

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can contact Customer Support for initial help in getting your product up and running.

<table>
<thead>
<tr>
<th>Region</th>
<th>Phone Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>United States or Canada</td>
<td>1.440.646.3434</td>
</tr>
<tr>
<td>Outside United States or Canada</td>
<td>Use the Worldwide Locator available at <a href="http://www.rockwellautomation.com/locations">http://www.rockwellautomation.com/locations</a> <a href="http://www.rockwellautomation.com/locations">http://www.rockwellautomation.com/locations</a> or contact your local Rockwell Automation representative.</td>
</tr>
</tbody>
</table>

New product satisfaction return

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. However, if your product is not functioning and needs to be returned, follow these procedures.

<table>
<thead>
<tr>
<th>Region</th>
<th>Process Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>United States</td>
<td>Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to your distributor to complete the return process.</td>
</tr>
<tr>
<td>Outside United States</td>
<td>Please contact your local Rockwell Automation representative for the return procedure.</td>
</tr>
</tbody>
</table>

Documentation feedback

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, complete the feedback form, publication RA-DU002 http://literature.rockwellautomation.com/idc/groups/literature/documents/du/ra-du002_en-e.pdf.

Rockwell Otomasyon Ticaret A.Ş., Kar Plaza İş Merkezi E Blok Kat:6 34752 İçerenköy, İstanbul, Tel: +90 (216) 5698400

www.rockwellautomation.com