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1 Introduction

This chapter introduces you to the Emonitor® software, and gives an overview of the 
installation process.

Overview

This installation guide offers information on the entire installation process, including 
software installation, database server and client installation, and database connection 
information.

This installation guide is intended for first-time installations or upgrades from earlier 
versions of Emonitor software. It also contains reference information for later use.

Your satisfaction with the products we provide is our highest priority. Thank you for 
letting us help you with your machinery information needs.

Emonitor system requirements

 an Intel Pentium™ 4, Pentium 4-compatible, or greater microprocessor 

 1 GB of RAM (more is better)

 a DVD drive

 200 MB of space available on the hard drive, or more depending on the size of your 
database

 VGA or SVGA graphics card

 17 inch or larger computer monitor (screen)

 Microsoft® Windows® 7 Professional, Enterprise, or Ultimate operating system.

In addition, you must have Administrator rights on the computer where you are installing 
Emonitor or any Emonitor components.

Database system requirements

Refer to the database software manufacturer’s documentation for the requirements for the 
computer running the database server software. Note that Emonitor system performance 
may be reduced by running the Emonitor OPC Server with a large database. In this case, 
upgrading the database server computer may resolve the problem.
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Planning for the installation

Be sure to perform the following tasks before installing Emonitor for the first time.

FIND THE SERIAL NUMBER AND PRODUCT KEY ON THE ACTIVATION 
CERTIFICATE.

Emonitor requires that you activate your software using license files. As part of the 
Emonitor installation process, you must install the FactoryTalk Activation software.

The FactoryTalk Activation Manager replaces the old parallel port security keys and the 
CD Activation Key. The FactoryTalk Activation Manager is installed with Emonitor, and 
requires the Serial number and Product Key to activate your software. The Activation 
Certificate is included with your Emonitor Install DVD.

For more information on FactoryTalk Activation, refer to the FactoryTalk Activation 
documentation.

1. Insert the Emonitor Install DVD into your computer.

2. After the Autorun screen appears, click Documentation. The list of available 
documentation appears in your default HTML browser.

3. Click FactoryTalk Activation.

MAKE SURE A COMPUTER CAN ACCESS THE INTERNET.

FactoryTalk Activation requires an activation file, also called a license file. Unless you 
are using a hardware dongle (usually a USB key), you must use the FactoryTalk 
Activation Manager to request one or more license files from the Rockwell software 
licensing website. If the computer running Emonitor does not have Internet access, you 
must contact Rockwell Automation Technical Support to get the activation file by phone. 
Refer to the FactoryTalk Activation document for more information.

CHECK YOUR AVAILABLE DISK SPACE. 

Disk space requirements vary depending on which components you need to install. For a 
guideline, the Emonitor software requires about 170 megabytes (MB) of disk space. There 
are additional disk space requirements depending on your database setup. Be sure to 
check with your database administrator about these requirements and about backing up 
your database.

You must have Adobe Reader installed on your computer to read the documentation 
(documents are in PDF format). To install Adobe Reader, click Extras on the Emonitor Install 
screen, and then click Adobe Reader.
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BE SURE YOU HAVE THE CORRECT VERSION OF THE DATABASE SOFTWARE 
INSTALLED. 

 On the database server computer: 
Before installing Emonitor, make sure the database server version is compatible. You 
might need to consult with your database administrator to verify which version of the 
database server you are using. The Microsoft SQL Server database versions supported 
by Emonitor are versions 2008, and 2012. If you need to install a new version, ask 
your database administrator for assistance.

 On the Emonitor client computers:
 All Emonitor client computers must have the correct database client installed. 
 Before you can open the database using Emonitor, you must create a database 

alias TNS Names reference to the Oracle server to find the database on the 
network. 

BE SURE YOU HAVE WINDOWS 7 PROFESSIONAL INSTALLED.

Before installing Emonitor, you need to have the Windows 7 Professional, Enterprise, or 
Ultimate operating system installed on your computer. Emonitor version 3.70 is supported 
on the 32-bit versions of Microsoft Windows 7 Professional, Enterprise and Ultimate. 
Emonitor version 3.70 is not supported on the Windows NT, Windows Vista, Windows 
2000 Pro, Windows 2000 Server, Windows XP, Windows Server 2008 or 64-bit versions 
of Windows 7 operating systems.

Upgrading from a previous version

Emonitor version 3.70 runs only on the Windows 7 operating system. This means that you 
cannot directly upgrade Emonitor running on an earlier version of Windows (Emonitor 
3.50 was not supported on Windows 7). Instead, you must follow these steps:

1. Install Emonitor version 3.70 on a computer running Windows 7,

2. Move your Emonitor configuration files to the computer where you installed 
Emonitor version 3.70. 

Refer to the chapter titled Upgrading from a previous version. A new feature of the 
upgrade process is that the installation program asks if you want to back up your Emonitor 
configuration files. This includes all the data collector INI files, as well as any 
configuration files for any of the Emonitor programs (such as the Emonitor Scheduler and 
the Emonitor Online components). This allows you to protect your configuration files 
during an upgrade, and then bring them back into the new version.

If you are upgrading from a version of Emonitor prior to 3.20 (including Emonitor for 
Windows (EFW), Odyssey, or IQ 2000), please contact Customer Support for assistance. 
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Additional steps are required to upgrade from the 16-bit to 32-bit software. See Statement 
of Technical Support on page 4 for contact information.

What to read next

To learn about new features and improvements in Emonitor, read the Emonitor Product 
Release Notes. These are located on the Emonitor Install DVD (insert the DVD and then 
click Documentation).

To get started quickly, read the Emonitor Getting Results Guide. The Emonitor Getting 
Results Guide introduces you to the software, and shows you how to use the online help 
included with the software. This Guide is also located on the Emonitor Install DVD.

Refer to the online help for detailed instructions on using all the functions of the software. 
The online help system also includes explanations for all the commands and controls. Just 
press F1 to access the online help at any time in Emonitor.

If you are using data collectors with a walk-around system, you may receive an additional 
Data Collector User’s Guide for each of those interfaces. If you are using an online 
system, read the Emonitor Online Getting Results Guide and the Emonitor Enterprise 
Online Condition Monitor Getting Results Guide (on the Emonitor Install DVD and in the 
Emonitor program directory). You may receive additional manuals for the hardware you 
use for data collection. These manuals are delivered as PDF files on the CD that comes 
with the data collector or other hardware. You can also reference the data collector online 
help files installed with Emonitor from the Help menu in Emonitor.

Statement of Technical Support

Technical Support

If you cannot connect to the Internet or cannot find answers to your questions in this help 
file or on the Technical Support Web site, call Technical Support.

 Phone: 440-646-3434 in North America

 Technical Support hours of operation: 8:00 AM - 5:00 PM

If you are not located in North America and want to contact Rockwell Automation 
Technical Support by telephone, access the web address 
http://www.rockwellautomation.com/support/, select your region and country under Get 
Support Now, and then click Get Support for information about contacting your local 
support organization.

When you call you should be at your computer and be prepared to give the following 
information:

http://www.rockwellautomation.com/support/
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 The product version number

 The type of hardware you are using

 The exact wording of any messages that appeared on your screen

 A description of what happened and what you were doing when the problem occurred

 A description of how you tried to solve the problem

For information about all Rockwell Automation products or for technical support, select 
one of the following:

http://www.rockwellautomation.com/rockwellsoftware/

http://www.rockwellautomation.com/support/

http://rockwellautomation.custhelp.com/

http://www.rockwellautomation.com/rockwellsoftware/
http://www.rockwellautomation.com/support/
http://rockwellautomation.custhelp.com/
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2 Installing the database components

This chapter goes through the database installation process.

Installing Microsoft SQL Server

If you have a database server already installed and you have checked the version number 
to make sure it is compatible with Emonitor, you can skip this section. The minimum 
Microsoft SQL Server database version supported by Emonitor is version 2008. As 
always, if you are updating, back up your database directories to insure that you have a 
backup copy.

Refer to the Microsoft documentation for instructions on installing the database server, 
including the choice of Microsoft operating systems. The server installation procedures 
may require a database administrator to complete the configuration.

Installing database components for SQL Server 2008 and 2012

Creating the databases 

You must create the databases that hold the data for Emonitor. This section shows you 
how to create the databases and the users, or logins, for those databases.

1. Start Microsoft SQL Server Management Studio by choosing it from the Start menu.

2. Open the Databases directory by expanding the hierarchy on the left-hand side. 

The Group names in the following steps (ENTEKI, ENTEKD) are recommended but not required; 
you can substitute different Group names in the steps.
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3. Right-click the Databases directory and select New Database.

4. Name the new database Entek.

5. Click Add to create an ENTEKD database file.

a. Double-click in the Initial Size column to set the file size to 500 MB.

b. Double-click in the File Group column to create a new file group called 
ENTEKD.

6. In the row under the ENTEKD name, create an ENTEKI file group to hold the data 
information. 

a. Double-click in the Initial Size column to set the file size to 50 MB.

b. Double-click in the File Group column to change the name to ENTEKI.

7. Double-click in the Initial Size column for Entek_log to set the file size to 25 MB.

If your database administrator chooses not to use file groups, you must edit the database 
creation scripts to remove any reference to 'on enteki' and 'on entekd'
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8. Click the Options page, and set the Compatibility level. For MS SQL 2008, select 
SQL Server 2000 (80). For the MS SQL 2012 database, select SQL Server 2005 (90).

9. Repeat these steps for the Econfig database, using initial sizes of:

 40 MB for the Data file (EconfigD)

 10 MB for the Index file (EconfigI)

 5 MB for the Log file (Econfig_Log)

10. Open the Security folder in the left-hand side of the window. Right-click Logins and 
choose New Login.

a. In the General page, enter entek as the Login name and choose SQL Server 
authentication. Enter a Password. Select Entek as the Default database. Clear 
the Enforce password policy check box.
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b. Click the User Mapping page. Click the check box in the Entek row under Map. 
Under Database role membership for: Entek, select db_owner as shown below. 
The dialog box should look like the following.
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c. Click OK.

Repeat this step to create an EConfig user with a database role of db_owner on the 
EConfig database.

11. Next, see Running the database creation script below.

Running the database creation script

You must run a database creation script to create the Entek and EConfig databases. If the 
Entek databases already exist, you can connect to them, and you do not need to follow 
these steps.

If you need to create the database, follow these steps. You can run the script either from 
the server or from a client machine.

1. Start Microsoft SQL Server Management Studio by choosing it from the Start menu.

2. Select File > Open File. Select SQL Server files for Files of type, and then select the 
entekmsq.sql scrip file, located in the Emonitor program directory:
C:\Program Files\Rockwell Software\Emonitor\entekmsq.sql

3. Select Query > Execute, or press F5. This creates the Entek database structure.

4. Next, open and run the EConfig creation script, cfgmsq.sql, located in the following 
directory. This creates the EConfig database structure.

C:\Program Files\Rockwell Software\Emonitor\cfgmsq.sql

Installing the network client

If using MS SQL Server 2008/2012, each Emonitor client computer must have the file 
ntwdblib.dll present in the c:\Windows\System32 folder. You must manually copy this file 
from c:\Program Files\Rockwell Software\Emonitor into the c:\Windows\System32 
folder.

The database creation scrips are installed with the Emonitor software (described in Chapter 3 - 
Installing Emonitor). You must install Emonitor first, and then run the database creation scripts.

The scripts may need to be modified to use the correct Group names.

If your database administrator chooses not to use file groups, you must edit the database 
creation scripts to remove any reference to 'on enteki' and 'on entekd'

Do not attempt to use ODBC with the client to connect to the SQL Server database.
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For more information on installing the SQL Server client software, refer to the Microsoft 
SQL Server documentation.
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3 Installing Emonitor

This chapter guides you through the installation process for Emonitor. If you are 
upgrading from an existing version, refer to Chapter 4, Upgrading from a previous 
version. 

Installing FactoryTalk Activation Manager

Emonitor requires that you activate your software using license files. As part of the 
Emonitor installation process, you must install the FactoryTalk Activation Manager. For 
more information on FactoryTalk Activation, refer to the FactoryTalk Activation 
documentation. To display the documentation, follow these steps:

1. Insert the Emonitor Installation DVD into the DVD drive of your computer. It should 
auto-start and display the Autorun screen. If the Autorun screen does not appear, start 
the Windows Explorer and navigate to your DVD drive. Double-click autorun.exe on 
the Emonitor DVD to run the installation program.

When you upgrade from an earlier version of the Emonitor software (version 2.3 and earlier), the 
Process data type is replaced with the new Numeric data type for existing measurement 
definitions.

If you are running the DVD from another computer, you must map the DVD to a drive on your 
local computer.
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2. After the Autorun screen appears, click Documentation. The list of available 
documentation appears in your default HTML browser.

3. Click FactoryTalk Activation.

4. After reviewing the FactoryTalk Activation documentation, return to the Autorun 
screen.

5. From the Autorun screen, click FactoryTalk Activation to install the FactoryTalk 
Activation Manager from the DVD drive.

6. When finished, click Back to return to the main Autorun screen.

Installing RSLinx Classic

You must install RSLinx® Classic if you want to import measurements from certain 
online instruments:

 Use XM/DYN Online Data to import data from XM and XM DYN modules into the 
Emonitor database

 Use Logix Online Data to import data from the Logix family of controllers into the 
Emonitor database.

Installing the software

If you already have RSLinx Classic version 3.60 or later installed, you do not have to 
perform these steps.

1. From the Autorun screen, click RSLinx Classic.

2. Follow the steps as directed by the RSLinx Classic installation wizard.

3. Click RSLinx Classic and follow the directions that appear on the screen.

4. When the installation is complete, return to the Autorun screen and continue the 
installation process.

Installing the XML Gateway prerequisites

When installing Emonitor version 3.70 on the Windows 7 Professional, Enterprise, or 
Ulitmate operating system, you do not need to install any additional software for the 
CMMS XML Gateway, and can skip this step.

5.

You must install RSLinx Classic before you install Emonitor. RSLinx Classic installs the 
FactoryTalk Services Platform, which includes the latest Windows Firewall Configuration 
Utility. This utility configures the Windows firewall to work with Rockwell Automation products.



3 • INSTALLING EMONITOR

15

•  •  •  •  •

Installing Emonitor 

This installation is intended for first-time installations. If you are upgrading from a 
previous version of Emonitor, see the chapter Upgrading from a previous version.

The installation program installs all Emonitor components by default. You can, however, 
customize your selections during the installation.

Portable systems use walk-around data collectors for collecting data, and all Emonitor 
components can be installed on one computer. Online systems use networked systems that 
monitor and collect data, and Emonitor can be installed on different computers to increase 
efficiency. You may also use a combination of portable and online systems, and use 
different computers for each part.

This section walks you through the installation step-by-step with specific information 
available when needed. This section goes through a typical installation for a portable 
system.

Exit any running applications before starting the Emonitor installation program.

1. From the main Autorun screen click Emonitor. Follow the instructions on the screen.

2. Select your database type at the Database Selection dialog, and then click Next.

3. Some database types ask you to confirm or select your database version. Click Next to 
continue.

4. Select the XML Gateway if you want to install the Emonitor CMMS XML Gateway, 
and then click Next.

5. The next dialog shows the system requirements. If your system passes, click Next. See 
Emonitor system requirements on page 1 for more information.

6. Choose the directory where you want to install Emonitor. Click Browse to change the 
destination directory.

7. Select the program folder on the Start menu for Emonitor, then click Next.

8. Click Next to accept the configuration. The installation program begins copying files 
to your computer.

The CD Activation Key that was used to define the available features in Emonitor 3.00 and 
earlier versions has been replaced by FactoryTalk Activation described in Installing FactoryTalk 
Activation Manager on page 13.

The Emonitor installation program requires that you reboot your computer after installing the 
software.
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9. The installation program installs the Windows Firewall Configuration Utility. The 
Firewall Configuration program then runs to automatically modify the Windows 
Firewall settings to allow the following Emonitor components to operate: Emonitor 
OPC Server and OPC Enumerator, SQL Server, DCOM, Enlive, and the Emonitor 
Online programs (Enwatch/6600 Setup, Online Data Console, Create Loadfile, Load 
and Unload). Then the DCOM Security configuration program runs to complete the 
modifications.

10. For Oracle or MS SQL Server databases, enter the name of the database 
alias/tnsname reference for the Entek database in the Connect field, and the username 
and password in the following fields. You may want to write down this string so you 
remember it later. Click Next to continue. 

Repeat this procedure at the next screen for the EConfig database.

The message “The Windows Firewall configuration interface is unavailable” may appear if 
the Windows Firewall is disabled. If you are using some other software or hardware firewall, 
you may need to manually configure it to allow the Emonitor programs to communicate.

IMPORTANT: If you do not enter the correct information, the next time you start Emonitor, the 
program displays a database connection error message. Click Retry and enter the correct 
information (your connect string, username, and password). Due to enhanced security in 
Emonitor versions 3.40 and later, the password is encrypted and can no longer be edited in 
the Registry.
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11. The installation is nearly complete. Select Yes, I want to restart my computer now 
and click OK to restart your computer. The Emonitor installation is now complete.

Running the database creation scripts

You must run a database creation script to create the Entek and EConfig databases. If the 
Entek databases already exist, you can connect to them, and you do not need to follow 
these steps. The scripts to create the databases are installed with Emonitor, so they 
can only be run after you install Emonitor. See Running the database creation script on 
page 11..

Importing the data

1. After running the table creation script, you must import the data into the tables. Select 
Start > Program Files > Rockwell Software > Emonitor > Utilities > Emonitor 
Import-Export Utility.

2. From the Options menu, choose Import. Choose the following settings for each field.

 Leave Database blank.

 For Username, enter your username.

 For Password, enter the password for the chosen username.

Before starting Emonitor for the first time, you must import the Emonitor data. See the next 
section, Importing the data on page 17.

If you are upgrading Emonitor version 3.70 on a network system with a pre-existing Emonitor 
database, do not run the database creation scripts, The Emonitor databases already exist on 
your database server.

If you are upgrading Emonitor version 3.70 on a network system with a pre-existing Emonitor 
database, do not perform the steps in this section. The Emonitor databases already exist on your 
database server.

This procedure must be done after installing Emonitor because you use the data import utility 
provided with the installation. It must be done before you start Emonitor for the first time, but after 
you run the database creation scripts (describe in the chapter on installing the database 
components).
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 For DBServer, enter the connect string for the database. This is the “Server alias” 
from the Microsoft SQL Server Client Network Utility. 

3. From the File menu, choose Import Database. Select the dbu file you just created 
and choose Open.

The import process may take some time, so please wait. You must import both the 
entek.dbu and the econfig.dbu files. When the import is complete, you can install the 
client and connect to the database.

Installing the EDS files

If you are want to use Emonitor Online with, or import data from, XM or XM DYN 
modules into Emonitor, you must install the latest EDS files for the XM and XM DYN 
modules. EDS files are simple text files that are used by network Configuration Tools 
such as the Emonitor Online Configuration Utility to describe products so that you can 
easily commission them on a network. EDS files describe a product device type, revision, 
and configurable parameters.

1. Start the EDS Hardware Installation Tool. Click Start > Program Files > Rockwell 
Software > RSLinx > Tools > EDS Hardware Installation Tool.

2. In the EDS Hardware Installation Tool, click Add.

3. Select Register a directory of EDS files.

4. Click Browse, and navigate to the Emonitor program directory and click OK. The 
default directory is C:\Program Files\Rockwell Software\Emonitor.

You must install RSLinx Classic 3.60 or later before you can install EDS files.
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5. Click Next. The Tool installs all the EDS files in the Emonitor program directory. 
Some EDS files may show minor errors that do not have any functional impact, such 
as “The help string has exceeded the maximum length.” Click Next.

6. Continue to click Next to complete the EDS Wizard, and finally click Finish.

Installing online components

You can run all the components of the online system on a single computer or you can use 
several computers for an online system. If you are using a multi-user database, you can 
designate certain computers as Unload Stations and Viewing Stations, as illustrated in this 
diagram. For Emonitor with a single-user database, the Viewing Station, Database Server, 
and Unload Station are all on the same computer. This section covers setting up a 
multiple-computer Emonitor online system with an Unload Station and a Viewing Station.

For more information on the Emonitor Online system, please refer to the Emonitor Online 
Getting Results Guide and the help for the Online Data Management Console (Click Start 
> Programs > Rockwell Software > Emonitor > Help > Online Data Management 
Console).

Previous versions of Emonitor required that you install different components on different 
computers within an Emonitor Online system. This version of Emonitor simplifies the 
install process by installing all components to all computers in the Emonitor Online 
system.

This section only applies to Emonitor Online systems. If you do not have Emonitor Online, you 
can skip this section and go to Setting up Scheduler to automate tasks on page 20.
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Installing an Unload Station

Choose the computer to be used as an Unload Station, and start the Emonitor installation 
program at that computer. Go through the installation process as directed in Installing 
Emonitor on page 15. Make sure you install RSLinx Classic version 3.60 or later if you 
want to import data from XM or XM DYN modules or the Logix family of controllers.

Installing a Viewing Station

Choose the computer to be used as a Viewing Station, and start the Emonitor installation 
program at that computer. Go through the installation process as directed in Installing 
Emonitor on page 15.

Setting up Scheduler to automate tasks

You can use the Scheduler program to automate many data-related tasks. A task 
automated in Scheduler is called an event. A Scheduler profile defines not only the event, 
but also when and how often the event should occur. The Scheduler has two parts:

 The Scheduler program that allows you to create and edit profiles.

 The Scheduler service that runs in the background and launches (executes) the 
scheduled profiles. The Scheduler service must be running in order to execute 
scheduled profiles.

The Emonitor Scheduler service is disabled by default. In order to launch (run) scheduled 
tasks, including importing data, you must enable the Scheduler service.

To start the Scheduler service

You must have Administrator privileges to start the Scheduler service.

1. Click Start > Control Panel > Administrative Tools > Services.

2. Select Services (local) in the left side of the Services window.

3. Select SchedulrSvc in the right side of the Services window.

4. The SchedulrSvc Startup Type should be Automatic. If it is Manual or Disabled, 
right-click on SchedulrSvc and select Properties. In the Properties dialog box, set 
Startup Type to Automatic, and then click OK.

5. The SchedulrSvc Status should be Started. If it is Stopped, right-click on 
SchedulrSvc and select Start.

We strongly recommend that you leave the Startup Type for the SchedulrSvc as “Automatic” 
in the Services console. This starts the Scheduler service automatically when Windows 
starts.
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After you have enabled the Scheduler service, it starts when you start Windows. 
Scheduled events are executed only when the Scheduler service is running. You can use 
the Scheduler on any computer in an Emonitor Online system (both Viewing station and 
Unload station computers).

These steps show you how to set up two different online profiles. The first is the Online 
Import Event, which looks for unload files (containing data from the data collection 
instruments) in the unload directory and sends the information to the Emonitor database. 
The second is the Storage Limit Updater, which allows you to limit data storage to 
specific parameters and specify a time during low database usage, saving disk space and 
time (a database maintenance task). Follow these steps to set up online profiles using 
Scheduler.

1. Start Scheduler (Start > Programs > Rockwell Software > Emonitor > Utilities > 
Scheduler) and click Add. 

2. On the Profile dialog, enter the Profile Name, such as Storage Limit Updater or 
Online Import Event. You can enter notes about the profile as well. Select Enable 
profile for scheduling. Click Next to continue.

The Emonitor Scheduler is installed as part of the Emonitor software. Since Scheduler profiles 
are stored in the central Emonitor database, all scheduler profiles are launched on all computers 
in an Emonitor Online system that are running the Scheduler service. This may not be a problem 
if you are using Scheduler only for data import tasks on one or two computers. If you are using 
Scheduler for additional kinds of tasks, such as Emonitor database maintenance, running the 
same scheduled task from multiple computers can place a significant load on the Database 
Server computer. Refer to the Scheduler help for more information (Start > Programs > 
Rockwell Software > Emonitor > Help > Scheduler).

For more information on setting up different kinds of Scheduler profiles, refer to the Scheduler 
online help.



INSTALLING EMONITOR SOFTWARE WITH AN MS SQL SERVER MULTI-USER DATABASE

22

• 
 •

  
• 

 •
  

•

3. On the Response dialog, select Scheduled time/date/frequency.

 For the Storage Limit Updater, click Next and then skip to step 7. 

 For the Online Import Event, select File change notification and click Settings. 

4. Click Add File. Select the UD directory under your Emonitor program directory. In 
the File name box, enter *.ulf. This tells Scheduler to look for unload files in the 
unload directory. Click Open. 

5. The unload files appear in the Monitored Files list. Click OK to continue.

6. Click Next on the Response dialog.

7. On the Events dialog, click Add Event.

8. Enter the Executable file and the Command line using the following guidelines, then 
click OK. This example used the default Emonitor installation directory. If you 
installed Emonitor in a different directory, use the path to your Emonitor program 
directory.

For Online Import Event:

Executable file: C:\Program Files\Rockwell Software\
Emonitor\didaemon.exe

Command line: C:\Program Files\Rockwell Software\
Emonitor\odonline.edi

For Storage Limit Updater:

Executable file: C:\Program Files\Rockwell Software\
Emonitor\stglimit.exe

Command line (must be one of the following): 

 /all - Remove all measurement data, system event log data and alarm event log 
data outside the storage limits.

 “/list:list name” - Remove measurement data which are saved to a list 
with “list name” and are outside the storage limits. Note: “list name” is case 
sensitive, and must be enclosed in quotes if the list name contains a space.

 /alarm - Remove alarm event log data outside the storage limits.

 /system - Remove system event log data outside the storage limits. 

9. Click Next to continue.

10. On the Frequency dialog, set the Date and Time you want to launch the profile. Click 
Finish.
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The profile is now added to Scheduler. The executable file and command line information 
for the various database import and update programs is also included in the online help for 
the Scheduler program. You can display the Scheduler help by pressing F1, or from the 
Start menu (Start > Programs > Rockwell Software > Emonitor > Help > Scheduler).

You can find more information on using the Scheduler in an Emonitor Online system in 
the help for the Online Data Management Console. Click Start > Programs > Rockwell 
Software > Emonitor > Help > Online Data Management Console in the section on 
“Setting up the Emonitor Online System”.

Installing the Emonitor Web software

Any level of Emonitor can now be enhanced with the Emonitor Web software. This 
allows you to view data from your Emonitor database over an intranet or over the Internet, 
using Microsoft Internet Explorer. The Emonitor Web software uses concurrent user 
licensing. This limits the number of people who can view the Emonitor data at one time, 
without restricting them to specific computers with FactoryTalk Activation.

The Emonitor Web software allows you to view data for any point in your Emonitor 
database by “drilling down” to the location, and then double-clicking the data type to view 
trend and spectrum plots from within Internet Explorer. Typical Emonitor cursor functions 
are available in these plots. You can also view reports with Emonitor Web, as well as load 
and unload a data collector from a remote location, and then transfer the data back to the 
Emonitor database.

Prerequisites

 Microsoft Internet Information Server (MS IIS) version 7.5 or greater must be 
installed and configured to run active server pages on the web server computer.

 The FTP component in MS IIS must be installed if you want to load and unload data 
from a remote site using Emonitor Web. The FTP directory should be on the same 
computer as the Emonitor Web server.

 The FactoryTalk Activation Manager software must be installed on the web server 
computer (installed from the Emonitor DVD).

 The Oracle database client or MS SQL Server client must be installed on the web 
server computer, and configured to connect to the database server. The database server 
can be located on the web server.

 The computer running Internet Explorer must be able to access the web server 
computer, either over an intranet, or over the Internet.

 Users are able to connect to the database using the database alias, Windows computer 
name, or IP address.
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 If users at the remote site are logged into a Windows domain controller, Emonitor Web 
uses the user name and domain name to identify the Emonitor Web user.

 The FactoryTalk Activation license must include the license for the Emonitor Web 
Client.

 Emonitor Web has been tested (and is supported) on the following combinations of 
software and operating systems:

Emonitor Web is not supported with Windows XP, Windows Vista, Windows Server 2008, 
or any earlier version of Windows.

Setting up an Emonitor Web website

These instructions assume you have already installed Emonitor and the required database 
software as described in this manual. You must have Administrator privileges to install the 
software.

1. Insert the Emonitor DVD into the DVD drive of the web server computer (the 
computer with Microsoft IIS).

2. After the Autorun screen appears, click FactoryTalk Activation to install the 
FactoryTalk Activation client software on the web server computer. When finished, 
return to the Autorun screen.

3. Click Emonitor Web to install the required files on the web server.

4. Set up a Web Application in the MS IIS, with the Virtual Directory pointing to the 
directory where you installed the Emonitor Web files. The default Execute 
Permissions (Scripts Only) are sufficient to operate the Emonitor Web Server.

5. Create an FTP load and unload directory for each Emonitor Web user created in 
Emonitor. The Emonitor Web user must have read/write permission in both 
directories.If the Emonitor Web user’s name is “fred”, the directories should be:

IIS version Host operating system

7.5 Windows 7 Professional

IE version Host operating system

9.x Windows 7 Professional
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(FTP root)/fred/upload
(FTP root)/fred/download

6. To start the Emonitor Web Client from a different computer, start Internet Explorer. 
Enter the correct IP address or URL, followed by the name of the Virtual Directory. 
For example, if the URL for the web server is www.webserver.com/server, and the 
Virtual Directory is /emonitor, use www.webserver.com/server/emonitor as the 
Emonitor Web Client address in Internet Explorer.

For more information on setting up Emonitor Web users, refer to the Emonitor online help.



INSTALLING EMONITOR SOFTWARE WITH AN MS SQL SERVER MULTI-USER DATABASE

26

• 
 •

  
• 

 •
  

•



27

4 Upgrading from a previous version

This chapter guides you through the process of upgrading from an earlier version of the 
Emonitor software.

Emonitor version 3.70 runs only on the Windows 7 operating system. This means that you 
cannot upgrade your previous version of Emonitor (3.50 and earlier); instead, you must 
install Emonitor version 3.70 on the computer running Windows 7. As part of this process, 
you must move your Emonitor configuration files from the computer with the earlier 
version of Emonitor to the computer where you will install Emonitor version 3.70.

If you are upgrading from Emonitor 3.60 on Windows 7, you do not have to move your 
files from the computer running Emonitor 3.60. You can upgrade to Emonitor version 
3.70 by running the Emonitor Installation program on that computer.

Your Scheduler, Enwatch/6600 Online Data, XM/DYN Online Data, Enterprise Online 
Configuration Utility, and Emonitor OPC Client, and Emonitor OPC Server configuration 
files from previous versions of Emonitor should work with the new version of Emonitor. 
You will need to move these configurations to the new computer. You will also need to 
create new data sources in the Online Data Management Console after you install 
Emonitor 3.7. For more information, refer to the Online Data Management Console help 
after you complete the upgrade (click Start > Programs > Rockwell Software > 
Emonitor > Help > Online Data Management Console).

Backing up your Emonitor configuration files

Emonitor uses configuration files that are stored outside of the Emonitor database. These 
files contain the settings for a number of Emonitor programs, including the Scheduler, 
Enwatch/6600 Online Data, XM Emonitor Gateway, Enterprise Online Configuration 

Emonitor version 3.70 has been tested on, and is supported on, Windows 7 Professional, 
Enterprise, and Ultimate (32-bit versions only). Emonitor version 3.70 is not supported, and may 
not install or run as expected, on any other Windows operating system.

If you are urading from Emonitor version 3.30 or earlier (earlier versions were called Emonitor for 
Windows - EFW - or Odyssey), please contact Customer Support for assistance. You may need 
to perform additional steps to upgrade (see Statement of Technical Support on page 4).

When you upgrade from a previous version of the Emonitor software, the Process data type is 
replaced with the new Numeric data type for existing measurement definitions.

You must have Administrator rights on the computer to be able to upgrade Emonitor.
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Utility, and Emonitor OPC Client, and Emonitor OPC Server. If you are upgrading from 
Emonitor version 3.5 or earlier, and want to use these configuration files with Emonitor 
version 3.70, you must copy them from your current Emonitor installation to the computer 
running Emonitor version 3.70. If you are upgrading from Emonitor 3.60 on the same 
computer, you do not need to manually back up your configuration files.

The default directories for the configuration files are listed below. If you have stored 
configuration files in different directories, make sure that you back up the files from those 
directories as well.

 DCF Files (Windows XP)
For Emonitor Online:
C:\Program Files\Rockwell Software\Emonitor\[PROFILE_NAME].DCF
For RSMACC EOL:
\Program Files\Rockwell Software\RSMACCEOL

 EOL Files (Windows XP)
For Emonitor Online:
C:\Program Files\Rockwell Software\Emonitor\[PROFILE_NAME].EOL
For RSMACC EOL:
\Program Files\Rockwell Software\RSMACCEOL

 OnlineDataConsole.xml (Windows XP)
C:\WINDOWS\system32\OnlineDataConsole.xml

 Templates (Windows XP)
C:\Program Files\Rockwell Software\Emonitor\English Templates
C:\Program Files\Rockwell Software\Emonitor\Metric Templates

 Load and Unload directories (Windows XP)
C:\Program Files\Rockwell Software\Emonitor\LD
C:\Program Files\Rockwell Software\Emonitor\UD

 Online directory (Windows XP)
C:\Program Files\Rockwell Software\Emonitor\Online

 New EDS files are installed when you install Emonitor 3.70 on the computer running 
Windows 7; however, you must back up any custom EDS files.

 INI, EDI and EAX Files (Windows XP)
C:\Program Files\Rockwell Software\Emonitor\

If you are backing up configuration files for RSMACC EOL, make sure that the .DCF file names 
do not conflict with the same file types from Emonitor Online. If necessary, rename the .DCF files 
from RSMACC EOL.
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Backing up your Emonitor database

Unload any data collectors and back up your Emonitor database before proceeding.

Installing Emonitor version 3.70

If you are upgrading from Emonitor 3.50 or earlier, install Emonitor version 3.70 on the 
computer running the Windows 7 operating system. See Chapter 3, Installing Emonitor 
for instructions. If you are upgrading from Emonitor 3.60 on Windows 7, see “Running 
the Emonitor upgrade program” on page 29.

Running the Emonitor upgrade program

If you are upgrading from Emonitor version 3.60 on Windows 7, you can use the 
installation program on the Emonitor DVD to upgrade your Emonitor software.

Exit any running applications before starting the Emonitor upgrade program.

1. Insert the Emonitor Installation DVD into the DVD drive of your computer.

2. Emonitor requires that you activate your software using license files. As part of the 
Emonitor upgrade process, you must install or upgrade the FactoryTalk Activation 
software. For more information on FactoryTalk Activation, refer to the FactoryTalk 
Activation documentation. To display the file, follow these steps:

a. Insert the Emonitor Install DVD into your computer.

b. After the Autorun screen appears, click Read Documentation. The list of 
available documentation appears in your default HTML browser.

c. Click FactoryTalk Activation.

Make sure you follow these steps before upgrading.
1. Unload all data collectors before upgrading. You will not be able to unload them after the 
upgrade.
2. Back up your databases before upgrading to the latest version.

The Emonitor upgrade program requires that you reboot your computer after upgrading the 
software.

If you are running the DVD from another computer, you must map the DVD to a drive on your 
local computer.
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d. When finished, click Back to return to the main Autorun screen, and then click 
FactoryTalk Activation to install or upgrade the FactoryTalk Activation 
software. You can skip this step if the latest software is already installed.

5. When finished, click Back to return to the main Autorun screen, and then click 
RSLinx Classic to upgrade RSLinx® Classic. If you want to use XM/DYN Online 
Data to import data from XM modules or Logix Online Data to import data from the 
Logix family of controllers, RSLinx Classic version 3.60 or later must be installed on 
the same computer. Follow the instructions on the screen to install or upgrade RSLinx 
Classic. You can skip this step if the latest software is already installed.

6. When finished, return to the main Autorun screen. Even if you are using the XML 
Gateway with your Emonitor system, you do not need to install the XML Gateway 
Prerequisites. The necessary software is included in Microsoft Windows 7.

7. When finished, click Back to return to the main Autorun screen, and then click 
Emonitor. Follow the instructions on the screen.

8. The installation program detects that installed Emonitor components are not up to 
date.

 Upgrade all components installed by the previous setup. This option installs 
the upgraded version with the same configuration as your existing installation.

The XM/DYN Online Data and Logix Online Dats software require the RSLinx Classic 
software. It is recommended that you update RSLinx Classic before you updat Emonitor.
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 Remove all installed components. This option removes the Emonitor software 
from your computer. You will not be able to run Emonitor after you remove the 
software; however, the Emonitor database, other data files, and configuration files 
remain on your computer.

Click Upgrade all components installed by the previous setup. If you see a 
message about a read-only file having been detected, click Yes to continue.

9. Enter or select the folder where the installation program stores the Emonitor 
configuration files. This includes all the data collector INI files, as well as any 
configuration files for any of the Emonitor programs (such as the Emonitor Scheduler 
and the Emonitor Online components). This allows you to protect your configuration 
files during an upgrade, and then bring them back into the new version.

10. After backing up your configuration files, the installation program removes the old 
version of Emonitor, and then requires that you restart your computer. Select Yes, I 
want to restart my computer now and click OK to restart your computer. After you 
restart the computer, the installation program continues.

11. Select the XML Gateway if you want to install or upgrade the Emonitor CMMS XML 
Gateway, and click Next.

12. The next dialog shows the system requirements. If your system passes, click Next.

13. Choose the directory where you want to install Emonitor. Click Browse to change the 
installation directory. 

14. Click Next to add the Emonitor folder to your Start menu.

15. Click Next to accept the configuration. Setup begins copying files to your computer.

16. The installation program installs the Windows Firewall Configuration Utility. The 
Firewall Configuration program then runs to automatically modify the Windows 
Firewall settings to allow the following Emonitor components to operate: Emonitor 
OPC server and OPC enumerator, SQL Server, DCOM, Enlive, and the Emonitor 
Online programs (Enwatch/6600 Online Data, Online Data Console, Create Loadfile, 
Load and Unload). Then the DCOM Security configuration program runs to complete 
the modifications.

You can choose a different directory in which to install Emonitor, but the previous installation 
will no longer work. The installation program will not upgrade your previous installation or 
install a new database. 

The message “The Windows Firewall configuration interface is unavailable” may appear if 
the Windows Firewall is disabled. If you are using some other software or hardware firewall, 
you may need to manually configure it to allow the Emonitor programs to communicate.
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17. The upgrade is nearly complete. Select Yes, I want to restart my computer now and 
click OK to restart your computer. The Emonitor software upgrade is now complete.

Installing the EDS files

If you are want to use Emonitor Online with, or import data from, XM or XM DYN 
modules into Emonitor, you must install the latest EDS files for the XM and XM DYN 
modules. EDS files are simple text files that are used by network Configuration Tools 
such as the Emonitor Online Configuration Utility to describe products so that you can 
easily commission them on a network. EDS files describe a product device type, revision, 
and configurable parameters.

1. Start the EDS Hardware Installation Tool. Click Start > Program Files > Rockwell 
Software > RSLinx > Tools > EDS Hardware Installation Tool.

2. In the EDS Hardware Installation Tool, click Add.

3. Select Register a directory of EDS files.

4. Click Browse, and navigate to the Emonitor program directory and click OK. The 
default directory is C:\Program Files\Rockwell Software\Emonitor.

5. Click Next. The Tool installs all the EDS files in the Emonitor program directory. 
Some EDS files may show minor errors that do not have any functional impact, such 
as “The help string has exceeded the maximum length.” Click Next.

6. Continue to click Next to complete the EDS Wizard, and finally click Finish.

Restructuring the database

After any upgrade, you must restructure the database. This adds the necessary data and 
structure information to your current database, allowing you to run the new version of the 
program. When you start Emonitor, the restructure program automatically starts if it is 
needed. Follow these steps the first time you start Emonitor after performing an upgrade.

1. If you are upgrading from Emonitor version 3.30 or earlier, you must rename the 
rename the files in the \Restruct folder from *.msq to *.sql (on the computer where 

You must install RSLinx Classic 3.60 or later before you can install EDS files.

Make sure you follow these steps before restructuring your database.
1. Back up your databases before upgrading to the latest version.
2. Unload any data collectors before upgrading.
3. Make sure no users are connected to the database.
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you installed Emonitor). If you fail to rename the restructure files, the database 
restructure process will fail.

2. Start your Emonitor software from the Start menu on any client computer (Start > 
Programs > Rockwell Software > Emonitor > Emonitor). Click Yes to update your 
database.

After you enter the Admin user name and password, the restructure program 
automatically starts. The default Admin username and password are “admin” and 
“password”.

3. Click Restructure to begin the update process. 

4. Make sure you have backed up your database, then click OK to continue. 

5. Make sure that no users are still attached to the database, then click OK to continue. 

Allow plenty of time to restructure your database. It may appear to stop or be locked up, and 
stay at 99% for a long time. Do not try to restart your computer during restructure–just be 
patient and let the program finish.
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6. When the process is finished, click Close. You can now run the new version of 
Emonitor. 

The amount of time needed for this process depends on your processor speed and the 
amount of RAM available.

Restoring your Emonitor configuration files

After you have restored the Emonitor database files, restore the Emonitor configuration 
files.

The default directories for the Emonitor 3.70 configuration files are listed below. 

 DCF Files (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\[PROFILE_NAME].DCF

 EOL Files (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\[PROFILE_NAME].EOL

Note that the default directories for Emonitor version 3.70 configuration files on Windows 7 are 
different than they were on versions prior to 3.60.

If you are restoring configuration files from RSMACC EOL version 2.50, make sure that the .DCF 
and .EOL file names do not conflict with the same file types from Emonitor Online. If necessary, 
rename the .DCF and .EOL files from RSMACC EOL. We recommend using different .DCF and 
.EOL files for Emonitor EOL version 3.70 and Emonitor Online version 3.70.
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 OnlineDataConsole.xml (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\OnlineDataConsole.xml

 Templates (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\Templates\English
C:\Users\Public\Documents\Rockwell Software\Emonitor\Templates\Metric

 Load and Unload directories (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\UD
C:\Users\Public\Documents\Rockwell Software\Emonitor\ld

 Online directory (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\Online

 EDS files are installed with Emonitor 3.70. If you backed up any custom EDS files, 
restore them to:
C:\Program Files\Rockwell Software\Emonitor\ 

 INI, EDI and EAX Files (Windows 7)
C:\Program Files\Rockwell Software\Emonitor\
(This is the same directory as for Emonitor 3.5)

Changing paths in odonline.edi

After you restore the odonline.edi file, you must edit the file to update the path 
information.

1. Shut down Emonitor if it is running.

2. Open C:\Program Files\Rockwell Software\Emonitor\odonline.edi with Windows 
Notepad or some other text editor.

Edit the XML files and change all instances in the document from: 
<XMProfile>C:\Program Files\Rockwell Software\Emonitor\

to:

<XMProfile>C:\Users\Public\Documents\Rockwell Software\Emonitor\



INSTALLING EMONITOR SOFTWARE WITH AN MS SQL SERVER MULTI-USER DATABASE

36

• 
 •

  
• 

 •
  

•

3. Edit C:\Program Files\Rockwell Software\Emonitor\odoonline.edi as follows:

[Source]

DataFileConfigFile=C:\Program Files\Rockwell 
Software\Emonitor\odonline.ini

DataFileDir=C:\Users\Public\Documents\Rockwell 
Software\Emonitor\ud

DataFiles=C:\Users\Public\Documents\Rockwell 
Software\Emonitor\ud\*.ulf

[Options]

BackupPathnameOnError=C:\Users\Public\Documents\Rockwell 
Software\Emonitor\online\backup\

LogFilePathname=C:\Users\Public\Documents\Rockwell 
Software\Emonitor\online\online.log

4. Restart the Scheduler and OLDM_Service services.

a. Click Start > Control Panel > Administrative Tools > Services.

b. Select Services (local) in the left side of the Services window.

c. Select SchedulrSvc in the right side of the Services window.

d. If the SchedulrSvc Status is Started, right-click on SchedulrSvc and select Stop.

e. Right-click on SchedulrSvc and select Start.

f. Select OLDM_Service in the right side of the Services window.

g. If the OLDM_Service Status is Started, right-click on OLDM_Service and select 
Stop.

h. Right-click on SchedulrSvc and select Start.
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