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1 Introduction

This chapter introduces you to the Emonitor® software, and gives an overview of the 
installation process.

Overview

This installation guide offers information on the entire installation process, including 
software installation, database server and client installation, database maintenance, and 
database connection information.

This installation guide is intended for first-time installations or upgrades from earlier 
versions of Emonitor software. It also contains reference information for later use.

Your satisfaction with the products we provide is our highest priority. Thank you for 
letting us help you with your machinery information needs.

Emonitor system requirements

 an Intel Pentium™ 4, Pentium 4-compatible, or greater microprocessor 

 1 GB of RAM (more is better)

 a DVD drive

 200 MB of space available on the hard drive, or more depending on the size of your 
database

 VGA or SVGA graphics card

 17 inch or larger computer monitor (screen)

 Microsoft® Windows® 7 Professional, Enterprise, or Ultimate operating system.

In addition, you must have Administrator rights on the computer where you are installing 
Emonitor or any Emonitor components.

Database system requirements

The requirements for the computer running the Gupta SQLBase single-user database are 
the same as those for Emonitor (listed above).

Gupta SQLBase is the new name for the Centura database software.
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Note that Emonitor system performance may be reduced by running the Emonitor OPC 
Server with a large database. In this case, upgrading the database server computer may 
resolve the problem.

Planning for the installation

Be sure to perform the following tasks before installing Emonitor for the first time.

FIND THE SERIAL NUMBER AND PRODUCT KEY ON THE ACTIVATION 
CERTIFICATE.

Emonitor requires that you activate your software using license files. As part of the 
Emonitor installation process, you must install the FactoryTalk Activation software. If 
you are using a single-user version of Emonitor on a single computer you can install the 
FactoryTalk Activation Server software on the same computer as Emonitor.

The FactoryTalk Activation Manager replaces the old parallel port security keys and the 
CD Activation Key. The FactoryTalk Activation Manager is installed with Emonitor, and 
requires the Serial number and Product Key to activate your software. The Activation 
Certificate is included with your Emonitor Install DVD.

For more information on FactoryTalk Activation, refer to the FactoryTalk Activation 
documentation.

1. Insert the Emonitor Install DVD into your computer.

2. After the Autorun screen appears, click Documentation. The list of available 
documentation appears in your default HTML browser.

3. Click FactoryTalk Activation.

MAKE SURE A COMPUTER CAN ACCESS THE INTERNET.

FactoryTalk Activation requires an activation file, also called a license file. Unless you 
are using a hardware dongle (usually a USB key), you must use the FactoryTalk 
Activation Manager to request one or more license files from the Rockwell software 
licensing website. If the computer running Emonitor does not have Internet access, you 
must contact Rockwell Automation Technical Support to get the activation file by phone. 
Refer to the FactoryTalk Activation document for more information.

CHECK YOUR AVAILABLE DISK SPACE. 

Disk space requirements vary depending on which components you need to install. For a 
guideline, the Emonitor software requires about 170 megabytes (MB) of disk space. There 

You must have Adobe Reader installed on your computer to read the documentation 
(documents are in PDF format). To install Adobe Reader, click Extras on the Emonitor Install 
screen, and then click Adobe Reader.
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are additional disk space requirements depending on your database setup. Be sure to 
check with your database administrator about these requirements and about backing up 
your database.

BE SURE YOU HAVE THE CORRECT VERSION OF THE DATABASE SOFTWARE 
INSTALLED. 

 On the computer hosting the Emonitor software: 
Before installing Emonitor, make sure the database version is compatible. You might 
need to consult with your database administrator to verify which version of the 
database server you are using. The Gupta SQLBase database version supported by 
Emonitor is SQLBase version 9.0.1. 

BE SURE YOU HAVE WINDOWS 7 PROFESSIONAL INSTALLED.

Before installing Emonitor, you need to have the Windows 7 Professional, Enterprise, or 
Ultimate operating system installed on your computer. Emonitor version 3.70 is supported 
on the 32-bit versions of Microsoft Windows 7 Professional, Enterprise and Ultimate. 
Emonitor version 3.70 is not supported on the Windows NT, Windows Vista, Windows 
2000 Pro, Windows 2000 Server, Windows XP, Windows Server 2008 or 64-bit versions 
of Windows 7 operating systems.

Upgrading from a previous version

Emonitor version 3.70 runs only on the Windows 7 operating system. This means that you 
cannot directly upgrade Emonitor running on an earlier version of Windows (Emonitor 
3.50 was not supported on Windows 7). Instead, you must follow these steps:

1. Install Emonitor version 3.70 on a computer running Windows 7,

2. Move your Emonitor database and Emonitor configuration files to the computer 
where you installed Emonitor version 3.70. 

Refer to the chapter titled Upgrading from a previous version. A new feature of the 
upgrade process is that the installation program asks if you want to back up your Emonitor 
configuration files. This includes all the data collector INI files, as well as any 
configuration files for any of the Emonitor programs (such as the Emonitor Scheduler and 
the Emonitor Online components). This allows you to protect your configuration files 
during an upgrade, and then bring them back into the new version.

If you are upgrading from a version of Emonitor prior to 3.20 (including Emonitor for 
Windows (EFW), Odyssey, or IQ 2000), please contact Customer Support for assistance. 
Additional steps are required to upgrade from the 16-bit to 32-bit software. See Statement 
of Technical Support on page 4 for contact information.
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What to read next

To learn about new features and improvements in Emonitor, read the Emonitor Product 
Release Notes. These are located on the Emonitor Install DVD (insert the DVD and then 
click Documentation).

To get started quickly, read the Emonitor Getting Results Guide. The Emonitor Getting 
Results Guide introduces you to the software, and shows you how to use the online help 
included with the software. This Guide is also located on the Emonitor Install DVD.

Refer to the online help for detailed instructions on using all the functions of the software. 
The online help system also includes explanations for all the commands and controls. Just 
press F1 to access the online help at any time in Emonitor.

If you are using data collectors with a walk-around system, you may receive an additional 
Data Collector User’s Guide for each of those interfaces. If you are using an online 
system, read the Emonitor Online Getting Results Guide and the Emonitor Enterprise 
Online Condition Monitor Getting Results Guide (on the Emonitor Install DVD and in the 
Emonitor program directory). You may receive additional manuals for the hardware you 
use for data collection. These manuals are delivered as PDF files on the CD that comes 
with the data collector or other hardware. You can also reference the data collector online 
help files installed with Emonitor from the Help menu in Emonitor.

Statement of Technical Support

Technical Support

If you cannot connect to the Internet or cannot find answers to your questions in this help 
file or on the Technical Support Web site, call Technical Support.

 Phone: 440-646-3434 in North America

 Technical Support hours of operation: 8:00 AM - 5:00 PM

If you are not located in North America and want to contact Rockwell Automation 
Technical Support by telephone, access the web address 
http://www.rockwellautomation.com/support/, select your region and country under Get 
Support Now, and then click Get Support for information about contacting your local 
support organization.

When you call you should be at your computer and be prepared to give the following 
information:

 The product version number

 The type of hardware you are using

http://www.rockwellautomation.com/support/
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 The exact wording of any messages that appeared on your screen

 A description of what happened and what you were doing when the problem occurred

 A description of how you tried to solve the problem

For information about all Rockwell Automation products or for technical support, select 
one of the following:

http://www.rockwellautomation.com/rockwellsoftware/

http://www.rockwellautomation.com/support/

http://rockwellautomation.custhelp.com/

http://www.rockwellautomation.com/rockwellsoftware/
http://www.rockwellautomation.com/support/
http://rockwellautomation.custhelp.com/
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2ts Installing Emonitor

This chapter guides you through the installation process for Emonitor. If you are 
upgrading from an existing version, refer to Chapter 3, Upgrading from a previous 
version. 

Installing FactoryTalk Activation Manager

Emonitor requires that you activate your software using license files. As part of the 
Emonitor installation process, you must install the FactoryTalk Activation Manager. For 
more information on FactoryTalk Activation, refer to the FactoryTalk Activation 
documentation. To display the documentation, follow these steps:

1. Insert the Emonitor Installation DVD into the DVD drive of your computer. It should 
auto-start and display the Autorun screen. If the Autorun screen does not appear, start 
the Windows Explorer and navigate to your DVD drive. Double-click autorun.exe on 
the Emonitor DVD to run the installation program.

When you upgrade from an earlier version of the Emonitor software (version 2.3 and earlier), the 
Process data type is replaced with the new Numeric data type for existing measurement 
definitions.

If you are running the DVD from another computer, you must map the DVD to a drive on your 
local computer.
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2. After the Autorun screen appears, click Documentation. The list of available 
documentation appears in your default HTML browser.

3. Click FactoryTalk Activation.

4. After reviewing the FactoryTalk Activation documentation, return to the Autorun 
screen.

5. From the Autorun screen, click FactoryTalk Activation to install the FactoryTalk 
Activation Manager from the DVD drive.

6. When finished, click Back to return to the main Autorun screen.

Installing RSLinx Classic

You must install RSLinx® Classic if you want to import measurements from certain 
online instruments:

 Use XM/DYN Online Data to import data from XM and XM DYN modules into the 
Emonitor database

 Use Logix Online Data to import data from the Logix family of controllers into the 
Emonitor database.

Installing the software

If you already have RSLinx Classic version 3.60 or later installed, you do not have to 
perform these steps.

1. From the Autorun screen, click RSLinx Classic.

2. Follow the steps as directed by the RSLinx Classic installation wizard.

3. Click RSLinx Classic and follow the directions that appear on the screen.

4. When the installation is complete, return to the Autorun screen and continue the 
installation process.

You must install RSLinx Classic before you install Emonitor. RSLinx Classic installs the 
FactoryTalk Services Platform, which includes the latest Windows Firewall Configuration 
Utility. This utility configures the Windows firewall to work with Rockwell Automation products.
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Installing SQLBase

With the Gupta SQLBase single-user version of Emonitor, all of the database software 
(server and client) resides on the same machine. The Gupta SQLBase software must be 
installed before you can install Emonitor.

As always, if you are upgrading, back up your database directories to ensure that you have 
a backup copy (see Backing up your data on page 32). Then go to Chapter 3, Upgrading 
from a previous version.

Getting information from Gupta's website

You can obtain helpful information from Gupta's website at 
http://www.guptaworldwide.com/.

Installing the software

If you already have the Gupta SQLBase software 9.0.1 or later installed, you do not have 
to perform these steps.

1. From the Autorun screen, click SQLBase.

1. The Gupta SQLBase installation program starts. Click Next to continue.

2. Accept the license agreement, and then click Next.

3. Enter the Product Media Code:
132C8A2B-C296EAD6-3D4F990E-B7D930F7 
and then click Next.

4. Select the directory for the Gupta SQLBase database software, and then click Next.

5. Select the installation type (All SQLBase components, or Custom), and then click 
Next.

6. Enter the name of the database server if you want to change it (the default server name 
is Server1), and then click Next. The installation program then copies the database 
files to your computer.

Gupta SQLBase is the new name for the Centura database software.



INSTALLING EMONITOR SOFTWARE WITH A GUPTA SQLBASE SINGLE-USER DATABASE

10

• 
 •

  
• 

 •
  

•

7. Select No when prompted to restart your computer, and then click Finish. Rebooting 
your computer at this time is not required.

8. After the computer restarts, start the Emonitor Installation program again, and 
continue with the installation process as described below.

Installing the XML Gateway prerequisites

When installing Emonitor version 3.70 on the Windows 7 Professional, Enterprise, or 
Ulitmate operating system, you do not need to install any additional software for the 
CMMS XML Gateway, and can skip this step.

9.

The Gupta SQLBase server runs as a Windows service, and automatically starts when you 
start Windows. You can change this so the Gupta SQLBase server only starts when an 
Emonitor program or service starts. For more information, see Running the Gupta SQLBase 
Server as a program on page 31.
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Installing Emonitor 

This installation is intended for first-time installations. If you are upgrading from a 
previous version of Emonitor, see the chapter Upgrading from a previous version.

The installation program installs all Emonitor components by default. You can, however, 
customize your selections during the installation.

Portable systems use walk-around data collectors for collecting data, and all Emonitor 
components can be installed on one computer. Online systems use networked systems that 
monitor and collect data, and Emonitor can be installed on different computers to increase 
efficiency. You may also use a combination of portable and online systems, and use 
different computers for each part.

This section walks you through the installation step-by-step with specific information 
available when needed. This section goes through a typical installation for a portable 
system.

Exit any running applications before starting the Emonitor installation program.

1. From the main Autorun screen click Emonitor. Follow the instructions on the screen.

2. Select your database type at the Database Selection dialog, and then click Next.

3. Some database types ask you to confirm or select your database version. Click Next to 
continue.

4. Select the XML Gateway if you want to install the Emonitor CMMS XML Gateway, 
and then click Next.

5. The next dialog shows the system requirements. If your system passes, click Next. See 
Emonitor system requirements on page 1 for more information.

6. Choose the directory where you want to install Emonitor. Click Browse to change the 
destination directory.

7. Select the program folder on the Start menu for Emonitor, then click Next.

8. Click Next to accept the configuration. The installation program begins copying files 
to your computer.

The CD Activation Key that was used to define the available features in Emonitor 3.00 and 
earlier versions has been replaced by FactoryTalk Activation described in Installing FactoryTalk 
Activation Manager on page 7.

The Emonitor installation program requires that you reboot your computer after installing the 
software.
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9. The installation program installs the Windows Firewall Configuration Utility. The 
Firewall Configuration program then runs to automatically modify the Windows 
Firewall settings to allow the following Emonitor components to operate: Emonitor 
OPC Server and OPC Enumerator, SQL Server, DCOM, Enlive, and the Emonitor 
Online programs (Enwatch/6600 Setup, Online Data Console, Create Loadfile, Load 
and Unload). Then the DCOM Security configuration program runs to complete the 
modifications.

10. The installation is nearly complete. Select Yes, I want to restart my computer now 
and click OK to restart your computer. The Emonitor installation is now complete.

Installing the EDS files

If you are want to use Emonitor Online with, or import data from, XM or XM DYN 
modules into Emonitor, you must install the latest EDS files for the XM and XM DYN 
modules. EDS files are simple text files that are used by network Configuration Tools 
such as the Emonitor Online Configuration Utility to describe products so that you can 
easily commission them on a network. EDS files describe a product device type, revision, 
and configurable parameters.

1. Start the EDS Hardware Installation Tool. Click Start > Program Files > Rockwell 
Software > RSLinx > Tools > EDS Hardware Installation Tool.

2. In the EDS Hardware Installation Tool, click Add.

3. Select Register a directory of EDS files.

4. Click Browse, and navigate to the Emonitor program directory and click OK. The 
default directory is C:\Program Files\Rockwell Software\Emonitor.

5. Click Next. The Tool installs all the EDS files in the Emonitor program directory. 
Some EDS files may show minor errors that do not have any functional impact, such 
as “The help string has exceeded the maximum length.” Click Next.

6. Continue to click Next to complete the EDS Wizard, and finally click Finish.

The message “The Windows Firewall configuration interface is unavailable” may appear if 
the Windows Firewall is disabled. If you are using some other software or hardware firewall, 
you may need to manually configure it to allow the Emonitor programs to communicate.

You must install RSLinx Classic 3.60 or later before you can install EDS files.
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Installing online components

You can run all the components of the online system onto a single computer or you can 
use several computers for an online system. If you are using a multi-user database, you 
can designate certain computers as Unload Stations and Viewing Stations, as illustrated in 
this diagram. For Emonitor with a single-user database, the Viewing Station, Database 
Server, and Unload Station are all on the same computer.

For more information on the Emonitor Online system, please refer to the Emonitor Online 
Getting Results Guide, and the help for the Online Data Management Console (Click 
Start > Programs > Rockwell Software > Emonitor > Help > Online Data 
Management Console).

Setting up Scheduler to automate tasks

You can use the Scheduler program to automate many data-related tasks. A task 
automated in Scheduler is called an event. A Scheduler profile defines not only the event, 
but also when and how often the event should occur. The Scheduler has two parts:

 The Scheduler program that allows you to create and edit profiles.

 The Scheduler service that runs in the background and launches (executes) the 
scheduled profiles. The Scheduler service must be running in order to execute 
scheduled profiles.

The Emonitor Scheduler service is disabled by default. In order to launch (run) scheduled 
tasks, including importing data, you must enable the Scheduler service.

This section only applies to Emonitor Online systems. If you do not have Emonitor Online, you 
can skip this section and go to Setting up Scheduler to automate tasks on page 13.
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To start the Scheduler service

You must have Administrator privileges to start the Scheduler service.

1. Click Start > Control Panel > Administrative Tools > Services.

2. Select Services (local) in the left side of the Services window.

3. Select SchedulrSvc in the right side of the Services window.

4. The SchedulrSvc Startup Type should be Automatic. If it is Manual or Disabled, 
right-click on SchedulrSvc and select Properties. In the Properties dialog box, set 
Startup Type to Automatic, and then click OK.

5. The SchedulrSvc Status should be Started. If it is Stopped, right-click on 
SchedulrSvc and select Start.

After you have enabled the Scheduler service, it starts when you start Windows. 
Scheduled events are executed only when the Scheduler service is running. You can use 
the Scheduler on any computer in an Emonitor Online system (both Viewing station and 
Unload station computers).

These steps show you how to set up two different online profiles. The first is the Online 
Import Event, which looks for unload files (containing data from the data collection 
instruments) in the unload directory and sends the information to the Emonitor database. 
The second is the Storage Limit Updater, which allows you to limit data storage to 
specific parameters and specify a time during low database usage, saving disk space and 
time (a database maintenance task). Follow these steps to set up online profiles using 
Scheduler.

We strongly recommend that you leave the Startup Type for the SchedulrSvc as “Automatic” 
in the Services console. This starts the Scheduler service automatically when Windows 
starts.

The Emonitor Scheduler is installed as part of the Emonitor software. Since Scheduler profiles 
are stored in the central Emonitor database, all scheduler profiles are launched on all computers 
in an Emonitor Online system that are running the Scheduler service. This may not be a problem 
if you are using Scheduler only for data import tasks on one or two computers. If you are using 
Scheduler for additional kinds of tasks, such as Emonitor database maintenance, running the 
same scheduled task from multiple computers can place a significant load on the Database 
Server computer. Refer to the Scheduler help for more information (Start > Programs > 
Rockwell Software > Emonitor > Help > Scheduler).

For more information on setting up different kinds of Scheduler profiles, refer to the Scheduler 
online help.
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1. Start Scheduler (Start > Programs > Rockwell Software > Emonitor > Utilities > 
Scheduler) and click Add. 

2. On the Profile dialog, enter the Profile Name, such as Storage Limit Updater or 
Online Import Event. You can enter notes about the profile as well. Select Enable 
profile for scheduling. Click Next to continue.

3. On the Response dialog, select Scheduled time/date/frequency.

 For the Storage Limit Updater, click Next and then skip to step 7. 

 For the Online Import Event, select File change notification and click Settings. 

4. Click Add File. Select the UD directory under your Emonitor program directory. In 
the File name box, enter *.ulf. This tells Scheduler to look for unload files in the 
unload directory. Click Open. 

5. The unload files appear in the Monitored Files list. Click OK to continue.

6. Click Next on the Response dialog.

7. On the Events dialog, click Add Event.

8. Enter the Executable file and the Command line using the following guidelines, then 
click OK. This example used the default Emonitor installation directory. If you 
installed Emonitor in a different directory, use the path to your Emonitor program 
directory.

For Online Import Event:

Executable file: C:\Program Files\Rockwell Software\
Emonitor\didaemon.exe

Command line: C:\Program Files\Rockwell Software\
Emonitor\odonline.edi
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For Storage Limit Updater:

Executable file: C:\Program Files\Rockwell Software\
Emonitor\stglimit.exe

Command line (must be one of the following): 

 /all - Remove all measurement data, system event log data and alarm event log 
data outside the storage limits.

 “/list:list name” - Remove measurement data which are saved to a list 
with “list name” and are outside the storage limits. Note: “list name” is case 
sensitive, and must be enclosed in quotes if the list name contains a space.

 /alarm - Remove alarm event log data outside the storage limits.

 /system - Remove system event log data outside the storage limits. 

9. Click Next to continue.

10. On the Frequency dialog, set the Date and Time you want to launch the profile. Click 
Finish.

The profile is now added to Scheduler. The executable file and command line information 
for the various database import and update programs is also included in the online help for 
the Scheduler program. You can display the Scheduler help by pressing F1, or from the 
Start menu (Start > Programs > Rockwell Software > Emonitor > Help > Scheduler).

You can find more information on using the Scheduler in an Emonitor Online system in 
the help for the Online Data Management Console. Click Start > Programs > Rockwell 
Software > Emonitor > Help > Online Data Management Console in the section on 
“Setting up the Emonitor Online System”.
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3 Upgrading from a previous version

This chapter guides you through the process of upgrading from an earlier version of the 
Emonitor software.

Emonitor 3.7 runs only on the Windows 7 operating system. This means that you cannot 
upgrade your previous version of Emonitor (3.5 and earlier); instead, you must install 
Emonitor 3.7 on the computer running Windows 7. As part of this process, you must move 
your Emonitor database and Emonitor configuration files from the computer with the 
earlier version of Emonitor to the computer where you will install Emonitor version 3.70.

If you are upgrading from Emonitor 3.60 on Windows 7, you do not have to move your 
files from the computer running Emonitor 3.60. You can upgrade to Emonitor version 
3.70 by running the Emonitor Installation program on that computer.

Your Scheduler, Enwatch/6600 Online Data, XM Emonitor Gateway, Enterprise Online 
Configuration Utility, and Emonitor OPC Client, and Emonitor OPC Server configuration 
files from previous versions of Emonitor should work with the new version of Emonitor. 
You will need to move these configurations to the new computer. You will also need to 
create new data sources in the Online Data Management Console after you install 
Emonitor 3.7. For more information, refer to the Online Data Management Console help 
after you complete the upgrade (click Start > Programs > Rockwell Software > 
Emonitor > Help > Online Data Management Console).

Backing up your Emonitor configuration files

Emonitor uses configuration files that are stored outside of the Emonitor database. These 
files contain the settings for a number of Emonitor programs, including the Scheduler, 
Enwatch/6600 Online Data, XM Emonitor Gateway, Enterprise Online Configuration 
Utility, and Emonitor OPC Client, and Emonitor OPC Server. If you are upgrading from 

Emonitor version 3.7 has been tested on, and is supported on, Windows 7 Professional, 
Enterprise, and Ultimate (32-bit versions only). Emonitor 3.7 is not supported, and may not install 
or run as expected, on any other Windows operating system.

If you have a version of Emonitor earlier than version 3.20 (some earlier versions were called 
Emonitor for Windows - EFW - or Odyssey), please contact Customer Support for assistance. 
You must perform several additional steps to upgrade to the current Gupta SQLBase database 
software (see Statement of Technical Support on page 4).

When you upgrade from a previous version of the Emonitor software that uses the Process data 
type, the Process data type is replaced with the new Numeric data type for existing 
measurement definitions.
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Emonitor version 3.5 or earlier, and want to use these configuration files with Emonitor 
version 3.70, you must copy them from your current Emonitor installation to the computer 
running Emonitor version 3.70. If you are upgrading from Emonitor 3.60 on the same 
computer, you do not need to manually back up your configuration files.

The default directories for the configuration files are listed below. If you have stored 
configuration files in different directories, make sure that you back up the files from those 
directories as well.

 DCF Files (Windows XP)
For Emonitor Online:
C:\Program Files\Rockwell Software\Emonitor\[PROFILE_NAME].DCF
For RSMACC EOL:
\Program Files\Rockwell Software\RSMACCEOL

 EOL Files (Windows XP)
For Emonitor Online:
C:\Program Files\Rockwell Software\Emonitor\[PROFILE_NAME].EOL
For RSMACC EOL:
\Program Files\Rockwell Software\RSMACCEOL

 OnlineDataConsole.xml (Windows XP)
C:\WINDOWS\system32\OnlineDataConsole.xml

 Templates (Windows XP)
C:\Program Files\Rockwell Software\Emonitor\English Templates
C:\Program Files\Rockwell Software\Emonitor\Metric Templates

 Load and Unload directories (Windows XP)
C:\Program Files\Rockwell Software\Emonitor\LD
C:\Program Files\Rockwell Software\Emonitor\UD

 Online directory (Windows XP)
C:\Program Files\Rockwell Software\Emonitor\Online

 New EDS files are installed when you install Emonitor 3.70 on the computer running 
Windows 7; however, you must back up any custom EDS files.

 INI, EDI and EAX Files (Windows XP)
C:\Program Files\Rockwell Software\Emonitor\

If you are backing up configuration files for RSMACC EOL, make sure that the .DCF file names 
do not conflict with the same file types from Emonitor Online. If necessary, rename the .DCF files 
from RSMACC EOL.
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Backing up your Emonitor database

See Backing up your data on page 32 for instructions.

Installing Emonitor version 3.70 on Windows 7

If you are upgrading from Emonitor 3.50 or earlier, install Emonitor version 3.70 on the 
computer running the Windows 7 operating system. See Chapter 2, Installing Emonitor 
for instructions. If you are upgrading from Emonitor 3.60 on Windows 7, see “Running 
the Emonitor upgrade program” on page 20.

Installing the EDS files

If you are want to use Emonitor Online with, or import data from, XM or XM DYN 
modules into Emonitor, you must install the latest EDS files for the XM and XM DYN 
modules. EDS files are simple text files that are used by network Configuration Tools 
such as the Emonitor Online Configuration Utility to describe products so that you can 
easily commission them on a network. EDS files describe a product device type, revision, 
and configurable parameters.

1. Start the EDS Hardware Installation Tool. Click Start > Program Files > Rockwell 
Software > RSLinx > Tools > EDS Hardware Installation Tool.

2. In the EDS Hardware Installation Tool, click Add.

3. Select Register a directory of EDS files.

4. Click Browse, and navigate to the Emonitor program directory and click OK. The 
default directory is C:\Program Files\Rockwell Software\Emonitor.

5. Click Next. The Tool installs all the EDS files in the Emonitor program directory. 
Some EDS files may show minor errors that do not have any functional impact, such 
as “The help string has exceeded the maximum length.” Click Next.

6. Continue to click Next to complete the EDS Wizard, and finally click Finish.

Restoring your Emonitor database

Copy the database files to the computer where you installed Emonitor version 3.70. The 
default database directories are:

You must install RSLinx Classic 3.60 or later before you can install EDS files.

Make sure you shut down Emonitor before restoring your database files.
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C:\Program Files\Gupta>SQLBase901\Econfig
C:\Program Files\Gupta>SQLBase901\Entek

Running the Emonitor upgrade program

If you are upgrading from Emonitor version 3.60 on Windows 7, you can use the 
installation program on the Emonitor DVD to upgrade your Emonitor software.

Exit any running applications before starting the Emonitor upgrade program.

1. Insert the Emonitor Installation DVD into the DVD drive of your computer.

Emonitor requires that you activate your software using license files. As part of the 
Emonitor upgrade process, you must install or upgrade the FactoryTalk Activation 
software. For more information on FactoryTalk Activation, refer to the FactoryTalk 
Activation documentation. To display the file, follow these steps:

a. Insert the Emonitor Install DVD into your computer.

b. After the Autorun screen appears, click Documentation. The list of available 
documentation appears in your default HTML browser.

c. Click FactoryTalk Activation.

d. When finished, click Back to return to the main Autorun screen, and then click 
FactoryTalk Activation to upgrade the FactoryTalk Activation software. If you 
already have the latest version of the software, you can skip this step.

Make sure you follow these steps before upgrading.
1. Unload all data collectors before upgrading. You will not be able to unload them after the 
upgrade.

2. Back up your databases before upgrading to the latest version (see Backing up your data on 
page 32).

3. If you are upgrading from Emonitor 3.2, shut down the SQLBase server (locally for single-user 
systems and at the server for multi-user systems). After shutting down the server, delete any 
LOG files in the database directories (\Centura\Entek and \Centura\Econfig for the single-user 
version).

The Emonitor upgrade program requires that you reboot your computer after upgrading the 
software.

If you are running the DVD from another computer, you must map the DVD to a drive on your 
local computer.
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5. When finished, click Back to return to the main Autorun screen, and then click 
RSLinx Classic to upgrade RSLinx® Classic. If you want to use XM/DYN Online 
Data to import data from XM modules, or Logix Online Data to import data from the 
Logix family of controllers, RSLinx Classic version 3.60 or later must be installed on 
the same computer. Follow the instructions on the screen to install or upgrade RSLinx 
Classic. If you already have the latest version of the software, you can skip this step.

6. When finished, click Back to return to the main Autorun screen, and then click 
SQLBase. Follow the instructions on the screen. If you already have the latest version 
of the software, you can skip this step.

7. When finished, return to the main Autorun screen. Even if you are using the XML 
Gateway with your Emonitor system, you do not need to click XML Gateway 
Prerequisites. The correct versions of the software are included as part of Microsoft 
Windows 7.

8. When finished, click Back to return to the main Autorun screen, and then click 
Emonitor. Follow the instructions on the screen.

The XM/DYN Online Data and Logix Online Data software require the RSLinx Classic 
software. It is recommended that you upgrade RSLinx before you upgrade Emonitor.

Do not remove your existing version of the SQLBase database software before installing the 
new Gupta SQLBase 9.0.1 software. If you want to remove the SQLBase software, you can 
uninstall it after you verify that the Emonitor upgrade completed properly.
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9. The installation program detects that installed Emonitor components are not up to 
date.

 Upgrade all components installed by the previous setup. This option installs 
the upgraded version with the same configuration as your existing installation.

 Remove all installed components. This option removes the Emonitor software 
from your computer. You will not be able to run Emonitor after you remove the 
software; however, the Emonitor database, other data files, and configuration files 
remain on your computer.

Click Upgrade all components installed by the previous setup. If you see a 
message about a read-only file having been detected, click Yes to continue.

10. Enter or select the folder where the installation program stores the Emonitor 
configuration files. This includes all the data collector INI files, as well as any 
configuration files for any of the Emonitor programs (such as the Emonitor Scheduler 
and the Emonitor Online components). This allows you to protect your configuration 
files during an upgrade, and then bring them back into the new version.

11. After backing up your configuration files, the installation program removes the old 
version of Emonitor, and then requires that you restart your computer. Select Yes, I 
want to restart my computer now and click OK to restart your computer. After you 
restart the computer, the installation program continues.

12. Select the XML Gateway if you want to install or upgrade the Emonitor CMMS XML 
Gateway, and click Next.
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13. The next dialog shows the system requirements. If your system passes, click Next.

14. Choose the directory where you want to install Emonitor. Click Browse to change the 
installation directory. 

15. Select the program folder on the Start menu for Emonitor, then click Next.

16. Click Next to accept the configuration. Setup begins copying files to your computer.

17. The installation program installs the Windows Firewall Configuration Utility. The 
Firewall Configuration program then runs to automatically modify the Windows 
Firewall settings to allow the following Emonitor components to operate: Emonitor 
OPC server and OPC enumerator, SQL Server, DCOM, Enlive, and the Emonitor 
Online programs (Enwatch/6600 Online Data, Online Data Console, Create Loadfile, 
Load and Unload). Then the DCOM Security configuration program runs to complete 
the modifications.

18. The upgrade is nearly complete. Select Yes, I want to restart my computer now and 
click OK to restart your computer. The Emonitor software upgrade is now complete.

19. Install the EDS files. Emontior 3.70 works with the new XM module firmware. See 
Installing the EDS files on page 19.

Restructuring the database

After any upgrade, you must restructure the database. This adds the necessary data and 
structure information to your current database, allowing you to run the new version of the 
program. When you start Emonitor, the restructure program automatically starts if it is 
needed. Follow these steps the first time you start Emonitor after performing an upgrade.

You can choose a different directory in which to install Emonitor, but the previous installation 
will no longer work. The installation program will not upgrade your previous installation or 
install a new database.

The message “The Windows Firewall configuration interface is unavailable” may appear if 
the Windows Firewall is disabled. If you are using some other software or hardware firewall, 
you may need to manually configure it to allow the Emonitor programs to communicate.

Make sure you follow these steps before restructuring your database.
1. Back up your databases before upgrading to the latest version (see Backing up your data on 
page 32).
2. Make sure no users are connected to the database.
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1. Start your Emonitor software from the Start menu on any client computer (Start > 
Programs > Rockwell Software > Emonitor > Emonitor). Click Yes to update your 
database.

After you enter the Admin user name and password, the restructure program 
automatically starts. The default Admin username and password are “admin” and 
“password”.

2. Click Restructure to begin the update process. 

3. Make sure you have backed up your database, then click OK to continue. 

4. Make sure that no users are still attached to the database, then click OK to continue. 

Allow plenty of time to restructure your database. It may appear to stop or be locked up, and 
stay at 99% for a long time. Do not try to restart your computer during restructure–just be 
patient and let the program finish.
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5. When the process is finished, click Close. You can now run the new version of 
Emonitor. 

The amount of time needed for this process depends on your processor speed and the 
amount of RAM available.

Restoring your Emonitor configuration files

After you have restored the Emonitor database files, restore the Emonitor configuration 
files.

The default directories for the Emonitor 3.70 configuration files are listed below. 

 DCF Files (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\[PROFILE_NAME].DCF

 EOL Files (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\[PROFILE_NAME].EOL

Note that the default directories for Emonitor version 3.70 configuration files on Windows 7 are 
different than they were on versions prior to 3.60.

If you are restoring configuration files from RSMACC EOL version 2.50, make sure that the .DCF 
and .EOL file names do not conflict with the same file types from Emonitor Online. If necessary, 
rename the .DCF and .EOL files from RSMACC EOL. We recommend using different .DCF and 
.EOL files for Emonitor EOL version 3.70 and Emonitor Online version 3.70.
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 OnlineDataConsole.xml (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\OnlineDataConsole.xml

 Templates (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\Templates\English
C:\Users\Public\Documents\Rockwell Software\Emonitor\Templates\Metric

 Load and Unload directories (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\UD
C:\Users\Public\Documents\Rockwell Software\Emonitor\ld

 Online directory (Windows 7)
C:\Users\Public\Documents\Rockwell Software\Emonitor\Online

 EDS files are installed with Emonitor 3.70. If you backed up any custom EDS files, 
restore them to:
C:\Program Files\Rockwell Software\Emonitor\ 

 INI, EDI and EAX Files (Windows 7)
C:\Program Files\Rockwell Software\Emonitor\
(This is the same directory as for Emonitor 3.5)

Changing paths in odonline.edi

After you restore the odonline.edi file, you must edit the file to update the path 
information.

1. Shut down Emonitor if it is running.

2. Open C:\Program Files\Rockwell Software\Emonitor\odonline.edi with Windows 
Notepad or some other text editor.

Edit the XML files and change all instances in the document from: 
<XMProfile>C:\Program Files\Rockwell Software\Emonitor\

to:

<XMProfile>C:\Users\Public\Documents\Rockwell Software\Emonitor\
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3. Edit C:\Program Files\Rockwell Software\Emonitor\odoonline.edi as follows:

[Source]

DataFileConfigFile=C:\Program Files\Rockwell 
Software\Emonitor\odonline.ini

DataFileDir=C:\Users\Public\Documents\Rockwell 
Software\Emonitor\ud

DataFiles=C:\Users\Public\Documents\Rockwell 
Software\Emonitor\ud\*.ulf

[Options]

BackupPathnameOnError=C:\Users\Public\Documents\Rockwell 
Software\Emonitor\online\backup\

LogFilePathname=C:\Users\Public\Documents\Rockwell 
Software\Emonitor\online\online.log

4. Restart the Scheduler and OLDM_Service services.

a. Click Start > Control Panel > Administrative Tools > Services.

b. Select Services (local) in the left side of the Services window.

c. Select SchedulrSvc in the right side of the Services window.

d. If the SchedulrSvc Status is Started, right-click on SchedulrSvc and select Stop.

e. Right-click on SchedulrSvc and select Start.

f. Select OLDM_Service in the right side of the Services window.

g. If the OLDM_Service Status is Started, right-click on OLDM_Service and select 
Stop.

h. Right-click on SchedulrSvc and select Start.
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4 Database maintenance

This chapter describes specific procedures for maintaining your database. These steps will 
help your database speed and efficiency. Note that the procedures in this document apply 
to Emonitor installations using the single-user or network (multi-user) versions of the 
Gupta SQLBase database software.

Using SQLTalk Interactive

SQLTalk is the Gupta SQLBase program that allows you to communicate directly with 
your database. Some of the procedures in this document require that you use SQLTalk.

1. Make sure that all users are logged out of Emonitor, and that no one is accessing the 
database with SQLTalk or another utility.

2. From the Start menu, click Programs > Gupta > SQLBase 9.0.1 > SQLTalk 
Interactive SQL.

3. From the Session menu, click Connect, or press F2. The Connect dialog appears. 

4. Enter the database name, username, and password for your database. For the Entek 
database, the default user name is entek, and the default password is euser. For the 
EConfig database, the default username is also entek, and the default password is 
also euser. The name and password are not case-sensitive. Passwords are encrypted.

5. Click Connect to connect to the database. Your database name should appear in the 
Current Connections box.

6. Select the database in the Current Connections box and click Use, and then click 
Close.
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Checking the integrity of your database

A database is a file, or set of files, stored on your computer. In rare instances, a database 
can be damaged or corrupted. If this happens, you may not know about it until you 
attempt to recall information from the damaged part of the database. In some cases, you 
may not discover the damage for days, weeks, or months.

For this reason, it is important that you regularly check the integrity of your databases, for 
both the Entek and the Econfig databases.

1. If you are using a network version of Emonitor, make sure that all users are logged out 
of Emonitor, and that no one is accessing the database with SQLTalk or another utility.

2. Start SQLTalk as described in Using SQLTalk Interactive on page 29.

3. In the Input Window (the top pane), type the following, including the semicolon:

check database;

4. Press Shift+F2 to execute the command, or click Execute Command from the 
Session menu. If the check is successful, SQLTalk displays the message:

DATABASE CHECKED

If any other message appears, your database may be corrupt. Contact Customer 
Support immediately for assistance. Run this command on both the Entek and the 
Econfig databases.

Speeding up database access 

You can also use SQLTalk Interactive to speed up database access by optimizing the 
database. To do so, follow these steps.

1. If you are using a network version of Emonitor, make sure that all users are logged out 
of Emonitor, and that no one is accessing the database with SQLTalk or another utility.

2. Start SQLTalk and connect to the Entek database. See Using SQLTalk Interactive on 
page 29.

3. In the Input Window (the top pane), type the following, including the semicolon:

update statistics on database;

4. Press Shift+F2 to execute the command, or click Execute Command from the 
Session menu. If the check is successful, SQLTalk displays a message similar to this 
one depending on the number of rows in your database:

STATISTICS UPDATED ON 44,410 ROWS
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This command may take some time depending on the size of your database, so please 
be patient. Run this command on both the Entek and the Econfig databases.

Running the Gupta SQLBase Server as a program

By default, the Gupta SQLBase Server runs as a Windows service. This means the Server 
starts when you start Windows, and you cannot close the SQLBase Server program (the 
Exit button is disabled). You can change the way the Server starts, so that it only starts 
when it is needed by Emonitor.

1. If you are using a network version of Emonitor, make sure that all users are logged out 
of Emonitor, and that no one is accessing the database with SQLTalk or another utility.

2. Start the Gupta SQLBase Management Console. Select Start > Program Files > 
Gupta > SQLBase 9.0.1 > SQLBase Management Console.

3. Expand the Console Root by double clicking it.

4. Right-click the database server name. The default name is Server1. Select Stop to 
stop the database server.

5. Right-click Service Properties. Select Startup Type > Disabled. This means the 
database server will only start when you start Emonitor.

You can also run the SQLBase Server as a service without displaying the Server 
Console. Right-click Service Properties, and then select Server Console > Off.

6. Close the SQLBase Management Console. The next time you start Windows, the 
SQLBase Server will not automatically start. It will only start when you start 
Emonitor, or manually start the server by selecting Start > Program Files > Gupta > 
SQLBase 9.0.1 > SQLBase Database Engine.
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Backing up your data

How often should I back up my data?

You should back up as often as you can afford to lose data. If you can lose a week’s worth 
of data, back up once a week. If you need to have all of your data from each day, back up 
daily.

What files and directories do I need to back up?

The Gupta SQLBase database directories should be backed up. These database directories 
contain the individual Gupta SQLBase database files (.dbs). Typically the database 
directories are stored in subdirectories of the main Gupta SQLBase directory. Simply 
copy the directories and files within the directories.

For example, to back up the Entek database, you would copy the Entek directory which 
contains the entek.dbs file (copy both the .dbs file and any other files that are in the 
directory).

You also need to back up the Econfig directory containing the Econfig database.

What is the correct backup procedure for SQLBase 
databases?

1. Shut down Emonitor.

2. From the Start menu, point to Programs, then to Gupta, then to SQLBase 9.0.1, then 
click SQLTalk Interactive SQL.

3. From the Session menu, click Connect, or press F2.

4. Enter the database name, username and password for your database. The default user 
name is ENTEK, and the default password is EUSER. 

5. Click Connect. Your database name should appear in the Current Connections box.

6. Click Close to close the Connect dialog. 

The name of the directory that contains the SQLTalk database has changed from Centura to 
Gupta. The new database directory for Gupta SQLBase 9.0.1 is \Program 
Files\Gupta\SQLBase901.

The default database directories are:

C:\Program Files\Gupta>SQLBase901\Econfig

C:\Program Files\Gupta>SQLBase901\Entek
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7. In the Input Window (top pane), type the following, including the semicolon:

check database;

8. Press Shift+F2 to execute the command. If the check is successful, SQLTalk displays 
the message:

DATABASE CHECKED

If any other message appears, your database may be corrupt. Contact Customer 
Support immediately for assistance. Repeat these steps for the Econfig database.

9. Type the following in the Input window (top pane), including the semicolon:

Update statistics on database;

10. Press Shift+F2 to execute the command. After SQLTalk executes the command, it 
displays a message similar to this one depending on the number of rows in your 
database:

STATISTICS UPDATED ON 13,443 ROWS

11. Repeat this command on the Econfig database. After the Update Statistics command is 
finished, select File > Exit to exit SQLTalk.

12. Shut down the SQLBase engine (locally for single-user systems and at the server for 
multi-user systems).

13. Back up the database subdirectories with your own backup software, or copy the 
subdirectories to a network drive that is backed up. After backing up the database 
directories, simply restart Emonitor (on single-user installations). For multi-user 
installations, you must restart the database engine software before launching 
Emonitor.

14. Remember to rotate the storage media (tapes or disks) in order to ensure that you have 
at least one good previous backup set aside. This will help prevent the accidental 
overwriting of the previous good backup with a bad one. A recommended back up 
strategy would be to create separate tapes or disks that are used for annual, quarterly, 
monthly and weekly backups.

Using the correct storage media for your data

To help prevent database corruption, do not run your database from removable storage 
media such as Zip, JAZZ, Bernoulli, SyQuest, or SuperDISK drives. These removable 
storage devices are excellent for backing up or copying databases, but are not suited to the 
constant I/O requirements of the database engine.
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Adding a new database

You may want to add another database to your system. You can use one Econfig database 
for your configuration data and have multiple other databases for storing data similar to 
the Entek database.

Add the SQLBase server to the SQLConsole display

You only have to follow this procedure once to add the server to the SQLConsole display. 
If the server name appears in the SQLConsole display, you can skip these steps. The 
default server name is SERVER1.

1. Start the Gupta SQLBase server if it is not running. Select Start > Programs > Gupta 
> SQLBase 9.0.1 > SQLBase Database Engine.

2. Start the SQLConsole by selecting it from Start > Programs > Gupta > SQLBase 
9.0.1 > SQLConsole DBA Utility.

3. The first time you run the SQLConsole, a message appears:

Select No to run in Enhanced mode.

4. Click Yes at the next dialog to create a local SQLConsole database.

5. Click Yes at the next dialog to use the default database name (SQLSCRVR), and leave 
the password blank.

Before you add a new database, you must restart your computer at least once since you installed 
Emonitor, in order to restart the Gupta SQLBase server.
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6. The SQLConsole appears. Double click Tools, and then double-click Connection 
Manager.

7. In the Connection Manager dialog, enter the SQLBase server name, and then click 
OK. The default server name is Server1 (“server”, followed by the number 1).
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8. Exit and then restart SQLConsole.

9. The name of the SQLBase server appears in the tree below Tools.

Add the new database

If the SQLBase server name appears in the SQLConsole display, you can add a new 
database to the server.

1. Create a directory in the \Program Files\Gupta\SQLBase901 folder with the name for 
your database. You have to have a separate directory for each database.

2. Copy entek.dbs from the product directory (\extras\emonitor) on the Emonitor DVD 
into the new directory. The product directories are located in the Extras folder on the 
DVD. 

3. Right-click on the entek.dbs file on your computer and click Properties. Change the 
Attributes by clearing the Read-only checkbox. Click OK.
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4. Rename the entek.dbs file to the name of the directory. In this picture, the new 
database and directory are named Newtest.

5. Start the SQLConsole if it is not running (select Start > Programs > Gupta > 
SQLBase 9.0.1 > SQLConsole DBA Utility).

6. Right-click the server name in the SQLConsole display, and then select Manage 
Database > Install.

7. Enter the name of the new database that you created steps 1-4, and then click Install. 
The new database appears in the tree under the database server name.
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5 Troubleshooting

This chapter offers troubleshooting information for Emonitor installations.

Troubleshooting database connections

What version ODBC driver should I use?

Use Gupta SQLBase ODBC driver version 9.00.01 or later. The previous version does not 
work with this version of Emonitor.

Why am I getting a configuration file error? 

There could be several reasons for this type of error. Here is a list of potential fixes.

 Make sure that you have only one copy of SQL.INI on your computer.

 Make sure that the SQL.INI file has not been renamed or deleted.

 If you log in to your computer, make sure that you used the correct login name and 
password.

Why can’t I connect to the database?

If you cannot connect to databases after installing, ensure that your databases have been 
added to the server configuration and that they are enabled. See Adding a new database on 
page 34 for more information.

If you still can't connect to the database, check the SQL.INI file to make sure the line that 
says DBDIR=C:\Program Files\SQLBase901 actually points to the installed location of 
the SQLBase database. 
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Why can’t it find the ERROR.SQL file? 

If you get an error like this, check your path by typing PATH at an MS-DOS prompt. If 
your path does not contain the SQLBase program directory, Emonitor cannot find the 
needed database files. Also, check to make sure error.sql is in the SQLBase directory and 
has not been renamed. 

My other SQLBase programs cannot find the SQL.INI file.

The Emonitor installation program renames any SQL.INI, MESSAGE.SQL, or 
ERROR.SQL file that it finds in your path. If other SQLBase programs are affected by 
this, you must rename these other files before attempting to run the other program that 
uses SQLBase.

Do I add DBNTSRV to the Windows Firewall exceptions?

If you do not reboot after installing the SQLBase and Emonitor software, a message 
appears when you start Emonitor, asking if you want to add DBNTSRV to the Windows 
Firewall exceptions. In order for Emonitor to communicate with the database, you must 
allow DBNTSRV to be added to the exceptions list.

Troubleshooting during the installation

Client-server applications like Emonitor can be complicated. This section is provided to 
give you a guide if things don't go quite right the first time.

Do I have to install certain online components to certain 
computers?

No. The current Emonitor installation program installs all Emonitor components to each 
computer if you are using a multi-user version of Emonitor. The single-user version of 
Emonitor with SQLBase has all components on the same computer.
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Why can’t I run the Emonitor installation program on Windows 
2000, XP, or 7?

The current version of Emonitor cannot be installed or run on any version of Windows 
2000, Windows XP, or Windows 7 Home.

In order to install the program on a computer running Windows 7 Professional, Enterprise, 
or Ultimate, you have to have Administrator rights. You might have to ask your computer 
staff to give you administrator rights in order to install Emonitor.

What happens if the computer gets turned off in the middle of 
an installation?

If your computer crashes or gets turned off in the middle of the installation, the uninstall 
procedure will not work. Use these steps to complete the installation.

1. Remove the Emonitor DVD and reboot your computer.

2. After the computer reboots, insert the Emonitor DVD back in the DVD drive.

3. Begin the installation process again. When you see a dialog similar to the following, 
select Add or reinstall components. 

4. Follow the installation process as described in Chapter 2, Installing Emonitor.
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Troubleshooting FactoryTalk Activation

If you experience any problems with the FactoryTalk Activation, refer to the FactoryTalk 
Activation online help file, installed when you installed FactoryTalk Activation. Click the 
Windows Start button, then select Programs > Rockwell Software > FactoryTalk 
Activation > FactoryTalk Activation Manager, and then click Help in the FactoryTalk 
Activation Manager window.
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