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Emonitor Online Getting Results Guide User Manual

Important User Information
Read this document and the documents listed in the additional resources section about installation, configuration, and operation of this equipment before 
you install, configure, operate, or maintain this product. Users are required to familiarize themselves with installation and wiring instructions in addition to 
requirements of all applicable codes, laws, and standards.

Activities including installation, adjustments, putting into service, use, assembly, disassembly, and maintenance are required to be carried out by suitably 
trained personnel in accordance with applicable code of practice.

If this equipment is used in a manner not specified by the manufacturer, the protection provided by the equipment may be impaired.

In no event will Rockwell Automation, Inc. be responsible or liable for indirect or consequential damages resulting from the use or application of this 
equipment.

The examples and diagrams in this manual are included solely for illustrative purposes. Because of the many variables and requirements associated with 
any particular installation, Rockwell Automation, Inc. cannot assume responsibility or liability for actual use based on the examples and diagrams.

No patent liability is assumed by Rockwell Automation, Inc. with respect to use of information, circuits, equipment, or software described in this manual.

Reproduction of the contents of this manual, in whole or in part, without written permission of Rockwell Automation, Inc., is prohibited.

Throughout this manual, when necessary, we use notes to make you aware of safety considerations.

These labels may also be on or inside the equipment to provide specific precautions.

The following icon may appear in the text of this document.

WARNING: Identifies information about practices or circumstances that can cause an explosion in a hazardous environment, 
which may lead to personal injury or death, property damage, or economic loss.

ATTENTION: Identifies information about practices or circumstances that can lead to personal injury or death, property 
damage, or economic loss. Attentions help you identify a hazard, avoid a hazard, and recognize the consequence.

IMPORTANT Identifies information that is critical for successful application and understanding of the product.

SHOCK HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that dangerous 
voltage may be present.

BURN HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that surfaces may 
reach dangerous temperatures.

ARC FLASH HAZARD:  Labels may be on or inside the equipment, for example, a motor control center, to alert people to 
potential Arc Flash. Arc Flash will cause severe injury or death. Wear proper Personal Protective Equipment (PPE). Follow ALL 
Regulatory requirements for safe work practices and for Personal Protective Equipment (PPE).

Identifies information that is useful and can help to make a process easier to do or easier to understand.
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Preface

About This Publication This user manual provides information on how to start using your Emonitor® Online system. 
This manual gives a general overview of the Emonitor Online functions and helps you 
configure the online data collection. This manual does not cover the selection or installation of 
online data collection hardware or networks.

For complete information on all Emonitor features, tasks, and interface elements, see 
publication EMONTR-UM002 and the online help within the software (from the Help menu, press 
F1). See publication EMONTR-GR001 to familiarize yourself with and begin using Emonitor.

Use this manual if you use Emonitor Online to collect data from online systems. You must be 
familiar with:

• Microsoft Windows® operating systems
• Personal computers
• Predictive maintenance principles
• The hardware in your online system (Enwatch® units, XM® modules, Logix family of 

controllers)
• Computer and device networks (Ethernet, DeviceNet®, ControlNet®)

Use the feedback form that is packaged with your software to report errors and/or request 
information to be added in future editions of this manual.

Download Firmware, AOP, 
EDS, and Other Files 

Download firmware, associated files (such as AOP, EDS, and DTM), and access product release 
notes from the Product Compatibility and Download Center at rok.auto/pcdc.

Summary of Changes This publication contains the following new or updated information. This list includes 
substantive updates only and is not intended to reflect all changes.

Topic Page
Updated Emonitor Online 9
Updated About Emonitor 9
Updated Step 5 - Import the Data Into the Database 17
Updated Step 7 - Configure EmonitorScheduler to Import Data 23
Updated Step 8 - Configure EmonitorScheduler to Import Data 30
Updated Step 9 - Start Data Collection 31
Updated Step 6 - Configure EmonitorScheduler to Import Data 36
Added EmonitorEEM Utility 43
Rockwell Automation Publication EMONTR-GR002D-EN-E - January 2023 7
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Additional Resources These documents contain additional information concerning related products from Rockwell 
Automation. You can view or download publications at rok.auto/literature.

Resource Description
Emonitor 4.1 User's Guide User Manual, publication EMONTR-UM002 Provides guidance on how to use the Emonitor software.
Getting Results Guide, publication EMONTR-GR001 Provides guidance on how to get started using your Emonitor system. 

EtherNet/IP Network Devices User Manual, ENET-UM006 Describes how to configure and use EtherNet/IP™ devices to communicate on the 
EtherNet/IP network.

Ethernet Reference Manual, ENET-RM002 Describes basic Ethernet concepts, infrastructure components, and infrastructure features.

System Security Design Guidelines Reference Manual, SECURE-RM001
Provides guidance on how to conduct security assessments, implement Rockwell 
Automation products in a secure system, harden the control system, manage user access, 
and dispose of equipment. 

UL Standards Listing for Industrial Control Products, 
publication CMPNTS-SR002

Assists original equipment manufacturers (OEMs) with construction of panels, to help ensure 
that they conform to the requirements of Underwriters Laboratories.

American Standards, Configurations, and Ratings: Introduction to
Motor Circuit Design, publication IC-AT001

Provides an overview of American motor circuit design based on methods that are outlined 
in the NEC.

Industrial Components Preventive Maintenance, Enclosures, and Contact 
Ratings Specifications, publication IC-TD002

Provides a quick reference tool for Allen-Bradley industrial automation controls and 
assemblies.

Safety Guidelines for the Application, Installation, and Maintenance of 
Solid-state Control, publication SGI-1.1

Designed to harmonize with NEMA Standards Publication No. ICS 1.1-1987 and provides 
general guidelines for the application, installation, and maintenance of solid-state control in 
the form of individual devices or packaged assemblies incorporating solid-state 
components.

Industrial Automation Wiring and Grounding Guidelines, publication 1770-4.1 Provides general guidelines for installing a Rockwell Automation industrial system.
Product Certifications website, rok.auto/certifications. Provides declarations of conformity, certificates, and other certification details.

EtherNet/IP Network Devices User Manual, ENET-UM006 Describes how to configure and use EtherNet/IP devices to communicate on the EtherNet/IP 
network.
8 Rockwell Automation Publication EMONTR-GR002D-EN-E - January 2023

https://literature.rockwellautomation.com/idc/groups/literature/documents/um/emontr-um002_-en-e.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/gr/emontr-gr001_-en-e.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/um/enet-um006_-en-p.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/rm/enet-rm002_-en-p.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/rm/enet-rm002_-en-p.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/rm/secure-rm001_-en-p.pdf
https://rok.auto/literature
https://literature.rockwellautomation.com/idc/groups/literature/documents/rm/secure-rm001_-en-p.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/sr/cmpnts-sr002_-en-p.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/at/ic-at001_-en-p.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/td/ic-td002_-en-p.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/in/sgi-in001_-en-p.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/in/1770-in041_-en-p.pdf
https://rok.auto/certifications
https://literature.rockwellautomation.com/idc/groups/literature/documents/um/enet-um006_-en-p.pdf


Chapter 1

Introduction

Emonitor Online Emonitor® Online is a set of Windows® programs that provide complete data management for 
predictive maintenance services for online systems. Emonitor Online collects data from one or 
more instruments that continuously monitor your machinery and processes. The data is stored 
in the Emonitor database, which allows you to use the powerful Emonitor analysis tools to 
examine the data.

The system automatically collects data from permanently mounted transducers so workers do 
not regularly enter hazardous or uncomfortable places. In addition, the system collects data as 
often as desired (every minute if necessary). The Emonitor Online System can also import data 
from external OPC sources and make data available to other OPC clients.

Currently Emonitor Online can collect data from many different sources.
• Dynamix™ 1444 Online Dynamic Measurement modules
• Enwatch®
• Allen-Bradley® XM® modules and the XM Dynamic Measurement module 

(1440-DYN02-01RJ)
• OPC servers
• Allen-Bradley Logix family of controllers

About Emonitor This manual describes the main features of the Emonitor software relating to online data 
collection. 

• Database setup
• Scheduling, loading, and unloading lists and data from data collectors
• Overall and narrowband (spectrum) alarms, displaying the results with alarms in plots 

and reports
• OPC Server and Client modules
• XM/DYN Online Data for importing data from XM modules
• Anomaly frequency modeling
• Bearing fault frequency database
• Fault frequency identification (in plots and reports)
• Fault frequency downloading to portable data collectors
• Alarm screening and Intelligent Advisory capability
• Asset Health module with email and Emonitor gateways
• Intelligent Advisory Decision module
• Work tracking capability

You can use Emonitor and the Emonitor Online features to perform the following: 
• Configure the database to model your machinery and processes and to hold the data 

you collect from the online instruments. You can use templates that contain 
information about different types of machinery to configure your database quickly.

• Manually or automatically map data from the instruments to measurement definitions 
in the Emonitor database.
Rockwell Automation Publication EMONTR-GR002D-EN-E - January 2023 9



Chapter 1          Introduction
• Use the Online Data Management Console to manage data collection from permanently 
mounted instruments (Enwatch units, Logix controllers, and XM modules), and to collect 
and serve OPC data.

• Use all Emonitor data monitoring and analysis features, including alarms, reports, plots, 
calculated measurements, frequency items, rule sets, and intelligent advisories. See 
publication EMONTR-UM002 and the online help for more information.

• Use the EmonitorEEM Utility to manage data collection from Dynamix 1444 Online 
Dynamic Measurement modules.

System Overview A typical medium size installation has permanently mounted transducers at the desired 
locations that collect vibration, temperature, voltage, or other types of data. You connect the 
transducers to XM modules, Enwatch units, or Logix family of controllers. These instruments 
acquire, process, and buffer data from the transducers.

An unload station computer that connects to the instruments, collects this data at specified 
intervals. The unload station computer stores this data on disk in unload files, and then 
imports the unload files into the database on the database server computer.

View and analyze data at the viewing station computer. Periodically, the viewing station 
computer updates its screen with new data from the database. You can display plots and 
alarms, create lists and reports, and manage the database.

Figure 1 shows some hardware components of a basic Emonitor Online system. Your system 
can be smaller, or much larger. A single-user system can have the database and all programs 
running on one computer. More often, there are one or more viewing station computers, a 
separate database server computer, and one or more unload station computers.

Figure 1 - Basic Emonitor Online System

Protection 
Monitors
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Chapter 2

Get Started with Emonitor Online

Emonitor Online Emonitor® online makes it easy to build, collect, and store predictive maintenance data from 
online instruments. This manual describes the elements of the Emonitor Online interface, and 
covers the basic Emonitor Online functions of database configuration, online instrument 
connections, mapping online data to the Emonitor database, and data collection management.

Online data collection and analysis tasks are divided between Emonitor and the Online Data 
Management Console (ODMC).

• Use Emonitor to configure your database, and perform all data analysis and reporting.
• Use the Online Data Management Console to configure and control data collection from 

online instruments and OPC servers. Also use the ODMC to configure and control the 
Emonitor OPC server to provide data to other systems.

Starting Emonitor and the ODMC 

After you install Emonitor according to the installation guide, to start Emonitor, select the Start 
menu and navigate to Programs > Rockwell Software > Emonitor.

The Online Data Management Console (ODMC) controls the Emonitor Online features. To start 
the ODMC, use the Windows® search function to locate the Online Data Management Console.

Log In

Log in to Emonitor 

If Emonitor is configured to require login, the program displays the Log In dialog. Enter your 
user name and password.

Log In to the Online Data Management Console 

The ODMC requires that you use an administrator-level user name and password set in 
Emonitor to log in. Log in credentials can be the same as the ones you use to log in to 
Emonitor. For more information on user names and passwords, see publication
EMONTR-UM002 and online help.

Log Off 
• You can log off Emonitor without exiting the program. Select File > Log Off.
• Select the Log Out button to log off from the ODMC.

The ODMC does not provide tools for data collection from the Dynamix™ 1444 
online modules. The Emonitor EEM utility provides this capability, see 
EmonitorEEM Utility on page 43.

You use your own user name for login. Select File > Log In after Emonitor starts.
Rockwell Automation Publication EMONTR-GR002D-EN-E - January 2023 11

https://literature.rockwellautomation.com/idc/groups/literature/documents/um/emontr-um002_-en-e.pdf


Chapter 2          Get Started with Emonitor Online
Set Up the Database

Before you can use Emonitor to view and analyze data from online instruments, you must first 
configure your machinery in the Emonitor database. You can do this configuration in two 
ways, depending on the type of online instrument.

• You can manually configure the machines, locations, and measurement definitions in 
the database in Emonitor. This setup is necessary when you collect data from Enwatch® 
units, and OPC servers. See Quick Start - Configure Emonitor Online on page 13, 
publications EMONTR-GR001 and EMONTR-UM002, and the Emonitor online help.

• You can automatically create the measurement definitions at a pre-defined location in 
the database. This feature is an option when you collect data from XM® modules and the 
Logix family of controllers. You can also manually configure the database for data from 
these instruments. If you automatically create the measurement definitions, you must 
manually edit the collection specifications and other information.

Set Up Data Collection

These steps are described in Quick Start - Configure Emonitor Online on page 13.

Data Sources 

Next, configure one or more data sources. A data source is one of the data collection or data 
server programs the Online Data Management Console controls. These sources include 
Enwatch® Online Data, XM/DYN Online Data, and the Emonitor OPC client, and the Emonitor OPC 
server.

Data Source Configurations 

A data source includes a data source configuration that controls how and when data is 
collected from the online instruments. The data source configuration also controls how data is 
mapped to measurement definitions in the Emonitor database. For data from XM® modules 
and the Logix family of controllers, you can use the Auto Map feature to create the 
measurement definitions automatically in the Emonitor database.

Collect Data

After you configure your data sources, use the Online Data Management Console to start and 
stop data collection from online instruments. You can choose to start data collection manually, 
or you can have the ODMC automatically start data collection when Windows® starts. Finally, 
you configure the EmonitorScheduler to watch for unload files that contain the collected data. 
After the system starts to collect data, the EmonitorScheduler imports the data into the 
database.

Analyze Data

You can use the data analysis tools in Emonitor to view your data. These include many 
different types of plots and reports. See publications EMONTR-GR001 and EMONTR-UM002, and 
the Emonitor online help.
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The Online Data 
Management Console 

The Online Data Management Console has one window.

• Title bar - The title bar shows the name of the software (Online Data Management 
Console).

• Data source list - This area displays the data sources that you create in the ODMC. The 
Data Source List includes the data source name, the status (Editing, Started or 
Stopped), and the startup type (Manual or Automatic).

Quick Start - Configure 
Emonitor Online

This section explains how to perform these operations with Emonitor Online:
• Configure the Emonitor database for online data
• Create data sources in the Online Data Management Console
• Create data source configurations to control online data collection for each data source
• Start and stop online data collection
• Import online data into the Emonitor database

To use the quick start steps, select a function, then perform the quick start steps for that 
function. Detailed information on how to use the Online Data Management Console to create 
and manage data sources is available in the online help for the Online Data Management 
Console (press F1 in the Online Data Management Console).

Step 1 - Configure the Database for the Online System

Before Emonitor Online can store data from an online system, there must be measurement 
definitions in the Emonitor database to store the data. For most data sources in the Emonitor 
Online System, you must manually create the measurement definitions in the Emonitor 
program to configure the database.

• In general, configure one location for each permanently mounted transducer, and one 
measurement definition for each type of measurement collected from that transducer. 

• For the Emonitor OPC Client, configure one measurement definition for each OPC item 
or tag.

Title Bar

Data Source List

You can also create measurement definitions with Emonitor by auto-mapping XM 
measurements directly to existing locations in the Emonitor database (see Step 7 - 
Map Data to the Emonitor Database on page 29). You can also use auto mapping 
with measurements from the Logix family of controllers (see Step 7 - Map Data to 
the Emonitor Database on page 29).
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You must perform the following quick start steps in the Emonitor software before you can 
export data to the Emonitor database. These steps include configuring the machine hierarchy 
(the plant, train, and machine in the database) and a location for each transducer and 
measurement definition for each measurement.

For more information on how to install and use Emonitor, see Additional Resources on page 8.

Start the Emonitor Software 

To start the Emonitor program, select the Start button, then select Programs > Rockwell 
Software > Emonitor > Emonitor.

Create the Machine Hierarchy 

The Emonitor program supports up to six hierarchy levels. Our example uses three levels: 
Plant, train, and machine. To create a plant, train, and machine in Emonitor, complete 
step 1…step 7. If the machine hierarchy for the exported measurement data exists in the 
database, skip to the next step.

1. To open the Database window in Emonitor, select Window > Database and select the 
Database Setup view in the Select View dialog. The view shows the Hierarchy pane on 
the left and the Location pane on the right. You can select in a pane, then press F1 for a 
description of the pane.

2. To add a plant, select the disk icon in the Hierarchy pane, and press the Insert key. The 
cursor appears in a box next to a new hierarchy item at the bottom of the Hierarchy 
tree.

3. Type in the name of your new plant. For example, type Plant A, and press Enter.
4. Press Insert again to add a hierarchy item. Type in the name of your new train. For 

example, type Area 41, and press Enter.
5. To move the new train under the plant, press Ctrl+Right Arrow.

6. Press Insert again to add a machine under the new train, and type in the name of your 
new machine. For a motor-pump combination, type Pump #1, and press Enter.

7. To move the new machine under the new train, press Ctrl+Right Arrow. You have 
configured the hierarchy for your new machine.

For more information about hierarchy levels, see Additional Resources on page 8.

New Hierarchy Item
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Create locations 

Each location in the Emonitor database corresponds to a transducer attached to an online 
instrument. After you create a location in Emonitor, you can create measurement definitions 
that correspond to individual measurements (overall, speed, spectrum) from the online 
instrument.

To create a location:
1. Open the Database window if it is not open. Select Window > Database and then select 

the Database Setup view in the Select View dialog. The view shows the Hierarchy pane 
on the left and the Location pane on the right.

2. Select the desired machine in the Hierarchy pane. To expand the hierarchy level so you 
can view the machine, select the + signs.

3. In the Location pane, several columns describe the measurement. Double-click in the 
Location ID column and type the ID (for example, Mtr-OB-Horiz).

4. Press Tab, or double-click in the Position column. Type 1 for the first transducer 
position. Notice that other fields have default values in them, and the gray arrow in the 
first column indicates the active location.

5. Press Tab, or double-click in the Direction column, and select Horizontal for the 
transducer direction.

6. Press Tab, or double-click in the Category column, and select Standard Machine for the 
category.

7. Press Tab, or double-click in the RPM column, and type the running speed of the 
machine. For this example, you can type 1800.

8. Press Tab, or double-click in the Description column. You can leave this area blank or 
enter a brief description for the location.

Create measurement definitions 

In the Emonitor program, create one or more measurement definitions at each location.

A measurement definition describes how Emonitor collects and stores the data in the 
database. The measurement definition specifies the type of measurement, the units, various 
details about how to store the data, which measurement filter to apply, and so forth.

The following step 1…step 9 configure the first magnitude measurement definition for a 
motor-pump combination running at 1800 CPM with anti-friction bearings. You can configure 
multiple measurement definitions for a location, one type of measurement from that 
transducer.

1. Select Window > Database. Select the Measurement view. If you already have the 
Database window open, select View > Measurement.

2. Select the desired machine in the Hierarchy pane. To expand the plant or train so you 
can view the machine, select the + signs.

3. Select the desired location in the Location pane.
4. Double-click in the Data Type column in the Measurement Definition pane and select 

the data type. The data type must match the data type for the actual measurement. For 
more information, see the Mapping Rules topic in the online help for the data source.

In most cases, add one location for data from each transducer. For more 
information about locations, see the online help for the Emonitor program.

A measurement definition corresponds to an online instrument measurement 
(overall, speed, spectrum). The measurement definition data type and units must 
match the data type and units for the measurement. For some data sources, the 
measurement type and the signal detection (in the collection specification) must 
also match the actual measurement. For more information, see the Mapping Rules 
topic in the online help for the data source.
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5. Press Tab, or double-click in the Units column, and select the measurement units. 
Remember, the units must match the units for the actual measurement.

6. Press Tab, or double-click in the Collection column, and choose the collection 
specification for the measurement definition. For some data sources, the parameters 
in the collection specification and signal detection must match the parameters for the 
actual measurement. The other options are not required to map the measurement to 
the Emonitor measurement definition.

7. Press Tab, or double-click in the Filter column, and select the measurement filter. The 
filter must match that used for the actual measurement; however, this filter is not 
required to map the measurement to the Emonitor measurement definition.

8. Double-click in the Storage column, then select the storage specification. For example, 
Always/S026 saves the last 26 samples of data from this measurement on any condition 
(alarm or not). You can use the storage specification to control the amount of data in 
the database. See Understanding Emonitor Storage Specifications on page 18

.

9. When you are done configuring measurement definitions, you can close Emonitor, or 
leave it running when you return to Emonitor.

For more information about measurement definitions, see Additional Resources on page 8.

Step 2 - Start the Online Data Management Console

All Emonitor Online components are managed through the Emonitor Online Data Management 
Console. 

1. To start the Online Data Management Console, select the Windows Start button, and 
then select Programs > Rockwell Software > Emonitor > Online > Online Data 
Management Console.

2. Select Log In and enter an Administrator-level Emonitor user name and password 
(defined in Emonitor). You must log in if you want to add, edit, delete, start, or stop a 
data source in the Online Data Management Console. A data source is an Emonitor 
Online component that acquires data from either permanently mounted transducers or 
from an OPC server. You also use the Online Data Management Console to manage the 
Emonitor OPC Server.

Step 3 - Add and Configure a Data Source
1. In the Online Data Management Console, select New to add a data source. Select the 

type and enter a name for the data source, and then select OK.
2. Select the data source that you created, and select Edit to edit the data source 

configuration. The data source configuration controls how data is collected and written 
to unload data files. Each data source is described later in this Getting Results Guide:

• XM and XM DYN modules, see XM/DYN Online Data on page 27
• OPC data, see Emonitor OPC Client on page 33
• OPC server, see Emonitor OPC Server on page 39

Step 4 - Start and Stop Data Collection

In the Online Data Management Console, select the data source, and then select Start or Stop 
to start or stop the data source. You can also automatically start a data source by setting the 
Startup Type to Automatic. The ODMC automatically restarts the data source when the 
computer reboots

You can right-click the collection specification and select Edit to see the details of 
the collection specification. 

You can right-click the storage specification and select Edit to see the details of 
the collection specification. 
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.

Step 5 - Import the Data Into the Database

The EmonitorScheduler imports the data from the unload data files into the Emonitor 
database. You create Scheduler profiles to control how often data is imported from the unload 
files. The EmonitorScheduler service is disabled by default. To launch (run) scheduled tasks 
and import data, you must enable the EmonitorScheduler service. The Online Data 
Management Console does not control the EmonitorScheduler service; the EmonitorScheduler 
service runs as a Windows service.

To start the EmonitorScheduler service:

1. Select Start > Control Panel > Administrative Tools > Services.
2. Select Services (local) in the left side of the Services window.
3. Select EmonitorScheduler in the right side of the Services window.
4. The EmonitorScheduler Startup Type must be Automatic. If it is Manual or Disabled, 

right-click on EmonitorScheduler and select Properties. In the Properties dialog box, set 
Startup Type to Automatic, and then select OK.

5. The EmonitorScheduler Status must be Started. If it is Stopped, right-click on 
EmonitorScheduler and select Start.

To create the Scheduler profile
1. Start the EmonitorScheduler. Select Start > Programs > Rockwell Software > Emonitor > 

Utilities > Scheduler.
2. Select Add to create a Scheduler Profile.
3. Select or enter the information for each dialog box, and then select Next to go to the 

next dialog box. Press F1 or select Help for information about the fields in each of the 
dialog boxes.

After you complete step 1…step 3 to create the Scheduler profile, you do not need to do 
anything else. You can close the Scheduler. The EmonitorScheduler service runs in the 
background and automatically lunches each Scheduler profile at the correct time. If you want 
Scheduler to start using the new profile immediately, you must stop and then restart the 
EmonitorScheduler service.

You can find more information on how to configure Scheduler profiles in the 
EmonitorScheduler help. Start the Scheduler, and then select Help > Contents and Index.

Step 6 - View and Analyze Data in Emonitor

After the EmonitorScheduler has imported the data into the Emonitor database, you can use 
the Emonitor data analysis features to view and analyze your data. These features are 
described in publications EMONTR-GR001 and EMONTR-UM002, and the Emonitor online help.

The Emonitor OPC Server cannot be set to automatically started; instead, you must 
manually start the Emonitor OPC Server.

You must have Administrator privileges to start the EmonitorScheduler service.

We strongly recommend that you leave the Startup Type for the 
EmonitorScheduler as Automatic in the Services console. This setting starts the 
EmonitorScheduler service automatically when Windows starts.

Each Scheduler profile must have a unique name because Scheduler profiles are 
global to the Emonitor Online system. Disabling a Scheduler profile on one Unload 
Station disables it on all Unload Stations. Scheduler profiles are stored in the 
Emonitor database, not on the Unload Station computer.
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Understanding Emonitor 
Storage Specifications 

Since online systems can gather large amounts of data in relatively short time periods, data 
management is especially important. For example, you cannot control how often an individual 
measurement is exported from an XM module, but you can control how much data is stored.

For example, a spectrum measurement takes up much more space in the Emonitor database 
than an overall vibration measurement. You might want to save the overall vibration 
measurement every 30 minutes, but save a spectrum measurement from the same XM module 
only once every 4 hours. You might also want to keep the overall measurements for 3 months, 
but keep only the most recent 10 days of spectrum measurements.

You manage data by creating separate storage specifications for the different types of 
measurements. The storage specification controls how often data is stored, and how long that 
data is kept in the database. You can also configure running averages with the storage 
specification.

Suppose that you export data from the XM module every 30 minutes. You can configure the 
following two storage specifications:

• The first storage specification gathers data at frequent intervals and stores it for a 
longer period (the overall measurement in the previous example).

• The second storage specification gathers data at less frequent intervals and stores it 
for a shorter period (the spectrum measurement in the previous example).

The storage specification controls the storage, but not the collection interval from the 
instruments. You control the collection interval in Emonitor when you create the data source 
configuration.

1. To start the Emonitor program, select the Windows Start button, then select Programs > 
Rockwell Software > Emonitor > Emonitor.

2. Select Setup > Storage in the Emonitor program.
3. Select New in the Define Storage Specification dialog.
4. Select the parameters for the storage specification in the New Storage Specification 

dialog.

To use the new storage specification, double-click in the Storage column of the measurement 
definition pane and select the new storage specification.

For more information on the role of storage specifications in an Emonitor Online system, refer 
to the online help for the Online Data Management Console.

The collection interval that you set in Emonitor must be shorter than the storage 
interval you set in the Emonitor program. If the collection interval is longer than 
the storage interval, the system stores the same data repeatedly.
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Enwatch Online Data

Introduction The purpose of the Enwatch® Online Data Setup is to gather data from transducers that 
connect to Enwatch units and store the data in the Emonitor® database. This process includes 
mapping each transducer to a specific location in the Emonitor database, and each 
measurement to a specific measurement definition in the database. This chapter explains the 
steps to configure the Enwatch Online data source.

1. Use Emonitor to create a machine, a location and one or more measurement definitions 
for each transducer in the Emonitor database. See publications EMONTR-GR001 and 
EMONTR-UM002, and the online help for more information.

2. Use the Online Data Management Console to start and manage the Enwatch Online Data 
Setup program.

3. Use the Enwatch Online Data Setup to store the hardware settings of each Enwatch 
instrument in the database.

4. Use the Enwatch Online Data Setup to identify the location in the database for the data 
from the transducer (map the data from each transducer to a corresponding 
measurement definition in the database).

In a multi-computer system, the Emonitor program runs on the viewing station computer. The 
Enwatch Online Data Setup usually runs on the viewing station computer, but can also run on 
the unload station computer.

How Enwatch Online Data 
Works with Emonitor 

Enwatch units are Ethernet devices. You use Enwatch Online Data (which runs on a Microsoft® 
Windows®-based computer) to configure and monitor Enwatch units.

You also use Enwatch Online Data to map measurements from the instruments to 
measurement definitions in the Emonitor database. At defined intervals, Enwatch Online Data 
exports the mapped measurements from the instruments to unload files. The unload files are 
stored on the computer that hosts Enwatch Online Data. The EmonitorScheduler service then 
imports the measurements from the unload files into the Emonitor database. For more 
information on Emonitor Online systems, see Emonitor Online on page 9.
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Enwatch Online Data can only be started from the Emonitor Online Data Management Console. 
Both programs are installed with Emonitor. Detailed instructions for configuring an Emonitor 
Online System are available in the online help. Select Start > Programs > Rockwell Software > 
Emonitor > Online > Online Data Management Console, and then press F1.

Required Information

The required items for Enwatch Online Data are:
• You must know the Emonitor database connection information, including user name, 

and password for that database connection. These settings vary according to the 
database server that you use.

• You must know the location of the Enwatch units on your network.
• There must be measurement definitions in the Emonitor database to store the data. For 

more information on how to add measurement definitions to the Emonitor database, 
see Set Up the Database on page 12.

Enwatch Online Data Main 
Window

The Enwatch Online Data software has one main program window.

Explore Enwatch Online 
Data

The following sections discuss navigation through the Enwatch Online Data software:
• Title bar - The title bar shows the name of the software (Enwatch Online Data Setup). It 

also contains the name of the current window in the workspace if that window is 
maximized.

• Menu bar - You can open any menu by holding the Alt key and pressing the underlined 
letter in the menu name. For example, press Alt-v to display the View menu. You can 
also highlight a command and press F1 for more information.

• Toolbar - The Enwatch Online Data toolbar contains the toolbar buttons. Each button is 
a shortcut to a feature, which is also available from the menus.

Title Bar
Menu Bar

Toolbar

Instrument 
Hierarchy

Status Bar
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The following table lists the toolbar buttons and provides you with a brief description of 
the function of the button and its corresponding menu bar selection.

• Instrument hierarchy - This area displays the Enwatch instrument hierarchy.
• Right-click shortcut menus - To open a shortcut menu with tasks specific to the current 

selection, simply right-click the selection.

• Status bar - The status bar appears at the bottom of the Enwatch Online Data window. It 
displays a brief, context-sensitive help message. It also displays the database name. 
You can hide and show the status bar with View > Status Bar.

Quick Start - Configure 
Enwatch Online Data

Perform the following tasks to configure Enwatch Online Data to export data.
• Configure the Emonitor database to store data from the online instruments.
• Create a data source for Enwatch Online Data.

Button Description

Load the measurements to the currently selected instruments and start acquiring/unloading data.

Unload data from one channel of the selected instrument.

Unload data from the selected instruments.

Synchronize the clocks for the selected Unload Station or the Online System Root to the internal clock 
of the computer.

Refresh the screen with the latest information on the instrument status.

Delete the currently selected item.

Display the properties dialog for the selected item.

Print a report that contains information about the selected item.

Cut the selected item to the Clipboard.

Copy the selected item to the Clipboard.

Paste an item or items from the Clipboard into the Enwatch Online Data Setup window below the 
selected item.

Copy the configuration of one monitor to other monitors of the same type.
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• Select the Emonitor database.
• Configure the Enwatch module hardware for data collection. Configure the instruments 

and map each measurement to a measurement definition in the Emonitor database.
• Configure the EmonitorScheduler to import data.
• Start data collection.

To use the quick start steps, select a task and then perform the quick start steps for that task. 
For detailed information on tasks or on how to use specific dialog boxes in Enwatch Online 
Data, refer to the online help.

Step 1 - Configure the Emonitor Database 

You must create measurement definitions in the Emonitor database to store the data from the 
Enwatch monitors. See Set Up the Database on page 12 for the steps to configure the 
database.

Step 2 - Start the Online Data Management Console
1. To start the Online Data Management Console, select the Windows Start button, and 

then select Programs > Rockwell Software > Emonitor > Online > Online Data 
Management Console.

2. Select Log In and enter an Administrator-level Emonitor user name and password 
(defined in Emonitor).

Step 3 - Add and Configure the Data Source

You can create only one Enwatch data source on each Unload Station.
1. In the Online Data Management Console, select New to add a data source. Select the 

Enwatch Online Data type, enter a name for the data source, and then select OK.
2. Select the data source that you created, and select Edit to edit the data source 

configuration. This action starts the Enwatch Online Data Setup program.

Step 4 - Select the Emonitor Database 
1. In the Enwatch Online Data Setup program, select Hardware > Change Database.
2. Enter the database information. To display the help topic for the dialog, press F1.

Step 5 - Configure Enwatch Instruments 

Use the Enwatch Online Data Setup program to configure both the hardware and the data 
collection. Also map data from Enwatch Online data to measurement definitions in the 
Emonitor database. See step 1…step 12 to add an Enwatch unit. At any point, you can press F1 
to get more information from the online help for a command, dialog box, or window.

1. To add an instrument, select the desired level in the hierarchy.

2. Select Edit > Insert. The Insert Unload Station wizard appears.
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3. Select the correct Unload Station from the list in the Insert Unload Station dialog. To 
configure an Enwatch unit, select Enwatch Unload Station. Select Next to continue. 

4. To enter the Computer name, either by type in the exact name or select Browse to find 
it. To obtain the Computer name, you can go to the computer that acts as the Unload 
Station, right-click on My Computer, then select the Computer Name tab. You can enter 
a name in the Computer description field, which is for label information only. Select 
Finish to complete the task. The hierarchy now shows a new Enwatch Unload Station.

5. Next, insert Enwatch units under the newly created Unload Station. Select the Unload 
Station and select Edit > Insert. The Insert Enwatch Hardware wizard begins.

6. To insert one Enwatch unit, select Insert an Instrument in the Insert Enwatch Hardware 
dialog and then select Next to continue.

7. Select the type of Enwatch unit from the list. For this example, choose a 16 channel 
Enwatch. Select Next to continue.

8. Use the Enwatch setup dialog to configure each field for your Enwatch unit. Select Help 
for help on the fields.

9. To configure each channel of the Enwatch unit, select the Channel tab.
10. To display the Location Browser, double-click in the Machine or Location column. Then, 

use the + icons to expand the hierarchy and select the correct location in the Location 
Browser. These locations correspond to locations in your Emonitor database. If you 
have not already configured the locations, go to Emonitor to do so (see Set Up the 
Database on page 12). To close the Location Browser, select OK when you are finished.

11. The Channel column shows the machine and location you recently selected. To 
complete all 16 channels, repeat step 1…step 11. Select Next to continue, and select 
Finish when you are done.

12. Close the Enwatch Online Data Setup program.

Step 6 - Schedule Data Collection

You can schedule data collection for an unload station, instrument group, for instrument.
To set the data collection schedule for an unload station or group:

1. Select the unload station or group.
2. Select Control > Schedule.
3. Choose the start date and frequency for data collection.

To set the data collection schedule for an instrument:
1. Select the Enwatch units.
2. Select Hardware > Properties.
3. Adjust the start date and the frequency on the Schedule tab.

Step 7 - Configure EmonitorScheduler to Import Data

The following quick start steps apply to the EmonitorScheduler software. Enwatch Online Data 
exports data into unload files. EmonitorScheduler then imports the unload files into the 
Emonitor database.
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The Scheduler has two parts:
• The EmonitorScheduler service that runs in the background and launches (executes) 

the scheduled events (profiles). The EmonitorScheduler service must be running to 
execute scheduled events.

• The EmonitorScheduler program that allows you to create and edit profiles. This 
program does not have to be running for the EmonitorScheduler service to execute 
scheduled events.

Normally, the EmonitorScheduler service is installed when you install Emonitor, but it is 
disabled by default. If the service is disabled, or you have stopped it, you must restart the 
service if you want it to execute scheduled events and start automatically when you start 
Windows. The start and stop of the EmonitorScheduler program has no effect on the 
EmonitorScheduler service.

To start the EmonitorScheduler service:

1. Select Start > Control Panel > Administrative Tools > Services.
2. Select Services (local) in the left side of the Services window.
3. Select EmonitorScheduler in the right side of the Services window.
4. The EmonitorScheduler Startup Type must be Automatic. If it is Manual or Disabled, 

right-click on EmonitorScheduler and select Properties. In the Properties dialog box, set 
Startup Type to Automatic, and then select OK.

5. The EmonitorScheduler Status must be Started. If it is Stopped, right-click on 
EmonitorScheduler and select Start.

.

To create the Scheduler profile:
1. Start the EmonitorScheduler. Select Start > Programs > Rockwell Software > Emonitor > 

Utilities > Scheduler.
2. Select Add to create a Scheduler Profile.
3. Select or enter the information for each dialog box, and then select Next to go to the 

next dialog box. Press F1 or select Help for information about the fields in each of the 
dialog boxes.

The following examples use the default program directory. If you have changed the 
default program directory, substitute the Emonitor program directory path into the 
parameters. The EmonitorScheduler uses the DataFileDir and DataFiles path in the 
Source section of the odonline.edi file on the Unload Station computer to define the 
directory.

• Executable file: 
C:\Program Files (x86)\Rockwell Software\Emonitor\didaemon.exe

• Command line: 
C:\Program Files (x86)\Rockwell Software\Emonitor\odonline.edi

After you complete these steps to create the Scheduler profile, you do not need to do anything 
else. You can close the Scheduler. TheEmonitorScheduler service runs in the background and 

The EmonitorScheduler service must be running to import data into the Emonitor 
database from Emonitor.

You must have Administrator privileges to start the EmonitorScheduler service.

We strongly recommend that you leave the Startup Type for the 
EmonitorScheduler as Automatic in the Services console. This setting starts 
theEmonitorScheduler service automatically when Windows starts.

Each Scheduler profile must have a unique name because Scheduler profiles are 
global to the Emonitor Online system. If you disable a Scheduler profile on one 
Unload Station, the Scheduler profile is disabled on all Unload Stations. Scheduler 
profiles are stored in the Emonitor database, not on the Unload Station computer.
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automatically lunches each Scheduler profile at the correct time. If you want Scheduler to 
start using the new profile immediately, you must stop and then restart theEmonitorScheduler 
service.

You can find more information on the odonline.edi file and how to Scheduler profiles in the 
EmonitorScheduler help. Start the EmonitorScheduler, and then select Help > Contents and 
Index.

Step 8 - Start Data Collection 

The EmonitorScheduler service must be running to import data into the Emonitor 
database from Emonitor.
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XM/DYN Online Data

Introduction The purpose of the XM®/DYN Online Data is to gather data from transducers that connect to 
Allen-Bradley® XM modules and store the data in the Emonitor® database. This process 
includes mapping each transducer to a specific location in the Emonitor database, and each 
measurement to a specific measurement definition in the database. This chapter explains the 
steps to configure the XM/DYN Online Data data source.

1. Select the XM network configuration file. This file contains the configuration 
parameters for a network of XM modules, and defines which XM modules are available 
for data export. The file includes configuration information for the Ethernet network, 
the DeviceNet® network, the ControlNet® network, and the XM modules on the network. 
If there are no XM network configuration files, you must create one by configuring the 
networks and XM modules.

2. Configure networks and XM modules. Use the Enterprise Online Configuration Utility to 
create the XM network configuration file. Also use the Enterprise Online Configuration 
Utility program to configure XM modules, and to view data from XM modules.

3. Select the Emonitor database. XM/DYN Online Data exports data from XM modules to 
unload files, which then import into the selected Emonitor database.

Configure the Emonitor database. Before you can export data to a specific Emonitor database, 
you must configure that database to receive the data by creating a measurement definition 
for each XM module measurement you want to export.

4. After you configure the database, map each XM module measurement that you want to 
export to a specific measurement definition in the Emonitor database.

5. Configure the EmonitorScheduler to import data into the database. Emonitor exports 
XM module data to unload files. The EmonitorScheduler is responsible for importing the 
unload files from the Unload Station computer into the Emonitor database.

6. You can start and stop data collection from XM modules either manually or 
automatically when Windows® starts.

XM/DYN Online Data Main 
Window

The XM/DYN Online Data software has one main window:

You can also create measurement definitions in Emonitor by auto-mapping XM 
measurements directly to locations in the Emonitor database. This action adds 
one measurement definition for each measurement under the selected location.

Start the Enterprise Online 
Configuration Utility to 
configure XM modules and 
networks

Show/hide the message log

Select the XM network configuration 
file

Exit XM/DYN Online Data and return to 
the Online Data Management Console.

Map XM module 
measurements to the 
measurement definitions in 
the Emonitor database

Select the Emonitor 
database to receive the 
exported XM data The status bar shows the name of the 

current XM network configuration file

Current data source name and startup 
type from the Online Data 
Management Console
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Exploring XM/DYN Online 
Data 

This section discusses navigation through the XM/DYN Online Data software:
• Title bar - The title bar shows the program icon, the name of the software (XM/DYN 

Online Data), and the Minimize, Maximize, and Close buttons. 

To see the Control Menu, select the program icon on the title bar. The following items 
appear on the Control Menu:

• Status bar - The status bar displays the name and path to the selected XM network 
configuration file. The XM network configuration file defines the XM modules and 
networks that connect the XM modules to XM/DYN Online Data.

Quick Start - Configure XM/
DYN Online Data

Perform the following tasks when configuring XM/DYN Online Data to export data.
• Configure the Emonitor database to store data from the online instruments.
• Create a data source for XM/DYN Online Data.
• Select or create the XM network configuration file.
• Select the Emonitor database.
• Configure the XM modules and view data from the XM modules.
• Map each measurement to a measurement definition in the Emonitor database.
• Configure the EmonitorScheduler to import data.
• Start data collection.

To use the quick start steps, select a task and then perform the quick start steps for that task. 
For detailed information on tasks or how to use specific dialog boxes in XM/DYN Online Data, 
refer to the online help.

Step 1 - Configure the Emonitor Database 

You must create measurement definitions in the Emonitor database to store the data from the 
XM modules. See Set Up the Database on page 12 for the steps to configure the database.

Step 2 - Start the Online Data Management Console
1. To start the Online Data Management Console, use the Windows search function to 

navigate to the Online Data Management Console.

Item Description
Restore Disabled

Move Choose Move when you want to reposition the window on the desktop by using the arrow keys on 
the keyboard or the mouse.

Size Disabled

Minimize Choose Minimize when you want to shrink the window to a button on the Windows Taskbar. This 
action performs the same function as if you selected the Minimize button on the title bar.

Maximize Disabled

Close Choose Close when you want to exit the XM/DYN Online Data program. This action performs the 
same function as if you selected the Close button on the title bar.

About Choose About XM/DYN Online Data to display product name, version, and copyright information.
Release Notes Choose Release Notes to display the release notes for this version of the software.

Select for Control Menu CloseMaximizeMinimize

You can also create measurement definitions in Emonitor by auto-mapping XM 
measurements directly to existing locations in the Emonitor database. Emonitor 
automatically adds the measurement definitions under the selected location. See 
Step 7 - Map Data to the Emonitor Database on page 29.
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2. Select Log In and enter an Administrator-level Emonitor user name and password 
(defined in Emonitor).

Step 3 - Add and Configure the Data Source
1. In the Online Data Management Console, select New to add a data source. Select the 

XM/DYN Online Data type, enter a name for the data source, and then select OK.
2. Select the data source that you created, and select Edit to edit the data source 

configuration. This action starts the XM/DYN Online Data program.

Step 4 - Select the Emonitor Database 

The following quick start steps apply to the Change Database function in XM/DYN Online Data.

1. Select the Change Database button on the XM/DYN Online Data window.
2. Enter the database information. To display the help topic for the dialog box, press F1.

Step 5 - Select the XM Network Configuration File 

The following steps apply to the Assign XM Profile function in XM/DYN Online Data. If you have 
not created an XM network configuration file that describes your XM modules and networks, 
skip this step. 

1. Select the Assign XM Profile button on the XM/DYN Online Data window.
2. Select the XM network configuration file.

Step 7 - Map Data to the Emonitor Database 

The following quick start steps apply to the Emonitor Mapping function of XM/DYN Online Data. 
Once you have created the measurement definitions in the Emonitor database, you are ready 
to map data from the XM modules to the Emonitor database.

XM/DYN Online Data only checks for matching data type and units when mapping to Emonitor 
measurement definitions. See the online help for more information on how XM/DYN Online 
Data maps data to Emonitor measurement definitions.

1. Select the Emonitor Mapping button on the main XM/DYN Online Data window. This 
action starts the XM Data Export Wizard that guides you through the steps. These steps 
include setting the schedule for data collection to import into Emonitor. For more 
information, press F1 or select Help to display the help topic for the current dialog.

2. After you have mapped data from the XM module to the Emonitor database, close 
XM/DYN Online Data to return to the Online Data Management Console.

The first time that you run XM/DYN Online Data, it can display the Emonitor DB 
Setup dialog box so you can select the database. After you select a database, XM/
DYN Online Data starts with the same database that was selected when you closed 
the program. 

The first time that you run XM/DYN Online Data, it prompts you for the name of the 
new XM network configuration file. After you select an XM network configuration 
file, XM/DYN Online Data starts with the same file that was selected when you 
closed the program. 

You can also create measurement definitions in the database with XM/DYN Online 
Data by auto-mapping XM measurements directly to existing locations in the 
Emonitor database. XM/DYN Online Data automatically adds the measurement 
definitions under the selected location.
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Step 8 - Configure EmonitorScheduler to Import Data 

The following quick start steps apply to the EmonitorScheduler software. XM/DYN Online Data 
exports data into unload files. EmonitorScheduler then imports the unload files into the 
Emonitor database.

The Scheduler has two parts:
• The EmonitorScheduler service that runs in the background and launches (executes) 

the scheduled events (profiles). The EmonitorScheduler service must be running to 
execute scheduled events.

• The Scheduler that allows you to create and edit profiles. This program does not have to 
be running for the EmonitorScheduler service to execute scheduled events.

Normally, the EmonitorScheduler service installs when you install Emonitor, but it is disabled 
by default. If the service is disabled, or you have stopped it, you must restart the service if you 
want it to execute scheduled events and start automatically when you start Windows. The start 
and stop of the Scheduler has no effect on the EmonitorScheduler service.

To start the EmonitorScheduler service:

1. Select Start > Control Panel > Administrative Tools > Services.
2. Select Services (local) in the left side of the Services window.
3. Select EmonitorScheduler in the right side of the Services window.
4. The EmonitorScheduler Startup Type must be Automatic. If it is Manual or Disabled, 

right-click on EmonitorScheduler and select Properties. In the Properties dialog box, set 
Startup Type to Automatic, and then select OK.

5. The EmonitorScheduler Status must be Started. If it is Stopped, right-click on 
EmonitorScheduler and select Start.

To create the Scheduler profile:
1. Start the EmonitorScheduler. Select Start > Programs > Rockwell Software > Emonitor > 

Utilities > Scheduler.
2. Select Add to create a Scheduler Profile.
3. Select or enter the information for each dialog box, and then select Next to go to the 

next dialog box. Press F1 or select Help for information about the fields in each of the 
dialog boxes.

The following examples use the default program directory. If you have changed the 
default program directory, substitute the Emonitor program directory path into the 
parameters. The EmonitorScheduler uses the DataFileDir and DataFiles path in the 
Source section of the odonline.edi file on the Unload Station computer to define the 
directory.

• Executable file: C:\Program Files (x86)\Rockwell Software\Emonitor\didaemon.exe
• Command line: C:\Program Files (x86)\Rockwell Software\Emonitor\odonline.edi

The EmonitorScheduler service must be running to import data into the Emonitor 
database from Emonitor.

You must have Administrator privileges to start the EmonitorScheduler service.

We strongly recommend that you leave the Startup Type for the 
EmonitorScheduler as Automatic in the Services console. This action starts the 
EmonitorScheduler service automatically when Windows starts.

Each Scheduler profile must have a unique name because Scheduler profiles are 
global to the Emonitor Online system. If you disable a Scheduler profile on one 
Unload Station, the Scheduler profile is disabled on all Unload Stations. Scheduler 
profiles are stored in the Emonitor database, not on the Unload Station computer.
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After you complete these steps to create the Scheduler profile, you can close the Scheduler. 
The EmonitorScheduler service runs in the background and automatically lunches each 
Scheduler profile at the correct time. If you want Scheduler to start using the new profile 
immediately, you must stop and then restart the EmonitorScheduler service.

You can find more information on the odonline.edi file and how to configure Scheduler profiles 
in the EmonitorScheduler help. Start the EmonitorScheduler, and then select Help > Contents 
and Index.

Step 9 - Start Data Collection 

In the Online Data Management Console, select the XM/DYN Online Data data source, and then 
select Start to start data collection. Select Stop to stop the data source. You can also 
automatically start a data source by setting the Startup Type to Automatic. The ODMC 
automatically restarts the data source when Windows starts.

The EmonitorScheduler service must be running to import data into the Emonitor 
database from Emonitor.
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Emonitor OPC Client

Introduction The purpose of the Emonitor® OPC Client is to simplify the task of data importation that 
originates from any OPC server into an Emonitor database. Emonitor OPC Client saves the data 
to unload files that are imported into an Emonitor database on a scheduled basis by the 
EmonitorScheduler. The Emonitor OPC Client can run on any computer that connects through a 
network to the computer with the Emonitor database.

Emonitor OPC Client conforms to the OLE for Process Control (OPC) 2.04 Data Access 
standards. OPC is based on Microsoft® OLE technology and provides an industry standard 
mechanism to communicate and exchange data between clients and servers. A server is a 
producer of data in the exchange. An example is the RSLinx® OPC Server. A client is a 
consumer of data in the exchange. Examples include SCADA/HMI software and the Emonitor 
OPC Client. The OPC Foundation - a coalition of industrial/manufacturing companies of which 
Rockwell Automation, Inc. is a member - defines and manages the OPC standards.

This chapter explains the steps to configure the Emonitor OPC Client data source. This process 
includes mapping each OPC item to a specific measurement definition in the database.

1. Use Emonitor to create a machine, a location and one or more measurement definitions 
for each transducer in the Emonitor database. See Quick Start - Configure the Emonitor 
OPC Client on page 35. For more information, see publications EMONTR-GR001 and 
EMONTR-UM002, and the online help for more information.

2. Use the Online Data Management Console to start and manage the Emonitor OPC Client.
3. Use the Emonitor OPC Client to create a data source configuration. This configuration is 

a set of parameters that controls how to connect to the Emonitor database and the OPC 
server, what data to map from the server to the Emonitor database, and how often to 
save the data.

4. You can optionally monitor data in the Emonitor OPC Client.

In a multi-computer system, the Emonitor OPC Client usually runs on the Viewing Station 
computer, but can also be run on the Unload Station computer.

How the Emonitor OPC 
Client Works with Emonitor 

You use the Emonitor OPC Client to map measurements from OPC servers to measurement 
definitions in the Emonitor database. At defined intervals, the Emonitor OPC Client exports the 
mapped measurements from the OPC servers to unload the files. The unload files are stored on 
the computer that hosts the Emonitor OPC Client. The EmonitorScheduler service then imports 
the measurements from the unload files into the Emonitor database. For more information on 
Emonitor Online systems, see Emonitor Online on page 9.

The Emonitor OPC Client can only be started from the Emonitor Online Data Management 
Console. Both programs are installed with Emonitor. Detailed instructions for configuring an 
Emonitor Online System are available in the online help. Select Start > Programs > Rockwell 
Software > Emonitor > Online > Online Data Management Console, and then press F1.
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Required Information

The required items for the Emonitor OPC Client are:
• You must know the Emonitor database connection information, including user name, 

and password for that database connection. These settings vary according to the 
database server that you are using.

• You must know the OPC server name and type.
• There must be magnitude or numeric measurement definitions in the Emonitor 

database to store the data. For more information on how to add measurement 
definitions to the Emonitor database, see Set Up the Database on page 12.

Emonitor OPC Client Main 
Window

The Emonitor OPC Client has one main program window.

Exploring the Emonitor OPC 
Client 

The following sections discuss navigation through the Emonitor OPC Client:
• Title bar - The title bar shows the name of the software (Emonitor OPC Client). It also 

contains the name of the current window in the workspace if that window is maximized.
• Menu bar - You can open any menu by holding the Alt key and pressing the underlined 

letter in the menu name. For example, press Alt-v to display the View menu. You can 
also highlight a command and press F1 for more information.

• Console window - The Console window is the main part of the Emonitor OPC Client. It 
displays the current values of the OPC items when a check mark appears next to View > 
Item Data.

• Client Status window - The Client Status window displays events that have occurred in 
Emonitor OPC Client. It is included for diagnostic purposes. You can hide and show the 
Client Status window with View > Client Status. Hiding the Client Status window 
increases the size of the Console window.
You can drag the Client Status window to another location in the Console window by 
selecting the move handle.

• Status bar - The status bar appears at the bottom of the Emonitor OPC Client window. It 
displays a brief, context-sensitive help message. It also displays the database name, 
and the name of the current data source configuration. You can hide and show the 
status bar with View > Status Bar.
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Quick Start - Configure the 
Emonitor OPC Client 

You perform the following tasks when configuring the Emonitor OPC Client to export data:
• Configure the Emonitor database to store data from the online instruments
• Create a data source for Emonitor OPC Client
• Select the Emonitor database
• Configure Emonitor OPC Client to collect data from an OPC server. This step includes 

mapping each OPC item to a measurement definition in the Emonitor database.
• Configure the EmonitorScheduler to import data
• Start data collection

To use the quick start steps, select a task and then perform the quick start steps for that task. 
For detailed information on tasks or how to use specific dialog boxes in the Emonitor OPC 
Client, refer to the online help.

Step 1 - Configure the Emonitor Database 

You must create measurement definitions in the Emonitor database to store the data from the 
OPC server. See Set Up the Database on page 12 for the steps to configure the database.

Step 2 - Start the Online Data Management Console
1. To start the Online Data Management Console, select the Windows® Start button, and 

then select Programs > Rockwell Software > Emonitor > Online > Online Data 
Management Console.

2. Select Log In and enter an Administrator-level Emonitor user name and password 
(defined in Emonitor).

Step 3 - Add and Configure the Data Source 
1. In the Online Data Management Console, select New to add a data source. Select the 

OPC Client type, enter a name for the data source, and then select OK.
2. Select the data source that you created, and select Edit to edit the data source 

configuration. This action starts the Emonitor OPC Client.

Step 4 - Select the Emonitor Database 
1. In the Emonitor OPC Client, select File > New to create a data source configuration, or 

select File > Load to open an existing configuration.
2. If you open an existing configuration, select Setup > Settings. If you create a 

configuration, this dialog box appears automatically.
3. In the Setup dialog box, on the Database Setup tab, enter the database information. To 

display the help topic for the dialog, press F1.

Step 5 - Select and Map Data from the OPC Server 
1. On the OPC Parameter tab of the Setup dialog box, select the OPC server.
2. On the Data Map tab of the Setup dialog box, select the OPC items and map them to 

measurement definitions in the Emonitor database. The only valid data types in 
Emonitor that work with the Emonitor OPC Client are Numeric and Magnitude (without 
phase).

3. On the Options tab of the Setup dialog box, choose the options for data collection, 
including the schedule for regular data collection.

The only valid data types in Emonitor that work with the Emonitor OPC Client are 
Numeric and Magnitude (without phase).
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Step 6 - Configure EmonitorScheduler to Import Data 

The following quick start steps apply to the EmonitorScheduler software. Emonitor OPC Client 
exports data into unload files. EmonitorScheduler then imports the unload files into the 
Emonitor database.

The Scheduler has two parts:
• The EmonitorScheduler service that runs in the background and launches (executes) 

the scheduled events (profiles). The EmonitorScheduler service must be running to 
execute scheduled events.

• The Scheduler that allows you to create and edit profiles. This program does not have to 
be running for the EmonitorScheduler service to execute scheduled events.

Normally, the EmonitorScheduler service is installed when you install Emonitor, but it is 
disabled by default. If the service is disabled, or you have stopped it, you must restart the 
service if you want it to execute scheduled events and start automatically when you start 
Windows. The start and stop of the Scheduler has no effect on the EmonitorScheduler service.

To start the EmonitorScheduler service, you must have Administrator privileges.
1. Select Start > Control Panel > Administrative Tools > Services.
2. Select Services (local) in the left side of the Services window.
3. Select SchedulrSvc in the right side of the Services window.
4. The SchedulrSvc Startup Type must be Automatic. If it is Manual or Disabled, right-click 

on SchedulrSvc and select Properties. In the Properties dialog box, set Startup Type to 
Automatic, and then select OK.

5. The SchedulrSvc Status must be Started. If it is Stopped, right-click on SchedulrSvc and 
select Start. We strongly recommend that you leave the Startup Type for the 
SchedulrSvc as Automatic in the Services console. This action starts the 
EmonitorScheduler service automatically when Windows starts.

To create the Scheduler profile:
1. Start the EmonitorScheduler. Select Start > Programs > Rockwell Software > Emonitor > 

Utilities > Scheduler.
2. Select Add to create a Scheduler Profile.
3. Select or enter the information for each dialog box, and then select Next to go to the 

next dialog box. Press F1 or select Help for information about the fields in each of the 
dialog boxes.

The following examples use the default program directory. If you have changed the default 
program directory, substitute the Emonitor program directory path into the parameters. The 
EmonitorScheduler uses the DataFileDir and DataFiles path in the Source section of the 
odonline.edi file on the Unload Station computer to define the directory.

• Executable file: C:\Program Files (x86)\Rockwell Software\Emonitor\didaemon.exe
• Command line: C:\Program Files (x86)\Rockwell Software\Emonitor\odonline.edi

After you complete these steps to create the Scheduler profile, you do not need to do anything 
else. You can close the Scheduler. The EmonitorScheduler service runs in the background and 
automatically lunches each Scheduler profile at the correct time. If you want Scheduler to 
start using the new profile immediately, you must stop and then restart the EmonitorScheduler 
service.

The EmonitorScheduler service must be running to import data into the Emonitor 
database from Emonitor.

Each Scheduler profile must have a unique name because Scheduler profiles are 
global to the Emonitor Online system. If you disable a Scheduler profile on one 
Unload Station, the Scheduler profile is disabled on all Unload Stations. Scheduler 
profiles are stored in the Emonitor database, not on the Unload Station computer.
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You can find more information on the odonline.edi file and how to configure Scheduler profiles 
in the EmonitorScheduler help. Start the EmonitorScheduler, and then select Help > Contents 
and Index.

Step 7 - Start Data Collection 

In the Online Data Management Console, select the OPC Client data source, and then select 
Start to start data collection. Select Stop to stop the data source. You can also automatically 
start a data source by setting the Startup Type to Automatic. The ODMC automatically restarts 
the data source when Windows starts.

The Emonitor OPC Client appears as an icon in the system tray on the right side of the taskbar.

• To restore the Emonitor OPC Client, double-click the icon, or right-click the icon and 
select Restore. You can then use the File > Preview Data command to view the data 
transfer messages.

• To minimize the Emonitor OPC Client to a system tray icon, select File > Exit, or select 
the Close button in the upper right corner of the window.

• To stop the Emonitor OPC Client, select the OPC Client data source in the Online Data 
Management Console and select Stop.

You can have multiple instances of the Emonitor OPC Client running on one computer 
simultaneously. This function allows you to connect to multiple OPC sources.

Step 8 - Monitoring the Emonitor OPC Client 

You can view the status of communications between the Emonitor OPC Client and the OPC 
server. This information can be useful for problem diagnostics. You can monitor the following 
events and data.

• Client events
• OPC item data
• Server status
• Status of group parameters

While Editing a Data Source Configuration
1. If you are editing a data source configuration in the OPC Client, select File > Preview 

Data. The OPC Client connects to the OPC server, but does not import any data.
2. Display the Client Status window with View > Client Status. A check mark appears next 

to the command when the window is visible.
3. To view, and in some cases modify, the communications between the OPC server and 

the Emonitor OPC Client, use the commands on the View menu.

The EmonitorScheduler service must be running to import data into the Emonitor 
database from Emonitor.

When you restore the OPC Client from the system tray icon, the title bar includes 
the words Diagnostic View. This signal indicates that the OPC Client is running in 
the background and acquiring data.
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While the OPC Client is Running
1. Right-click the OPC Client icon in the System Tray and select Restore.
2. To view, and in some cases modify, the communications between the OPC server and 

the Emonitor OPC Client, use the commands on the View menu. You can also use the 
Server Status and Group Status commands on the right-click menu for the Emonitor 
OPC Client icon.
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Emonitor OPC Server

Introduction The purpose of the Emonitor® OPC Server is to enable an OPC-based client application to 
access values stored in an Emonitor database. These values include the archive data from the 
magnitude and numeric measurement definitions. The Emonitor OPC Server can run on any 
computer that connects through a network to the computer with the Emonitor OPC Server 
database.

Emonitor OPC Server conforms to the OLE for Process Control (OPC) 2.04 Data Access 
standards. OPC is based on Microsoft® OLE technology and provides an industry standard 
mechanism to communicate and exchange data between clients and servers. A server is a 
producer of data in the exchange. An example is the Emonitor OPC Server. A client is a 
consumer of data in the exchange. Examples include SCADA/HMI software and the Emonitor 
OPC Client. The OPC Foundation - a coalition of industrial/manufacturing companies of which 
Rockwell Automation, Inc. is a member - defines and manages the OPC standards.

This chapter leads you through the steps to configure the Emonitor OPC Server.
1. Use the Online Data Management Console to start and manage the Emonitor OPC Server.
2. Use the Emonitor OPC Server to create a data source configuration. This configuration 

is a set of parameters that controls how to connect to the Emonitor database, what 
data to make available, and how often to refresh the data.

3. You can optionally preview data in the Emonitor OPC Server.

In a multi-computer system, the Emonitor OPC Server usually runs on the Viewing Station 
computer, but can also be run on the Unload Station computer.

How the Emonitor OPC 
Server Works with Emonitor 

You use the Emonitor OPC Server to make data from the Emonitor database available to other 
OPC clients. This data can be collected as part of a walk-around predictive maintenance 
system, or collected by an Emonitor Online system. For more information on Emonitor Online 
systems, see Emonitor Online on page 9.

The Emonitor OPC Server can only be started from the Emonitor Online Data Management 
Console. Both programs are installed with Emonitor. Detailed instructions for configuring an 
Emonitor Online System are available in the online help. Select Start > Programs > Rockwell 
Software > Emonitor > Online > Online Data Management Console, and then press F1.

Required Information

The requirement for the Emonitor OPC Server is:
• You must know the Emonitor database connection information, including user name, 

and password for that database connection. These settings vary according to the 
database server that you are using.
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Emonitor OPC Server Main 
Window

Exploring the Emonitor OPC 
Server 

The Emonitor OPC Server window consists of the following parts:
• Title bar - The title bar contains the name of the program.
• Menu bar - The menu bar contains the menu commands. You can highlight a command 

and press F1 for more information. You can also highlight a command and press F1 for 
more information.

• Console window - The Console window is the main part of Emonitor OPC Server. It 
displays the current values of the OPC items when a check mark appears next to View > 
View Data

• Server Status window - The Server Status window displays events that have occurred in 
Emonitor OPC Server. It is included for diagnostic purposes. You can hide and show the 
Server Status window with View > Server Status. Hiding the Server Status window 
increases the size of the Console window.
You can drag the Server Status window to another location in the Console window by 
selecting the move handle.

• Status bar - The status bar appears at the bottom of the Emonitor OPC Server window. It 
displays a brief, context-sensitive help message. It also displays the database name 
and the name of the current data source configuration. You can hide and show the 
status bar with View > Status Bar.

Quick Start - Configure the 
Emonitor OPC Server 

You perform the following tasks when configuring the Emonitor OPC Server to serve OPC data:
• Create a data source for Emonitor OPC Server
• Select the Emonitor database
• Configure Emonitor OPC Server to serve data from the Emonitor database.
• Start serving data

To use the quick start steps, select a task and then perform the quick start steps for that task. 
For detailed information on tasks or on how to use specific dialog boxes in the Emonitor OPC 
Server, refer to the online help.

Step 1 - Start the Online Data Management Console
1. To start the Online Data Management Console, select the Windows® Start button, and 

then select Programs > Rockwell Software > Emonitor > Online > Online Data 
Management Console.
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2. Select Log In and enter an Administrator-level Emonitor user name and password 
(defined in Emonitor).

Step 2 - Add and Configure the Data Source 
1. In the Online Data Management Console, select New to add a data source. Select the 

OPC Server type, enter a name for the data source, and then select OK.
2. Select the data source that you created, and select Edit to edit the data source 

configuration. This action starts the Emonitor OPC Server.

Step 3 - Select the Emonitor Database 
1. In the Emonitor OPC Server, select File > New to create a data source configuration, or 

select File > Load to open an existing configuration.
2. If you open an existing configuration, select Setup > Settings. If you create a 

configuration, this dialog box appears automatically.
3. In the Setup dialog box, on the Database Setup tab, enter the database information. To 

display the help topic for the dialog, press F1.
4. To display the help topic for the dialog, press F1.

Step 4 - Select Data from the Emonitor Database 
1. On the OPC Item tab of the Setup dialog box, select the measurement definitions from 

the Emonitor database that you want to make available to OPC clients.
2. Edit the OPC item name. By default, the OPC item name is created from the 

measurement definitions name and a unique ID number.
3. On the Options tab of the Setup dialog box, choose the options to refresh data.

Step 5 - Start Data Service 

In the Online Data Management Console, select the Emonitor OPC Server data source, and then 
select Start to start serving data. Select Stop to stop the data service.

The Emonitor OPC Server appears as an icon in the system tray on the right side of the 
taskbar.

• To restore the Emonitor OPC Server, double-click the icon, or right-click the icon and 
select Restore. After the data service is started, the word Running appears in the lower 
right corner of the OPC Server program. When the OPC Server is visible and running, the 
following icon appears in the lower right corner of the program.

• To minimize the Emonitor OPC Server to a system tray icon, select File > Exit, or select 
the Close button in the upper right corner of the window.

• To stop the Emonitor OPC Server, select the OPC Server data source in the Online Data 
Management Console and select Stop.

Unlike the other data sources in an Emonitor Online system, the Emonitor OPC 
Server cannot be started automatically. The Emonitor OPC Server also shuts down 
if you log out of Windows, and does not automatically restart when you restart 
Windows.
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You can have only one instance of the Emonitor OPC Server running on a computer at a time.

Step 6 - Monitoring the Emonitor OPC Server 

You can view the status of communications between Emonitor OPC Server and the OPC client. 
This information can be useful for problem diagnostics. You can monitor the following events 
and data.

• Server events
• OPC item data

Editing a Data Source Configuration
1. If you are editing a data source configuration in the OPC Server, select File > Preview 

Data. The OPC Server connects to the Emonitor database, but does not serve any data.
2. Display the Server Status window with View > Server Status. A check mark appears next 

to the command when the window is visible.
3. To view the data, select View > View Data.

While the OPC Server is Running
1. Right-click the OPC Server icon in the System Tray and select Restore.
2. To view the communication status, use the commands on the View menu.

When you restore the OPC Server from the system tray icon, the title bar includes 
the words Diagnostic View. This signal indicates that the OPC Server is running in 
the background.
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EmonitorEEM Utility

Introduction The EmonitorEEM utility lets you import data from Dynamix™ 1444 online monitors into the 
Emonitor® database for trending and analysis. You can import data on either a scheduled 
interval or based on a triggered condition by monitoring a Boolean controller tag via OPC. This 
import configuration is known as an Extraction. EmonitorEEM lets you define many extractions 
to support many Dynamix 1444 modules.

The EmonitorEEM utility relies on the EmonitorDDM service to communicate with the Dynamix 
1444 modules via RSLinx® Classic.

Create Data Extraction in 
EmonitorEEM

When you create an Extraction, you are able to obtain data on either a Scheduled or Triggered 
basis.

With the Scheduled method, you can obtain data from either the Live Data buffers or the 
Demand Data buffers on Dynamix 1444 modules. Live Data Extraction uses the specific 
measurement configuration defined the Dynamix 1444 Logix Add-on Profile (AOP). Demand 
Data Extraction enables you to use the EmonitorEEM Extraction Wizard to specify various 
measurement parameters on-demand.

With the Triggered method, you can use a defined tag in Logix to act as a trigger that signals 
the EmonitorDDM service to collect data. This method allows you to use Logix to determine the 
specific conditions when data is collected. For example, you can set data to collect only when 
the machine is in a run state, or runs a specific process or material.

Launch EmonitorEEM 1. Confirm that the EmonitorDDM service is enabled and running.
2. From the Windows® Start menu, navigate to Rockwell Software® > EmonitorEEM (or use 

the Windows Search function to search EmonitorEEM).
3. When EmonitorEEM first opens, it displays any currently configured Extractions. To 

Stop/Start or create extractions: 
a. Select Log In. 
b. Sign in with any Emonitor admin-user credentials. Default Emonitor admin-user 

credentials are:
Username: admin 
Password: password

Emonitor user credentials are managed from within the main Emonitor application. To 
protect your Emonitor configurations, we recommend that you change the default 
admin/user credentials.

4. To open the Extraction Wizard, select New.
5. Specify the desired Collection Method: 

- Scheduled intervals (see Scheduled Data Collection on page 44)
- Triggered conditions (see Triggered Data Collection on page 47) 

The EmonitorDDM service is disabled on a default Emonitor installation. To use the 
EmonitorEEM utility, you must first enable and start the EmonitorDDM service.
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Scheduled Data Collection When you select the Scheduled collection method, you must choose to either collect data from 
the Live Data or Demand Data buffer. 

To select the Live Data Extraction:
1. Select one or more Dynamix 1444 modules from which to acquire.
2. Select the Dynamix 1444 channels and measurements that you want to collect.
3. Map the selected Dynamix 1444 measurements to Emonitor measurements.
4. Set an Unload Interval (minutes, hours, or days).
5. To begin data collection, save and start the Extraction.

To select the Demand Data Extraction:
1. Select one or more Dynamix 1444 modules from which to acquire.
2. Specify the desired measurement parameters for each channel.
3. Map the selected Dynamix 1444 measurements to Emonitor measurements (the Demand 

Data buffer only provides Spectrum and Time-Waveform data).
4. Set an Unload Interval (minutes, hours, or days).
5. To begin data collection, save and start the Extraction.

The EmonitorScheduler service must be enabled and started, and a data import profile must 
be configured in the Scheduler to process the unload files (.ulf) that the EmonitorDDM service 
produces.

Live Data Extraction
1. With the Collection Method set to Scheduled and the Dynamix 1444 Buffer set to Live 

Data Extraction, either Select new devices in the next screen (default), or Start with 
existing devices.

2. Select Next.
3. The Select Devices dialog shows the RSLinx Classic RSWho tree that displays the 

currently defined Communications Drivers. Navigate to your Dynamix 1444 modules and 
add one or more to the device list. To add modules, either double-click the modules one 
at a time, or single-click each selection and then Add Device.

- You can optionally remove previously selected modules from the device list by 
selecting the Remove Device button.

- To provide an easy-reference name to each module (instead of the default IP 
address), use the Rename Device button. This option writes an entry to an XML file 
that the EmonitorRTA utility shares, so modules with easy-reference names are also 
selected there if they are renamed during the EmonitorEEM configuration.

4. Select Next.
5. In the leftmost column of the Map Devices dialog, select the Modules, Channels, or 

Measurements you wish to collect data from. 
Selecting a parent-level object auto-selects all child objects beneath that parent object.

If you are unable to browse to your Dynamix 1444 modules, you must add the 
appropriate driver from the RSLinx application-mode interface. 

To proceed with your Live Data Extraction, your Dynamix 1444 modules must 
be online with RSLinx Classic.
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6. In the center column, select the appropriate Machine, Location, or Measurement object 
from the hierarchy tree where you want the Dynamix 1444 data to be mapped. 

7. Select either:
- Map (if the measurements exist in the Emonitor hierarchy)
- Auto Map (to create the location and/or measurements automatically under the 

selected hierarchy item)
The resulting mapped items show in the far right-hand column. Repeat the mapping 
procedure as necessary.

8. Select Next.
9. From the Phase Settings dialog, you can optionally select whether to store Phase data 

on a channel-by-channel basis. 

10. Select Next.
11. In the resulting Extraction Info dialog, set the desired Extraction Interval. 

12. Select Save Extraction and assign a name. Use a descriptive name for each Extraction 
that you create, as this name also shows in the EmonitorEEM Extraction list.

13. Select Save to create your Extraction. If the name you provide is already in use, you are 
prompt to overwrite an existing extraction.

14. Select Finish to return to the main EmonitorEEM interface.
15. To begin data collection with this Extraction, confirm that it is selected in the Extraction 

list, then select Start.

Demand Data Extraction
1. With the Collection Method set to Scheduled and the Dynamix 1444 Buffer set to Demand 

Data Extraction, either Select new devices in the next screen (default), or Start with 
existing devices.

2. Select Next.
3. The Select Devices dialog shows the RSLinx Classic RSWho tree, which displays the 

currently defined Communications Drivers. Navigate to your Dynamix 1444 modules and 

IMPORTANT • When you use the Auto Map option, only specify a Machine-level 
Emonitor object to map to; the Auto Map auto-creates the 
Location and Measurement objects for you. 

• When you use the Map option, you can only select and map one 
measurement at a time; you must first manually create a 
compatible measurement in Emonitor for that purpose. 

To refresh the Emonitor hierarchy list, right-click in the middle pane and 
select Reload Database. This action is helpful if you add new Emonitor 
hierarchy objects after the Extraction Wizard - Map Devices dialog opened.

Phase data requires an additional Dynamix 1444 module configuration.

IMPORTANT Use caution when you set the Extraction Interval, as short 
intervals can quickly overwhelm a vibration database, which 
results in severe performance degradation or system crashes. 
Common Extraction Intervals are: 1 Day, 12 hours, 6 hours, 1 hour 
(minimum 15 minutes). When online data collection is populating 
a vibration database, always properly configure Emonitor 
measurement Storage Limits and the necessary automated 
processes to enforce them. See publication EMONTR-UM002 for 
additional information. 
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add one or more to the device list. To add modules, either double-click the modules one 
at a time, or single-click each selection and then Add Device.

- To remove previously selected modules from the device list, select the Remove 
Device button.

- To rename the modules, select Rename Device. We recommend you provide an 
easy-reference name to each module instead of the default IP address. This action 
writes an entry to an XML file that the EmonitorRTA utility shares. If you rename 
modules during the EmonitorEEM configuration, the new name is also selected in the 
XML file.

4. Select Next.
5. In the Demand Acquisition Settings dialog, the default setting collects both Waveform 

and FFT data for each channel. Optionally, you can change the setting and only select 
specific measurements and channels.
To simplify channel configuration, set the specific measurements and parameters for 
one channel, then use the far right-hand column to copy that channel configuration to 
the other channels.

6. Select Next.
7. In the leftmost column of the Map Devices dialog, select the Modules, Channels, or 

Measurements from which you wish to collect.

8. In the center column, select the appropriate Machine, Location, or Measurement object 
from the hierarchy tree where you want the Dynamix 1444 data to be mapped. 

9. Select either:
- Map (if the measurements exist in the Emonitor hierarchy)
- Auto Map (to create the location and/or measurements automatically under the 

selected hierarchy item)
The resulting mapped items show in the far right-hand column. Repeat the mapping 
procedure as necessary.

10. Select Next.
11. From the Phase Settings dialog, you can optionally select whether to store Phase data 

on a channel-by-channel basis.

12. Select Next.

If you are unable to browse to your Dynamix 1444 modules, you must add the 
appropriate driver from the RSLinx application-mode interface. 

To proceed with your Live Data Extraction, your Dynamix 1444 modules must 
be online with RSLinx Classic.

When you select a parent-level object, all child objects auto-select beneath 
that parent object.

Demand Data only provides Spectrum and Waveform measurement options.

IMPORTANT • When you use the Auto Map option, only specify a Machine-level 
Emonitor object to map to; the Auto Map auto-creates the Location 
and Measurement objects for you. 

• When you use the Map option, you can only select and map one 
measurement at a time; you must first manually create a 
compatible measurement in Emonitor for that purpose. 

To refresh the Emonitor hierarchy list, right-click in the middle pane and 
select Reload Database. This action is useful when you add new Emonitor 
hierarchy objects after the Extraction Wizard - Map Devices dialog opens.

Phase data requires an additional Dynamix 1444 module configuration.
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13. In the resulting Extraction Info dialog, set the desired Extraction Interval. 

14. Select Save Extraction and assign a name. Use a descriptive name for each Extraction 
that you create, as this name shows in the EmonitorEEM Extraction list.

15. To create your Extraction, select Save. If the name that you provide has already in use, 
you are prompt to overwrite an existing extraction.

16. To return to the main EmonitorEEM interface, select Finish.
17. To begin data collection with this Extraction, select the Extraction in the Extraction list, 

then select Start.

Triggered Data Collection To select the Triggered collection method:
1. Specify a local or remote RSLinx Classic OPC server and one or more trigger tags, which 

act as signals for the EmonitorDDM service to begin data collection.
2. Select one or more Dynamix 1444 modules from which to acquire data.
3. Select the Dynamix 1444 channels and measurements that you want to collect.
4. Map the selected Dynamix 1444 measurements to Emonitor measurements.
5. Create one or more triggers and assign one or more corresponding tags to these 

triggers.
6. Select whether to collect data on a scheduled interval, or only one collection when the 

trigger condition is True.
7. Save and start the Extraction to begin data collection.

The EmonitorScheduler service must be enabled and started, and a data import profile must 
be configured in the Scheduler to process the unload files (.ulf) that the EmonitorDDM service 
produces.

1. Sign in to the EmonitorEEM utility.
2. To open the Extraction Wizard, select New.
3. Select Triggered as the Collection Method option. The Demand Data Extraction is now 

unselectable, as the Triggered collection can only access the Live Data buffer.
4. In the Use Devices From section at the bottom of the screen, choose Select new devices 

in the next screen (default), or Start with existing devices.
5. Select Next.
6. In the OPC Parameter Settings dialog:

a. Enter the Computer Name for the RSLinx OPC Server where your Trigger Tags are 
served. This field is optional when the RSLinx OPC Server runs on the local 
workstation. 

b. In the Server Name field, use the Select button to designate the Remote RSLinx OPC 
Server, if appropriate.

IMPORTANT Use caution when setting the Extraction Interval, as short 
intervals can quickly overwhelm a vibration database, which 
results in severe performance degradation or system crashes. 
Common Extraction Intervals: 1 Day, 12 hours, 6 hours, 1 hour 
(minimum 15 minutes). When online data collection is populating 
a vibration database, always properly configure Emonitor 
measurement Storage Limits and the necessary automated 
processes to enforce them. See Understanding Emonitor Storage 
Specifications on page 18 for additional information. 

IMPORTANT If you use a Remote RSLinx OPC Server, confirm that the 
Windows User account you use on the EmonitorEEM workstation 
has a valid matching Windows Local User account or Domain 
account on the Remote RSLinx OPC Server. If this configuration is 
not done, the EmonitorDDM service is unable to monitor remote 
OPC Trigger Tags successfully and additional Windows and DCOM 
configuration is necessary.
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c. For OPC Topic, use the Select button that corresponds to the appropriate OPC Topic 
where you find your Trigger Tags. If this selection list is blank, your OPC Server is not 
running and/or requires additional configuration to enable topic browsing.

d. For the ACD file, select Browse to navigate to the Logix ACD project file with the 
defined Trigger Tag instructions. The Logix Designer application Tag Import process 
immediately imports the compatible Boolean tags from the ACD file for subsequent 
assignment later in the Triggered Extraction configuration. A Tags Imported 
successfully message displays when the process is complete.

e. Select OK to acknowledge the message and continue.

7. Select Next.
8. The Select Devices dialog shows the RSLinx Classic RSWho tree, which displays the 

currently defined Communications Drivers. Navigate to your Dynamix 1444 modules and 
add one or more to the device list. To add modules, either double-click the modules one 
at a time, or single-click each selection and then Add Device.

- You can optionally remove previously selected modules from the device list by 
selecting the Remove Device button.

- To provide an easy-reference name to each module (instead of the default IP 
address), use the Rename Device button. This option writes an entry to an XML file 
that the EmonitorRTA utility shares, so modules with easy-reference names are also 
selected there if they are renamed during the EmonitorEEM configuration.

9. Select Next.
10. In the leftmost column of the Map Devices dialog, select the Modules, Channels, or 

Measurements you wish to collect data from. 
Selecting a parent-level object auto-selects all child objects beneath that parent object.

11. In the center column, select the appropriate Machine, Location, or Measurement object 
from the hierarchy tree where you want the Dynamix 1444 data to be mapped. 

IMPORTANT You must have the Logix Designer application locally installed for 
the Tag Import procedure to run successfully. Logix Designer 
does not require FT Activation for this function to complete 
successfully. The Logix Designer version must match the ACD file 
version for the Tag import process to properly execute.

The ACD file that you select to import tags from cannot be an open project 
in the Logix Designer application during the Tag Import. If the project is 
open, the Tag Import process shows an error message and fails to 
complete.

If you are unable to browse to your Dynamix 1444 modules, you must add the 
appropriate driver from the RSLinx application-mode interface. 

To proceed with your Live Data Extraction, your Dynamix 1444 modules must 
be online with RSLinx Classic.

IMPORTANT • When you use the Auto Map option, only specify a Machine-level 
Emonitor object to map to; the Auto Map auto-creates the 
Location and Measurement objects for you. 

• When you use the Map option, you can only select and map one 
measurement at a time; you must first manually create a 
compatible measurement in Emonitor for that purpose. 

To refresh the Emonitor hierarchy list, right-click in the middle pane and 
select Reload Database. This action is helpful if you add new Emonitor 
hierarchy objects after the Extraction Wizard - Map Devices dialog opened.
48 Rockwell Automation Publication EMONTR-GR002D-EN-E - January 2023



Chapter 7          EmonitorEEM Utility
12. Select either:
- Map (if the measurements exist in the Emonitor hierarchy)
- Auto Map (to create the location and/or measurements automatically under the 

selected hierarchy item)
The resulting mapped items show in the far right-hand column. Repeat the mapping 
procedure as necessary.

13. Select Next.
14. In the Trigger Setting dialog, enter a trigger name in the Name field. 
15. To browse for the tag that you wish to use, select the ellipsis button (…) to the right of 

the Tag field. The Trigger Tag Browser displays only Boolean tags to help keep the tag 
list short.

16. To confirm your tag selection, select OK.
17. For the Condition setting, select and set Trigger Collection Interval while the tag is True 

at the desired interval, or select Trigger Single Collection while the tag is True if you 
want one measurement sample for each True state condition.
For Trigger Single Collection, one sample is collected each time the associated trigger 
tag changes states from False to True.

18. To add your trigger configuration to the available triggers list, select the Create button. 
19. To add additional triggers, repeat step 14…step 18. 
20. Select Next.
21. In the resulting Bind Mapped items to Trigger dialog, select a defined Trigger from the 

left-hand Triggers list.
22. Select Add (enlarge the Extraction Wizard window to see the Add button near the bottom 

of the dialog box) to open the Mapped Item Browser selection box.
23. The Mapped Item Browser displays a list of all currently mapped measurements from 

step 10…step 12. Use Select All to bind the selected trigger to all available mapped 
measurements, or use the Shift or Ctrl keys to select specific measurements as needed.   

24. To confirm your selections, select OK. 
25. Repeat step 21…step 24 as required for additional triggers.
26. Select Next.
27. From the Phase Settings dialog, you can optionally select whether to store Phase data 

on a channel-by-channel basis. 

28. Select Next.
29. Select Save Extraction and assign a name. Use a descriptive name for each Extraction 

that you create, as this name shows in the EmonitorEEM Extraction list.
30. To create your Extraction, select Save. If the name that you provide has already in use, 

you are prompted to overwrite an existing extraction.
31. To return to the main EmonitorEEM interface, select Finish.
32. To begin data collection with this Extraction, select the Extraction in the Extraction list, 

then select Start.

When you begin an Extraction that is configured to monitor a remote RSLinx OPC Server, you 
must provide valid user credentials for the remote server before the start operation can 
complete for that Extraction.

Phase data requires an additional Dynamix 1444 module configuration.
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Manual/Automatic Startup By default, all new Extractions have a Manual startup type; if the EmonitorEEM workstation 
restarts, you must manually restart the Extractions again from the EmonitorEEM interface. 

You can optionally set an Extraction to use Automatic startup type; if the EmonitorEEM 
workstation restarts, the EmonitorDDM service automatically attempts to reinitiate data 
collection with that Extraction. 

IMPORTANT The Automatic startup type is not compatible with Extractions that are 
configured to monitor trigger tags on a remote RSLinx OPC Server; you 
must manually restart these Extractions after a workstation restart.
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