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Important user information 
Read this document and the documents listed in the additional resources section about installation, configuration, and operation of this 
equipment before you install, configure, operate, or maintain this product. Users are required to familiarize themselves with installation and 
wiring instructions in addition to requirements of all applicable codes, laws, and standards. 

Activities including installation, adjustments, putting into service, use, assembly, disassembly, and maintenance are required to be carried 
out by suitably trained personnel in accordance with applicable code of practice. If this equipment is used in a manner not specified by the 
manufacturer, the protection provided by the equipment may be impaired. 

In no event will Rockwell Automation, Inc. be responsible or liable for indirect or consequential damages resulting from the use or 
application of this equipment. 

The examples and diagrams in this manual are included solely for illustrative purposes. Because of the many variables and requirements 
associated with any particular installation, Rockwell Automation, Inc. cannot assume responsibility or liability for actual use based on the 
examples and diagrams. 

No patent liability is assumed by Rockwell Automation, Inc. with respect to use of information, circuits, equipment, or software described 
in this manual. 

Reproduction of the contents of this manual, in whole or in part, without written permission of Rockwell Automation, Inc., is prohibited. 

Throughout this manual, when necessary, we use notes to make you aware of safety considerations. 

 
WARNING: Identifies information about practices or circumstances that can cause an explosion in a hazardous environment, which may lead to 
personal injury or death, property damage, or economic loss. 

 
ATTENTION: Identifies information about practices or circumstances that can lead to personal injury or death, property damage, or economic 
loss. Attentions help you identify a hazard, avoid a hazard, and recognize the consequence 

Important: Identifies information that is critical for successful application and understanding of the product. 

Labels may also be on or inside the equipment to provide specific precautions. 

 
SHOCK HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that dangerous voltage may be 
present. 

 
BURN HAZARD: Labels may be on or inside the equipment, for example, a drive or motor, to alert people that surfaces may reach dangerous 
temperatures. 

 
ARC FLASH HAZARD: Labels may be on or inside the equipment, for example, a motor control center, to alert people to potential Arc Flash. Arc 
Flash will cause severe injury or death. Wear proper Personal Protective Equipment (PPE). Follow ALL Regulatory requirements for safe work 
practices and for Personal Protective Equipment (PPE). 

Allen-Bradley, Rockwell Software, Rockwell Automation, and TechConnect are trademarks of Rockwell Automation, Inc. 

Trademarks not belonging to Rockwell Automation are property of their respective companies. 
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Preface 

This getting results guide provides you with information on how to install 
and navigate the RSNetWorx™ for DeviceNet™ software. It explains how 
to effectively use the RSNetWorx for DeviceNet software and how to access 
and navigate the online help. 

We assume that you are familiar with: 

 Microsoft® Windows® operating systems 

 RSLinx® Classic™ communications software 

The Getting Results with RSNetWorx for DeviceNet guide can be considered 
the entry point into Rockwell Software’s documentation set for this product. 
Other components of the documentation set include online help, Online 
Books, and electronic release notes. 

The documentation set contains pertinent, easily accessible product 
information. This set ships with the software product, and is designed to free 
you from tedious paper shuffling and reduce information overload. 

The online help includes all overview, procedural, screen, and reference 
information for the product. The help contains these basic components: 
overview topics, quick start topics, step-by-step procedures, troubleshooting 
topics, and screen element descriptions (for example, text boxes, drop-down 
lists, and option buttons). All of the help is context-sensitive with the 
application and provides you with immediate access to application tasks and 
screen element descriptions. Refer to the "Finding the information you need" 
chapter in this guide for a more detailed description of the online help. 

Within RSNetWorx for DeviceNet, we provide a Product manuals feature 
that allows you to immediately access and search your product 
documentation from the Help menu. This feature includes the Getting Results 
with RSNetWorx for DeviceNet guide, as well as several hardware product 
reference guides, in an electronic book format. As a part of the product 
installation, you have the option of installing these electronic books to your 
local hard drive during installation, or access them directly from the 
installation files. 

Tip: The product manuals included with RSNetWorx for DeviceNet are in portable 
document format (PDF), and can be viewed using Adobe® Acrobat® Reader. 

 

If you cannot find the answer to your question in the documentation or on 
the Internet, contact Rockwell Automation Technical Support, using any of 
these methods: 

 Telephone: 1-440-646-3434 

Purpose of this document 

Intended audience 

How does the guide fit in 
with other Rockwell 
Software product 
documentation? 

Online help 

Product manuals 

Contact Rockwell 
Automation Technical 
Support 
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 Online: 
https://www.rockwellautomation.com/global/support/overview.page  

Support staff are available Monday to Friday from 8:00 a.m. to 5:00 p.m. 
local time (North America only), except on statutory holidays. 

Copyright notice 

Copyright © 2018 Rockwell Automation Technologies, Inc. All Rights 
Reserved. Printed in USA. 

This document and any accompanying Rockwell Software products are 
copyrighted by Rockwell Automation Technologies, Inc. Any reproduction 
and/or distribution without prior written consent from Rockwell Automation 
Technologies, Inc. is strictly prohibited. Please refer to the license agreement 
for details. 

End User License Agreement (EULA) 

You can view the Rockwell Automation End-User License Agreement 
("EULA") by opening the Rockwell_EULA_02102016_Final.pdf file located 
in your product's install folder on your hard drive. 

Open Source Licenses 

The software included in this product contains copyrighted software that is 
licensed under one or more open source licenses. Copies of those licenses are 
included with the software. Corresponding Source code for open source 
packages included in this product are located at their respective web site(s). 

Alternately, obtain complete Corresponding Source code by contacting 
Rockwell Automation via the Contact form on the Rockwell Automation 
website: 
http://www.rockwellautomation.com/global/about-us/contact/contact.page    
Please include "Open Source" as part of the request text. 

A full list of all open source software used in this product and their 
corresponding licenses can be found in the OPENSOURCE folder  included 
with this product's Release Notes respectively. The default installed location 
of these licenses is: 

 For RSNetWorx for ControlNet, C:\Program Files (x86)\Common 
Files\Rockwell\Help\RSNetWorx for ControlNet Release 
Notes\OPENSOURCE\index.htm. 

 For RSNetWorx for DeviceNet, C:\Program Files (x86)\Common 
Files\Rockwell\Help\RSNetWorx for DeviceNet Release 
Notes\OPENSOURCE\index.htm. 

 For RSNetWorx for EtherNet/IP, C:\Program Files (x86)\Common 
Files\Rockwell\Help\RSNetWorx for EtherNetIP Release 
Notes\OPENSOURCE\index.htm. 

Legal Notices 

https://www.rockwellautomation.com/global/support/overview.page
http://www.rockwellautomation.com/global/about-us/contact/contact.page
/usmkesrv7265/Publishing/PROD/IndividualPublishing/ZhaoRi/Word%20(Manuals)/Getting%20Results%20with%20RSNetWorx%20for%20DeviceNet/OPENSOURCE/index.htm
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Trademark Notices 

Advanced Interface Series, AdvanceDDE, Allen-Bradley, Arena, 
ControlLogix, ControlView, Data Highway Plus, Datapac, DH+, Emonitor, 
Emonitor Odyssey, Enlab, Enlube, Enpac, Enshare, Entrx, Enwatch, 
eProcedure, FactoryTalk, FactoryTalk Activation, FactoryTalk Activation 
Manager, FactoryTalk Administration Console, FactoryTalk Alarms and 
Events, FactoryTalk AssetCentre, FactoryTalk Audit, FactoryTalk 
Automation Platform, FactoryTalk Batch, FactoryTalk Diagnostics, 
FactoryTalk Directory, FactoryTalk Gateway, FactoryTalk Historian Classic, 
FactoryTalk Historian for Batch, FactoryTalk Live Data, FactoryTalk 
Metrics, FactoryTalk Portal, FactoryTalk ProductionCentre, FactoryTalk 
Scheduler, FactoryTalk Security, FactoryTalk Services Platform, 
FactoryTalk Transaction Manager, FactoryTalk View, FactoryTalk View 
Machine Edition, FactoryTalk View SE, FactoryTalk View Studio, 
GuardLogix, GuardPLC™, MicroLogix, MobileView, MotorMonitor, ODS, 
PanelBuilder, PanelView, PhaseManager, PlantLink, PLC-2, PLC-3, PLC-5, 
PowerMonitor, ProcessLogix, Propack Data, Rockwell Automation, 
Rockwell Software, RSAssetSecurity, RSBizWare, BatchCampaign, 
BatchHistorian, Historian, MaterialTrack, PlantMetrics, Scheduler, 
RSEnergyMetrix, RSLadder, RSLinx, RSLinx Classic, RSLinx Enterprise, 
RSLogix, RSLogix 5, RSLogix 500, RSLogix 5000, RSLogix Emulate, 
RSLoop Optimizer, RSMACC, RSNetWorx, RSNetWorx for ControlNet, 
RSNetWorx for DeviceNet, RSNetWorx for EtherNet/IP, RSOPC Gateway, 
RSPower, RSSql, RSTrend, RSTune, RSView, RSView32, SLC, SLC 500, 
SoftLogix, Studio 5000 Logix Designer, VersaView, WINtelligent, and XM 
are trademarks of Rockwell Automation, Inc. 

Any Rockwell Automation logo, software or hardware product not 
mentioned herein is also a trademark, registered or otherwise, of Rockwell 
Automation, Inc. 

Other Trademarks 

ActiveX, DirectX, Microsoft, SQL Server, Visual Basic, Visual C++, 
Windows, Windows NT, Windows Server, and Windows Vista are either 
registered trademarks or trademarks of Microsoft Corporation in the United 
States and/or other countries. 

Acrobat, Adobe, and Reader are either registered trademarks or trademarks 
of Adobe Systems Incorporated in the United States and/or other countries. 

CIP, ControlNet, DeviceNet, and EtherNet/IP are either registered 
trademarks or trademarks of the ODVA, Inc. in the United States and/or 
other countries. 

IBM is a registered trademark of International Business Machines 
Corporation. 

OPC is a registered trademark of the OPC Foundation. 
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Oracle and SQL*Plus are either registered trademarks or trademarks of 
Oracle Corporation in the United States and/or other countries. 

Intel, Intel Core, and Pentium are either registered trademarks or trademarks 
of the Intel Corporation in the United States and/or other countries. 

All other trademarks are the property of their respective holders and are 
hereby acknowledged. 

Warranty 

This product is warranted in accordance with the product license. The 
product’s performance may be affected by system configuration, the 
application being performed, operator control, maintenance, and other related 
factors. Rockwell Automation is not responsible for these intervening factors. 
The instructions in this document do not cover all the details or variations in 
the equipment, procedure, or process described, nor do they provide 
directions for meeting every possible contingency during installation, 
operation, or maintenance. This product’s implementation may vary among 
users. 

This document is current as of the time of release of the product; however, 
the accompanying software may have changed since the release. Rockwell 
Automation, Inc. reserves the right to change any information contained in 
this document or the software at any time without prior notice. It is your 
responsibility to obtain the most current information available from Rockwell 
when installing or using this product. 

Environmental compliance 

Rockwell Automation maintains current product environmental information 
on its website at 
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainabi
lity-ethics/product-environmental-compliance.page  

Contact Rockwell Automation 

Customer Support Telephone — 1.440.646.3434 

Online Support — http://www.rockwellautomation.com/support/  

 

http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/rockwellautomation/about-us/sustainability-ethics/product-environmental-compliance.page
http://www.rockwellautomation.com/support/


 

 Rockwell Automation Publication DNET-GR001K-EN-E - November 2018 9 

Chapter 1 

Welcome to RSNetWorx for DeviceNet 

RSNetWorx for DeviceNet is a 32-bit Windows application program that 
allows you to configure DeviceNet devices. Using a graphical or spreadsheet 
representation of your network, you can configure all devices on the network. 

This chapter contains the following sections: 

 Features and benefits 

 Understanding DeviceNet concepts 

 Exploring RSNetWorx for DeviceNet 

 Quick Start steps 

The current release of RSNetWorx for DeviceNet contains the following 
new features: 

 Support for SmartGuard EIP hardware. 

 Support for DeviceLogix version 5.18.01. 

 Support for third party DeviceNet scanners whose vendor IDs are not 
Rockwell. The third party DeviceNet scanner is supported if the EDS is 
licensed. Devices whose EDS are licensed and can pass the CRC 
License check are supported. 

 Support for Molex Safety slave device and any safety static 
configuration device. There are no parameters or assemblies you need 
to configure. The Configuration Signature field in the device Safety 
page is enabled, allowing you to set the proper value. For the static 
safety I/O device, you must configure the Configuration Signature field 
before you can setup the connection with a scanner. 

 DeviceLogix enhancements that include: 

Features 
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 Logic Enable and Logic Disable menu options for selected 
DeviceLogix devices that are online and for all DeviceLogix 
devices on a network. 

 Remember the last project folder when a project is opened or a 
new project is created. 

 Display a logic enabled or logic disabled state icon of a 
DeviceLogix device when the device is online. 

 The duplicate device name is no longer changed to an EDS product 
name. Instead the node address is added to the head of the base 
device name to make the new device name unique. 

The DeviceNet network is a control area network that logically connects 
input/output (I/O) devices to processors via DeviceNet scanners rather than 
directly to discrete I/O modules located in processor racks. Scanners reduce 
the burden placed on processors by handling all the I/O device management. 

Each DeviceNet network supports up to 64 nodes. The data rate and node 
address of all the devices connected to the network are user-configurable. 
Both the signal and the power wires are bundled in the same cable. Several 
different types of connectors are available. The signal lines are terminated at 
each end to insure that the line remains balanced. 

The topology of a DeviceNet network can be a drop line configuration 
(devices are connected to the network by drop lines and network taps), a 
trunk line configuration (devices are connected in a daisy chain fashion), or 
any combination of these configurations. For example, several devices could 
be daisy-chained together and then connected to the network via a network 
tap. 

The DeviceNet specification is maintained by ODVA, Inc. ODVA is an 
independent organization of product suppliers. For more information about 
ODVA products and services, visit their website at http://www.odva.org.  

Understanding DeviceNet 
concepts 

http://www.odva.org/
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When you start RSNetWorx for DeviceNet software, the RSNetWorx for 
DeviceNet window appears. It shows the current network (DeviceNet is the 
default name) in its view. The following illustration shows the RSNetWorx 
for DeviceNet window and the design elements associated with it. Each of 
the design elements are described in the sections following this illustration. 

 

The title bar shows the RSNetWorx icon, the name of the current 
RSNetWorx configuration, the name of the software product, and so on. 

The RSNetWorx for DeviceNet menu bar contains the following menus: 

 

Each menu contains options for performing the following tasks: 

Menu Description 

File Create, print, and save a network configuration, or exit RSNetWorx for DeviceNet. 

Edit Invoke actions such as cut, copy, and paste on selected items in the network configuration. 

View Set and change RSNetWorx for DeviceNet interface displays and access specialized tools. 

Network Choose browsing options, upload or download network information, view network properties, or enable 
or disable DeviceLogix devices that are online. 

Device Upload or download device information, resolve device mismatches, view device properties, or enable or 
disable DeviceLogix devices that are online. 

Diagnostics Start and stop diagnostics, add/remove devices from the diagnostic scan, select and troubleshoot a fault, 
specify diagnostic options, or generate a diagnostics report. 

Tools Access the EDS Wizard, the node commissioning tool, or the Faulted Address Recovery (FAR) wizard. 

Help View help options for RSNetWorx for DeviceNet and other Rockwell Software products and services. 

Exploring RSNetWorx for 
DeviceNet 

Title bar 

Menu bar 
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The toolbars contain shortcuts to several commonly used functions. Each 
button on the toolbars is a graphical representation of a command (except the 
Symbol Legend) that is also available from the RSNetWorx for DeviceNet 
menu bar. RSNetWorx for DeviceNet contains the standard toolbar and the 
tools toolbar. 

The following items appear on the RSNetWorx for DeviceNet standard 
toolbar. 

 

Icon Menu Selection Description 

 

File > New Creates a new network configuration. 

 

File > Open Opens an existing network configuration. The arrow to the right of the Open 
icon provides quick access to recently used files. 

 

File > Save Saves the current network configuration. 

 

File > Print Prints the current network configuration. 

 

Edit > Cut Cuts the selected device from the network configuration and place it on the 
clipboard. 

 

Edit > Copy Copies the selected device to the clipboard. 

 

Edit > Paste Pastes the device from the clipboard to the current network configuration. 

 

Help >  
What’s This? 

Places the cursor in What’s This? help mode. Place the cursor on the control 
you want help with and right-click to see the context-sensitive help. 

The following items appear on the RSNetWorx for DeviceNet tools toolbar. 

 

Icon Menu Selection Description 

 

View > Zoom-In Increases the size of the images located in the current network configuration. 
The choices available are high, medium, and low. Zoom-In only applies to 
the graph view. 

Toolbars 
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Icon Menu Selection Description 

 

View > Zoom-Out Decreases the size of the images located in the current network 
configuration. The choices available are high, medium, and low. Zoom-Out 
only applies to the graph view. 

 

View > Hardware Displays a list of all available hardware devices. 

 

View > Favorites Displays a list of hardware devices that you have added to your favorites list. 

 

Network > Single Pass 
Browse or Network > 
Continuous Browse 

Locates all currently available devices based on the drivers configured in 
RSLinx Classic. Allows you to browse once and stop (single pass) or browse 
continuously (continuous browse). 

 

Network > Online Places RSNetWorx for ControlNet in online mode. To go offline, click the 
button or choose Network > Online again. 

 

View > Diagnostics Displays the Diagnostic view, allowing you to view the diagnostic parameters 
for all of the devices on your network, and indicates the current diagnostic 
status of your network. 

 

View > Refresh Refreshes the window. This will reorder the graphic display by device 
address. 

 
No menu selection Displays the Symbol Legend, which contains descriptions of the device 

comparison states. 

 

Hardware and Favorites lists 
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A device can be added to the network configuration by selecting it from the 
Hardware view and dragging it to the Configuration view. Once a device is 
added, it will display in the appropriate configuration. The Favorites view 
displays all hardware devices that you have defined as favorites by selection 
from the Hardware list. 

 

Configuration view 
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The Configuration view displays network information in a graphical, 
spreadsheet, or master/slave form. For example, this graphical application 
workspace shows the devices that currently exist on the network. The 
Spreadsheet view of the configuration displays the names of all devices on 
the network along with state, node, slot, and description information. You 
can add a device to the project by selecting it from the Hardware view and 
dragging it into the configuration view. The Master/Slave Configuration 
view displays any scanner to target device relationships that exist among the 
devices in your current DeviceNet configuration. 

 

Diagnostics view 
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RSNetWorx Diagnostics provides a hierarchal view of the real-time status 
(or health) of a network. At a glance, you can quickly and easily determine 
the overall status of your network, or any device on your network, by 
viewing a single status indicator. Click the Diagnostics tab in the network 
configuration to display this view. 

 

The Message view, which appears in the bottom portion of the workspace, 
displays a log of messages. Each message consists of the following four 
parts: 

 an icon that indicates error, warning, or information. 

 an error code (including a distinguishing software component 
designator and a 16-bit numeric designator) 

 a timestamp that displays the date and time the message is generated 

 a description of the message 

Tip: If you want more information on any particular message, you can select the 
message and press the F1 key to access the online help. You can show, clear, copy, 
and/or clear and hide messages by making the appropriate selection from the 
View > Messages command on the main menu, or by right-clicking and selecting 
the Message option while in the Message view. 

 

The status bar, which is located at the bottom of the RSNetWorx for 
DeviceNet main window, provides information about the status of the 
software. 

The left portion of the status bar displays informational messages about the 
operation of RSNetWorx for DeviceNet software. For example when you 
highlight a device in the configuration view, a brief description of that device 
appears on the status bar. 

Message view 

Status bar 
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The right portion of the status bar displays the following: 

 Offline 

 Online - Not Browsing 

 Starting Browse... 

 Browsing - Node address or Node, slot address 

 

This section walks you through the tasks you will need to perform in order to 
use RSNetWorx for DeviceNet software. To remain focused on the 
high-level nature of each task and the flow of these tasks, the following steps 
do not include the step-by-step procedure for accomplishing each task. When 
you are ready to use RSNetWorx for DeviceNet software, you should follow 
the detailed procedures found in the Quick Start, which is located in the 
RSNetWorx for DeviceNet online help. 

To access the online quick start, select Help > Quick Start from the menu 
bar on the RSNetWorx for DeviceNet window. To view information about 
any control in the RSNetWorx for DeviceNet software, remember to use the 
What’s This? help (available by positioning the cursor over a control and 
right-clicking the mouse). 

Before you start 

Before you can add a device to a DeviceNet network, it may need to be 
commissioned. This means that the node address and the data rate must be 
programmed into the device. Node commissioning, which is also called 
device commissioning, is the process of assigning a node address and a data 
rate to a device for use on a DeviceNet network. The node address and data 
rate are referred to as the network parameters. 

Most DeviceNet devices are factory commissioned with default values per 
the DeviceNet specification. Usually, the node address is set to 63 and the 
data rate is set to 125K baud. As long as the factory default parameters do 
not conflict with those of other devices already on the network, you can 
connect the new device to the network and then use the Node 
Commissioning tool within the RSNetWorx for DeviceNet software to 
change the node address and data rate. If the data rate conflicts, use a 
separate network to commission the device or a local connection between the 
device and the PC. 

Some devices do not support software-based node commissioning. For those 
devices, the product will have some alternative way (for example, 
thumbwheel switches) to set the address and data rate. See the specific 
device’s documentation for more information. 

Quick Start steps 

Online mode 
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Step 1 – Create a new configuration and browse for an online network 

The first step in using RSNetWorx for DeviceNet in the online mode is to 
create a new DeviceNet configuration (by selecting File > New). Once you 
create the configuration, an empty network displays in the Configuration 
view. 

Next, go online and select a communications driver using the RSWho browse 
utility. A graphical representation of the network appears in the 
Configuration view. If you would like to see a tabular view of the 
information, select the Spreadsheet tab or the Master/Slave tab. 

Tip: At various times, you may want to save the work you have completed on your 
network configuration. To save a configuration file (*.dnt), click File > Save. 

Step 2 – Upload and configure the online DeviceNet network 

After creating your configuration and going online, you must upload the 
configuration of each device and the entire DeviceNet network. Once your 
configuration has been uploaded, you can then edit your network properties. 
Editing network properties includes entering a network name and 
description. 

Step 3 – Configure the DeviceNet devices 

After uploading and configuring the entire DeviceNet network, you must 
configure the devices on the network. To configure a device, select a device 
in the configuration view and choose Device > Properties from the main 
menu. Configuring your devices consists of tasks like: 

 configuring general device properties 

 editing and monitoring device parameters 

In addition you can also view I/O message data and the contents of the EDS 
file. 

As you configure each device, you may need to choose to upload from the 
device or download to the device before changing its configuration. This 
reconciliation process keeps the online device and the current configuration 
synchronized. When you are in online mode, the configuration displayed for 
the device represents the configuration in the online device. 

Step 4 – Configure the DeviceNet scanner 

When you have completed your device configuration(s), you can then 
configure the scanners on your DeviceNet network. To configure a scanner, 
select a scanner in the configuration view and choose Device > Properties 
from the main menu. Configuring your scanner includes advanced tasks like 
configuring a scanlist (a list of the devices that you want the scanner to scan), 
and mapping device input and output data. In addition, you may also want to 
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configure general device properties, specify module parameters (including 
scan-time related items), or view a summary of the scanner configuration. 

Step 5 – Save your network configuration 

The final step is to save your DeviceNet configuration information to a file. 
To save your configuration file (*.dnt), select File > Save. Your DeviceNet 
devices are now configured and ready to use. 

You can use the RSNetWorx for DeviceNet software to further customize 
your DeviceNet configuration. For example, you can re-assign node 
addresses, modify a device’s configuration, etc. And, when you are not using 
these applications to configure your network, you can use RSNetWorx for 
DeviceNet software to monitor and troubleshoot the devices on your 
network. For information on how to accomplish these tasks, see the 
comprehensive online help. 

Step 6 - Diagnose and troubleshoot your online network 

Once you save your configuration, you can diagnose the network and 
determine the status of all of the devices on that network. If any of the 
devices are exhibiting diagnostics problems, you can troubleshoot those 
devices and return your network to proper operating condition. 

Step 7 - Schedule network diagnostics 

After diagnosing and troubleshooting your online network, you can schedule 
diagnostics to occur for each network that has an associated offline 
configuration file (*.dnt) developed in RSNetWorx, allowing you to support 
an unattended, background mode of diagnostic operation. Further, via the 
RSNetWorx Diagnostics Service Monitor, you can start, stop, and establish 
the startup mode for each network diagnostic schedule that you have 
configured. 

Step 1 – Create a new configuration and describe your network topology 

The first step in using RSNetWorx for DeviceNet in the offline mode is to 
create a new DeviceNet configuration (by selecting File > New). Once you 
create the configuration, an empty network displays in the Configuration 
view. 

Next, describe your network topology by dragging a device or scanner from 
the Hardware view and dropping it in the network configuration. Repeat this 
process until you have defined your entire DeviceNet network in the 
software. If you would like to see a tabular view of the information, select 
the Spreadsheet tab or the Master/Slave tab. 

Offline mode 



Chapter 1 Welcome to RSNetWorx for DeviceNet 

 

20 Rockwell Automation Publication DNET-GR001K-EN-E - November 2018 

Tip: At various times, you may want to save the work you have completed on your 
network configuration. To save a configuration file (*.dnt), click File > Save. 

Step 2 – Configure the DeviceNet network 

After creating your configuration, you can edit your network properties. 
Editing network properties includes entering a network name and 
description. 

Step 3 – Configure the DeviceNet devices 

After configuring your DeviceNet network, you can configure the devices on 
the network. To configure a device, select a device in the configuration view 
and choose Device > Properties from the main menu. Configuring your 
devices consists of tasks like: 

 configuring general device properties 

 editing and monitoring device parameters 

In addition you can also view I/O message data and the contents of the EDS 
file. 

Step 4 – Configure the DeviceNet scanner 

When you have completed your device configuration(s), you can then 
configure the scanners on your DeviceNet network. Configuring your 
scanner includes advanced tasks like configuring a scanlist (a list of the 
devices that you want the scanner to scan), and mapping device input and 
output data. In addition, you may also want to configure general device 
properties, specify module parameters (including scan-time related items), or 
view a summary of the scanner configuration. 

Step 5 – Save your network configuration 

The final step is to save your DeviceNet configuration information to a file. 
To save your configuration file (*.dnt), select File > Save. Your DeviceNet 
devices are now configured and ready to use. 

You can use the RSNetWorx for DeviceNet software to further customize 
your DeviceNet configuration. For example, you can re-assign node 
addresses, modify a device’s configuration, etc. 

 



 

 Rockwell Automation Publication DNET-GR001K-EN-E - November 2018 21 

Chapter 2 

Installing and starting RSNetWorx for DeviceNet 

This chapter explains how to install and start RSNetWorx for DeviceNet 
software. This chapter includes information on the following: 

 system requirements 

 software compatibility 

 installation methods 

 installation procedure 

 starting procedure 

 troubleshooting 

After installing the software, we recommend that you read the release notes 
located in the online help. The release notes may contain more up-to-date 
information than was available when this document was published. To view 
the release notes, start RSNetWorx for DeviceNet, and then choose Help > 
Release Notes from the main menu. 

Before you can use RSNetWorx for DeviceNet software, you must install 
RSLinx Classic software. To ensure that you are using the most current and 
compatible version of RSLinx Classic, it is also included in the RSNetWorx 
for DeviceNet installation package. 

Tip: If the installation program encounters an incompatible and/or previous version of 
RSLinx Classic on your computer, it will notify you to install the version of RSLinx 
Classic included in the RSNetWorx for DeviceNet installation package. 

 

To run RSNetWorx for DeviceNet, your system must meet the following 
hardware and software requirements: 

To run RSNetWorx for DeviceNet, your system must meet the following 
hardware requirements: 

 An Intel® Core™ 2 Duo processor running at 2.8 GHz or faster or 
another processor with equivalent specifications 

 4 GB or more memory RAM 

 At least 16GB of available hard drive space 

Before you begin 

System requirements 

Hardware requirements 
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To run RSNetWorx for DeviceNet, you require one of the following 
operating systems:  

 Windows 10 Enterprise v1803 

 Windows 10 Professional v1803 

 Windows 10 Enterprise v1709 

 Windows 10 Professional v1709 

 Windows 10 Enterprise v1703 

 Windows 10 Professional v1703 

 Windows 7 Ultimate with Service Pack 1 

 Windows 7 Enterprise with Service Pack 1 

 Windows 7 Professional with Service Pack 1 

 Windows Server 2016 Standard 

 Windows Server 2016 Datacenter 

 Windows Server 2012 Standard 

 Windows Server 2012 Datacenter 

 Windows Server 2012 R2 Standard 

 Windows Server 2012 R2 Datacenter 

 Windows Server 2008 R2 Standard with Service Pack 1 

 Windows Server 2008 R2 Enterprise with Service Pack 1 

 

RSNetWorx for DeviceNet version 28.00 is a component aligned to Studio 
5000 Logix Designer™ version 32.00. RSNetWorx for DeviceNet has been 
tested with, and is compatible with the following products: 

 FactoryTalk® Activation Manager version 4.03 

 FactoryTalk® Services Platform version 6.10 

 RSLinx® Classic version 4.10 

 RSLogix™ 5 version 9.00 

 RSLogix 500® version 12.00 

 Studio 5000 Logix Designer® version 32.00 

It is recommended that you use all products from the same CPR release. 

Software requirements 

Software compatibility 
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RSNetWorx supports two installation methods: Setup wizard installation and 
unattended installation. 

The unattended installation reduces user interaction and provides command 
line parameters to install RSNetWorx. For more information, see Use 
unattended installation on page 53. 

This chapter uses the Setup wizard installation method to illustrate the steps. 

Tip: While installing RSNetWorx for DeviceNet software, you will have the opportunity 
to specify a directory. The default directory is: 
x:\Program Files\Rockwell Software\RSNetWorxII 
where x is the drive where the operating system is installed. 
We recommend that you use the default directory whenever possible.This 
subdirectory contains all of the application files required to run the product. 
In procedures that appear throughout this document, it is assumed that you used 
the default name. If you did not use the default name, substitute the actual name 
you specified for the default name shown. 

To install RSNetWorx for DeviceNet software, perform the following steps: 

1. Launch the installation wizard and select what to install. 

2. Set up security in RSNetWorx. 

3. Read and accept license agreements. 

4. Start the installation. 

5. Finish the installation. 

1. Close all open programs. 

2. In the RSNetWorx installation package, double-click Setup.exe. 

3. If Microsoft .NET Framework 4 is not installed on your computer, the 
Microsoft .NET Framework Setup dialog box shows. Click Install. 

 

Installing RSNetWorx for 
DeviceNet software 

Step 1: Launch the installation 
wizard and select what to 
install 
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4. On the RSNetWorx Setup page, select a language to be shown during 
the installation process if needed. By default, your system language is 
selected. 

 

5. To install RSNetWorx for ControlNet, RSNetWorx for EtherNet/IP, 
and RSNetWorx for DeviceNet, click Install now and skip to Step 2: 
Read and accept license agreements on page 26. 

6. To select a particular software product, click Customize. 
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7. On the Customize page, select RSNetWorx for DeviceNet v27.00.00 
and its components. 

 

8. Select the location for Rockwell Automation software. The default 
location is C:\Program Files (x86)\Rockwell Software. 

9. Click Install. 

On this page, you can set up FactoryTalk Security in RSNetWorx to improve 
the security of your automation system by limiting access to those with a 
legitimate need. 

Step 2: Set up security in 
RSNetWorx 
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1. Select the Enable FactoryTalk® Security option. And then select the 
FactoryTalk directory (Network or Local) that will be used to 
authenticate and authorize user access. 

 

2. Click Install. 

 

End-user license agreements (EULA) spell out your rights and 
responsibilities. Depending on the components being installed, there may be 
more than one license agreement on this page. The individual license 
agreements are listed above the text box. 

Step 3: Read and accept license 
agreements 
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Tip: You can also view the license agreements from the License folder of RSNetWorx 
installation package. 

Some software products may be delivered or made available only after you 
agree to the terms and conditions of each of the license agreements. 

1. On the End User License Agreements page, select each agreement 
and read the agreement carefully. 

2. When all license agreements have been read, click Accept All. 

 

Step 4: Start the installation 
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After accepting the license agreements, the Setup Wizard automatically 
installs all the Rockwell Software applications selected previously. 
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During the installation, if prompted to restart your computer, click Restart 
now. 

 

Step 5: Finish the installation 
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After the installation completes, you need to activate the software for its full 
feature capabilities. You can activate the software now or late. For more 
information about activation, see Activation on page 45. 

 

 To active the software, select Activate your software and click Next. 
Make sure your computer is connected to the Internet. 

In the Software Activation dialog box, enter the required information 
and click Continue. 
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You will be prompted to restart the computer after the activation. 

 

 To finish the installation without activation, Select Skip activation and 
click Next. 
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 To view the installation details, click Installation Summary. 

 To receive latest product updates and patch notification, click 
Register for updates. 

 To install the latest version of Adobe Acrobat Reader, click 
Download it free and follow the on-screen instructions. 

Restart the computer to complete the installation. 

 

As a client to a client-server installation, you can install one or more 
Rockwell Software products from the dedicated server location to an 
end-user destination. To install the RSNetWorx for DeviceNet software from 
the server, perform the following steps: 

1. Map a network drive to the dedicated server location provided by your 
system administrator. The system administrator must have copied the 
entire installation contents and provided only Read and Execute 
permissions of the files. Users installing the software cannot have write 
access to the files. 

2. Double-click Setup.exe in the client installation directory. 

Installing a client copy from a 
dedicated server 
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3. See the Installing RSNetWorx for DeviceNet software on page 23 
section in this chapter. 

To start RSNetWorx for DeviceNet software, click Start > All Programs > 
Rockwell Software > RSNetWorx > RSNetWorx for DeviceNet. 

If RSNetWorx for DeviceNet does not start up or run properly, consider the 
following: 

 Do you have the correct version of RSLinx Classic installed? 
RSNetWorx for DeviceNet requires RSLinx Classic version 4.00. 

 Does your computer have enough memory? Running RSNetWorx for 
DeviceNet requires a minimum of 4 GB of RAM. 

 Have you reinstalled an earlier Service Pack, or removed a component, 
such as DCOM, that RSNetWorx for DeviceNet requires? 

 Have you checked the RSNetWorx support on the web for 
troubleshooting information? Go to 
http://www.rockwellautomation.com/support , click Knowledgebase, 
and search for Tech Notes on RSNetWorx for DeviceNet. 

 Do you have the up-to-date compatibility information for the software? 
Go to Product Compatibility and Download Center at 
https://compatibility.rockwellautomation.com/Pages/home.aspx . 

 

Starting RSNetWorx for 
DeviceNet 
Troubleshooting 
installation 

http://www.rockwellautomation.com/support
https://compatibility.rockwellautomation.com/Pages/home.aspx
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Chapter 3 

Advanced concepts 

This chapter contains the following sections: 

 EDS-based devices 

 EDS library 

 DeviceNet node commissioning tool 

 Faulted Address Recovery wizard 

 Class Instance Editor 

RSNetWorx for DeviceNet relies on an electronic data sheets (EDS) for 
configuring devices. An electronic data sheet is an ASCII file that is created 
by the manufacturer and supplied with the device. 

As long as the EDS file for the device you want to configure is registered 
with the RSNetWorx for DeviceNet software, you can configure its target 
connection configuration (attributes) and how it will communicate with other 
devices on the DeviceNet network. Although the procedure for  configuring 
a device is basically the same for all devices, each device will have a unique 
set of properties. 

The electronic data sheet (EDS) library is a collection of EDS files that have 
been registered with RSNetWorx for DeviceNet. The EDS files, which are 
provided by the device manufacturers, contain configuration and 
identification information for the devices. 

RSNetWorx for DeviceNet software can access only those devices that have 
been registered. You must use the EDS Wizard for registering EDS files for 
unknown devices, or if you have updated EDS files to install. To access the 
EDS Wizard, select Tools > EDS Wizard. 

Although you get a large number of electronic data sheet (EDS) files with the 
RSNetWorx for DeviceNet software, there may be a time when you need to 
acquire/create additional EDS files. The most common ways of getting these 
files are to: 

 obtain them on distribution media that accompany the devices. 

 download them from DeviceNet sites on the world wide web. You can 
either select the device in the network configuration, right-click the 
mouse and select Re-register Device, and click Download EDS File in 

EDS-based devices 

EDS library 
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the EDS Wizard or access one of the following world wide web sites 
from which EDS files are available: 

 https://www.rockwellautomation.com/global/support/networks/eds.
page?  (Allen-Bradley technical support site) 

 http://ab.rockwellautomation.com/Drives  (Allen-Bradley 
Standard Drive Products site) 

 http://www.odva.org  (ODVA organization website) 

 create the EDS file using the EDS Wizard. 

The DeviceNet node commissioning tool lets you commission, that is, set the 
node address and the data rate parameters of, devices that are either 
connected: 

 to a DeviceNet network, or 

 via a point-to-point connection. 

Before you can add any node to a live DeviceNet network, it must be 
commissioned. This means that a node address and a data rate must be 
programmed into the device. Most devices are preset with a node address, 
which is usually set to 63, and a data rate, which is usually set to 125K baud. 
These default preset values will need to be changed to meet your application 
needs. Once a device has been commissioned and attached to a network, you 
can use the RSNetWorx for DeviceNet node commissioning tool to edit the 
node address that was set previously. 

Tip: Some devices do not permit software setting of the node address or data rate. 
Refer to the device documentation for specific information. 

 

Important: Exercise caution while editing node addresses when on a network. When 
you apply a new node address, it immediately overwrites the node 
address data in the device currently specified. If you re-assign node 
addresses, first determine the order in which this needs to be done so that 
all the devices will still have unique node addresses throughout the 
address assigning process. If your scanner supports Automatic Device 
Replacement (ADR), your system may automatically perform this 
commissioning. 

For example, if two of the devices on your network are a photoelectric sensor 
and a hand controller and you accidentally change the node address of the 
hand controller to be the same as that of the photoelectric sensor, then the 
hand controller will no longer have a unique address, which means that it 
will not be able to communicate on the network. If you cannot access a 
device, because you have used its node address for another device, you will 
have to remove it from the network, recommission it, then reinstall it on the 
network. For information on how to recover a faulted device, see the Faulted 
Address Recovery wizard in this chapter. 

DeviceNet node 
commissioning tool 

Commissioning devices on a 
DeviceNet network 

https://www.rockwellautomation.com/global/support/networks/eds.page?
https://www.rockwellautomation.com/global/support/networks/eds.page?
http://ab.rockwellautomation.com/Drives
http://www.odva.org/
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When the baud rate of a device does not match the DeviceNet network (for 
example, when adding a new device [out of the box] or when moving a 
device from one DeviceNet network to another) and the dip switches are not 
provided, it may be necessary to establish a point-to-point connection to that 
device and prepare it for integration onto your existing DeviceNet network. 
Using the Node Commissioning Tool, you can establish a point-to-point 
connection to a device and change the node address and/or the data rate 
parameters to match your existing DeviceNet network. 

Important: You should not change the data rate of devices while they are connected 
to a network; otherwise, erratic operation may result. We recommend that 
if you need to change the data rate of a device, that you complete the 
following: 
1. Remove it from the network. 
2. Establish a point-to-point connection between the PC, which hosts the 
RSNetWorx for DeviceNet software, and the target device. 
3. Recommission the device. 
4. Reconnect the device to the network. 

 

The Faulted Address Recovery wizard allows you to recover select faulted 
devices with duplicate node addresses on your DeviceNet network. In 
addition, you can detect faulted devices on your DeviceNet network and 
"flash" the LEDs on those devices to locate them in your application. 

Tip: The faulted address recovery function is not supported by all devices. For more 
information, consult your hardware documentation or contact your hardware 
vendor. 
The Faulted Address Recovery feature requires RSLinx 2.20, Service Pack 1 or later. 

 

The Class Instance Editor is a tool that allows you to send data to, and read 
data from, a DeviceNet device that is not otherwise configurable with 
RSNetWorx for DeviceNet. Using the Class Instance Editor, you can enter 
raw data and download it to the device, or read the data from the device. 

Important: We do not recommend configuring devices with the Class Instance Editor 
unless you are instructed to do so by technical support personnel for the 
hardware product. 

To use the editor, you will need to know the service code, class, instance, and 
attribute by their appropriate hexadecimal codes within the device. This 
information may be available on the printed data sheet accompanying the 
device. 

Tip: For further information about configuring a device with the Class Instance Editor, 
contact the manufacturer of the device. For more information on how to enter data 
into the Class Instance Editor, contact Rockwell Automation technical support. 

 

Commissioning a device via a 
point-to-point connection 

Faulted Address Recovery 
Wizard 

Class Instance Editor 
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Chapter 4 

Finding the information you need 

Use this chapter to review the sources of additional information about 
RSNetWorx for DeviceNet software. This chapter helps you to find what you 
need efficiently by describing how to: 

 Use the online help 

 Access product manuals 

 Participate in Rockwell Automation training courses 

 Contact technical support 

RSNetWorx for DeviceNet online help provides general overview 
information, comprehensive step-by-step procedures, and context-sensitive, 
dialog box control definitions for working with all of the features in the 
software. To view online help while running RSNetWorx for DeviceNet: 

 choose Contents from the Help menu on the RSNetWorx for 
DeviceNet main window 

 click Help on any RSNetWorx for DeviceNet dialog box or property 
page 

 position the cursor over any control with which you want help and 
right-click 

 press F1 

 click the What’s This? icon located in the toolbar or in the upper right 
corner of dialog boxes, then click any control 

 

Using the online help 

Accessing help for a control or 
field 
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To display a definition for a control or a field, click the What’s This? icon in 
the upper right corner of the dialog box, drag the cursor to the selected area, 
and then click to display the definition. You can also right-click on a control 
to display the definition. In this example, the Name control was selected. 

 

The message view, which appears in the bottom portion of the workspace, 
displays a log of messages. This view may contain informational, warning, 
and/or error messages. 

 

To troubleshoot a particular message, you can select the message and press 
the F1 key or right-click on the message and select Troubleshoot to access 
the online help. 

Accessing help for error 
messages 
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For example, if you select the DNET:0001 error code shown here and press 
F1, the browse operation has timed out help topic displays: 

 

From the message view, you can also select a message and choose View > 
Messages > Troubleshoot to display online help for the message. You can 
also show, clear, copy, and/or clear and hide messages by making the 
appropriate selection from the View > Messages command on the main 
menu. The copy menu item copies the selected message to the Windows 
clipboard so it can be pasted into other applications (for example, an e-mail 
message). 

To view a list of tasks related to the current task-based topic, move to the 
What do you want to do? section at the bottom of the help window and select 
one of the listed tasks. The contents pane of the help window is updated, 
displaying a step-by-step procedure for completing the selected task. 

Finding step-by-step 
procedures 
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For example, from the Configuring EDS-based devices topic, if you select 
Learn how to configure EDS devices under the What do you want to do? 
section, the help topic that describes how to configure an EDS-based device 
appears. 

 

Within the RSNetWorx for DeviceNet help, blue text highlighted with an 
underline indicates a pop-up definition or a link to a related topic. For 
example, in the DeviceNet node commissioning tool help topic, node address 
is a pop-up definition. Click the link to see the definition of a node address. 

 

Finding definitions 
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You can gain immediate access to product documentation through the 
Product Manuals feature in RSNetWorx for DeviceNet. Product Manuals 
include this Getting Results Guide, as well as many reference guides, in an 
electronic book format. Select Help > Product Manuals to access this 
documentation. 

 

One of the best ways to increase your proficiency at using Rockwell 
Software products is to attend a Rockwell Automation training program. Our 
training programs can help you master the basics and show you how to 
unleash the full potential of our software. 

We offer a wide range of training programs, from regularly scheduled classes 
conducted at Rockwell Software facilities, to custom-tailored classes 
conducted at your enterprise. The size of each class is kept small 
intentionally to maximize student engagement. 

If you would like more information about our training programs, visit the 
Rockwell Software website or contact the Rockwell Automation Training 
Coordinator. Our website address and telephone numbers appear on the 
inside front cover of this document. 

Tip: For more information on Rockwell Automation training, go to the Training Services 
website: 
http://www.rockwellautomation.com/global/products/training/overview.page?  

 

If you cannot find answers to your questions in the Getting Results with 
RSNetWorx for DeviceNet guide, the online help, or the Online Books 
documentation, you can call Rockwell Software Technical Support at the 
numbers listed on the inside front cover of this guide. You can also access 
the Rockwell Software Online Support Library and receive information about 
Autofax Product Information System from the website listed on the inside 
front cover of this guide. 

When you call, you should be at your computer and prepared to give the 
following information: 

Accessing the Product 
Manuals 

Training 

Technical support 

When you call 

http://www.rockwellautomation.com/global/products/training/overview.page?
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  product serial numbers 

  product version number 

 The product serial numbers and version number can be found in the 
software by selecting Help > About RSNetWorx 

 hardware you are using 

 exact wording of any errors or messages that appeared on your screen 

 description of what happened and what you were doing when the 
problem occurred 

 description of how you attempted to solve the problem 

Tip: For more information on Rockwell Software training, go to the Training Services 
website: 
http://www.rockwellautomation.com/global/products/training/overview.page?  

 

 

http://www.rockwellautomation.com/global/products/training/overview.page?
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Appendix A 

Activation 

RSNetWorx for DeviceNet only supports FactoryTalk activation. If you are a 
new user, you will need to activate your software using FactoryTalk 
Activation. 

RSNetWorx for DeviceNet supports the following types of activation: 

Node-locked activation 

This type of activation can be either locked to a particular piece of hardware, 
such as an EtherNet card or a hard disk of a stand-alone computer, or to a 
hardware dongle. Depending upon the kind of device (stand-alone computer 
or hardware dongle) you want to activate, you can purchase either 

 Local "node-locked" activation: This kind of activation activates 
software only on a single computer. If the activation file is copied to 
another computer, the software will not run on that other computer, or 

 Mobile "node-locked" activation: This kind of activation is locked to 
hardware dongle. A dongle is a security or copy protection device that 
must be connected to the computer while the program runs. The 
activation files can be copied to multiple computers, but the software 
activates only on the computer where the dongle is connected. 

Concurrent activation 

This type of activation allows multiple computers across a network to use 
Rockwell Software products at the same time. There are two kinds of 
concurrent activations: 

 Floating activations: activations that "float" from an activation server 
to any computer that needs them. 

 Borrowed activations: activations that are retrieved from a server for a 
specific period of time before expiring and returning automatically to 
the pool of available activations on the server. 

For more information about FactoryTalk Activation, refer to the FactoryTalk 
Activation Manager help. 

You can activate your copy of RSNetWorx on the Software Activation 
dialog box towards the end of installation. If you skipped the activation 
during installation, activate RSNetWorx using the FactoryTalk Activation 
Manager installed during the installation process. 

Activate RSNetWorx with 
FactoryTalk Activation 

How to activate RSNetWorx 
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For help with FactoryTalk Activation at any point, you can click: 

 the Help button in FactoryTalk Activation Manager 

 the Help link on the Rockwell Software Activation website: 
https://activate.rockwellautomation.com/  

 View How to Activate Rockwell Software Products on the Required 
Steps of the Install program 

If you cannot connect to the Internet, call Technical Support for help creating 
an activation file from an e-mail or a fax. 

Phone: 440-646-3434 in North America. Outside of North America, call your 
local support organization. 

In RSNetWorx for DeviceNet v10.00.00 (CPR 9 Service Release 2) and 
later, the software supports a seven day activation grace period when a valid 
activation is not found. During grace period: 

 If RSNetWorx is started and an activation key is not present, the 
software shall enter grace period and run with full functionality. 

 Once RSNetWorx has entered grace period, the software shall check 
for an activation key every four hours. If the activation is not found, a 
message will be generated to FactoryTalk Diagnostics. 

 RSNetWorx can be started an unlimited number of times while in 
grace period and be able to run with full functionality. If the grace 
period ends and a valid activation has not been found, RSNetWorx 
shall run in Demo mode. 

 While RSNetWorx is running, the software cannot change modes. 
RSNetWorx can only change to Demo mode when the software is 
restarted and/or grace period has already expired. 

Tip: If RSNetWorx is unable to successfully obtain valid activations (for example, a 
network failure occurs), the software will attempt run in grace period for up to 
seven days. 

 

Following are some common problems that people encounter with activation 
and their solutions. 

If you have lost the activation because the activation file is damaged, you 
need to reset activation. Follow the Reset Codes instructions on the 
Rockwell Software Technical Support web page, or call the technical support 
telephone number. The web page and telephone number are both listed on the 
inside front cover of this guide. 

Finding more information 
about FactoryTalk Activation 

Grace period 

Some common questions 

My activation files were damaged. 
What should I do? 

https://activate.rockwellautomation.com/
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No. Deleting the program files does not delete your activation. The 
activation files are not stored in the program directory; they are located in the 
root directory. Your activation files will not be lost unless you format the 
hard drive, tamper with hidden files in the root directory, or perform certain 
other hard drive operations (refer to the "Protecting your activation files" 
section in this chapter for more information). 

To get the software running again, simply reinstall the software, but do not 
move the activation when given the opportunity. 

 

I accidentally deleted the software 
directory on my hard drive. Do I need 
to call Rockwell Software for 
replacement activation files? 
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Appendix B 

Security 

FactoryTalk Security™ is intended to improve the security of your 
automation system by limiting access to those with a legitimate need. 
FactoryTalk Security authenticates user identities and authorizes user 
requests to access a FactoryTalk-enabled system. These security services are 
fully integrated into the FactoryTalk Directory and are included as part of the 
FactoryTalk Services Platform that installs with many products. 

For more information on how to use security services, refer to FactoryTalk 
Security’s Online help. 

RSNetWorx supports FactoryTalk Security. FactoryTalk Security™ is 
intended to improve the security of your automation system by limiting 
access to those with a legitimate need. FactoryTalk Security authenticates the 
identities of users and authorizes user requests to access a 
FactoryTalk-enabled system against a set of defined user accounts and access 
privileges held in the FactoryTalk Directory. For more information on 
FactoryTalk Security, refer to the ‘About FactoryTalk Security’ topic in 
RSNetWorx for DeviceNet Online Help. 

Follow the steps below to set up security in RSNetWorx: 

How do I set up security in 
RSNetWorx? 
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1. During RSNetWorx’s installation, you will see the RSNetworx 
Security Configuration Selection page. On this page, select the 
Enable FactoryTalk® Security option. And then select the 
FactoryTalk Directory (Network or Local) that will be used to 
authenticate and authorize user access. 

 

2. Click Install to continue the RSNetWorx installation. 

3. Follow the screen instructions to complete the installation. 

RSNetWorx implements FactoryTalk Security through three securable 
actions: Access, Modify, and Go Online. These securable actions let you 
restrict user access to actions, such as opening a project file, creating a new 
project file, making changes to a project file, uploading or downloading to a 
device, browsing to a device from the network, viewing the properties of a 
device, etc., in RSNetWorx. 

What can I secure in 
RSNetWorx? 
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Securable action Description 

Access The Access securable action allows you to perform actions such as opening an 
offline project file for viewing, viewing the properties of a device, etc. 

Modify The Modify securable action allows you to perform actions such as creating a 
project file, making changes to a project file, saving any pending edits, etc. 
Note: To modify a project file, you need both Access (to open the file) and Modify 
(to make changes) securable actions. 

Go Online The Go Online securable action allows you to download information saved in a 
project file or upload information into a project file, as well as browse to a device 
on the network. 

Tip: To download information saved in an existing project file, you need 
Access (to open the file), Go Online (to go online to prepare to 
download), and Modify (to download) securable actions. 
To upload information into an existing project file, you need Access (to 
open the file), Go Online (to go online to prepare to upload), and 
Modify (to upload) securable actions. 
To upload information into a new project file, you need Go Online (to 
go online to upload) securable action. 

 

To allow or deny user access to one or more of the above securable actions, 
you will need to: 

1. Start FactoryTalk Administration Console from Start > Programs > 
Rockwell Software > FactoryTalk Administration Console. You 
will see the Log On to FactoryTalk screen, as shown below. 

 

2. Enter your username and password, and select the directory you want 
to log on to. (The username and password were set when you set up an 
account during FactoryTalk Directory configuration.) 

Tips for choosing a directory: 
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 Click Network to access Network (also called Distributed) 
applications on the Network Directory Server. 

 Click Local to access Local (also called Stand-alone) applications 
on the Local Directory. Local applications are always located on 
your local computer. You cannot access local applications 
remotely. 

 If you cannot log on to a particular directory on your computer, it 
may be because it has not yet been configured. For more 
information, refer to the Right FactoryTalk Directory is not 
configured on this computer topic in FactoryTalk help. You can 
launch FactoryTalk Help from FactoryTalk Administration 
Console. 

3. In FactoryTalk Administration Console, click on the RSNetWorx 
folder (located under System > Policies > Product Policies), to 
expand it. You will see the Feature Security file. 

4. Double-click the Feature Security file to launch the Feature Security 
Properties dialog box. 

 

5. In the Feature Security Properties dialog box, click the securable action 
you want to grant the user access to. 

6. In the Configure Securable Action dialog box, from the list of users, 
select the user you want to grant access to, and click Add. 

Tip: For more information on FactoryTalk and FactoryTalk Security, refer to RSNetWorx 
for DeviceNet Online Help. 
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Appendix C 

Use unattended installation 

The unattended installation is an automated installation method that you can 
use to install RSNetWorx. You can typically use the unattended installation 
during large-scale rollouts when it might be too slow and costly to have 
administrators or technicians interactively install the RSNetWorx software 
on individual computers. 

In the unattended installation, you enter a specified command line with 
multiple parameters. During the installation process, instead of prompting 
you for installation and configuration information interactively, the process 
follows the parameters you specified in the command lines. 

For detailed description about each parameter, see Parameters. You can also 
type Setup /? in the Command Prompt window, and press Enter to view 
the help information of all parameters and examples. 

To install RSNetWorx in the unattended mode, follow the steps below. The 
steps may vary slightly. Follow the on-screen instructions that apply to your 
operating system. 

1. Close all open Windows programs. 

2. Open the Command Prompt window. 

3. In the Command Prompt window, navigate to D:, where D: is the 
drive containing the RSNetWorx installation DVD or installation 
package, and press Enter. 

Tip: The User Account Control dialog box may show after you press Enter, click Yes 
to continue. The unattended installation requires the administrator permission. 

4. Type a command line with the following syntax: 

Setup {/Q | /QS} 

/IAcceptAllLicenseTerms 

[/AutoRestart] 

[/SetupLanguage=language] 

[/ProductLanguage=product_language] 

[/InstallLocation=location] 

[/SerialNumber=serial_number] 

Perform unattended 
installation 
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[/ProductKey=product_key] 

[/Version=product_version] 

5. Press Enter. The installation process starts with the parameters you 
specified. 

The parameters and values are not case sensitive. If the value includes 
spaces, you need to enclose it in quotation marks (" "). 

If your installation package is Personalized Edition, the following parameters 
will be ignored during installation: 

 /SerialNumber 

 /ProductKey 

/Q 

Required if /QS or /Record is not specified. 

Installs the product in the silent mode without any user interface. 

/QS 

Required if /Q or /Record is not specified. 

Installs the product in the unattended mode without user interaction 
during installation, and shows the progress, errors, or complete 
messages on the user interface. 

/IAcceptAllLicenseTerms 

Required. Specified that you read and acknowledge all license 
agreements, and agree to continue the installation. 

/AutoRestart 

Optional. If specified, the computer will be restarted automatically 
after the installation if a restart is required to complete the installation. 

The parameter is ignored if a restart is not required. 

/SetupLanguage=setup_language 

Optional. Specifies which language will be displayed during the 
installation process. The value must be the one of ENU, CHS, DEU, 
ESP, FRA, ITA, JPN, KOR, or PTB. 

If it is omitted or if the specified language is not available, the default 
language is the user or system user interface language. 

/Record 

Parameters 
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Optional. Records the installation options chosen to a recoding file. 

/Playback 

Optional. Plays back a recording file to specify the installation options. 

/ProductLanguage=product_language 

Optional. Specifies which language of components will be installed. 
The value must be the one of ENU, CHS, DEU, ESP, FRA, ITA, 
JPN, KOR, or PTB. 

If it is omitted or if the specified language is not available, the default 
language is the same as SetupLanguage. 

/InstallLocation=location 

Optional. Specifies the installation location. 

If omitted, the default location is "C:\Program Files (x86)\Rockwell 
Software" (64-bit) or "C:\Program Files\Rockwell Software" (32-bit). 

/SerialNumber=serial_number 

Optional. Specifies the serial number that is required if you want to get 
activation keys during installation. 

/ProductKey=product_key 

Optional. Specifies the product key that is required if you want to get 
activation keys during installation. 

/Version=product_version 

Optional. Specifies the version corresponding to the product version 
that the SerialNumber and ProductKey are able to activate if you 
want to get activation keys during the installation. 

If omitted, the installer uses a default version which is the most recent 
product version available when retrieving the activation. 

The following examples show how to use the commands during the 
unattended installation. 

Example 1: 

Setup.exe /Q /IAcceptAllLicenseTerms 

means: 

 The installation uses the default settings during the installation process. 

Examples 
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Example 2: 

Setup.exe /QS /IAcceptAllLicenseTerms /AutoRestart 
/SetupLanguage=CHS /SerialNumber=0123456789 
/ProductKey=ABCDE-FGHIJ /Version=27.00.00 

means: 

 During the installation, the displayed language is Chinese. 

 The setup will get activation keys for RSNetWorx version 27.00.00 
during installation if the serial number 0123456789 and product key 
ABCDE-FGHIJ are valid. 

 After the installation, if a restart is required, the computer will be 
restarted automatically. 
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Glossary 

Activation file — A hidden, read-only, system file that "activates" a 
Rockwell Software product. The software will run only if your system can 
find the correct activation file. 

Activation key — Activation files contain a database of activation keys. 
Each key is particular to a certain product and must be accessible on a local 
or remote drive for that product to run. 

DeviceNet network — A topology for industrial automation networks. 

FactoryTalk is a manufacturing information platform that integrates 
plant-wide control systems and connects the enterprise with the production 
facility. 

The FactoryTalk Automation Platform: 

 provides common services (such as diagnostic messages and access to 
real-time data) and shares plant resources (such as tags and graphic 
displays) throughout a production facility 

 allows defining plant-floor resources once, and then allows 
simultaneous access to those resources across product boundaries 

 supports centralized security services 

FactoryTalk Administration Console — Part of the FactoryTalk 
Automation Platform, FactoryTalk Administration Console is an optional, 
stand-alone tool that allows you to: 

 Create and configure application, area, and data server elements in the 
FactoryTalk Directory. 

 Back up and restore an entire directory or an individual application. 

 Set up redundancy for OPC data servers. 

 Configure client computers to recognize the location of a FactoryTalk 
Directory Server computer. 

 Configure options for routing and logging diagnostic messages. 

 View system-wide diagnostic messages. 

 Configure system-wide policy settings. 

 Secure your FactoryTalk-enabled system with FactoryTalk Security™ 
services. 

Run FactoryTalk Administration Console from the Windows Start menu: 
Start > Programs > Rockwell Software > FactoryTalk Administration 
Console. 
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FactoryTalk Directory — FactoryTalk Directory provides a central lookup 
service for software products participating in a FactoryTalk-enabled 
automation system. 

The FactoryTalk Automation Platform includes two separate directories: a 
Local Directory and a Network Directory. Either directory, or both 
directories, can be configured on the same computer. Project information, 
including security settings, cannot be shared between a Local Directory and 
Network Directory, even if both directories are configured on the same 
computer. Create and configure application, area, and data server elements in 
the FactoryTalk Directory. 

 Local Directory — all project information and participating software 
products are located on a single computer, and the FactoryTalk-enabled 
system cannot be shared across a network or accessed remotely. 

 Network Directory — organizes project information from multiple 
software products across multiple computers on a network. 

Some FactoryTalk-enabled products require a Network directory, others 
require only a Local directory, and some require that both directories be 
configured. 

RSNetWorx configuration — A collection of user-defined parameters for 
networks. 
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Rockwell Automation support 
Rockwell Automation provides technical information on the web to assist you in using its products. At 
http://www.rockwellautomation.com/support  you can find technical and application notes, sample code, and links to software service 
packs. You can also visit our Support Center at https://rockwellautomation.custhelp.com  for software updates, support chats and forums, 
technical information, FAQs, and to sign up for product notification updates. 

In addition, we offer multiple support programs for installation, configuration, and troubleshooting. For more information, contact your 
local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/services/online-phone . 

Installation assistance 

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can 
contact Customer Support for initial help in getting your product up and running. 

United States or Canada 1.440.646.3434 

Outside United States or Canada Use the Worldwide Locator available at http://www.rockwellautomation.com/locations , or contact your local Rockwell 
Automation representative. 

 

New product satisfaction return 

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. 
However, if your product is not functioning and needs to be returned, follow these procedures. 

United States Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to 
your distributor to complete the return process. 

Outside United States Please contact your local Rockwell Automation representative for the return procedure. 

 

Documentation feedback 

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, 
complete the feedback form, publication RA-DU002 

 

http://www.rockwellautomation.com/support
https://rockwellautomation.custhelp.com/
http://www.rockwellautomation.com/services/online-phone
http://www.rockwellautomation.com/locations
http://literature.rockwellautomation.com/idc/groups/literature/documents/du/ra-du002_-en-e.pdf
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