PanelBuilder32 Software

Getting Results
Catalog Number 2711-ND3
Application Development Software for PanelView Standard Terminals
Important User Information

Solid state equipment has operational characteristics differing from those of electromechanical equipment. Safety Guidelines for the Application, Installation and Maintenance of Solid State Controls (publication SGI-1.1 available from your local Rockwell Automation sales office or online at http://literature.rockwellautomation.com) describes some important differences between solid state equipment and hard-wired electromechanical devices. Because of this difference, and also because of the wide variety of uses for solid state equipment, all persons responsible for applying this equipment must satisfy themselves that each intended application of this equipment is acceptable.

In no event will Rockwell Automation, Inc. be responsible or liable for indirect or consequential damages resulting from the use or application of this equipment.

The examples and diagrams in this manual are included solely for illustrative purposes. Because of the many variables and requirements associated with any particular installation, Rockwell Automation, Inc. cannot assume responsibility or liability for actual use based on the examples and diagrams.

No patent liability is assumed by Rockwell Automation, Inc. with respect to use of information, circuits, equipment, or software described in this manual.

Reproduction of the contents of this manual, in whole or in part, without written permission of Rockwell Automation, Inc., is prohibited.

Throughout this manual, when necessary, we use notes to make you aware of safety considerations.

<table>
<thead>
<tr>
<th>WARNING</th>
<th>Identifies information about practices or circumstances that can cause an explosion in a hazardous environment, which may lead to personal injury or death, property damage, or economic loss.</th>
</tr>
</thead>
<tbody>
<tr>
<td>IMPORTANT</td>
<td>Identifies information that is critical for successful application and understanding of the product.</td>
</tr>
<tr>
<td>ATTENTION</td>
<td>Identifies information about practices or circumstances that can lead to personal injury or death, property damage, or economic loss. Attentions help you identify a hazard, avoid a hazard, and recognize the consequence</td>
</tr>
<tr>
<td>SHOCK HAZARD</td>
<td>Labels may be on or inside the equipment, for example, a drive or motor, to alert people that dangerous voltage may be present.</td>
</tr>
<tr>
<td>BURN HAZARD</td>
<td>Labels may be on or inside the equipment, for example, a drive or motor, to alert people that surfaces may reach dangerous temperatures.</td>
</tr>
</tbody>
</table>
Summary of Changes

The information below summarizes the changes to this manual since the last revision.

Revision bars, as shown in the margin, identify updated information. This document includes the following changes.

Version 3.83 of the PanelBuilder32 now supports the Windows Vista operating system. This is the only difference between version 3.83 and the previous version.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Updated Additional Resources table</td>
<td>10</td>
</tr>
<tr>
<td>Updated technical support information</td>
<td>10</td>
</tr>
</tbody>
</table>
# Table of Contents

**Preface**
- Intended Audience ........................................ 9
- Additional Resources ..................................... 10
- Technical Support ......................................... 10

**Chapter 1**
- Installing PanelBuilder32 ............................... 11
- System Requirements .................................... 11
- Installing PanelBuilder32 ............................... 11
- Starting and Exiting PanelBuilder32 ................. 13

**Chapter 2**
- Using PanelBuilder32 ................................... 15
- Startup Dialog ............................................. 15
- Application Window ..................................... 16
- Screen Window ........................................... 18
- Right-click Menus ....................................... 22
- Setting Preferences and Defaults ..................... 23
- Using PanelBuilder32 Online Help ..................... 24

**Chapter 3**
- Applications and Screens .............................. 27
- About File Types ......................................... 27
- Creating a New Application ............................ 27
- Opening an Application ................................. 28
- Working with Screens ................................... 29
- Basic Screen Operations ................................ 30
- Saving an Application ................................... 32
- Closing an Application .................................. 33
- Generating an Application Report ..................... 33
- Checking the Size of an Application ................. 34
- Capturing Screen Images ............................... 34

**Chapter 4**
- Working with Screen Objects .......................... 35
- Overview of Objects .................................... 35
- Things to Know About Objects ......................... 39
- Create Screen Objects .................................. 42
- Configure Properties of Objects ...................... 44
- Configuring States of Multistate or List Objects ... 45
- Push Buttons ............................................. 46
- Control List Selectors ................................... 48
- Numeric Entry Controls ................................. 50
- ASCII Entry Controls .................................... 52
- Message Displays ........................................ 54
- Data Displays ............................................ 55
- Screen Selectors .......................................... 58
- Using Global Objects ..................................... 60
Table of Contents

Chapter 5
Working with Alarms
Overview of Alarms ............................................ 63
Alarm Banner .................................................. 64
Alarm Lists .................................................... 65
Alarm Buttons .................................................. 67
How to Configure Alarms .................................... 67
Alarm Triggering Examples .................................. 71

Chapter 6
Working with Text
Editing Text in an Object ..................................... 73
Adding Variables to Text ....................................... 75
Adding Background Text to a Screen ....................... 78
Scrolling Text .................................................. 79
Changing the Appearance of Text ......................... 79
Using the Application Text Editor ......................... 80
Storing Translated Text for Multiple Languages ........ 86
Using Font Files to Translate Application Text .......... 88

Chapter 7
Working with Graphics
Using Graphic Tools ........................................... 93
Adding ISA Symbols .......................................... 94
Adding Graphics to a Screen ............................... 94
Inserting a Graphic in an Object ......................... 95
Importing and Exporting Graphics ....................... 96

Chapter 8
Formatting Objects
Changing the Appearance of Objects ................... 100
Using Color .................................................. 101
Applying Color to Objects .................................. 102
Applying Color to Text ...................................... 102
Applying Color to Inner Graphics ....................... 103
Setting Default Colors for Objects ..................... 103

Chapter 9
Using the Tag Editor
What is the Tag Editor? .................................... 105
Tag Editor Worksheet ....................................... 106
Exiting the Tag Editor ...................................... 107
Another Way to Enter Tags ................................ 107
Description of the Tag Fields ............................. 108
Inserting or Adding Tags ................................... 109
Selecting Tags ............................................... 109
Copying/Cutting, Pasting and Deleting Tags .......... 110
Duplicating Tags ............................................. 110
Sorting and Filtering Tags .................................. 110
# Table of Contents

- Finding and Replacing Tags ...................................................... 111
- Printing Tags ............................................................................. 111
- Searching for Where a Tag is Used .......................................... 111
- Counting and Purging Tags ....................................................... 113
- Converting Tags ......................................................................... 113
- Saving Tags ................................................................................ 114
- Checking Tags for Errors ............................................................. 114
- Importing and Exporting Tags ................................................... 116
- Using Projects to Share Tags ....................................................... 120
- Creating Project Worksheets ....................................................... 121

## Chapter 10

### Application Settings
- Configuring Communications .................................................. 123
- Setting Power-up Options .......................................................... 124
- Changing the Date and Time Format ......................................... 126
- Configuring the Printer Port ....................................................... 127
- Converting an Application for Another Terminal Type .............. 128
- Defining Control Tags Used by Controller ................................. 129
- Defining Status Tags Used by Controller .................................... 130
- Enabling External Fonts ............................................................. 131
- Setting Advanced Terminal Options ......................................... 132
- Enabling or Disabling the Use of a Project ................................. 133
- Setting up Security for an Application ....................................... 133

## Chapter 11

### Transferring Applications
- Ways to Transfer Applications ................................................. 135
- Using a Memory Card ............................................................... 136
- Communication Drivers ............................................................ 136
- Validating an Application ......................................................... 137
- Monitoring the Progress of a Download or Upload .................... 138
- Downloading Application Directly to a Terminal ....................... 139
- Downloading Application Over a Network ............................... 140
- Using Remote I/O Pass-Through .............................................. 141
- Downloading Application to a Memory Card ............................ 142
- Uploading Application Directly from a Terminal ...................... 143
- Uploading Application Over a Network .................................... 144
- Using the WinPFT File Transfer Utility ..................................... 145

### Index .................................................................................... 153
Preface

The PanelBuilder32 software allows you to create control panel applications for the Standard PanelView operator terminals. Because the terminals provide flexible communication options, you can create applications to run in a variety of communication environments.

- Data Highway Plus
- Remote I/O
- DH-485
- RS-232 (DH-485)
- DeviceNet
- ControlNet
- EtherNet/IP
- DF1

You might want to review the online PanelBuilder32 Quick Start manual before creating your application. It takes you through all the steps required to create a sample application including how to download and run the application in a PanelView terminal. Ladder logic is provided for each of the above communication protocols.

Intended Audience

Use this manual if you are responsible for using PanelBuilder32 software to design control panel applications that will run in the PanelView Standard terminals. It provides information on how to use the software and complements the extensive online help.

You should have a basic understanding of PLC, ControlLogix, SLC 500 and MicroLogix products and the network environment in which the application will run. If you do not, contact your local Allen-Bradley representative for the proper training before using this product.
PanelBuilder32 software provides extensive online help. For additional information, refer to these publications that you can download from http://literature.rockwellautomation.com.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PanelBuilder32 Application Development Software for PanelView Standard Terminals Quick Start, publication 2711-QS003</td>
<td>Describes how to use the PanelBuilder32 software to create, download, and run a sample application on a PanelView Standard terminal.</td>
</tr>
</tbody>
</table>

The pdf files for these documents are also available on your installation CD. For information on how to use the Adobe Acrobat Reader, refer to the Help menu while viewing a pdf file.

If you have questions about the PanelBuilder32 software or the PanelView terminals, please refer to the online help and manuals first.

If you can’t find the answer, contact Rockwell Automation technical support. Please have your serial number available when you call. The serial number is on the PanelBuilder32 Help>About menu.

To upgrade PanelBuilder32 software and PanelView firmware:
- call your local Allen-Bradley sales office or distributor
- call technical support at 1-440-646-3434
- access the website http:\support.rockwellautomation.com. You must be a registered user.
Chapter 1

Installing PanelBuilder32

This chapter explains how to install PanelBuilder32 from your CD to a hard drive.

- System requirements
- Installation instructions
- Starting and exiting PanelBuilder32

PanelBuilder32 installs directly from your CD to a hard drive. The CD also contains a disk installation procedure for installing the 16-bit, 2.60 version of PanelBuilder. Refer to the .pdf version of publication 2711-6.0 for installation details.

System Requirements

- 100MHz Pentium Class 2 or greater PC compatible
- Windows 95, Windows 98, Windows 2000, Windows Millenium Edition (ME), Windows XP, Windows NT 4.0 (or later) or Windows Vista operating system
- 30 MB free hard disk space required for a minimum installation
- 270 MB free hard disk space required for a full package installation
- 32 MB of installed RAM (48 MB RAM recommended)
- CD-ROM drive
- 500K free conventional memory

Installing PanelBuilder32

Before you start the installation, close all programs that are active.

To install PanelBuilder32:

1. Insert the CD into your CD ROM drive. The installation is set to automatically run. If it doesn’t, run Setup.exe from the CD.

2. Follow the instructions on the screen. By default, PanelBuilder32 is installed in C:\Program Files\Allen-Bradley\PanelBuilder32.

3. The installation program prompts you to select a type of setup:

   Typical: Installs all PanelBuilder32 options and is intended for the typical user.
**Typical (without RSLinx Classic):** Installs PanelBuilder32 without RSLinx Classic. Select this option if you already have the required version of RSLinx installed.

**Compact:** Installs PanelBuilder32 without RSLinx Classic, External Fonts or Support Files. Select this option if you are installing on a computer with limited resources.

**Custom:** Select this option if you are an experienced user and would like to customize the selection of installed options. The disk space required for each option is listed with available disk space.

<table>
<thead>
<tr>
<th>Custom Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Program Files</td>
<td>All the files necessary to run PanelBuilder32.</td>
</tr>
<tr>
<td>RSLinx Classic</td>
<td>Installs RSLinx Classic which is required to configure communication drivers for transferring applications.</td>
</tr>
<tr>
<td>External Fonts</td>
<td>Installs the FontTool Utility used to create font files for PanelBuilder32 applications.</td>
</tr>
<tr>
<td>Support Files</td>
<td>Installs demo, sample, library and documentation (including online help) files.</td>
</tr>
</tbody>
</table>

4. When the installation finishes, PanelBuilder32 programs appear on the Start menu under Programs>PanelBuilder32.

RSLinx appears on the Start menu under Programs>Rockwell Software>RSLinx.
Starting and Exiting PanelBuilder32

Follow these directions to start PanelBuilder32:

1. From the Start menu, click Programs.

2. Select PanelBuilder32 and click PanelBuilder32.

The startup screen appears with copyright and release information followed by a dialog that allows you to create, open, download or upload an application.

Follow these directions to exit PanelBuilder32:

1. From the File menu, click Close.

   All open screens for the current application close.

   If you’ve made any changes to the application since the last save, you are prompted to save the application before closing it.

2. Click Exit from the File menu.
Using PanelBuilder32

Like most Window applications, PanelBuilder32 uses menus, toolbars, dialogs and windows to perform operations. This chapter covers:

- Startup dialog
- Application window
- Screen window
- Toolbars
- Status bar
- Right-click menus
- Setting preferences and defaults
- Online help

Startup Dialog

Each time you start PanelBuilder32, the startup dialog opens letting you know what operations you can perform: create, open, download or upload an application. This is the same as selecting a command from the File menu.

You can disable this dialog on the General tab of the Tools>Options dialog.
Chapter 2  Using PanelBuilder32

Application Window

Whenever you open a new or existing application, the Application window appears. This window provides an overall view of an application. Its expandable/collapsible folders provide quick access to key application components. Just double-click an icon in a folder to open a screen, dialog or spreadsheet. Operations accessed from the Application window are also available from menus.

The Application window can be docked or fixed at the left side of the PanelBuilder32 window so it doesn’t interfere with the view of application screens. When undocked (or floating), you can move or size the Application window like any other window. The Application window is docked or undocked from the View menu.

If more than one application is open, an Application window appears for each application.

<table>
<thead>
<tr>
<th>Application Folders</th>
<th>Double-click this icon</th>
<th>Application Folder Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>Description</td>
<td>Enter a description or rename the application.</td>
</tr>
<tr>
<td></td>
<td>Print Only Objects</td>
<td>Configure an object that prints triggered messages for terminals that support printing.</td>
</tr>
<tr>
<td></td>
<td>Panel Indicator Objects</td>
<td>Configure horn/LED indicators for specific terminals.</td>
</tr>
<tr>
<td>Exceptions</td>
<td></td>
<td>Open the Exceptions window which shows errors and warnings that occur when an application is validated.</td>
</tr>
<tr>
<td>Text Editor</td>
<td></td>
<td>Access all text strings defined in the application.</td>
</tr>
<tr>
<td>Tag Database</td>
<td></td>
<td>Open the Tag Editor which defines all read and write tags in the application.</td>
</tr>
<tr>
<td>Application Folders</td>
<td>Double-click this icon</td>
<td>Application Folder Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Application settings</td>
<td>Terminal Setup</td>
<td>Change the selected terminal for the application.</td>
</tr>
<tr>
<td></td>
<td>Communications Setup</td>
<td>Define terminal/controller settings for runtime.</td>
</tr>
<tr>
<td></td>
<td>Display Maintenance</td>
<td>Set a schedule for reconditioning the screen of specific PanelView terminals.</td>
</tr>
<tr>
<td></td>
<td>External Fonts</td>
<td>Enable an external font file which is used to enter application text in another language. Font files are created with the FontTool utility.</td>
</tr>
<tr>
<td></td>
<td>Printer</td>
<td>Configure the printer port and print options for a terminal with an RS-232 port.</td>
</tr>
<tr>
<td></td>
<td>Status Tags</td>
<td>Define tags used by the controller to monitor the number of the current screen, time or date.</td>
</tr>
<tr>
<td></td>
<td>Control Tags</td>
<td>Define tags used by the controller to change the current screen, time or date.</td>
</tr>
<tr>
<td></td>
<td>Time / Date</td>
<td>Format how the date/time will appear on the terminal. All objects that display a time or date use this format.</td>
</tr>
<tr>
<td></td>
<td>Advanced</td>
<td>Configure options such as the screen saver, display options, auto-repeat settings for keys/touch cells.</td>
</tr>
<tr>
<td></td>
<td>Power-Up</td>
<td>Configure power-up defaults for the terminal.</td>
</tr>
<tr>
<td></td>
<td>Project</td>
<td>Enable/disable use of a project for shared tags.</td>
</tr>
<tr>
<td></td>
<td>Security</td>
<td>Define screen/terminal security for an application.</td>
</tr>
</tbody>
</table>

| Alarms               | Setup                  | Configure global parameters for all alarms. |
|                      | Alarm Triggers         | Define triggers for alarm messages. |
|                      | Alarm Messages         | Configure alarm messages. |

| Screens              | Alarm Banner (example) | Open a screen. An icon appears for each application screen by name and number. Screens appear in sequential order in the Screens folder. |
|                      | 1 - Motor Speed 1      | |
|                      | 2 - Motor Status 2      | |
Screen Window

The Screen window (resembling the front panel of a terminal) appears when you open a new or existing screen. The title bar shows the name and number of the screen. Screens are moved and sized like any other window.

You can drop objects inside the display area of the screen or on a function key depending on the terminal type. The mouse pointer changes to a crosshair (+) when objects are dropped in either of these areas. Objects are accessed from the Objects menu or the Toolbox (available from the View>Toolbars dialog). Select an object and click in the screen to drop the default size of the object or drag to size the object.

Touch Grid

Touch screen terminals use a touch grid to align control objects such as push buttons with the touch cells. Push buttons are moved and sized in increments of touch cells. The size of the touch grid (number of touch cells) varies for each terminal. To show or hide the grid, Select View>Touch Grid. The touch grid is active for input objects even if the view is turned off.

To align display or graphic objects on touch screen terminals, use the Grid.

Grid

A grid is also available on Keypad terminals to align objects. Default grid spacing is set for screens based on the terminal type. You can change the grid spacing when creating a new screen or changing the properties of a screen. To show or hide the grid, select View>Grid.
Toolbars

There are nine toolbars available in PanelBuilder32. They give access to commands and dialogs with just the click of a button. Most toolbars are initially docked (or anchored) below the menu bar.

All toolbars can float or be docked. To undock a toolbar, click one of its edges and drag the toolbar to the middle of the screen. When undocked, the toolbar looks like any other window. To dock a toolbar, drag it to any edge of the screen - top, bottom, left or right. You can also double-click a toolbar to dock or float it.

Showing or Hiding the Toolbars

To access the toolbars, click View>Toolbars, then select the check boxes next to the toolbars you want to display. To hide a toolbar, clear the appropriate check box.

ToolTips

If you place the mouse pointer over an icon (toolbar, toolbox or color palette) without clicking, a help prompt known as a tooltip appears below the icon. Tooltips are enabled or disabled from the View>Toolbars dialog.

If you want even more help, select the arrow icon on the toolbar or press Shift+F1 and then click on any icon.
Chapter 2  Using PanelBuilder32

Standard Toolbar

Provides file, screen management and editing tools.

![Standard Toolbar](image)

State Toolbar

Accesses states of a multistate or list object, inner text mode and inner graphic mode. Also has zoom icons to magnify or reduce the view of a screen.

![State Toolbar](image)

Inner Text Toolbar

Enters, formats and aligns text in objects. From this toolbar, you can edit text in the text box, click the down-arrow to open the Text Edit dialog or open the application Text Editor. You can also insert variables in the text.

![Inner Text Toolbar](image)

Format Toolbar

Applies formatting to objects such as line type, fill pattern, shape, reverse video and blinking. Also has icons to group/ungroup objects or stack objects.

![Format Toolbar](image)

Graphics Toolbar

Provides a list of bitmaps or ISA symbols you can insert in an object. You can also import graphics from this toolbar.

![Graphics Toolbar](image)
ISA Symbols Toolbox

Contains standard ISA symbols. You can drop these objects directly onto a screen or insert them in an object (when in Inner Graphic mode).

Toolbox

Contains objects (controls, displays, alarms, graphics) you can drop on a screen. These objects are also accessed from the Objects menu.

Color Palette

Applies foreground and background colors to objects, text or graphics. For color terminals with firmware 4.10 or later, the palette supports 32 colors. For grayscale terminals, the palette supports four colors (shades of gray). Left-click a color cell to apply a foreground color to the selection. Right-click a color cell to apply a background color to the selection.

Language Toolbar

Activates another language for application. The application can store text for up to five languages if the application is enabled for multiple language support.
Status Bar

The bar at the bottom of the window displays information about a command or toolbar button, an operation in progress, or the location of the insertion point.

When creating or selecting an object on an application screen, the status bar displays this information:

<table>
<thead>
<tr>
<th>ID number of object (assigned by PanelBuilder 32)</th>
<th>Coordinates of upper left corner of object (in pixels). Referenced from upper left corner of screen (x=0, Y=0)</th>
<th>width and height of object (in pixels)</th>
<th>location of insertion point</th>
<th>object selected</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object ID: 23</td>
<td>x=234, y=320, width=130, height=90</td>
<td>x=275, y=300</td>
<td></td>
<td>Maintained Push Button</td>
</tr>
</tbody>
</table>

Right-click Menus

Right-click menus are available for the most frequently used tasks. Simply right mouse click on an item and select from the available options on the menu. Right-click menus are available when you:

- Edit an object. Select an object and then right-click to copy, cut, paste, delete the object, or to edit the properties of an object.
- Edit a screen. Select a screen in the Screens folder of the Application window. Then right-click to create, open, copy, cut, delete, or edit the properties of a screen.
- Hide or show a toolbar. Right-click in the toolbar area to hide or show a toolbar, toolbox or palette.
- Edit states of multistate objects. Right-click in the States spreadsheet of an object’s dialog to append, delete or edit states of an object, or to insert a variable in the text field.
- Edit alarm messages and triggers. Right-click in the Alarm Messages or Alarm Triggers spreadsheet of the Alarms dialog to append, delete and edit alarms or triggers.
- Edit application text. Right-click in the Text Editor to append, delete, or edit text strings in the application.
- Correct validation errors. Select an error or warning in the Exceptions window and then right-click to navigate to the source of an error, correct, print or get help for an error. You can also hide or dock the Exceptions window.
- Edit tags. Right-click in the Tag Editor to copy, cut, paste, insert, duplicate, delete, or sort tags.
Setting Preferences and Defaults

You can customize or set defaults for many PanelBuilder32 operations by selecting Options on the Tools menu.

For details on setting preferences, open the Customizing PanelBuilder32 book in the Contents tab of the general help.

<table>
<thead>
<tr>
<th>Select this tab:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>General</td>
<td>• Enable/disable the display of the startup dialog when PanelBuilder32 starts.</td>
</tr>
<tr>
<td></td>
<td>• Enable/disable the automatic creation of screen 1 when a new application is created.</td>
</tr>
<tr>
<td></td>
<td>• Change the number of most recently used files that appear at the end of the File menu.</td>
</tr>
<tr>
<td></td>
<td>• Enable or disable the creation of backup (.BAK) files for PanelBuilder32 applications.</td>
</tr>
<tr>
<td></td>
<td>• Enable/disble the auto assignment of function keys to objects as they are created.</td>
</tr>
<tr>
<td>Default Terminal Selection</td>
<td>Select a PanelView terminal to use as the default for all new applications that are created.</td>
</tr>
<tr>
<td>Report Setup</td>
<td>• Define topics or attributes to include in application reports.</td>
</tr>
<tr>
<td></td>
<td>• Define the format of the title page and page headers for application reports.</td>
</tr>
<tr>
<td>Objects</td>
<td>Configure drop mode for objects (drop a single or multiple objects of the same type, and optionally display the properties of the object). Enable/disable the display of data tips for objects when the mouse pointer pauses on an object and what data tips to display.</td>
</tr>
<tr>
<td></td>
<td>Select the default text size and text alignment for objects.</td>
</tr>
<tr>
<td></td>
<td>Set the line width of the rectangle that is drawn when objects are created or sized.</td>
</tr>
<tr>
<td>Save</td>
<td>Save the .PBA and .PVA file when downloading an application.</td>
</tr>
<tr>
<td></td>
<td>Change the default locations for saving PanelBuilder32 application files and project files. The initial defaults are defined at installation.</td>
</tr>
<tr>
<td>Tag Edit</td>
<td>Define settings used when tags are duplicated in the Tag Editor. Also enables auto options for creating tag names from tag addresses and for converting tags to another protocol when an application is converted to run in a different terminal.</td>
</tr>
<tr>
<td>Tag Defaults</td>
<td>Define default values for tag attributes. These defaults are used when you create new tags or import tags in the Tag Editor.</td>
</tr>
</tbody>
</table>
Using PanelBuilder32

PanelBuilder32 provides extensive online help to assist you in application development. The online help includes overview information, step-by-step procedures and context-sensitive help. To view online help while using PanelBuilder32:

- select Help from the menu bar in PanelBuilder32.
- click the Help button on any dialog.
- press F1 or right-click and select What’s This? on any dialog field, menu item or window view.

General Help

Select Help>Contents from the PanelBuilder32 window.

- Click the Contents tab to scroll through the table of contents for the help file.
- Click the Index tab to search for topics by using an index of help subjects. Either type the word (or topic) you’re looking for or scroll through the list.
- Click the Find tab to search for words or phrases.
Dialog Help

Each dialog in PanelBuilder32 provides a Help button you can click to get information. This includes overview and step-by-step procedures. The example below shows the help that comes up when you are configuring a push button.

Context-sensitive Help

You can also get help for fields within a dialog.
Applications and Screens

This chapter covers these topics:

- Create a new application
- Open an application
- Work with application screens
- Save and close applications
- Generate application reports
- Check the size of an application
- Capture screen images

For more information on applications, open the Working with Applications book in the Contents tab of general help.

For more information on screens, open the Working with Screens book in the Contents tab of general help.

About File Types

PanelBuilder32 files use these file types:

- .PBA - refers to an application configured and saved in PanelBuilder32.
- .PVA - refers to an application saved in a PanelView Terminal format.
- .BAK - refers to a backup file automatically created by PanelBuilder32.

Creating a New Application

There are two ways to create a new application:

- Select Create a New Application from the startup dialog.
- Select File> New or click the New tool on the standard toolbar.
The Create a New Application dialog opens.

Enter a (1 to 32 character) name for the application.
Select the protocol of the terminal.
Select the operator input type.
Click to access different firmware versions of the terminal.

The Application window opens along with a blank screen.

An asterisk (*) appears after the application name until the file is saved.
To rename the screen, select Screen>Properties.

You can rename or enter a description for the application from the Application>Description dialog.

Opening an Application

There are two ways to open an existing application.

- Select Open an existing application from the startup dialog.
- The dialog shows all .PBA applications stored in the default applications folder. Select a file and click OK or just double-click on a file.
• Select File>Open or click the Open tool on the standard toolbar.

**TIP**
If you open a 16-bit application created with any earlier version of PanelBuilder, the application is automatically updated. When you save the application, it is saved in a 32-bit format.

The Application window opens for the application. The Screens folder shows all screens in the application.

### Working with Screens

Each application screen has these properties:

- Name (default is Screen 1, Screen 2, Screen 3, . . .)
- Number (sequential number 1-255)
- Background (screen color for color/grayscale terminals)
- Optional description
- Default grid spacing

When you create a new screen (Screen>New) or change the properties of a screen (Screen>Properties), a dialog opens so you can change the defaults.

![Screen Properties Dialog](image)

- Enter a descriptive name (up to 32 characters)
- Sequential number assigned to new screen.
- Appears only for color or grayscale terminals. You can change the color on a per screen basis. To apply setting to all new screens, click Set as Defaults. To restore last defaults saved, click Restore Defaults.
- The description appears in the application report.
- You can change the grid spacing on a per screen basis. To apply the settings to all new screens created for a terminal type, click Set as Defaults. To restore the last defaults saved, click Restore Defaults.
- Allows only authorized operators to access screen.
When you exit the dialog, a screen opens with the name and number showing in the title bar. A screen icon is also created in the Screens folder with the same name and number.

The Power-Up tab on the Application>Settings dialog is where you select the startup screen for the application.

### Basic Screen Operations

<table>
<thead>
<tr>
<th>To:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new screen</td>
<td>Select Screen&gt;New.</td>
</tr>
<tr>
<td>Open a screen</td>
<td>Double-click on a screen in the Screens folder or click on a screen and select Screen&gt;Open.</td>
</tr>
<tr>
<td>Change a screen properties</td>
<td>Click on a screen in the Screens folder and then select Screen&gt;Properties or right-click and select Properties.</td>
</tr>
<tr>
<td>Activate a screen</td>
<td>If multiple screens are open, select a screen from the lower portion of the Window menu or click anywhere inside a screen. On the Window menu, the active screen appears at the top of the open screen list.</td>
</tr>
<tr>
<td>Close a screen</td>
<td>Click X in the upper left corner of the window or click on a screen and select Screen&gt;Close.</td>
</tr>
<tr>
<td>Delete a screen</td>
<td>Click on a screen in the Screens folder, then select Edit&gt;Delete or press the Delete key. Deleted screens leave a numbering gap. New screens are created with the lowest available number.</td>
</tr>
</tbody>
</table>
| Copy or cut a screen          | • Select a screen in the Screens folder, then select Edit>Copy or Cut.  
                                     • Select Edit>Paste  
                                     Screens are pasted into the folder with the same name and number. If the number is used, the screen is pasted with the lowest available number. Numbering gaps are filled.  
                                     You can also copy or move screens between applications by right-clicking on the Screens folder in the target Application window and selecting Paste. |

Another way to select screen commands is to right-click on a screen in the Screens folder and select a command from the shortcut menu.
Selecting a Range of Screens

To select a range of screens in the Screens folder, hold down the Shift key, click the first screen and then the last screen in the range.

To select multiple screens that are not contiguous, hold down the Ctrl key while you click on each screen.

Dragging and Dropping Screens

Instead of using the Copy and Paste commands, you can drag and drop screens between two open applications. You can drag individual screens or the entire Screens folder. Position the Application windows side-by-side. Open the Screens folder in the source application. Drag the Screens folder or an individual screen over the Screens folder in the target Application window. Screens are pasted using the same screen numbers unless the numbers aren’t available (then the lowest available numbers are used).

Using Workbook Mode

In workbook mode, tabs are evenly spaced along the bottom of the screen workspace for all open screens. Each tab is labeled with the application name, screen number, and screen name. Pausing the mouse pointer over a tab displays this information. The tab for the active screen is on top. To activate a screen, just click a tab.

Workbook mode is turned on or off from the View menu. If the Application window is undocked, it will also have a tab.

Screen Security

You can restrict access to one or more application screens by requiring operators to enter a password before the screen is displayed at the terminal.

Other security options let you create a screen that would require the operator to press a login key and enter a password before logging in to the terminal. Or you can allow authorized operators to select and change the passwords of other operators at the terminal.

For more information on security, open the Working with Applications book and then the Working with Security book in the Contents tab of general help.
Saving an Application

You have two options for saving an application.

- Select File>Save or click the Save tool on the standard toolbar.

  The application is saved to the default location overwriting the previous version.

- Select File>Save As. The application is saved with a new name leaving the original intact.

The first time an application is saved, the Save As dialog opens. The default file name is the application name. The file type .PBA is appended to the file name.

A backup file (.BAK) is automatically created for the application with the same file name. Each time you save the application, the .BAK file is updated. To display the version number or save date of the application, click Application> Description.

Saving in Other Formats

<table>
<thead>
<tr>
<th>Save as types</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PanelBuilder32 (*.PBA)</td>
<td>Saves the application to a 32-bit .PBA file. This is the default.</td>
</tr>
<tr>
<td>PanelView Terminal (*.PVA)</td>
<td>Saves the application in a PanelView terminal (.PVA) format which can be downloaded to a terminal.</td>
</tr>
<tr>
<td>PanelBuilder 2.6 (*.PBA)</td>
<td>Saves the application in a 16-bit format compatible with version 2.60 (or later) of PanelBuilder.</td>
</tr>
<tr>
<td>PanelView 2.6 (*.PVA)</td>
<td>Saves the application in a 16-bit .PVA format compatible with previous firmware versions of the PanelView terminal. The only way to download a 16-bit .PVA file to a terminal is to use the WinPFT File Transfer Utility.</td>
</tr>
</tbody>
</table>
Closing an Application

To close the application and all open screens select File>Close or click the X in the upper left corner of the Application window. If you’ve made changes to the application since the last save, you are given the option of saving the file before closing it.

Generating an Application Report

You can generate a report documenting all or specific aspects of an application. Reports are useful for tracking application updates and changes.

The Report Setup tab of the Tools>Options dialog defines what information to include in the report and the format of the page headers and title page. You can customize the report for your needs.

To print the report based on the above selections, select File>Reports. Before clicking Print in the dialog, you can specify whether to generate the report for:

- All screens or a
- range of screens.

You can also print the images for each screen along with an object summary.
Checking the Size of an Application

To compare the RAM size of an application with the file size and RAM limit of the PanelView terminal, select Application>Application Size.

The dialog shows the size of the application with and without upload information. The upload information includes the number of bytes required to upload these components of an application:

- Objects
- Tags and devices

The dialog also shows the size of the application without the above upload information. You can upload an application without the above data, but you would have to re-create the application including all screens, objects, tags and communication settings for devices.

Capturing Screen Images

Use the Screen>Capture Manager dialog to take screen captures of one or more screens in the active application and:

- copy to clipboard.
- copy to .BMP file.
- import as bitmap images into current application. These images are then available from the graphics toolbar while in inner graphic mode.

Screens can be captured at their normal size, thumbnail size, or a percentage of their normal size. For optimum resolution, select View>Full Size to zoom screen to full size before capturing image. If you do not zoom the screen to full size, the captured image may be distorted.

You capture a single screen or multiple screens at one time. If capturing multiple screens, you can save each image in its own .bmp file or save them all in a single .bmp file. You can even specify the layout of the images in the file (horizontal strip, vertical strip, or specific number of images per row).

TIP Use the Screen>Capture to Clipboard command to quickly capture the active screen to the clipboard.
Working with Screen Objects

This chapter covers these topics:

- Overview of screen objects
- Things to know about objects
- Create objects
- Configure the properties of an object
- Configure states of multistate or list objects
- Push buttons
- Control list selectors
- Numeric entry controls
- ASCII entry controls
- Message displays
- Data displays
- Screen selectors
- Global objects

Overview of Objects

Objects are graphics displayed on the PanelView terminal. Objects may be a simple line of text, a graphic, control or alarm banner. Some objects are static, they provide visual information but don’t provide any type of control function. Other objects such as control list selectors are dynamic and interact with both the terminal operator and logic controller. Dynamic objects are linked to a logic controller by a tag. A tag contains the object’s address and other parameters such as data type that allows data to be read or written with a logic controller.

For complete details on the different objects available, open the Creating Control and Display Objects book in the Contents tab of general help.
**Push Buttons**

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Momentary</td>
<td>Changes state when pressed and returns to original state when released.</td>
</tr>
<tr>
<td>Maintained</td>
<td>Changes state when pressed and remains in changed state when released.</td>
</tr>
<tr>
<td>Latched</td>
<td>Changes state when pressed and remains in latched state until unlatched by logic controller.</td>
</tr>
<tr>
<td>Multistate</td>
<td>Supports 2-16 states. Changes to next state each time button is pressed.</td>
</tr>
</tbody>
</table>

**Control List Selectors**

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standard</td>
<td>List type selector allows an operator to select a state from a scrolling list of up to 255 control states.</td>
</tr>
<tr>
<td>Piloted</td>
<td>Same as the standard control list but access to list can be restricted to the logic controller, operator, or both.</td>
</tr>
</tbody>
</table>

**Numeric Entry Objects**

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursor Point</td>
<td>Displays the current value at a logic controller address. When selected, opens the numeric scratchpad allowing the operator to send a new value to the controller.</td>
</tr>
<tr>
<td>Keypad Enable</td>
<td>When pressed, opens the numeric scratchpad allowing the operator to send a new value to the controller.</td>
</tr>
<tr>
<td>Inc/Dec</td>
<td>Increments a numeric value using fine or coarse step control.</td>
</tr>
</tbody>
</table>

**ASCII Entry Objects**

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursor Point</td>
<td>Displays a character string at a controller address. When selected, opens the ASCII scratchpad allowing the operator to enter and send a character string to the controller.</td>
</tr>
<tr>
<td>Keypad Enable</td>
<td>When pressed, opens the ASCII scratchpad allowing the operator to enter and send a character string to the controller.</td>
</tr>
</tbody>
</table>
Indicators and Data Displays

<table>
<thead>
<tr>
<th>Indicator Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multistate Indicator</td>
<td>Displays up to 2,000 unique states as determined by a value at the object’s controller address.</td>
</tr>
<tr>
<td>List Indicator</td>
<td>Displays up to 256 items in a scrolling list. The currently highlighted item is determined by a value at the object’s controller address.</td>
</tr>
<tr>
<td>Bar Graph</td>
<td>Displays changing data as a vertical or horizontal bar. Add linear scale.</td>
</tr>
<tr>
<td>Gauge</td>
<td>Shows a process variable as a rotating needle on a gauge, with a circular scale and tick marks. A gauge supports up to 4 needles.</td>
</tr>
<tr>
<td>Scale</td>
<td>Linear or circular scale with tick marks. Tick marks added as text objects.</td>
</tr>
<tr>
<td>Numeric Data Display</td>
<td>Shows current value at a controller address (binary, BCD, integer, float).</td>
</tr>
<tr>
<td>Message Display</td>
<td>Displays status information or instructions to an operator.</td>
</tr>
<tr>
<td>Print Only Message Object</td>
<td>Similar to Message Displays except the message is printed rather than displayed on the screen.</td>
</tr>
<tr>
<td>Panel Indicator Setup</td>
<td>Configures the different states for the horn and leds on terminals that support these features.</td>
</tr>
</tbody>
</table>

Screen Selectors

<table>
<thead>
<tr>
<th>Button Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Goto Screen Button</td>
<td>Displays a specified application screen.</td>
</tr>
<tr>
<td>Goto Config Screen Button</td>
<td>Displays the terminal’s Configuration Mode menu.</td>
</tr>
<tr>
<td>Return Screen Button</td>
<td>Returns to a previous screen.</td>
</tr>
<tr>
<td>Screen List Selector</td>
<td>Displays a screen selected from a list of screens.</td>
</tr>
</tbody>
</table>

Variables

<table>
<thead>
<tr>
<th>Variable Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time, Date</td>
<td>Displays the current time and date in a text string or object.</td>
</tr>
<tr>
<td>ASCII Variable</td>
<td>Displays an ASCII variable in a text string or object.</td>
</tr>
<tr>
<td>Numeric Variable</td>
<td>Displays a numeric value in a text string or object.</td>
</tr>
</tbody>
</table>

List Keys

<table>
<thead>
<tr>
<th>Key Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move Up, Move Down</td>
<td>Controls cursor movement in a control or screen list selector.</td>
</tr>
<tr>
<td>Page Up, Page Down</td>
<td>Moves the cursor up or down a page in a scrolling control or screen selector list.</td>
</tr>
<tr>
<td>Home, End</td>
<td>Moves the cursor to the first or last item in a control or screen selector list.</td>
</tr>
<tr>
<td>Backspace</td>
<td>Returns cursor to its previous position in a control or screen selector list.</td>
</tr>
<tr>
<td>Enter</td>
<td>Displays or confirms a list selection.</td>
</tr>
</tbody>
</table>
Chapter 4  Working with Screen Objects

Security Keys

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Login</td>
<td>Logs an authorized operator into the terminal after entering a password.</td>
</tr>
<tr>
<td>Logout</td>
<td>Logs the operator off the terminal.</td>
</tr>
<tr>
<td>Select Operator</td>
<td>Allows an authorized operator to change the password for a selected operator. The Select Operator, New Password, and Verify Password keys must be used together on a screen.</td>
</tr>
<tr>
<td>Enable Security</td>
<td>Enables or disables security at the terminal. When disabled, all screens are unsecured meaning any operator can access any application screen.</td>
</tr>
<tr>
<td>New Password</td>
<td>Requires the operator to enter a new password at the terminal. The Select Operator, New Password, and Verify Password keys must be used together on a screen.</td>
</tr>
<tr>
<td>Verify Password</td>
<td>Requires the operator to verify the new password entered at the terminal. The Select Operator, New Password, and Verify Password keys must be used together on a screen.</td>
</tr>
</tbody>
</table>

Alarm List and Alarm Buttons

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm Banner</td>
<td>Defines the screen area in which alarm and alarm control buttons appear on a screen.</td>
</tr>
<tr>
<td>Acknowledge Button</td>
<td>Acknowledges the displayed alarm.</td>
</tr>
<tr>
<td>Clear Button</td>
<td>Clears but does not acknowledge an alarm.</td>
</tr>
<tr>
<td>Print Button</td>
<td>Prints the currently displayed alarm message.</td>
</tr>
<tr>
<td>Acknowledge All Button</td>
<td>Acknowledges all alarms (current &amp; pending).</td>
</tr>
<tr>
<td>Alarm List</td>
<td>Displays a list of triggered alarms.</td>
</tr>
<tr>
<td>Print Alarm List Button</td>
<td>Prints all alarms in the alarm list.</td>
</tr>
<tr>
<td>Clear Alarm List Button</td>
<td>Clears the alarm list and also clears the Alarm banner</td>
</tr>
</tbody>
</table>

Graphics and Text

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line, Rectangle, Circle, Ellipse</td>
<td>Graphic shapes</td>
</tr>
<tr>
<td>Freeform</td>
<td>Freeform line art</td>
</tr>
<tr>
<td>ISA Symbols</td>
<td>Standard ISA symbols</td>
</tr>
<tr>
<td>Imported Graphic</td>
<td>Bitmap artwork.</td>
</tr>
<tr>
<td>Background Text</td>
<td>Text in various font sizes and styles.</td>
</tr>
<tr>
<td>Scrolling Text</td>
<td>Text scrolls from right to left at a set rate.</td>
</tr>
</tbody>
</table>
### Things to Know About Objects

For complete details, open the Working with Objects book in the Contents tab of general help.

### Selecting and Deselecting Objects

<table>
<thead>
<tr>
<th>To:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an object</td>
<td>Click anywhere on the object. Handles appear around the object.</td>
</tr>
<tr>
<td>Deselect an object</td>
<td>Click anywhere outside the object or click another object.</td>
</tr>
<tr>
<td>Select multiple objects</td>
<td>Click and drag a rectangle that encloses the objects.</td>
</tr>
<tr>
<td></td>
<td>Or hold down the Shift key while you select each object.</td>
</tr>
<tr>
<td>Select all objects</td>
<td>Click Edit-&gt;Select All.</td>
</tr>
</tbody>
</table>

### Sizing and Moving Objects

<table>
<thead>
<tr>
<th>To:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Size an object</td>
<td>Select the object, then position the mouse pointer over a handle to show the direction you can size the object. Drag the handle until the object is the right size. You can also use the arrow keys (up, down, left, right) on your keyboard to resize an object. Select the object, hold down the Shift key and press one of the arrow keys to resize the object horizontally or vertically.</td>
</tr>
<tr>
<td>Move an object</td>
<td>Position the pointer over the object and then drag the object to a new location. Or use the arrow keys (up, down, left, right) on your keyboard to move the object up, down, left or right.</td>
</tr>
</tbody>
</table>
Chapter 4  Working with Screen Objects

Grouping and Ungrouping Objects

To: Do this:

Group a set of objects
Select the objects you want to group, then select Arrange>Group. An outline appears around the grouped objects.

Selecting an object in the group selects the entire group. You can move, size, cut/copy/paste or delete objects in a single operation. You can also size an object while maintaining its group status.

Ungroup objects
Select the group and then select Arrange/Ungroup. Deselect the group before selecting a single object.

Regroup objects
To reassemble a former group of objects, select Arrange>Regroup.

Stacking Objects

You can change the stacking order of objects that overlap on the screen using commands on the Arrange menu.

Aligning Objects Along a Horizontal or Vertical Plane

You can align objects horizontally or vertically by their left, right, top or bottom edges or midpoints from the Arrange menu. To align 2 or more objects by their center points so that they overlap, use the Align Center Points command.

Aligning objects horizontally
Align top
Align middle
Align bottom

Aligning objects vertically
Align left
Align right
Align centers
Spacing Objects Evenly Either Horizontally or Vertically

To adjust the spacing between 3 or more objects so they have equal spacing between them, use the Space Evenly Horizontal or Space Evenly Vertical commands on the Arrange menu.

Flipping Objects Horizontally or Vertically

You can flip the positions of 2 or more objects horizontally (left to right) or vertically (top to bottom) from the Arrange menu.

Zooming In or Out

You can increase the view of the screen so that objects look larger or smaller than their actual size. Select View>Zoom In to magnify the view and Zoom Out to reduce the view. The view can be magnified or decreased several times. To return the screen to its normal size, select View>Full Size.

Copying or Moving Objects

You can copy or move objects:

• on the same screen
• to another screen
• to a screen in another application

Use the Edit>Copy, Cut and Paste commands or tools to copy or move objects. When you copy or cut an object, an outline of the object appears. Move the outline to a new location and then paste it. When using these commands, the destination screen must be open. If the target screen is in another application, then both the target Application window and screen must be open.

Another way to select these commands is to right-click on the object.
Easier yet, you can drag objects between open screens or closed screens. If dragging an object over a closed screen in the Screens folder, the screen automatically opens. You can then move the object. To copy the object instead of moving it, hold down the Ctrl key while you drag.

Objects retain all properties during copy and move operations.

**Showing Data Tips for Objects**

Data tips provide quick access to information about objects including its type, tag name/address, node name/address of logic controller, number of states, its global status and grouped status. To see data tips for an object, just pause the mouse pointer over the object.

To customize the type of information you want to show for an object or to disable data tips, select the Objects tab on the Tools>Options dialog.

**Create Screen Objects**

All objects are placed on the screen in the same way.

1. Select an object from the Objects menu or the Toolbox.
2. Position the mouse pointer (+) in the screen where you want to drop a single object.

   **TIP** To change the drop mode for objects, select the Objects tab on the Tools>Options dialog. You can drop a single object, multiple objects of the same type, and/or open the object’s dialog after dropping the objects.

3. Click to drop the default size or drag to size the object.

   Many objects have default inner text you can change. You will see an asterisk (*) if the object is too small to fit all the text. Just resize the object.

   ![Push Button](image1) ![Screen Button](image2) ![Screen List Selector](image3)

   **TIP** You can drop some objects on function keys rather than displaying them on the screen. This is useful if function keys perform the same operation regardless of which screen is displayed. Position the pointer (+) over a function key and click. A graphic appears on the function key for the object. To delete an object on a key, select the key and select Edit>Delete.

For each object you place on the screen, the status bar shows:

- object ID number (assigned by PanelBuilder32)
- X and Y coordinates of upper left corner of object (in pixels)
- width and height of object (in pixels)
- object type (right side of bar)
**Configure Properties of Objects**

Most objects, except for graphics and text, have properties that define their operation and how they interact with the PanelView terminal and logic controller. To access the properties of an object, double-click the object. You can also left-click on the object and then select Edit>Object Properties.

![Control Object](image)

Control objects have a **Write Tag**. This tag defines the logic controller address where the terminal writes data for the object. Objects may have more than one tag.

![Display Object](image)

Display objects have a **Read Tag**. This tag defines the logic controller address the terminal reads to display data for the object.

Properties are unique to each object. For control objects, the **Input area** defines whether the object is activated by a function key or touch cell on the PanelView terminal. On the PanelView 300 Micro, you can also assign the arrow keys to objects. Touch cell is automatically enabled for touch-screen terminals.

**TIP**

For keypad terminals, function keys are automatically assigned to objects. To disable this feature, select the **General tab** on the Tools>Options dialog.

Use the **Options tab** to:

- enter an optional description for the object.
- make an object available for global use so that you can reuse it on other screens. See page 60 for more details on global objects.
- hide the view of a control object if screen space is limited (the function key or touch cell is still active). For touch screens you must place a graphic over the hidden object so the operator doesn’t inadvertently touch that screen area and activate the function.
Configuring States of Multistate or List Objects

The dialogs for multistate or list objects have a States tab. This tab appears as a spreadsheet and provides a convenient way to enter text and other formatting options for each state.

Each row in the spreadsheet represents a separate state or entry. The fields in each row define the text and other formatting options for each state. Some fields require text, some provide a drop-down list of available options and others have a check box for toggling a feature on or off. The fields in each row are specific to the object.

Many state operations are performed by selecting a command from a shortcut menu. When you right-click or press Ctrl+M in the States tab, a menu opens.

For example, to add or remove states or entries, right-click on the States tab and select Append State or Delete State from the shortcut menu. Use only the number of states or entries required by the application. Unused states take up application memory.

Other menu commands let you move states, edit states, delete states or embed variables within the Text field of a state. You can even copy text that already exists in the application by using the Use Existing Text command.
Screen push buttons function like mechanical push buttons, where a logic value of 0 represents open contacts and a logic value of 1 represents closed contacts. Each push button can be assigned normally open / normally closed contacts or you can assign a numeric value to each push button state.

**Momentary Push Button** changes state when pressed and returns to its initial state when released. The push button is held in the pressed state for 500 milliseconds (1/2 second). You can specify a different hold time on the Properties tab of the Push Buttons dialog.

**Maintained Push Button** changes state when pressed and remains in the changed state when released. Pressing and releasing the push button again returns the push button to its initial state. Maintained push buttons maintain their last state following screen changes. The Power-Up tab on the Application Settings dialog determines the initial state on powerup.

**Latched Push Button** changes state when pressed and remains in the changed state when released. The push button does not return to its initial state until it is unlatched by setting a handshake bit or value. The latched status is not maintained after a power-up but is retained between screen changes. The push button will not unlatch unless the current screen is showing the latched button.

Latched push buttons require a handshake tag to unlatch the push button. The button is unlatched when the tag’s address contains a non-zero value.

**Multistate Push Button** has 2 - 16 states. Each state is assigned a bit or a value. Each time the push button is pressed, it changes to the next state. After the last state, the push button returns to its initial state. Push button states are maintained between screen changes. The Power-Up tab on the Application Settings dialog determines the initial state on powerup.
Push Button Text and Graphics

Push buttons can have inner text and/or inner graphic. You can assign different inner text/graphics to each state. Inner text can also contain a time, date, numeric or ASCII variable. When you first create a push button, the inner text defaults to ST 0 - ST 3.

Editing Push Button States

Text and other formatting options for states are entered on the States tab of the object’s dialog. To add or remove states for a multistate push button, right-click on the States tab and select Append State or Delete State from the shortcut menu.

Safety Considerations

ATTENTION

Don’t place emergency stop buttons or controls critical for safe operation on a screen. Use separate hard-wired operator interface devices. Reference the inside cover of his manual for appropriate standards.

- Don’t place important push buttons in the middle of touch screens. They may be blocked temporarily by alarm messages, alarm banner or the scratchpad.
- Place push buttons far enough apart on touch screens so the operator doesn’t mistakenly press two objects, resulting in unintended operation.
- Push buttons are disabled for 1/2 second after a screen change. The terminal will not respond to push buttons on a new screen until push buttons from the previous screen are released.
Control List Selectors

Control list selectors perform many of the same functions as push buttons, including set value and on/off controls. A control list is a scrolling list that can contain up to 255 different states. The initial state value is set in the Properties tab of the dialog. This value is sent to the logic controller on power-up.

Standard Control Lists

On standard control lists, a cursor is moved to select a state on the list. On keypad terminals, the operator uses the up and down arrow keys to move the cursor and the Enter key to send the state to the logic controller.

Touch screen terminals require list keys on the screen to enable the operator to move the cursor and send a state to the controller.

If a screen contains multiple control lists, a vertical bar appears to the left of the active list. The operator selects a control list by pressing the touch screen, the assigned function key, or the left and right arrow keys.

Piloted Control Lists

Use a Piloted control list to restrict access to the control list. For each state, you can restrict access to controller only, user only, user and controller, or no access. The initial state must allow user access.

The logic controller selects a state by setting the Control Tag value to 1 and then writing the state value to the Search Tag address. The PanelView reads the value at the Search Tag and highlights the corresponding state on the control list. The PanelView then writes the state value to the Write Tag assigned to the control list.
Block Write Data (Piloted Control List Only)

Use the Block Write tag to write all states displayed in the control list to a block of addresses in the logic controller. The Block Write Start tag defines the starting address for the operation. Reserve one address following the Block Write Tag address for each state in the control list. The maximum number of states the Block Write tag supports depends on tag data type size and protocol specific data transfer limits.

Inactive States (Piloted Control List Only)

Inactive states on the list cannot be selected by the operator. The cursor is hollow when moved to an inactive state. Inactive states are included with the block write data sent to the logic controller.

Editing States of a Control List

Text and other formatting options for each state are defined on the States tab of the object’s dialog. To add or delete states, right-click in the States tab and select Append State or Delete State from the shortcut menu. Use only the number of states required. Each state is limited to one line. Any changes to text size apply to the entire list.
**Numeric Entry Controls**

The Keypad Enable and Cursor Point controls allow an operator to enter and send a numeric value to a logic controller address. Both numeric entry controls open a numeric entry scratchpad where the operator enters the numeric value. The Inc/Dec control allows the operator to increment or decrement a value in predefined steps.

The initial value for numeric entry controls is set in the tag editor. This value is sent to the controller on powerup. (Not all protocols write values to controller on powerup). The initial value is not scaled, so must be entered in units used by the logic controller. For example, the terminal uses °C and the controller °F. To initialize the terminal for 32 °F, the initial value in the tag editor must be entered as 32 not 0.

**Keypad Enable Button**

The keypad enable button is a momentary push button which can display a value at a logic controller address. When pressed, this button opens the numeric scratchpad and enables the terminal keypad for data entry.

**Cursor Point**

A cursor point is a data box that can display a value stored at a controller address. When the cursor point is selected and the Enter key or a numeric key is pressed, the numeric scratchpad opens and the terminal keypad is enabled for data entry.

The operator selects a cursor point by pressing the touch screen, the assigned function key, or the left/right arrow keys on the terminal. The indicator bar to the left of the object shows the active cursor point.
Inc/Dec Control

The Inc/Dec control increments or decrements a numeric value in programmed steps. Each time the operator presses the Up or Down key, the current value is incremented or decremented using the defined step value and sent to the controller. Touch screen terminals require lists keys on the screen to increment or decrement the value.

Numeric Scratchpad

The numeric scratchpad opens in the center of the terminal screen when a numeric entry control is selected. The top of the scratchpad shows the current value entered. Below the current value is the range of values the operator can enter. The data entry limits for values are set in the tag editor. The look of the numeric scratchpad varies for PanelView terminals.

Terminals without a numeric keypad or touch screen (PanelView 300 or 300 Micro) use a thumbwheel scratchpad to enter characters. Search for thumbwheel scratchpad in the index of the online help.

Scaling Data

Data entered by the operator can be scaled using the following formula.

\[
\text{Value Stored at Controller} = \frac{\text{Entered Value} - \text{Offset}}{\text{Scale}}
\]

Scale and offset values are entered in the tag editor. If a scaled value exceeds the range for the selected data type, the terminal displays an error message.

Precision and Rounding - Except for floating point values, the logic controller stores all values as integers. Digits to the right of a decimal point are rounded. However, the terminal can scale decimal values to or from integer values.
ASCII Entry Controls

ASCII entry controls allow an operator to send an alphanumeric string (up to 128 characters) to a logic controller. Note that not all controllers support 128 characters. Like numeric entry controls, the ASCII controls can appear on a terminal screen as either a keypad enable button or a cursor point.

The initial value for the ASCII entry controls is set in the tag editor. This value is sent to the controller on power-up and may also be configured to display in the object.

Keypad Enable Button

The keypad enable button is a momentary push button which can display an ASCII character string at a controller address. When pressed, the keypad enable button opens the ASCII scratchpad allowing the operator to enter and send a new character string to the logic controller.

Cursor Point

The cursor point is a data box which displays an ASCII character string at a controller address. Multiple cursor points may appear on a screen. An indicator bar to the left of the object indicates the active cursor point. The operator selects a cursor point by pressing the touch screen, the assigned function key, or the terminal’s left/right arrow keys.

When entering a string such as a password in the scratchpad, a security feature is available allowing you to mask each character. For example, if the operator entered the password, LETMEIN, the characters would appear as ####### in the scratchpad. Each character is replaced with #.
ASCII Scratchpad

The look of the ASCII scratchpad varies for the PanelView terminals.

Characters selected on the scratchpad keyboard are entered in the display area. This area scrolls so that all of the characters in the string may not be visible. All characters are sent to the controller whether or not they are visible. The controls for entering characters are different for each scratchpad. See the online help.

When the operator presses the Enter key on the terminal keypad or the touch screen, the string is sent to the logic controller. The leftmost character is placed in the high byte of the first word (using the write tag address), the next character in the low byte and so on. DeviceNet protocol allows for byte swapping.

Terminals without a numeric keypad or touch screen (PanelView 300 or 300 Micro) use a thumbwheel scratchpad to enter characters. Search for thumbwheel scratchpad in the index of the online help.

Scratchpad Support for Other Languages

The ASCII scratchpad is available with character keyboards in French, German, Italian and Spanish. If the PanelView terminal is configured for operation in one of these languages, the ASCII scratchpad automatically displays the character keyboard appropriate to the language.
Message Displays

Message displays present status information or instructions to an operator. Message displays can show a variety of information.

- Status of a process
- Operator prompts
- Time / date
- Numeric or ASCII variable

Messages displays can be triggered by:

- Single bit.
- Least significant bit.
- Value.

Editing Messages

Text and other formatting options for messages are entered on the States tab of the object’s dialog. To add or remove messages for a message display, right-click on the States tab and select Append State or Delete State from the shortcut menu. Use only the number of messages required by the application.

The message display reserves one message as an error state to notify the operator when data is out of range or unavailable. You can change the default text for the error state or use a graphic. You cannot delete the error state.
Creating Objects to Print Messages

You can create a print only object that sends all triggered messages to a printer rather than displaying the messages on screen. Any variables in the message are also printed. Print objects are not linked to specific screens like message displays so messages can be triggered any time an application is running. To create a print object, select Application>Print Only Object Setup.

Print objects are only supported on terminals equipped with an RS-232 serial printer port. You enter messages similar to the way you do for message displays but without any formatting options.

Data Displays

Bar graphs, multistate indicators, list indicators, and numeric data displays show a numeric value or a graphic representation of data stored at a logic controller address.

Indicators do not have a “dead band” in which a range of values is interpreted as a single state. For most applications, the ladder logic should allow a range of values above and/or below the specified value to be interpreted as the same state.

Multistate Indicators

Multistate indicators can display up to 2,000 different states. Each state can display a unique numeric value or graphic. States can be triggered by a bit, least significant bit or value.

<table>
<thead>
<tr>
<th>State 0</th>
<th>State 1</th>
<th>State 2</th>
<th>State E</th>
</tr>
</thead>
<tbody>
<tr>
<td>![State 0 Icon]</td>
<td>![State 1 Icon]</td>
<td>![State 2 Icon]</td>
<td>![State E Icon]</td>
</tr>
</tbody>
</table>

Error state indicates data is out of range or multiple states triggered.
Bar Graphs

Bar graphs provide a visual representation of a numeric value at a controller address. You can specify the direction to fill the bar graph and the range of values represented. Scales can be added to bar graphs to show data ranges. Use the Text object to create tick-mark labels for the scale. You can also create inner text inside the bar graph to identify the bar graph.

Analog Gauges

The analog gauge is an indicator that uses a rotating needle to display a process variable such as speed, temperature or pressure. The gauge consists of a circular scale with tick marks, 1 to 4 needles, and a label with text or variable data. The circular scale is an integral part of the gauge but can be created separately, or you can create a secondary scale for the gauge. Tick mark labels are created using the Text object.

Each needle has its own read tag for tracking a process variable. You can enable or disable pegging for a needle. Pegging prevents a needle from moving outside the range of minimum and maximum values set for the needle.

The needle has attributes that you can adjust such as length, thickness, shape. Plus, you can set the needle to appear with a shadow or bi-colored.

When you resize a gauge, the needle is also resized according to the smallest dimension (height or width) of the gauge. The needle maintains its same relative position to the gauge.
List Indicators

List indicators are scrolling lists containing up to 255 entries with the current list entry highlighted. List entries can be triggered by a bit, least significant bit or value.

<table>
<thead>
<tr>
<th>Tank Level</th>
<th>Temperature Controls</th>
</tr>
</thead>
<tbody>
<tr>
<td>Empty</td>
<td>Off</td>
</tr>
<tr>
<td>1/4</td>
<td>Temperature Low</td>
</tr>
<tr>
<td>1/2</td>
<td>Normal</td>
</tr>
<tr>
<td>Full</td>
<td>Temperature High</td>
</tr>
</tbody>
</table>

Error State - no state is highlighted. This occurs if data is outside of valid range or multiple states are triggered.

Numeric Data Displays

Numeric data displays show actual or scaled values at a controller address. For the value, you can specify the field width (1 -12 digits), fixed or floating point decimal, zero fill or no zero fill. You can even add text around the value.

<table>
<thead>
<tr>
<th>90 PSI</th>
<th>090 PSI</th>
<th>90.25 PSI</th>
<th>**** PSI</th>
</tr>
</thead>
<tbody>
<tr>
<td>no zero fill</td>
<td>zero fill</td>
<td>decimal point</td>
<td></td>
</tr>
</tbody>
</table>

If a value exceeds the specified field width, the value is replaced with asterisks.

About Scaling

Controller data can be scaled by the PanelView before it is displayed. This allows you to take raw numeric values from devices such as sensors or thermocouples and convert them to standard units such as gallons, liters, pounds, degrees Fahrenheit. Data is scaled using the formula:

\[
\text{Scaled Value} = (\text{Scale Multiplier} \times \text{Controller Value}) + \text{Offset}
\]

The scale (multiplier) and offset values are entered in the Tag Editor for the display object. Values may be stored as an integer, then scaled by the terminal to be displayed with a fixed or floating point decimal.
Screen Selectors

Screen selector controls allow the operator to move between application screens. When screen space is limited, use screen buttons.

Screen Buttons

The following screen buttons are available. Place screen buttons in the same place on screens so operators can quickly navigate from screen to screen.

- **Goto Screen Button** is a momentary push button that displays a specific application screen when pressed.

- **Return Screen Button** is a momentary push button that returns to the previous screen when pressed. This control only goes back one screen. It does not provide a continuous link back to the first screen in the application.

- **Goto Config Screen Button** is a momentary push button that displays the terminal's Configuration Mode menu when pressed. This menu accesses terminal functions such as communications settings, the current time/date format and language settings.

Screen List Selector

- **Screen List Selector** is a list control that contains a menu (or list) of screens from which an operator can make a selection. A cursor indicates the current selection. The operator uses the up and down cursor keys on the terminal keypad to move the cursor and the Enter key to select a screen.

Touch screen terminals require list keys on the screen to enable the operator to control the cursor and also select a screen.

Multiple screen lists can be used on the same screen. To activate a list, the operator presses the assigned function key or the touch screen. Another way to select between lists is to use the left and right arrows on the terminal's keypad.
Editing Screen List Entries

Entries for a screen list are defined on the States tab of the object’s dialog. A screen list supports a maximum of 255 entries. Use only the number of entries required by the application.

To add or delete entries in the screen list, right-click in the States tab and select Append State or Delete State from the shortcut menu. Each entry is limited to one line. Any changes to text size affect all entries in the list.

List Keys

List keys allow an operator to perform operations on lists such as a control or screen list selector. List keys are required on touch screen terminals but can also be used on terminals with a keypad. The list keys are available from the Objects>List Keys menu or the toolbox.

On the PanelView 300 Micro terminal, you can assign the cursor keys to objects, similar to function keys. However, if a screen has a control or screen list selector, the cursor keys cannot be assigned to objects and also used to move the cursor in a list.

Logic Controller Screen Changes

Your logic controller can control screen changes and return a screen value to the controller. Control and status tags are used to perform these logic controller functions. See page 129 in Chapter 10 for details.
Using Global Objects

A global object is a single object that can be referenced multiple times in an application while retaining the object’s properties. The object is created and stored only once in the PanelView regardless of the number of times it is used. Not only do global objects save time but they also reduce application memory.

You can edit the properties of a global object from any screen. All other occurrences of the global object are automatically updated with the changes.

Each control object must have a unique write tag unless the object is used as a global object. If control objects, that are not global objects, use the same write tag the application will not validate.

A global object can only be used once per screen. However, you can use different global objects on the same screen. Do not copy or paste global objects.

Follow these directions to make an object available for global use.

1. Double-click on the object.
2. Select the Options tab.
3. Select the Mark for Global Selection check box.

A grouped set of objects can be marked for global use by double-clicking the group and selecting the Options tab. If you enter a description for the object, the first few characters will appear in the Global Objects dialog when you reuse the object.
Follow these directions to reuse a global object:

1. Select Objects>Global Object or click the Global Object tool in the toolbox.

2. The Global Objects dialog opens identifying each global object by its tag name, object ID and object type, or description.

3. Double-click the object you want to reuse or select the object and click Copy To.

4. Position the crosshair (+) on a screen where you want to drop the object and left-click.

A global object doesn’t have to appear in the same place on each screen. Plus, you can assign a different function key to a global object when it is reused.

Any changes to a global object, except for screen location and function key assignment, apply to all instances of that object.
Working with Alarms

This chapter covers these topics:

- Overview of alarms
- Alarm banner and alarm lists
- Alarm buttons
- How to configure alarms (including defaults, triggers and messages)
- Alarm triggering examples

For complete details on alarms, open the Working with Alarms book in the Contents tab of general help.

Overview of Alarms

Alarms provide an operator with a visual or printed notification that a trigger value has been met or exceeded. This trigger value may be linked through a controller to a variety of production control sensors or monitoring programs. However, there are some safety considerations when doing this:

ATTENTION

Do not rely on the PanelView terminal as a primary warning device in applications that could result in physical injury, product damage, or significant process down time. All critical alarm indications and any critical logic controller responses must employ redundant and hard-wired / mechanical interlocks.

Each alarm has associated with it both a message and a trigger value. For each alarm you can specify whether or not the alarm must be acknowledged, displayed or printed.

Alarm Lists - when triggered, alarms are added to an Alarm List. The Alarm List allows the operator to view and manage multiple alarms.

Alarm Banner - defines an area on a screen in which alarm messages and controls can be viewed and accessed by the operator. The banner pops up when an alarm occurs regardless of which screen is active.
Alarm Banner

The following illustrates an alarm banner with an alarm message, alarm list, and alarm controls. Many of the items shown are optional. You can tailor alarm functions to meet your own requirements.

An alarm banner (shown above) defines an area on the screen in which alarm messages and alarm controls are displayed. Alarm messages are displayed in a chronological order depending on when they were triggered.

The alarm banner is a global display that is created only once in an application, but appears in the same position on every screen. The banner only appears when an alarm is triggered. Since the alarm banner can open up over control and display objects, you can specify whether or not all or just covered screen objects are disabled while the banner is displayed. The banner is cleared from the display when the:

- operator presses the Acknowledge, Clear, or Ack All buttons.
- controller clears or acknowledges the alarm.
- terminal enters Configuration Mode.

Creating an Alarm Banner

To create an alarm banner, select Screen>Create Alarm Banner. The alarm banner appears as a separate screen in the Screens folder of the Application window. Unlike other screens, the alarm banner cannot be renamed and does not have a number.

The default alarm banner opens with a:

- One-line message display (which cannot be deleted)
- Clear Alarm button
Working with Alarms

Chapter 5

The alarm banner can moved and sized but not smaller than the objects in it. Deselect the alarm banner before adding or selecting objects inside. Add alarm buttons to the banner by selecting objects from the Objects>Alarm Buttons menu. To add an alarm list, select Objects>Alarm List.

Things to Know About Alarm Banners

Alarm banner location - Select View>Alarm Banner Position to show the location of the alarm banner from any screen in the application. This allows you to see which screens objects are covered (disabled) when an alarm is triggered.

Alarm banner position / size - can be changed when you are on the Alarm Banner screen. To open the alarm banner, double-click Alarm Banner in the Screens folder of the Application window.

Banner appearance - on color terminals, the default background color of the banner and alarm objects is red and the foreground color is white. On monochrome or grayscale terminals, the background is black and the foreground is white. You can change the foreground and background colors from the color palette or the Format menu.

Alarm Lists

The alarm list maintains a record of all triggered alarms. The maximum number of alarms in a list is 100. However, the amount of available RAM in the terminal may restrict the number of alarm messages that can be stored.

Each alarm list can appear on multiple screens in an alarm banner or by itself on a screen. For each alarm, the list can display:

- whether or not alarm is acknowledged (optional).
- date and time of alarm or acknowledgment (optional).
- alarm trigger value (optional).
- alarm text (required).
Creating an Alarm List

The alarm list object is similar to a control list selector in that the operator uses a cursor to select and acknowledge specific alarms.

Similar to control list selectors, touch screen terminals require list keys on the screen to enable the operator to move the cursor through the list and to acknowledge alarms. To create a list key, select an option from the Objects> List Key menu.

To create an alarm list, select Objects> Alarm List. Double-click the object to open its dialog. Properties you can configure for each alarm list are:

- **Display fields** - specifies the data to display for each alarm in the list including alarm date/time, acknowledge date/time, and alarm trigger value.

- **List display options** - For each entry, you can also specify the number of lines to display and the text size. You can also fix the cursor at specific position in the list so that the list scrolls while the cursor remains static.

- **Alarm display options** - specifies the alarm conditions (active and/or inactive) and statuses (acknowledged, unacknowledged, none required) to appear in the alarm list. You can create multiple alarm lists to display specific types of information for alarms. For example, you can create separate lists to display:
  - active alarms that have not been acknowledged
  - active alarms that have been acknowledged
  - inactive alarms that have been acknowledged

Things to Know About Alarm Lists

**Printing alarm list** - if required, create a Print Alarm List button to print the Alarm List periodically or you can configure specific alarms to print on occurrence.

**Full alarm lists** - If the alarm list is full when an alarm is triggered, the most recent alarm is added to the top of the list and:

- the oldest alarm not requiring acknowledgment is removed (includes previously acknowledged alarms).
- if all alarms not requiring acknowledgment have been removed, the oldest alarm is removed.
Alarm Buttons

Place alarm buttons in an alarm banner to allow an operator to act on an alarm. Some of these buttons can be used outside of the alarm banner. Alarm buttons are accessed from the Objects>Alarm Buttons menu.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
<th>May be used outside of an Alarm Banner?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ack</td>
<td>• Acknowledges receipt of the currently displayed alarm.</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>• Removes the Alarm Banner from the display, but does not clear the alarm condition.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Marks alarm as acknowledged in the Alarm List</td>
<td></td>
</tr>
<tr>
<td>Clear</td>
<td>• Clears the Alarm Banner from the display without acknowledging the alarm.</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>• Does not clear the alarm condition.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If individual alarms are not configured for acknowledgment, the alarm banner should contain a clear button.</td>
<td></td>
</tr>
<tr>
<td>Print</td>
<td>Prints the current alarm message in the Alarm Banner (terminals with RS-232 printer port only). With each message printed, you can include:</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>• alarm date and time</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• acknowledge date and time</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• trigger value</td>
<td></td>
</tr>
<tr>
<td>Ack All</td>
<td>• Acknowledges all alarms in the Alarm List.</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>• Removes the Alarm Banner from the display, but does not clear the alarm condition.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Marks alarm as acknowledged in the Alarm List</td>
<td></td>
</tr>
<tr>
<td>Clear Alarm List</td>
<td>• Clears the alarm list.</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>• Clears the Alarm Banner even though an alarm condition may exist.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>The alarm list is automatically cleared when an application is downloaded.</td>
<td></td>
</tr>
<tr>
<td>Print Alarm List</td>
<td>Prints all alarms in the Alarm List (terminals with RS-232 printer port only). With each message printed, you can include:</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>• alarm date and time</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• acknowledge date and time</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• trigger value</td>
<td></td>
</tr>
</tbody>
</table>

How to Configure Alarms

For each alarm you create, you must configure:

• alarm message and alarm attributes
• alarm trigger tag and trigger type

You can also modify default parameters that apply to all alarms.
Chapter 5  Working with Alarms

Changing Alarm Defaults

There are certain setup parameters that apply to all alarms that you can modify. For example, you can specify:

• whether all screen objects or only covered objects are disabled when the Alarm Banner opens. The initial default is to disable all screen objects.
• size of the alarm list (default is 25) and whether to clear the alarm list on powerup.
• data to print with each alarm (alarm time/date, acknowledge time/date, trigger value). This information applies to alarms that print on occurrence or when the Print Alarm List button or Print Alarm button is pressed.
• remote tags are used by the logic controller to clear or acknowledge all alarms or to receive the alarm text for all triggered alarms. These tags are not activated unless you select the Use Optional Fields check box.

To edit the definition of each tag, select the tag name and then click the Edit Tag button.

• Time values used to complete I/O scans when alarms are triggered and to ensure the controller has time to acknowledge an alarm (if required).

To change alarm defaults:

• Open the Alarms folder in the Application window and double-click on the Setup icon or

- System
- Application Settings
- Alarms
  - Settings
  - Alarm Triggers
  - Alarm Messages
• Select Application>Alarm Setup

The Alarms dialog opens with the Setup tab selected.
Defining Alarm Triggers

Each alarm is associated with a trigger. For each trigger, you must define:

- **Trigger tag** - defines the logic controller address the terminal monitors for an alarm trigger value or bit. Most applications use only one trigger tag.

- **Trigger type** - defines what type of data will trigger the alarm (bit, value, least significant bit).

| IMPORTANT | The data types for ControlLogix applications are different. Refer to the online help. |

Triggers are assigned to individual alarms on the Alarm Messages tab of the Alarms dialog.

To define alarm triggers:

- Open the Alarms folder in the Application window and double-click the Alarm Triggers icon or
- Select Application>Alarm Setup and then select the Alarm Triggers tab.

The Alarm Triggers tab looks similar to a spreadsheet. Each row defines a separate trigger. The fields in each row define attributes of the trigger. Some fields require you to enter text and others require you to select an option from a drop-down list.

At a minimum, you must enter a trigger tag name and select a trigger type (bit, LSBit, value). You can enable optional tag fields for triggers by selecting Optional Fields from the shortcut menu.

The logic controller address for a trigger tag must be the lowest address of the corresponding alarm.
Defining Alarm Messages

For each alarm message, you can define the specific attributes.

- Alarm message (maximum of 255 characters)
- Value or bit that triggers the alarm to appear in the Alarm Banner or Alarm List. The logic controller writes this bit or value to the trigger tag address. For the Bit or LSBit trigger type, you actually enter a bit offset from the trigger tag address.
- Trigger tag associated with the alarm (defined on the Alarm Triggers tab)
- Whether the alarm must be acknowledged by the operator or logic controller.
- Whether the alarm is printed on occurrence when triggered
- Whether the alarm displays in the Alarm Banner when triggered
- Background/foreground colors of alarm text
- Whether to send the alarm message to the remote device when triggered

The trigger tag, variables in alarm message, and other alarm tags (if used) must be in the same scan group.

All PanelView terminals support a maximum of 2,000 alarms except for the PanelView 300, 300 Micro and 550, which support 1,000 alarms.

To define alarm messages:

- open the Alarms folder in the Application window and double-click the Alarm Messages icon or
- select Application>Alarm Setup and then select the Alarm Messages tab

Each row in the spreadsheet defines a separate alarm message. The fields in each row define attributes associated with each alarm. Some fields require text, some provide a drop-down list of options, and others have a check box for toggling a feature on or off.

Many operations are performed by selecting a command on a shortcut menu. For example, to add an alarm message, right click (or press Ctrl+M) and select Append Alarm from the menu. To sort the message text field, select Sort by Message Text. To filter all alarms by the trigger field, select Filter by Trigger.
Alarm Triggering Examples

This section shows an example of three alarms using a Bit trigger.

**Bit or LSBit Triggering**

The data range for a bit trigger is 0 - 255 (bit, signed/unsigned integer, BCD data types). For bit array, the range is the array size. If using the Ack tag, the data range begins with 1, not 0.

In the example below, three alarms (A,B,C) are assigned to the alm_tag trigger. The trigger type is Bit. The data you enter in the Value/Bit field is actually a bit offset from the trigger tag address (not a value).

In the tag editor, the tag definition for alm_tag is:

<table>
<thead>
<tr>
<th>Tag Name</th>
<th>Data Type</th>
<th>Tag Address</th>
<th>Node Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>alm_tag</td>
<td>Bit</td>
<td>N15:0/0</td>
<td>SLC_1</td>
</tr>
</tbody>
</table>

The tag handles up to 256 consecutive bits/alarms (0-255), N:15:0/0 to N15:15/15.

The address of the alarm trigger bit is the number in the Value/Bit field plus the trigger address: Trigger Tag Address + Value/Bit = Trigger Bit Address

For example, Alarm A triggers when N15:1/0 changes from 0 to 1.

\[16 + N15:0/0 = N15:1/0\]

Alarm B triggers when N15:0/2 changes from 0 to 1.

\[2 + N15:0/0 = N15:0/2\]

For the LSBit trigger type, an alarm triggers when its trigger bit changes from 0 to 1 and all other bits between the trigger tag address and the trigger bit address are cleared. If the trigger tag address is N7:12/4 and the Value/Bit is 6, an alarm is triggered when N7:12/10 changes from 0 to 1. It is the only bit set between N7:12/4 and N7:12/10 inclusive.

If N7:12/4 is 1 when N7:12/10 changes to 1, the alarm corresponding to N7:12/10 will not trigger until N7:12/4 is reset to 0.
Value Triggered Alarm

This section shows an example of 3 alarms that use a Value trigger. Trigger values must not exceed the range of the data type selected for the trigger tag (for example, signed/unsigned integer, BCD).

Below are 3 alarms (A, B, C) assigned to the alm_tag trigger. The trigger type is Value. The Value/Bit field shows a different value (1, 2, 3) for each alarm. The value 0 is reserved.

In the tag editor, the tag definition for alm_tag is:

<table>
<thead>
<tr>
<th>Tag Name</th>
<th>Data Type</th>
<th>Tag Address</th>
<th>Node Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>alm_tag</td>
<td>Unsigned Integer</td>
<td>N15:0</td>
<td>SLC_1</td>
</tr>
</tbody>
</table>

Each alarm is triggered when its assigned value is entered at N15:0. For example, a value of 2 at N15:0 triggers Alarm B.
Working with Text

This chapter shows how to:

- Edit inner text of objects
- Add variables to text
- Enter screen text or scrolling text
- Change the appearance of text
- Use the application text editor
- Storing translated text for multiple languages in application
- Use font files to translate text into another language

For more details on working with text, open the Adding Text, Inner Graphics and Variables book in the Contents tab of general help.

Editing Text in an Object

Most objects are created with default inner text that can be edited. The inner text appears inside the object and is linked to the object. When you move or delete the object, the inner text is also moved or deleted.

Push buttons and multistate objects can have different inner text for each state.
Editing Inner Text for an Object Without States

1. Select the object.

2. Click the Inner Text tool or select Format>Inner Text. The Text toolbar opens.

3. For numeric data displays or numeric entry objects, you'll see a variable placeholder /*N:6 NO FILL FIX:0*/ with formatting details in the text box. You can’t delete this variable (characters between the slash characters /*N . . .*/), but you can add text around it.

4. Edit the text or click the down arrow at the right of the text box to edit the text in a Text Edit dialog. From this dialog you can enter text and variables.

As you edit the text, it's also entered in the object. If you press Enter to start a new line, you’ll see the characters /*R*/ indicating a carriage return. An asterisk (*) appears if the text exceeds the size of the object.

5. Resize the object, if necessary, to fit all the text.

Editing Inner Text for a Multistate or List Object

1. Select the object.

2. Click the Inner Text tool or select Format>Inner Text. The Text toolbar opens.

3. Select the state from the State box on the State toolbar or select Format>Next State or Previous State.

4. Edit the text or click the down arrow at the right of the text box to edit the text in a Text Edit dialog. From this dialog you can enter text and variables.

As you edit the text, it’s also entered in the object. Press Enter to start a new line. An asterisk (*) appears if the text exceeds the size of the object.

5. Repeat steps 3 and 4 to edit text for other states.
6. Resize the object, if necessary, to fit all the text.

**TIP**  
For multistate or list objects, you can enter the text for each state on the State tab of the object’s dialog.

### Adding Variables to Text

You can insert a time, date, numeric or character variable in an object or text string. The time and date variable are formatted according to settings on the Time/Date tab of the Application Settings dialog. The numeric and character variables are formatted according to properties you set in a dialog.

For a time or date variable, the screen object shows the format of how the variable will appear on the PanelView terminal. For a numeric or character variable, the screen object shows a series of #### to show the field width of the variable.

| The current date is MM/DD/YY | The current time is 1H:MM:SS PM | The current temperature is ### degrees. |

### Adding a Time or Date Variable

1. Select the object.

2. Click the Inner Text tool or select Format>Inner Text. The Text toolbar opens.

3. For a multistate object, select a state from the State box on the State toolbar or select Format>Next State or Previous State.

4. Click in the text box where you want to insert the variable.

   Or click the down arrow at the right of the text box to open the Text Edit dialog. From this dialog you can edit text and insert variables.

5. Select Time or Date from the Format>Embedded Variable menu or the menu that opens when you click the Embedded Variable tool on the Text toolbar.

6. The time /*T*/ or date /*D*/ placeholder is inserted in the text box and the time or date format is inserted in the object.

7. Resize the object, if necessary to fit all the text.

**TIP**  
To delete a variable, just click on the placeholder in the Text box or the Text Edit dialog and press the Delete key.
Adding a Numeric Variable

The numeric variable displays a numeric value read from a controller address. The variable can display up to 12 digits using a fixed or floating point decimal, with or without zero fill.

1. Select the object.

2. Click the Inner Text tool or select Format>Inner Text. The Text toolbar opens showing the existing text.

3. For a multistate object, select a state from the State box on the State toolbar or select Format>Next State or Previous State.

4. Click in the text box where you want to insert the variable.

Or click the down arrow at the right of the text box to open the Text Edit dialog. From this dialog you can edit text and insert variables.

5. Select Numeric from the Format>Embedded Variable menu or the menu that opens when you click the Embedded Variable tool on the Text toolbar.

A dialog opens to specify the field width, decimal point format, and tag address from which to read the variable. When you exit the dialog, a placeholder is inserted in the Text box with the formatting details.

6. Resize the object, if necessary to fit all the text.

TIP
To edit a numeric variable, click on the variable placeholder in the text box and select Edit from the Embedded Variable menu. To delete the variable, just select it and press the Delete key.

Adding a Character Variable

The ASCII variable displays a character string (maximum of 12 characters) read from a controller address. The variable is updated whenever the string changes. The variable can display any character in the extended ASCII character set. Characters are processed sequentially until a Null character (all bits 0) is received.
The string is stored in the data table as consecutive characters. The format of the string must be as follows:

<table>
<thead>
<tr>
<th>Bit</th>
<th>15</th>
<th>8</th>
<th>7</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>1st word</td>
<td>1st character</td>
<td>2nd character</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd word</td>
<td>3rd character</td>
<td>4th character</td>
<td></td>
<td></td>
</tr>
<tr>
<td>...</td>
<td>...</td>
<td>...</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. Select the object.

2. Click the Inner Text tool 🛠️ or select Format>Inner Text. The Text toolbar opens showing the existing text.

3. For a multistate object, select a state from the State box on the State toolbar or select Format>Next State or Previous State.

4. Click in the text box where you want to insert the variable.

   Or click the down arrow at the right of the text box to open the Text Edit dialog. From this dialog you can edit text and insert variables.

5. Select Character from the Format>Embedded Variable menu or the menu that opens when you click the Embedded Variable tool 📄 on the Text toolbar.

   A dialog opens allowing you to specify the field width and tag address from which to read the character string. When you exit the dialog, a placeholder is inserted in the text box with the formatting details.

A string of characters ###### the length of the field is inserted in the object.

6. Resize the object, if necessary to fit all the text.

TIP
To edit the character variable, click on the variable in the text box and then select Edit from the Embedded Variable menu. To delete the variable, just select it and press the Delete key.
Adding Background Text to a Screen

You can add text to a screen that is not attached or linked to an object. Examples of this kind of text are screen titles, object labels or tick-mark labels for bar graph scales.

Background text can contain up to 255 characters using the default text size and can appear anywhere on the screen. You can resize text and use different types of emphasis such as underlining, blinking, or applying a color.

1. Click the Screen Text tool or select Objects>Text.

2. Click on the screen where you want to drop the text box or drag to size the object.

The Text toolbar opens allowing you to enter text.

3. Type your text in the blank box on the toolbar. You can also enter text directly in the Text Edit dialog by double-clicking on the object or clicking the down arrow at the right of the text box. This dialog also lets you insert variables in the text.

As you enter text, it’s also entered in the text box on the screen. If you press Enter to start a new line, you’ll see the characters /*R*/ indicating a carriage return. An asterisk (*) appears if the text exceeds the size of the object.

If text is breaking in the middle of a word, select Format>Word Wrap. Text will then wrap on word boundaries.

4. Resize the text block, if necessary, to fit all the text.

Scrolling Text

The scrolling text object is useful on screens with limited space. It is similar to the background text object but text scrolls right to left at a set rate. Select Objects>Scrolling Text to access object.
You can change the way text looks using combinations of size, emphasis and alignment. In inner text mode, you can select tools from the Text toolbar or the Format menu. Some of the commands toggle on and off, others open a menu. To change the appearance of an object that is already created, simply select the object and then select a format option.

The Text toolbar is automatically activated when you enter inner text mode. You can also turn it on or off from the View>Toolbars menu.

For more details on formatting text, open the Formatting Objects and Text book in the Contents tab of general help.

<table>
<thead>
<tr>
<th>Click this tool:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blink</td>
<td>Activate blinking for the inner text of an object. Blinking applies to the entire text string. Blinking is not available for list objects. The blink rate is .5 seconds and is not activated until the application is downloaded to the PanelView terminal.</td>
</tr>
<tr>
<td>Underline Text</td>
<td>Turn underlining on or off for inner text. Underlining applies to the entire text string.</td>
</tr>
<tr>
<td>Toggle Fore/Background</td>
<td>Reverse the foreground/background colors of inner text. The entire text string is affected. This option is not available for list objects. The foreground/background colors of text is toggled independent of the foreground/background colors of the object.</td>
</tr>
<tr>
<td>Size Text</td>
<td>Change the text size for the inner text of an object. In list objects, text size changes affect all entries in the list. The text sizes available vary for each terminal. If external fonts are enabled, the text sizes for the external font file appear in parentheses at the bottom of the text size menu.</td>
</tr>
<tr>
<td>Align Text Horizontal</td>
<td>Align inner text of an object to the left, center or right.</td>
</tr>
<tr>
<td>Align Text Vertical</td>
<td>Align inner text of an object to the top, middle or bottom.</td>
</tr>
</tbody>
</table>

**TIP** For multistate objects, you can apply text formatting options to each state.

To apply format options to text of an existing object:

1. Select the object.
2. If the object is multistate, select a state from the State box or select Next State or Previous State on the Format menu.

3. Click the tools on the Text toolbar that you want to apply or select the corresponding commands on the Format menu.

**TIP**

For multistate and list objects, you can adjust many of the text formatting options from the State tab of the object’s dialog.

### Using the Application Text Editor

The text editor is a spreadsheet that stores all text strings in an application. You can use this editor to:

- enter or edit text (with embedded variables)
- delete unused text
- copy text into objects
- renumber text
- filter or sort text
- print all application text

To open the Text Editor:

- double-click the Text Editor icon in the System folder

- select Text Editor from the Tools menu

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>

![Application Text Editor - Sample FIA](image-url)
## Adding or Editing Text

You can add a text string as the last row in the spreadsheet or at a specific location.

- To add text at the end of the spreadsheet, double-click in the Text field of the last row and replace the default text “New Text” with your text.
- To insert a text string above a row, select the row, then right-click and select Insert Text Item from the menu. Double-click in the Text field and replace the default text with your text.

To enter a carriage return, press the Enter key. The /*R*/ characters appear indicating a new line.

The Text ID field is automatically updated with the next available number. The Count field remains 0 until the string is used by an object.

If you edit a text string, the text is automatically updated wherever it is used in the application.

### Inserting Variables in Text

You can insert a time, date, numeric or character variable in a text string as described on page 75 to 77.

Double-click in the Message Text field and then position the cursor where you want to insert the variable. Right-click and select an option from the Embedded Variable menu. When you select Numeric (for numeric) or Character, a dialog opens to specify the format of the variable at the read tag address.

The following placeholders are inserted in the text string for each variable.

<table>
<thead>
<tr>
<th>For this variable:</th>
<th>This placeholder is inserted:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time</td>
<td>/<em>T</em>/</td>
</tr>
<tr>
<td>Date</td>
<td>/<em>D</em>/</td>
</tr>
</tbody>
</table>
To edit a numeric or character variable, just select the placeholder, right-click and select Embedded Variable>Edit. To delete a variable, select the placeholder and press the Delete key.

### Finding and Replacing Text

Use the Find and Replace commands on the shortcut menu to find and/or replace text in a specific column. Just click in the column you want to search, right-click and select Find. A dialog will prompt for the search text. Use the Replace command to search for and replace text. With both of these commands, you can search up or down a column and perform case sensitive searches.

To determine where a specific text string is used in the application, select a row, right-click and select Used By from the shortcut menu. A dialog opens listing details on where the object is used.
Sorting Text

You can sort the data in columns numerically or alphabetically depending on the contents of the column. For example, if you sort the Message Text field, all rows are rearranged alphabetically. Identical strings appear together.

To sort a column of data, select an option from the Sort By box. The option None indicates no sort column.

Filtering Text

You can filter text to display or work with only a subset of strings in the application. A filtered list can be sorted and printed.

To filter text, click the Filter button. A dialog opens showing check boxes next to objects using text in the application. Check boxes are also available for filtering unused text, alarms, or print only objects.

Initially, all the check boxes are selected. To work with only a subset of text, select or clear the appropriate check boxes. For example, to view all unused text strings in the application (Count= 0), clear all check boxes except the Unused check box.

Renumbering Text

You may want to consolidate memory if there are gaps in the numbering sequence. You can easily check for numbering gaps by sorting the Text ID field.

<table>
<thead>
<tr>
<th>To renumber:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>a single text string</td>
<td>Double-click in the Text ID field and type a unique number. If duplicate numbers are detected, you’ll get a message when leaving the Text Editor.</td>
</tr>
<tr>
<td>all text strings</td>
<td>Click the Select All button and then the Renumber button. All strings are renumbered starting with the Text ID value in row 1.</td>
</tr>
<tr>
<td>a block of text strings</td>
<td>Hold down the left mouse button on the first row in the block and drag until all rows are included in the block. Or click on a row, hold down the Shift key and select the last row. All text strings are renumbered in the block, starting with the number of the first string. For example, a block of text numbered 80, 84, 85, 88 would be renumbered 80, 81, 82, 83.</td>
</tr>
</tbody>
</table>
Moving Text

You can rearrange text by moving text strings up or down or to a specific location.

<table>
<thead>
<tr>
<th>To move a text string:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>up or down one row</td>
<td>Select the row, right-click and select Move Text Item Up or Move Text Item Down.</td>
</tr>
<tr>
<td>to a specific location</td>
<td>Select the row, right-click and select Move Text Item To:. In the dialog that opens, enter the number of the row where you want to move the text. The text is moved and all other rows are renumbered.</td>
</tr>
</tbody>
</table>

Deleting Text

You can delete unused text. If the Count field for a string contains a 0, the string is not being used. To create a subset of all unused text:

- Sort the Count field. All text strings with a count of 0 will appear in a block at the end of the spreadsheet.
- Filter all text but the unused text strings. Click the Filter button. Clear all check boxes except the Unused check box.

After sorting or filtering unused text, you can delete the unused text. Click the Select All button and then the Purge button. All unused text (Count of 0) is permanently removed from the spreadsheet.

To delete one or several unused text strings, select the rows (with a Count of 0) and then click the Purge button or right-click and select Purge Text Item.

Printing Text

You can print all or a range of text in the Text Editor. Create a subset of the text to print using the filter option. You can also sort a filtered list or range of text before printing. For each text string, the Text ID and Message Text prints. A header prints at the top of each page.

To print application text, select the text you want to print and then click the Print button. From the Print dialog, select the range of items to print (All or Selection).
Copying Text Directly into Objects

Text stored in the text editor can be copied into objects. If you reuse the same text several times, only one copy of the text string is stored.

The procedures below show the different ways to copy text into objects that is stored in the text editor.

To copy text from the text editor into an object:

1. Select the object in which to copy text.
2. Click the Inner Text tool or select Format>Inner Text.
3. For a multistate object, select a state from the State box on the State toolbar or select Format>Next State or Previous State.
4. Click the Existing Text tool on the Text toolbar or select Edit>Use Existing Text. The text editor opens in read-only mode.
5. Select the row you want to copy.
6. Click the Update button. The object text is replaced with the selected text.

To copy text from the text editor into the state tab of a multistate object:

1. Double-click the object.
2. Select the State tab.
3. Select the row of text you want to replace with text from the text editor.
4. Right-click and select Use Existing Text from the menu. The text editor opens in read only mode.
5. Select the row containing the text you want to copy.
6. Click the Apply button and then the Close button. The Text ID and Message Text field are updated with text from the text editor.

Storing Translated Text for Multiple Languages

See Translating Applications in other Languages under Working with Applications in the Contents tab of the general help.

PanelBuilder32 lets you store translated text for five languages in an application including:
By storing translated text for objects in the application, you can easily change the language as needed while the application is running on the terminal. The five languages can be selected at any time, changing the language in the objects throughout the entire application. Only one language is active for the application at one time.

You can enable multiple language support for new or existing applications.

- For new applications, select the Multiple Language Support check box in the Create New Application dialog.
- For existing applications, select the Multiple Language Support check box on the Application Settings dialog.

When multiple language support is enabled, the Language toolbar and View>Language menu are activated. Use either of these options to switch the application to another language for the purposes of translating text. When switching languages, the attributes associated with each text string such as text size, font and alignment are maintained.

To store translated text for more than one language:

1. Create the text in the language you want to standardize on, English, for example.

2. Select a language from the View>Language menu or the Language toolbar.

   Each object can store translated text for English, French, German, Spanish, and Italian. Only one language is active.

   Even though you select one of the 5 standard languages, you could actually enter text for any extended ASCII language. You can substitute an Asian language but this is not recommended because of font size requirements.

3. Translate the text for all objects on a screen-by-screen using inner text mode or the Tools>Text Editor.

   The Text Editor also has a Language list box so that you can switch the application text between languages.
The application is downloaded to the terminal with the translated text for all languages, however, the application will run using the language specified in the Advanced tab of the Application Settings dialog. You change the active language for an application from the terminal by:

- sending an internal tag @Write_CurrentLang to the terminal using a push button or control list selector in the application. Values from this tag are:
  - French = 0
  - German = 1
  - Italian = 2
  - Spanish = 3
  - English = 4

It is recommended that you set the initial state to 4 = English or to the value that corresponds to the default language for the application.

- selecting a language from the Language Setup screen on the terminal’s Configuration Mode menu.

Converting Between Single Language and Multiple Language Support Applications

- If you enable multiple language support for an existing application, all objects are updated to support multiple languages. Multiple text strings are created for objects in each of the 5 languages (even if not translated). Use the Language tool bar to switch between languages.
- If you copy an object from an application that supports multiple languages to one that only supports one language, the object is updated to support only one language. The object retains the text in the language that was active at the time of the copy; all other translated text is deleted.
- If you disable multiple language support for an application, only the text for the active language is retained; all other translated text for objects is deleted.

Using Font Files to Translate Application Text

See Translating Applications in other Languages under Working with Applications in the Contents tab of the general help.

The PanelView terminal supports English, French, German, Spanish and Italian characters. For other languages, a Windows compatible font can be referenced in a PanelBuilder32 application.

You can create a font file (*.OTF) for a specific language using the FontTool utility and then enable this file in PanelBuilder32. The font file must reside on
a memory card in the PanelView terminal when the application is running. The terminal uses the characters in the font file to display the characters on the screen. A memory card with the font file is not required for the English, French, Germinal, Spanish and Italian languages since the terminal supports them.

With FontTool, you can create font files for any of the installed set of languages (or code pages) supported by Windows. The code page for Western European languages is 1252. Arial and Times Roman are fonts supported by code page 1252. The character set of the language you want to use must reside on your computer.

To enter text in PanelBuilder32 for languages that use double-byte characters, your system must run either an:

- International version of Windows for the language
- Input Method Editor (IME)

For single-byte languages, you can enter application text using:

- font file enabled in PanelBuilder32
- character keyboard in Windows
- character map utility in Windows or pressing the Alt key + 4-digit decimal equivalent of an extended ASCII character. From the Index tab of the general help, search for enter ASCII characters.

**Using FontTool**

To use the FontTool utility select Programs>PanelBuilder32>FontTool from the Start menu. This utility has its own menu bar and toolbar.
Creating a Font File

1. Select File>New Font or click the New Font tool on the toolbar.

   The width of the available text sizes is in multiples of 8.
   The sizes you select will appear on PanelBuilder32 menus with the standard text sizes. The text sizes from the font file will appear in parenthesis.

2. Select a font from the Locale box. If the font has a subtype, its name appears in parenthesis, for example, Chinese (Simplified).

3. Under Available Sizes, select the character sizes you want to store in the font file.

   **TIP**
   Deselecting sizes will reduce the size of the application.

4. From the Font dialog, select a font style. The style must be compatible with the font definition. For example, if you select Chinese (Simplified):
   - a Chinese font must reside on your computer
   - the appropriate code page must reside on your computer
   - run the IME program with the appropriate language selected.

   If your system is running a Chinese version of Windows, an IME is not required; the code page is automatically available.

5. Click OK to generate the file. The time it takes to generate the font file depends on the number of characters/sizes in the definition and your computer's speed.

   For the following single-byte languages, select Courier New under Font:
   - English
   - French
   - Italian
   - German
   - Spanish
6. Sample text in the selected style is displayed for the font definition. Verify that the text looks okay.

At this point, the font file *.OTF resides in memory but is not saved to disk.

**Saving a Font File**

You can save a font file to disk and/or to a memory card. The font file must reside on a memory card in the PanelView terminal when the application is running. The terminal uses the font file to display the appropriate characters on the screen.

To save the font file to disk:

1. Select File>Save As.

2. In the File Name box, enter a descriptive name for the file with the .OTF file type.

PanelBuilder32 expects to find the file in the default location: Program Files>Allen-Bradley>PanelBuilder32>Applications>Font.
To save the font file to a memory card:

1. Load an ATA card only (catalog number 2711-NM2xx8) in the ATA card drive on your computer.

   The ATA cards are recommended for double-byte languages because they have more memory.

2. Select File>Save to Memory Card or click the Memory Card tool on the toolbar.

3. From the Save in box, select the location of the ATA card drive.

4. In the File name box, enter or select the name of the .OTF to save on the card.

   **TIP** To save the font file to an ATA card drive in PanelBuilder32, use the File>Copy Font File>Save As command.

To copy a font file to a flash memory card catalog number, 2711-NM1x, use the File>Save As command in PanelBuilder32.

### Using a Font File in PanelBuilder32

Before you can use the font file in PanelBuilder32, you must enable external fonts and select the font file from the External Fonts tab of the Application Settings dialog. See page 131 in Chapter 10 for details on how to do this.

<table>
<thead>
<tr>
<th>Text sizes from font file</th>
<th>Text sizes for the default font</th>
</tr>
</thead>
<tbody>
<tr>
<td>8x16</td>
<td>8x24</td>
</tr>
<tr>
<td>16x24</td>
<td>24x22</td>
</tr>
<tr>
<td>32x40</td>
<td>1x3</td>
</tr>
</tbody>
</table>

Text sizes in the font file (*.OTF) appear in parenthesis at the bottom of PanelBuilder32 text size menus.

If you select these text sizes, PanelBuilder32 uses the characters in the font file to generate the text that appears on the application screen. If you select a text size not within parenthesis, PanelBuilder32 uses its standard font.

You cannot use text sizes from the font file and the standard font in the same text string. You can, however, use a combination of both throughout the application.

To enter double-byte characters stored in the font file, your computer must be running an International version of Windows or an IME with the correct language (code page) selected. If you do not use either of these, your computer will display double-byte characters as 2 single-byte characters.
Running the Application with the Font File

Download the application to the PanelView terminal as described in Chapter 11. Make sure the memory card containing the font file is inserted in the card slot of the terminal. Use the memory card retainer that came with your terminal to secure the memory card in the slot.

Translating Application Text in Excel

You can copy text from a PanelBuilder32 application into Excel, translate the text in Excel, and then copy the translated text back into PanelBuilder32. This process is beneficial if the individual translating the text is not familiar with PanelBuilder32.

For complete details on translating application text in Excel, open the Working with Applications book in the Contents tab of general help.
Working with Graphics

This chapter covers:

- using graphic tools
- adding ISA symbols to a screen
- adding bitmap graphics to a screen
- inserting a graphic in an object
- importing and exporting graphics

For more information on graphics, open the Adding Drawings and Importing Graphics book in the Contents tab of general help.

Using Graphic Tools

PanelBuilder32 provides graphic tools for creating simple lines, shapes, and drawings. These graphics are available on the Objects>Graphics menu or the Toolbox. Unlike control and display objects, graphics can overlap on the screen.

<table>
<thead>
<tr>
<th>Click this tool:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Draw a straight line. Click and drag where you want to draw the line.</td>
<td></td>
</tr>
<tr>
<td>Draws open connected lines or simple polygons such as triangles. Click where you want to start and end each line. When you are done drawing the lines, double-click.</td>
<td></td>
</tr>
<tr>
<td>Draw a rectangle. Click and drag where you want to draw the rectangle. To draw a square, hold down the Shift key while you drag.</td>
<td></td>
</tr>
<tr>
<td>To draw a circle. Click and drag where you want to draw the circle. Circles process more efficiently than ellipses on the PanelView.</td>
<td></td>
</tr>
<tr>
<td>To draw an ellipse. Click and drag where you want to draw the ellipse.</td>
<td></td>
</tr>
<tr>
<td>To draw a freehand drawing. Freehand drawings are memory intensive. For complicated drawings, create bitmaps with another program and then import the graphic.</td>
<td></td>
</tr>
<tr>
<td>Places a graphic image on the screen.</td>
<td></td>
</tr>
</tbody>
</table>
Adding ISA Symbols

You can place standard ISA symbols on a screen. To access these symbols, select the ISA Symbols check box from the View>Toolbars dialog.

Select a symbol in the toolbox and click where you want to place the symbol on the screen. ISA symbols can be moved and sized. PanelBuilder32 retains the image in its original size and the modified size.

Adding Graphics to a Screen

Besides ISA graphics, you can place other bitmap graphics on the screen that are imported from other programs or supplied by PanelBuilder32.

To place a graphic on a screen:

1. Click the Graphic Image tool in the toolbox or select Graphic Image from the Objects>Graphics menu.

2. Click to drop a temporary border to hold the image. The Graphic toolbar opens.

3. Select a graphic from the Graphics list.

The border is sized to the object and then removed. Size the graphic as desired. PanelBuilder32 retains the graphic in its original size and modified size. If you select a graphic that is available in several sizes, a dialog will open allowing you to select one of the existing sizes or specify a new size.

While the image is selected (Graphics list appears in reverse video), you can view other graphics in the border by clicking the Up and Down arrow keys.

4. Deselect the object to leave graphic mode.
Inserting a Graphic in an Object

You can insert a graphic in an object (not list objects). For multistate objects, you can insert a different graphic for each state. The graphic can be an ISA symbol or a bitmap created with another program.

The graphic is linked to the object just like inner text. If you move or delete the object, the graphic is also moved or deleted.

To insert a bitmap or ISA symbol in an object:

1. Select the object.

2. If the object is multistate, select the state from the State box or select Next State or Previous State from the Format menu.

3. Click the Inner Graphic tool on the State toolbar or select Format>Inner Graphic. The Graphic toolbar opens.

4. Select a graphic or ISA Symbol from the Graphics list. Toggle through views of other graphics while the Graphics list box is highlighted using the Up and Down arrow keys.

5. Position and resize the graphic in the object. Position the graphic by dragging it. Resize the graphic by its handles. If a bitmap or ISA symbol is resized, PanelBuilder32 retains the image in its original size and modified size. If you select a graphic that is available in several sizes, a dialog will open allowing you to select one of the existing sizes or specify a new size.

6. Resize the object if necessary.

7. Deselect the object to exit graphic mode.

**TIP**

To remove text in the object, click the Inner Text tool and delete the text.

To remove a graphic from an object, select None from the list.

**TIP**

You cannot edit the content of a bitmap or ISA symbol in PanelBuilder32. You must export the graphic to a file, revise it in a program such as Paint and then re-import the graphic. See the next section.
Importing and Exporting Graphics

You can import monochrome and color bitmaps from other programs. These bitmaps can then be placed on a screen or inserted in an object. A bitmap is imported in its original size. If the bitmap is resized, PanelBuilder32 maintains both the original and resized bitmap.

Imported bitmaps cannot exceed the number of pixels supported by the terminal. Larger bitmaps are cropped when imported.

The standard PanelView terminals (with firmware 4.10 or higher) support 32 colors. If you import a full color bitmap, it is exported to a maximum of 256 colors. Previous releases, exported bitmaps to a maximum of 16 colors. For grayscale terminals, full color bitmaps are reduced to 4 colors (shades of gray).

You can also export graphics to a file or the clipboard, edit them in another program and then re-import them.

To import or export bitmap graphics, select File>Import/Export Graphics.

To import a bitmap:


2. Select the bitmap file (*.bmp, .gif, .tif,...) you want to open from the Import Graphic From File dialog.
If you import a bitmap with more than 256 colors, the Color reduction method area becomes available. Select the method that provides the best image. The number of colors in the image will be reduced to the number of colors supported by your PanelView terminal.

3. Click Open. The Graphic Name dialog opens and displays the file name of the bitmap.

4. Accept the default file name or enter another unique name for the bitmap

5. Click OK.

You return to the Import/Export Graphics dialog. The name of the graphic appears under Currently Imported Graphics.

To paste a bitmap from the clipboard:

1. In another program such as Paint, copy or cut the bitmap to the clipboard.


3. Click the Paste button.

4. In the dialog that opens, enter a unique name for the graphic. This name will appear under Currently Imported Graphics.

When you exit the dialog, the graphic appears under Currently Imported Graphics.
To copy a bitmap to the clipboard:

1. Select a graphic from the Currently Imported Graphics list.
2. Click the Copy button.

You can now paste the graphic into another program such as Paint.

To export a bitmap to a file:

1. Select the name of the graphic you want to export.
   Color bitmaps are exported as they are stored in PanelBuilder32. If a full color bitmap was imported, it is exported to a maximum of 256 colors.
2. Click the Export button.
3. In the dialog that opens, enter a file name for saving the graphic (the .bmp file type is added) and click OK.

To delete a graphic:

1. Select a graphic from the Currently Imported Graphics list.
2. Click the Delete button.

You cannot delete any of the ISA symbols.
Chapter 8

Formatting Objects

This chapter covers these topics.

- Change the appearance of objects.
- Use color to change the appearance of objects and text.

**ATTENTION**

Some combinations of format options could result in a control object not being visible (object blends into screen background). All touch screen controls must be visible or have a graphic showing the location of the object. Failure to do so may result in accidental or unpredictable operation.

For more details on formatting objects, open the Formatting Objects and Text book in the Contents tab of general help.
You can change the visual characteristics of an object from the Format toolbar or the Format menu. Some of the commands toggle on and off, others open a menu.

The Format toolbar is turned on and off from the View>Toolbars menu.

<table>
<thead>
<tr>
<th>Click this tool:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Shape" /></td>
<td>Change the shape of a button or graphic. Circles require less memory and process better than ellipses on the PanelView terminal. The shape is resized to fit inside the area of the original object. The only fill patterns retained when changing shape to a circle or ellipse are white, black, or none.</td>
</tr>
<tr>
<td><img src="image" alt="Line Type" /></td>
<td>Change the border type or edge of an object. On monochrome terminals, the line type options are black, white or none. On color or grayscale terminals, the options are solid or none.</td>
</tr>
<tr>
<td><img src="image" alt="Fill Type" /></td>
<td>Change the fill pattern for the interior of a rectangular object. The default fill is white. On color/grayscale terminals, circles and ellipses cannot have fill. On monochrome terminals, fill patterns for circles and ellipses are black, white, or none.</td>
</tr>
<tr>
<td><img src="image" alt="Blink" /></td>
<td>Activate blinking for an object or graphic (including fill pattern and border). Blinking is not available for list objects. The blink rate is 0.5 seconds and is not activated until the application is downloaded to the PanelView terminal. Blinking for text is set independently of the object.</td>
</tr>
<tr>
<td><img src="image" alt="Toggle Fore/Background" /></td>
<td>Reverse the foreground/background colors of an object or graphic in an object. This option is not available for list objects. For monochrome terminals, the fore/background toggles between black and white. For color and grayscale terminals, the fore/background toggles between the set colors. The fore/background of objects is toggled independently of text.</td>
</tr>
</tbody>
</table>

- To toggle the fore/background of the object, text and graphic, select the object, then click the Fore/Background tool.
- To toggle only the inner text, click the Inner Text tool and then the Fore/Background tool.
- To toggle the inner graphic, click the Inner Graphic tool and then the Fore/Background tool.
To apply format options to objects:

1. Select the object.

2. If the object is multistate, select a state from the State box or select Next State or Previous State on the Format menu.

3. Click the tools on the Format toolbar that you want to apply or select the corresponding commands on the Format menu.

   **TIP**

   For multistate and list objects, you can adjust the fill and activate blinking for individual states on the State tab of the object's dialog.

   **TIP**

   For multistate objects, you can apply the text formatting options to individual states.

### Using Color

For color and grayscale terminals, use the color palette to apply foreground and background colors to objects, text, or graphics. PanelView standard terminals with firmware 4.10 (or later) support 32 colors. The grayscale palette supports 4 colors (shades of gray). The palette is turned on and off from the View>Toolbars dialog.

On color terminals, the default background color is blue; the foreground is white. On grayscale terminals, the default background color is black; the foreground is white.

Foreground colors affect text, lines, borders of objects, list cursor, fill pattern. Background colors affect the area containing text and the solid fill area of objects.
Applying Color to Objects

1. Select the object.

2. If the object is multistate, select a state from the State box or select Next State or Previous State on the Format menu.

3. To change the foreground color, left-click a cell on the color palette or select a color from the Format>Foreground Color menu.

4. To change the background color, right-click a cell on the color palette or select a color from the Format>Background Color menu.

You cannot change the background color for text in list objects.

**TIP**

For multistate objects, you can set the foreground/background colors for objects on the State tab of the object’s dialog.

Applying Color to Text

1. Select the object.

2. Click the Inner Text tool on the State toolbar or select Format>Inner Text.

3. If the object is multistate, select a state from the State box or select Next State or Previous State on the Format menu.

4. To change the foreground color, left-click a cell on the color palette or select a color from the Format>Foreground Color menu.

5. To change the background color, right-click a cell on the color palette or select a color from the Format>Background Color menu.

6. Deselect the object to exit inner text mode.

If you want the background of the text to match the background of the object, you must set the same background color for the object and the text.

**TIP**

For multistate objects, you can set the foreground/background colors for text on the State tab of the object’s dialog.
Applying Color to Inner Graphics

Foreground and background colors can be set for objects with inner graphics that are monochrome (not color).

1. Select the object.

2. Click the Graphic tool on the State toolbar or select Format>Inner Graphic.

3. If the object is multistate, select a state from the State box or select Next State or Previous State on the Format menu.

4. To change the foreground color, left-click a cell on the color palette or select a color from the Format>Foreground Color menu.

5. To change the background color, right-click a cell on the color palette or select a color from the Format>Background Color menu.

6. Deselect the object to exit inner graphic mode.

If you want the background of the object to match the background of the graphic, you must set the same background color for the object and the graphic.

To reverse the foreground and background colors of monochrome bitmaps, click the Toggle Fore/Background tool while in Inner Graphic mode.

For bitmaps that are placed on the screen with the Objects>Graphics>Graphic Image command, simply select the object and then select a foreground or background color from the Format menu or color palette.

Setting Default Colors for Objects

You can apply color defaults to objects of the same type. For example, you might want all push buttons to use the same colors.
Create a push button, apply the colors and formatting you want to use, then select Edit>Set Object Color Defaults. Every new push button you create will appear with the default colors.

Color defaults are maintained across applications and across sessions of PanelBuilder32.
Chapter 9

Using the Tag Editor

This chapter covers these topics.

• Tag editor worksheets and the Tag Form dialog
• Inserting or adding tags
• Selecting, copying/cutting, pasting and deleting tags
• Duplicating, sorting, filtering, finding replacing and printing tags
• Searching for where a tag is used in the application
• Counting and purging tags
• Saving tags
• Converting tags and checking tags for errors
• Importing and exporting tags
• Using a project database to store tags

For complete details on using the tag editor, open the Working with the Tag Editor book in the Contents tab of general help.

What is the Tag Editor?

The tag editor is used to enter application tags. Tags link objects to addresses in a data table. Each tag defines an address and data attributes the PanelView terminal uses to read or write data. For example, a read tag is assigned to a bar graph. The terminal reads the data at the read tag address to fill the bar graph.

The attributes of a tag are protocol dependent. Tags are saved and downloaded with the application to a PanelView terminal.

To open the tag editor:

• double-click the Tag Editor icon in the System folder

  System
  • Description
  • Print Only Objects
  • Exceptions
  • Text Editor
  • Tag Editor

• or click Tools>Tag Editor
Tag Editor Worksheet

The tag editor uses worksheets, similar to Excel, to enter and edit tags. The worksheet tab identifies the protocol for which you are creating tags. For some protocols, such as DeviceNet, ControlNet and EtherNet/IP, you will see multiple tabs because they support several options. Just click the appropriate tab. The tag editor has its own menu bar and toolbar that are activated when the tag editor is opened.

Freezing Columns

You can freeze one or more columns on the left side of the window to prevent them from scrolling off the screen. Click the header of a column, then click the Freeze Columns tool, or select View>Freeze Columns. The column is highlighted. Click the tool again to unfreeze the column. To freeze more than one column, hold down the Ctrl key while you click column headers.

Moving columns

To move a column, click a column header and then drag the column to a new location. A red line appears at positions (between columns) where you can drop the column.
Exiting the Tag Editor

Double-click \( \text{X} \) in the upper left corner of the window or click the X in the upper right corner of the window. Tags are not automatically saved when you exit. If you made changes and did not save them, you are prompted to save the tags.

If you select File>Exit and changes have been made to tags, you are prompted to save the tags and the application.

Another Way to Enter Tags

The other way to enter tags is to enter a single tag at a time using the Tag Form dialog. You can access this dialog directly from an object’s dialog. Click the Edit Tag button from the Properties tab of the object’s dialog.

Any tags you enter in the Tag Form dialog are automatically added to the worksheet.

**TIP**

If the tag editor is open when you enter a tag in the Tag Form dialog, you must select View>Refresh to see the tag in the tag editor.
## Description of the Tag Fields

The fields that appear in the worksheet and Tag Form dialog are protocol dependent and specific to the communication protocol selected for the terminal.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tag Name</td>
<td>A unique name for the tag. You must enter this same tag name in the dialog for the object using the tag. You can generate names automatically based on the contents of the Address field. See the Tag Edit tab in the Tools&gt;Options dialog to enable this option.</td>
</tr>
<tr>
<td>Data Type</td>
<td>The data format for the tag. Click on the drop-down list in the field to see the available options. The data type you select must be compatible with the data format selected in the object's dialog.</td>
</tr>
<tr>
<td>Description</td>
<td>A description of the purpose of the tag.</td>
</tr>
<tr>
<td>Array Size</td>
<td>The size of the array for a Bit Array or Character Array data type. The size of a bit array is 1 - 16. The size of a character array is protocol dependent. <strong>Important:</strong> When working with a Character Array using a string (ST) data file, address the tag to the second offset in the data file, for example: ST9:0.1.</td>
</tr>
<tr>
<td>Node Name</td>
<td>The name of the controller node associated with the tag. The Node Name must match the node name entered in the Communication Setup dialog.</td>
</tr>
<tr>
<td>Address</td>
<td>The data table address within the processor for the tag. For example, B3:0/1 or N7:9 for an SLC or I:0:0/10 or O:0:10/10 for a PLC-5 Remote I/O. Some controllers use a period (.) instead of a slash (/) when addressing bits. For details on addressing, refer to your controller manual. You can generate sequential addresses for the Bit and Integer data types. Select the Address column or a range of cells, right-click and select Extrapolate. Addresses are updated with sequential addresses based on the syntax of the first cell. For example, the addresses B3:0/3, B3:0/2, B3:0/9 will be renumbered as B3:0/3, B3:0/4, B3:0/5.</td>
</tr>
<tr>
<td>Initial Value</td>
<td>The starting value for the tag in engineering units. Provides a preset value for numeric entry objects only. Valid characters are 0 - 9, e, E, +, - and period. The maximum precision for non-floating point values is 6 places to the right of the decimal.</td>
</tr>
</tbody>
</table>

### Extended Attributes appear only for selected Data Types

<table>
<thead>
<tr>
<th>Scaling</th>
<th>The values to use to convert the tag's processor integer value (x) to engineering units (y). Valid characters are 0 - 9, e, E, +, - and period. (1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scale:</td>
<td>'m' in ( y = mx + b )</td>
</tr>
<tr>
<td>Offset:</td>
<td>'b' in ( y = mx + b )</td>
</tr>
<tr>
<td>Data Entry Limits</td>
<td>The minimum/maximum values that can be assigned to the tag. You can enter a maximum of 12 characters, including 0 - 9, e, E, +, - and period. (1)</td>
</tr>
</tbody>
</table>

(1) Maximum precision is six places to the right of the decimal. If present, the + or - for a number must be first (+ is the default). If present, a sign for the exponent must immediately follow e or E.
**Inserting or Adding Tags**

1. Click the Insert Tag tool \[\text{Insert Tag}\] or select Edit>Insert Tag.

   A new row is added before all other rows in the worksheet. To insert a row above a specific row, select a row first and then click the Insert Tag tool.

   2. Double-click in a field to enter, edit or select data.

   Press Tab to advance through fields in a row and Shift+Tab to move back.

   **TIP** New tags are created with default values set on the Tag Defaults tab of the Tools>Options dialog.

**Selecting Tags**

<table>
<thead>
<tr>
<th>To select:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>a single column</td>
<td>Click the column header.</td>
</tr>
<tr>
<td>contiguous columns</td>
<td>Click the header of the first column. Hold down the Shift key and click the last column. Or hold down the left mouse button on the header of the first column and drag to the last column.</td>
</tr>
<tr>
<td>non-contiguous columns</td>
<td>Click the header of the first column. Hold down the Ctrl key and click the headers of the other columns.</td>
</tr>
<tr>
<td>a single row</td>
<td>Click the status column of the row.</td>
</tr>
<tr>
<td>contiguous rows</td>
<td>Hold down the left mouse button on the status column of the first row and drag to the last row. Or click the status column of the first row, then hold down the Shift key while you select other rows.</td>
</tr>
<tr>
<td>non-contiguous rows</td>
<td>Click the status column of the first row. Hold down the Shift key while you select other rows.</td>
</tr>
<tr>
<td>all rows and columns</td>
<td>Select Edit&gt;Select All or click the empty box in the upper left corner of the spreadsheet.</td>
</tr>
</tbody>
</table>
Chapter 9  Using the Tag Editor

Copying/Cutting, Pasting and Deleting Tags

<table>
<thead>
<tr>
<th>To:</th>
<th>Select a row and then:</th>
</tr>
</thead>
</table>
| copy a tag           | Click \[\text{Ctrl} + \\text{C} or select Edit>Copy. Copies the tag data or the selection to the clipboard. |”
| cut a tag            | Click \[\text{Ctrl} + \\text{X} or select Edit>Cut. Moves the tag data or the selection to the clipboard leaving the row intact. |”
| paste a tag          | Click \[\text{Ctrl} + \\text{V} or select Edit>Paste. The tag data or selection is replaced with the contents of the clipboard. |”
| insert and paste a tag| Select Edit>Insert and Paste. A row is inserted above the selected row with the contents of the clipboard. |”
| delete               | Click \[\text{Del} or select Edit>Delete. All rows are renumbered.                   |”

Duplicating Tags

You can duplicate tags with similar attributes instead of creating new tags from scratch. Tags can be duplicated once or several times.

When a tag is duplicated, a suffix(_01) is appended to the new tag name to distinguish it from the original tag. If duplicating a tag several times, the 2-digit suffix increments with each new tag. Duplicated tags are created below the selected tag.

<table>
<thead>
<tr>
<th>To duplicate a tag:</th>
<th>Select the row you want to duplicate, then:</th>
</tr>
</thead>
</table>
| once                | Click \[\text{Ctrl} + \\text{C} or select Edit>Duplicate Once. |”
| multiple times      | Click \[\text{Ctrl} + \\text{X} or select Edit>Duplicate Several. |”

TIP

Tags increment according to defaults set on the Tag Edit tab of the Tools>Options dialog.

Sorting and Filtering Tags

You can sort data in a single column, alphabetically or numerically, in ascending order. Click in any cell of the column you want to sort, then click the Sort tool or select View>Sort. The data is automatically sorted.

Use the filter icon to view rows based on a common cell element. For example, you might only want to see those tags using the Bit data type. Click in the cell containing the data you want to filter and then click the Filter tool. Only the rows containing the common cell element are visible. Click the tool again to view all tags.
Finding and Replacing Tags

You can search for text or a value in a specific column. Click anywhere in the column you want to search, then click the Find tool or select Edit>Find. In the dialog that opens, enter the characters to search for and the direction of the search (up or down). The search can match uppercase and lowercase characters or ignore the case of the characters.

To locate and replace a single or all occurrences of text in a column, click the header of the column and select Edit>Replace.

Printing Tags

It is very easy to print all tags in the active worksheet. Just click the Print tool or select File>Print. You can reorder columns or adjust the widths of columns before printing. The tags are printed according to the format specified in the File>Print Page Setup dialog.

You can also print tags by including them in your application report. From the Report Setup tab of the Tools>Options dialog, select the Tag Attributes check box. To print the report with the tags, select Reports on the File menu.

Searching for Where a Tag is Used

You can search for all occurrences of a single tag in the current application. This includes tags that are used by screen objects as well as objects that do not appear on the screen, such as embedded variables or print objects.

Select the row of the tag you want to search for, then right-click and select Used By from the shortcut menu. A dialog opens and shows all occurrences of the selected tag in the application. For each occurrence (or row), you will see the following fields:

- Tag name
- Screen name (where tag is used)
- Object ID (of object using tag)
- Object type (type of object using tag)
- Details (provides information for a tag used by embedded variables or print objects since these objects do not appear on a screen)

You can navigate to a screen using the tag by selecting a tag row and then clicking the Go To button. The screen is opened and the object using the tag is selected. The GoTo button is only available for objects that appear on a screen.
Chapter 9  Using the Tag Editor

The Tag Search dialog opens in pin mode. This allows you to perform other operations without closing the dialog. If the dialog is not pinned, it will close when you click outside the dialog.

You can also search for tags from PanelBuilder32 (without the Tag Editor open):

- Right-click on a screen object, then select a tag from the Tag Search submenu. This menu lists all tags that could be defined for the selected object. Tags that are defined for the object will appear on the menu with a tag name. Undefined tags are dimmed and not available for searching. Selecting a tag opens the Tag Search dialog.

- Select Edit>Tag Search. When the Tag Search dialog opens, select a tag from the Tag Name list and then click the Search button. The dialog is updated to show all occurrences of the tag.

Right-click on tag row and select Used By from shortcut menu.

Numeric entry object has one write tag defined, named Set_Max_Motor_Speed. Selecting this tag opens the Tag Search dialog.
Counting and Purging Tags

It's a good idea to check for tags that are not used in the application and purge them. Purging unused tags will reduce the size of the application. Select Tools>Tag Count. A dialog opens with the names of all tags that are defined in the application and the number of times each tag is used. Tags that are not used will have a Usage Count of 0. Tags that are used by objects will have a Usage Count that is greater than 0.

You can purge unused tags but not the others. You can purge a single tag or a range of tags. To purge all unused tags, sort by the Usage Count field so that all unused tags (Usage Count of 0) are grouped together. Select all unused tags by clicking on the first row, then hold down the Shift key and click the last row in the range. Click the Purge button. The unused tags are permanently removed from the application.

Converting Tags

When an application is converted to run in a different terminal, you must also convert the tags to use the proper data fields for the new protocol. This conversion occurs automatically if you select the Convert check box under Auto Options on the Tag Edit tab of the Tools>Options dialog.

A worksheet is created for the selected protocol and has a tab with the protocol name. Tag data from the old worksheet is imported to the new worksheet. None of the tag data is modified. You must update the data for each field appropriately.

To manually convert the tags, right-click in the worksheet and select the appropriate protocol from the Convert to submenu. Common refers to DF1, DH485, DH Plus, Remote I/O or ControlNet Unscheduled. These protocols are available as one menu option because they use the same data fields.
**Saving Tags**

Tags are not saved automatically. You must click the Save tool or select File>Save Project. Tags are checked for errors, such as missing or invalid field data, and then saved to the tag database or project associated with the application. Error checking does not validate the contents of field data, such as the address syntax, but checks only for missing information. See the next section on how to correct errors.

In addition to saving the tags in the Tag Editor, you must also perform a File>Save in PanelBuilder32 to make the tags available to the application (unless you are using a project).

You have the option of saving tags temporarily to a tag editor draft file (.tdf) for later use by selecting File>Save as Draft. These tags are not available to the application until saved without errors. Please note that .tdf files are only used by PanelBuilder32 and are not available to other programs. To open .tdf files, select File>Open Draft. Any tags in the active worksheet should be deleted before opening a draft file or you may end up with duplicate tags.

**Checking Tags for Errors**

Tags are automatically checked for missing or required information when you save the tags. If there are no errors or warnings, you will get the message Check Tags Passed - No Error Founds.

If errors or warnings are detected, the Errors worksheet is activated. This is a read-only worksheet to assist with error correction. Errors must be corrected, warnings are optional. When errors are corrected, the worksheet closes.

**IMPORTANT** Error checking does not validate the tags for correct data such as the address syntax - only for missing field data.

The Errors worksheet shows all errors, warnings and information messages. Each row displays the following fields:

- Error type (Error, Warning, Information)
- Row number of tag containing error
- Message relating to the error or warning
The example shows errors in rows 4 and 6. In row 4, the node name is missing and in row 6, the tag name is field is empty.

Printing Tag Errors

To print all errors on the Errors worksheet:

1. Click the Errors tab to activate the worksheet.
2. Click the Print tool or select File>Print.

The worksheet is printed according to settings in the File>Print Page Setup dialog.

Correcting Errors and Warnings

When the Errors worksheet is active, the View>Errors submenu and the tool icons below are available.

<table>
<thead>
<tr>
<th>To:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>activate the Errors tab</td>
<td>Click , select View Errors&gt;Window or click the tab.</td>
</tr>
<tr>
<td>locate the first error</td>
<td>Click or select View&gt;Errors&gt;First Error.</td>
</tr>
<tr>
<td>locate the next error</td>
<td>Click or select View&gt;Errors&gt;Next Error.</td>
</tr>
<tr>
<td>locate the last error</td>
<td>Click or select View&gt;Errors&gt;Last Error.</td>
</tr>
</tbody>
</table>
To correct errors:

1. Double-click on a row in the **Errors** worksheet for the error you want to correct. Or click the icons below to move between errors.

   You are taken directly to the tag with the error. The tag is color-coded by error type (errors are red, warnings are yellow, information message are green).

2. Click in the appropriate cell to correct the error.

3. Repeat the above steps until all errors are corrected.

**Importing and Exporting Tags**

You can import tags into the tag editor from the following file formats or export tags to these file formats:

- Allen-Bradley APS or 6200 Format (*.txt)
- RSI AI Format (*.eas)
- RS-Logix-5 ASCII (*.eas) or CSV Format (*.csv)
- RS-Logix 500 ASCII (*.eas) or CSV Format (*.csv)
- RS-Logix 5000 ASCII CSV Format (*.csv)
- PanelBuilder32 CSV Format (*.csv)
- PanelBuilder32 Selected Tags Format (*.tag)

All file formats except for the PanelBuilder32 Selected Tags Format (*.tag) import/export only the tag name, tag address and description fields. The PanelBuilder32 Selected Tags Format (*.tag) imports/exports all tag data fields.

For details on these file formats, refer to your logic controller's documentation.
Importing Tags

To import tags from a supported file format, select File>Import Tags.

Tags are imported into the tag editor using the column order given on the first line of the import file. If you change the order of columns in the tag editor before importing tags, the columns will be imported incorrectly. If duplicate tag names are detected during the import, the tag is not imported from the source file.

When the import is complete, a dialog opens showing the number of lines and tags processed along with any errors or warnings. From this dialog, you can view a summary of the tags imported, which can also be printed to a file.

If conflicts occur when importing tags (such as duplicate tag names), the Tag Conflict dialog will open asking you how to handle the conflict. You are given the option of using the tag in the import file or the tag editor.
Importing Tags Using the PanelBuilder32 Selected Tags Format (*.tag)

Tags are typically imported in the order specified on the first line of the source file. The following table shows the default order of columns (1-12) in the tag editor.

<table>
<thead>
<tr>
<th>Column</th>
<th>Data</th>
<th>Column</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Tag Name</td>
<td>7</td>
<td>Initial Value</td>
</tr>
<tr>
<td>2</td>
<td>Data Type</td>
<td>8</td>
<td>Update Frequency</td>
</tr>
<tr>
<td>3</td>
<td>Array Size</td>
<td>9</td>
<td>Scale</td>
</tr>
<tr>
<td>4</td>
<td>Description</td>
<td>10</td>
<td>Offset</td>
</tr>
<tr>
<td>5</td>
<td>Node Name</td>
<td>11</td>
<td>Minimum</td>
</tr>
<tr>
<td>6</td>
<td>Address</td>
<td>12</td>
<td>Maximum</td>
</tr>
</tbody>
</table>

The following keywords are inserted in the first line of the source file to show the default column order:

Name,TagType,ArrayLength,Description,Node,Address,Initial,UpdateFreq,Scale,Offset,Min,Max
Motor_Start,Bit,0,Starts motor,LC_1,B3:0/0,0,1,0,0,0
Motor_Stop,Bit,0,Stops motor,LC_1,B3:0/1,0,1,0,0,0
Motor_Speed,UnsignedInteger,0,Controls motor speed,LC_1,N7:1,0,1,0,0,0,65535
Motor_Speed_Ind,UnsignedInteger,0,Indicates motor speed,LC_1,N7:2,0,1,0,0,65535

Each line of tag data in the source file is imported into the tag editor based on the order of keywords specified on the first line.

Exporting Tags

To export tags from the tag editor to one of the supported file formats, select File>Export Tags. The dialog that opens is similar to the Import dialog.
When you click Save, the tags are exported to the file in the order and format expected by the file format. When the export is complete, a dialog opens showing the number of lines and tags processed along with any errors or warnings. From this dialog, you can view a summary of the tags exported or save the details to a file.

Only tags on the active worksheet are exported. If your application uses a project to store tags, it is possible that the tag editor will have multiple worksheets. To export the data from all worksheets, select the Export All Views check box on the Tag Edit tab of the Tools>Options dialog. The Export dialog will automatically open for each worksheet so you can enter the appropriate file information.

**Exporting Tags Using the PanelBuilder32 Selected Tags Format (*.tag)**

The PanelBuilder32 Selected Tags Format (*.tag) is the only format that exports all fields of data in the tag editor.

Tag are exported using the column order.

<table>
<thead>
<tr>
<th>Column</th>
<th>Data</th>
<th>Column</th>
<th>Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Tag Name</td>
<td>7</td>
<td>Initial Value</td>
</tr>
<tr>
<td>2</td>
<td>Data Type</td>
<td>8</td>
<td>Update Frequency</td>
</tr>
<tr>
<td>3</td>
<td>Array Size</td>
<td>9</td>
<td>Scale</td>
</tr>
<tr>
<td>4</td>
<td>Description</td>
<td>10</td>
<td>Offset</td>
</tr>
<tr>
<td>5</td>
<td>Node Name</td>
<td>11</td>
<td>Minimum</td>
</tr>
<tr>
<td>6</td>
<td>Address</td>
<td>12</td>
<td>Maximum</td>
</tr>
</tbody>
</table>

The following keywords are inserted on the first line of the export file:

Name, Address, TagType, Description, ArrayLength, Node, Initial, UpdateFreq, Scale, Offset, Min, Max

The export file looks like this:

Motor_Start, Bit, 0, Starts motor, LC_1.B3:0/0, 0, 1, 0, 0, 0
Motor_Stop, Bit, 0, Stops motor, LC_1.B3:0/1, 0, 1, 0, 0, 0
Motor_Speed, UnsignedInteger, 0, Controls motor speed, LC_1.N7:1, 0, 1, 0, 0, 65535
Motor_Speed_Ind, UnsignedInteger, 0, Indicates motor speed, LC_1.N7:2, 0, 1, 0, 0, 65535

**TIP**

For DeviceNet, additional fields of tag data are exported for DeviceNet.
Using Projects to Share Tags

Each application has tags that are saved with the application. In other words, this information is private and used only by the application in which they were defined.

Also saved with the application is information on the devices using the tags including:

- node name of the logical controller
- terminal name
- network communication parameters for each device

You can create a separate project to save application tags and device information to a database file on disk. The tags in this database file can then be shared with other PanelBuilder32 applications. The project database is stored in a folder on disk separate from your application. The initial default location for projects is \PB32\Projects or the location entered during installation.

To enable the use of projects, click the Projects tab on the Application Settings dialog. Enter a name for the project. A file will be created in \PB32\Projects with your project name as the file name. A Project folder is also created in the Application Window with the project name in parenthesis. The Tag Editor in this folder is used by the application but can also be used by other applications.

To create or edit application tags stored in a project, you can open the Tag Editor in the Project folder or select Tools>Tag Editor.

To create, copy, delete, or rename projects open the Tools>Project Management dialog. This command is enabled only when there are no open applications in PanelBuilder32. To copy, delete, or rename devices used by an application or project, select the Tools>Device Management dialog.

IMPORTANT You cannot enable or disable the use of a project with an application while the tag editor is open.
Creating Project Worksheets

Additional worksheets are available in the tag editor if your application is enabled to use a separate project database for shared tags. You will see a worksheet labeled:

- All Tags - contains all tags in the project that have common fields across protocols. The worksheet is read-only and cannot be edited. You can find, copy, sort and filter tag data on this tab.

You can create separate worksheets to enter and group tags by protocol. To create a worksheet, select a protocol option from the Edit>Create Tags submenu. Available worksheets are:

- Common - Displays tags for DH-485, DH Plus, DF1, Remote I/O or ControlNet Unscheduled messages. These protocols are combined into one worksheet because they use common data fields.
- ControlNet Scheduled
- DeviceNet (I/O Slave, Explicit Server, Explicit Client, Listen Only)
- EtherNet/IP (Controller Address, CIP, Assembly Object)

Each worksheet is identified by protocol name. To switch between worksheets, just click the appropriate tab.
Application Settings

This chapter covers these topics.

- Configure communications for your terminal and controller
- Set power-up defaults for the terminal
- Change time and date format for the terminal
- Configure the RS-232 port on the terminal for printing
- Convert an application to run on a different terminal
- Define control tags the controller can use to change the current screen, date or time
- Define status tags the controller can use to read the current screen, date or time
- Enable an external font file for entering application text in another language
- Modify advanced terminal and display settings
- Enable or disable the use of a project with application
- Define screen and terminal security

For complete details on terminal and application settings, open the Setting up the Terminal book in the Contents tab of general help.

Configuring Communications

PanelView terminals communicate with controllers and remote devices on a variety of networks including: DH-485, DH+, Remote I/O, DF1, DeviceNet, ControlNet, EtherNet/IP and Modbus.

Each terminal supports a specific communication protocol which is selected when you create the application. Before downloading an application, you must configure the terminal and controller settings to enable communications.

For more information on the different protocols, open the Communications book in the Contents tab of general help.

To configure communications:

- double-click the Communications Setup icon in the Application Settings folder of the Application window or
• select Application>Settings and then click the Comms. Setup button

The dialog that opens shows parameters that are specific to the communication protocol of the terminal. In most cases, you will configure the network parameters for the terminal and the controller. For information on a specific dialog, click the Help button or press F1 to get help on a specific field.

Logic controller information (node name, node address, node type) is typically entered the same way for most protocols. Under Network Nodes, right-click in any field and select Insert Node from the menu. Click in a field to enter data or select an option. An asterisk (*) appears to the left of the row you are editing.

**IMPORTANT** The Node Name entered for the controller under Network Nodes must match the Node Name entered in the Tag Form dialog or the tag editor.

### Setting Power-up Options

The Power-Up tab on the Application Settings dialog defines power-up defaults for the PanelView terminal. To modify the settings:

• double-click the Power-Up icon in the Application Settings folder or
• select Application>Settings and then click the Power-Up tab
**Startup Screen (required)**

Specifies the first screen to display when the application runs in the terminal.

**Write to Controller on Startup**

Select to write object preset values to the controller on power-up. You can send either:

- Terminal Presets - initial values set by application
- Last Terminal States - values present prior to power-up

Remote I/O terminals, DeviceNet terminals using I/O and Explicit Server tags, ControlNet terminals using scheduled tags, and EtherNet/IP terminals using Assembly object tags always write preset values to the controller. You can disable/enable this check box for DeviceNet terminals using Explicit Client tags and for ControlNet terminals using unscheduled message tags.

Preset values for objects are entered in the object's dialog. These values override initial values entered in the tag editor except for numeric entry objects.

**Display Last User Screen on Restart**

Specifies what screen to display when the terminal resets; last screen displayed or the startup screen. The default is to display the startup screen.

**Memory Card**

Specifies what action to take if a memory card is loaded in the terminal.

- Always Load from Card - loads application on the card if the application is configured with this setting and if it is different than the application loaded in terminal. This is the default.
- Never Load from Card - do not load the application on the card if the application is configured with this setting. The operator must then load a specific application.
- Load from Card if Invalid Application detected - loads the application on the card only if the current application is invalid.

If a memory card isn't loaded or if the card has more than one application, the terminal restarts with the application that was running before the restart.
Use Downloaded Configuration Settings

Specifies whether or not you want to use the configuration settings downloaded with the application after the terminal is reset. This is the default.

Changing the Date and Time Format

You can change the format for how the time and date are displayed on the PanelView terminal. Changes affect any object that contains a time or date variable. The time can display in 12 or 24-hour format with or without leading zeroes and seconds. You can also add or change suffix notations. With dates, you can vary the order of month, day, year and specify whether the year appears in a 2 or 4-digit format.

To modify the time and date settings:

- double-click the Time/Date icon in the Application Settings folder or
- select Application>Settings and then click the Time/Date tab

<table>
<thead>
<tr>
<th>Date Formats</th>
<th>Time Formats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Month/Day/Year</td>
<td>12-hour format</td>
</tr>
<tr>
<td>7/3/02</td>
<td>with leading zeroes</td>
</tr>
<tr>
<td></td>
<td>07/03/02</td>
</tr>
<tr>
<td>Day/Month/Year</td>
<td>24-hour format</td>
</tr>
<tr>
<td>3/7/02</td>
<td>with leading zeroes</td>
</tr>
<tr>
<td></td>
<td>03/07/02</td>
</tr>
<tr>
<td>Year/Month/Day</td>
<td>different separator</td>
</tr>
<tr>
<td>02/7/3</td>
<td>with seconds</td>
</tr>
<tr>
<td></td>
<td>7<em>3</em>02</td>
</tr>
<tr>
<td></td>
<td>14:56:29</td>
</tr>
</tbody>
</table>

The time and date format are downloaded with the application to the terminal if Use downloaded configuration settings is selected on the Power-Up tab.
Configuring the Printer Port

The Printer tab on the Application Settings dialog configures the RS-232 port of the PanelView terminal for printing including:

- port settings
- printer configuration

To modify the printer settings:

- double-click the Printer icon in the Application Settings folder or
- select Application>Settings and then click the Printer tab

Below are the default port settings. The settings must match your printer’s settings.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baud Rate</td>
<td>9600</td>
</tr>
<tr>
<td>Data Bits</td>
<td>8</td>
</tr>
<tr>
<td>Stop Bits</td>
<td>1</td>
</tr>
<tr>
<td>Parity</td>
<td>None</td>
</tr>
<tr>
<td>Handshaking</td>
<td>None</td>
</tr>
</tbody>
</table>

Handshaking is not activated until after you reset the terminal.

The default printer configuration is:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left Margin</td>
<td>0</td>
</tr>
<tr>
<td>Page Width</td>
<td>80</td>
</tr>
<tr>
<td>Perforation Skip Value</td>
<td>6</td>
</tr>
<tr>
<td>End of Line Char</td>
<td>CR</td>
</tr>
<tr>
<td>Page Length</td>
<td>66</td>
</tr>
<tr>
<td>New Page Control</td>
<td>Form Feed</td>
</tr>
<tr>
<td>Printer Initialization String</td>
<td>Null</td>
</tr>
</tbody>
</table>

The printer port settings are downloaded with the application to the terminal if Use downloaded configuration settings is selected on the Power-Up tab.
You can convert an application to run on another terminal. However, you may need to modify properties of the application to make it compatible with the terminal.

To convert an application to run on another terminal:

- double-click the Terminal Setup icon in the Application Settings folder or
- select Application>Settings and then click the Terminal Setup tab

Select the terminal for which you want to convert the application. When you click OK the application is validated. Any errors or warnings that occur will appear in the Exceptions window.

<table>
<thead>
<tr>
<th>If converting an application from:</th>
<th>Do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>touch screen to keypad</td>
<td>Assign function keys to control objects.</td>
</tr>
<tr>
<td>one size terminal to another size</td>
<td>Move/resize objects or adjust the grid spacing. You may need to reduce the number of objects on a screen. Text sizes are converted to closest size.</td>
</tr>
<tr>
<td>one protocol to another protocol</td>
<td>Update the communication parameters for the terminal and controller. Update the tags (address and node name) if necessary.</td>
</tr>
<tr>
<td>monochrome to grayscale or color (32 colors)</td>
<td>From the dialog that opens, select the colors to replace the monochrome colors (black and white) in the application. During the conversion, each monochrome color is replaced by the selected color. The selected colors apply to all screens, objects (including states), inner text and inner graphics. Text sizes are converted to the closest size.</td>
</tr>
<tr>
<td>grayscale to color (32 colors)</td>
<td>From the dialog that opens, select the colors to replace the grayscale colors in the application. During the conversion, each grayscale color is replaced by the selected color. The selected colors apply to all screens, objects (including states), and inner text. Text sizes are converted to the closest size.</td>
</tr>
<tr>
<td>color to grayscale</td>
<td>The screen background color is converted to black. Colors are converted to a shade of gray. Color bitmaps are converted to grayscale. Text sizes are converted to the closest size.</td>
</tr>
<tr>
<td>color to monochrome</td>
<td>Screen background is converted to white, objects are converted to white or black, color bitmaps are converted to monochrome. Text sizes are converted to the closest size.</td>
</tr>
<tr>
<td>terminal supporting printing to one that doesn’t support alarms</td>
<td>The print attribute is removed from appropriate objects. An error message is generated for Print Only objects used by the application. The message indicates the object.</td>
</tr>
<tr>
<td>terminal supporting alarms to one that doesn’t support alarms</td>
<td>An error message is generated indicating the target terminal does not support alarms. Remove alarms from the application.</td>
</tr>
</tbody>
</table>
Defining Control Tags Used by Controller

Control tags are used by the controller to change the current screen or the date and time displayed on the terminal. A controller screen change overrides whatever screen the operator is currently viewing. The time and date are updated every minute.

To define control tags:

- double-click the Control Tags icon in the Application Settings folder or
- select Application>Settings and then click the Control Tags tab

<table>
<thead>
<tr>
<th>Control Tag</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Screen number</td>
<td>Name of tag address where the controller writes a screen number to change the current screen. For operator controlled screen changes, the Screen Number tag address must be 0.</td>
</tr>
</tbody>
</table>
| Date            | Name of tag addresses where the controller writes the current year, month and day for date displays. The value of the Year tag must be 2 digits (90-99 for 1990-1999 or 00-89 for 2000-2089). To maintain Y2K compliance, the ladder logic must convert the values as follows before sending them to the terminal:  
  - If the year is ≤ 1999, the ladder logic must subtract 1900  
  - If the year is > 1999, the ladder logic must subtract 2000 |
| Time            | Name of tag addresses where the controller writes the current hour, minutes and seconds for time displays.                                      |

After entering a tag name, click the Edit Tag button on the dialog to enter the tag attributes. The data type of the tag must be unsigned integer.
Defining Status Tags Used by Controller

Status tags are used by the controller to monitor or read the current screen number or date and time.

The time and date are updated every minute. You can change the Time/Date Output Interval to a range within 1 - 60 minutes. Increasing the interval reduces network traffic but also the accuracy of the time.

To define status tags:

- double-click the Status Tags icon in the Application Settings folder or,
- select Application>Settings and then click the Status Tags tab.

<table>
<thead>
<tr>
<th>Status Tag</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Screen number</td>
<td>Name of tag address where the terminal writes the current screen number. The controller can read this screen number.</td>
</tr>
</tbody>
</table>
| Date | Name of tag address where the terminal writes the current year, month and day. The value of the Year tag must be 2 digits (90-99 for 1990-1999 or 00-89 for 2000-2089).

The ladder logic must convert the values as follows before sending them to the controller.

- add 1900 to the 2-digit year (90-99)
- add 2000 to the 2-digit year (00-89)

| Time | Name of tag addresses where the terminal writes the current hour, minutes and seconds for time displays. |

After entering a tag name, click the Edit Tag button on the dialog to enter the tag attributes. The data type of the tag must be unsigned integer.
Enabling External Fonts

You can enter application text in another language (or character set) using a font file (*.OTF) specific to the language. The font file is created outside of PanelBuilder32 using the FontTool utility. You must enable the font file in PanelBuilder32 before you can use its character set.

To enable a font file:

- double-click the External Fonts icon in the Application Settings folder or,
- select Application>Settings and then click the External Fonts tab.

Select the External Fonts Enabled check box and then under External Font File select the font file you want to use.

From the External Fonts tab, you can also translate the text that appears in the Numeric Scratchpad so it appears in the correct language on the PanelView terminal. Select the Use Custom Text check box to translate (or edit) the numeric scratchpad text.

Text sizes for the character set in the font file are enclosed in parenthesis at the bottom of text size menus. In this way, you can clearly identify the text sizes in the font file from the PanelBuilder32 default text sizes.

See Chapter 6 for details on entering text in other languages.
Setting Advanced Terminal Options

The Advanced tab on the Application Settings dialog defines defaults for specific terminal settings. You don’t have to access this tab unless you want to:

- change the autorepeat settings for function keys/touch cells.
- (used only by the up/down arrow keys to move the cursor through lists).
- adjust display intensity settings (display intensity, reverse video)
- enable screen saver mode.
- select a language other than English for terminal messages.
- If the application is enabled for multiple language support, this setting must be set to the language that is active for the application before downloading.
- change the handshake timeout used by objects with handshake tags.
- change the maintenance schedule for conditioning the display of a PanelView 900 monochrome terminal or degaussing the PanelView 1400.

To change any of the advanced settings:

- double-click the Advanced icon in the Application Settings folder or
- select Application>Settings and then click the Advanced tab.

The tab that appears shows fields that are specific to your terminal. For more information on advanced options, click the Help button on the dialog, or for details on a specific field, press F1 on the field.

Any changes you make are downloaded with the application to the terminal if Use downloaded configuration settings is selected on the Power-Up tab.
Enabling or Disabling the Use of a Project

The Project tab on the Application Settings dialog enables or disables the use of a project with the application. If you enabled the use of projects with your application so that a tag database can be shared or used by other applications, the project icon will be available in the Application Settings folder. See page 120 for more details.

To enable or disable the use of a project:

- double-click the Project icon in the Application Settings folder or
- select Application>Settings and then click the Project tab.

Setting up Security for an Application

PanelBuilder32 provides security features that allow you to restrict screen and terminal access (including configuration screens) to authorized operators. You can also create screens that would allow authorized operators to select and change the passwords of other operators at the terminal.

To access security options for an application:

- double-click the Security icon in the Application Settings folder or
- select Application>Security.

The Security dialog has three tabs from which most of the security options are set.

Properties - defines general security properties including:

- screen, login or autologin mode
- numeric or alphanumeric passwords
- masked password entry
- securing terminal's configuration screens
- securing terminal when idle

Operators - defines operator privileges including:

- username and password for each operator
- access to terminal's configuration screens
- authorization to modify the passwords of other operators
- whether an operator's password can be changed
- whether to disable the view of an operator password on terminal
Secured Screens Info - lists all screens in the application and restricts operator access to secured screens. For each screen, you can specify:

- whether it is secured or unsecured
- which operators are authorized to access a secured screen

You can also secure a screen and authorize operator access to the screen from the Screen>New or Properties dialog. However, operator privileges must be defined in the Application>Security dialog.

In the example below, the Operator tab shows a name and password assigned to two operators (Supervisor and Engineering). Both operators have access to the terminal’s configuration screens. The Supervisor has privileges to change the password for Engineering. Note that the Engineering password is set for modification by other operators.

The Secured Screen Info tab shows that all screens are secured (Main Menu, Pump Controls, Changing Security). The Supervisor has access to all screens while Engineering is not allowed to access the Changing Security screen.

Security Keys

Screen objects are located on Objects>Security Keys menu and are used to access these areas.

- Password entry/verification
- Login/logout
- Selecting and changing operator passwords
- Disabling/enabling terminal security
Transferring Applications

This chapter covers these topics.

- Ways to transfer applications
- Using a memory card
- Communication drivers
- Validating an application
- Downloading an application directly to a terminal
- Downloading an application over a network
- Downloading an application to a memory card
- Uploading an application directly from a terminal
- Uploading an application over a network
- Using the File Transfer Utility

For complete details on downloading and uploading applications, open the Transferring Applications book in the Contents tab of general help.

Ways to Transfer Applications

You can transfer applications between a computer and a PanelView terminal or memory card using:

- File>Download or File>Upload commands in PanelBuilder32
- File Transfer Utility (WinPFT) outside of PanelBuilder32

If using the File Transfer Utility, you must first save your application as a .PVA file using the File>Save As command. The File Transfer Utility only transfers files that are in a PanelView Terminal .PVA format.

**TIP**

You can also use the File>Save As command in PanelBuilder32 to save a .PVA file directly to an ATA memory card drive.
Using a Memory Card

Applications can be downloaded to a memory card on computers with a DataBook TMB240/TMB250 or ATA compatible card drive.

- ATA drives support catalog number 2711-NM2xx cards
- DataBook drives support catalog number 2711-NM1x cards

You can insert the memory card into the card slot of a PanelView terminal and load the application into the terminal from the terminal’s Configuration Mode menu. With memory cards, you can load an application into multiple terminals on the plant floor without the need for a computer.

If your computer doesn’t have an ATA card drive, you can still use a memory card. Download the application to a terminal. Transfer the application loaded in the terminal onto a memory card. Then take this memory card to other terminals on the plant floor and load the application.

Communication Drivers

Before transferring applications between a computer and a PanelView terminal, you must have the appropriate communication driver installed on your computer. The driver establishes communications needed to transfer files. The driver required depends on the network configuration.

Using the Internal DF1 Driver

To transfer applications point-to-point between your computer’s serial COM port and the RS-232/DF1 port of a PanelView terminal, use the PanelBuilder32 internal DF1 driver. This driver is available when you download or upload the application. You don’t have to do anything else. The DF1 driver has settings that must match the PanelView terminal’s settings.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baud Rate</td>
<td>19200</td>
</tr>
<tr>
<td>Parity</td>
<td>None</td>
</tr>
<tr>
<td>Error Detect</td>
<td>CRC</td>
</tr>
<tr>
<td>Stop Bits</td>
<td>1</td>
</tr>
<tr>
<td>Protocol</td>
<td>Full Duplex</td>
</tr>
</tbody>
</table>
You cannot use the DF1 driver to transfer applications between a computer and a DH-485 or RS-232 (DH-485) PanelView terminal. You must use the RSLinx 1747-PIC Device driver.

**IMPORTANT** The DF1 driver will not be available to any serial port on your computer that is configured to use an RSLinx driver or is used by another application.

**Using RSLinx Classic Drivers**

To transfer applications over a network or between two different communication networks, you must configure the appropriate RSLinx driver on your computer. RSLinx Classic is installed as a part of the PanelBuilder32 installation.

To access RSLinx:

- click the Start button, click Programs, click Rockwell Software, click RSLinx submenu and select RSLinx Classic.
- or in PanelBuilder32, click File>Workstation Setup.

For details on how to configure an RSLinx Classic driver, refer to the RSLinx online documentation. In general, you configure a driver by selecting Communications>Configure Drivers in RSLinx Classic or from the WinPFT dialogs.

**Validating an Application**

An application is automatically validated or checked for errors when downloaded to a terminal. You can also validate an application by selecting the Validate All or Validate Changes command from the Application menu. If errors or warnings occur during validation, the Exceptions window opens. You must correct errors; warnings are optional. Warnings do not affect the integrity of the application.
When the Exceptions window opens, the Exceptions menu is available. This menu has commands that operate on errors/warnings in the window or on the window itself. Simply select an error or warning and then select a command from the Exceptions menu (or right-click and select a command from the shortcut menu).

<table>
<thead>
<tr>
<th>Select:</th>
<th>To:</th>
</tr>
</thead>
<tbody>
<tr>
<td>GoTo</td>
<td>Navigate to the source of the selected error.</td>
</tr>
<tr>
<td>Details</td>
<td>Display help for the selected error.</td>
</tr>
<tr>
<td>Suppress Selected Warning</td>
<td>Suppress the selected warning message from displaying in the Exceptions window.</td>
</tr>
<tr>
<td>Suppress Warnings</td>
<td>Suppress messages for specific warning codes from appearing in the Exceptions window. You cannot suppress error messages.</td>
</tr>
<tr>
<td>Print All</td>
<td>Prints all errors and warnings in the Exceptions window.</td>
</tr>
<tr>
<td>Allow Docking</td>
<td>Dock the Exceptions window at a window edge or float the window like any other window.</td>
</tr>
</tbody>
</table>

The Exceptions menu remains active until the Exceptions window is closed from the View menu or by clicking the X in the corner of the window.

### Monitoring the Progress of a Download or Upload

When downloading and uploading applications, a dialog opens so that you can monitor the progress of the transfer.

- Download Tasks area monitors each step performed during the transfer and shows the current task.
- Status area shows any errors that occur during the transfer. You can double-click on any error to get help.
- Progress bar shows the progress of the transfer in terms of percentage complete.

While the download or upload is in progress, the PanelView terminal also shows the status of the transfer.
**Downloading Application Directly to a Terminal**

This section shows how to download an application from a serial COM port on your computer to the RS-232/DF1 port of the PanelView terminal using a point-to-point connection. The download uses the internal DF1 driver on your computer's COM1- COM9 port.

Use catalog number 2711-NC13 or 2706-NC13 cable (9-pin connector) for the point-to-point connection. For the PanelView 300 Micro, use catalog number 2711-CBL-PM05 cable. Check the cable connections before starting the download.

**IMPORTANT** To transfer applications between a computer and a DH-485 or RS-232 (DH-485) PanelView terminal, you must use the RSLinx Classic 1747-PIC Device driver, not the DF1 internal driver.

Open the application you want to download and select File>Download. The application is validated during the download. Any errors that occur during validation must be corrected before you can proceed with the download.

When the download is complete, the terminal resets, verifies and starts the application.
To download applications over a network or between different networks, the appropriate RSLinx Classic driver must be configured and running on your computer.

For a list of supported network configurations for the PanelView terminals, open the Transferring Applications book in the Contents tab of the general help and select RSLinx Network Paths.

Open the application you want to download and select File>Download. The application is automatically validated. Any errors that occur must be corrected before you can proceed with the download.

You can also download a file from the startup dialog when you first enter PanelBuilder32. Because a file is not open, you will be asked to enter or browse for an application saved in a PanelView terminal .PVA format.

When the download is complete, the terminal resets, verifies and starts the application.
To transfer an application between a computer and a PanelView terminal on a Remote I/O network, select Remote I/O Pass-Through as the Transfer Type on the Download or Upload dialog. Using RSWho, select the PLC, SLC or 1756-DH RIO scanner the PanelView is connected to on the Remote I/O network. Click the Setup button to configure the parameters shown below.

### PLC Parameters

<table>
<thead>
<tr>
<th>Rack Address</th>
<th>For PLC Scanner Type, select the rack address (0 - 76 octal) of the PanelView on the Remote I/O link.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting Module</td>
<td>Select the starting module group (0,1,2,3,4,5 or 6,7) of the PanelView in the Remote I/O rack.</td>
</tr>
</tbody>
</table>

### SLC Parameters

<table>
<thead>
<tr>
<th>SLC Scanner Location</th>
<th>Select the slot number where the SLC scanner resides. The default is the leftmost slot (scanner card closest to the processor).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rack Address</td>
<td>Specify the rack address of the PanelView on the Remote I/O network.</td>
</tr>
<tr>
<td>Starting Module</td>
<td>Select the starting module group (0,1,2,3,4,5 or 6,7) of the PanelView in the Remote I/O rack.</td>
</tr>
</tbody>
</table>

### SLC Scanner Type

- **RSWho**

### TIP

The Pass-Through check box must be enabled on the Block Transfer dialog in the Communication Setup dialog.

### ATTENTION

If downloading with the processor in run mode, verify the rack address of the target terminal. Downloading to an incorrect rack address may result in unexpected operation or damage to equipment.
Chapter 11  Transferring Applications

Downloader Application to a Memory Card

This section shows how to download an application to a memory card. Open the application you want to download and select File>Download. The application is automatically validated, translated and copied to the card in a PanelView terminal .PVA format.

**TIP**
You can also use the File>Save As command in PanelBuilder32 to save a .PVA file directly to an ATA card drive.

Select Memory Card and the click Setup

For ATA Cards
2711NM2xx

For Linear Flash Cards
2711-NM1X

For DataBook TMB240 or TMB250 card drives, you must enter the following command string.

**CMD**
[%s]  Drive:

**CMD**
DOS command which copies file to card. Command is drive specific. See instructions for your card drive.

**%s**
Wild card character which PanelBuilder32 replaces with the application file name.

**Drive:**
Card drive on your computer (F:)

**Example:** TCXCOPY %s F:

The next time you download to a memory card, you can just select the command line from the box.
Transferring Applications

Chapter 11

Uploading Application Directly from a Terminal

This section shows how to upload an application from the RS-232/DF1 port of a PanelView terminal to your computer's serial COM port using a point-to-point connection. The upload uses the internal DF1 driver on your computer's COM1 - COM9 port.

Use catalog number 2711-NC13 cable (9-pin connector) for the point-to-point connection. For the PanelView 300 Micro, use catalog number 2711-CBL-PM05 cable. Check the cable connections before starting the upload.

IMPORTANT
To transfer applications between a computer and a DH-485 or RS-232 (DH-485) PanelView terminal, you must use the RSLogix Classic 1747-PI Device driver, not the DF1 internal driver.

To upload an application, select File>Upload. You can also upload a file from the startup dialog when you first enter PanelBuilder32.

Select the destination for the uploaded file:
- to disk file (do not open in PanelBuilder32)
- to disk file and then open in PanelBuilder32
- open in PanelBuilder32 (do not save to disk)

Uploads file to default or other location
Uploads file with original file name or specify another file name
Select a COM port to use for the upload

When the upload is complete, the application is opened in PanelBuilder32 unless you uploaded the application to a disk file.
Transferring Applications

**Uploading Application Over a Network**

This section shows how to upload applications over a network or between different networks using RSLinx drivers. The appropriate RSLinx driver must be configured and running on your computer. To upload an application, select File>Upload.

For a list of supported network configurations for the PanelView terminals, open the Transferring Applications book in the Contents tab of the general help and select RSLinx Network Paths.

When the upload is complete, the application is opened in PanelBuilder32 unless you uploaded the application to a disk file.
Using the WinPFT File Transfer Utility

Use the WinPFT File Transfer Utility to transfer applications between a PanelView terminal and computer in Windows without opening PanelBuilder32.

**IMPORTANT** The File Transfer Utility only downloads files in a PanelView terminal .PVA format. Use the File>Save As command in PanelBuilder32 to save applications in this format.

To open the File Transfer Utility, select Programs>PanelBuilder32>WinPFT from the Start menu.

**TIP** If you disable the Use RSLinx if available checkbox, RSLinx Network and Remote I/O Pass-Through will not be available as Transfer Type options on the dialogs. To transfer files directly using the DF1 driver, disable this check box. Disabling the check box saves time because RSLinx will not be loaded into memory.

The Download File dialog in the File Transfer Utility is the same dialog used in PanelBuilder32 with a few exceptions.

- You must enter the name of a .PVA file to download since the File Transfer Utility only downloads applications in a .PVA terminal format.

- You can choose to download the application only if it is different from the application loaded in the target PanelView terminal.

The Upload File dialog is identical to the Upload File dialog in PanelBuilder32.
Verifying an Application

Click Verify on the File Transfer Utility dialog to compare the application you want to download with an application loaded in a PanelView terminal or a disk file. You might want to verify that differences exist before downloading an application to a terminal. You also have the option of downloading the application if the reference application is different than the application loaded in the terminal.

Enter or browse for the name of the .PVA file you want to compare with the application in a terminal or a disk file.

Select the target location of the application for the Verify.
- DF1 Point-to-Point
- RSLinx Network or Remote I/O Pass-Through
- Application on Disk

Select to download the application to a terminal if it is different from the application in the terminal.

Enter or browse for the disk file you want to compare with the reference application.

Select the PanelView terminal node you want to compare with the reference application.
Index

A
Ack alarm button 67
Ack All alarm button 67
alarm banner
adding an alarm list 65
adding buttons 64
clearing 64
creating 64
default colors 65
description 64
disabling objects when banner opens 64
showing the location 65
sizing 65
which objects are disabled 68
alarm buttons
Ack 67
Ack All 67
Clear 67
Clear Alarm List 67
Print 67
Print Alarm List 67
where you can use them 67
alarm list
changing the default size 68
creating 66
defining data to include with each alarm 66
description 65
maximum size 65
multiple display options 66
printing 66
what happens when its full 66
alarm messages
attributes 70
defining 70
alarm triggers 69
alarms 38
data to print with triggered alarms 68
defaults that apply to all alarms 68
defining triggers 69
descriptions 63
definitions 70
messages 70
remote tags used by controller to clear or acknowledge alarms 68
safety 63
aligning
objects 40
text 79
analog gauges 56
application window
docked or floating 16
screens folder 30
what it is and what it looks like 16
applications
closing 33
converting 128
creating 27
default save location 23
defining the startup screen 30
displaying version number 32
downloading 135
enabling font file 131
entering a description 28
entering text in another language 88
network communication settings 123
opening 28
power-up settings 124
renaming 28
reports 33
save date 32
save defaults 23
saving 32
saving backup files 23, 32
screens 29
security 31, 133
uploading 135
validating 137
ASCII entry controls 36
cursor point 52
initial value 52
keypad enable button 52
scratchpad 53
B
Backup .BAK files 27
bar graphs 56
bitmaps
adding to a screen 94
copying to the clipboard 98
deleting from graphics list 98
exporting 96
importing 96
inserting in object 95
removing from an object 95
blinking
objects 100
text 79
block write data 49
C
circular scale 56
character variable
adding to text 77
Clear alarm button 67
Clear Alarm List button 67
color
  applying to objects 102
  applying to text 102
color palette 101
color palette 21, 101
communication drivers
  DF1 136
  RSLogix 137
control list selectors 36
  editing states 49
  list keys 48
  piloted 48
  standard 48
color palette 21, 101
converting applications for other terminals 128
cursor point
  ASCII entry controls 52
data displays 37
  bar graphs 56
  list indicators 57
  multistate indicators 55
  numeric data displays 57
  scaling 57
data tips
  defining for objects 23, 42
  displaying 42
description
  for a screen 29
  for an object 44
  for application 28
downloading applications
  communication drivers 136
  over a network 140
  using a memory card 142
  validating 137
dragging
  objects 42
  screens 31
dropping objects
  on a function key 43
  on a screen 43

E
exiting PanelBuilder32 13
exporting
  bitmaps 96
  tags 116

F
file types
  .BAK 27
  .OTF 88
  .PBA 27
  .PVA 27
flipping objects horizontally or vertically 41
font files
  creating 89
  enabling 91, 131
  running application with a font file 92
  saving to disk or memory card 90
  to create text in another language 88
  using in PanelBuilder32 91
FontTool utility 88
  creating a font file 89
  enabling font files in PanelBuilder32 91
  saving font files 90
format toolbar 100
formatting objects
  changing fill 100
  changing line type 100
  changing shape 100
  format toolbar 100
  making them blink 100
  toggling the foreground and background 100
function keys
  auto-assigning 44
  enabling or disabling auto-assignment 23
gauge, analog 56
global objects
  description 60
  making an object global 44
  reusing 61
goto config screen button 58
goto screen button 58
graphic tools
  circle 93
  connected line 93
  ellipse 93
  graphic image 93
  line 93
  rectangle 93
graphics 38
adding bitmaps to a screen 94
changing background color 103
changing foreground color 103
exporting 96
importing 96
inserting a bitmap in an object 95
removing from an object 95
reversing foreground/background colors 103
sizing 94, 95
grid
changing the default spacing 18, 29
default grid spacing 18
showing or hiding 18
grouping and ungrouping objects 40

H
help
available 24
context-sensitive 25
custom context-sensitive help for menu
commands and icons 19
dialog 25
general 24

I
importing
bitmaps 96
tags 116
inactive states, piloted control list 49
Inc/Dec numeric entry 51
indicators 37
inner text
adding variables 75
changing background color 102
changing foreground color 102
default 73
editing 74
inner text toolbar 79
Input Method Editor 88
installation
CD ROM 11
setup options 11
system requirements 11
ISA symbols
adding to a screen 94
showing the toolbox 94

K
keypad enable button

L
language support
using font files 88
latched push button 46
list indicators 57
list keys 37, 59
logic controller
defining network communications 123

M
maintained push button 46
manuals
related 10
memory card 136
message displays 54
configuring messages to print only 55
editing messages 54
triggering 54
momentary push button 46
multiple language support
changing language at terminal 86
changing the active language 86
downloading specific language 86
enabling 86
translating text 86
multistate indicators 55
multistate objects
configuring states 45
multistate push button 46

N
numeric data displays 57
numeric entry controls 36
Inc/Dec control 51
initial value 50
keypad enable button 50
scaling data 51
scratchpad 51
numeric variable
adding to text 76
editing 76
format 76

O
objects
accessing 18
activating blinking 100
aligning horizontally or vertically 40
changing background color 102
changing fill 100
changing foreground color 102
changing line type 100
changing shape 100
changing the drop mode 23
configuring properties 44
configuring states 45
copying or moving 41
creating 42
data tips 42
dragging 42
enabling or disabling data tips 23
entering a description 44
entering tag names 44
entering tags 44
flipping horizontally or vertically 41
formatting 99
graphics 93
grouping/ungrouping 40
hiding its view 44
making it global 44, 60
moving 39
overview 35
selecting and deselecting 39
sizing 39
spacing 41
stacking 40
toggling foreground/background colors 100
type and description 35
zooming in or out 41

Print Alarm List button 67
print only messages 55
printer port
  configuring 127
defaults 127
projects
  enable or disable 120, 133
  private or shared 120
properties
  objects 44
  screens 29
publications
  related 10
push buttons 36
  latched 46
  maintained 46
  momentary 46
  multistate 46
  states 47
text 47
R
remote alarm tags used by logic controller 68
reports
  changing the format 23, 33
  defining topics to include 23
  printing 33
  topics to include 33
return screen button 58
S
saving
  16-bit .PVA file 32
  as a 16-bit .PBA file 32
  standard .PBA file 32
scales
  circular 56
  linear 56
scratchpad
  ASCII entry controls 53
  numeric entry 51
screen captures 34
screen list selector 58
  editing screen entries 59
  linking screens to entries in list 59
  list keys 58, 59
  selecting a screen 58
screen saver 132
screen selectors 37

PanelBuilder32 Selected Tags Format
exporting tags 118
powered control list
  block write data 49
  inactive states 49
  restricting access 49
power-up settings
  display screen on a restart 125
  if memory card loaded 125
  object preset values 125
  startup screen 124
  use terminal defaults or settings
    downloaded with application 125
preset values for objects 125
Print alarm button 67
goto config screen button 58  
goto screen button 58  
return screen button 58  
screen lists 58  
**screen window** 18  

**screens**  
activating 30  
capturing images 34  
changing properties 30  
changing the properties 29  
closing 30  
controller screen changes 59, 129  
copying, cutting, pasting 30  
creating 29, 30  
deleting 30  
dragging and dropping 31  
monitoring screens by controller 130  
opening 30  
properties 29  
screen folder 30  
securing 31  
selecting 31  
startup screen 30  
workbook mode 31  
zooming in or out 41  

**scrolling text** 79  

**security**  
authorizing operators 133  
keys 38, 134  
login modes 133  
operator passwords 133  
screen 31, 133  
**security keys** 38  

**spacing objects** 41  

**stacking objects** 40  

**standard control lists** 48  

**starting PanelBuilder32** 13  

**startup dialog** 15  

disabling or enabling 15, 23  

**status tags** 130  

---

**T**  

**tag editor**  
checking and correcting errors 114  
copying, cutting, pasting, deleting tags 110  
counting tags 113  
defining defaults for tag fields 23  
duplicating tags 110  
exit 107  
freezing columns 106  
finding text 111  
moving columns 106  
opening 105  
printing tags 111  
purging unused tags 113  
saving tags 114  
searching for occurrence of a tag 111  
searching for where a tag is used 111  
selecting tags 109  
showing extended attributes 108  
sorting tags 110  
tag attributes 108  
Tag Form dialog 107  
worksheets 106  
worksheets for projects 121  

**Tag Form dialog** 107  

tags  
adding 109  
attributes 108  
checking for errors 114  
converting to another protocol 113  
copying, cutting, pasting, deleting 110  
correcting errors 114  
counting tags 113  
creating sequential addresses 108  
creating tag names from addresses 108  
defining defaults for duplicating tags 23  
duplicating 110  
entering 107  
entering in Tag Form dialog 107  
exporting 116  
extrapolating addresses 108  
filtering data 110  
finding and replacing 111  
finding text in column 111  
filtering data 110  
importing 116  
inserting 109  
printing 111  
project folder 120  
purging unused tags 113  
saving 114  
saving tags to a draft file 114  
searching for 111  
searching for occurrence of a tag 111  
searching for where a tag is used 111  
selecting tags 109  
sharing 120  
showing extended attributes 108  
sorting a single column 110  
using a project 120  
worksheets for projects 121  

**terminal**  
adjusting display intensity 132
Index

adjusting display maintenance schedule 132  
autorepeat settings for keys 132  
changing language for terminal messages 132  
configuring printer port 127  
defining network communications 123  
selecting a default 23  
time and date format 126  
using a screen saver 132

text
activating blinking 79  
adding to screen 78  
adding variables 75  
aligning 79  
changing background color 102  
changing foreground color 102  
changing size 79  
default inner text 73  
editing for multistate objects 74  
entering in an object 74  
inner text toolbar 79  
object 38  
scrolling 79  
sizing 79  
toggling foreground/background 79  
underlining 79  
using the text editor 80

text editor 80  
adding or editing text 81  
copying text into objects 85  
deleting text 84  
inserting variables in text 82  
moving text 84  
printing text 84  
renumbering text strings 83  
sorting text 83

time or date
adding a variable to text 75  
changing from controller 129  
changing the format 126  
default format 75  
monitoring from controller 130

toolbars
color palette 21  
docked or floating 19

format 20  
graphic 20  
inner text 20  
ISA symbols 21  
showing or hiding 19  
standard 20  
state 20  
toolbox 21

tooltips
enabling or disabling 19  
how to use 19

touch grid 18

U
underlining text 79
uploading applications
direct connection 143  
over a network 144  
validating 137

V
validating application 137
variables 37  
character 77  
numeric 76  
time or date 75

W
WinPFT File Transfer utility 135  
verifying applications 146
workbook mode  
enabling or disabling 31  
screens 31
worksheets

tag editor 106, 121  
tag Error worksheet 114  
using with projects 121

Z
zooming 41
Rockwell Automation provides technical information on the Web to assist you in using its products. At http://support.rockwellautomation.com, you can find technical manuals, a knowledge base of FAQs, technical and application notes, sample code and links to software service packs, and a MySupport feature that you can customize to make the best use of these tools.

For an additional level of technical phone support for installation, configuration, and troubleshooting, we offer TechConnect support programs. For more information, contact your local distributor or Rockwell Automation representative, or visit http://support.rockwellautomation.com.

**Installation Assistance**

If you experience a problem within the first 24 hours of installation, please review the information that's contained in this manual. You can also contact a special Customer Support number for initial help in getting your product up and running.

<table>
<thead>
<tr>
<th>United States</th>
<th>1.440.646.3434</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Monday – Friday, 8am – 5pm EST</td>
</tr>
</tbody>
</table>

| Outside United States | Please contact your local Rockwell Automation representative for any technical support issues. |

**New Product Satisfaction Return**

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. However, if your product is not functioning and needs to be returned, follow these procedures.

<table>
<thead>
<tr>
<th>United States</th>
<th>Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to your distributor in order to complete the return process.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States</td>
<td>Please contact your local Rockwell Automation representative for the return procedure.</td>
</tr>
</tbody>
</table>

www.rockwellautomation.com

**Power, Control and Information Solutions Headquarters**

Americas: Rockwell Automation, 1201 South Second Street, Milwaukee, WI 53204-2496 USA, Tel: (1) 414.382.2000, Fax: (1) 414.382.4444

Europe/Middle East/Africa: Rockwell Automation, Vorstlaan/Boulevard du Souverain 56, 1170 Brussels, Belgium, Tel: (32) 2 663 0600, Fax: (32) 2 663 0640

Asia Pacific: Rockwell Automation, Level 14, Core E, Cyberport 3, 100 Cyberport Road, Hong Kong, Tel: (852) 2887 6788, Fax: (852) 2508 1946

Publication 2711-GR003D-EN-P - June 2009

Supersedes Publication 2711-GR003C-EN-P - March 2002

Copyright © 2009 Rockwell Automation, Inc. All rights reserved. Printed in the U.S.A.